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RX Family  
Provisioning Procedure for IoT Devices  
Introduction 
IoT device provisioning is required in order to connect to AWS IoT, a cloud service provided as part of 
Amazon Web Services™ (AWS). As used here, the term “provisioning” refers to the process of generating, 
utilizing, and managing authentication information such as things, private keys, and device certificates. 
Provisioning requires consideration of matters such as how to write authentication information to products as 
part of the manufacturing process (initial installation) and how to manage (protect) and update key data. 
These types of data are stored in the on-chip flash memory of RX Family MCUs. Since it is extremely difficult 
to modify the provisioning method for IoT devices afterward, the above-mentioned consideration must begin 
at the product development stage so that verification can be completed by the mass production phase. 

 
Of the various provisioning methods provided by AWS, this document describes the “fleet provisioning 
method,” which automates provisioning during the manufacturing process and when the device is initially 
used. 

Deploying the fleet provisioning method eliminates the need to devote time and effort to cumbersome 
provisioning procedures while making the provisioning process more secure and convenient. 

 

 
 
The contents of this document are sufficient to implement provisioning, but if followed unmodified will result 
in important data saved as part of the provisioning processing, such as the private key and device certificate, 
being stored as “clear text” (unencrypted text) in the on-chip flash memory of the RX Family MCU. This 
means that if there is a security hole in a user program programmed to the RX Family MCU that allows 
arbitrary areas of memory to be read, the provisioning data in the flash memory could be accessed, possibly 
allowing an attacker to perform an unauthorized login to the user’s AWS account. 
Using the Trusted Secure IP (TSIP) module of the RX Family MCU enables the private key and device 
certificate to be stored in encrypted form, greatly reducing the danger of unauthorized access to the 
provisioning data. For details of the TSIP module, see the page linked to below. 
https://www.renesas.com/software-tool/trusted-secure-ip-driver 

We strongly encourage using the TSIP module to boost security.  
 
It is possible to reduce the risk of unauthorized access to provisioning data by improving software quality, but 
this approach can never completely eliminate it. In particular, if there are defects in the software of IoT 
devices, which are vulnerable to threats posed by attackers, it is recommended that firmware update 
functionality be used to apply corrections in a timely manner. For more information on firmware updates, 
please refer to the application note Renesas MCU Firmware Update Design Policy (R01AN5548). 
  

 Overview of provisioning methods provided by AWS. 

 How to realize fleet provisioning using demo and confirm operation. The steps to run the demo will 
be explained from "4 Running the Fleet Provisioning Demo". 

What you will learn in this application note 

https://www.renesas.com/software-tool/trusted-secure-ip-driver
https://www.renesas.com/document/apn/renesas-mcu-firmware-update-design-policy-rev100
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Note : This application note shows an implementation example based on the operating environment of the 

CK-RX65N v1 board and the RYZ014A PMOD module, 
but it can also be utilized with other boards and communication control combinations.  
For each board and communication control combination, please see: 
 
[GitHub] iot-reference-rx/Getting_Started_Guide.md at main · renesas/iot-reference-rx (github.com) 
 

Note : Renesas announces to discontinue the existing Sequans-sourced LTE module known as the part 
number RYZ014A and will no longer be shipping this product. 
With the discontinuation of RYZ014A, the CK-RX65N v1 board will also be discontinued. 
If you are using RYZ014A in a current design or production, the Sequans part numbers, GM01Q is a 
pin and functionally compatible replacement for RYZ014A. 
 
Below Cellular driver of RX family works the below alternate product combination. 

- RYZ014A Cellular Module Control Module ： Sequans GM01Q is the compatible module. 
 

Regarding EOL notice of the RYZ014A, please see : 
[The link] https://www.renesas.com/document/eln/plc-240004-end-life-eol-process-select-part-

numbers?r=1503996 
[The product page] https://www.renesas.com/products/wireless-connectivity/cellular-iot-

modules/ryz014a-lte-cat-m1-cellular-iot-module 
 

 

  

https://github.com/renesas/iot-reference-rx/blob/main/Getting_Started_Guide.md#getting-started-guide
https://www.renesas.com/document/eln/plc-240004-end-life-eol-process-select-part-numbers?r=1503996
https://www.renesas.com/document/eln/plc-240004-end-life-eol-process-select-part-numbers?r=1503996
https://www.renesas.com/products/wireless-connectivity/cellular-iot-modules/ryz014a-lte-cat-m1-cellular-iot-module
https://www.renesas.com/products/wireless-connectivity/cellular-iot-modules/ryz014a-lte-cat-m1-cellular-iot-module
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Operating Environment 
The operation described in this application note has been confirmed on the following environment. 

Integrated development environment e2 studio 2024-04 
Board CK-RX65N 
Toolchain CC-RX Compiler v3.05.00 
Emulator E2OB (E2 Lite On Board) module of CK-RX65N 

 
Before applying the contents of this application note to another MCU, a review of product-specific settings 
matching the specifications of the MCU should be made and adequate evaluation performed. 

 

Related Application Notes 
Information on documents related to this application note is provided below. Refer to these documents as 
necessary. 

• Renesas MCU Firmware Update Design Policy (R01AN5548) 
• RX Family How to implement FreeRTOS OTA by using Amazon Web Services on RX65N (R01AN5549) 
• Firmware Integration Technology User’s Manual (R01AN1833) 
• RX Family Adding Firmware Integration Technology Modules to Projects (R01AN1723) 
 
Information about boards, related programs, and development tools needed to develop RX cloud solutions is 
summarized on the page linked to below. 

https://www.renesas.com/rx-cloud 
 
Also, the following information publicly released by AWS may be of use. (The first two items are only 
available in Japanese.) 

• Provisioning authentication information to devices in AWS IoT 
Video: https://youtu.be/gcJwNEQ2eLY 
Document: https://pages.awscloud.com/rs/112-TZM-766/images/EV_iot-deepdive-aws2_Sep-2020.pdf 

• Document on fleet provisioning templates  
https://docs.aws.amazon.com/iot/latest/developerguide/provision-template.html 

• Document on AWS IoT Core policies  
https://docs.aws.amazon.com/iot/latest/developerguide/iot-policies.html 

• AWS IoT API reference document: CreateCertificateFromCsr  
https://docs.aws.amazon.com/iot/latest/apireference/API_CreateCertificateFromCsr.html 

• Provisioning devices that don’t have device certificates using fleet provisioning  
https://docs.aws.amazon.com/iot/latest/developerguide/provision-wo-cert.html 

• How to automate onboarding of IoT devices to AWS IoT Core at scale with Fleet Provisioning  
https://aws.amazon.com/blogs/iot/how-to-automate-onboarding-of-iot-devices-to-aws-iot-core-at-scale-
with-fleet-provisioning/ 

 
 

https://www.renesas.com/document/apn/renesas-mcu-firmware-update-design-policy-rev100
https://www.renesas.com/document/apn/rx-family-how-implement-freertos-ota-using-amazon-web-services-rx65n-rev102
https://www.renesas.com/document/apn/firmware-integration-technology-users-manual
https://www.renesas.com/document/apn/rx-family-adding-firmware-integration-technology-modules-projects-rev121
https://www.renesas.com/rx-cloud
https://youtu.be/gcJwNEQ2eLY
https://pages.awscloud.com/rs/112-TZM-766/images/EV_iot-deepdive-aws2_Sep-2020.pdf
https://docs.aws.amazon.com/iot/latest/developerguide/provision-template.html
https://docs.aws.amazon.com/iot/latest/developerguide/iot-policies.html
https://docs.aws.amazon.com/iot/latest/apireference/API_CreateCertificateFromCsr.html
https://docs.aws.amazon.com/iot/latest/developerguide/provision-wo-cert.html
https://aws.amazon.com/blogs/iot/how-to-automate-onboarding-of-iot-devices-to-aws-iot-core-at-scale-with-fleet-provisioning/
https://aws.amazon.com/blogs/iot/how-to-automate-onboarding-of-iot-devices-to-aws-iot-core-at-scale-with-fleet-provisioning/
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1. Terminology 
The following terms are used in this document. 

 
Table 1.1   List of Terms 

Term Meaning 
AWS A suite of cloud computing services provided by Amazon Web Services, Inc.  
FreeRTOS An open-source real-time operating system for embedded systems. 
Provisioning Device provisioning. Certification of a device to enable communication with 

AWS IoT Core. 
Fleet provisioning  Functionality that implements automated provisioning of IoT devices when 

they are turned on for the first time. 
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2. Device Provisioning  
IoT device provisioning refers to the process of generating a unique ID (such as an X.509 certificate or 
private key) for a device, registering the unique ID with an AWS IoT endpoint, and linking the necessary 
access privileges (IoT policies, etc.) to enable the device to connect securely to AWS IoT and other cloud-
based applications. (See Figure 2.2) 

Device provisioning on AWS IoT makes use of AWS IoT Core functionality such as just-in-time-registration 
(JITR) and just-in-time-provisioning (JITP) to automate the process of registering the identity of each device 
in the AWS cloud and linking it with the necessary permissions, making it easy the perform provisioning for 
multiple devices. However, the process of securely generating a unique ID and writing it to each device is the 
responsibility of the user, and for OEM vendors manufacturing large numbers of devices, this process can 
involve manual operations and be quite time consuming. 

Fleet provisioning, which is described in this document, is one way to deal with this issue. 

 
Figure 2.1   Device Provisioning 

 

 
Figure 2.2   IoT Device Provisioning  
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2.1 Provisioning Methods of AWS IoT 
AWS IoT allows the user to select from the provisioning methods listed below. 

AWS allows the user to select the device provisioning method that best matches their application. Multiple 
provisioning methods are available to accommodate market demand and a variety of use cases. The 
following document describes now the various provisioning methods work as well as their advantages and 
disadvantages in order to assist users in making a selection. We recommend referencing this document 
when considering the different provisioning methods. 

https://pages.awscloud.com/rs/112-TZM-766/images/EV_iot-deepdive-aws2_Sep-2020.pdf#page=115 

 
[ Provisioning Methods of AWS IoT ] 

1.  Private key and certificate issuance and pre-registration by AWS IoT (registration at time of device kitting) 
2.  Certificate issuance and pre-registration by AWS IoT (registration at time of device kitting) 
3.  Fleet provisioning registration (Described in this document.) 
4.  Certificate issuance by your own certification authority and pre-registration on AWS IoT 
5.  Certificate issuance by your own certification authority and registration by JITR 
6.  Certificate issuance by your own certification authority and registration by JITP 
7.  Registration of a certificate from an unregistered certification authority (multi-account registration) 
 
 
When confirming the operation of FreeRTOS at the preliminary stages when considering mass production, 
the simplest approach is “private key and certificate issuance and pre-registration by AWS IoT.” In this case 
a private key certificate is issued and the source code is converted on AWS, and the resulting source code is 
embedded in the source code of FreeRTOS. However, it is difficult to embed individual certificates during 
manufacturing using this method. For this reason, this document focuses on fleet provisioning, which does 
not require use of a certification authority and imposes the lightest workload during mass production. 

 
Note:  A part of RX Family MCUs incorporate a Trusted Secure IP (TSIP) module. When the TSIP is used, 

an on-chip random number generator is used to generate an RSA or elliptic curve cryptosystem key 
pair, and the public key is extracted and sent to a user-specified certification authority, which appends 
and returns a certificate. This enables implementation of JITR or JITP. This method provides strong 
security while reducing the implementation cost, and it should be considered for practical use moving 
forward.  

 

https://pages.awscloud.com/rs/112-TZM-766/images/EV_iot-deepdive-aws2_Sep-2020.pdf#page=115
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2.2 Fleet Provisioning Method 
Fleet provisioning is a procedure in which provisioning takes place when each IoT device is started for the 
first time. Generally speaking, it can be implemented in either of the following two ways.  

1.  Provisioning by claim (approach using provisioning claim certificates) 
2.  Provisioning by trusted user (mobile or web app user, etc.) 
 
In addition, either of the following two procedures can be used to obtain the individual certificates and private 
keys used for fleet provisioning. 

 
A)  Having the AWS certification authority generate a new individual certificate and private key and send it to 

the device (CreateKeysAndCertificate). 
B)  Generating a key pair on the device internally and sending a certificate signature request (CSR) to AWS 

to have them generate only an individual certificate and send it to the device (CreateCertificateFromCsr). 
 
This document describes the implementation of a fleet provisioning demo that combines 1. and B). (See 
Figure 2.6.) The provisioning method presented in this document provides the following advantages. 

 
Advantages: 
• The device’s private key never leaves the device. 
• There is no need to establish a connection between the manufacturing plant and AWS IoT. 
• There is no need to put in place a structure for issuing individual certificates or registering devices. 
 
 
On the other hand, it also has the following disadvantages. It is necessary to be aware of both the 
advantages and the disadvantages when using this provisioning method. 

 

Disadvantages: 
• It is necessary to take into account the possibility that the provisioning claim certificate could leak to an 

unauthorized party.  
• It is necessary to implement functionality on the device to issue a provisioning request and receive a 

response. 
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2.3 Provisioning by Claim (Approach Using Provisioning Claim Certificates) 
Each device can be manufactured with an embedded provisioning claim certificate and private key. If these 
credentials have been registered with AWS IoT, AWS IoT can exchange them for a unique device certificate 
that can then be used in the normal operation of the device. This process consists of the steps listed below. 

The design of provisioning by claim assumes a scenario in which all the devices are manufactured using a 
common provisioning claim certificate. The provisioning claim certificate only allows each device to do the 
following. 

1.  Establish an initial connection to AWS IoT Core. 
2.  Verify identity. 
3.  Use data communication as described below to request an ID to which the necessary permissions have 

been assigned. 
 
 
The provisioning claim certificate common to all the devices is written to each device, along with the initial 
software, at a site such as the manufacturing plant. If the device already contains an individual private key, it 
can send a provisioning claim certificate to be signed by AWS IoT Core and a certificate signature request 
(CSR). (See Figure 2.6.) 

In addition to the provisioning claim certificate presented by each device, fleet provisioning can make use of 
Lambda-based provisioning hooks to verify the attributes of devices. Examples of device attributes include 
serial number, MAC ID, and device location. We recommend that you consider making use of Lambda 
functions in provisioning transactions as a way to automate acceptance or rejection of the provisioning status 
of individual devices based on the custom attributes sent during this process. 

(The demo project described in this application note does not make use of Lambda functions.) 

 
Refer to the page linked to below for information on using AWS Lambda for provisioning. 

https://docs.aws.amazon.com/iot/latest/developerguide/provision-wo-cert.html 

“Using pre-provisioning hooks with the AWS CLI” 

 

https://docs.aws.amazon.com/iot/latest/developerguide/provision-wo-cert.html
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2.3.1 Overview of Provisioning by Claim (Using Provisioning Claim Certificate) 
When the device is powered on and capable of establishing a network connection, one of the following 
workflows is executed. 

Figure 2.5 and Figure 2.6 show the workflows for the CreateKeysAndCertificate method and 
CreateCertificateFromCsr method, respectively. 

Also, you can confirm the details of the AWS IoT Fleet Provisioning Demo workflow 
(CreateCertificateFromCsr method), on which the fleet provisioning demo described in this document is 
based, by visiting the page linked to below. 

https://aws.github.io/aws-iot-device-sdk-embedded-
C/latest/docs/doxygen/output/html/fleet_provisioning_demo.html 

 
1.  Using the claim certificate written to the device beforehand, the device connects to AWS IoT Core via a 

secure TLS 1.2 connection. If the device contains a CSR, this is presented along with the provisioning 
claim certificate. 

 
2.  The certificate is linked to an extremely restrictive policy that only provides access to IoT topics linked to 

the fleet provisioning process. 
 
3.  The fleet provisioning service returns a token providing “proof of ownership” to securely isolate the 

transaction and a valid certificate and private key payload. The token will be called later to activate the 
certificate. If a CSR was presented, it is used to generate the certificate. 

 
4.  The device sends a MQTT request to AWS IoT Core and presents the ownership token, the name of the 

fleet provisioning template created by the account owner, and (optionally) device attributes for 
provisioning validation. It is recommended that Lambda-based provisioning hooks be used to enable 
additional validation, such as checking the device’s serial number or MAC ID against a pre-approved list. 

 
5.  The fleet provisioning template is acted upon, the provisioning transaction takes place, and the results are 

returned. Typically, these results may include verification by Lambda function of device attributes, 
certificate activation, production policy attachment, and thing or group creation (optional). 

 
6.  Based on the results of the provisioning transaction, the status of the new certificate is returned. If the 

transaction was successful, the provisioning claim certificate is deprecated or rotated for the “production” 
certificate. If the transaction is denied, an “access denied” error is returned to the device. 

 
  

https://aws.github.io/aws-iot-device-sdk-embedded-C/latest/docs/doxygen/output/html/fleet_provisioning_demo.html
https://aws.github.io/aws-iot-device-sdk-embedded-C/latest/docs/doxygen/output/html/fleet_provisioning_demo.html
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Figure 2.3   Workflow of Provisioning by Claim Using CreateKeysAndCertificate Method 

 

 
Figure 2.4   Workflow of Provisioning by Claim Using CreateCertificateFromCsr Method 
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2.3.2 Determining a Unique Thing Name 
When sending a request to MQTT during fleet provisioning, the device’s serial number can be included in the 
payload to ensure that each device has a unique thing name that does not duplicate an existing one. 

Generally speaking, one of the following two methods is used to determine the serial number. 

1.  A random value generated by a random number generator or an ID value unique to the device is used as 
the serial number. 

2.  A Lambda-based provisioning hook and Amazon S3 or a user-specified database are used to change a 
temporarily assigned serial number to a unique serial number. 

 
The example described in this document makes use of method 1. The unique ID assigned to each RX Family 
MCU is used to prevent duplication of thing names. 

 
Figure 2.5   Using a Random Value or Unique ID to Determine the Thing Name 

 

 
Figure 2.6   Using Amazon S3 or a Database to Determine the Thing Name 
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3. Preparation 
This section and those that follow describe the sequence of steps from importing the project accompanying 
this application note to running the fleet provisioning demo on the CK-RX65N board. 

 

3.1 Hardware Environment 
The components of the hardware environment for the demo project are listed below. 

 
Table 3.1   Hardware Components 

Item Product Name Provider Description 
Board CK-RX65N Renesas Electronics 

Corporation 
RX65N Cloud Kit 

PC PC running Windows 10 
(recommended) 

 Host PC for demo 

 
 

3.2 Software Environment 
The components of the software environment for the demo project are listed below. 

 
Table 3.2   Components 

Item Product Name Version Description 
Integrated development 
environment 

e2 studio 2024-04  

Toolchain CC-RX v3.05.00  
Communication software Tera Term Ver 4.106 For displaying logs 
FreeRTOS v202210.01-LTS-rx V1.2.1  
Emulator E2OB (E2 Lite On Board) 

module of CK-RX65N 
  
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3.3 Tera Term Installation and Settings 
The demo uses Tera Term to display log output. 

1. Access the Tera Term download page. 
Tera Term download page (GitHub) 

 
2. Download the Tera Term installer. 

 
Figure 3.1   Downloading Tera Term 

 
3. Launch the installer, and follow the instructions that appear to install Tera Term. 
4. In the Start menu, click the Tera Term icon and confirm that Tera Term starts. 
5. Configure the following settings in Tera Term. 
 
Table 3.3   Tera Term Settings 

Item Setting 
Baud rate 115,200 
Data length 8 bits 
Parity None 
Stop bits 1 bit 
Flow control None 

 
 

https://github.com/TeraTermProject/osdn-download/releases
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3.4 FreeRTOS Project 
Figure 3.2 shows the software components of the demo project. 

 
Figure 3.2   Components of Demo Project Accompanying This Application Note 

 

The AWS IoT Fleet Provisioning Library for FreeRTOS is used to implement fleet provisioning functionality. 
RX Driver Package, FreeRTOS, AWS IoT Fleet Provisioning Library, and the demo application are available 
from the repository linked to below. 

 
Demo application: iot-reference-rx : FreeRTOS reference repository 

 

https://github.com/renesas/iot-reference-rx
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4. Running the Fleet Provisioning Demo 
How to run the fleet provisioning demo application is described below. 

 

4.1 Preparing the Running Environment 
First, prepare the environment on which the demo will run. Figure 4.1 shows an example using the 
CK-RX65N board. Either a wired (Ethernet) or wireless (cellular) communication interface can be used to 
connect to AWS. 

 
Figure 4.1   Demo Running Environment 
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4.2 AWS Preparation 
An AWS account is required to run the fleet provisioning demo application. If you do not have an account, 
start by creating an account and logging in to the console. Note that the screenshots of the AWS console 
appearing in this application note are current as of September 2023. 

 
AWS top page (https://aws.amazon.com/ ) 

 
① Select Sign In to the Console → Get Started for Free to create a new account. 

 
 
② Click Sign In to the Console and sign in. 

 
 
③ Select Services → Internet of Things → IoT Core to open the AWS IoT console. 

 
Figure 4.2   AWS Console 

 

https://aws.amazon.com/
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4.3 AWS Settings for Fleet Provisioning 
It is necessary to configure AWS settings in order to run the fleet provisioning demo. 

1. Policy settings 
2. Generating a claim certificate and claim key pair 
3. Creating a fleet provisioning template 
 
 
4.3.1 Policy Settings 
Follow the steps below to create AWS IoT Core policies. The first policy you create will be used when fleet 
provisioning is run. 

 
Select Security → Policies and then click the Create policy button. 

 
Figure 4.3   Creating an AWS IoT Policy (1) 
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In the Policy name field, enter a policy name of your choice. 

Click the JSON button to display the policy document input field, then copy and paste the policy document 
shown in Figure 4.5 into the input field. When copying and pasting the policy document in Figure 4.5, make 
the following changes: 

• Change “ap-northeast-1” to match the region used. 
• Change <account id> to your own account ID (account ID is the 12-digit number after @ that is displayed 

by clicking on the account name in the upper right corner, excluding the hyphen) 
 
Click the Create button to create the policy. 

 

 
Figure 4.4   Creating an AWS IoT Policy (2) 

 

Copy and paste the text of the policy document here. 
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Figure 4.5   Policy Document 

 

{ 

  "Version": "2012-10-17", 

  "Statement": [ 

    { 

      "Effect": "Allow", 

      "Action": "iot:Connect", 

      "Resource": "*" 

    }, 

    { 

      "Effect": "Allow", 

      "Action": [ 

        "iot:Publish", 

        "iot:Receive", 

        "iot:RetainPublish" 

      ], 

      "Resource": [ 

        "arn:aws:iot:ap-northeast-1:<account id>:topic/$aws/certificates/create-from-csr/*", 

        "arn:aws:iot:ap-northeast-1:<account id>:topic/$aws/provisioning-templates/*" 

      ] 

    }, 

    { 

      "Effect": "Allow", 

      "Action": "iot:Subscribe", 

      "Resource": [ 

        "arn:aws:iot:ap-northeast-1:<account id>:topicfilter/$aws/certificates/create-from-csr/*", 

        "arn:aws:iot:ap-northeast-1:<account id>:topicfilter/$aws/provisioning-templates/*" 

      ] 

    } 

  ] 

} 
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Next, create a policy that will be attached to things created after fleet provisioning is run. 

 
Select Security → Policies and then click the Create policy button. 

 
Figure 4.6   Creating an AWS IoT Policy (1) 
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In the Policy name field, enter a policy name of your choice. 

For Policy action under Policy document, select Allow for iot:Connect, iot:Publish, iot:Subscribe, and 
iot:Receive. For Policy resource enter the wildcard character (*) to allow all resources. By default you can 
configure one statement. Click the Add new statement button to add additional statements as needed. 

 
Figure 4.7   Creating an AWS IoT Policy (2) 
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4.3.2 Generating a Claim Certificate and Claim Key Pair 
Generate a provisioning claim certificate and provisioning claim key pair for use in fleet provisioning. 

 
Select Security → Certificates and then click Add certificate → Create certificate. 

 
Figure 4.8   Creating a Certificate 
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Click Auto-generate new certificate (recommended) → Create. 

 

Figure 4.9   Creating a Certificate Automatically 

 
Download the newly created certificate ① and key pair ②③, then click the Continue button. 

 

Figure 4.10   Downloading the Certificate and Key Pair 

① 

② 

③ 
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On the AWS console, select Security → Certificates and select the newly generated certificate ID. 

 

Figure 4.11   Certificate Settings 
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Click Actions → Activate to activate the certificate. Also click the Attach policies button. 

 

Figure 4.12   Certificate Settings: Attach Policies (1) 

 
Clicking the Attach policies button opens the dialog box shown in Figure 4.13. 

Select the policy to be used when fleet provisioning is run, created in 4.3.1, Policy Settings, and then click 
the Attach policies button to attach it to the certificate. 

This completes the settings related to generation of the claim certificate and claim key pair. 

 

Figure 4.13   Certificate Settings: Attach Policies (2) 
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4.3.3 Creating a Fleet Provisioning Template 
Select Connect many devices → Connect many devices, then click the Create provisioning template 
button. 

 
Figure 4.14   Creating a Provisioning Template (1) 

 
Select Provisioning devices with claim certificates, then click the Next button. 

 
Figure 4.15   Creating a Provisioning Template (2) 
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On the template creation screen, specify the provisioning template status, template name, and provisioning 
role. For Provisioning template status select Active, and enter the name of the provisioning template. 
Then click the Create new role button and enter the role name. 

 
Figure 4.16   Creating a Provisioning Template (3) 

 
Here Role name is set to fleet_demo, but you can create any role name you wish. 

Next, click the Create button. 

 
 

Figure 4.17   Creating a New Role 
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For Claim certificate policy, select the policy to be used when fleet provisioning is run, created in 4.3.1, for 
Claim certificate, select the certificate created in 4.3.2, and click the Next button. 

 
Figure 4.18   Creating a Provisioning Template (4) 
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For Pre-provisioning actions, select Don’t use a pre-provisioning action. Also, under Automatic thing 
creation, turn on Automatically create a thing resource when provisioning a device, and if necessary 
enter a character string of your choice as the thing name prefix. The thing name registered with AWS will be 
generated from this character string and the serial number set by the program. After entering the prefix, click 
the Next button. 

 
Note:  The demo does not use pre-provisioning actions. Refer to the page linked to below for information on 

using pre-provisioning actions. 
https://docs.aws.amazon.com/iot/latest/developerguide/provision-wo-cert.html 
“Using pre-provisioning hooks with the AWS CLI” 

 

 

 
Figure 4.19   Creating a Provisioning Template (5) 

 

https://docs.aws.amazon.com/iot/latest/developerguide/provision-wo-cert.html
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For Set device permissions, check the box next to the policy attached to newly created things, which was 
created in 4.3.1, then click the Next button.  

 
Figure 4.20   Creating a Provisioning Template (6) 

 
Click the Create template button to complete the process of creating a fleet provisioning template.  

 
Figure 4.21   Creating a Provisioning Template (7) 
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4.4 Creating the Sample Projects 
Follow the procedure below to create a sample project to perform provisioning for IoT devices using Amazon 
Web Services, as described in 4.5. 

If you wish to use the import function to run the demo project, refer to the instructions in Getting Started 
Guide. 

(1) Create a workspace in e2 studio. 
Launch e2 studio and create a new workspace. 
Keep the names of the workspace and the project files as short as possible. If the full path to the files at 
the lowest level of the directory structure exceeds 256 bytes, an error will occur when you build the 
project. 
Errors may also occur if the file path contains Japanese characters, so make sure the name you enter 
contains only alphanumeric characters.  
Example: Creating a workspace in location C:\workspace 

 

 
Figure 4.22   Dialog Box for Creating a Workspace 

 
After launching e2 studio, from the File menu select New > Renesas C/C++ Project > Renesas RX to 
display the New C/C++ Project dialog box. 

 

 
Figure 4.23   Creating a New Project from the File Menu 

 
  

https://github.com/renesas/iot-reference-rx/blob/main/Getting_Started_Guide.md
https://github.com/renesas/iot-reference-rx/blob/main/Getting_Started_Guide.md
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In the New C/C++ Project dialog box, select the type of project to be created. In this case, select All, 
then select Renesas CC-RX C/C++ Executable Project and click the Next button. 
Selecting the project type opens the New Renesas CC-RX Executable Project dialog box. 
To use GCC, select GCC for Renesas RX C/C++ Executable Project as the project type. 

 

 
Figure 4.24   Dialog Box for Selecting the Project Type 
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(2) Create a sample project. 
Here you will specify the project name. Enter fleet_demo as the project name and click the Next button. 
The Select toolchain, device & debug settings dialog box opens. 

 

 
Figure 4.25   Dialog Box for Specifying the Project Name 
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Configure the toolchain, device, and debug settings to use for the project. 
The setting for Toolchain is pre-selected based on the type of project. To change the toolchain version, 
select the version of your choice from the drop-down list next to Toolchain Version. 
For RTOS, select Free RTOS (with IoT libraries), and for RTOS Version select 202210.01-LTS-rx-
1.2.1. If you are running e2 studio for the first time or if the desired version does not appear in the list, 
click Manage RTOS Versions... to display the RTOS Module Download dialog box, check the box next 
to the desired version, and click the Download button to download it. 
For Target Board, select CK-RX65N. (The setting for Target Device is selected automatically.) 
For Bank Mode, select Dual Bank.  
After all the settings have been configured, click the Next button. 

 

 
Figure 4.26   Dialog Box for Specifying Toolchain, Device, and Debug Settings 
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When the Select Coding Assistant settings dialog box appears, click the Next button without changing 
any settings. 

 

 
Figure 4.27   Dialog Box for Selecting the Coding Assistant Tool 
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A list of sample projects is displayed in the Select RTOS Project Settings dialog box. 
Use the scroll bar to scroll down the list, select (Cellular) PubSub/MQTT with Fleet Provisioning 
sample project, and click the Next button. 

 

 
Figure 4.28   Dialog Box for Selecting RTOS Project Settings 
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When the Settings The Contents of Files to be Generated dialog box appears, click the Next button 
without changing any settings.  

 
Figure 4.29   Dialog Box for Specifying Details of Files to Be Created  
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A dialog box appears indicating that the project has been created. If everything appears to be in order, 
click the Finish button. 

 

  
Figure 4.30   Dialog Box Indicating that Project Creation is Complete 

 
When the Editors available on the Marketplace dialog box appears, click the Cancel button to close it. 

 

  
Figure 4.31   Dialog Box for Displaying Editors Available on the Marketplace 

 



RX Family Provisioning Procedure for IoT Devices 

R20AN0674EJ0110  Rev.1.10  Page 40 of 60 
Jun.14.24 

This completes the procedure for creating the project in e2 studio. 
If Project Explorer is not visible, click the button for the C/C++ perspective in the upper right corner of the 
window, then select Window > Show View > Project Explorer. 

 

 
Figure 4.32   Window Displayed after Creation of Fleet Provisioning Sample Project 

 
In the discussion that follows, replace the project name aws_ryz014a_ck_rx65n with fleet_demo as 
appropriate. 
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4.5 FreeRTOS Settings 
You will need to make a modification to the program in order to run the demo. 

 
4.5.1 Modifying the Configuration File 
From the Project Explorer panel in e2 studio, open aws_ryz014a_ck_rx65n/src/frtos_config/demo_config.h 
and change the value of ENABLE_FLEET_PROVISIONING_DEMO to 1. 

 
Figure 4.33   Location of Modification in demo_config.h 
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4.5.2 Cellular information settings 
From the Project Explorer panel in e2 studio, open aws_ryz014a_ck_rx65n/aws_ryz014a_ck_rx65n.scfg 
and launch the Smart Configurator. (Figure 4.34) 

Select the Components tab in the Smart Configurator and select Middleware → Generic → r_cellular from 
the Components. Set each item of Access point name, Access point login ID, Access point password 
and SIM card PIN code according to the SIM card you are using. If there is no content to enter, leave it 
blank. (Figure 4.35) 

After entering the Cellular information, click the Generate Code button to apply the settings to the program. 

 
Figure 4.34   Launch the Smart Configurator 
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Figure 4.35   Entering Cellular information 

 

 
Note: About the setting of Wi-Fi network with DA16600 module, please refer to the GitHub「Settings of Wi-Fi 
network (Only using Wi-Fi)」. And regarding setting of country code and GMT timezone, please refer to the 
Settings of Country code and GMT timezone (Only using Wi-Fi) as needed. 

 

https://github.com/renesas/iot-reference-rx/blob/main/Getting_Started_Guide.md#settings-of-wi-fi-network-only-using-wi-fi
https://github.com/renesas/iot-reference-rx/blob/main/Getting_Started_Guide.md#settings-of-wi-fi-network-only-using-wi-fi
https://github.com/renesas/iot-reference-rx/blob/main/Getting_Started_Guide.md#settings-of-country-code-and-gmt-timezone-only-using-wi-fi
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4.6 Building and Running the Program 
Build the project, program it to the device, and run the demo. 

 
First, on the Project Explorer panel, right-click aws_ryz014a_ck_rx65n and select Build Project to build the 
project. 

Next, select Run → Debug Configurations… from the e2 studio menu to open the Debug Configurations 
window. In the list at the left of the Debug Configurations window, select Renesas GDB Hardware 
Debugging → aws_ryz014a_ck_rx65n Hardware Debug. Then select the Debugger tab followed by the 
Connection Settings tab (indicated by arrows in Figure 4.36). 

Check to make sure that the settings of the items enclosed by red frames in Figure 4.34 match those shown, 
then click the Debug button to download to the device the executable data produced by building the project. 

 
Figure 4.36   Debug Configurations 
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Launch Tera Term in order to enter the claim certificate, claim private key, endpoint, and provisioning 
template name. 

 
After Tera Term starts, select Serial and USB Serial Device, then click the OK button. 

 
Figure 4.37   Initial Window when Tera Term Starts 

 
Select Setup → Serial port… from the menu, configure the serial port setting items enclosed by red frames 
as shown, and then click the New setting button. 

 
Figure 4.38   Serial Port Setup 
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Select Setup → Terminal… from the menu, set Receive: to AUTO and Transmit: to CR+LF as shown in 
the red frames, and then click the OK button. 

 
Figure 4.39   Terminal Setup 

 
From the AWS IoT console, select MQTT test client, enter # under Topic filter, and click the Subscribe 
button. 

 
Figure 4.40   MQTT Test Client Settings 
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In e2 studio, press Resume (F8) to display the text output shown below in Tera Term. Within 10 seconds, 
type CLI in Tera Term and press the Enter key. 

 
Figure 4.41   Entering Information Using CLI (1) 

 
It is possible that information may have been stored already if the demo was run previously, so type format 
in Tera Term and press the Enter key. 

This causes all stored information to be erased. 

 
Figure 4.42   Entering Information Using CLI (2) 
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To enter the endpoint, type conf set endpoint <endpoint> in Tera Term and press the Enter key.  

For <endpoint>, enter the value in the format xxxxxxxxxx.amazonaws.com that is displayed for Endpoint 
when you select Settings → Device data endpoint on the AWS IoT console. 

 

 
Figure 4.43   Entering Information Using CLI (3) 
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To enter the provisioning template name, type conf set template <template_name> in Tera Term and 
press the Enter key.  

For <template_name>, enter the name of the provisioning template created in 4.3.3. 

 
Figure 4.44   Entering Information Using CLI (4) 
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To enter the provisioning claim certificate, type conf set claimcert in Tera Term. Next, drag and drop the 
provisioning claim certificate file (xxxx-certificate.pem.crt) created in 4.3.2 onto the Tera Term window 
(Send File). Finally, press the Enter key in Tera Term.  

 

 
Figure 4.45   Entering Information Using CLI (5) 

 

After typing conf set claimcert, drag and drop 
the certificate file. Then press the Enter key. 
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To enter the provisioning claim private key, type conf set claimkey in Tera Term. Next, drag and drop the 
provisioning claim private key file (xxxx-private.pem.key) created in 4.3.2 onto the Tera Term window 
(Send File). Finally, press the Enter key in Tera Term.  

 

 
Figure 4.46   Entering Information Using CLI (6) 

 

After typing conf set claimkey, drag and drop 
the private key file. Then press the Enter key. 
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To store the information entered up to this point in the data flash memory, type conf commit in Tera Term 
and press the Enter key. 

 
Figure 4.47   Entering Information Using CLI (7) 

 
To start the demo, type reset in Tera Term and press the Enter key. If nothing is entered in Tera Term for 
10 seconds after the reset, the demo starts. 

 
Figure 4.48   Entering Information Using CLI (8) 
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4.7 Confirming the Results of Running the Demo 
Figure 4.49 shows a log file produced by running the fleet provisioning demo. 

(The log is displayed in Tera Term.) 

If the text string “Demo completed successfully.” appears at the end of the log, the fleet provisioning demo 
completed successfully. Successful completion of the demo means that a new thing has been registered on 
AWS IoT Core and an individual device certificate assigned to it. 

 
Figure 4.49   Log Produced when Fleet Provisioning Demo Completes Successfully 
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After running the fleet provisioning demo, you can use the individual device certificate and private key 
obtained from AWS to run the PubSub demo. Check to confirm that the text string “Successfully sent QoS 0 
publish to topic:” appears in the log as shown in Figure 4.50. 

 
Figure 4.50   Log Produced when PubSub Demo Completes Successfully  

 
You can also check MQTT messages sent to AWS from CK-RX65N by selecting MQTT test client from the 
AWS IoT console.  

 
Figure 4.51   MQTT Test Client after Successful Completion of PubSub Demo 
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You can check on the thing registered by the fleet provisioning demo from the AWS IoT console. 

Under All devices, select Things. The thing (shown as 
“FPDemoID_xxxxxxxx_xxxxxxxx_xxxxxxxx_xxxxxxxx” in Figure 4.52) will have been registered if the demo 
completed successfully. 

 
Figure 4.52   Confirming the Results of Running the Demo (1) 
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By checking the registered things, you can confirm that the individual device certificate generated and 
assigned by fleet provisioning (Certificate ID in Figure 4.53) has been attached and activated. 

 

 
Figure 4.53   Confirming the Results of Running the Demo (2) 

 

Confirm that the certificate ID matches that shown in 
the debug log. 
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5. Conclusion 
As mentioned earlier, there are multiple provisioning methods, and there are also various ways to enhance 
security. Nowadays, it is essential to select and deploy an appropriate provisioning method that matches the 
actual application in the target market, the scale of the system (number of devices), and the required level of 
security. 

However, it is not a simple matter to maintain, manage, and operate a secure manufacturing facility in-house 
in order to implement provisioning functionality. This is why the fleet provisioning method had gained so 
much attention as an approach to the device provisioning process, and this is probably why market demand 
for this method is growing rapidly. 

The provisioning method described in this document is only one example, so it will not satisfy the 
requirements of all users. Nevertheless, we think the information presented here will help deepen the 
reader’s understanding of the advantages and disadvantages of deployment. It is our hope that this 
document will help users build convenient and practical production lines. 

 

6. Websites and Support Information 
AWS re:Post : https://repost.aws 

Renesas FreeRTOS GitHub : https://github.com/renesas/iot-reference-rx 

 

https://repost.aws/
https://github.com/renesas/iot-reference-rx
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7. Appendix 
7.1 Points to Keep in Mind when Operating Multiple Devices within the Same LAN 

Environment 
Addresses assigned from the header ID of Renesas Electronics Corporation are used as the MAC addresses 
contained in the sample code. 

When using the sample program to operate multiple devices within the same LAN environment, it is 
necessary to change the MAC addresses to avoid duplication.  

The sample program may not operate properly if the same MAC addresses are duplicated among multiple 
devices. 

The procedure for changing the MAC addresses is described below. 

 
Open aws_ether_ck_rx65n.scfg in Smart Configurator, and select the Components tag. 

In the tree, select RTOS → RTOS Kernel → FreeRTOS_Kernel, then under Property set Value for MAC 
address 0 to MAC address 5 to hexadecimal values of your choice. 

Enter values in the format 0xXX (where XX represents a hexadecimal value of your choice). 

When commercializing a product for sale, make sure to apply to the IEEE to obtain the MAC addresses 
eventually used. 

 

Figure 7.1   MAC Address Settings 
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After making the above changes, click the Generate Code button in the upper right corner of the window to 
apply the changes made in Smart Configurator to the code. 

 

Figure 7.2   Generating Code 
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General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 
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3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, 
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RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO 
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. 

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas 
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such 
specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
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controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 
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prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
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Electronics products. 
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