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Notice

All information included in this document is current as of the date this document is issued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sal es office. Also, please pay regular and careful attention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

Y ou should not ater, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. Y ou are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any losses incurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. 'Y ou should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the development of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errors in or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific’. The recommended applications for each Renesas Electronics product depends on the product’s quality grade, as
indicated below. You must check the quality grade of each Renesas Electronics product before using it in a particular
application. You may not use any Renesas Electronics product for any application categorized as “ Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not be in any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as“ Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is“ Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home el ectronic appliances, machine tools; persona electronic equipment; and industria robots.

“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.

“Specific™: Aircraft; agrospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or heathcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life.

Y ou should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,
especialy with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.

Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physical injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as a result of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics’ as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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2.1  M32C Compact Emulator Debugger
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Section 1 Notes on Using the
High-performance Embedded Workshop

This section shows notes on using the High-performance Embedded Workshop .
1.1 Notes on Network Drive Issues

1.1.1  Time discrepancies between computers

The time kept by a computer differs between computers. The time when a source file or an output file is updated
differs depending on a computer. It may happen that building a project can be incorrect because of difference of
times kept by computers if a source file or an output file is shared via network. If such problem occurs, build a
project using [Build->Build All].

1.1.2  Building a project on a network drive

When you build a project on the network an error might occur depending on the condition of the network. For
example, a C/C++ compiler might output the following error message.

C3019 (F) Cannot open source file

If such an error occurs, build the project again.

1.1.3  Adding a file to a project

When you add a file on a remote drive on the network via [Project->Add Files...] or else, the High-performance
Embedded Workshop might cause an application error depending on the condition of the network. In this case, try to
add the file to the project again. If application errors occur many times, consider copying the file to a local drive
then adding to the project.

1.2 Note on Network database feature

This feature is not available if your OS is Windows® 98 or Windows® Me.
1.3  Notes on Comments of the C/C++ Language

1.3.1  Syntax coloring of the High-performance Embedded Workshop editor

With the syntax coloring capability of the High-performance Embedded Workshop, comments and keywords in a
source program file are colored. But the syntax coloring of the High-performance Embedded Workshop editor does
not work correctly depending on the way the source code is written. Disable the syntax coloring if you are not
satisfied with the syntax coloring. To disable it, select [Setup->Options...], uncheck “Enable Syntax Coloring” on
the [Editor] tab of the [Options] dialog box, and click the OK button.

Syntax colouring does not work correctly in the following cases:
Case 1. A comment is nested.
e.g. /* /% *x/ */ <~—the underlined part is colored as comment

Case 2. “/*” or “* /” is placed in a string.
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e.g. /* <~-the underlined part is colored as comment
char A[]=“*/"; <~the underlined part is colored as comment
*/

Try to avoid using the * characters and the / characters placed adjacent to each other in a C/C++ source file unless
you specify a comment.

1.3.2  File dependencies scanned by the High-performance Embedded Workshop

The High-performance Embedded Workshop scans an include file of a C/C++ source file to show dependencies of
source files on the “Projects” tab of the “Workspace” window and to decide whether to build a file or not. Even
though the source code is syntactically correct, it may happen that a scan error is detected; that an include file which
is not actually included might be shown as a dependent file; or that an include file which is included might not be
shown as a dependent file. In these cases, (a) build all files by selecting [Build->Build All] or (b) select the source
file in the “Projects” tab of the “Workspace” window and select [Build->Build File].

Dependencies are not scanned correctly in the following cases:
Case 1. “/*” or “*/” is placed in a string.

e.g. char A[] = “/*”; <-assumed as beginning of comment incorrectly
#include “file.h” <- this file is not scanned as include file
char B[] = “*/”; <-assumed as end of comment incorrectly

To support preprocessor statements such as #if, #ifdef, and #define by the High-performance Embedded Workshop,
go to the [Build] menu to open the Toolchain Option dialog box. On the [Toolchain Option] tab, check [Support
dependency scan of preprocessor statement].

When a preprocessor statement has an expression, the following ten kinds of operators are currently supported with
the dependency check. The dependency search does not operate correctly if an operator, other than those listed
below, is used.

( )7 !’ <7 <:7 >a >:7 ==, !:, &&, and ||
14 Notes on the Navigation Facilities

1.4.1  Navigation to a Definition of a C Function

The High-performance Embedded Workshop scans a definition of a C function in a C/C++ source file and displays a
tag of the definition on the “Navigation” tab of the “Workspace” window so that double-clicking the tag will
navigate you to the line of the definition in a corresponding file. The High-performance Embedded Workshop
ignores preprocessor directives when it searches a definition of a C function. For example, two definitions of func()
might be displayed on the “Navigation” tab of the “Workspace” window in the following code.

#define DEF 1
#ifdef DEF
void func (void)
{

}

felse

int func(int a)
{

}

Rev.1.00 Oct. 01, 2005 page 4 of 12
REJ10J0989-0100



1.4.2  Default Setting for "C++ Classes' of the Navigation Facilities

“C++ Classes” of the navigation facilities is disabled (unchecked) at default. You can check the setting in the
“Select Categories” dialog box (figure 1.1). To open the “Select Categories” dialog box, click the right-hand mouse
button on the window of the “Navigation” tab and then select “Select Categories...”

Select Gategories x|

Please zelect the categories to zcan for:
(W] Defines g |

. ance |
(W] Functions

[(J5++ Clazses

Figure 1.1 Select Categories Dialog Box

1.4.3  Warning Message by ""C++ Classes' of the Navigation Facilities

When "C++ Classes" of the navigation facilities is enabled (checked), the warning message will appear (figure 1.2).
While this item is enabled, the navigation facilities run in the background. The CPU usage of your host computer
may be shown as 100% and the reaction of the High-performance Embedded Workshop may be slow.

High—performance Embedded Workshop ﬂ

L E WARMNIMNG: Enabling thiz item may cause HEW to run = lowmly
L

Figure 1.2 Warning Message

1.5  Note on Expression

1. A function name of the C++ program cannot be specified for the expression symbol.

2. No overloaded operator can be used as a function name.
1.6  Note on Opening a File which Caused an Error

This is a note when you double click an error/warning message of the C/C++ Compiler or the Assembler on the
“Output” window and open the corresponding line of the corresponding file. If the corresponding file window,
however, has been minimized in the editor window area, the file is not opened on double clicking the error/warning
message. In this case, restore the file window or maximize it.
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1.7  Note on Use of a Relative Path on a Option Dialog Box

Using the [Build] menu of the High-performance Embedded Workshop, you can launch an option dialog box on
which you can specify options to a tool such as a compiler. Do NOT specify a relative path when you specify a path
on an option dialog box. Especially, when “Custom directory” is selected in the “Relative to” field on a dialog box
as shown in figure 1.3, do specify an absolute path in the “Directory” field.

=g

Belative ta: (014
IGustDm directary j Ciancel
Directary :

| Browse... |

Figure 1.3 Dialog Box to Specify a Directory Path
1.8 Note on Debugging (Common)

1.8.1 Source-Level Execution

Even standard C libraries are executed by [Step In]. To return to a higher-level function, enter the [Step Out] button.
In a “for” statement or a “while” statement, executing a single step does not move to the next line. To move to the
next line, execute two steps.

1.8.2  Moving Source File Position after Creating Load Module

When the source file is moved after the load module has been created, the [Open] dialog box, which specifies the
source file, may be displayed during debugging the created load module. Select the corresponding source file and
click the [Open] button.

1.8.3 Editor window

After modifying the program displayed in the editor window and reloading the source files and load modules, close
the editor window then open it again; otherwise the program displayed in the window may not be correct.

1.8.4 Stack trace window

When the stack trace window is displayed with the interruption function executed, the display before the
interruption function becomes incorrect.

1.8.5 Font in Memory window

Some data may not be displayed when a proportional font is used in the [Memory] window.

1.8.6  Entry Point

Even when an entry point is specified by the ENTRY option of the linkage editor, the entry point address is not set
for the PC during program downloading. Set the PC before program execution.
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1.9 Note on Debugging (M16C Family Debugging Platform)

1.9.1 Line Assembly

Regardless of the Radix setting, the default for line assembly input is decimal. Specify H as the radix for a
hexadecimal input.

1.9.2 Event Setting

e TAB order in Set Event Status dialog box

Even when you press [TAB] key, the next input control may not be focused on the Set Event Status dialog boxes
opened from H/W Break, Time Measurement, and Trace Point.

e In-place-edit mode on event list

On event list in H/'W Break, Time measurement and Trace Point, High-performance Embedded Workshop will not
escape from in-place-edit mode even when you press the [ESC] key.

1.9.3 Data Trace

e  Split-bar behavior when double-clicking

If you double-click the split-bar, which divides view up and down, the horizontal scroll-bar, vertical scroll-bar, and
tabs in the upper view will vanish. Drag the split-bar to display them again.

1.94 Trace

e  Specifying function in SRC mode

In the SRC mode, when you specify a function to display it, if the current displayed source file includes the function,
the top of the source file will be displayed.

e  Saving of tracing result in text

When you save a tracing result in text with only “BUS” and “DATA” buttons ON, the vertical position of some
headers will shifts from the corresponding data. Check “Tab Separated Format” and open it with spreadsheet
applications to display them correctly.

e  Saving of tracing result in text

When you save a tracing result that includes BUS and DATA access information in text, some headers can not be
correct. When you check “Tab Separated Format”, the headers will be correct.

e Time concerned data

Displayed time concerned data is not measured, though time concerned buttons and items in pop-up menu are
active.(Time measurement is not supported.)

1.9.5 RAM Monitor

e  Proportional Fonts

When a proportional font is selected, a part of the characters in the view may be hidden. Fixed fonts are
recommended.

1.9.6 Memory

e 8 bytes data operations
To set, fill, and copy 8 bytes data are not supported.
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1.9.7 Seript

e Result of interactive command

When you invoke an interactive command, for example, Assemble and setMemoryByte, the running dialog box will
appear and may hide the view of the results.

e SCOPE Command

When you refer current scope name with SCOPE command after program execution, the scope of the start-up
module will be returned even if scope has been changed to the other.

1.9.8 M32C Emulator Debugger (Common)
1.9.8.1 About using cast operators for the member variable

When you use cast operators for the member variable to refer to it as the pointer of the structure, you would not refer
to it correctly.

1.9.8.2 About the download module dialog box

This debugger does not support the setting of "Offset", "Memory verify on download", and "Access Size" in the
download module setting dialog box. These are always treated as "Offset: 0", "Memory verify: off", and "Access
Size: 1".

1.9.9 M32C Emulator Debugger (for Compact Emulator)

1.9.9.1 Connection to the compact emulator

After setting of MCU by MCU Setting dialog, it takes 10-30 seconds to start up debugger. After setting of MCU,
please wait for the moment.

1.12 Note on Windows and Dialog Boxes

1.12.1 Scrolling

Up-scrolling may not be available with an intelligent mouse.
In this case, use a scrolling button on the window.

1.12.2 Saving the location of windows

The location of windows displayed may be changed by saving or loading of a session or switching of the virtual
desktop.

1.13 Note on Help

When the help is used in Windows® English version, the following message box may be displayed:

Click the [Download] button to download ‘Japanese Text Display Support’, or check the [Never download any of
these components.] check box and click the [Cancel] button.

Even if ‘Japanese Text Display Support’ is not downloaded, the help is normally displayed.
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; Internet Explorer Inztall on Demand EHE |

To dizplay language characters comectly you need to
download and install the following components:

Japanese Test Display Support

Dowrload Size: 2.7 MB Dawnload Time: 23 min

r Mever download any of theze compaonents.

Download Cancel

Figure 1.4: Internet Explorer Install on Demand message box

1.14 Note on Commands

1.14.1 MEMORY_EDIT command

Even if characters are enclosed with quotation marks ('), the ASCII character strings cannot be input as data.
When the character strings are input as data, enter the corresponding numerical values.

1.14.2 Command batch file load timing (Debug Settings Dialog Box)

(1) When the [INITIALIZE] command is specified in the command file that [At target connection] has been
selected for [Command batch file load timing] on the [Options] tab, do not execute the [INITIALIZE] command
in the [Command Line] window.

For initialization, select [Debug->Initialize].

(2) Do not specify the following commands in the command file that [At target connection] has been selected for
[Command batch file load timing] on the [Options] tab.

(a) [OPEN_WORKSPACE] command
(b) [CHANGE_ PROJECT] command
(¢) [CHANGE CONFIGURATION] command

(3) Do not specify the following commands in the command file that [Before download of modules] or [After
download of modules] has been selected for [Command batch file load timing] on the [Options] tab.

(a) [OPEN_WORKSPACE] command

(b) [CHANGE PROJECT] command

(¢) [CHANGE CONFIGURATION] command
(d) [GO] command

(e) [GO_RESET] command

(f) [GO_TILL] command

(g) [STEP] command

(h) [STEP_OUT] command

(i) [STEP_OVER] command
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1.14.3 Command line batch processing (Debug Settings Dialog Box)
[File directory] cannot be used in the placeholder of [Command Line Batch Processing] on the [Options] tab. If a

command file is specified with the relative path format, the file may not be correctly accessed.
Specify the absolute path format to the command file that cannot apply a placeholder.

1.14.4 File Specification of Command Line
To specify a file in the command line, use a placeholder (excluding TCL). If you wish to specify a directory not
included in the placeholder, specify an absolute path. After specifying the absolute path, this file will not be
correctly found when it is in another host computer or environment where the path content is different. In such cases,
specify the file again.

Example: FILE LOAD ELF/DWARF2 $ (CONFIGDIR) \\demo.abs
1.14.5 CACHE Command

Do not specify the CACHE command unless it is defined in the user’s manual of the emulator or debugger. The unit
of an access to the cache memory is a fixed value such as Ox3FF. Thus the range of the cache memory being
accessed may be larger than the access range specified by the user.

1.14.6 Abbreviation of a Command
e REMOVE FILE

In High-performance Embedded Workshop 3.01 or later version, the abbreviation has been changed from “RF” to
“REM”_

1.15 Note on the Tcl/Tk Command Input

(1) Canceling the interactive mode

To return from the interactive mode to the command input mode while using the [TCL Toolkit], enter */.”. It is
possible to know the current mode by entering “/.”.

1.16 Notes on Commands in [TCL Toolkit] and [Command Line]

(1) “trace” command

(a) To execute the “trace” command for Tcl in [TCL Toolkit], the command name must be specified in
lowercase letters.

(b) To execute the “TRACE” command for High-performance Embedded Workshop in [TCL Toolkit], the
command name must be specified in uppercase letters.

(c) To execute the “trace” command for Tcl in the [Command Line] window, the command name must be
replaced with “tcl_trace”.

(2) “clock” command

(a) To execute the “clock” command for Tcl in [TCL Toolkit], the command name must be specified in
lowercase letters.

(b) To execute the “CLOCK” command for the emulator in [TCL Toolkit], the command name must be specified
in uppercase letters.
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(c) To execute the “clock” command for Tcl in the [Command Line] window, the command name must be
replaced with “tcl_clock”.

(3) “event” command

(a) To execute the “event” command for Tk in [TCL Toolkit], the command name must be specified in
lowercase letters.

(b) To execute the “EVENT” command for the emulator in [TCL Toolkit], the command name must be specified
in uppercase letters.

Note that some emulators do not support commands “CLOCK” and “EVENT”.
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Section 2 System Requirements

2.1 M32C Compact Emulator Debugger

Target host PC
PC IBM PC/AT compatible with Pentium III 600MHz or higher
Windows XP
0s Windows 2000
Windows Me
Windows 98 Second Edition
Memory 128MB (ten times the size of the target load module file recommended)

Hard disk available capacity for installation: 100MB or more.
HDD Prepare an area at least double the memory capacity (four-times or more
recommended) as the swap area.

Display Resolution 1024 x 768 or higher recommended
Compact Emulator MCU file
M30850T-CPE M30850.MCU

M30870.MCU

M30870T-CPE
M30870 AD.MCU
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