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Notice

All information included in this document is current as of the date this document is issued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful attention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. You are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any losses incurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. You should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the development of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errors in or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific”. The recommended applications for each Renesas Electronics product depends on the product’s quality grade, as
indicated below. You must check the quality grade of each Renesas Electronics product before using it in a particular
application. You may not use any Renesas Electronics product for any application categorized as “Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not be in any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as “Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home electronic appliances; machine tools; personal electronic equipment; and industrial robots.

“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.

“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or healthcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life.

You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,

especially with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.

Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physical injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as a result of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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The export of these products from Japan is regulated by the Japanese government. The export of some or all of these
products may be prohibited without governmental license. To export or re-export some or all of these products from a
country other than Japan may also be prohibited without a license from that country. Please call an NEC sales
representative.

e The information in this document is current as of October, 2002. The information is subject to
change without notice. For actual design-in, refer to the latest publications of NEC's data sheets or
data books, etc., for the most up-to-date specifications of NEC semiconductor products. Not all
products and/or types are available in every country. Please check with an NEC sales representative
for availability and additional information.

* No part of this document may be copied or reproduced in any form or by any means without prior
written consent of NEC. NEC assumes no responsibility for any errors that may appear in this document.

* NEC does not assume any liability for infringement of patents, copyrights or other intellectual property rights of
third parties by or arising from the use of NEC semiconductor products listed in this document or any other
liability arising from the use of such products. No license, express, implied or otherwise, is granted under any
patents, copyrights or other intellectual property rights of NEC or others.

* Descriptions of circuits, software and other related information in this document are provided for illustrative
purposes in semiconductor product operation and application examples. The incorporation of these
circuits, software and information in the design of customer's equipment shall be done under the full
responsibility of customer. NEC assumes no responsibility for any losses incurred by customers or third
parties arising from the use of these circuits, software and information.

* While NEC endeavours to enhance the quality, reliability and safety of NEC semiconductor products, customers
agree and acknowledge that the possibility of defects thereof cannot be eliminated entirely. To minimize
risks of damage to property or injury (including death) to persons arising from defects in NEC
semiconductor products, customers must incorporate sufficient safety measures in their design, such as
redundancy, fire-containment, and anti-failure features.

®* NEC semiconductor products are classified into the following three quality grades:

"Standard", "Special" and "Specific". The "Specific" quality grade applies only to semiconductor products

developed based on a customer-designated "quality assurance program" for a specific application. The

recommended applications of a semiconductor product depend on its quality grade, as indicated below.

Customers must check the quality grade of each semiconductor product before using it in a particular

application.

"Standard": Computers, office equipment, communications equipment, test and measurement equipment, audio
and visual equipment, home electronic appliances, machine tools, personal electronic equipment
and industrial robots

"Special": Transportation equipment (automobiles, trains, ships, etc.), traffic control systems, anti-disaster
systems, anti-crime systems, safety equipment and medical equipment (not specifically designed
for life support)

"Specific": Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control systems, life
support systems and medical equipment for life support, etc.

The quality grade of NEC semiconductor products is "Standard" unless otherwise expressly specified in NEC's

data sheets or data books, etc. If customers wish to use NEC semiconductor products in applications not

intended by NEC, they must contact an NEC sales representative in advance to determine NEC's willingness
to support a given application.

(Note)

(1) "NEC" as used in this statement means NEC Corporation and also includes its majority-owned subsidiaries.

(2) "NEC semiconductor products" means any semiconductor product developed or manufactured by or for

NEC (as defined above).
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Regional Information

Some information contained in this document may vary from country to country. Before using any NEC
product in your application, please contact the NEC office in your country to obtain a list of authorized

representatives and distributors. They will verify:
 Device availability

« Ordering information

 Product release schedule

« Availability of related technical literature

« Development environment specifications (for example, specifications for third-party tools and
components, host computers, power plugs, AC supply voltages, and so forth)

« Network requirements

In addition, trademarks, registered trademarks, export restrictions, and other legal issues may also vary

from country to country.

NEC Electronics Inc. (U.S.) * Filiale Italiana
Santa Clara, California Milano, Italy
Tel: 408-588-6000 Tel: 02-66 75 41
800-366-9782 Fax: 02-66 75 42 99
Fax: 408-588-6130
800-729-9288 e Branch The Netherlands
Eindhoven, The Netherlands
NEC do Brasil S.A. Tel: 040-244 58 45
Electron Devices Division Fax: 040-244 45 80
Guarulhos-SP, Brasil
Tel: 11-6462-6810
Fax: 11-6462-6829

e Branch Sweden
Taeby, Sweden
Tel: 08-63 80 820

NEC Electronics (Europe) GmbH Fax: 08-63 80 388

Duesseldorf, Germany
Tel: 0211-65 03 01
Fax: 0211-65 03 327

» United Kingdom Branch
Milton Keynes, UK
Tel: 01908-691-133

« Sucursal en Espafia Fax: 01908-670-290

Madrid, Spain
Tel: 091-504 27 87
Fax: 091-504 28 60

* Succursale Francaise
Vélizy-Villacoublay, France
Tel: 01-30-67 58 00
Fax: 01-30-67 58 99
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NEC Electronics Hong Kong Ltd.
Hong Kong

Tel: 2886-9318

Fax: 2886-9022/9044

NEC Electronics Hong Kong Ltd.
Seoul Branch

Seoul, Korea

Tel: 02-528-0303

Fax: 02-528-4411

NEC Electronics Shanghai, Ltd.
Shanghai, P.R. China

Tel: 021-6841-1138

Fax: 021-6841-1137

NEC Electronics Taiwan Ltd.
Taipei, Taiwan

Tel: 02-2719-2377

Fax: 02-2719-5951

NEC Electronics Singapore Pte. Ltd.
Novena Square, Singapore

Tel: 253-8311

Fax: 250-3583
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Target Readers

Purpose

Organization

How to Use This Manual

Conventions

PREFACE

This manual is intended for user engineers who design and develop application systems
of the V850 Series.

This manual is intended for users to understand the functions of the ID850 in the
organization below.

This manual consists of the following chapters:

e OVERVIEW

¢ INSTALLATION

o STARTING AND TERMINATING
¢ ASSOCIATION WITH PM plus

e FUNCTIONS OF ID850

e OPERATION

e WINDOW REFERENCE

e COMMAND REFERENCE

It is assumed that the readers of this manual have general knowledge of electrical
engineering, logic circuits, microcontrollers, C language, and assemblers.

To understand the functions of the V850 Series
— Refer to Hardware User's Manual for each product..

To understand the instruction functions of the V850 Series
— Refer to V850 Series Architecture User’s Manual or V850E/MS1TWI Architecture
User’s Manual.

Data significance: Higher digits on the left and lower digits on the right
Note: Footnote for item marked with Note in the text
Caution: Information requiring particular attention

Remark: Supplementary information

Numerical representation: Binary ... XXXX or XXXXB

Decimal ... XXXX
Hexadecimal ... OXXXXX
Prefix indicating the power of 2 (address space, memory capacity):
K (Kilo): 2" =1024
M (Mega): 2%° = 1024?
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Related Documents Refer to the documents listed below when using this manual.
The related documents indicated in this publication may include preliminary versions.
However, preliminary versions are not marked as such.

Documents related to development tools (User's Manuals)

Document Name Document No.
IE-703002-MC (In-circuit emulator for V853™, Vv850/SA1™, v850/SB1™, v850/SB2™, v850/SC1™, | U11595E
v850/SC2™, v850/sCc3™, ves0/SF1™, ves0/sv1™)
IE-V850E-MC (In-circuit emulator for V850E/IA1™, V850E/IA2™), U14487E
IE-V850E-MC-A (In-circuit emulator for V850E/MA1™, V850E/MA2™)
IE-703003-MC-EM1 (In-circuit emulator option board for V853) U11596E
IE-703017-MC-EM1 (In-circuit emulator option board for V850/SA1) U12898E
IE-703037-MC-EM1 (In-circuit emulator option board for V850/SB1, V850/SB2) U14151E
IE-703040-MC-EM1 (In-circuit emulator option board for V850/SV1) U14337E
IE-703079-MC-EM1 (In-circuit emulator option board for V850/SF1) U15447E
IE-703102-MC (In-circuit emulator for V850E/MS1, V850E/MS2™) U13875E
IE-703102-MC-EM1, IE-703102-MC-EM1-A (In-circuit emulator option board for V850E/MS1, V850E/MS2) | U13876E
IE-703107-MC-EM1 (In-circuit emulator option board for V850E/MA1) U14481E
IE-703116-MC-EM1 (In-circuit emulator option board for V850E/IA1) U14700E
CA850 Ver. 2.50 C Compiler Package Operation U16053E
C Language U16054E
PM plus U16055E
Assembly Language U16042E
ID850 Ver. 2.50 Integrated Debugger Operation This manual
SM850 Ver. 2.50 System Simulator Operation U16218E
SM850 Ver. 2.00 or Later System Simulator External Part User Open Interface | U14873E
Specifications
RX850 Ver. 3.13 or Later Real-Time OS Basics U13430E
Installation U13410E
Technical U13431E
RX850 Pro Ver. 3.13 Real-Time OS Fundamental U13773E
Installation U13774E
Technical U13772E
RD850 Ver. 3.01 Task Debugger U13737E
RD850 Pro Ver. 3.01 Task Debugger U13916E
AZ850 Ver. 3.10 System Performance Analyzer U14410E
PG-FP3 Flash Memory Programmer U13502E
PG-FP4 Flash Memory Programmer U15260E
TW Ver. 1.00 Performance Analysis Tuning Tool U16104E
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1.2

CHAPTER 1 OVERVIEW

Overview

The Integrated debugger ID850 for the V850 Series (hereafter referred to as the ID850) is a software tool
developed for NEC's V850 Series of 32-bit microcontrollers for embedded control. This software tool is
intended to enable efficient debugging of user programs.

The ID850 runs on a host machine that uses Windows as the operating system and employs an easy-to-
understand, easy-to-use GUI (Graphical User Interface).

The commands that are often used are displayed as buttons, so that they can be executed with a single

mouse click. In this way, an environment with excellent operability can be provided.

Features

The ID850 has the following features.

(1) Source debugging

A C source program and source program in assembly language can be debugged.

(2) Using functions of in-circuit emulator
By using the detailed event setting function of an in-circuit emulator, break events can be set and the

user program can be traced.

(3) Monitor function (automatic display updating function when execution is stopped)
If execution of the user program is stopped, the values of the window displayed on the screen are

automatically updated.

(4) sSaving/restoring debugging environment
The debugging environment including information on setting of breakpoints and events, downloading
files, and display status and position of windows can be saved to a file (project file).

By loading this project file, the debugging environment can be restored.

(5) Function expansion by TIP or ToolLink
By associating with a task debugger (RD) and system performance analyzer (AZ) supporting TIP (Tool
Interface Protocol) or ToolLink, the debugging efficiency of the user program using a real-time OS (RX)

can be dramatically improved.
(6) Batch execution by command and creation of custom window

A console window that allows batch processing on the command line and creation of the user's own

custom window has been added.
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1.3 System Configuration

The supplies a comfortable debugging environment for the user program and target system developed for

the V850 Series, by connecting the host machine and an in-circuit emulator with an interface board.

1.3.1 Example of system configuration

Figure 1-1 shows an example of the system configuration of the ID850.

Figure 1-1 Example of ID850 System Configuration

) Interface board
Host machine

Target system

1.4  Operating Environment

The ID850 has the following hardware and software requirements:

1.4.1 Hardware environment

(1) Host machine (any of the following)

« IBM PC/AT ™ _compatible machine

(2) In-circuit emulator (any of the following)
* |E-703002-MC
* |IE-703102-MC
¢ |[E-VB50E-MC, or IE-V850E-MC-A
¢ |IE-V850ES-G1

(3) Interface board (any of the following)
* |[E-70000-PCI-IF-A (for PCI bus)
« |[E-70000-CD-IF-A (for PCMCIA card slot)
« IE-70000-PC-IF-C (for ISA bus)
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1.4.2 Software environment

(1) Operating system (any of the following)
Windows98, Windows2000, Windows NT4.0 (Service Pack5 or above), Windows Me, Windows XP

Home Edition, Windows XP Professional

Caution Regardless of which of the OSs above is used, we recommend that the latest Service Pack is

installed.

(2) Device file

The device file of the target device to be used.

(3) Device driver

Device driver for interface board (supplied with the product)

Remark The driver can also be downloaded from the Online Delivery Service (ODS).

1.5 Notes on Source-Level Debugging

To perform source-level debugging, add an option (-g option) to generate debug information when the
source file is compiled.

If this option is not added, the source file cannot be debugged at the source level.
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CHAPTER 2 INSTALLATION

This chapter explains the procedure of installing and uninstalling ID850.

2.1 Installing ID850

To use the 1D850, the ID850, a device file and a device driver are necessary. Install the device file with
the dedicated installer "DFINST.exe" (supplied with the ID850 ), and the device driver in accordance with

Readme.txt in the FD"NEC IE-PC Driver Installation Disk".

Caution To install the ID850 again after the ID850 has been installed once, be sure to uninstall the
ID850. If the ID850 is installed in a directory different from that in which the ID850 has been
already installed, without uninstalling the 1D850, the ID850 that has already been installed

cannot be uninstalled.

To install the ID850, prepare the following:

« |D850 system disk

An example of installing the ID850 is shown below.

In this example, the settings are as follows:

Install directory C:\NECTools32
CD-ROM drive Drive Q
Directory to which Windows is installed C:\WINDOWS

2.1.1 Installing procedure

1 Start Windows.
2 Insert the ID850 system disk to the CD-ROM drive.

3 Start Explorer and double-click "Setup.exe" in the drive Q.
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4 After setup initialization, the setup program is started. Click the <Next>> button.

wWelcome to the ID3B0 Setup program. Thig program
will inztall 10850 on your computker.

It iz strongly recommended that you exit all Windows programs
befare mnning thiz Setup program.

Click Cancel to quit Setup and then cloze any programs you
have mnming.  Chck Mest to continue with the Setup program.

WARMIMG: Thiz program is protected by copyright law and
international treaties.

Unauthorized reproduction or distribution of this program, or any
portion of it, may result in zevere civil and criminal penalties, and
violators will be prosecuted to the masimum extent possible under
la.

Cahcel |

5 At this time, your agreement with the Software License Agreement is necessary.

Click the <Yes> button. To stop installation, click the <No> button.

Software License Agreement m

Fleaze read the fallowing license agreement. Scroll down to zee the rest of the
agreement,

[JSER LICENSE AGREEMENT FOR MEC SOFT'WARE -~
IMPORTANT-READ CAREFLILLY:

Thiz zer Licenze Agreement ["ULA"] i a legal agreement between you
[either a natural person or an entity] and MEC Corporation far the
SOFTWARE PRODUCT. Az uzed herein, "SOFTWARE PRODUCT"
means the MEC software product provided with this ULS, which includes
computer zoftware and may include azsociated media, printed materials,
and "onling'' filez or data. By installing, copying, or otherwize uzing the
SOFTWARE PRODUCT, wou agree to be bound by the terms of this
UL, If you do not agree to the terms of thiz ULA, do not install or use
the SOFTWWARE PRODIUCT.

=l

Do you accept all the terms of the preceding License Agreement? T o ingtall this product, you
muzt click Yes to accept. If you chooze Mo, Setup will exit,

< Back Ve Ma |
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6 Input the product ID. The product ID of the SP product may be input. Click the <Next>> button.

Product ID B

Enter Product 1D.

Product 1D iz witten in CD' package or accompanying
docunment.

Product 1D: I

< Back I Meut > I Cancel

7 Select items to be installed, and the drive and directory in which the ID850 is to be installed. The
default drive and directory is "C:\NECTools32".
To change the drive and directory, click the <Browse...> button. After each item has been set, click
the <Next>> button. To stop installation, click the <No> button.

Caution If the ID850 previously installed is not uninstalled, a confirmation dialog box inquiring if the

ID850 is uninstalled is displayed.

Select Components n

Select the components you want to install, clear the components
you do not want ta install,

LComponents

5
10850 W ww Documents st

r Destination Directany

CAMECT ools32 Browse. . |
Space Required: 40722 K DS
Space Availlable: 2096832 K —lIS 2pAce.

< Back I Mext » I Cancel |
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8 Specify the name of the folder to which the icon of the ID850 is to be registered. Specify a group
name, and click the <Next>> button. To stop installation, click the <Cancel> button. The default
folder is "NEC Tools32".

Select Program Folder n

Setup will add program icons to the Program Folder listed below.
rou may type a new folder name, or zelect one fram the existing
Folders list. Chck Mest to continue,

Program Faolders:

Existing Folders:

Accerzones
Java 2 Buntime Errvironrment

Orline Services
StartUp

< Back I Mext » I Cancel

9 Final check for starting installation
Confirm the set contents. If you don't need to change the setting, click the <Next>> button. To
change the setting, click the <Back> button and change the setting. If there are any problems, stop
installation by clicking the <Cancel> button.

Start Copying Files m

Setup haz enough infarmation ta start copying the program files.
If you want to review or change any zettings, chck Back. 1f you
are zatisfied with the settings, click Mest to begin copying files.

Current Settings:

Product to install; d
10850 %350 Integrated Debugger W s
D850 Y s Documents

Target Directomy
C:AMECToole32

Prograrm Folder
MEC Tools32

[

< Back

_>I_I
Cancel |

10 Copy the files to the specified directory.
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11 Completing installation
When the installation has been completed, a dialog box indicating that setup has been completed
is opened. Click the <Finish> button.

Setup Complete

Setup complete.

Click Finizh to complete Setup.

<Back |7 Finish

12 When the system disk has been copied, the icon of the ID850 is registered to the "NEC Tools32"
group. This completes the installation of the ID850.

& NEC Tools32 !EII!I
File Edit Yiew Go Favontes Help |
I ‘ 4 i 7
Back Forward Up Cut Copy Paste
Agdress [ C-\WINDOWS\Start Menu\Programs\NEC Tools32 ~]

® I B

| CAS50 Help comcti32.dll DeviceFile
4 72 insta... Installer

| Tools32 _\ =

DF703107 hhctil.ocx 1D850 Help 1D850
ReadMe 1.32in...

# M OH @

PM plus PM pluz TclLicense Tcl8.1 Help
Help

@

b

Wish

Select an itern to
wiew its description,

|2.16KB | [B] My Camputer A
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2.2 Uninstalling ID850

This section explains how to uninstall the ID850 .

2.2.1 Uninstalling procedure

1 Start Windows.
2 Start [Add and Delete Application] from the Control Panel.

3 [NEC ID850 V850 Integrated Debugger Vx.xx] from the list displayed at [Setup and Delete], and
click the < Add/Remove...> button.

Add{Remove Programs Properties HE

Install{Uninstall |Wind0ws Setupl Startup Diskl

@ To install & new program from a floppy disk or CD-ROM
g

drive, click Install.
Ingtall...

The following software can be automatically remowved by
Windows. To remowve a program or to modify its installed
components, select it frarm the list and click Add/Remove.

Adobe Acrobat 3.0 -
NEC CAS50 W8I0 C Compiler Wiixx
MEC Ervircnment of NEC Tools Customise

NEC Project Manager Yoo
MEC MB350 W30 Simulator Yoo

=
Add/Bemove.. |
[0]4 | Cancel | Apphe |

4 The Confirm File Deletion dialog box will be displayed. Click the <Yes> button.

Confirm File Deletion

@ Are you sure you want to completely remove the selected application and all of its components?

7 " |

5 While the files are being deleted, the following dialog box is displayed. Click <Yes> for all the files
that are inquired (even if <No> is selected, the newest files of the same name will overwrite the
existing files when the ID850 is installed again).
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Remove Shared File?

The zystem indicates that the following shared file iz no longer used by any
programs. |f any programs are still using this file and it is removed, those
programs may not function. Are you sure you want to remove the shared file?

Leaving thiz file will not harm your system. If pou are not sure what to do, it is
suggested that you choose to not remove this shared compaonent.

File: names:

Located in: |C:\NECTO0I332\BIN\ |

Yes Yes To &l No Na to Al |

6  The program will be deleted. When the message "Uninstalling is complete." is displayed, click the
<OK> button.

7  This completes the uninstallation of the ID850.
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This chapter explains the procedure of starting and terminating the ID850.

3.1 Starting

Start the ID850 as follows:

1 Turn on the power to the in-circuit emulator, and then turn on the power to the target system.

2  Start Windows on the PC.

3 Select [Start] -> [Program] -> [NEC Tools32] -> [ID850] from the Windows start menu to start the
ID850. The Configuration dialog box will be opened.

4  Set the items related to the operating environment of the ID850 in the Configuration dialog box.
After setting each item, click the <OK> button in the dialog box.

Figure 3-1 Configuration Dialog Box

Contfiguration
~Chip Clock of
Mame: uPD Im vl & Internal I_
Cancel
~Internal ROMRAM ———————— | {7 Targat
Be=t
Intermal ROM:  |32% - | KByte |33_335 vl Deshre
Praoject...

Internal R |1|324* v| Bvte (MHz) _—
Help |

—Programmable /0 Ares

[ Start Sddrass: I

r Emulation Memory Mask

O Wit Mazk [T mml [T RESET [ welT [T HLDRG
%) 1 Wiait Access [T sTOP

) Targat Wait [T MODE 01,2 | Ll
~Memory Mapping

Access Size: & 8Bt O 16Bit O 326t 2dd
Memary MAttribuote: Mapping Lddress: Q;Iete I

Emulstion oM v | | -

5 The Main window will be opened and the ID850 can be operated. Mainly use this window for

debugging.
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Figure 3-2 Main Window

Fi

e Edt View Option ERun Ewent Browse Jump Window Help

[---#--- |[--- |[ooooooo0 || [[BRE&K  |[Manual Break [[aute [ins

R

3.2 Terminating

Terminate the ID850 as follows:

1 Select the [File] menu -> [Exit] on the Main window. The following Exit Debugger dialog box will be
opened:

Figure 3-3 Exit Debugger Dialog Box

D850

Thiz will end wour Debugeger session, _ _
Do wouw want to zave the zettings in the project file 7

Mo | Cancel |

If the above operation is performed while the user program is being executed, the dialog box shown in
Figure 3-4 is opened.

In this case, clicking the <Yes> button opens the Exit Debugger dialog box.

Figure 3-4 Message Box for Confirmation of Stopping Execution

1D850

@ ifb00: Uzer proeram iz running. Do wou want to stop uzer program®

No |
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2 To save the current debugging environment to a project file, click the <Yes> button.
If the <No> button is clicked, all the windows are closed and the ID850 is terminated.
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CHAPTER 4 ASSOCIATION WITH PM plus

This chapter explains the procedure and points to be noted when a function to associate the PM plus is
used.

The ID850 can automatically perform a series of operations in development processes, such as creating
source files -> compiling -> debugging -> correcting source files, in association with the PM plus.

The operation explained in this chapter requires a PM plus(V5.00 or later).

Caution If a load module file is created by using the Windows command prompt, the function to

associate the 1D850 with the PM plus cannot be used.

4.1 Setting Build Mode

To debug the load module file created by the PM plus on the ID850 at the source level, build to output
symbol information for debugging must be performed to create a load module file. This setting can be

performed by selecting [Debug Build] on the PM plus.

4.2 Registering Debugger to PM plus Project

The debugger to be used or the load module files to be downloaded can be specified for each project in
the PM plus.

Select a debugger using the following procedure:

4.2.1 Selecting debugger

The procedure for selecting the debugger is as follows:

Creating a new workspace
1 Select [File] menu -> [New Workspace...] on the PM plus.

-> This opens the dialog box to create a new workspace using the wizard format.

2 Creating the necessary settings for the workspace with the wizard, the [New Workspace - Step 7/8
(Select Debugger)] dialog box will be opened. Specify [ID850 V850 Integrated Debugger] in this
dialog box.

-> For details of the setting, refer to the PM plus online help or user's manual.

Using an existing workspace

1 Select [Tool] menu -> [Debugger Settings...] on the PM plus.
-> The Debugger Settings dialog box will be opened.

2 Specify [ID850 V850 Integrated Debugger] and click the <OK> button in this dialog box.

The ID850 is registered as the debugger of the active project.
The ID850 icon is displayed on the toolbar of the PM plus.
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4.2.2

Downloading multiple load module files

The load module files of the same project group are downloaded to the debugger.
For details of the project group, refer to the PM plus online help or user's manual.

Download multiple load module files in the following steps.

1 Select [Tool] menu -> [Debugger Settings...] on the PM plus.
-> The Debugger Settings dialog box will be opened.

Figure 4-1 Debugger Settings Dialog Box (PM plus)

Debugeer Settings

Select Debugger

Debugeer:

File Name: | CANECTools324BINVD 85032 EXE

Debug Target

Debue Tareet File:

Ia.out ;I

[~ Execute svmbol reset after download

¥ Execute GPL rezet after download

Debug Options
™ | Dyl Bl the defe tate et filEs it the Sate praje et Ernn
Debue Target File List:

[ C:AMECT ools32Mzample b.out

Ok I Cancel Help

2 Specify [ID850 V850 Integrated Debugger] in this dialog box.

3 Specify the load module file to be downloaded first in the [Debug Target File] when the debugger is

started.

4  Check the [Download the debug target files in the same project group] check box, and select the
debug target files in the same group to be downloaded in the Debug Target File List.
->The selected file will be downloaded right after the file specified in [Debug Target File] when the
debugger is started. Note that when these files are downloaded, symbol reset and CPU reset are

not executed.

5 Click the <OK> button.

Remark Multiple load module files that are being downloaded can be checked in the Load Module List

dialog box dialog box of the ID850.
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4.3 To Start ID850 from PM plus

The ID850 can be started from the PM plus as follows:

« Click the ID850 starting button on the toolbar of the PM plus.
 Select the [Build] menu -> [Debug] on the PM plus.

« Select the [Build] menu -> [Build and Debug] on the PM plus.

¢ Select the [Build] menu -> [Rebuild and Debug] on the PM plus.

If the debugging environment of the ID850 is saved to a project file currently being used by the PM plus, it
will be started in the debugging environment saved in the project file.
If the debugging environment of the ID850 is not saved to a project file being used by the PM plus, the

Configuration dialog box is opened. At this time, the device type (Chip name) cannot be changed.

4.3.1 Restoring debugging environment
The previous debugging environment can be restored by the following procedure when the ID850 is
started from the PM plus:

1 Create a new workspace (project file : e.g., sample.prj) on the PM plus.

Caution In the ID850 and PM plus, the environment information is saved to a project file and
referenced. The extension of the project file that can be used by the ID850 and PM plus is prj.
For the information that is saved or restored by the project file, refer to the online help or the

user's manual of each product.

2 Start the ID850 from the PM plus. Because a new project file is created, set items other than the
device type (Chip name) in the Configuration dialog box in the same manner as when only the
ID850 is started.

3 Download the load module file to be debugged with the Download dialog box of the ID850.
4 Debug the load module file on the ID850.

5 Click the <Yes> button on the Exit Debugger dialog box when the ID850 is terminated.
-> The debugging environment will be saved to the project file (sample.prj) for the PM pluswhen the
ID850 is terminated (the debug environment can also be saved to the sample.prj file by overwriting
the project file at times other than the completion of ID850 debugging).

6 When the ID850 is next started up after the sample.prj file is read by PM plus, the debug
environment at the point when the project file was saved is automatically restored.

4,4 Auto Load

If a bug is found while the load module file is being debugged by the ID850, correct the source file using
the following procedure. Compiling and re-downloading the file can be automatically executed (Refer to
"Auto load by correcting source code").

The load module is downloaded again to the ID850 by compiling and linking the file on the PM plus with
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the activated ID850 (refer to "Auto load by starting debugger").

4.4.1 Auto load by correcting source code

Correct the source file for auto load as follows:

1  Open the source file to be corrected in the Source window. Select [File] menu -> [Open] and
specify the file to be corrected on the ID850 (if the file is already open in the Source window, that
window is displayed in the forefront).

-> The specified file will be opened in the Source window.

2 Select [Edit] menu -> [Correct Source] on the ID850.

-> An editor will be opened and the specified source file will be read.
3 Correct the source file on the editor.

4 Terminate the editor.

Caution The CPU reset is not performed when the load module file is automatically downloaded. The
debug window that was opened when the editor was called, and each event setting will be
restored. If the previously used line or symbol has been deleted as a result of correcting the
source file, the following happens:

- A software break point may be deleted.
- A variable that was displayed is dimmed.

- The event mark of an event condition is displayed in yellow.

5 Select [Build] menu -> [Build and Debug], or [Build] -> [Rebuild and Debug] on the PM plus.

4.4.2 Auto load by starting debugger

If the following operation is performed on the PM plus with the ID850 started, the load module will be

automatically downloaded to the ID850.

¢ Selecting the [Build] menu -> [Build and Debug] on the PM plus.
« Selecting the [Build] menu -> [Rebuild and Debug] on the PM plus.

The CPU reset is not performed after the load module has been downloaded.
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This chapter explains the basic debugging functions of the ID850.

« Mapping function

Setting Debugging Environment

« Program Execution Function

Event function

Break function
* Trace function

» Coverage Measurement Function

Snapshot Function

¢ Stub Function

Register Manipulation Function
« Memory Manipulation Function
* Watch Function

« Time Measurement Function

» Load/Save Function

« Real-Time RAM Sampling Function

5.1 Mapping function

The following types of mapping functions that can be set in the Configuration dialog box are available:

(1) Internal ROM
A memory area specified as the internal ROM is equivalent to the internal ROM of the target device.

If the target device writes data to this memory area, a write protect break occurs.

(2) Internal RAM
A memory area specified as the internal RAM is equivalent to the internal RAM of the target device.

The target device accesses the memory in the in-circuit emulator.
(3) User area mapping (Target)
A memory area specified as user area mapping is an area that accesses the memory on the target

system. The target device accesses the memory on the target system.

Caution  Addresses of memory areas other than the internal ROM, internal RAM, and peripheral 1/0

registers can be set.
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5.2
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(4) Emulation ROM

A memory area specified as the emulation ROM is equivalent to when ROM is connected to the target
device. The target device accesses the memory in the in-circuit emulator. If the target memory

accesses this area, a write protect break occurs.

Caution  Addresses of memory areas other than the internal ROM, internal RAM, and peripheral 1/0

registers can be set.

(5) Emulation RAM

A memory area specified as the emulation RAM is equivalent to when RAM is connected to the target
device. The target device accesses the memory in the in-circuit emulator. If the target memory

accesses this area, a write protect break occurs.

Caution  Addresses of memory areas other than the internal ROM, internal RAM, and peripheral 1/0

registers can be set.

(6) 1/O Protect area

An |/O Protect area can be set in the area specified for the target device. This area is displayed in the
same manner as an area that is not mapped (display symbol: ??), on the Memory window. By
mapping an area with this attribute, data cannot be read or written from/to this area by the Memory
window, on the area can therefore be protected from an illegal access.

To read or write the value of the area mapped with this attribute, register the value in the IOR window

or Watch window.

Setting Debugging Environment

Set a debugging environment with the Configuration dialog box that is opened when the debugger is
started, or the Extended Option dialog box or Debugger Option dialog box.

By creating a file (project file) to which the current debugging environment is saved during debugging,
and loading this file, the debugging environment when the project file is saved can be restored.

To manipulate the project file, use the Project File Save dialog box and Project File Load dialog box.

After the project file has been loaded, the size and position of the displayed window are returned to the
previous size and status (refer to "Table 7-8 Contents Saved to Project File").

To load the project file when starting up the debugger, press the <Project...> button in the Configuration
dialog box. It can also be specified that the project file is automatically loaded each time the debugger is

started up (refer to "To automatically load a project file").

Program Execution Function

The program execution function is used to start execution of the user program by the CPU and operation

of the tracer.

These functions can be executed by selecting the [Run] menu or the corresponding function button, and
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5.3.1

5.3.2
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the execution formats are classified into real-time execution and non-real-time execution.

Real-time execution function

The following real-time execution functions are available:

@)

)

@)

(4)

®)

* [Go] (Go button)

« [Ignore break points and Go] (GoN button)
 [Start From Here] (Start function)

« [Come Here] (Come function)

 [Restart] (ReGo button)

[Go] (Go button)

The user program is executed starting from the address indicated by the current PC register and is
stopped if a set break event condition is satisfied. Each analyzer prepares for operation as soon as
execution of the user program is started, and is executed or stopped by a condition set as an event

condition (break event condition or trace event condition).

[lgnore break points and Go] (GoN button)
This command executes the user program starting from the address indicated by the current PC

register. Execution of the user program continues, ignoring set breakpoints.

[Start From Here] (Start function)
This command executes the user program starting from the specified address. Execution of the user

program is stopped when a set break event condition is satisfied.

[Come Here] (Come function)

The user program is executed from the address indicated by the current PC register to the address
selected in the line/address display area of the Source window or the Assemble window, and then a
break occurs.

While the user program is being executed, the break event currently set does not occur.

[Restart] (ReGo button)
The CPU is reset and the user program is executed starting from address 0.
This is the same operation as "resetting the CPU before execution of the user program and executing

[Go]".

Non-real-time execution function

The following non-real-time execution functions are available:

 [Step In] (Step button)

« [Next Over] (Over button)
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@)

)

@)

« [Slow Motion]

[Step In] (Step button)

The operation differs depending on whether this function is executed in the Source window or the
Assemble window.

In the Source window

Step execution of one line of the source text is performed starting from the current PC register value
and the contents of each window are updated.

In the Assemble window

One instruction is executed from the current PC register value and the contents of each window are

updated.

[Next Over] (Over button)

The operation differs depending on whether the instruction to be executed is the jarl instruction or any
other instruction.

jarl instruction

Next step execution is performed, assuming the function or subroutine called by the jarl instruction as
one step (step execution continues until the nesting level becomes the same as when the jarl
instruction was executed).

Instruction other than jarl

The same processing as [Step In] is performed.

[Slow Motion]

Step execution of one line is performed from the address indicated by the current PC register value in
the source mode. In the instruction mode, step execution of one instruction is performed. The contents
of each window are updated each time step execution is performed. This operation is repeated until

the user executes [Stop].

Event function

An event is a specific status of the target system during user program execution, such as "address

0x1000 is fetched" or "data is written to address 0x2000".

The ID850 uses an event to trigger an action of functions such as break and trace functions. An event

function is used to set, delete, and reference a specific status of the target system that triggers an action

(debugging action) as an event condition.

Using event function

So that an action that is triggered by an event function in accordance with the user's debugging aim, the

following various event conditions must be set.
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Table 5-1 Various Event Conditions

Set Condition Setting Dialog Box Contents

Break event Break dialog box Condition in which the execution of the user program or
the operation of the tracer is stopped.

Trace event Trace dialog box Condition in which the process of user program
execution is saved to the trace memory.

Snapshot event | Snap Shot dialog box Condition in which the timing of executing a snapshot is
specified.

The following three snap data items can be registered:
- Register value

- Peripheral 1/O register value

- Memory contents

Stub event Stub dialog box Condition in which the timing of inserting the program is
specified when the stub function is used.

(To return from a specified function if a stub event
occurs, be sure to describe the JMP [r31] instruction in
the function.)

Timer event Timer dialog box Condition in which the timing of starting and stopping
time measurement is specified when zone
measurement is performed.

These various event conditions are set independently as an "Event condition” or "Event link condition", or
as a combination of these. To use the event function of the ID850, therefore, first create the necessary
"Event condition" and "Event link condition", and set the various event conditions shown in the Table 5-1 by

using these conditions.

5.4.2 Event condition

Create an event condition in the Event dialog box.

Set an address condition, status condition, and data condition in this dialog box. Specify a combination of
these as one event condition and name and register this event condition. The registered event condition
can be used to set various event conditions. However, the number of event conditions that can be set is
limited.

The event condition that is created when a breakpoint is set in the Source window or the Assemble

window can also be used (Breakpoint setting/deletion function).

5.4.3 Eventlink condition
An event link condition specifies sequential constraints for each event, so that two or more events are
treated as a single event.
To create an event link condition, use the Event Link dialog box.
By arranging already registered event conditions in this dialog box, one event link condition can be
named and registered. The registered event link condition can be used to set various event conditions in
the same manner as the event condition. However, the number of event conditions that can be set is

limited.
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5.4.4 Setting of various event conditions

5.5

Various event conditions listed in Table 5-1 are individually created in the corresponding dialog box.

To create various event condition, drag and drop the event icon of an event condition or event link

condition registered on the Event Manager to the condition area of each setting dialog box.

The created various event condition is set by clicking the <Set> or <OK> button in the setting dialog box.

The mark of the event that has been set is displayed in red. After the event has been set, a debugging

action occurs as various event condition.

Up to 256 various event conditions can be registered. The number of various event conditions that can

be

"set" differs depending on the various event condition (refer to "Table 7-31 Maximum Number of Valid

Events for Each Event Condition").

Break function

The break function is used to stop execution of the user program by the CPU and operation of the tracer.

The following types of break functions are available:

» Event detection break

« Break by Come function

 Software break

« Break on satisfaction of condition of step execution
» Forced break

+ Fail-safe break

Caution  The event detection break and software break are not performed when [Come Here], [Step

@)

)

In], [Return Out], or [Next Over] described in "Program Execution Function" is executed.

Event detection break
Event detection break is a function used to stop execution of the user program by detecting a set break
event condition. This break is valid for [Go], [Go & Go], [Start From Here], and [Restart].
In the case of [Go & Go], however, the contents of each window are updated and the user program is
executed again after the event detection break has occurred. Set a break event as follows:
» Set as an execution event in the Source window or Assemble window (Breakpoint setting/deletion
function).

» Set in the Break dialog box.

Break by Come function

The Break by Come function is used to stop the user program that is executed by the [Come Here]
command, by detecting an address specified in the Source window or Assemble window. When
execution of the user program has been stopped, the breakpoint by the Come function is eliminated.
While the user program is being executed by using this function, a break event that has been set does

not occur.
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(3) Software break
Software break is a function to replace the instruction at the specified address with a debugger-
dedicated software break instruction and stop the user program executed by the [Go], [Go & Go], [Start
From Here], or [Restart] command.
As many software break events as necessary can be set (however, only 100 of them are valid).
Because the instruction at the specified address is rewritten, however, a software break event cannot
be set on the external ROM or stopped by the access timing of a variable.
While one event detection break uses one hardware resource per event condition, the feature of a
software break is that a breakpoint is set at two or more addresses.
Set a software break event in the Source window or Assemble window (refer to "Breakpoint setting/
deletion function").

The Software Break Managermanages the software breaks (by validating or invalidating).

(4) Break on satisfaction of condition of step execution
Break on satisfaction of condition of step execution is a function used to stop execution of the user
program when the end condition of each command ([Step In], [Next Over], [Return Out], and
[Slowmotion]) is satisfied.
Because one instruction is executed, stopped, and the condition is confirmed at one time, the

processing time is longer than that of real-time execution.

(5) Forced break
Forced break is a function used to forcibly stop execution of the user program. It is valid for all the

program execution commands. Force break includes the following:

 [Stop] command: Forcibly stops execution of the user program.

(6) Fail-safe break
A fail-safe break is a function for forcibly stopping the user program when the user program has
executed a prohibited action on the memory and registers.

The types of fail-safe break functions are as follows:

Non-map break This break occurs if an attempt is made to access a non-map area.

Write-protect break This break occurs if an attempt is made to write to memory that must
not be written to, such as ROM.

Peripheral I/O register This break occurs if an attempt is made to access peripheral 1/0
lllegal access break registers illegally.

Note that if a fail-safe break occurs, there may be a problem with the user program or the set

environment of the ID850 may be wrong.

5.6 Trace function

The trace function is used to save the history of the data indicating the execution process of the user
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program to the trace memory. The trace data saved to the trace memory can be checked in the Trace
window.

The item to be displayed in the Trace window can be selected in the Trace Data Select dialog box.

To use the trace function, check that the trace function is valid by selecting the [Option] menu -> [Tracer
ON]. The trace function is valid in the default status, and all data is unconditionally traced (unconditional
trace) when the program is executed.

When the IE-V850E-MC or IE-V850E-MC-A is used, the result of a DMA trace can be collected, in

addition to the ordinary trace result (refer to "To execute DMA trace" ).

5.6.1 Operation of trace
The trace memory of the ID850 is a ring buffer with a capacity of 32,768 frames.
The operation of the tracer differs as indicated in (1) to (3) below, depending on the style of execution of

the user program.

(1) Operation during real-time execution

The operation of the tracer differs depending on the specified trace mode.

All trace Trace is started when real-time execution of the program is specified,
(Unconditional trace) and ends when a break occurs.
Conditional trace Trace is started or stopped by the condition set in the Trace dialog

box (if a break occurs while a trace is being executed, however, trace
is stopped immediately).

These trace modes can be set by selecting the [Run] menu -> [Conditional Trace /Unconditional

Trace].
(2) Operation during Step In execution
The tracer operates every step execution, and trace data of one step is successively added to the

trace memory.

(3) Operation during Next Over execution

The operation of the tracer differs depending on the instruction to which Next Over is to be executed.

Table 5-2 Operation of Tracer (During Next Over Execution)

Instruction Tracer Operation
jarl disp22, [Ip] instruction The jarl instruction and the subroutine that was called are traced.
Other instructions The same operation as that during Step In execution is performed.

5.6.2 Trace condition setting function

The following setting types of trace condition are available:
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(1) Setting trace mode

Two trace modes, unconditional trace and conditional trace, are available.

(2) Setting of tracer control mode

The tracer has a ring structure.

The following operation modes of the tracer can be selected from the [Run] menu:

Non-Stop Goes around the trace memory and overwrites data from the oldest frame
(default).

Eull Stop Goes around the trace memory and then stops the tracer.

Full Break Goes around the trace memory and then stops the tracer and program
execution.
* Only IE-703102-MC, IE-V850E-MC or IE-V850E-MC-A used

(3) Setting trace event condition

A trace event condition triggers starting/stopping trace execution when a conditional trace is set.

A trace event condition is set in the Trace dialog box.

The following types of trace event conditions can be specified:

Section trace

Executes a trace between two specified conditions (in a specific zone).
A section trace (zone trace) can be executed by setting a trace start event
and trace end event and executing a conditional trace.

Qualify trace

Executes a trace only when a condition is satisfied.

If two or more events are set as qualify trace events, a qualify trace can be
executed by executing a conditional trace.

A qualify trace can be executed by setting a qualify trace event and
executing a conditional trace.

Delay trigger trace

Executes a trace by the number of delay counts after a condition has been
satisfied.

A delay trigger trace can be executed by setting a delay trigger event
condition, setting a delay count in the Delay Count dialog box, and
executing a conditional trace.

Coverage Measurement Function

Coverage is a function used to record the status (such as execution, read, and write) for each address

when the user program is executed.

Coverage measurement can be performed by selecting the [Option] menu -> [Coverage ON], and the

status of each address is recorded in the coverage memory by executing the program.

The coverage results can be checked in the Coverage window. This window displays the results of

coverage executed in the 1 MB space specified in the Coverage-Address dialog box.

The efficiency of the coverage can be checked in the Coverage-Efficiency View dialog box that is opened

by clicking the <View> button on the Coverage-Condition Setting dialog box.
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Snapshot Function

Snapshot is a function used to save the contents of registers, memory, and peripheral I/O registers to the
trace memory as snap data while the user program is being executed.

A snap event condition specifies the trigger by which a snapshot is to be executed.

The snap event condition can be set in the Snap Shot dialog box.

The following snap data can be collected:

« Register value (program registers, system registers)
« Peripheral I/O register value

« Memory contents

One snap event condition can specify collection of up to 16 snap data.

Stub Function

The stub function is used to execute the user program (sub-program) that has been downloaded or
written by online assembly to a vacant memory area in advance when an event occurs.

A stub event condition is a trigger by which the stub function is to be executed. The snap event condition
can be set in the Stub dialog box.

Append the JMP [r31] instruction to the end of the sub-program that is executed when a stub event
occurs, otherwise, malfunction may occur.

Use the stub function in the "after" break mode. If it is used in the "before" break mode, only the sub-

program is repeated.

Figure 5-1 Flow of Stub Function

Main program

Sub-program

@)

(4)
©)

(6)

)

JMP [r31] instruction

If stub function is not used

(1) and (2) are executed.

If stub function is used
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1 (1) is executed.
2 Astub event occurs in (3) and a break occurs.

3 The in-circuit emulator sets the current address to the r31 register in (4), and rewrites the PC value
to the entry address of the sub-program.

4 (5)is executed.

5 Execution is returned to the main program by the JMP instruction at the end of the sub-program in

(6).

Register Manipulation Function

The register manipulation function is used to display or change the contents of the program registers,
system registers, and peripheral I/O registers.

This function can be used in the Register window or IOR window. To change the register to be displayed
in each window, use the Register Select dialog box or IOR Select dialog box.

A user-defined I/O port can be displayed or changed by registering it to the Add 1/O Port dialog box. In a
device supporting programmable IOR, programmable IOR can be displayed or changed by using the

Configuration dialog box.

Memory Manipulation Function

As a memory manipulation function, the memory contents can be displayed or changed by using
mnemonic codes, hexadecimal codes, and ASCII codes.
This function can be used in the Memory window or Assemble window. The contents of memory can be

copied, initialized, and compared.

Watch Function

Data (variable) values can be checked or changed in the Watch window.
Local variables can be checked or changed in the Local Variable window.
The contents of a variable value can be easily referenced in the Source window or Assemble window by

placing the mouse cursor on the selected variable (balloon watch function).

Time Measurement Function

The time measurement function is used to measure the full execution time from the start of execution of
the user program to the occurrence of a break, or the execution time of the user program in a specific zone
by using a timer event.

A timer event condition specifies the trigger by which time measurement is started or stopped. Set a
timer event condition in the Timer dialog box. The time from the start of execution of the user program to
the occurrence of a break can be easily measured by using the Run-Break event registered in advance.

To use the timer function, select the [Option] menu -> [Timer On] to set the timer to ON. If the timer is set

to OFF, the timer does not operate. However, the Run-Break event is not affected regardless of whether the
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timer is set to ON or OFF.

To stop the timer currently in operation during emulation, select the [Run] menu -> [Timer Stop]. To
operate the timer when it is stopped, select the [Run] menu -> [Timer Start]. These two menus are toggled
and alternately displayed depending on the current timer status.

The maximum execution measurement time is about 2 minutes 51 seconds (at 25 MHz).

5.14 Load/Save Function

The load/save function is used to load/save each file.
The ID850 loads/saves each file individually.

These three types of files can be handled:

view files File recording the screen information when it is saved. By loading this file, a
reference file is opened in the Source window.

Information file File recording the set data and debugging environment as information on the
user program and debugger.

Setting files File recording the window information.

5.14.1 View files
The list of the view files to be handled is shown below:

These files can be manipulated in the View File Load dialog box and View File Save dialog box.

Table 5-3 List of View Files

File Type Contents

Source Text (*.SVW) Source window view file
Records the source text in the Source window.

Assemble (*.DIS) Assemble window view file
Records the assembly information in the Assemble window.

Memory (*.MEM) Memory window view file
Records the memory information in the Memory window.

Register (*.RGW) Register window view file
Records the register information in the Register window.

Local Variable (*.LOC) | Local Variable window view file
Records the local variable information in the Local Variable window.

Stack Trace (*.STK) Stack Trace window view file
Records the stack trace information in the Stack Trace window.

Trace (* TVW) Trace window view file
Records the trace information in the Trace window.

Coverage (*.COV) Coverage window view file
Records the coverage information in the Coverage window.

Console (*.LOG) Console window view file
Records the information in the Console window.
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5.14.2 Information files

The list of the information files to be handled is shown below.

Table 5-4 List of Information Files

File Name (Extension) Contents Dialog Box
Object file Stores the object codes of the user Download dialog box,
(*.HEX) program. Upload dialog box

Load module file Stores the object codes, symbols, and Download dialog box
(*.0uUT) source information of the user program.

Project File Stores the debugging environment Project File Load dialog box,
(*.PRJ) Project File Save dialog box
Binary file Records data in binary format. Download dialog box,
(*.BIN) Upload dialog box
Coverage result file Stores the coverage results. Download dialog box,
(*.CVB) Upload dialog box

A project file sets the display information, size, and display position of a window or dialog box, and
restores the debugging environment to the previous status (when the project file was saved) when it is

loaded.

5.14.3 Setting files

The list of the setting files to be handled is shown below:

These files can be manipulated in the View File Load dialog box and View File Save dialog box.

Table 5-5 List of Setting Files

File Name (Extension) Contents
Watch setting file Stores the watch setting contents of the Watch window.
(*.WCH)
Peripheral I/O register setting file Stores the peripheral 1/O register setting contents of the IOR
(*.OR) window.
Event setting file Stores the event setting contents of the Event Manager.
(*.EVN)

5.15 Real-Time RAM Sampling Function

The following two types of real-time RAM sampling functions are available

¢ Real-time internal RAM sampling function

¢ Real-time RAM sampling function

The real-time RAM sampling functions are used to read and display the memory contents, even during
user program execution, if a variable allocated to a range in which the memory contents can be read, or the

memory contents are displayed.
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While the memory range for the former depends on the in-circuit emulator (refer to "Table 7-7 Address
Range and Valid Size", no memory range limitation applies to the latter.
This function can be checked in the Watch window or Memory window.

Settings related to this function are performed in the Extended Option dialog box.
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This chapter explains the flow of basic debugging operations using the ID850 and the following functions:

« Flow of Debugging Operations
¢ Active Status and Static Status
« Jump Function

¢ Trace Result with Linking Window

6.1 Flow of Debugging Operations

(1) Setting debugging environment
Prepare for debugging.
-> Mapping function
-> Configuration dialog box
Download a load module file to be debugged.
-> Download dialog box
Checking the loaded file.
-> Load Module List dialog box

(2) Displaying source program
By downloading a load module file with debug information, the corresponding source file is
automatically displayed.

-> Source window

(3) Displaying disassemble result
The disassembled result of the downloaded user program is displayed.

-> Assemble window

(4) Setting breakpoint
Breakpoints can be set easily in the Source window, Assemble window, and Watch window.
-> Breakpoint setting/deletion function

-> To set a breakpoint for read/write access to a variable

(5) Setting event
Register event conditions and event link conditions.
-> Event dialog box, Event Link dialog box
Setting of various event conditions
Set a various event condition by using the Event Manager or an event icon in the event manager area
on each various event setting dialog box.

Each various event condition corresponds to the following various event setting dialog box.
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(6)
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(10)

(11)

(12)

(13)

(14)

Break event condition -> Break dialog box

Trace event condition -> Trace dialog box

Snap event condition -> Snap Shot dialog box

Stub event condition -> Stub dialog box

Timer event condition -> Timer dialog box

Checking setting status of various event conditions

-> Event dialog box or the event manager area in each various event setting dialog box
Checking setting status of software breakpoint

-> Software Break Manager

Executing user program
By executing the user program, the PC advances to the set breakpoint, break event, or forced
breakpoint (refer to "Program Execution Function™).

Use the execution control button or [Run] menu to execute the user program.

Checking trace data

-> Trace window

Editing, checking, and changing memory contents
-> Memory window, Memory Copy dialog box, Memory Fill dialog box, Memory Compare dialog box,

Memory Compare Result dialog box

Registering, checking, and changing variable value
-> Watch window, Quick Watch dialog box, Add Watch dialog box, Change Watch dialog box, Local

Variable window

Checking stack contents

-> Stack Trace window
Checking and changing of registered contents of register value
-> Register window, Register Select dialog box

The value of the PC register can also be checked in the Source window and Assemble window.

Checking and changing peripheral I/O register value

-> |OR window, IOR Select dialog box

Registering, checking, and changing user-defined 1/O port value

-> Add 1/O Port dialog box, IOR window

Changing mnemonic and executing online assembly

-> Assemble window, Source window
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(15) Checking execution time of user program

-> Timer dialog box, Timer Result dialog box, Trace window

(16) Checking coverage measurement result
-> Coverage window, Coverage-Clear dialog box, Coverage-Address dialog box, Coverage-Condition

Setting dialog box, Coverage-Efficiency View dialog box

(17) Searching character string in each window
By clicking the < Search...> button in the window in which searching is to be executed, the following
types of searching dialog boxes are opened:
Source Search dialog box, Assemble Search dialog box, Memory Search dialog box, Trace Search

dialog box, Coverage Search dialog box

(18) Manipulating view file

-> View File Save dialog box, View File Load dialog box

(19) Uploading memory contents and coverage result

-> Upload dialog box

(20) Saving debugging environment to project file

-> Project File Save dialog box

(21) Terminating 1D850
-> Exit Debugger dialog box

Active Status and Static Status

The Source window, Assemble window, Memory window, and Coverage window have the following two

window statuses:

Active status The display position and contents of the window in the active status are
automatically updated in association with the current PC value.

This window is also the jump destination of the jump function. If this window is
linked with the Trace window, the contents displayed in the active window are
updated in association with the Trace window. Only one window can be opened
in the active status.

Select this status by the [Window] menu.

Static status The display position of the window in the static status does not move in
association with the current PC value, but the displayed contents are updated.
The static window is not used as the jump destination of the jump function. In
addition, it is not linked with the Trace window.

If an active window is already open, the next window is opened in the static
status. Two or more static windows can be opened at the same time.

Select this status by the [Window] menu.

Because two or more static windows can be opened, the current status of the windows can be
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temporarily held.

Jump Function

The jump function is used to jump to Source window, Assemble window, Memory window, or Coverage
window from a jump pointer that is the line or address on which the cursor is placed, and display the
contents of the jump destination window from the jump pointer.

You can jump among the above windows, or from Trace window, Stack Trace window, Event Manager,

and Register window to the above windows.

Jump method

1 Move the cursor to the line or address that is to be used as the jump pointer, on the window from

which jumping is possible (select an event icon on the Event Manager).

2 Select the following menu item to which execution is to jump from the [Jump] menu.
Source window->Select [Source].
Assemble window->Select [Assemble].
Memory window->Select [Memory].
Coverage window->Select [Coverage].

Caution If a program code does not exist on the line at the cursor position, the first address of the line

with a program code above or below that line is used as the jump pointer.

Details of jump source address

To jump from the following windows, the jump destination is as follows:

e To jump from the Trace window to the Memory window or Coverage window, the jump source
address differs depending on the cursor position in the trace result display area.

If the cursor is at an access address, access data, or access -> Access address
status

Other than above -> Fetch address
To jump to the Source window or Assemble window -> Fetch address

 To jump from the Register window, move the cursor to a register value.
« To jump from the Stack Trace window, the jump destination is as follows:
[With current function]

« If the jJump destination is the Source window -> Jumps to the current PC line.

« If the jump destination is a window other than the Source window -> Jumps to the current PC
address.

[With function other than current function]

« If the jump destination is the Source window
-> Jumps to the line that calls a nested function.
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« If the jJump destination is a window other than the Source window
-> Jumps to the address next to the instruction that calls a nested function.

Trace Result with Linking Window

By linking Trace window with each window (Source window, Assemble window, Memory window, or
Coverage window), the corresponding part can be displayed on the linked window, by using the address at
the cursor position on the Trace window as a pointer.

If the cursor is moved on the Trace window, the corresponding part on the linked window is highlighted or

indicated by the cursor position.

To link a window

1 Setthe Trace window as the current window.

2  Select a window to be linked with the [View] menu -> [Window Synchronize].
Source window ->Select [Source].
Assemble window ->Select [Assemble].
Memory window ->Select [Memory].
Coverage window ->Select [Coverage].

3 Move the cursor to the line to be linked in the trace result display area of the Trace window.

4 Using the address of the line selected in 3 as a pointer, the corresponding part is highlighted (or
indicated by the cursor position) in the display area of the window selected in 2.

Caution The linking source address differs as follows depending on the cursor position in the trace
result display area if the Memory window or Coverage window is linked.
Access address, access data, access status -> Access address
Others -> Fetch address
When the Source window or Assemble window is linked, the fetch address is always used as

the pointer.
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This chapter explains the details of the window/dialog box functions of the ID850.

7.1 Window List

Table 7-1 lists the windows of the ID850.

Table 7-1  Window List

Window Name

Contents

Main window

This window is displayed first, when the debugger is started.
It controls execution of the user program. Various windows are
opened from this window.

Configuration dialog box

Displays and sets the debugger operation environment.

Extended Option dialog box

This dialog box is used to display and set the extended options of the
debugger.

Debugger Option dialog box

Displays and sets options.

Font dialog box

Displays the types of fonts displayed in the Source window and sets
the size of the font.

Project File Save dialog box

Saves the debug environment.

Project File Load dialog box

Loads the debug environment.

View File Save dialog box

Saves the contents of the current window to a view file or event setting
file.

View File Load dialog box

Reads the view file or source event setting file of each window.

Download dialog box

Loads an object file and binary file.

Upload dialog box

Saves the memory contents to a file.

Load Module List dialog box

Lists the names and file path names of the downloaded load module
files.

Browse dialog box

Debugger Option dialog box, Select the file to be set in Source Search
dialog box.

Source Text Move dialog box

This dialog box is used to specify a file to be displayed in Source
window and the position from which displaying the file is to be started.

Address Move dialog box

Specifies the start address to display the contents of the Memory
window, Assemble window or Coverage window.

Trace Move dialog box

Specifies the start address to display the contents of the Trace
window.

Symbol To Address dialog box

Displays the addresses and symbol values of variables and functions.

Source window

Displays a source file or text file.

Source Search dialog box

Searches for a character string in a source file.

Assemble window

Disassembles the program and executes online assembly.

Assemble Search dialog box

Searches the contents of the Assemble window.

Memory window

Displays and modifies the contents of memory.

Memory Search dialog box

Searches the contents of the Memory window.
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Table 7-1  Window List

Window Name

Contents

Memory Fill dialog box

Initializes the memory contents with specified data.

Memory Copy dialog box

Copies the memory.

Memory Compare dialog box

Compares the memory.

Memory Compare Result dialog box

Displays the result of comparing the memory.

DMM dialog box

Sets addresses and data subject to DMM.

Watch window

Displays and modifies variables.

Quick Watch dialog box

Temporarily displays and changes the value of a variable.

Add Watch dialog box

Registers a variable to be displayed in the Watch window.

Change Watch dialog box

Changes a variable to be displayed in the Watch window.

Local Variable window

Displays and changes the local variable in the current function.

Stack Trace window

Displays and changes the stack contents of the current user program.

Register window

Displays and changes the contents of the registers (program registers
and system registers).

Register Select dialog box

Selects a register to be displayed in the Register window.

IOR window

Displays and changes the contents of the peripheral I/0O registers.

IOR Select dialog box

Selects a peripheral I/0 register or I/O port to be displayed in the IOR
window.

Add /0O Port dialog box

Registers an 1/0O port to be displayed in the IOR window.

Trace window

Displays trace results.

Trace Search dialog box

Searches trace data.

Trace Data Select dialog box

Selects items to be displayed in the Trace window.

Coverage window

Displays the coverage results.

Coverage Search dialog box

Searches coverage results.

Coverage-Clear dialog box

Clears the coverage results.

Coverage-Address dialog box

Selects the coverage measurement range as a space of 1 MB or more.

Coverage-Condition Setting dialog box

Sets a coverage efficiency measurement range.

Coverage-Efficiency View dialog box

Displays the coverage results in terms of efficiency.

Event Manager

Displays, enables/disables, and deletes each event condition.

Event dialog box

Registers and displays event conditions.

Event Link dialog box

Registers and displays event link conditions.

Break dialog box

Registers, sets, and displays break event conditions.

Trace dialog box

Registers, sets, and displays trace event conditions.

Snap Shot dialog box

Registers, sets, and displays snapshot event conditions.

Stub dialog box

Registers, sets, and displays stub event conditions.

Timer dialog box

Displays execution time measurement result, and registers, sets, and
displays timer event conditions.

Timer Result dialog box

Displays execution time measurement results.

Delay Count dialog box

Sets the delay count of a trace.
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Table 7-1  Window List

Window Name

Contents

Software Break Manager

Display, enable or disable, and delete software breaks.

Reset Debugger dialog box

Initializes the 1D850, target CPU, and symbol information.

About dialog box

Displays the version of the ID850.

Exit Debugger dialog box

Terminate the ID850.

Console window

Inputs commands.

Error/Warning dialog box

Displays error/warning messages.

7.2 Explanation of Windows

This section explains each debug window as follows:
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Window/dialog name

Briefly explains the function of the window or dialog box and points to be noted.
In addition, the display image of the window or dialog box is also illustrated.

Items of related operation are also explained.

Opening

Explains how to open the window or dialog box.

If two or more methods of opening are listed, the window or dialog box can be opened by any of them.

Explanation of each area

Explains items to be set to or displayed in each area of the window or dialog box.

Functions often used (right-click menu)

Explains the context menu that is displayed in the window when the right mouse button is clicked.
From the context menu, convenient functions often used in this window can be selected with a single

action (window only).

Function buttons

Explains the operation of each button in the window or dialog box.

Related operations

Explains the operation of a window or dialog box related to this window or dialog box.
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Main window

This window is automatically opened when the ID850 is started up and initialized. It exists on the screen
until the ID850 is terminated. Other windows are manipulated from this window. Execution of the user
program is controlled in this window.

Execution of the user program is controlled in the following three modes:

Source mode Debugs the user program at the source level.
Instruction mode Debugs the user program at the instruction level.
Auto mode Automatically selects the source mode or instruction mode.

The auto mode is set when the debugger is started up.

Figure 7-1 Main Window

Wieww Option Eun Bwent Browse  Jump  Window  Help
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This section explains the following items:

¢ Toolbar
¢ Menu bar
« Window display area

« Status bar

Toolbar

The toolbar is a collection of buttons that can execute often-used commands with a single action. Each
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button is graphically displayed to indicate the image of its function. This toolbar can be displayed in the

following two modes. The modes are selected in Debugger Option dialog box.

Figure 7-2 Toolbar with Only Graphics (default)
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Figure 7-3 Toolbar with Graphics and Characters
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Whether the toolbar is displayed or not can be specified by selecting [Option] -> [Tool Bar] from the menu
bar. This toolbar can be moved inside or outside the main window by dragging and dropping with the
mouse.

The meaning of each button on the toolbar is as follows. When the mouse cursor is placed on a button

of the toolbar, a tool hint pops up several seconds later.

T Stops execution of the user program.
Stop Same function as [Run] -> [Stop] on the menu bar.
» Resets the CPU and executes the user program.
Same function as [Run] -> [Restart] on the menu bar.
ReGo
> | Executes the user program from the current PC without resetting the CPU.
Go Same function as [Run] -> [Go] on the menu bar.
|ﬂ Executes the user program without a break occurrence.
N Go Same function as [Run] -> [Ignore break points and Go] on the menu bar.
= | The user program is real-time executed until execution returns.
Ret Same function as [Run] -> [Return Out] on the menu bar
€ * This command is used for a function described in C language.
e Step execution (executes instructions in the program one by one.)
Step If a function or subroutine is called, its instructions are executed one by one.

Same function as [Run] -> [Step In] on the menu bar.

ﬂ| Next step execution (executes the program, assuming a function/call statement as one
Over step.)

If a function or subroutine is called, its instructions are not executed on a step-by-step
basis.

Same function as [Run] -> [Next Over] on the menu bar.

- Resets the CPU.
;l Res Same function as [Run] -> [CPU Reset] on the menu bar.

El Opens View File Load dialog box.
Open | Same function as [File] -> [Open...] on the menu bar.

E Opens Download dialog box.
Load Same function as [File] -> [Download...] on the menu bar.
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Opens Project File Load dialog box.
@l Proj Same function as [File] -> [Project] -> [Open...] on the menu bar.
| Displays the source text.
Src Opens Source window.
Same function as [Browse] -> [Source Text] on the menu bar.
Displays the disassemble results.
=l Asm Opens Assemble window.

Same function as [Browse] -> [Assemble] on the menu bar.

Displays the contents of the memory.
Opens Memory window.
Same function as [Browse] -> [Memory] on the menu bar.

Displays the watch contents.
Opens Watch window.
Same function as [Browse] -> [Watch] on the menu bar.

Displays the register contents.
Opens Register window.
Same function as [Browse] -> [Register] on the menu bar.

Displays the contents of the Peripheral I/O registers.
Opens IOR window.
Same function as [Browse] -> [I/O Register] on the menu bar.

Displays the local variable contents.
Opens Local Variable window.
Same function as [Browse] -> [Local Variable] on the menu bar.

Displays the stack contents.
Opens Stack Trace window.
Same function as [Browse] -> [Stack Trace] on the menu bar.

Displays the trace results.
Opens Trace window.
Same function as [Browse] -> [Trace] on the menu bar.

Displays coverage measurement results.
Opens Coverage window.

Cov
Same function as [Browse] -> [Coverage] on the menu bar.
Opens Event Manager.
== ] Mgr Same function as [Event] -> [Event Manager] on the menu bar.

Registers and sets events.
Opens Event dialog box.
Same function as [Event] -> [Event...] on the menu bar.

Registers and sets break events.
Opens Break dialog box.
Same function as [Event] -> [Break...] on the menu bar.

Registers and sets trace events.
Opens Trace dialog box.
Same function as [Event] -> [Trace...] on the menu bar.

Registers and sets timer events.
Opens Timer dialog box.
Same function as [Event] -> [Timer...] on the menu bar.
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Menu bar

The menu bar consists of the following menus:

@)

(1) [File] menu

(2) [Edit] menu

(3) [View] menu
(4) [Option] menu
(5) [Run] menu

(6) [Event] menu
(7) [Browse] menu
(8) [Jump] menu
(9) [Window] menu
(10) [Help] menu

[Eile] menu

Edit Wiew Option HRun Ewvent Browse Jump Window Help

Open__.
Save As_..
Close

Ctrl+O

Download._ .
Load Module...
Upload...

Project

v I open..

Debugger Reset...

Save
Save As ..

Exit

1

2C
3 CAVELDSRCV .out
1cC

C:AWB50SRCADEMO . out
AVBs0SRC\calc3003 out

A\DEMOSET w8504 a.out

Open... Loads a view file, source file, or text file.
Opens View File Load dialog box.
The operation differs depending on the extension of the file selected in the
dialog box.
Save As... Saves the contents displayed on the current window to the file whose name is
specified.
Opens View File Save dialog box.
Close Closes the current window.
Download... Downloads a program.
Opens Download dialog box.
Load Module... Lists the names of the files that have been downloaded.
Opens Load Module List dialog box.
Upload... Uploads a program.
Opens Upload dialog box.
Project Manipulates a project file.
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Open... Opens a project file.
Opens Project File Load dialog box.

Save Overwrites the current status to the project file currently being read to the
debugger.

Save As... Saves the current status to a specified project file.
Opens Project File Save dialog box.

Debugger Reset...

Initializes the target CPU, symbols, and debugger.
Opens Reset Debugger dialog box.

Exit Terminates the debugger.
Opens Exit Debugger dialog box.
(Open file) Lists the names of the files opened.

(2) [Edit] menu

|Ei|e =Ll Yiew Option Bun Event Browse Jump Window Help

Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+¥
Write in Enter
Restore Esc Fill...
Memory »—{ Copy-.
Compare...
Edit Source Modify._
Cut Cuts a selected character string and saves it to the clipboard buffer.
Copy Copies a selected character string and saves it to the clipboard buffer.
Paste Pastes the contents of the clipboard buffer to the text cursor position.
Write in Writes the modified contents to the target.
Restore Cancels the modification.
Memory Manipulates the memory contents.
Eill... Initializes the memory.
Opens Memory Fill dialog box.
Copy... Copies the memory.
Opens Memory Copy dialog box.
Compare... Compares the memory.
Opens Memory Compare dialog box.
Modify... Rewrites the memory contents in close to real time during user program
execution.
Opens DMM dialog box.
Edit Source Opens the source file displayed in the active Source window with the editor

specified by the PM plus when the PM plus runs.

User's Manual U16217EJ1VOUM

61




CHAPTER 7 WINDOW REFERENCE

(3) [View] menu
This menu displays different items depending on the window that is active. The following items may be

displayed:

« Common items

» Source window-dedicated items

» Assemble window-dedicated items

* Memory window-dedicated items

» Watch window-dedicated items

» Register window-dedicated items

* |OR window-dedicated items

* Local Variable window-dedicated items, Stack Trace window-dedicated items
* Trace View window-dedicated items

« Coverage window-dedicated items

« Event Manager-dedicated items

Common items

File Edit Option Run Event Browse Jump Window Help

Search... Ctrl+G
Move__. Ctrl+J
Quick Yyatch... Cirl+w
Add Watch__.

View Watch

Change Watch._..
Delete Watch Del
Symbol._..

Search... Performs a search.
Opens the search dialog box corresponding to the current window.
Same operation as the <Search> button.

Move... Moves the display position.
Opens the specification dialog box corresponding to the current window.

Quick Watch... Temporarily displays the contents of the specified data.
Opens Quick Watch dialog box.

Add Watch... Registers the specified data to the Watch window.
Opens Add Watch dialog box.

View Watch Adds the selected data to the Watch window.
If the data is a symbol, it is added in accordance with the setting of Debugger
Option dialog box.

Change Watch... Changes the data on the line selected by the Watch window.
Opens Change Watch dialog box.
This menu is valid only when a variable is selected in Watch window.

Delete Watch Deletes the selected watch point from the Watch window. This menu is valid
only when a variable is selected in Watch window.
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Symbol...

Displays the address of the specified variable or function, or the value of the
specified symbol.
Opens Symbol To Address dialog box.

Source window-dedicated items

Break when fccess to this Wariable

Event?
P iz

Break when Write to thiz Yariable
Break when Bead fram thiz Wariable
Cilear

Create Break Event

Creates a break event by using the selected variable.

Break when Access
to this Variable

Creates a break event that can be accessed for read/write.

Break when Write to
this Variable

Creates a break event that can be accessed for write.

Break when Read
from this Variable

Creates a break event that can be accessed for read.

Clear Deletes a break event corresponding to the selected variable.
Event? Displays the event information of a line at the cursor position or a selected
variable name.
If an event is set, Event dialog box is opened.
Mix Specifies whether the results of assembly are displayed in mixed display

mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Ewvent ?

Assemble window-dedicated items

Event?

Displays the event information of the address at the cursor position.
If an event is set, Event dialog box is opened.

Memory window-dedicated items

Mibble

& Bvie
Half Wword
Word

Ascii

» | ittle Endian
Biz Endian
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Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Nibble Displays in 4-bit units.

Byte Displays in 8-bit units (default).

Half Word Displays in 16-bit units.

Word Displays in 32-bit units.

Ascii Selects whether ASCII characters are displayed or not.
Checked: Displayed
Not checked: No display (default)

Little Endian Displays in little endian (default).

Big Endian Displays in big endian.

Watch window-dedicated items

Only "selected items" can be manipulated in the Watch window.

Break when fAccess to this Variable

Break when Write to thiz VYariable

He:x
Siring
& Proper

Break when Bead from this Wariable
Clear ’

Biyte
Half ‘ord
Wiard

& fdaptive

Up
Do
Compulsion Fead

Create Break Event

Creates a break event by using the selected item.

Break when Access
to this Variable

Creates a break event that can be accessed for read/write.

Break when Write to
this Variable

Creates a break event that can be accessed for write.

Break when Read
from this Variable

Creates a break event that can be accessed for read.

Clear

Deletes a break event corresponding to the selected item.

Event?

Displays the event information of the variable selected. If an eventis
set, Event dialog box is opened.
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Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays octal numbers.

String Displays character strings.

Proper Displays the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger
Option dialog box (default).

Byte Displays in 8-bit units.

Half Word Displays in 16-bit units.

Word Displays in 32-bit units.

Adaptive Displays the default value of each variable.
Only this item is valid for a symbol in C language.
Symbols are displayed in accordance with the setting of Debugger
Option dialog box (default).

Up Moves up one line.

Down Moves down one line.

Compulsion Read Forcibly reads the peripheral I/O registers that are disabled from being
read because their values will be changed, or the data of the 1/0 ports
and I/O protect area added in Add I/O Port dialog box.

Register window-dedicated items

Ein
Oct
Dec
® Hex
Pick Up
Select...
Bin Displays binary numbers.
Oct Displays octal numbers.
Dec Displays decimal numbers.
Hex Displays hexadecimal numbers (default).
Pick Up Displays only the registers selected in Register Select dialog box.
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).
Select... Opens Register Select dialog box.
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IOR window-dedicated items

Ein
Ot
Dec
® Hewx

Sort By Mame
® Sort By Address
UnSort

v Attribute

Pick Up
Select..

Compulsion Read

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Sort By Name

Displays in alphabetical order.

Sort By Address

Displays in address order (default).

Unsort Does not sort.

Attribute Displays or does not display an attribute field (Attribute).
Checked: Displayed (default)
Not checked: Not displayed

Pick Up Displays only the registers selected in IOR Select dialog box.
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).

Select... Opens IOR Select dialog box.

Compulsion Read

Forcibly reads the peripheral I/O registers that are disabled from being
read because their values will be changed, or the data of the 1/0O ports
and I/O protect area added in Add I/O Port dialog box.

Local Variable window-dedicated items, Stack Trace window-dedicated items

EBin

Oct

Dec

Hex

String
® Proper
Bin Displays binary numbers.
Oct Displays octal numbers.
Dec Displays decimal numbers.
Hex Displays octal numbers.
String Displays character strings.
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Proper

Displays the default value of each variable (default).

Trace View window-dedicated items

Select.
Pick Up
iz

Window Svnchronize

* Off
Search
Shap
BRIM1

SourceText
Assemble
Memory
Coverage

Select... Selects the contents to be displayed.
Opens Trace Data Select dialog box.

Pick Up Performs the setting for pickup display.

Off Does not pick up and display (default).

Search Picks up and displays a frame that satisfies the search condition.

Snap Picks up and displays a snap frame.

BRM1 Picks up and displays the first M1 fetch frame after a program branch.
Mix Specifies whether the results of assembly are displayed in mixed display

mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Window Synchronize

Sets linking between Trace window and the following windows.
A checked window is linked.

Source Text Links Source window.
Assemble Links Assemble window.
Memory Links Memory window.
Caoverage Links Coverage window.

Coverage window-dedicated items

= 1 Bvte

64 Byvtes

1024 Bytes
1Byte Displays in 1-byte units (default).
64Bytes Displays in 64-byte units.
1024Bytes Displays in 1024-byte units.
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Event Manager-dedicated items

(4)

Select All BEvent
Delete Event

Ctri+A

Dl

Sort By MName
Sort By Kind
e LInSort

Detail
" Overview

Select All Event

Selects all the events registered to the Event Manager.

Delete Event

Deletes a selected event.

Sort By Name

Displays icons in the order of event names.

Sort By Kind Displays icons in the order of event types.
Unsort Does not sort icons (default).

Detail Detailed display

Overview List display (default)

[Option] menu

|Ei|e Edit !iewmﬁun Event Browse Jump Window Help

+ Tool Bar
v Status Bar
+ Button

Source Mode
Instruction Mode
Auto Mode

Configuration...
Extended Option...
Debugger Option...
Add 1/O Port...

Trace Clear

DMA Trace Clear...
Coverage *— Select..
¥ Coverage ON Condition...
¥ Timer ON Efficiency...
v Tracer ON

Tool Bar Selects whether the tool bar is displayed (default) or not.
Status Bar Selects whether the status bar is displayed (default) or not.
Button Selects whether the buttons on each window are displayed (default) or not.

Source Mode

Executes step execution at the source level (in line units).

Instruction Mode

Executes step execution at the instruction level (in instruction units).

Auto Mode

Automatically selects step execution at the source level or step execution at
the instruction level (default).

Step execution is performed at the source level (in a mode other than mixed
display mode) if Source window is active. It is performed at the instruction
level if Assemble window is active. If neither window is active, step execution
is performed at the source level.
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Configuration...

Sets the environment.
Opens Configuration dialog box.

Extended Option...

Sets extended functions.
Opens Extended Option dialog box.

Debugger Option...

Sets debugger options.
Opens Debugger Option dialog box.

Add 1/0 Port... Adds user-defined 1/O ports.
Opens Add I/O Port dialog box.
Trace Clear Clears the trace data.
This item is displayed only when Trace window is active.
DMA Trace Turns ON/OFF DMA trace (default: OFF).
If checked, DMA trace takes precedence.
* Displayed only when the IE-V850E-MC or |IE-V850E-MC-A is used.
Coverage Opens the following dialog boxes related to coverage measurement.
Clear... Clears the coverage measurement results.
Opens Coverage-Clear dialog box.
Select... Selects the coverage measurement range as a space of 1 MB or more.
Opens Coverage-Address dialog box.
Candition... Sets a coverage efficiency measurement condition.
Opens Coverage-Condition Setting dialog box.
Efficiency... Displays coverage efficiency.
Opens Coverage-Efficiency View dialog box.

Coverage ON

Turns ON/OFF coverage measurement (default: ON).
This item cannot be selected during user program execution.

Timer ON Turns ON/OFF timer measurement (default: ON).
This item cannot be selected during user program execution.
The timer measuring Run-Break time cannot be stopped.
Tracer ON Turns ON/OFF the tracer (default: ON).

This item cannot be selected during user program execution.
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(5) [Run] menu

[ File Edit View Option @

Ewvent Browse Jump Window Help

Restart F4
Stop F2

Go F5
Ignore break points and Go  Cirl+Fb
Return Out F7
StepIn F8
Next Over F10
Start From Here Shift+Fb
Come Here Fb

Go & Go

Slowmotion

CPU Reset F3
Change PC Ctrl+F9
Break Point F9

Software Break Point
Delete All Breakpoints

® Uncond. Trace ON
Cond. Trace ON

Trace Control Mode » [— ® Mon Stop
Eull Stop
Coverage Start Full Break

Timer Start
Tracer Start

Restart Resets the emulation CPU and executes the program.
Same operation as the ReGo button

Stop Forcibly stops program execution.
Same operation as the Stop button

Go Executes the program from the current PC.

Same operation as the Go button

Ignore break points and Go

Executes the program, ignoring break points being set.
Same operation as the GoN button

Return Out The user program is real-time executed until execution returns.
Same operation as the Ret button
Note: This menu item is available only for a function described in C
language.

Step In Executes the instructions in the program one by one (step execution).
If a function or subroutine is called, its instructions are executed one by
one.

Same operation as the Step button
Next Over Executes the instructions in the program one by one (Next step

execution).

If a function or subroutine is called, its instructions are not executed on
a step-by-step basis.

Same operation as the Over button

Start From Here

Executes the program from the cursor position on Source window or
Assemble window (Start function).

Come Here

Executes the program from the current PC to the cursor position in the
Source window or Assemble window (Come function).
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Go & Go

Continues executing the program.

If a break occurs because a break condition is satisfied, the window is
updated and the program is executed again.

Each time a break has occurred, the same operation as clicking the
Go button is performed.

Slowmotion

Continues step execution.

Each time step execution has been performed, the window is updated
and then step execution is performed again.

Same operation as clicking the Step each time a break has occurred.

CPU Reset

Resets the emulation CPU.
Same operation as the Res button

Change PC

Sets the address at the cursor position in the Source window or
Assemble window to the PC.

Break Point

Sets or cancels a breakpoint at the cursor position in the Source
window or Assemble window.

Software Breakpoint

Sets or cancels a software breakpoint at the cursor position in the
Source window or Assemble window.

Delete All Breakpoints

Deletes all software breakpoints that are set.

Uncond. Trace ON

Validates unconditional trace so that trace can always be executed
during program execution (default).
The trace mode cannot be changed while the tracer is activated.

Cond. Trace ON

Validates conditional trace and traces in accordance with the trace
condition during program execution.
The trace mode cannot be changed while the tracer is activated.

Tracer Control Mode

Selects settings related to the tracer from the following menus:

Non Stop Goes around the trace memory and overwrites data from the
oldestframe (default).

Eull Stop Goes around the trace memory and then stops the tracer.

Full Break Goes around the trace memory and then stops the tracer and program
execution
* Only IE-703102-MC, IE-V850E-MC or |E-V850E-MC-A

Coverage Start/
Coverage Stop

Starts coverage measurement when it is stopped, or stops it when it is
in progress.

This item is invalid if the program is not being executed or if the
coverage function is OFF (if [Option] -> [Coverage ON] is not
checked). Immediately after program execution has been started with
the coverage function ON, coverage measurement is in progress.

Timer Start/
Timer Stop

Starts timer measurement when it is stopped, or stops it when it is in
progress.

This item is invalid if the program is not being executed, if a timer event
is not used, and if the timer function is OFF (if [Option] -> [Timer ON] is
not checked). Immediately after program execution has been started
with the timer function ON, timer measurement is in progress.

Tracer Start/
Tracer Stop

Starts the tracer when it is stopped, or stops it when it is in progress.
This item is invalid if the program is not being executed and if the trace
function is OFF (if [Option] -> [Tracer ON] is not checked).
Immediately after program execution has been started with the tracer
function ON, the tracer is executed.
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(6) [Event] menu

|Ei|e Edit ¥iew Option Bun Browse Jump Window Help

Event Manager
Software Break Manager

Ewvent...

Ewvent Link...
Break. ..
Trace...

Snap Shot...
Stub...
Timer...
Delay Count...

Event Manager

Manages various event conditions.
Opens Event Manager.
Same operation as the Mgr button

Software Break Manager

Manages software break event conditions.
Opens the Software Break Manager.

Event...

Registers an event condition.
Opens Event dialog box.
Same operation as the Evn button

Event Link...

Registers an event link condition.
Opens Event Link dialog box.

Break...

Registers and sets a break condition.
Opens Break dialog box.
Same operation as the Brk button

Trace...

Registers and sets a trace event condition.
Opens Trace dialog box.
Same operation as the Trc button

Snap Shot...

Registers and sets a snap event condition.
Opens Snap Shot dialog box.

Registers and sets a stub event condition.
Opens Stub dialog box.

Registers and sets a timer event condition.
Opens Timer dialog box.
Same operation as the Tim button

Delay Count...

Sets a delay count and displays the delay value.
Opens Delay Count dialog box.
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(7) [Browse] menu

|Ei|e Edit ¥iew Option Run Evemgump Window Help

SourceText
Assemble
Memory

Watch
Register

170 Register
Local Variable
Stack Trace
Trace
Coverage
Console
Others r

Source Text

Displays a source text.

Opens Source window.

Same operation as the Src button

If there is a Source Text window already open in the active status, it is
opened in the static status.

Assemble

Displays the disassemble results.

Opens Assemble window.

Same operation as the Asm button

If there is a Assemble window already open in the active status, it is
opened in the static status.

Memory

Displays the contents of the memory.

Opens Memory window.

Same operation as the Mem button

If there is a Memory window already open in the active status, it is
opened in the static status.

Watch

Displays the watch contents.
Opens Watch window.
Same operation as the Wch button

Register

Displays the register contents.
Opens Register window.
Same operation as the Reg button

1/0 Register

Displays the contents of the Peripheral I/O registers.
Opens IOR window.
Same operation as the IOR button

Local Variable

Displays the local variable.
Opens Local Variable window.
Same operation as the Loc button

Stack Trace

Displays the stack trace results.
Opens Stack Trace window.
Same operation as the Stk button

Trace

Displays the trace results.
Opens Trace window.
Same operation as the TrW button

Coverage

Displays coverage measurement results.
Opens Coverage window.
Same operation as the Cov button.

Console

Opens Console window.
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Others

Displays other windows.
Displays a user-defined window list.

(8) [Jump] menu

|Ei|e Edit Yiew Option Bun Ewvent Browse ﬁinduw Help

SourceText Ctrl+U
Assemble Ctrl+D
Memory Ctrl+M
Coverage Ctrl+1

Source Text

Displays the corresponding source text and source line, using the data value
selected in the current window as the jump destination address.

If no line information is at the jump destination address, however, you cannot
jump.

Opens Source window.

If an active Source window is open, that window is displayed in the forefront (so
that it can be manipulated).

Assemble Disassembles and displays the results from the jump destination address
specified by the data value selected in the current window.
Opens Assemble window.
If an active Assemble window is open, that window is displayed in the forefront
(so that it can be manipulated).

Memory Displays the memory contents from the jump destination address specified by
the data value selected in the current window.
Opens Memory window.
If an active Memory windowis open, that window is displayed in the forefront (so
that it can be manipulated).

Coverage Displays coverage measurement results from the jump destination address

specified by the data value selected in the current window.

Opens Coverage window.

If an active Coverage windowis open, that window is displayed in the forefront
(so that it can be manipulated).

(9) [Window] menu

|Ei|e Edit View

Option Run Ewvent Browse Jump ﬂelp J

New Window
Cascade

Tile

Arrange lcons
Close All

Befresh

* Active
Static

1 Trace View
v 2 Assemble

New Window

Opens a new window displaying the same contents as those of the current
window. This menu is valid only when the current window is Source window,
Assemble window, Memory window, or Coverage window.
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Cascade Cascade display of the windows in the Main window.

Tile Tile display of the windows in the Main window.

Arrange Icons Rearranges the icons in the Main window.

Close All Closes all windows, except the Main window.

Refresh Updates the contents of the window with the latest data.

Active Sets the window in the active status.
If the window is already in the active status, a check mark is shown on the left of
this item.

Static Sets the window in the static status.
If the window is already in the static status, a check mark is shown on the left of
this item.

(Open Window) Lists the windows that are open.
The window with the check mark shown on the side of the figure is the current
window. By selecting a window name, the selected window is used as the
current window.

(10) [Help] menu

|Ei|e Edit View Option Run Event Browse Jump Window m |

IDB50 Help
Command Reference

Main Window Help
Current Window Help F1

About...
ID850 Help Displays the help of ID850 .
Command Reference Opens the Help window of COMMAND REFERENCE.
Main Window Help Displays the help of the Main window.
Current Window Help Displays the help of the current window.
About... Displays the version of the debugger.
Opens About dialog box.

Window display area

This area (at the center) displays various debug windows.

The displayed window can be changed in size or an icon can be created in this area.

Status bar

The status bar is displayed at the bottom of the window and indicates the status of the debugger and In-
circuit emulator.

While the user program is being executed, the status bar is displayed in red.
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Whether the status bar is displayed or not can be selected by selecting [Option] -> [Status Bar] from the

menu bar.

Figure 7-4 Status Bar

. 2 a3 N i il )] )]
EmAT  CTawm s, @S | (NI

(1) Program name

Displays the program file name indicated by the PC value.

Source name

Displays the source file name indicated by the PC value.

Line number

Displays the line number indicated by the PC value.

(2) Function name

Displays the function name indicated by the PC value.

(3) PC value

Displays the current PC value.

(4) CPU status

Displays the status of the CPU (target device).

(If there are two or more CPU statuses, they delimited with '|' and displayed.)
STANDBY...Stanby mode

RESET...Reset status

POW OFF...Power is not supplied to the target.

(5) IE status

Displays the status of the in-circuit emulator.

(If there are two or more the statuses, they delimited with '|' and displayed.)
RUN...User program execution in progress (the color of the status bar
changes).

STEP...Step execution in progress

TRC...Tracer operating

TIM..Timer operating

COV...Coverage operation in progress

BREAK...Break occurring.

(6) Break Cause

Displays Table 7-2 Break Cause.

(7) STEP mode

Displays the step execution mode.

Displays that the following modes are selected from the [Option] menu:
SRC...Source mode

INST...Instruction mode

AUTO...Automatic mode

(8) Key input mode

Displays the key input mode.

INS... Insertion mode

OVR...Overwrite mode

The Memory window is fixed to OVR mode.

Table 7-2 Break Cause

Display

Meaning

Manual Break

Forced break

Temporary Break

Temporary break

Event Break

Break by event
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Table 7-2 Break Cause

Display

Meaning

Software Break

Software break

Trace Full Break

Break due to trace full
* Other than IE-703102-MC, IE-V850E-MC or |IE-V850E-MC-A

Non Map Break

Non-mapped area is accessed.

Write Protect

An attempt has been made to write to a write-protected area.

IOR lllegal

An illegal access is made to a peripheral I/O register.
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Configuration dialog box

This dialog box is used to display and set the operating environment of the in-circuit emulator.

This dialog box is automatically displayed after the debugger is started up.

To use the debugger, the operating environment of the in-circuit emulator must be first set in this dialog
box.

However, no setting is required to read a project as the results of reading the project file are reflected in
this dialog box.

For details of the mapping function, refer to "Mapping function".

Cautionl The following message may be displayed if the <OK> button on the Configuration dialog box

is clicked when the debugger is started up.

IDE50

& WE0T: When connecting the target svstem, pleaze turn an the tareet system.

If no target is connected, click the <OK> button.

Caution2 Turn on the power to the target if even one of the following items is set in the Configuration
dialog box.
- If Target is selected in Clock (CPU clock source selection area).
- If mapping to Target is specified in Memory Mapping (mapping setting area).
In this case, a message prompting you to turn on the power is displayed. Turn on the power
to the target and click the <OK> button. If power is not turned on, the following message is

displayed and the Configuration dialog box is displayed again.

& WT00f: Tareget iz nat turned an.

In this case, perform the setting again, press the reset button of the in-circuit emulator, and

click the <OK> button.
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Figure 7-5 Configuration Dialog Box

Internal RAM: ISD?E vl Byte (MH=]
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Project..
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[ Start Address:
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=

~ Mamary Mapping
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— Emulation Memary Mask
{0 Wait Mask _‘ [T mel [ RESET [ walT [ HLDRG
0

Erulaticon RAM SO100000 — COO1OFFFF

Aoocess Size: 2dd
Memary Attribute: Mapping Address: Delete I
Emulation R&M v | [00100000 == [0010FFFF

This section explains the following items:

« Opening
« Explanation of each area

» Setting of memory mapping
* Function buttons

« Related operations

« Changing the register values necessary for accessing the external memory

Opening

This dialog box can be opened as follows:

« Automatically when the debugger is started up

« Select [Qption] -> [Configuration...] from the menu bar.
(or press Alt+O, and C in that order)
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Explanation of each area

The Configuration dialog box consists of the following areas:

@)

)

(1) Chip (Emulation CPU selection area)

(2) Internal ROM/RAM (internal ROM/RAM setting area)

(3) Programmable I/O Area (programmable I/O area address setting area)
(4) Clock (CPU clock source selection area)

(5) Emulation Memory (wait selection area)

(6) Mask (mask setting area)

(7) Memory Mapping (mapping setting area)

Chip (Emulation CPU selection area)

This area is used to select the Emulation CPU.

Chip
lrﬂame: uPD I vl

Only the chip names registered to a registry by the DFINST utility are listed.

Specify a chip name from the drop-down list under Name.
A chip name can be specified only when the debugger is started up. The chip name selected at the
previous startup is selected by default. If the chip name is not stored, the top chip name that is

registered is selected by default.

Internal ROM/RAM (internal ROM/RAM setting area)

Internal ROMSRA M

Internal ROM: IW vl KBEyte
Internal RAM: ISD'."E vl Evyte

This area is used to set the size of the internal RAM and internal ROM of the emulation CPU.

The default value is automatically displayed with "*" suffixed, when Chip is selected.

To change the size of the internal RAM and internal ROM, select the size from the drop-down list under
Internal RAM and Internal ROM.

If the selected size cannot be implemented because of the constraints of the in-circuit emulator, the
debugger automatically adjusts the size (therefore, a size larger than that previously specified may be
displayed when the Configuration dialog box is displayed again).

The settable sizes are as follows:
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Table 7-3 Settable Sizes as Internal ROM/RAM

Internal ROM Internal RAM
Emulator used Both Alignment and Settable Range Both Alignment and Settable Range
(KByte) (Byte)
IE-703002-MC 0, 32, 64, 128, 256, 512 1024, 2048, 3072, 4096, 6144, 8192,
10240, 12288, 16384, 20480, 24576,
28672
IE-703102-MC 0, 32, 64, 128, 256, 512 1024, 2048, 3072, 4096, 6144, 8192,

10240, 12288, 16384, 20480, 24576,
28672, 36864, 45056, 53248, 61440

IE-V850E-MC or
IE-V850E-MC-A
IE-V850ES-G1

0, 32, 64, 128, 256, 512, 1024

4096, 12288, 28672, 61440

If the internal RAM size is changed, the internal RAM's start address shifts as shown below:

Table 7-4 Size of Internal RAM and Start Address

Types Internal RAM Size (Bytes) Start Address of Internal RAM
V85X, V850/XXX 1 to 4096 OxFFEO000
to 12288 OxFFCO000
to 28672 0xFF8000
V850E/MS1 1 to 4096 Ox3FFE000
to 12288 0x3FFC000
to 28672 0x3FF8000
to 61440 0x3FF0000
V850E other than 1 to 4096 Fixed to OxFFFC000
the above
to 12288
to 28672
to 61440
NB85E core 1 to 4096 Ox3FFEOO00
(64M model)
to 12288 0x3FFC000
to 28672 0x3FF8000
to 61440 0x3FF0000
NBS85E core 1 to 4096 OxFFFEO00
(256M model)
to 12288 OxFFFCO000
to 28672 OxFFF8000
to 61440 OxFFF0000
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®)

(4)

Table 7-4 Size of Internal RAM and Start Address

Types Internal RAM Size (Bytes) Start Address of Internal RAM
V850ES 1to 4096 Depends on the device
to 12288
to 28672
to 61440

Programmable I/O Area (programmable I/O area address setting area)

Programmable I/ 0 Area
’7 M Start Address: I

This area is used to specify usage of the programmable I/O area and the start address.

If programmable 1/O is used for a device that supports the programmable I/O, the start address can be
specified via keyboard input when the check box is checked. The address is aligned to 16 KB.

If the device has an extended 1/0O area whose address is fixed, the address setting and the check are
executed automatically. To use the programmable 1/O area or expansion |/O area, that area must be

mapped as Target.

Clock (CPU clock source selection area)

= Clock

{7 Internal
(%) Targat

|33.335 - I

(hHz)

This area is used to select a clock source to be input to the emulation CPU. The clock source can be
selected only when the IE-V850ES-G1 is connected to the ID850. If the IE-703002-MC is connected to

the ID850, this area is always fixed to Internal and dimmed because the clock is changed by a jumper

setting.
Internal Uses the clock on the in-circuit emulator as the CPU clock.
Target Uses the clock of the target as the CPU clock.

If Target is selected and if the power to the target is OFF, "Wrong Target
Status (Power Off)" is displayed.

Text area (MHz)
Specify the number of clocks by inputting from the keyboard or selecting from the drop-down list.
The relationship between the system clock frequency (phi) and the clock frequency input to the

emulation CPU (fxx) is as follows:

Direct mode phi = 1/2 x fxx
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PLL mode

phi =5 x fxx (multiplied by 5)
phi = fxx (multiplied by 1)

Specify the fcpu clock frequency for the V850/SA1 and V850/SBx.

(5) Emulation Memory (wait selection area)

Emulation Memory

it Mask

(% 1 Wait Agoess

{7 Target Wait

This area is used to select a wait signal when the emulation memory (in-circuit emulator alternate

ROM/RAM) is accessed.

This area can be used only when the IE-703002-MC is connected to the ID850.

For IE-703102-MC

Wait Types Emulation Memory Access

External Memory Access

Wait Mask

Data wait Fixed to 0 waits,
WAIT signal is masked.

Fixed to 0 waits,
WAIT signal is masked.

Idle state Depends on the setting of the
BCC register.

Depends on the setting of
the BCC register.

DWC register and the status
of the WAIT signal.

1 Wait Access Data wait Fixed to 1 wait, Depends on the setting of
(default) WAIT signal is masked. the DWC register and the
status of the WAIT signal.
However, the WAIT signal

can be masked.
Idle state Depends on the setting of the | Depends on the setting of

BCC register. the BCC register.

Target Wait Data wait Depends on the setting of the | Depends on the setting of

the DWC register and the
status of the WAIT signal.

Idle state Depends on the setting of the
BCC register.

Depends on the setting of
the BCC register.
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For IE-V850E-MC, IE-V850E-MC-A, IE-V850ES-G1

Wait Types Emulation Memory Access External Memory Access
0 Wait Access Data wait Fixed to 0 waits, Depends on the setting of the
WAIT signal is masked. DWC register. WAIT signal is
masked.
Idle wait Fixed to 0 waits. Depends on the setting of the
ASC or AWC register.
Idle state Fixed to 0 waits. Depends on the setting of the
BCC register.
1 Wait Access Data wait Fixed to 1 waits, Depends on the setting of the
(default) WAIT signal is masked. DWC register and the status of
the WAIT signal. The WAIT
signal can be masked.
Idle wait Fixed to 0 waits. Depends on the setting of the
ASC or AWC register.
Idle state Fixed to 0 waits. Depends on the setting of the
BCC register.
DWCO0, DWC1, | Data wait Depends on the setting of the | Depends on the setting of the
BCC DWC register. 1wait when O | DWC register and the status of
waits are set, and WAIT is the WAIT signal.
masked.
Idle wait Fixed to 0 waits. Depends on the setting of the
ASC or AWC register.
Idle state Depends on the setting of the | Depends on the setting of the
BCC register. BCC register.

(6) Mask (mask setting area)

fask

[T wwl [ RESET [ walT [ HLDRG
[ sTOP

[ MODE 0.2 I ;I

This area specifies a mask for the signal sent from the target.

The signal of the masked pin is not input to the in-circuit emulator.

Only mask pins when the operation of the target is unstable at the debugging stage.

The maskable pins are NMI, RESET, WAIT, HLDRQ, STOP, MODEQO, 1, and 2.

When the MODE 0, 1, 2 pin is masked, one of the operation modes described below can be selected.

The mode displayed depends on the definition in the device file.

Examples are as follows.

For V850

Single Chip Mode

Single-chip mode (V851/852/853)
Single-chip mode 1 (V854)

Single Chip Mode 2

Single-chip mode 2 (V851/852/853)

User's Manual U16217EJ1VOUM




CHAPTER 7 WINDOW REFERENCE

ROM Less Mode 1 ROMless mode (V851/852/853)
ROMIless mode(V854)

ROM Less Mode 2 ROMless mode 1 (V854)

For V850E/MS1

Single Chip Mode 0 Single-chip mode

Single Chip Mode 1 Single-chip mode

ROM Less Mode 1 ROMIless mode with 8-bit external bus
ROM Less Mode 0 ROMIless mode with 16-bit external bus

For V850E/MA1, V850E/IA1

Mode00 ROMIless mode 0
ModeO1 ROMless mode 1
Mode02 Single-chip mode 0
Mode03 Single-chip mode 1

(7) Memory Mapping (mapping setting area)

~ Memory Mapping

Locess Sige: & gBit 0 16Bit (O 32Bit Add
Memory Attribute: Mapping Address: Delete I
Emulation Ra&M v | [00100000 |~ [0010FFFF

Emulaticn RAM OO0 0

This area is used to set mapping by specifying the access size, memory attribute, and address.

Access Size (selection of memory access size)
Selects memory access size.
Because these settings specify the access size of the debugger software, the hardware of the external

bus operates in accordance with the settings of the MODE pin or the I/O register.

8Bit Accesses memory with Id.b instruction/st.b instruction.
16Bit Accesses the memory with the Id.h instruction/st.h instruction.
32Bit Accesses the memory with the Id.w instruction/st.w instruction.

Memory Attribute (mapping attribute specification)

The following mapping attributes can be selected. Select a mapping attribute according to the usage
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(refer to "Mapping function™).

Emulation ROM Selects the in-circuit emulator alternate ROM.
Emulation RAM Selects the in-circuit emulator alternate RAM.
Target Selects the target memory.
1/0 Protect Selects the 1/O protect area.
This area can be set only inside the area which is set as Target.

Caution The area set as I/O Protect cannot be read unless it has been registered as an 1/O port in the
IOR window, or registered in the Watch window. If it is necessary to read this area, execute a

forcible read in these windows.

Mapping Address (mapping address specification)
Specify the address to be mapped.

Input the higher and lower addresses from the keyboard.

Setting of memory mapping
Specify Memory Attribute and Mapping Address and then click the <Add> button.
-> The attribute of Memory Attribute, address range of Memory Mapping, and memory mapping
corresponding to the data of the bus width are set and displayed on a list.
For mapping attributes other than 1/0 Protect, the mapping units are adjusted when the <Add> button
is clicked. If the mapping unit does not match, the minimum settable range including the specified
address is mapped.

The mapping unit is as follows:

Table 7-5 Mapping Unit in Configuration Dialog Box

Mapping Area Mapping Unit
1/0 Protect 1 byte
Target For V85X, V850/XXX

Units of 1 MB inside the area of 0x100000 to OxFFFFFF

For VB50E/MS1

Units of 1 MB in the area of 0x100000 to Ox3FFFFF, excluding the
internal ROM area (1 MB) and the reserved area (32 MB).
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Table 7-5 Mapping Unit in Configuration Dialog Box

Mapping Area

Mapping Unit

Emulation ROM
Emulation RAM

For V85X, V850/XXX

Units of 64 KB in one 1 MB area inside the Target area which is set in the
above area.

For ROMless products, or for when ROMless mode has been selected,
they can each be mapped in units of 64 KB in the 1 MB area of 0 to
OxFFFFFF, which is separate to the above 1 MB area.

For V850E/MS1

Units of 64 KB in two 1 MB areas inside the above area.

For ROMless products, or for when ROMless mode has been selected,
mapping can be performed in the same way in the area of 0 to
0x3FFFFFF, excluding the reserved area (32 MB).

For other V850E and V850ES

Each memory can be mapped in units of 1 MB in the area of 0 to
0x3FFFFFF, excluding the internal ROM area (1 MB) and the reserved
area (32 MB). (Max. 4)

For ROMless products, or for when ROMless mode has been selected,
mapping can be performed in the same way in the area of 0 to
0x3FFFFFF. However, the start address of mapping may vary
depending on the device.

Caution  When the external memory is mapped, change the register values necessary for accessing

the external memory (refer to "Changing the register values necessary for accessing the

external memory").

Deleting memory mapping

Select mapping to be deleted from the list and click the <Delete> button.

-> This deletes the selected mapping.

Function buttons

OK Validates the current environment.
Sets the environment and closes this dialog box.

Cancel Cancels the changes and closes this dialog box.

Restore Restores the previous environment settings status before this dialog box was
opened.

Project... Opens the Project File Load dialog box. If an error occurs while a project file is being

opened or read, the debugger can no longer continue and is terminated.

Help Opens the Help window.

User's Manual U16217EJ1VOUM 87




CHAPTER 7 WINDOW REFERENCE

Related operations

Changing the register values necessary for accessing the external memory
When the external memory is being mapped, change the register values necessary for accessing the
external memory using the IOR window or by hook procedure before downloading.
For details of changing register values by hook procedure, refer to "Hook Procedure" described in the
COMMAND REFERENCE.

The registers to be changed are as follows.

Table 7-6 Registers Necessary for Accessing External Memory

<When IE-703002-MC is used> (Operation mode of device is single-chip mode)

Register Name Setting

MM Sets memory extension mode

Caution If the debugger is used with the IE-703017-MC-EM1 or IE-703037-MC-EM1, the MM register

cannot be set.

<When IE-703102-MC is used> (Operation mode of device is single-chip mode 0)

Register Name Setting
MM Sets memory extension mode
PMC8 Sets each of CS7/RAS7, CS6/RA6, CS5/RAS5/IORD, CS4/

RAS4/IOW, CS3/RAS3, CS2/RAS2, CS1/RAS1, CS0/RASO
to output mode.

PMC9 Sets HLDRQ to input, and each of HLDAK, OE, BCYST, WE,
RD, UWR/UCAS, LWR/LCAS to output mode.

PMCX Sets CLKOUT to output, WAIT to input, REFRQ to output
mode.

<When |IE-V850E-MC(-A) is used> (Operation mode of device is single-chip mode 0)

Register Name Setting

When device is used with IE-703116-MC-EM1

PMCAH Sets A25 to A16 to output mode

PMCAL Sets A15 to AO to output mode

PMCDL Sets D15 to DO to output mode

PMCCS Sets each CS7, CS6/RAS6, CS5/IORD, CS4/RAS4, CS3/

RAS3, CS2/IOWR, CS1/RAS1, CSO to output mode.

PMCCT Sets each of BCYST, OE, WE, RD, UCAS/UWR/UDQM,
LRAS/LWR/LQDM to output mode.
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<When IE-V850E-MC(-A) is used> (Operation mode of device is single-chip mode 0)

Register Name

Setting

PMCCM Sets SELFREF to output, REFRQ to output, HLDRQ to input,
HLDAK to output, CLKOUT/BUSCLK to output, and WAIT to
input mode.

PMCCD Sets each of UBE/SDRAS, LBE/SDCAS, SDCLK, SDCKE to

output mode.

When device is used with IE-703116-MC-EM1

PMCAH Sets A25 to A16 to output mode.

PMCAL Sets A15 to A0 to output mode.

PMCDH Sets A25 to A16 to output mode.

PMCDL Sets AD15 to ADO to output mode.

PMCCT Sets ASTB to output, RD to input, UWR to output, and LWR to
output mode.

PMCCM Sets HLDRQ to input, HLDAK to output, CLKOUT to output,

and WAIT to input mode.

When downloading to external memory SDRAM

Register Name

Setting

SDRAM configuration register

SCR1, SCR3, SCR4, SCR6

Refresh control register

RFS1, RFS3, RFS4, RFS6
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Extended Option dialog box

This dialog box is used to display and set the extended options of the debugger.

Figure 7-6 Extended Option Dialog Box

Extended Option
Trace Timetag Count Rate: - [T Add Up Timetae
Timer Count Fate: |1 vI
~RAM Monitor
[+ Realtime Readout
Braa O Whale ) IRAM + IOR
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Redraw Interval: IEEIEI —

Elazh Self Mode: & On (5 O
Break Condition: (& Before (O After ¥ Break Sound
On Mouze Click: & Soft break. € Hard break W' Verify Gheck

0K I Cancel Bestore | Help

]|

This section explains the following items:

* Opening
« Explanation of each area

* Function buttons

Opening

This dialog box can be opened as follows:

« Select [Option] ->[Extended Option...] from the menu bar.
(or press Alt+O, and X in that order.)

Explanation of each area

The Extended Option dialog box consists of the following areas:
(1) Trace Timetag Count Rate (trace time tag counter division ratio selection area)
(2) Timer Count Rate (timer count rate setting area)

(3) Add Up Timetag (total time tag specification area)
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@)
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(4) RAM Monitor (real-time RAM monitor setting area)
(5) Break condition (break mode setting area)

(6) On Mouse Click (default break selection area)

(7) Break Sound (beep sound specification area)

(8) Verify Check (verify specification area)

(9) Flash Self Mode (Flash self mode setting area)

Trace Timetag Count Rate (trace time tag counter division ratio selection area)

Trace Timetag Count Rate: IM - I

This area is used to set the division ratio of the counter used for time tag display in Trace window.

If the division ratio is set, the number of clocks necessary for counting up the counter displayed for time

tag is changed.

The division ratio differs depending on the IE connected.

Connected IE Division Ratio

IE-703002-MC 1(default value), 2, 4, 8, 16, 32, 64, 128, 256, 512, 1K, 4K,
8K,16K, 64K, 256K, 1M

IE-703102-MC, IE-V850E-MC or | 1(default value), 2, 4, 8, 16, 32, 64, 128, 256, 512, 1K, 2K, 4K,
IE-V850E-MC-A, 8K, 16K, 32K, 64K, 128K, 256K, 512K, ,1M, 2M, 4M, 8M,
IE-V850ES-G1 16M, 32M, 64M, 128M, 256M, 512M, 1G, 2G

Timer Count Rate (timer count rate setting area)

Timer Count Rate: |1 - I

This area is used to set the timer count rate.
The rate may be 1 (default), 2, 4, 8, 16, or 32.
Note that if IE-703102-MC is used, "32" is not displayed by the restriction of the in-circuit emulator

Add Up Timetag (total time tag specification area)
[ &dd Up Timetag

This area is used to specify whether time tags of trace data are totaled or not.

This check box is not checked by default, and the time tags are not totaled.
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(4) RAM Monitor (real-time RAM monitor setting area)

~ RAM Monitor
[+ Realtime Readout
. O ihale 3 IRAM + 1OR
Start Address: IUXHEDUD
Redraw Interval: 500 Mmsec

Realtime Readout (dummy real-time RAM monitor specification)
Specifies whether the RAM is monitored in real time or dummy real time (refer to"Real-Time RAM

Sampling Function™).

Checked Monitors the RAM in real time (default).
Specify a start address in Start Address.

Not checked Monitors the RAM in dummy real time.
Specify a sampling range in Area.

Area (real-time RAM sampling range specification)
Specify the address range in which dummy real-time RAM sampling is to be performed.
The variables and data allocated to this range can be displayed in close to real time in the Watch

window and Memory window.

Whole Whole memory space.
If this is specified, the user program is stopped for a long time if many
windows are open because the ranged memory read is wide.

IRAM+IOR Internal RAM area and peripheral 1/O register area

Start Address (real-time internal RAM sampling range specification)

Specify the start address of real-time internal RAM sampling.

For the range in which real-time sampling can be performed, refer to "Table 7-7 Address Range and
Valid Size".

The variables and data allocated to this range can be displayed in close to real time in the Watch
window and Memory window.

The address range, valid size, and start address are as follows:

Table 7-7 Address Range and Valid Size

Connected ID Area Valid Size Alignment of Start
Address
IE-703002-MC, or IE- Internal RAM only 1KB 1 KB alignment
703102-MC
IE-V850E-MC or |E- Unlimited 1KB 1 KB alignment
V850E-MC-A,or IE-
V850ES-G1

Redraw Interval (real-time internal RAM sampling time specification)
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This area is used to specify the sampling time (msec) for real-time internal RAM sampling.

Any 1 KB in the internal RAM area can be sampled in real time during emulation (the display range is
specified by Start Address).

The variables and data allocated to this range can be displayed in close to real time in the Watch
window and Memory window.

The sampling time can be specified in a range of 0 to 65500 and in units of 100 msec. If 0 is specified,

or if this area is blank, the sampling time is not displayed in real time.

Break condition (break mode setting area)

Break Condition: (% Before 0 Afrer
This area is used to select whether a break occurs before or after the instruction of a breakpoint is
executed. This setting affects only hardware breaks. This area is invalid if the IE-V850E-MC or IE-

V850E-MC-A is connected.

Before Sets a Run event as an event before executing (default).
The event occurs before the instruction is executed.

After Sets a Run event as an event after executing.
The event occurs after the instruction is executed.

On Mouse Click (default break selection area)

On Mouse Click: (% Soft break € Hard break
This area is used to select whether a software breakpoint or hardware breakpoint is set as the default
breakpoint if a breakpoint is set in the point mark area by clicking the mouse button in the Source

windowor Assemble window.

Break Sound (beep sound specification area)

[¥ Break Sound
This area is used to specify whether a beep sound is issued upon the occurrence of a break.

If the check box is checked, a beep sound is issued when a break occurs (default).

Verify Check (verify specification area)

W Werify Check

This area is used to specify whether a verify check is performed when data has been written to
memory.

If the check box is checked, a verify check is performed when download, memory fill, or memory copy
is executed (default). A verify check is also performed when a variable or data is changed in Watch

window or Memory window and is written to memory.
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(9) Flash Self Mode (Flash self mode setting area)

Elazh Self Mode: O On & Off

This area is used to set the flash self mode (default: Off).
In the flash self mode, since one access event, one execution event, and one event link are reserved,
the number of the events which can be used decreases.

When "On" is checked, all events will once become invalid, if at least one event is valid.

Function buttons

OK Validates the settings and closes this dialog box.

Cancel Cancels the settings and closes this dialog box.

Restore Restores the previous settings before this dialog box was opened.
Help Opens the Help window.
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Debugger Option dialog box

This dialog box is used to display and set the extended options of the debugger.

Figure 7-7 Debugger Option Dialog Box

rSource Path ~Tab Zize
Base: BX¥=samplel¥ Extension: I** LI
Browse... | Tab Size: [ 2 I 4 fry g
rDefault Extension Tab List: :z g &dd
Source File: I*'C;*'S .= ]
Delete |
Load Module: I*.out
- - —Startup Routine
~COpen File Histary Fant Begin lsbel [ start
e e =
Mz Mumber @ - 100 | Font.. | End label I_startend
r~ Project File maind label: I_main
Aarta Save: 0 On 0 Off & Query — Disfssambla
Auta Load: = On * Off Show Offset: [ Label [V Mnemonic
Load Project File: Register Mame: % Function Mame
I Broweze.. 0 Absolute Mame
r~ Toal Bar Piztures Kanji Watch Default
Size: Radix
{ Pictures and Tesxt % Sjis 2= |Byie LI - IHex LI
Show YWariable Type: 0N & Off
% Pictures only {7 Euc
Languags: = ) ASM
Ok I Cancel I Beasztore | Help

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [Option] -> [Debugger Option...] from the menu bar
(or press Alt+O, and G in that order).

Explanation of each area

The Debugger Option dialog box consists of the following areas:
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(1) Source Path (source path specification area)

(2) Default Extension (default extension specification area)
(3) Open File History (open file history setting area)

(4) Font (display font setting area)

(5) Project File (project file setting area)

(6) Tool Bar Pictures (toolbar display button setting area)
(7) Kanji (Kanji code setting area)

(8) Tab Size (tab size setting area)

(9) Startup Routine (start-up symbol setting area)

(10) DisAssemble (offset display setting area)

(11) Watch Default (watch symbol setting area)

Source Path (source path specification area)

Source Path
Basze: B¥sample2¥

Browse... |

This area is used to specify the directory in which a source file or text file is searched.

A path can be input from the keyboard or set by the <Browse...> button. A relative path can also be
specified.
The directory that is the basis of a relative path is displayed on the right of Base:. The base directory is

determined in the following sequence:

« Directory to which the project file has been loaded
« Directory to which a load module or hex file has been loaded last

 Current directory of Windows

To delimit paths, use ";" (semicolon) or "," (comma).

Japanese characters can be specified in a source path (Japanese version only).

Example: If a source is in the following directory

B:\src

C:\asm

The source path is specified as follows:

B:\src; C:\asm

Clicking the <Browse...> button displays the Add Source Path dialog box shown in Figure 7-8, and a

source path can be added.

Reference Immediately after the Debugger Option dialog box has been opened, the base directory is

selected and opened

If the selected directory has already been set for the source path, a source path is not added.
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Figure 7-8 Add Source path Dialog Box

Add Source path

Folder:

-2 (B -]
+ D 0 MmO

3 ddwin

D GIFConstructionSet

D helptohtml

D My Documents

|:| Mec—fm

|:| nectools32

|:| pdosro

% Reoycled

]2

|:| Sample_o ;I

0] I Cancel |

+

+

+

+

+

(2) Default Extension (default extension specification area)

Default Extension

Source File: I*-C:*-S

Load Madule: I*_.:.ut

Delimit extensions with " " (blank),";" (semicolon) or "," (comma).

Source File Set the extension of a source file that is displayed when the Browse
dialog box is opened by selecting [File] -> [Open...] from the menu
bar.

The default extension is "*.C, *.S".

Load Module Set the extension of a load module that is displayed when Download
dialog box is opened.
The default extension is "*.OUT".

(3) Open File History (open file history setting area)

Open File History
’7 Max Mumber @0 - 100 |4 _:l

This area is used to set the number of histories (0 to 10) of the open file displayed in the bottom field of
the [File] menu. If 0 is set, no history is displayed on the menu.

The default value is 4.
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(4) Font (display font setting area)

Fant —————
’7 Font... |

This area is used to specify the font displayed on the Source window. Clicking the <Font> button

opens the Font dialog box in which the font to be displayed and its size can be set.

(5) Project File (project file setting area)

~ Project File
Auto Save: £ On 0 Off % Cluery
Suto Load: 1 0n 0 Off

Load Projzct File:
I Browasa... |

This area is used to set automatic saving and loading of the project file.

Auto save

Sets whether the project file is automatically saved at the ID850 termination.

On Automatically saves the project file at the ID850 termination.
Off Does not automatically save the project file at the ID850 termination.
Query Displays the Exit Debugger dialog box at the ID850 termination
(default).
Auto Load

Sets whether the project file is automatically loaded at the ID850 start up.

On Automatically loads the project file at the ID850 start up.
Sets whether the Load Project File is automatically loaded

Off Does not automatically loads the project file at the ID850 start up.
(default)

Load Project File

Specify the project file to be loaded automatically.

This item can be specified only when On is specified for Auto Load.

Set a project file name by inputting from the keyboard or clicking the <Browse...> button. Clicking the

<Browse...> button displays Browse dialog box.
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(6) Tool Bar Pictures (toolbar display button setting area)

Tool Bar Pictures

{7 Pictures and Text

{* Pictures only

This area sets the buttons to be displayed on the toolbar.

Pictures and Text Displays a button on which a graphic and character are displayed.

Pictures only Displays a button with only graphic (default).

(7) Kanji (Kanji code setting area)

Eanmp
% Sjis
{7 Euc

This area is used to specify Kanji codes to be displayed in the Source window and Trace window.

Kaniji codes can be specified only on the Japanese Windows.

Sjis Uses SJIS as Kaniji codes (default).

Euc Uses EUC as Kaniji codes.

(8) Tab Size (tab size setting area)

~Tab Size
Extension: I** LI
Tab Size: 2 4 o35
Tab List  [** 8
ab Li= ¥ g 44
*.= g
Delate |

This area is used to set the tab size for each extension when files are displayed.

Extension

Set an extension. Input an extension from the keyboard, or select one from the drop-down list.
Tab Size

Select the tab size. Select how many spaces are displayed as a tab code.

2 Displays two spaces.
4 Displays four spaces.
8 Displays eight spaces.
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Tab List

Displays the tab size set for each extension.

To change the tab size setting,

select Extension and Tab Size and click the <Add> button.

The selected tab size is changed to the tab size set in Extension.

To delete the tab size setting,

select the setting to be deleted from Tab List and click <Delete> button.

The setting of the extension currently selected will be deleted.

(9) Startup Routine (start-up symbol setting area)

Startup Foutine

Begin labeal: I_start

End label: I_startend

maini) label: I_main

This area is used to specify the first address and end address of the text area (code area) of the start-
up routine by symbols.

Specify the symbol of the first address as Begin label, and the symbol of the last address as End label.
In this way, the source file can be automatically opened if an object file in the load module format is
downloaded in Download dialog box. Specify the source file to be displayed at this time as main()
label, as a display start symbol.

If the specified symbol is not correct, the source file cannot be opened until the PC reaches the
address range of the corresponding source file. In addition, the start-up routine cannot be skipped by

step execution.

Begin label Symbol of first address (default: _start)
End label Symbol of end address (default: _startend)
main() label Display start symbol (default: _main)

Caution  Be sure to specify this area. If this area is blank, the dialog box cannot be closed.

(10) DisAssemble (offset display setting area)

Distzsemble
Shaow Offzet: [T Lsbel W Mnemonic

Fegister Mame: & Function Mame

) Absolute Mame

Performs the setting for disassemble display.

Show Offset

Specifies whether an offset (symbol + offset) is displayed during disassemble display.

When the offset is not displayed, only a symbol that matches a numeric value is displayed, if any. If no

matching symbol is found, the numeric value is displayed as a hexadecimal number unchanged.
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Label Specifies whether the offset is displayed in the Label field.
This check box is not checked in the default condition, and the offset
is not displayed.

Mnemonic Specifies whether the offset is displayed in the Mnemonic field.

This check box is checked in the default condition, and the offset is

displayed.

Register Name (register name display selection area)

This area is used to select the method of displaying register names in mnemonics during disassemble

display.

Function Name

Displays register names as function names or nicknames.

Absolute Name

Displays register names as absolute names.

(11) Watch Default (watch symbol setting area)

Watch Default

Size: IB':-"tE vI Radix: IHEX vI

©on O
(O 0 A%

Show Wariable Type:

Language:

This area is used to specify a symbol to be watched.

Size (default size specification)

Sets the display size of data if [Adaptive] is selected in Watch window.

Byte 8-bit display(default)
Half Word 16-bit display
Word 32-bit display

Radix (default radix specification)

Sets the default radix in which data is to be displayed if [Proper] is specified in Watch window.

Hex Displays data in hexadecimal numbers (default).
Dec Displays data in decimal numbers.

Oct Displays data in octal numbers.

Bin Displays data in binary numbers.

String Character string

Show Variable Type (display/non-display of variable type)

Selects whether the type of a variable is displayed or not.

On

Displays the type of a variable.
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Off

Does not display the type of a variable (default).

Language (display/non-display of type of variable)

Selects the display format of the base number.

With the V800, the display format is fixed to C-like and cannot be selected.

Displays a C-like base number (default).

ASM

Displays an assembly language-like base number.

Function buttons

OK Validates the settings and closes this dialog box.

Cancel Cancels the settings and closes this dialog box.

Restore Restores the previous settings before this dialog box was opened.
Help Opens the Help window.
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Font dialog box

This dialog box is used to select the font to be displayed in the Source window.

Figure 7-9 Font Dialog Box

Sample

AaBbCc

Font

Font Face: Size: oK
8

Courier - 4 j Cancel
T Courier New 5

Fixedsys Fi

10
- |11 [+

This section explains the following items:

» Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

* Click the <Font> button in Debugger Option dialog box.

Explanation of each area

The Font dialog box consists of the following areas:
(1) Font Face: (font name specification area)
(2) Size: (font size specification area)

(3) Sample (sample display area)
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(1) Font Face: (font name specification area)

Font Face:

erminal

Courier -
T Courier New
Fixedsys

This area is used to select a font from the fonts currently usable.
Only fonts with equal width (fonts with a constant stroke width and a fixed pitch) are enumerated.
When a font name is selected from the list, the font name is displayed in the text box, and the font size

that can be used with that font is displayed under Size.

(2) Size: (font size specification area)

Size:

[==]

o

- |

=/ LT

10

1 |[+]

This area is used to specify the font size.

On the drop-down list, the font size usable for the font specified in Font Face is displayed in point units.
When the font size is selected from the drop-down list, the selected font size is displayed in this area.

The font size can also be directly input to the text box from the keyboard.

(3) Sample (sample display area)

—Sample

RaBhCrc:

This area displays a sample character string of the specified font and size.

Function buttons

OK Changes the font and its size in the Source window as specified, and closes
this dialog box.

Cancel Closes the dialog box without changing the font.
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Project File Save dialog box

Saves the debug environment.

It is used to save a new project file or an existing file with the file name changed (refer to "Setting

Debugging Environment").
When a file is saved, the size and position of the window that has been displayed are also saved.

Figure 7-10 Project File Save Dialog Box

Save As
Sawe in: IaSample E"
sm32_l::ﬂ|
& sm32_demo
sm32_st
File name: || | Sove I
Save as iype: IPrDjen:’t("‘.prj) E"

The following contents are saved to the project file:

Table 7-8 Contents Saved to Project File

Window Name Set Data

Configuration dialog box All items (target device, clock setting, pin mask setting,
mapping information)

Main window Display position, tool bar/status bar/button display
information, execution mode, information, trace on/off
information, coverage on/off information

Download dialog box File information to be downloaded

Extended Option dialog box, Set information

Debugger Option dialog box

Source window Display information, font information of window
Assemble window, Display information of window, display start address

Memory window
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Table 7-8 Contents Saved to Project File

Window Name Set Data
Stack Trace window, Display information of window
IOR window,
Local Variable window,
Trace window,
Event Manager,
Coverage window,
Console window,
Expansion window
Event dialog box Display information of window, event information
Event Link dialog box Display information of window, link event information
Break dialog box Display information of window, break event information
Trace window Display information of window, trace event information
Snap Shot dialog box Display information of window, snap event information
Stub dialog box Display information of window, stub event information
Timer dialog box Display information of window, timer event information
Register window Display information of window, display bank information
Watch window Display information of window, watch registration information
Add 1/0 Port dialog box Added 1/O port information
DMM dialog box DMM information
Delay Count dialog box Delay count value
Software Break Manager Display information of window, software break information

This section explains the following items:

« Opening

« Explanation of each area
¢ Function buttons

« Related operations

« To automatically save a project file

Opening

This dialog box can be opened as follows:

« Select [Eile] -> [Project] -> [Save As...] from the menu bar
(or press Alt+F, J and A in that order).

To save afile of same name as a project file previously loaded or saved

 Select [Eile] -> [Project] -> [Save...] on the menu bar
(or press Alt+F, J and S in that order).
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Explanation of each area

The Project File Save dialog box consists of the following areas:

(1) Save in:, File name: (file selection area)

(2) Save as type: (extension selection area)

(1) Savein:, File name: (file selection area)

This area is used to specify a file name. A file name can be directly input from the keyboard, or

selected from the list at the upper part of this area.

Up to 64 character string with a extension can be specified.

(2) Save as type: (extension selection area)

This area is used to specify the extension (.PRJ) of the project file to be loaded.

If the extension is omitted, .PRJ is appended as the default extension.

Function buttons

Save Saves the project information to the selected file. After saving, the dialog box is
closed.

Cancel Closes this dialog box without saving the file.

Help Opens the Help window.

Related operations

To automatically save a project file

Use Project File (project file setting area) in Debugger Option dialog box that is opened when [Option]

-> [Debugger Option...] is selected from the menu bar.

Select On for Auto Save in this area. The current environment will be automatically saved to the

project file when the dialog box is closed.
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Project File Load dialog box

This dialog box is used to return the debug environment to the previous environment.

After a file has been loaded, the size and position of the window is returned to the previous status (status

saved to a project file) (refer to "Setting Debugging Environment").

After a project file has been loaded, it is displayed on the top of an active Source window if any.

By loading the project file, the items to be saved in Table 7-8 Contents Saved to Project File are set.

If a project file different from the target device after the debugger has been loaded is loaded,

Caution
the debugger loads the project file after it has been reset (the debugger is then used as the
target device specified by the project file).
Figure 7-11 Project File Load Dialog Box
Open HE
Look in: IaSample
[Z]sm32_cal
sm3Z_demo
sm32_st
File hame: I | Open I
Files of type: IPrDject *.prl EI|

This section explains the following items:

* Opening

« Explanation of each area
* Function buttons
 Related operations

» To automatically load a project file

Opening

This dialog box can be opened as follows:
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« Click the Proj button.

 Select [Eile] -> [Project] -> [Open...] on the menu bar
(or press Alt+F, J and O in that order).

Explanation of each area

The Project File Load dialog box consists of the following areas:

(1) Look In:, File name: (file selection area)

(2) Files of type: (extension selection area)

(1) Look In:, File name: (file selection area)

This area is used to specify a file name. A file name can be directly input from the keyboard, or

selected from the list at the upper part of this area.

Up to 64 character string with a extension can be specified.

(2) Files of type: (extension selection area)

This area is used to specify the extension (.PRJ) of the project file to be loaded.

Function buttons

Open Loads the selected file. After loading the file, this dialog box is closed.
Cancel Closes this dialog box without loading the file.
Help Opens the Help window.

Related operations

To automatically load

a project file

Use Project File (project file setting area) in Debugger Option dialog box that is opened when [Option]

-> [Debugger Option...] is selected from the menu bar.

Select On for Auto Load in this area and specify the name of the project file to be loaded automatically

in the Load Project File area. The specified project file will be automatically loaded when the system is

started next time.
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View File Save dialog box

This dialog box is used to save the contents of the current window to a view file or event setting file when

a dialog box is opened.

Figure 7-12 View File Save Dialog Box
View File Save Dialog Box (Example: to Save Assemble Window)

Save As E
Save in: IESample \L" %

File name: I | Sawve

Sawve as type: IMemDry *.rmem) |L|| Cancel

Help

Save range Bestore
O Al

® Screen shot

0O Specify Address | — I

Hid

This section explains the following items:

* Opening
» Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

* When the window to be saved is the current window
Select [Eile] -> [Save As...] from the menu bar
(or press Alt+F and A in that order).
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Explanation of each area

This dialog box consists of the following areas:
(1) Save in:, File name: (file selection area)
(2) Save as type: (extension selection area)

(3) Save range (save range setting area)

(1) Savein:, File name: (file selection area)
This area is used to specify a file name. A file name can be directly input from the keyboard, or

selected from the list at the upper part of this area.
(2) Save as type: (extension selection area)

This area is used to specify the type (extension) of the file.

The extension of the file corresponding to the current window is displayed as follows:

Table 7-9 Extension Corresponding to Current Window

File Type (Extension) Current Window Name

Source Text (*.SVW) Source window

Assemble (*.DIS) Assemble window

Memory (*.MEM)

Memory window

Watch(*.WCH)

Watch window

Register (*RGW)

Register window

1/0 Register (*.I0R)

IOR window

Local Variable (*.LOC)

Local Variable window

Stack Trace (*.STK)

Stack Trace window

Trace (*.TVW)

Trace window

Coverage (*.COV)

Coverage window

Event(*.EVN)

Event Manager

Console (*.LOG)

Console window

All (*¥)

All files

(3) Saverange (save range setting area)

Save range
Al
% Screen shot

" Specify Address

This area is displayed if the current window to be saved is the Assemble window, Memory window,

Coverage window, Source window, or Trace window.
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Specify the range of data to be saved by selecting any of the following:

All Saves the entire range, from the first line to the last line.

Screen shot Saves the area visible on the screen, from the top line on the screen to
the bottom line. If the Source window is in the mixed display mode,
however, the window contents are saved from the source line that
includes the area visible on the screen.

Specify Line Specify the start line and end line of the area to be saved. If the start line
Specify Frame and end line are omitted, the first line and last line are assumed. For
Specify Address details, it is as follows.

above any

Specify Line (if current window is Source window)

{* Specify Line 1 | 1000
Specify the range of the line numbers to be saved. The default radix for inputting a numeric value is
decimal.

If the Source window is in the mixed display mode, the mixed displayed part on the specified line is

also saved.

If a range of 100 lines or more is specified, a message dialog box is displayed to indicate the progress

of saving. To stop saving midway, click the <Stop> button in the message dialog box.

Specify Frame (if current window is Trace window)

& Specify Frame 0 | 1000

Specify the range of trace frames to be saved (for how to specify, refer to "Trace Move dialog box").
The default radix for inputting a numeric value is hexadecimal.
If a range of 100 frames or more is specified, a message dialog box is displayed to indicate the

progress of saving. To stop saving midway, click the <Stop> button in the message dialog box.

Specify Address (if current window is Assemble window, Memory window, or Coverage window)

{* Specify Address 0 . noooft

This area is used to specify the address range in which data is to be saved to the file. An address can
be also specified by a symbol or expression (refer to "Table 7-15 Specifying Symbols"). The default
radix for inputting a numeric value is hexadecimal.

If a range of 256 bytes or more is specified, a message dialog box is displayed to indicate the progress

of saving. To stop saving midway, click the <Stop> button in the message dialog box.
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Function buttons

Save Saves the information of the current dialog box to the selected file. After
saving, the dialog box is closed.

Cancel Closes this dialog box without saving the file.

Help Opens the Help window.

Restore Restores the status before this dialog box was opened.
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View File Load dialog box

This dialog box is used to read the view file, source file, text file, event setting file, watch setting file, or
peripheral I/O register setting file saved in the View File Save dialog box, and open a window.

The window to be opened and its status differ as follows, depending on the file to be loaded.

Loading source file to which symbol information has been read

If there is a Source window in the active status, it is opened in the static status; otherwise, the Source

window is opened in the active status.

Loading source file to which symbol information has not been read, or view file

A window of text-format files is opened in the Source window in the static status.

Loading event setting file
The Event Manager is opened, and the event setting contents will return to the previous environment.

Loading watch setting file
The Watch window is opened, and the watch setting contents will return to the previous environment.

Loading peripheral I/O register setting file
The IOR window is opened, and the peripheral 1/O register setting contents will return to the previous

environment.

Figure 7-13 View File Load Dialog Box

Open HE|
Lookin: Ia Sample
Demo.c
startup.s
File name: I | Open I
Files of type: ISDuru:e [*o*s) E"

This section explains the following items:

* Opening

« Explanation of each area
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¢ Function buttons

Opening

This dialog box can be opened as follows:

 Click the Open button.

« Select [Eile] -> [Qpen...] on the menu bar
(or press Alt+F and O in that order, or press Ctrl+0O).

Explanation of each area

This dialog box consists of the following areas:

(1) Look In:, File name: (file selection area)

(2) Files of type: (extension selection area)

(1) Look In:, File name: (file selection area)

This area is used to specify a file name. A file name can be directly input from the keyboard, or

selected from the list at the upper part of this area.

Up to 64 character string with a extension can be specified.

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be loaded.

Table 7-10 Type of File That Can Be Loaded on View File Load Dialog Box

File Type (Extension)

Meaning

Source (*.C, *.S)

Source file
The extension of the source (c, s) can be changed in
Debugger Option dialog box.

Text (*. TXT)

Text file

Source Text (*.SVW)

Source windowView files

Assemble (*.DIS)

Assemble window view files

Memory (*.MEM)

Memory window view files

Watch (*.WCH)

Watch window setting files

Register (*.RGW)

Register window view files

1/0 Register (*.I0R)

IOR window setting files

Local Variable (*.LOC)

Local Variable window view files

Stack Trace (*.STK)

Stack Trace window view files

Trace (*. TVW)

Trace window view files

Coverage (*.COV)

Coverage window view files

User's Manual U16217EJ1VOUM

115



CHAPTER 7 WINDOW REFERENCE

Table 7-10 Type of File That Can Be Loaded on View File Load Dialog Box

File Type (Extension) Meaning
Event (*.EVN) Event setting file
Console (*.LOG) Console window
All (*.*) All files

Function buttons

Open Loads the selected file. After loading the file, this dialog box is closed.
Cancel Closes this dialog box without loading the file.
Help Opens the Help window.
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Download dialog box

This dialog box is used to select the name and format of a file to be downloaded, and downloads memory

contents or coverage results to the in-circuit emulator or the target.

If an object file in the load module format has been downloaded, the corresponding source file is

searched, and Source window is automatically opened.

Up to 20 load module files can be downloaded.

To check the loaded files, use Load Module List dialog box that is opened when [File] -> [Load Module] is

selected from the menu bar.

Format of file that can be downloaded

* NEC load module format (ELF (.OUT))

« Intel Hex format (standard, extended)

» Motorola Hex format S type (SO, S2, S3, S7, S8)

* Extended Tektronix Hex format

 Binary data format

« Coverage result

Caution If a file other than an object file in the load module format is loaded, source debugging cannot

be executed.

Figure 7-14 Download Dialog Box

N - |
Look in: |3 Sample K
demo._out
File name: || | Open I
Files of type: ILDEI.CI hModule (*.out) IL"
Symbol Symbol
Chject 1 CcPU Offset Address: D
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This section explains the following items:

Opening

Opening

Explanation of each area

Function buttons

Cancel processing

This dialog box can be opened as follows:

¢ Click the Load button.

« Select [Eile] -> [Download...] on the menu bar
(or press Alt+F, and D in that order).

Explanation of each area

@)

)

1)
)
®)
(4)
©)

Look In: , File name: (file selection area)
Files of type: (extension selection area)
Offset Address: (offset setting area)

Load (load condition specification area)

Reset (reset condition specification area)

Look In: , File name: (file selection area)

This area is used to specify a file name. A file name can be directly input from the keyboard, or

selected from the list at the upper part of this area.

Two or more files can be specified in this dialog box. To specify two or more files, delimit each file

name with " " (double quotation mark). Files can also be specified by clicking the mouse button while

holding down the Shift or Ctrl key.

Up to 64 character string with a extension can be specified.

Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be downloaded.

The contents displayed on the drop-down list are as follows:

Table 7-11 Type of File That Can Be Downloaded

Contents (extension) Format
Load Module(*.OUT) Load module format
Hex Format(*.HEX) Hex format (automatic format identification)
Binary Data(*.BIN) Binary data format
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Table 7-11 Type of File That Can Be Downloaded

Contents (extension) Format

Coverage (*.CVB) Coverage result

Reference These are default extensions; other extensions can also be used.
The default extension of the displayed load module can also be specified under Default

Extension (default extension specification area) in Debugger Option dialog box.

(3) Offset Address: (offset setting area)

Offset Address: I 0

This area is used to specify the offset address that is used when a file is loaded (for binary data,
specify the start address). An address can be also specified by a symbol or expression (refer to "Table

7-15 Specifying Symbols"). The default radix for inputting a numeric value is hexadecimal.

(4) Load (load condition specification area)

Load
W Symbol
W Ohject

This area is used to set a load condition.

This setting is valid only if a file in the load module format is specified.

Symbol Specifies whether symbol information is read (when checked, default) or not.
The memory capacity can be saved by not reading symbol information when a
program consisting of two or more load module files is to be debugged and if the
symbol information of some modules does not have to be read.

Object Specifies whether object information is read (when checked, default) or not.

(5) Reset (reset condition specification area)

Feset
I+ Symbol
[ cpPu

This area is used to set a reset condition.

This setting is valid only if a file in the load module format is specified.
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Symbol Specifies whether symbol information is reset (when checked, default) or not.
When debugging a program consisting of two or more load module files, load
each one of the load module files without resetting the symbol information.
When downloading two or more load module files, take care that location
addresses do not overlap.

CPU Specifies whether the CPU is reset or not (not checked, default).

Function buttons

Open Loads the selected file. After loading the file, this dialog box is closed.
Cancel Closes this dialog box without loading the file.

Help Opens the Help window.

Restore Restores the input data to the original status.

Cancel processing

The following dialog box appears while downloading and the downloading can be cancelled at any time.
The progress of the download is displayed in the dialog box.
This dialog box is closed automatically after completing downloading.

If an error occurs during the download, an error message will be displayed in a new window.

Figure 7-15 The Progress of Download

data: loading...
gvmbol: loading...

Cancel
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Upload dialog box

This dialog box is used to set the name and format of the file to which memory contents or coverage

results are to be saved.

Format of specifiable file

Intel Hex format (extended ... 20-bit address)

* Motorola Hex format (SO, S3, S7 ... 32-bit address)
» Extended Tektronix Hex format

 Binary data format

« Coverage result

Figure 7-16 Upload Dialog Box

N - |
Sawve in: |53 Sample =
=] demo_hex
File name: | | save |
Save astype:  |Intel Hex (“hex) Ed|
Save Address: | 0 | _ I 0 |

This section explains the following items:

» Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:
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« Select [Eile] -> [Upload...] on the menu bar

(or press Alt+F, and U in that order).

Explanation of each area

The Upload dialog box consists of the following areas:

@)

)

(1) Save in:, File name: (saved file name specification area)
(2) Save as type: (extension selection area)

(3) Save Address: (save range setting area)

Save in:, File name: (saved file name specification area)
This area is used to specify a file name. A file name can be directly input from the keyboard, or
selected from the list at the upper part of this area.

Up to 64 characters can be specified including the extension.

Save as type: (extension selection area)

This area is used to specify the type (extension) of the file. The format of the data to be saved to the

file is determined by the extension.

If "All (*. *)" is selected, however, the default Intel extended Hex format is selected. The contents

displayed on the drop-down list are as follows:

Table 7-12 Type of File That Can Be Uploaded

Contents (extension) Format
Intel Hex (*.HEX) Intel extended Hex format
Motorola Hex (*.HEX) Motorola Hex format
Tektro Hex (*.HEX) Extended Tektronix Hex format
Binary Data (*.BIN) Binary data format
Coverage (*.CVB) Coverage result
All (*.%) All files

Reference These are default extensions; other extensions can also be used.

(3) Save Address: (save range setting area)

Save Address: 1] .10

This area is used to specify the address range in which data is to be saved to the file. An address can
be also specified by a symbol or expression (refer to "Table 7-15 Specifying Symbols").

The default radix for inputting a numeric value is hexadecimal.
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Function buttons

Save Saves data in the specified address range to the specified file and closes this
dialog box.
Closes this dialog box. The font of the Source window is changed to the
specified font face and font size, and then the dialog box is closed

Cancel Closes this dialog box without saving the data to the file.

Help Opens the Help window.

Restore Restores the input data to the original status.
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Load Module List dialog box

This dialog box can be used to check the file name and file path name of a load module that has already

been downloaded. By using the <Download> button, The Download dialog box can be opened and a load

module can be downloaded.

Figure 7-17 Load Module List Dialog Box

Load madule list

Module list ’
Ma. | File name Help |
1 sample.out

[ Add Path

Dovenload.. |
K ]

This section explains the following items:

* Opening
« Explanation of each area

« Function buttons

Opening

This dialog box can be opened as follows:

« Select [Eile] -> [Load Module...] on the menu bar
(or press Alt+F, and L in that order).

Explanation of each area

The Load modaule list dialog box consists of the following items:
(1) Module list (file name display area)

(2) Add Path (path name addition check box)
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(1) Module list (file name display area)

Module list

=% | File name
1 zample.out

K E— ]

This area displays the names of the load module files that have already been downloaded.

The numbers displayed in the "No." field indicate the sequence in which the load module file names

were read. The file names are displayed with the full path if the path name addition check box is

checked; otherwise, only the file names will be displayed.

If the file names do not fit in the screen, the screen can be scrolled by using the mouse or the arrow

keys of the keyboard. If symbol information has been reset in the Reset Debugger dialog box box, or if

symbol information has been reset in the Download dialog box, the load module file names

downloaded before that are cleared.

(2) Add Path (path name addition check box)

[ Add Path

This area is used to specify whether load module file names are displayed with the path (checked) or

only file names are displayed (not checked, default) in the file name display area.

Function buttons

Close Closes this dialog box.
Help Opens the Help window.
Download... Opens Download dialog box.

A new load module can be downloaded. The file name of the newly
downloaded module will be added to the file name display area when the
Download dialog box is closed.

User's Manual U16217EJ1VOUM

125



CHAPTER 7 WINDOW REFERENCE

Browse dialog box

This dialog box is used to select the file to be set in the Source Search dialog box or the Source Text

Move dialog box.

Reference If this dialog box is opened for the first time after the system has been started up, the
directory first specified by the source path is displayed. When the dialog box is opened the
second and subsequent times, the previously displayed directory is recorded and displayed

again. If the <Cancel> button is pressed, however, the previously displayed directory is not

recorded.
Figure 7-18 Browse Dialog Box
Browse

Look in: IaSample lll'

Demo.c

startup.s

File name: I | Open I
Files of type: ISDurc:e *.c*s) E"

This section explains the following items:

» Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

* Click the <Browse...> button in the Source Search dialog box or the Source Text Move dialog box.
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Explanation of each area

The Browse dialog box consists of the following areas:

(1) Look In:, File name: (file selection area)

(2) Files of type: (extension selection area)

(1) Look In:, File name: (file selection area)

This area is used to specify a file name. A file name can be directly input from the keyboard, or

selected from the list at the upper part of this area.

Up to 64 character string with a extension can be specified.

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be opened.

Table 7-13 Type of File That Can Be Displayed in Browse Dialog Box

File Type (Extension)

Meaning

Source (*.C, *.S)

Source file

The extension of the source (c, s) can be changed in Debugger Option

dialog box.
Text(*.TXT) Text file
All(*.%) All files
Function buttons
Open Sets the selected file. After setting the file, closes this dialog box.
Cancel Does not set the file and closes this dialog box.
Help Opens the Help window.
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Address Move dialog box

This dialog box is used to specify the address from which displaying memory contents, results of
disassembly, results of coverage, or I/O registers are to be displayed. This dialog box is displayed if [View]
-> [Move] is selected from the menu bar while the Memory window, the Assemble window, the Coverage

window, or the IOR window is opened, and enables the display start address of data to be changed.

Figure 7-19 Address Move Dialog Box
(Example: When Memory Window Is Open)

e mory

Address

Ta: IE LI
(8] 4 I Cancel I Eestnrel Help |

This section explains the following items:

« Opening
« Explanation of each area

« Function buttons

Opening

This dialog box can be opened as follows:

When the Memory window, Assemble window, Coverage window, or IOR window is opened

¢ Select [View] -> [Move...] from the menu bar
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Address Move dialog box consists of the following areas:

(1) To (address specification area)

(1) To (address specification area)

T [ =]
This area is used to specify an address. In the default condition, the string selected in the window that

called this dialog box, the current PC value (Memory window, Assemble window, Coverage window),
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or blank (IOR window) is displayed.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying
Symbols"). The default radix for inputting a numeric value is hexadecimal.

By displaying the input history, the contents previously input can be reused.

Up to 16 input histories can be recorded.

Function buttons

OK Displays the memory contents, results of disassembly, results of coverage, or I/O
registers.

Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Source Text Move dialog box

This dialog box is used to specify a file to be displayed in the Source window and the position from which
displaying the file is to be started.
This dialog box is selected if [View] -> [Move...] is selected from the menu bar while the Source window is

open, and enables the display start position of a file to be changed (a new window is not opened).

Figure 7-20 Source Text Move Dialog Box

SourceText m |

Option
|7 {7 Addres=/Symbal

= Line/Filz File: Browsze... |

Te: main.c#50 LI

Ok I Cancel I Eestnrel Help |

This section explains the following items:

« Opening

« Explanation of each area

« Specifying
« Specifying a display start position by an address (or symbol).
« Specifying a file to be displayed in the Source window

¢ Function buttons

Opening

This dialog box can be opened as follows:

When the Source window is active

« Select [View] -> [Move...]
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Source Move dialog box consists of the following areas:
(1) Option (input mode selection area)

(2) To (file/address specification area)
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(1) Option (input mode selection area)

~Option
7 Address/ Symbol

% Line/File File: Browse.. |

This area is used to select the input mode when the display start position is specified.

Address/Symbol If the display start position is specified by an address (or symbol)

Line/File If the display start position is specified by a line number (or file name)

(2) To (file/address specification area)

This area is used to specify the file name or address to be displayed. In the default condition, the
character string selected in the window that called this dialog box is displayed in this area. If no
character string has been selected, the first character string of the input history is displayed. If no input
history is available, the current PC is displayed. As necessary, the character string displayed in this
area can be changed by directly inputting a character string from the keyboard.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.

Specifying

On this dialog box, the following two items can be specified.

« Specifying a display start position by an address (or symbol).

« Specifying a file to be displayed in the Source window

Specifying a display start position by an address (or symbol).
Select Address/Symbol under Option and specify the address from which display is to be started for
To.
An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying
Symbols"). The default radix for inputting a numeric value is hexadecimal.
Clicking the <OK> button displays the source text so that the source line corresponding to the specified

address value can be viewed.

Specifying afile to be displayed in the Source window
Select Line/File under Option and specify the name of the file to be displayed in the Source window for
To. Specification can be mode using only the file name, or using an absolute path or relative path.
If only the file name is specified, or if a relative path is specified, the files in the directory of the source
path specified in Debugger Option dialog box are sequentially searched. The file that is found first as

a result of searching is displayed.
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In addition to a file name, a line number can be also specified as follows:

<<path name>file name#>line number

Delimit the file name from the line number with "#". Specify the line number in decimal. The file name
may be omitted. The default radix for inputting a numeric value is hexadecimal.

Clicking the <OK> button displays the specified file with the specified line number as the first line. If
the file name omitted, the file being displayed is displayed starting from the specified line. If the line

number is omitted, the file is displayed starting from its first line.

Function buttons

Browse... Opens the Browse dialog box.

OK Starts displaying the source text from the specified position.
Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Trace Move dialog box

This dialog box is used to specify the position from which displaying the Trace window is started.

This dialog box is displayed if [View] -> [Move...] is selected from the menu bar while the Trace window is

open, and enables the display start position of the trace results to be changed.

Figure 7-21 Trace Move Dialog Box

1zt frame of last block

I
i Trigger frame of last block
i Last frame of last block

{* Frame Mo. Last

(8] 4 I Cancel I Eestn:rel

-

Help |

This section explains the following items:

« Opening

« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

When the Trace window is displayed

« Select [View] -> [Move...]

(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Trace Move dialog box consists of the following areas:

(1) Frame selection area

(2) Frame number specification area
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(1) Frame selection area

{7 15t frame of last black
" Trigger frame of last block
{7 Last frame of last black

* Frame Mo La=t -

This area is used to specify the frame at the destination.

1st frame of last block Moves the display start position to the to first frame in the newest
block of trace data. The display start position is moved to the first
frame of the trace data when using an in-circuit emulator without a
block frame.

Trigger frame of last block Moves the display start position to a trigger frame in the newest
block frame of trace data.

Last frame of last block Moves the display start position to the last frame of trace data.

Frame No. Moves the display start position to the specified frame number.

If 0 is specified, the display start position is moved to the first frame
of trace data.

If this item is checked, the focus moves to the text box on the side.

(2) Frame number specification area

% Frame Mo, Last v

This area is used to specify a frame number if Frame No. is selected in the frame selection area. In the
default condition, the character string selected in the window that called this dialog box or "Last" is
selected. As necessary, however, this can be changed by directly inputting a character string from the
keyboard.

The default radix for inputting a numeric value is hexadecimal.

A frame number can also be specified in the following format. The uppercase and lowercase
characters of the input character string are not distinguished. In addition, a frame number can also be

specified in abbreviated form.

Table 7-14 Frame Number Specification Format

Specification Abbreviation Contents

+numeric value None Moves backward (downward on screen) the display start
position from the frame at the cursor by the specified number
of frames (numeric value).

-numeric value None Moves forward (upward on screen) the display start position
from the frame at the cursor by the specified number of
frames (numeric value).

Top (0] Moves the display start position to the first frame of trace
data.
First S Moves the display start position to the first frame of the

current trace block. (Same as when Top is specified when
using an in-circuit emulator without a block frame.)

134 User's Manual U16217EJ1VOUM



CHAPTER 7 WINDOW REFERENCE

Table 7-14 Frame Number Specification Format

Specification Abbreviation Contents

Trigger T Moves the display start position to the trigger frame of the
current trace block.

Last L Moves the display start position to the last frame of the
current trace block. (Same as when Bottom is specified
when using an in-circuit emulator without a block frame.)

Bottom B Moves the display start position to the last frame of trace
data.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.

Function buttons

OK Starts trace display from the specified position.
Cancel Closes this dialog box.

Restore Restores the input data to the original status.
Help Opens the Help window.
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Symbol To Address dialog box

Displays the address of the specified variable or function, or the value of the specified symbol.

Figure 7-22 Symbol To Address Dialog Box

Symbol To Address

Symbaol: I

Radiz: % Hex & Dec 0t & Bin

Ok I Cancel Restare |

belp |

This section explains the following items:
« Opening

« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [View] -> [Symbol...] from the menu bar
(or press Alt+V and Y in that order).

Explanation of each area

The Symbol To Address dialog box consists of the following areas:

(1) Symbol: (symbol specification and conversion result display areas)

(2) Radix (display radix specification area)

(1) Symbol: (symbol specification and conversion result display areas)

Symbaol: I

-
|

The upper area (symbol specification area) is used to specify the variable, function name, symbol
name, or line number to be converted.

In addition, an 1/0O port name, peripheral I/O register name, register name, PSW flag name, or
expression can be also specified.
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In the lower area (conversion result display area), the variable, address of the function, value of the
symbol, address of the line number, or value of the expression specified under Symbol is displayed.
The address value of an I/O port name or peripheral 1/O register name, the register contents of a

register name, or flag value of a PSW flag name is displayed. The specification method is indicated

below.
Table 7-15 Specifying Symbols
Conversion Target Specification Method
Variable var
file#tvar (to specify a static function with file name)
func#tvar (to specify a static function with function name)
file#var (to specify a static function with file name and function name)
Function func
file#func (to specify a static function with file name)
Label label

file#label(to specify a local label with file name)

Line number of source file | prog$file#tvar

file#no
1/0 Port portname
1/0 Register 1/0 regname
Register regname
PSW Flag pswname

Remark var: Variable name, func: Function name, file: File name, label: Label name, bitsym: Bit
symbol name, portname: I/O port name, /O regname: Peripheral /O register name,

regname: Register, pswname: PSW flag name, no: Line number of source file

"#" is used as a separator for file names, variables, function names, and line numbers.

If a specified symbol is not found in the scope, all symbols (static variables, static functions, local
labels) are searched.

In the default status, a symbol name takes precedence. To temporarily change the priority, prefixing
"$" to a symbol gives the priority to a register name.

To specify a load module name when two or more load modules are read, use "$" as a separator to
delimit the load module name from a file name, variable, function name, or symbol name.

In the default condition, the character string selected in the window that called this dialog box is
displayed. As necessary, input data from the keyboard to change the character string. The default
radix for inputting a numeric value is decimal.

To change the contents of the symbol specification area, click the <OK> button. The conversion result
will be displayed in the conversion result display area.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.
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(2) Radix (display radix specification area)

Radiz: % Hex & Dec {7 0ot O Bin

This area is used to specify the radix of the data to be displayed in the conversion result display area.

Hex Hexadecimal number (default).
Dec Decimal number

Oct Octal number

Bin Binary number

Function buttons

OK If the contents of the symbol specification area have been changed, converts
the symbol.

After conversion, closes the dialog box if the contents of the symbol
specification area have not been changed.

Cancel Closes this dialog box.

Restore Restores the input data to the original status.
If the <OK> button has already been clicked, the data is restored to the status
immediately after the <OK> button was clicked.

Help Opens the Help window.
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Source window

This window displays source files or text files.

In Mixed display mode, the program can be disassembled and displayed and online assembly can be

executed while source files are being displayed.

The Source window that is displaying the source file to which symbol information is read may be in two

statuses: Active Status and Static Status.

Caution

If program codes is described in an include file and these codes are included in multiple files,
the line numbers and addresses do not correspond on a one-to-one bases. In such an include
file, function that indicates the correspondence relationship between line numbers and

addresses dose not correctly operate.

Figure 7-23 Source Window
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This section explains the following items:

* Opening

« Explanation of each area

» Breakpoint setting/deletion function
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« Functions often used (right-click menu)
» Function buttons
« Related operations
Concerning display
* Mixed display mode
« To set a source path

« To change the display start position

To display another source file

To specify the default extension of a source file

» To convert a symbol

To specify the symbol of a start-up routine

« To set an opened file history

» To set a beep sound to be issued upon break
» To change the displayed font

« To change the displayed tab size

Concerning operation
« Start function
» Come function
« Program counter setting function
« Jump function
» To change disassembled contents
« Watch function (referencing data value)
« To search in a source program
» To set a default breakpoint
» To set event after execution
» Drag & drop function (line/address)

« Drag & drop function (character string)

Opening

This window can be opened as follows:

« This window is automatically opened if the corresponding source file exists after the download module
file has been downloaded.

¢ Click the Src button.

Select [Browse] -> [Source] from the menu bar
(or press Alt+B, and S in that order).

« Select [Jump] -> [Source] from the menu bar
(or press Alt+J and S in that order, or press Ctrl+U).

« Click the <Open> button with selecting a source file or text file in the View File Load dialog box.
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Explanation of each area

The Source window consists of the following areas:

@)

(1) Point mark area
(2) Current PC mark area
(3) Line number/address display area

(4) Source text display area

Point mark area

—

T

This area displays the Breakpoint setting/deletion function, Event setting status, and Program code.

Breakpoint setting/deletion function

By clicking this area with the mouse, a breakpoint can be set or deleted. Whether a hardware
breakpoint or software breakpoint is to be set or deleted can be selected by the right-click menu of this
area (or by On Mouse Click in the Extended Option dialog box).

Setting a breakpoint

A breakpoint can be set on a line for which "*" is displayed in the point mark area (if "*" is not displayed
for the line, the breakpoint is set on the line above or below the line, whichever has "*" displayed).
When a breakpoint has been set, 'B (blue: software breakpoint)' or 'B (red: hardware breakpoint)' is
displayed.

If a breakpoint is set on a line on which an event breakpoint has already been set, "A" indicating that

multiple events have been set is displayed.

Caution A software breakpoint cannot be set in an externally mapped ROM area.

Deleting a breakpoint
Click the position at which the breakpoint to be deleted is set.
If right-click menu -> [Software Breakpoint] is selected, 'B (blue: software breakpoint' is deleted. If

[Hardware Breakpoint] is selected, 'B (red: hardware break)' is deleted. If another event remains,
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however, the mark of that event is displayed.

Table 7-16 Details of Setting/Deleting Breakpoint

Display Status of Line

On Mouse Click
[right-click menu]

Operation on clicking

Blank or with mark other
than B

Soft Break
[Software Breakpoint]

Sets a software breakpoint.

Blank

-> Displays B(blue) mark

Other than B mark

-> Displays A mark (indicating setting
of two or more events)

Hard Break
[Breakpoint]

Sets a hardware breakpoint

Blank

-> Displays B(red) mark

Other than B mark

-> Displays A mark (indicating setting
of two or more events)

With B(blue) mark
(Software breakpoint
setting status)

Soft Break
[Software Breakpoint]

Deletes a software breakpoint
-> Blank

Hard Break
[Breakpoint]

Sets a hardware breakpoint
-> Displays A mark (indicating setting
of two or more events)

With B(red, green, black)
mark

(Hardware breakpoint
setting status)

Soft Break
[Software Breakpoint]

Sets a software breakpoint.
-> Displays A mark (indicating setting
of two or more events)

Hard Break
[Breakpoint]

Sets a software breakpoint
-> Blank

The 'B' mark is displayed in the following colors, depending on the type and status of the breakpoint.

A breakpoint becomes valid as soon as it has been set in the point mark area.

Table 7-17 Display Color of Breakpoint and Its Meaning

Display Color Meaning

B(blue) Software breakpoint is set.

B (red) Valid hardware breakpoint (after execution) is set.

B (green) Valid hardware breakpoint (before execution) is set.
* This breakpoint is set, taking precedence over the hardware breakpoint after
execution.

B (black) Invalid hardware breakpoint is set.
This hardware breakpoint can be validated on the Event Manager or in the
Break dialog box.

Event setting status

The setting status of various events can be displayed.

If an execution event or access event is set on the corresponding line, a mark corresponding to the

type of event is displayed.

If an address range is specified as the address condition of the event, the lower addresses of the range

are displayed.
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The mask specification of the address condition is not reflected.

Table 7-18 Meaning of Event Display Mark

Mark Meaning

E Setting of event condition

L Setting of event for event link condition

B Setting of break event

T Setting of trace event

Ti Setting of timer event

S Setting of snapshot event

Setting of stub event
A Setting of multiple events

Program code
The line marked *' in the point mark area indicates that a program code corresponding to the line
number exists. This program code is displayed only if a load module has been downloaded and

symbol information has been read.

(2) Current PC mark area

The mark >', which indicates the current PC value (PC register value), is displayed in this area.
Clicking this mark with the mouse displays a pop-up window that shows the PC register value.

By double-clicking the current PC mark area, the program can be executed up to a specified line.

(3) Line number/address display area

This area displays the line numbers of a source file or text file.

If a Program code corresponding to a line number of the source file exists, the character of the line
number is displayed in red. If a program code does not exist, the character of the line number is
displayed in black.

In the mixed display mode, disassembled addresses are displayed. The characters of an address are
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(4)

displayed in gray.

In this area, any position can be selected (highlighted) by clicking the mouse button. The selected line
number of an address can be dragged to another window or area, so that its variable value can be
displayed or the line number of the address can be specified as an event condition (refer to "Drag &

drop function (line/address)").

Source text display area

This area displays source files or text files. In the mixed display mode, disassemble display and online
assemble can also be executed (refer to "To change disassembled contents").

A data value can be temporarily displayed by selecting (highlighting) a character string and placing the
mouse cursor over it (Balloon watch function).

The current PC line and the line on which a breakpoint is set are emphasized for display, as follows:

Current PC line This line is the source line or disassemble display line corresponding
(Yellow) to the current PC value (indicated by >").

Breakpoint setting line This line is the source line or a disassemble display line on which a
(red) valid breakpoint is set (indicated by a 'B' mark in red, green or blue).

In the mixed display mode, the color of only the disassemble display line is changed (the source line is
displayed in the normal color).

In this area, the following functions can be used on the line or address on which the cursor is placed
(start address of program code):

-> Start function

-> Come function

-> Program counter setting function

-> Jump function

Caution If a Program code does not exist on the source line, the top address of the line above or below

the line on which a program code exists is manipulated by these functions.

These functions cannot be performed in the following cases. The corresponding menu will be
dimmed and cannot be selected.

If a file other than a source file is displayed

While the user program is being executed

A character string selected in this area can be dragged and dropped to another window or dialog box

(refer to "Drag & drop function (character string)").

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button. In this way, the same function can be used more easily than with the normal
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procedure.
Move... Moves the display position.
Opens the Source Text Move dialog box.
Mix Turns on/off mixed display of disassembly.
Checked: Mixed display
Not checked: No display (default)
Add Watch Adds the specified data to the Watch window.
Opens the Add Watch dialog box.
Symbol Displays the address of the specified variable or function, or the value of

the specified symbol.
Opens the Symbol To Address dialog box.

Break when Access to
this Variable

Creates a break event for a read/write access.

Break when Write to this
Variable

Creates a break event for a write access.

Break when Read from

Creates a break event for a read access.

this Variable

Clear Deletes the selected break event condition.

Come Here Executes the program from the current PC to the cursor position (Come
function).

Break Point Sets or deletes a breakpoint at the cursor position.

Change PC Sets the address at the cursor position to the PC.

Software Break Point

Sets a software break point at the cursor position.

Assemble Disassembles and displays starting from the jump destination address
specified by the data value at the cursor position.
Opens the Assemble window.
If an active Assemble window is open, that window is displayed in the
forefront (so that it can be manipulated).

Memory Displays the memory contents starting from the jump destination address
specified by the data value at the cursor position.
Opens the Memory window.
If an active Memory window is open, that window is displayed in the
forefront (so that it can be manipulated).

Coverage Displays the coverage measurement results starting from the jump

destination address specified by the data value at the cursor position.
Opens the Coverage window.

If an active Coverage window is open, that window is displayed in the
forefront (so that it can be manipulated).
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Function buttons

Search... Opens the Source Search dialog box and searches a character string of the
source text.

If a character string is selected in the source text display area, the Source
Search dialog box is opened to search the character string. If no character
string is selected, the Source Search dialog box is opened with nothing
specified to be searched.

Specify a search method in the Source Search dialog box. The result of search
is highlighted in the Source window.

This is the same operation as selecting [View] -> [Search...] from the menu bar.
This button is invalid while the user program is executed.

<< Searches forward (upward on screen) for the text that satisfies the search
condition set in the Source Search dialog box, starting from the address at the
cursor position.

This button is displayed as the <Stop> button during a search.

This button is invalid while the user program is executed.

>> Searches backward (downward on screen) for the text that satisfies the search
condition set in the Source Search dialog box, starting from the address at the
cursor position.

This button is displayed as the <Stop> button during a search.

This button is invalid while the user program is executed.

Stop Stops searching.
(during search)

Watch Adds the variables selected in the source text display area to the Watch
window. If the Watch window is not opened, it is opened.

If no text is selected in the source text display area, the Watch window is only
opened.

This is the same operation as selecting [View] -> [View Watch] from the menu
bar.

Quick... Temporarily displays the contents, such as a variable, selected in the source
text display area in the Quick Watch dialog box. Opens the Quick Watch dialog
box. If no text is selected in the source text display area, the Quick Watch
dialog box is only opened.

This is the same operation as selecting [View] -> [Quick Watch] from the menu

bar.
Refresh Updates the contents of the window with the latest data.
Close Closes this window.

Related operations

Mixed display mode
The normal display mode and mixed display mode can be alternately selected by selecting [View] ->
[Mix] from the menu bar.

Normal display mode

b

50 TUMT = Qx200;

G0 CE1 =1;

1 time_aver = 0 f
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In the normal display mode, general text files can be displayed as well as source files.

Mixed display mode

5B
A0 TUMT = 0x200;
0000394 20660002 mowesa Qx200, r0, r12
0000398 GOGET40F2 zt.h r12, TUKI
G0 CE1T =1;
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00003 A0 44020000 mowhi QxQ, ep, rl
000 A B1071184 + o ri) =0y hFO 1] -]

In the mixed display mode, disassembly of programs combined with source files is displayed and
online assembly is carried out. (This mode is valid only when a load module is being downloaded and
symbol information is being read, and the source file that corresponds to the downloaded load module
is displayed).

If a program code corresponds to the line of the displayed source file, the disassembly line is displayed
next to the source line. In the disassembly line, an address label, a code data, and a disassembled
mnemonic are displayed (the starting position for display of the mnemonic can be adjusted by the tab
size setting value).

To execute online assembly, move the cursor to a mnemonic. The results of online assembly are also
reflected in the Memory window.

The contents displayed in the mixed display mode can be saved as a view file.

To set a source path
Set a source path under Source Path (source path specification area) in the Debugger Option dialog

box that is opened by selecting [Option] -> [Debugger Option] from the menu bar.

To change the display start position
Change the display start position in the Source Text Move dialog box that is opened when right-click

menu ->[Move...] is selected in the Source window.

To display another source file

Select [File] -> [Open] from the menu bar and specify a file.

To specify the default extension of a source file
Set a source path under Default Extension (default extension specification area) in the Debugger

Option dialog box that is opened by selecting [Option] -> [Debugger Option] from the menu bar.

To convert a symbol
Convert symbols in the Symbol To Address dialog box that is opened when right-click menu ->

[Symbol...] is selected in the Source window.

To specify the symbol of a start-up routine
Specify the symbol of a start-up routine under Startup Routine (start-up symbol setting area) in the
Debugger Option dialog box that is opened by selecting [Option] -> [Debugger Option...] from the

menu bar. If the setting in this area is wrong, the source file cannot be opened.
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To set an opened file history
Set an opened file history under Open File History (open file history setting area) in the Debugger
Option dialog box that is opened by selecting [Option] -> [Debugger Option...] from the menu bar. The

number of a history display of the opened files can be specified in this area.

To set a beep sound to be issued upon break
Set the beep sound under Break Sound (beep sound specification area) in the Extended Option dialog

box that is opened by selecting [Option] -> [Extended Option...] from the menu bar.

To change the displayed font
Change the displayed font in the Font dialog box that can be opened by clicking the <Font...> button in
the Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from

the menu bar.

To change the displayed tab size
The displayed tab size can be specified for each file extension under Tab Size (tab size setting area) in
the Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from

the menu bar.

Start function
This function is used to execute the user program from the line on which the cursor is placed.
Method
Move the cursor to the line from which the program is to be executed, and select right-click menu ->

[Start From Here].

Come function
This function is used to execute the user program to the line on which the cursor is placed (while the
user program is being executed in this mode, the break event currently set does not occur).
Method

Move the cursor to the line on which the break is to occur, and select right-click menu -> [Come Here].

Program counter setting function
This function is used to set the address of the line on which the cursor is placed to the program counter
(PC).
Method
Move the cursor to the line that is to be set to the PC, and select [Run] -> [Change PC] from the menu

bar.

Jump function
This function is used to jump to the Memory window,using the selected variable as a jump pointer.
The jump destination window will be displayed from the vicinity of the jump pointer.
1 Select the name of variable as a jump pointer with the mouse.
2 In the Main window, to jump to the Memory window

Select [Jump] -> [Memory] from the menu bar.
(or press Alt+J and E in that order, or press Ctrl+M).
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« To jump from the Trace window to the Memory window or Coverage window, the jump source address
differs as follows, depending on the cursor position in the trace result display area:

If the cursor is at an access address, access data, or access -> Access address
status

Other than above -> Fetch address
To jump to the Source window or Assemble window -> Fetch address

« To jump from the Register window, move the cursor to a register value.

« To jump from the Stack Trace window, the jump destination is as follows:

[With current function]

- If the jump destination is the Source window

-> Jumps to the current PC line.

- If the jump destination is a window other than the Source window
-> Jumps to the current PC address.

[With function other than current function]

- If the jump destination is the Source window

-> Jumps to the line that calls a nested function.

- If the jump destination is a window other than the Source window

-> Jumps to the address next to the instruction that calls a nested function.

To change disassembled contents
To change the disassembled contents, move the cursor to the mnemonic field (the overwrite and
insertion modes are alternately selected by pressing the Insert key).
If an attempt is made to move the cursor to another line after the disassembled contents have been
changed in the mnemonic field, the new contents are checked. If the new contents are illegal. the code
data on the line where the contents have been changed is indicated as *'. In this case, the new
contents are not written to memory even if the cursor is moved to another line.
The contents changed in the mnemonic field are written into the memory by pressing the Enter key.
When the Enter key is pressed, the new contents are checked and, if they are illegal, the code data on
the illegal line is indicated by *'. If even one line is illegal, the new contents are not written into the
memory.
In this case, correct the contents. To discard the contents, press the ESC key. If the contents are
correct and if the Enter key is pressed, the contents are written into the memory, and then the cursor

moves to the next line in the mnemonic field, so that the data on the next line can be changed.

Watch function (referencing data value)
Data values can be displayed as follows:
To temporarily display a value
The following two methods can be used:

 Select (highlight) a character string and put the mouse cursor on it then the data value is displayed
(Balloon watch function).
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 Select (highlight) a character string and click the <Quick> button. The Quick Watch dialog box will
be opened to display the data value.

To trace the change of a data value
Register a variable or symbol to the Watch window in either of the following ways:
« Select (highlight) the character string whose data value is to be displayed, click the <Watch> button,

or drag the character string to the Watch window and register it to the window (Drag & drop function
(character string)).

« Select (highlight) the character string whose a data value is to be displayed and register the data
value from the Add Watch dialog box that is opened when right-click menu -> [Add Watch] is
selected.

To search in a source program
Use the Source Search dialog box that is opened by clicking the <Search...> button in the Source
window.
If the character string to be searched exists in the window, select that character string and click the

<Search...> button. The selected character string will be opened in the specified format.

To set a default breakpoint
Set a default breakpoint under On Mouse Click (default break selection area) in the Extended Option
dialog box that is opened when [Option] -> [Extended Option...] is selected from the menu bar. In this

way, a default breakpoint that is assumed when the point mark area is clicked can be set.

To set event after execution
Set an event after execution under Break condition (break mode setting area) in the Extended Option
dialog box that is opened by selecting [Option] -> [Extended Option...] from the menu bar. If a normal
hardware breakpoint is set after this setting was performed, the hardware breakpoint is set as an event
after execution. This setting only affects hardware breakpoints. In the default condition, an event

before execution is set.

Drag & drop function (line/address)
The line number or address selected and highlighted can be dragged to another window or area.
If the position of the line number or address selected in this area is dragged with the left mouse button,
the shape of the mouse cursor changes from an arrow to '-'. When the cursor is moved to the window
or area in which they can be dropped, the mouse cursor changes to 'OK'.
In the window in which the line number of the address has been dropped, an operation is performed on
the dropped address or the address that is obtained from the dropped line number. The operation to
be performed after dropping the line number or address differs, depending on the window or area in

which the line number or address has been dropped.
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Table 7-19 Details of Drag & Drop Function (Line/Address)

Window/Area to Drop to

Operation After Drop

The Event Manager or the event
manager area in each various
event setting dialog box

Automatically creates an execution event condition by using
the dropped line number or address as an address condition.
Event condition names are automatically created as
Evt00001, Evt00002, and so on. An external sense data
condition and path count are not specified.

The address condition is set for the closest symbol in the
format of symbol name + offset value.

Condition setting area in each
various event setting dialog box
(other than address and data
setting areas)

Automatically creates an execution event condition by using
the dropped line number or address as an address condition.
The automatically created event condition is set in each
condition setting area in which the line number or address has
been dropped.

Event condition names are automatically created as
Evt00001, Evt00002, and so on. An external sense data
condition and path count are not specified.

The address condition is set for the closest symbol in the
format of symbol name + offset value.

Condition setting area in each
various event setting dialog box
(address and data setting areas)

The text of the dropped line number or address is set in the
area in which the line number or address has been dropped.
The address condition is set for the closest symbol in the
format of symbol name + offset value.

Caution The various event setting dialog boxes includes the Event dialog box, Event Link dialog box,

Break dialog box, Trace dialog box, Snap Shot dialog box, Stub dialog box, and Timer dialog

box.

Drag & drop function (character string)

A selected text can be moved to another window or area by dragging and dropping.

1

If the selected text is dragged by using the left mouse button, the shape of the mouse cursor

changes from an arrow to '-'.

When the cursor is moved to the window or area in which the text can be dropped, the mouse

cursor changes to 'OK'.

The operation to be performed after dropping the text differs, depending on the window or area in

which the text has been dropped.
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Table 7-20 Details of Drag & Drop Function (Character String)

Window/Area to Drop to

Operation After Drop

The Event Manager or the event
manager area in each various
event setting dialog box

If the dropped text can be converted as a symbol into an
address value, an event condition in the Access status (all
access statuses) or Execute status is automatically created,
using the converted address value as an address condition.
Event condition names are automatically created as
Evt00001, Evt00002, and so on. An external sense data
condition and path count are not specified.

The address condition is set by the dropped text.

The relationship between the event condition to be created
and the symbol is as follows:

Symbol Status
Variable Access(R/W)
Function Execute
Symbol in the data section Access(R/W)
Symbol in the code section Execute
Other Access(R/W)

Condition setting area in each
various event setting dialog box
(other than address and data
setting areas)

If the dropped text can be converted as a symbol into an
address value, an event condition in the Access status (all
access statuses) or Execute status is automatically created,
using the converted address value as an address condition.
The automatically created event condition is set in each
condition setting area in which the line number or address has
been dropped.

Event condition names are automatically created as
Evt00001, Evt00002, and so on. An external sense data
condition and path count are not specified.

The address condition is set by the dropped text.

The relationship between the event condition to be created
and the symbol is as follows:

Symbol Status
Variable Access(R/W)
Function Execute
Symbol in the data section Access(R/W)
Symbol in the code section Execute
Other Access(R/W)

Condition setting area in each
various event setting dialog box
(address and data setting areas)

The dropped text is set in the area.

Watch window

If the dropped text is recognizable as a symbol, the contents
of the symbol are displayed.

Caution The various event setting dialog boxes includes the Event dialog box, Event Link dialog box,

Break dialog box, Trace window, Snap Shot dialog box, Stub dialog box, and Timer dialog box.
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Source Search dialog box

This dialog box is used to search for the character string in the Source window.
By setting each item and then clicking the <Find Next> button, searching can be started.
By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Source windowcan be used

for the search.

Figure 7-24 Source Search Dialog Box

Source Search

Find What:

LI Find Me:xt

W Match Casze "Directinn Set Find

a Ur @ Down Cancel |

File: I LI Browse.. | Help |

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:
When Source window is displayed
¢ Click the <Search> button.

(or press Ctrl and G in that order).

« Select [View] -> [Search...]
(or press Alt+V, and S in that order).

Explanation of each area

The Source Search dialog box consists of the following areas:
(1) Find What (search data specification area)
(2) Match Case (search condition specification area)
(3) Direction (search direction specification area)

(4) File (search file specification area)
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@)

)

@)

(4)

Find What (search data specification area)

Find What:
This area is used to specify the data to be searched.

In the default condition, the character string selected in the window that called this dialog box is
displayed. As necessary, input data from the keyboard to change the character string.

Up to 256 character string can be specified.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.

Match Case (search condition specification area)

¥ Match Case

This area is used to specify whether uppercase and lowercase characters are distinguished, before

searching is started.

Checked Distinguished (default)

Not checked Not distinguished

Direction (search direction specification area)

Direction
’7 0 Up % Dowen

This area is used to specify the direction of the search.

Up Forward search.
Searches data forward (upward on screen) from the current position
of the cursor.

Down Backward search (default).
Searches data backward (downward on screen) from the current
position of the cursor.

File (search file specification area)

File: I LI Brovess.. I

This area is used to specify the file to be searched.

If no file is specified, searching is executed in the window that called this dialog box.
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Function buttons

Find Next Searches the specified data in accordance with a given condition.
If the specified character string is found as a result of a search, it is highlighted.
To continue searching, click this button again.

Set Find Sets the specified condition as the search condition and closes this dialog box.

Stop Stops searching.
(during search)

Cancel Closes this dialog box.
This button is displayed as the <Stop> button while data is being searched.

Browse... Opens Browse dialog box.

Help Opens the Help window.

User's Manual U16217EJ1VOUM 155



CHAPTER 7 WINDOW REFERENCE

Assemble window

This window is used to disassemble and display programs. It is also used to execute online assembly.
To execute online assembly, move the cursor to a mnemonic. The results of online assembly are also
reflected in the Memory window.

The Assemble window has two statuses: Active Status and Static Status.

Figure 7-25 Assemble Window

Search. ][ K [ %> ][ Wateh ][ Quick. ][ Refresh ][ Close ]
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peleleleledc =T 40574 af0 st. kb 10, MM
peleleleleb-Rol- 2OGaoadZ mowven D200, rOFJ
islelalalehcioFs a0a740fz2 =t_h 12, TIIML

1o peleleleledcy-T
lelaTaYalad: PN EEYeTVaTalstal mewvhi Oxd, g, 1z
ielelelelehyIr] al10711&84 st.w o, —-ox7kfc
islslaleleic = D2 dGm mow Dxd . rlE
peleleleleicyin A0af00fl =t.k 13, oWICL

E peleleleledcyiy
ielelelelehl h BEOTZ500 st.w 0, Ox2&8[=E

T islalalele el =17 2EE72200 ld.w OxZ&[=p]. 2
OO 0003 BA 2007 ka0l jr _main+Cxlfo

EE zo77s0fz d.h THM1, =14
[slalolalod: Lot ca7affff andi Ooxffff, vle
islalalelehepad:s GE?714d00 st .w 14, Oxlc[iv
[slelaleled:RatN 4G iaelO00 movhi Oxd, gg. -
peleleleledcyad z17£f11&4 ld.w —ox?kfo[rl]a
ieleleleleicl By GE37E£1200 =t.w 15, Oxla[=%

] >

This section explains the following items:

* Opening

« Explanation of each area

« Functions often used (right-click menu)
* Function buttons

* Related operations

Concerning display

« To change the display start position

» To change the displayed offset and register name

Concerning operation

« Start function

« Come function

« Program counter setting function
e Jump function

» To change the disassembled contents
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« Watch function (referencing data value)
» To search in the Assemble window

« To set a default breakpoint

* To set event after execution

» Drag & drop function (line/address)

» Drag & drop function (character string)

Opening

This window can be opened as follows:

¢ Click the Asm button.

« Select [Browse] -> [Assemble] from the menu bar
(or press Alt+B, and A in that order).

¢ Select [Jump] -> [Assemble] from the menu bar
(or press Alt+J and A in that order, or press Ctrl+D).

Explanation of each area

The Assemble window consists of the following areas:
(1) Point mark area
(2) Current PC mark area
(3) Address specification area

(4) Disassemble display area

(1) Point mark area

.

E

T

This area is displayed the Breakpoint setting/deletion function and the Event setting status.

(2) Current PC mark area

=

The mark >', which indicates the current PC value (PC register value), is displayed in this area.

By double-clicking the current PC mark area, the program can be executed up to a specified line.
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(3) Address specification area

[elsTeTe]eh L ale]

This area displays the disassembly start address. When this area is clicked, an address highlighted

and selected.
This area has the Drag & drop function (line/address) and the Trace Result with Linking Window

function.

(4) Disassemble display area

[53=3=10Y mow e, L
doafoofl =t.kb 13, CVIIL
GEQTFZH00 st.w 0, OQOxIZ&[=:
23272200 1d.w OxZ&[=p]. 2
2007kbe0l i _main+oxlfo
207750f=2 d.h TM1, 14
cae?7effff mndi Coxf£f£f, r=l1e
3771 d00 st _w rlad, O}\::Lc[sv
240000 movhi 0x2, gp. =
z17f11&4 ld.w —CxThfo[xl]e
627£1500 st.w rlS, Oxl&[c¥
1| b

This area displays the labels and code data of addresses, and disassembled mnemonics.

The current PC line and breakpoint setting line are displayed in different colors for emphasis (refer to
"Source text display area").

The disassembled mnemonics displayed in the mnemonic field can be changed (refer to "To change
disassembled contents").

If the number of new instruction bytes is less than the number of previous instruction bytes as a result
of changing, as many 'NOP' instructions as necessary are inserted. If the number of new instruction
bytes is more than the number of previous instruction bytes, the next instruction is overwritten. In this
case also, as many 'NOP' instructions as necessary are inserted. The same applies to instructions
that straddle over source lines.

In this area, the following functions can be used on the line or address on which the cursor is placed
(start address of program code):

-> Start function

-> Come function

-> Program counter setting function

-> Jump Function

A character string selected in this area can be dragged and dropped in another window or dialog box

(refer to "Drag & drop function (character string)").

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking
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the right mouse button.

In this way, the same function can be used more easily than with the normal

procedure.

Move... Moves the display position.
Opens the Address Move dialog box.

Add Watch Adds the specified data to the Watch window.
Opens the Add Watch dialog box.

Symbol Displays the address of the specified variable or function, or the value of the
specified symbol.
Opens the Symbol To Address dialog box.

Come Here Executes the program from the current PC to the cursor position (Come
function).

Change PC Sets the address at the cursor position to the PC.

Break Pont Sets or deletes a breakpoint at the cursor position.

Software Break Point | Sets or cancels a software break point at the cursor position.

Source Text

Displays the corresponding source text and source line, using the data value
at the cursor position as the jump destination address.

If no line information exists at the jump destination address, however, you
cannot jump.

Opens the Source window.

If an active Source window is open, that window is displayed in the forefront
(so that it can be manipulated).

Memory

Displays the memory contents starting from the jump destination address
specified by the data value at the cursor position.

Opens the Memory window.

If an active Memory window is open, that window is displayed in the forefront
(so that it can be manipulated).

Coverage

Displays the coverage measurement results starting from the jump
destination address specified by the data value at the cursor position.
Opens the Coverage window.

If an active Coverage window is open, that window is displayed in the
forefront (so that it can be manipulated).

Function buttons

Search...

Opens the Assemble Search dialog box and searches for a character string of
mnemonics.

If a character string is selected in the disassemble display area, the Assemble
Search dialog box is opened to search for the character string. If no character
string is selected, the Assemble Search dialog box is opened with nothing
specified to be searched.

Specify a search method in the Assemble Search dialog box. The result of
search is highlighted in the Assemble window.

This is the same operation as selecting [View] -> [Search...] from the menu bar.

<<

Searches forward (upward on screen) for the contents that satisfy the search
condition set in the Assemble Search dialog box, starting from the address at the
cursor position.

This button is displayed as the <Stop> button during a search.
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>> Searches backward (downward on screen) for the contents that satisfy the search
condition set in the Assemble Search dialog box, starting from the address at the
cursor position.

This button is displayed as the <Stop> button during a search.

Stop Stops searching.
(during search)

Watch Adds the symbols selected in the disassemble display area to the Watch window.
If the Watch window is not opened, it is opened.

If no text is selected in the disassemble display area, the Watch window is only
opened.

This is the same operation as selecting [View] -> [View Watch] from the menu bar.

Quick... Temporarily displays the contents, such as symbols, selected in the disassemble
display area on the Quick Watch dialog box. Opens the Quick Watch dialog box.
If no text is selected in the disassemble display area, the Quick Watch dialog box
is only opened.

This is the same operation as selecting [View] -> [Quick Watch...] from the menu

bar.
Refresh Updates the contents of the window with the latest data.
Close Closes this window.

Related operations

To change the display start position
Change the display start position in the Address Move dialog box, which is opened when right-click

menu -> [Move...] is selected in the Assemble window.

To change the displayed offset and register name
Change the display offset or register name under DisAssemble (offset display setting area) in the
Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from the

menu bar. A function name or an absolute name can be selected as a register name.

Start function

For the operation, refer to "Start function" in the Source window.

Come function

For the operation, refer to "Come function" in the Source window.

Program counter setting function

For the operation, refer to "Program counter setting function" in the Source window.

Jump function

For the operation, refer to "Jump function" in the Source window.

To change the disassembled contents

For the operation, refer to "To change disassembled contents" in the Source window.

Watch function (referencing data value)

For the operation, refer to "Watch function (referencing data value)" in the Source window.
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To search in the Assemble window
Use the Assemble Search dialog box, which can be opened by clicking the <Search...> button in the
Assemble window. If the character string to be searched is existed in the window, select that character

string and click the <Search...> button. The selected character string is opened in the specified format.

To set a default breakpoint

For details, refer to "To set a default breakpoint” described in the Source window.

To set event after execution

For the operation, refer to "To set event after execution" in the Source window.

Drag & drop function (line/address)

For the operation, refer to "Drag & drop function (line/address)" in the Source window.

Drag & drop function (character string)

For the operation, refer to "Drag & drop function (character string)" in the Source window.
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Assemble Search dialog box

This dialog box is used to search the contents of Assemble window.

Successive character strings included in an input character string and disassembler character string are
compared as one blank character.

By setting each item and then clicking the <Find Next> button, searching can be started.

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Assemble windowcan be

used for the search.

Figure 7-26 Assemble Search Dialog Box

Find what: || [~] | Eind Mest
|7 Match Case Direction ——— Sat Find
[ Scan Whole Region ’7 C Up & Down Cancel |

Address: IEI - IEI Help |

This section explains the following items:

* Opening
< Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:
When Assemble windowis the current window
¢ Click the <Search> button.

(or press Ctrl+G).

« Select [View] -> [Search...]
(or press Alt+V, and S in that order).

Explanation of each area

The Assemble Search dialog box consists of the following areas:
(1) Find What (search data specification area)
(2) Match Case (search condition specification area)
(3) Scan Whole Region (search condition specification area)

(4) Direction (search direction specification area)
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(5) Address (search range specification area)

(1) Find What (search data specification area)

Find What: || |

This area is used to specify the data to be searched.

In the default condition, the character string selected in the window that called this dialog box is
displayed. As necessary, input data from the keyboard to change the character string.

Up to 256 character string can be specified.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.
(2) Match Case (search condition specification area)
W Match Case

This area is used to specify whether uppercase and lowercase characters are distinguished, before

searching is started.

Checked Distinguished (default)

Not checked Not distinguished

(3) Scan Whole Region (search condition specification area)

[T Scan Wihale Region

This area is used to specify whether the specified range is fully searched or not.

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)

(4) Direction (search direction specification area)

Direction
’7 0 Up % Down

This area is used to specify the direction of the search.

Up Forward search.
Searches data forward (upward on screen) from the current position
of the cursor.

Down Backward search (default).
Searches data backward (downward on screen) from the current
position of the cursor.
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(5) Address (search range specification area)

Address=: IEI

— o

This area is used to specify the address to be searched.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.

Function buttons

(during search)

Find Next Searches the specified data in accordance with a given condition.
If the specified character string is found as a result of a search, it is highlighted.
To continue searching, click this button again.
Set Find Sets the specified condition as the search condition and closes this dialog box.
Stop Stops searching.

Cancel Closes this dialog box.
This button is displayed as the <Stop> button while data is being searched.
Help Opens the Help window.
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Memory window

This window is used to display and change the memory contents.

The display start position when the Memory window is opened is as follows:

First time

Display starts from the first address of the real-time RAM sampling area.

Second and subsequent

times

Display starts from the address at which an active status window was
closed
(if an active status window has never been closed, display starts from
the first display start position).

Even while the program is being executed, the range set in the Extended Option dialog box can be

displayed in real time.

The Memory window has two statuses: Active Status and Static Status.

Figure 7-27 Memory Window

This section explains the following items:

Opening

Explanation of each area

Functions often used (right-click menu)

Function buttons

Related operations

» To change the memory contents

« To change the display start position

« To search in the Memory window

» To display ASCII characters

« To initialize the memory contents with a specified code
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« To copy the memory contents
« To compare the memory contents
« To verify and check a memory write

« To change the memory contents in real time during program execution (DMM function)

Opening

This window can be opened as follows:

¢ Click the Mem button.

« Select [Browse] -> [Memory...] from the menu bar
(or press Alt+B, and M in that order).

¢ Select [Jump] -> [Memory...] from the menu bar
(or press Alt+J, and M in that order).

Explanation of each area

The Memory window consists of the following areas:
(1) Addr (address display area)
(2) +0 +1 +2....(memory display area)
(3) 0123.... (ASCIl display area)

(1) Addr (address display area)

2ddr

DOFFEOQOO
DOFFEOQLO
DOFFEOQZO
IDOFFEOS O
IDOFFEO4 O
IDOFFEOSO
IDOFFEOGO
COFFECY O

This area displays memory addresses.

(2) +0+1+2... (memory display area)

[a]
BJ
Lo
o]
o]
a]
o]
o]
e
a]
o]
o]
Lo
o]
]
a]
o]
Lo
o]
a]
anooanl +

This area is used to display and change the memory contents.
Data into which the current memory contents are to be changed is displayed in red and is actually

written to the target when the Enter key is pressed. The contents (displayed in red) can be canceled

by the ESC key. Up to 256 bytes can be specified at one time.
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This area is also used as a jump pointer of the jump function. In addition, it also has the Trace Result

with Linking Window function.

(3) 0123... (ASCll display area)

0123456789ABCDEF

This area is used to display and change the memory contents in ASCII characters.

This area is displayed when right-click menu -> [Ascii] is selected. Display of this area can be turned

on/off by this menu item.

Data can be changed in this area in the same manner as in the memory display area.

This area is also used as a jump pointer of the jump function.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button. In this way, the same function can be used more easily than with the normal

procedure.
Move... Moves the display position.
Opens the Address Move dialog box.
Bin Displays binary numbers.
Oct Displays octal numbers.
Dec Displays decimal numbers.
Hex Displays hexadecimal numbers (default).
Nibble Displays in 4-bit units.
Byte Displays in 8-bit units (default).
Half word Displays in 16-bit units.
Word Displays in 32-bit units.
Ascii Turns on/off display of ASCII characters.
Checked: Displayed
Not checked: No display (default)
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Function buttons

Search... Opens the Memory Search dialog box and searches for character strings from
the displayed memory contents, or memory contents.

Selected data (a memory value) is displayed in the Memory Search dialog box
as data to be searched. If the Memory Search dialog box is opened without
data specified, specify data from the keyboard.

The result of the search is highlighted in the Memory window.

<< Searches the memory contents satisfying the search condition set in the
Memory Search dialog box, forward (upward on screen) from the address at the
cursor position.

This button is displayed as the <Stop> button during a search.

>> Searches the memory contents satisfying the search condition set in the
Memory Search dialog box, backward (downward on screen) from the address
at the cursor position.

This button is displayed as the <Stop> button during a search.

Stop Stops searching.

(during search)

Refresh Updates the contents of the window with the latest data.
Modify... Opens the DMM dialog box.

This button is invalid at a break.

Close Closes this window.

Related operations

To change the memory contents
To change the memory contents, move the cursor to the memory display area or ASCII display area in
the window, and write data directly from the keyboard. The amount of memory contents that can be
changed at one time is 256 bytes or less. To set the change, press the return key. To cancel the

change, press the ESC key.

To change the display start position
Use the Address Move dialog box, which can be opened by selecting right-click menu -> [Move] in the

Memaory window.

To search in the Memory window
Use the Memory Search dialog box, which can be opened by clicking the <Search...> button in the
Memory window. If the character string to be searched exists in the window, select that character
string and click the <Search...> button. The selected character string is opened in the specified format.

Non-mapped, peripheral I/O register, and I/O protect areas are not searched.

To display ASCII characters
The memory contents are displayed in ASCII characters when right-click menu -> [Ascii] is selected in

the Memory window.
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To turn off display of ASCII characters, select [Ascii] again to remove the check mark.

To initialize the memory contents with a specified code
Initialize the memory contents with a specified code in the Memory Fill dialog box, which can be
opened by selecting [Edit] -> [Memory] -> [Initialize] from the menu bar.

If verify check is enabled in the Extended Option dialog box, verify check is executed after initialization.

To copy the memory contents
Copy the memory contents in the Memory Copy dialog box, which can be opened by selecting [Edit] ->
[Memory] -> [Copy] from the menu bar.

If verify check is enabled in the Extended Option dialog box, verify check is executed after copy.

To compare the memory contents
Compare the memory contents in the Memory Compare dialog box, which can be opened by selecting
[Edit] -> [Memory] -> [Compare] from the menu bar.
If a difference is found as a result of comparison, the Memory Compare Result dialog box is opened

and the details are displayed in this dialog box.

To verify and check a memory write
Use the Extended Option dialog box, which is opened by selecting [Option] -> [Extended Option] from

the menu bar. To execute a verify check, check the [Verify] check box.

To change the memory contents in real time during program execution (DMM function)
Set addresses and data for DMM (Dynamic Memory Maodification) in the DMM dialog box, which can
be opened by selecting [Edit] -> [Memory] -> [Modify] from the menu bar.

Note that this dialog box can be opened only while the program is being executed.
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Memory Search dialog box

This dialog box is used to search the memory contents of the part of Memory window at which the cursor
is located.

If the cursor is in the memory display area, the memory display area is searched for specified data, which
is assumed to be a binary data string. If the cursor is in the ASCII display area, the ASCII display area is
searched for specified data, which is assumed to be an ASCII character string.

By setting each item and then clicking the <Find Next> button, searching can be started.

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Memory window can be
used for the search.

Non-mapped, peripheral I/O register, and I/O protect areas are not searched.

Figure 7-28 Memory Search Dialog Box

Memory Search

Find hat || =] [ Eind et |
, Sit Find
Unit. & Byte € Half Word € Word [ Set Find |

Direction Cancel |
[ Scan Whale Region ’V 0 Up & Down ﬂl

Address: I -—= I

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:
When Memaory windowis the current window
¢ Click the <Search> button.

(or press Ctrl+G).

« Select [View] -> [Search...]
(or press Alt+V, and S in that order).
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Explanation of each area

The Memory Search dialog box consists of the following areas:

@)

)

@)

(1) Find What (search data specification area)

(2) Unit (search condition specification area)

(3) Scan Whole Region (search condition specification area)
(4) Direction (search direction specification area)

(5) Address (search range specification area)

Find What (search data specification area)

Find What: || |

This area is used to specify the data to be searched.

In the default condition, the character string selected in the window that called this dialog box is
displayed. As necessary, input data from the keyboard to change the character string.

When searching the memory display area, up to 16 data items can be specified. Delimit each data
with a "blank character". When searching the ASCII display area, data of up to 256 characters can be
specified. A "blank character” in the data is treated as a blank character.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.
Unit (search condition specification area)

Urit: & Byte 0 Half Word € Wiard

This area is used to specify the number of bits of the data to be searched in the memory display area.

Byte Searches the data as 8-bit data (default).
Half Word Searches the data as 16-bit data.
Word Searches the data as 32-bit data.

Scan Whole Region (search condition specification area)

[T Scan Whole Region

This area is used to specify whether the specified range is fully searched or not.

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)
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(4) Direction (search direction specification area)

Direction
’Vr' Up % Down

This area is used to specify the direction of the search.

Up Forward search.
Searches data forward (upward on screen) from the current position
of the cursor.

Down Backward search (default).

Searches data backward (downward on screen) from the current
position of the cursor.

(5) Address (search range specification area)

Address: |

This area is used to specify the address to be searched.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.

Function buttons

(during search)

Find Next Searches the specified data in accordance with a given condition.
If the specified character string is found as a result of a search, it is highlighted.
To continue searching, click this button again.
Set Find Sets the specified condition as the search condition and closes this dialog box.
Stop Stops searching.

Cancel Closes this dialog box.
This button is displayed as the <Stop> button while data is being searched.
Help Opens the Help window.
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Memory Fill dialog box

This dialog box is used to initialize the memory contents in the Memory window with specified codes.

Figure 7-29 Memory Fill Dialog Box

Memory Fill

Addres=s
From: m - IEI
fill code => [0

614 I Cancel | Eestnrel Help

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Select [Edit] -> [Memory] -> [Eill] from the menu bar.
(or press Alt+E, M and F in that order).

Explanation of each area

The Memory Fill dialog box consists of the following areas:
(1) Address (address range specification area)

(2) fill code (data specification area)
(1) Address (address range specification area)
Addrezs

Fram: m - Il:l

This area is used to specify the memory address range whose contents are to be initialized.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying
Symbols"). The default radix for inputting a numeric value is hexadecimal.

Input the first address to be initialized and then the last address to be initialized.
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(2) fill code (data specification area)

fill code => [0

This area is used to specify the data with which the memory contents are to be initialized.

Up to 16 binary data strings (byte data strings) can be specified.

Delimit each data with a "blank character".

Function buttons

OK

Initializes the memory.

Stop
(during initialization)

Stops initialization.
While initialization is in progress, the <Cancel> button is replaced by the
<Stop> button.

Cancel Closes this dialog box.
While memory contents are being initialized, this button is replaced by the
<Stop> button.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Memory Copy dialog box

This dialog box is used to copy the memory contents in the Memory window.

Figure 7-30 Memory Copy Dialog Box

Addres=s

From: m - IEI
Tex IEI
0 ]8 I Cancel | Restore | Help

This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [Edit] -> [Memory] -> [Copy] from the menu bar.
(or press Alt+E, M and C in that order).

Explanation of each area

The Memory Copy dialog box consists of the following area:

(1) Address (address range specification area)

(1) Address (address range specification area)

Address

From: m - IEI
Tex IEI

This area is used to specify the copy source and copy destination addresses.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.
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From Specify the address range of the copy source.
Input the first address of the copy source and then the end address.
To Specify the first address of the copy destination.

Function buttons

OK

Copies the memory.

Stop
(during copying)

Stops copying.
While copying is in progress, the <Cancel> button is replaced by the <Stop>
button.

Cancel Closes this dialog box.

While copying is in progress, this button is replaced by the <Stop> button.
Restore Restores the input data to the original status.
Help Opens the Help window.
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Memory Compare dialog box

This dialog box is used to compare the memory contents in the Memory window.

Figure 7-31 Memory Compare Dialog Box

hemory Compare

Addrez=s

hleml: ﬁ - IEI
hemz: ID—
o] I Cancel | Bestore I Help

This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Select [Edit] -> [Memory] -> [Compare] from the menu bar.
(or press Alt+E, M and P in that order).

Explanation of each area

The Memory Compare dialog box consists of the following area:

(1) Address (comparison range specification area)

(1) Address (comparison range specification area)

Address

Meml: m - II:I
hemz: ||:|

This area is used to specify the comparison source address and comparison destination address.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.
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Mem1 Specify the address range of the comparison source.
Input the first address of the comparison source and then the end address.
Mem?2 Specify the first address of the comparison destination.

Function buttons

OK Compares the memory.
If no difference is found as a result of comparison, a confirmation dialog box
is displayed. If a difference is found, Memory Compare Result dialog box is
opened.
Figure 7-32 Confirmation Dialog Box
1D850
@ W200: No difference encountered.
Clicking the <OK> button ends memory comparison.
Stop Stops memory comparison.
(during comparison) While comparison is in progress, the <Cancel> button is replaced by the
<Stop> button.
Cancel Closes this dialog box.
While comparison is in progress, this button is replaced by the <Stop> button.
Restore Restores the input data to the original status.
Help Opens the Help window.

User's Manual U16217EJ1VOUM




CHAPTER 7 WINDOW REFERENCE

Memory Compare Result dialog box

Displays the result of comparing the memory.

This dialog box is displayed if any difference is found in the memory contents when the memory has been

compared in Memory Compare dialog box.

Figure 7-33 Memory Compare Result Dialog Box

Meml Mem2
Addr e mory Addr
jelalelsleleraIupnroTe] 12 (2OOOFFFEF &
pexalaleialeeh BN eL S| o0l oo
iealaleloeyee) t=Ye] 14 (ool ool
peralalelalepeh Lo D% ool oo
elalelsieleyal: ol 4% |(Dool o3
QS |BF 1E (ool oo
D0 s (Bh D (ool
ieialeleielerehe = EF |(QCoolooda
el als e bepals] == G| DDl oooT
ieialelelolepel-RuRNFoV8 EE |[QCOolools ﬂ

Close I

Heb |

This section explains the following items:

« Explanation of each area

* Function buttons

Explanation of each area

The Memory Compare Result dialog box consists of the following area:

(1) Mem1l, Mem2 (comparison result display area)

(1) Meml, Mem2 (comparison result display area)

feml hemz
Addr Mlemary Addr
lalalalalale Lo RRRytYe] 1| (2O OFFFE &
ieleteleleloleh BN = =)napislelohiRelslels]
elalalelalelep: t=1e} 1 | (DS T
Qo0 E (Ol (o R=RE T Lol Relele )=
elalalelale el =78 EE-RE e Ts Lok Relalahs)
Qo055 | &F 1E (0Ll oo0d
eleialalelole LRI ¥y Dz | (DOl o5
ieletelelelole hr i e EF (D201 o006
elslalelaleley: == [ZLenEn s Te Lok Relalaly)
islelelerelelel- RERNFIWCY EE (D001 o008 -

This area displays the results of comparing the memory. Only differences that have been found as a
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result of comparison are displayed.

Mem1 Addr Displays a comparison source address in which a difference has been found.
Memory Displays the data in which a difference has been found.
Left: Comparison source data
Right: Comparison destination data
Mem2 Addr Displays the comparison destination address at which a difference has been
found.

Function buttons

Close

Closes this dialog box.

Help

Opens the Help window.
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DMM dialog box

This dialog box is used to set addresses and data for DMM (Dynamic Memory Modification).
DMM is used to rewrite the memory contents in real time while the user program is being executed.
Because this function is implemented by software emulation, however, the user program under execution

is temporarily stopped and then executed again.

Caution The following points must be noted when using the DMM function.
- If data is written to an address for which a software break is set, the program may not run
correctly.
- If the program is stopped immediately before rewriting the memory because a break event is
generated, the generated break event is invalid because program execution is resumed,
regardless of the break event.

- Verify check is always invalid.

Figure 7-34 DMM Dialog Box

N |
Address=: Il II

Cancel

Data:
=ata I Bestore

Dats Size: % Byte {0 Half Word {7 Wiord Help

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Select [Edit] -> [Memory] -> [Modify] from the menu bar.
(or press Alt+E, M and M in that order).

¢ Click the <Modify> button in the Memory window.
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Explanation of each area

The DMM dialog box consists of the following areas:
(1) Address (address setting area)
(2) Data (data setting area)

(3) Data Size (data size setting area)

(1) Address (address setting area)

Address: Il

This area is used to specify the address to which data is to be written.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.

(2) Data (data setting area)

Data: I
This area is used to specify the data to be written to the memory address specified in Address.
One binary data string can be specified at one time. Specify the data size in Data Size. Specify the

data size in Data Size. The default radix for inputting a numeric value is hexadecimal.
(3) Data Size (data size setting area)

Cata Size: (% Bwte €0 Half Word £ Word

This area is used to specify the size of the data to be written.

Byte Writes data specified in Data as 8-bit data.
Half Word Writes data specified in Data as 16-bit data.
Word Writes data specified in Data as 32-bit data.

Function buttons

OK Writes the data.

Cancel Closes this dialog box.

Restore Restores the input data to the original status.
Help Opens the Help window.
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Watch window

This window is used to display and change specified data.

The result of updating and rewriting data in this window will be reflected in the Memory window.

This window can also display wide-ranging data (such as global variables and public symbols) in real time
even during program execution, in the same way as the Memory window.

To set a breakpoint for read/write access to a variable can be performed by a single action from the menu

that is displayed by clicking the right mouse button.

Caution If a local variable and a global variable exist with the same name, the local variable takes

priority.

Figure 7-35 Watch Window

Add.. Up | Dawn || Refresh || Cle

TOLE TS 24 T xRS
pek-{alen Relslalee]
mfter mma[O] o} el
mfter ama[l] [oF el
mfter ama[2] o} el
mfter amal[3] [oF el
mfter mma[4d] o} el
mafter amal[S] [oF el
mfter mma[E)] o} el
mfter ama[7] [oF el
mfter mma[a] o} el
mfter ama[2] [oF el
| e o

This section explains the following items:

* Opening
» Explanation of each area
 Functions often used (right-click menu)
¢ Function buttons
* Related operations
« To add/delete displayed data (variable)
« To change data on the selected line
« To temporarily display a data (variable) value
« To display/change a local variable value
« To set a breakpoint for read/write access to a variable

» To change displayed radix/size
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Opening

This window can be opened as follows:

¢ Click the Wch button.

Select [Browse] -> [Watch] from the menu bar,
(or press Alt+B, and W in that order).

Select data in the Source window or Assemble window,

* Select [View] -> [View Watch] from the menu bar,
(or press Alt+ V, and | in that order),
or click the <Watch> button.

In the Quick Watch dialog box or Add Watch dialog box dialog box,

* Click the <Add> button.

Explanation of each area

The Watch window consists of the following areas:

(1) Leftfield (symbol name display area)

(2) Right field (data value display/setting area)

(1) Leftfield (symbol name display area)

TS T2 <22 T

aftaer amm [O]
after ama[l]
aftaer aam[2]
after ama[3]
aftaer amm[4]
after amal[5]
after aam[&6]
after =ama[7]
after aam[&]
aftar mma[2]

<

k

This area is used to display variable names, symbol names and types, and tag names of structures or

unions.

Refer to "Name (symbol specification area)" in the Add Watch dialog box for details on the displayed

contents.

'+'is prefixed to the displayed arrays, pointer variables, and structures or unions. These variables are

expanded and displayed as follows when they are double-clicked:

Array

All the elements of the variable are displayed in accordance with the type
of the array variable.
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Pointer variable The data indicated by the pointer is displayed.

Structure/union All the members of the structure/union are displayed in accordance with
the type of the member variable.

If a structure or union is defined in the structure or union, the structure
name or union name of the internal structure or union is also displayed.
The internal structure or union can be also expanded by using '+'.

'+' of the variable that has been expanded and displayed changes to '-'. If the variable is double-
clicked in this status, the expanded display is canceled. Expanded display can be also specified or
canceled by selecting a variable with the arrow keys and then pressing the Enter key.

If an access breakpoint is set for a variable or a symbol in the Watch window, the symbol name display

area is highlighted in gold.

Reference If an array has too many variables and takes too long to expand, a warning message is

displayed.

(2) Right field (data value display/setting area)

LxES
eF{elealstalale]
el
akLale]
el
akLale]
el
w{ele]
el
w{ele]
el
=delel

<] ]

This area is used to display and change data values.

A value is updated when execution is stopped. To save a value, select [File ] -> [Save As...] from the
menu bar when the Save window is the current window. This area is blank if getting data has failed.
'?" is displayed for data that has been invalidated because of a change in the scope or optimized
compiling. The contents of the change are written into the target when the Enter key is pressed. The
previous value can be canceled by the ESC key.

The display format is as follows:
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Table 7-21 Data Display Format (Watch-Related)

Display Data

Contents

Integer

Displayed in the same manner as the language specified in the
Debugger Option dialog box.

C-like (value: xxxx)

Hexadecimal (Oxxxxx)

Decimal (xxxx)

Octal (0xxxx)

Binary (Obxxxx)

Assembly language-like (value: xxxx)
Hexadecimal (xxxxH)

Decimal (xxxxT)

Octal (xxxxQ)

Binary (ObxxxxY)

Enumeration type

Member name

If scope is specified

Displayed in accordance with specified scope

Floating-point type

Single precision/double precision supported
The input/display format is as follows:
[+]-T1inf

[+]-]nan

[+]-]integer e[+ |- ]Jexponent

[ +]-]integer.fraction [e [ + | - ]Jexponent

The size and radix of a data value can be specified on the [View] menu for each variable.

However, the display size cannot be selected if the display size is fixed, such as for variables in C or bit
symbols or registers of the assembler.
If [View] -> [Adaptive] or [View] -> [Proper] from the menu bar is selected, the size and radix specified

in the Debugger Option dialog box are used for display (refer to "To change displayed radix/size").

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking
the right mouse button. In this way, the same function can be used more easily than with the normal

procedure.

Break when Access
to this Variable

Creates a break event that occurs if the selected variable is accessed for
read/write.

Break when Write to
this Variable

Creates a break event that occurs if the selected variable is accessed for
write.

Break when Read
from this Variable

Creates a break event that occurs if the selected variable is accessed for
read.

Clear

Deletes the break event corresponding to the selected variable.

Event?

Displays the event information of the line at the cursor position or the
selected variable.
If an event is set, Event dialog box is opened.
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Change Watch... Changes the selected data.

Delete Watch Deletes the selected watch point from the window.

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.

Symbols are displayed in accordance with the setting of Debugger Option
dialog box (default).

Byte Displays the selected line in 8-bit units.

Half Word Displays the selected line in 16-bit units.

Word Displays the selected line in 32-bit units.

Adaptive Displays the selected line as the default value of each variable.

Only this item is valid for a symbol in C language.
Symbols in assembly language are displayed in accordance with the setting
of Debugger Option dialog box (default).

Up Moves the selected line one line up.

Down Moves the selected line one line down.

Function buttons

Add... Opens the Add Watch dialog box.
If data is specified and the <Add...> button is clicked in the Add Watch dialog
box, the specified data is added to the Watch window.

Delete Deletes the specified data from the Watch window.
The DEL key performs the same operation.

Up Moves the selected data one line up.

Down Moves the selected data one line down.

Refresh Updates the contents of the window with the latest data.
Close Closes this window.

Related operations

To add/delete displayed data (variable)
Addition method (any of the following)

» Select a variable name or symbol name and click the <Watch> button in the Source window or
Assemble window.
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« Select a variable name or symbol name in the Source window or Assemble window, and drag it to
the Watch window.

» Specify a variable name or symbol hame and click the <Add> button in the Quick Watch dialog box
or Add Watch dialog box.

Deletion method

 Click a variable name or symbol name (two or more variable or symbol names can be selected
using the Shift or Ctrl key), and click the <Delete> button. A line with an expanded hierarchy, such
as the elements of an array, and members of structures and unions cannot be changed.

To change data on the selected line
To change data (variables), select a line to be changed in the Watch window and select right-click
menu -> [Change Watch...]. The Change Watch dialog box will be opened to change the data.
A line with an expanded hierarchy, such as the elements of an array, and members of structures and

unions cannot be deleted.

To temporarily display a data (variable) value
A data (variable) value can be temporarily displayed in the following two ways:
To display using the balloon watch function
Select data (a variable name) in the Source window or Assemble window. Then place the mouse
cursor on the selected character string. The value of the selected data will be displayed.
To display in the Quick Watch dialog box
Select data (a variable name) in the Source window or Assemble window. Then click the <Quick...>

button. The value of the selected data will be displayed in the Quick Watch dialog box.

To display/change a local variable value
A local variable value can be checked or changed in the Local Variable window, which is opened when
the Loc button is clicked.
In this window, the local variable in the current function is automatically displayed and the displayed
variable cannot be added or deleted.
To change a local variable value, move the cursor to the local variable value display/changing area on
the window and write a value in this area directly from the keyboard.

To determine the displayed contents, use the Enter key. To cancel, use the ESC key.

To set a breakpoint for read/write access to a variable
Select a variable in the Watch window and select [Break when Access to this Variable], [Break when
Write to this Variable] or [Break when Read from this Variable] from the right-click menu. In this way, a
hardware break event will be created in the valid status in accordance with the selected item.

Whether the event has been correctly created can be confirmed on the Event Manager.

To change displayed radix/size
Changing each data (variable) at any time
Select a data (variable) name to be changed in the Watch window or Quick Watch dialog box, and

select the radix and size from the right-click menu.
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Specifying default condition

Adaptive (when display size is specified) or Proper (when display radix is specified) for watching a
symbol that specifies a default value can be set as the default assumption.

This is done in the Watch Default area of the Debugger Option dialog box, which is opened when
[Option] -> [Debugger Option...] is selected from the menu bar.

The size specified under Size is displayed when Adaptive is specified, and the radix specified under

Radix is displayed when Proper is specified.
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Quick Watch dialog box

190

This dialog box is used to temporarily display or change specified data.

Figure 7-36 Quick Watch Dialog Box

Quick Watch

[Proper ]| =] wiew | add | Close |
Mame: LI Mumber: I
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This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Select [View] -> [Quick Watch...]
(or press Alt+V, and Q in that order).

¢ Click the <Quick> button in Source window.
(or press Ctrl+W).

« Click the <Quick> button in Assemble window.
(or press Ctrl+W).

Explanation of each area

The Quick Watch dialog box consists of the following areas:
(1) Name (symbol specification area)
(2) Symbol name display area
(3) Data value display/setting area

(4) Display radix selection area (upper left field)
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(5) Display size selection area (second upper left field)

(6) Number (display number specification area)

(1) Name (symbol specification area)

MName: | NN |

This area is used to specify the data to be displayed.

In the default condition, the character string selected in the window that called this dialog box is
displayed. As necessary, input data from the keyboard to change the character string. This area is
blank if no character string is selected.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories
can be recorded.

If the contents of Name have been changed, the data specified in Name can be displayed in the field

below by clicking the <View> button.

(2) Symbol name display area

« | ’

This area is used to display the variable name and the symbol name.
The displayed contents are the same as those of Name (symbol specification area) in the Add Watch

dialog box.

(3) Datavalue display/setting area

Ox0QO0

« | b

This area is used to display and change data values. The displayed contents and display method are

the same as those of Watch window.
The displayed contents are the same as those of Right field (data value display/setting area) in the

Watch window.

(4) Display radix selection area (upper left field)

Proper LI
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®)

(6)

This area is used to select the display radix.

The display radix of the data name selected in the symbol name display area will be changed.

Proper Variable
The default value of each variable is displayed.
Symbol
Displays data with the radix set in Debugger Option dialog box.
Hex Displays data in hexadecimal numbers (0XXxxx)
Dec Displays data in decimal numbers (Xxxx)
Oct Displays data in octal numbers (0xxxx)
Bin Displays data in binary numbers (Obxxxx)
String Displays character strings.

Display size selection area (second upper left field)

This area is used to select the display size.
The display size of the data selected in the symbol name display area will be changed.

If the display size is fixed, such as when a variable in C or register is to be displayed, it cannot be

changed.
Adaptive Variable
The default value of each variable is displayed.
Symbol
Displays data with the size set in Debugger Option dialog box.
Byte Displays data in 8 bits.
Half Word Displays data in 16 bits.
Word Displays data in 32 bits.

Number (display number specification area)

TR —

This area is used to specify the number of data to be displayed.

Specify blank or a number of 1 to 256.

If this area is blank, data is displayed as a simple variable.

If a number of 1 or more is specified, data is displayed as an array variable.

If an array variable is displayed, '+ is prefixed to the data. By double-clicking this '+, all the elements
of the data are expanded and displayed in accordance with the type of the data (-' is prefixed to the
expanded data. If this '-'is double-clicked, the expanded display is canceled).

If the number of data to be displayed is fixed, such as when a variable in C or register is to be

displayed, the specified number of data is invalid.
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Function buttons

View Displays the data specified in Name in the field below.
Add Displays the data specified in Name to the Watch window.
Close Closes this dialog box.
Data that has not actually been written to the target will be canceled.
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Add Watch dialog box

This dialog box is used to register data to be displayed in the Watch window.

Multiple data with the same symbol name can be registered.

Figure 7-37 Add Watch Dialog Box

Add Watch
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Size: ¥ Adaptive {7 Byte {0 Half Ward ™ idard

Mumber: I
0] 4 I Cancel Restore Help

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Select [View] -> [Add Watch...] from the menu bar
(or press Alt+V, and W in that order).

¢ Click the <Add> button in Watch window.

Explanation of each area

The Add Watch dialog box consists of the following areas:
(1) Name (symbol specification area)
(2) Radix (display radix selection area)
(3) Size (display size specification area)

(4) Number (display number specification area)
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This area is used to specify data to be added to the Watch window.

(1) Name (symbol specification area)

In the default condition, the character string selected in the window that called this dialog box is

displayed. As necessary, input data from the keyboard to change the character string. This area is

blank if no character string is selected.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.

The format in which a variable can be input and how a variable is handled when a scope is specified

are as follows:

* Variable Name

Variable expression : Variable Name

|Variable expression[Constant value | Variable Name]

|Variable expression .

|Variable expression -> Member name

|*Variable expression

|&Variable expression

Register name

IOR name, IOR bit name

Member name

Label and address of immediate value

Register name . bit

Entity members of structure/union

Elements of array

Value of pointer variable

Address where variable is located

Label name . bit , address of immediate value . bit

Specification of scope

Members of structure/union indicated by pointer

Scope Specification Program name File name Function name ngﬁ]bée
prog$file#functtvar prog file func var
prog$file#var prog file Global var
prog$func#var prog Global func var
prog$var prog Global Global var
file#tfunc#tvar Current file func var
file#var Current file Global var
func#var Current Current func var
var Current Current Current var
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(2) Radix (display radix selection area)

Radix: % Proper {7 Hex {7 Dec ) Dot 0 Bin {7 Strine

This area is used to change the radix of the data to be displayed.

Proper Variable
The default value of each variable is displayed.
Symbol
Displays data with the radix set in Debugger Option dialog box.
Hex Displays data in hexadecimal numbers (0XXxxx)
Dec Displays data in decimal numbers (xxxx)
Oct Displays data in octal numbers (0xxxx)
Bin Displays data in binary numbers (Obxxxx)
String Displays character strings.

(3) Size (display size specification area)

(4)

Size: " Adaptive {7 Byte {0 Half Word {7 Word
This area is used to change the size of data to be displayed.
If the display size is fixed, such as when a variable in C or a bit symbol or register of the assembler is

to be displayed, it cannot be changed.

Adaptive Variable
The default value of each variable is displayed.
Symbol
Displays data with the size set in Debugger Option dialog box.
Byte Displays data in 8 hits.
Half Word Displays data in 16 bits.
Word Displays data in 32 bits.

Number (display number specification area)

Mumber: I

This area is used to specify the number of data to be displayed.

Specify blank or a number of 1 to 256.

If this area is blank, data is displayed in Watch window as a simple variable.

If a number of 1 or more is specified, data is displayed in the Watch window as an array variable.
The maximum number of lines that can be displayed in the Watch window is 10,000.

If an array variable is displayed, '+' is prefixed to the data. By double-clicking this '+, all the elements
of the data are expanded and displayed in accordance with the type of the data ('-' is prefixed to the
expanded data. If this '-'is double-clicked, the expanded display is canceled).

If the number of data to be displayed is fixed, such as when a variable in C or register is to be
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displayed, the number of data is invalid in the Watch window even if it has been changed.

Function buttons

Add Adds the specified data to the Watch window.
The dialog box remains open.

OK Adds the specified data to the Watch window.
Closes this dialog box.

Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Change Watch dialog box

This window is used to change the data on a line selected in the Watch window.

A line with an open hierarchy, such as the elements of an array, and members of structures and unions
cannot be changed.

When watch data is changed, the contents of the selected line are replaced with the new data.

The symbol name can be changed even if it results in duplication of a name already in use with existing

data.

Figure 7-38 Change Watch Dialog Box

Change Watch

Mame: Lime ower LI Add |
Radix: % Proper {7 Hex {7 Dec 7 Dot i Bin i Sirine
Size: % Adaptive {7 Byte {7 Half Ward 7 idard

Mumber: I
o] 8 I Cancel| Restore Help

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

When the Watch window is open or a line is selected

« Select [View] -> [Change Watch...] from the menu bar
(or press Alt+V, and G in that order).

Explanation of each area

The Change Watch dialog box consists of the following areas:
(1) Name (symbol specification area)
(2) Radix (display radix selection area)
(3) Size (display size specification area)

(4) Number (display number specification area)
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@)

)

@)

(4)

Name (symbol specification area)

=

This area is used to change a symbol name.

By displaying the input history, the contents previously input can be reused. Up to 16 input histories

can be recorded.

The format in which a symbol name can be input is the same as that of Name (symbol specification

area) in the Add Watch dialog box.

Radix (display radix selection area)

Radis: % Proper {7 Hex {7 Dec 0 Dot {7 Bin {7 String

This area is used to change the radix of data to be displayed.

Proper Variable
The default value of each variable is displayed.
Symbol
Displays data with the radix set in Debugger Option dialog box.
Hex Displays data in hexadecimal numbers (0XXxxx)
Dec Displays data in decimal numbers (Xxxx)
Oct Displays data in octal numbers (0xxxx)
Bin Displays data in binary numbers (0Obxxxx)
String Displays character strings.

Size (display size specification area)

Size: o Adaptive i Evte i Half Ward [ Wiard

Displays and modifies variables.

If the display size is fixed, such as when a variable in C or register is to be displayed, it cannot be

changed.
Adaptive Variable
The default value of each variable is displayed.
Symbol
Displays data with the size set in Debugger Option dialog box.
Byte Displays data in 8 bits.
Half Word Displays data in 16 bits.
Word Displays data in 32 bits.

Number (display number specification area)

Mumbet: I
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This area is used to specify the number of data to be displayed.

Specify blank or a number of 1 to 256.

If this area is blank, data is displayed in Watch window as a simple variable.

If a number of 1 or more is specified, data is displayed in the Watch window as an array variable.

The maximum number of lines that can be displayed in the Watch window is 10,000.

If an array variable is displayed, '+' is prefixed to the data. By double-clicking this '+, all the elements

of the data are expanded and displayed in accordance with the type of the data (-' is prefixed to the

expanded data. If this '-'is double-clicked, the expanded display is canceled).

f the number of data to be displayed is fixed, such as when a variable in C or register is to be

displayed, the number of data is invalid in the Watch window even if it has been changed.

Function buttons

Add Cannot be selected.

OK Replaces the registration contents currently selected with the specified data,
and then closes this dialog box.
Closes this dialog box.

Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Local Variable window

This window is used to display and change the local variable in the current function.
This window automatically displays the local variable in the current function. It is linked with the jump
function of the Stack Trace window, and displays the local variable in the function jumped when jumping to

the Source window. Variables cannot be added or deleted.

Figure 7-39 Local Variable Window,
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This section explains the following items:

« Opening
« Explanation of each area
« Functions often used (right-click menu)

¢ Function buttons

Opening

This window can be opened as follows:

¢ Click the Loc button.

« Select [Browse] -> [Local Variable] from the menu bar,
(or press Alt,+B, and L in that order).

Explanation of each area

The Local Variable window consists of the following areas:
(1) Leftfield (local variable name display area)

(2) Right field (local variable value display/setting area)
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(1) Leftfield (local variable name display area)

1
)
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tim.
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tim.
tim.
tim.
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|
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This area displays local variable name.

Auto, internal Static, and Register variables can be displayed.

The display format is the same as that of the Watch window.

This area cannot be edited directly.

Right field (local variable value display/setting area)

iel-{elelslalatalel=)
D000 0005
QOO0 52
Ox0QOO2TED
(el el e iy nlie
CxFFFF&Dad
iel-{elolelalaleleh]
Ox0000dB5ES
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iel-{alelslalataleal) ]

J ]
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This area displays local variable values.

The display format of the variable value is the same as that of the Watch window.

The display radix of variables can be switched by the menu selection in accordance with each variable.

The new value is written into the target when the Enter key is pressed. The previous value can be

canceled by the ESC key.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.

In this way, the same function can be used more easily than with the normal

procedure.
Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.
Bin Displays the selected line in binary numbers.
Oct Displays the selected line in octal numbers.

202

User's Manual U16217EJ1VOUM



CHAPTER 7 WINDOW REFERENCE

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger
Option dialog box (default).

Function buttons

Refresh

Updates the contents of the window with the latest data.

Close

Closes this window.
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Stack Trace window

This window is used to display or change the current stack contents of the user program.
From this window, you can also jump to the Source window, Assemble window, Memory window, and

Coverage window corresponding to the stack contents.
Caution  The stack trace display function may not operate correctly if there is a function that does not
create a stack frame. In addition, [ERROR] may be displayed during prologue or epilogue

processing of a function.

Figure 7-40 Stack Trace Window

Refresh | Shrink <54 | Close |
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This section explains the following items:

« Opening
« Explanation of each area
« Functions often used (right-click menu)

¢ Function buttons

Opening

This window can be opened as follows:

* Click the Stk button.

« Select [Browse] -> [Stack Trace] from the menu bar,
(or press Alt+B , and K in that order).
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Explanation of each area

The Stack Trace window consists of the following areas:
(1) Leftfield (stack frame number display area)
(2) Center field (stack frame contents display area)

(3) Right field (stack contents display/setting area)

(1) Leftfield (stack frame number display area)

OO0

This area assigns numbers to and displays the stack contents.
A stack frame number is a natural number starting from 1. The shallower the nesting of the stack, the
higher the number. This means that a function having stack number one higher than that of a certain

function is the function that calls the certain function.

(2) Center field (stack frame contents display area)

sanple. cutfmain. cfmain
mrbto__owver
i
j .
meto__time
+tim

< | o

This area displays the stack frame contents.

It displays function names or local variable names. Note, however, that this area cannot be directly
edited.

If the stack contents consist of a function, they are displayed as follows:

program name$file name#function name (argument list) #line number

If this line is double-clicked, the operation will be the same as jumping to the Source window of the
jump function (i.e., the local variable in the function to which execution has jumped will be displayed in
the Local Variable window).

If the function has a local variable, the local variable will be displayed on the next and subsequent
lines.

If the stack contents consist of a local variable, its type and name are displayed. These are displayed

User's Manual U16217EJ1VOUM 205



CHAPTER 7 WINDOW REFERENCE

in the same manner as in the Watch window. Note that the internal Static and Register variables are

not displayed.

(3) Right field (stack contents display/setting area)

aldelelslalalelels)
sl delejslalalaleh]
e delerelalalels b
S Leletelelayry cic)
D20l oo s D

< ] ]

This area is used to display or change the stack contents.

- or a local variable value is displayed. If the stack contents are a function '-' is displayed and the
function cannot be changed.

If the stack contents are a local variable, the variable value is displayed in the same manner as in the
Watch window.

The display radix of variables can be switched by the menu selection in accordance with each variable.
A variable value can be changed. The new value is written into the target when the Enter key is
pressed. The previous value can be canceled by the ESC key.

This area is used as the jump source area of the jump function.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button. In this way, the same function can be used more easily than with the normal

procedure.

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger Option dialog
box (default).
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Source Text Displays the corresponding source text and source line from the jump
destination address specified by the data value at the cursor position (the local
variable in the function to which you have jumped is displayed in the Local
Variable window).

If no line information exists at the jump destination address, however, you
cannot jump.

Opens the Source window.

If an active Source window is open, that window is displayed in the forefront (so
that it can be manipulated).

Assemble Disassembles and displays starting from the jump destination address specified
by the data value at the cursor position.

Opens the Assemble window.

If an active Assemble window is open, that window is displayed in the forefront
(so that it can be manipulated).

Memory Displays the memory contents starting from the jump destination address
specified by the data value at the cursor position.

Opens the Memory window.

If an active Memory window is open, that window is displayed in the forefront (so
that it can be manipulated).

Coverage Displays the coverage measurement results starting from the jump destination
address specified by the data value at the cursor position.

Opens the Coverage window.

If an active Coverage window is open, that window is displayed in the forefront
(so that it can be manipulated).

Function buttons

Refresh Updates the contents of the window with the latest data.
Shrink<<< Collapses the local variable list of the selected function.
Expand>>> Displays the local variable list of the selected function.
Close Closes this window.
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Register window

This window is used to display and change the contents of registers (program registers and system
registers).

The register to be displayed in this window can be selected in the Register Select dialog box.

Figure 7-41 Register Window
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This section explains the following items:

« Opening
« Explanation of each area
« Functions often used (right-click menu)
* Function buttons
« Related operations
» To change a register value

 To select the register to be displayed

Opening

This window can be opened as follows:

¢ Click the Reg button.

« Select [Browse] -> [Register] from the menu bar,
(or press Alt+B, and R in that order).
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Explanation of each area

The Register window consists of the following areas:

(1) Upper left field (program register display area)

(2) Lower left field (system register display area)

(1) Upper left field (program register display area)

)
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This area is used to display or change the contents of program registers.
The new value is written into the target when the Enter key is pressed. The previous value can be
canceled by the ESC key.

This area is also used as a jump pointer of the jump function.

Lower left field (system register display area)
g COOO0SAR
eipa COO00 SRS
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This area is used to display or change the contents of system registers.

The new value is written into the target when the Enter key is pressed. The previous value can be
canceled by the ESC key.

If the name of a register with '+' prefixed is double-clicked, the names and values of its flags are
displayed, and '+' changes to '-'. This '+' can be also changed to '-' by selecting a register name with
the arrow keys and pressing the Enter key.

This area is also used as a jump pointer of the jump function.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button. In this way, the same function can be used more easily than with the normal
procedure.
Add Watch Registers a selected character string to the Watch window.

Opens the Add Watch dialog box.
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Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers (default).

Pick Up Displays only the registers selected in Register Select dialog box.
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).

Select... Opens the Register Select dialog box.

Function buttons

Refresh Updates the contents of the window with the latest data.

Close Closes this window.

Related operations

To change a register value
To change the value of a register, move the cursor to the system register display area or program
register display area in the window, and directly write a value from the keyboard.

Press the return key to set the new value. To cancel the change, press the ESC key.

To select the register to be displayed
Use the Register Select dialog box, which can be opened by selecting right-click menu -> [Select...] in

the Register window.
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Register Select dialog box

This dialog box is used to select registers that are not displayed in the Register window.

Figure 7-42 Register Select Dialog Box
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This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

When Register window is the current window,

« Select [View] -> [Select...] from the menu bar
(or press Alt+V, and E in that order).

Explanation of each area

The Register Select dialog box consists of the following area:

(1) Display, No Display (display register selection area)

User's Manual U16217EJ1VOUM 211



CHAPTER 7 WINDOW REFERENCE

(1) Display, No Display (display register selection area)
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This area is used to select registers that are displayed in the Register window, and those that are not.

Display

Registers displayed in the Register window.

No Display

Registers not displayed in the Register window.

To display or not display a register in the Register window, select a register name from these lists, and

click the <<<Show> or <Hide>>> button. To display all the registers, click the <<<Show All> button. To

not display any of the registers, click the <<<Hide All> button.

The function of each button is as follows:

<< Show Moves the register selected from the No Display list to Display.
Hide >> Moves the register selected from the Display list to No Display.
<< Show All Moves all registers to Display.

Hide All >> Moves all registers to No Display.

When selecting a register from the lists, two or more registers can be selected by clicking any of the

above buttons while holding down the Ctrl or Shift key.

Function buttons

OK Reflects the selection in this dialog box inRegister window and closes this
dialog box.

Cancel Cancels the changes and closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.
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IOR window

This window is used to display and change the contents of peripheral I/O registers and the 1/O ports that
have been registered in the Add I/O Port dialog box.

Note, however, that the values of read-only peripheral 1/O registers and 1/O ports cannot be changed. In
addition, the peripheral 1/O registers and I/O ports that cause the device to operate when they are read are
read-protected and therefore cannot be read.

To read these registers, select a register, and select and execute [Compulsion Read] from the right-click

menu.
Reference If the device supports programmable 1/O registers and a programmable 1/O area has been set
in the Configuration dialog box, the programmable 1/O registers are also displayed. If the

value of an I/O port address is defined, the I/O port name is displayed in light color.

Figure 7-43 10R Window

Close I
Ottribute

FREPRERPEREE R
G0 0o 02 0o 0o 00 0o 0o 0o Go P

This section explains the following items:

» Opening
« Explanation of each area
 Functions often used (right-click menu)
* Function buttons
* Related operations
» To change a peripheral I/O register value
 To select a peripheral I/O register or I/O port to be displayed
« To change the display sequence
» To change the display radix
« To add, change the contents of, and delete a user-defined 1/0O port

« To change the display start position
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Opening

This window box can be opened as follows:

¢ Click the IOR button.

« Select [Browse] -> [I/O Register] from the menu bar

(or press Alt,+B, and G in that order).

Explanation of each area

The IOR window consists of the following areas:

1)

)

(1) Name (peripheral 1/O register name display area)
(2) Attribute (attribute display area)

(3) Value (peripheral I/O register contents display area)

Name (peripheral I/O register name display area)

This area displays the names of peripheral I/O registers and I/O ports.
When the IE-703102-MC, IE-V850E-MC or IE-V850E-MC-A is used, it also displays the programmable
peripheral I/O registers and expansion peripheral I/O registers.

If the value of an I/O port address is not defined, the 1/0 port name displayed in light color.

Attribute (attribute display area)

Attribute

1,5
R/ 1.8 QOFFFOO
R/ 1.8 QOFFFOO
R/ 1.8 QOFFFOO
R/ 1.8 QOFFFOO
R/ 1.8 QOFFFOO
R/ 1.8 QOFFFOO
R/ 1.8 QOFFFOL
R/ 1.8 QOFFFOL
R/ 1.8 QOFFFO2
R/ 1.8 QOFFFO2

This area displays the read/write attributes, access types, and absolute addresses of the peripheral I/O
registers and I/O ports. when the bit peripheral 1/O register is displayed, bit-offset value is also
displayed.

It can be specified whether this area is displayed or not, by selecting [View] -> [Attribute] from the
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menu bar. As an attribute, the following contents are displayed.

Read/Write Attribute

R Read only
W Write only
R/W Read/write

Register that is read via an emulation register to prevent the device from operating
when this register is read.

To read this attribute directly from a peripheral 1/0O register, execute [View] ->
[Compulsion Read] from the menu bar.

Even a write-only peripheral 1/O register can also be read via an emulation register.
However, some devices do not support this function.

Access Type

1 Can be accessed in bit units.

8 Can be accessed in byte units.

16 Can be accessed in halfword units.
32 Can be accessed in word units.

(3) Value (peripheral I/O register contents display area)

FF hd

This area is used to display and change the contents of a peripheral 1/O register and 1/O port.

The contents are displayed differently as follows, depending on the attribute:

Black Display Read only or read/write

- Write only

* Value changes if read

The new value is written into the target when the Enter key is pressed. The previous value can be

canceled by the ESC key.
The value of read-protected peripheral I/O registers and I/O ports can be read by selecting right-click

menu -> [Compulsion Read].
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Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button. In this way, the same function can be used more easily than with the normal

procedure.

Move... Moves the display position.
Opens the Address Move dialog box.

Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.

Add 1/O Port ... Adds user-defined 1/0 ports.
Opens the Add I/O Port dialog box.

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers (default).

Sort By Name Displays in alphabetical order.

Sort By Address Displays in address order (default).

Unsort Does not sort.

Attribute Displays or does not display an attribute area (Attribute).
Checked: Displayed (default)
Not checked: Not displayed

Pick Up Displays only the registers selected in IOR Select dialog box.
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).

Select... Opens the IOR Select dialog box.

Compulsion Read Forcibly reads the peripheral I/O registers that are disabled from being read
because their values will be changed, or the data of the I/O ports and 1/O
protect area added in Add 1/0O Port dialog box.

Function buttons

Refresh Updates the contents of the window with the latest data.

Close Closes this window.
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Related operations

To change a peripheral 1/0 register value
To change the contents of a peripheral I/O register or 1/0 port, move the cursor to the Value area on the
window, and write a value directly from the keyboard.
Press the return key to set the new value. To cancel the change, press the ESC key.

Note that the values of read-only peripheral 1/O registers and 1/0 ports cannot be changed.

To select a peripheral 1/0 register or I/O port to be displayed
Use the IOR Select dialog box, which can be opened by selecting right-click menu -> [Select...] in the

IOR window.

To change the display sequence
The display sequence can be changed by selecting right-click menu -> [Sort By Name/Sort By

Address/Unsort].

To change the display radix

Select the line whose radix is to be changed, and select right-click menu -> [Bin/Oct/Dec/Hex].

To add, change the contents of, and delete a user-defined 1/O port
To manipulate an I/O port, use the Add I/O Port dialog box, which can be opened by selecting right-
click menu -> [Add I/O Port...] in the IOR window.

To change the display start position
Use the Address Move dialog box, which can be opened by selecting right-click menu -> [Move...] in

the Assemble window.
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IOR Select dialog box

This dialog box is used to select peripheral 1/0 registers and 1/O ports that are not displayed the IOR
window.

Itis also used to specify the sequence in which registers and ports are displayed.

Figure 7-44 IOR Select Dialog Box
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This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

When IOR window is the current window

« Select [View] -> [Select...] from the menu bar
(or press Alt+V, and E in that order).

Explanation of each area

The IOR Select dialog box consists of the following areas and buttons:
(1) Display, Pick Up, No Display (display peripheral I/O register selection area)

(2) Arrange (display sequence specification button)
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(3) Sort by (No Display list display sequence change button)

(1) Display, Pick Up, No Display (display peripheral I/O register selection area)

Display: = Pick Up

FO ry <€ Shaws |
2 Hide > |
Eg 44 Shgwe Al |
ES Hide All 3> |

P10

Phid
Pt

P2
Phis
Phad
PHi5

PMG R

This area is used to select registers and 1/O ports that are displayed or not displayed on the IOR

Mo Display:

window.
Display Registers and 1/O ports are displayed in the IOR window
No Display Registers and 1/O ports are not displayed in the IOR window

To display or not display a register or 1/O port in the IOR window, select the name of the register or 1/O
port from these lists, and click the <<<Show> or <Hide>>> button. To display all the peripheral I/O

registers, click the <<<Show All> button; to not display any of the registers, click the <Hide All>>>

button.
<< Show Moves the register or I/O port selected from the No Display list to Display.
Hide >> Moves the register or I/O port selected from the Display list to No Display.
<< Show All Moves all the registers and I/O ports to Display.
Hide All >> Moves all the registers and I/O ports to No Display.

When selecting a peripheral 1/O register from the list, two or more registers can be selected by clicking

any of the above buttons with the Ctrl or Shift key held down.

(2) Arrange (display sequence specification button)

—&prange

Top
Up
Davan

Bottom

il

This button sets the sequence in which the registers and 1/O ports are displayed in the Display list.
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A peripheral 1/O register or I/O port selected in the Display list can be moved to the top of the list by
pressing the <Top> button, or to the bottom of the list by pressing the <Bottom> button. The <Up>

button moves the register or port one line up. The <Down> button moves the register or port one line

down.
Top Moves the selected peripheral 1/O register or 1/0O port to the top of the list.
Up Moves the selected peripheral 1/O register or 1/0 port one line up.
Down Moves the selected peripheral 1/O register or 1/0 port one line down.
Bottom Moves the selected peripheral 1/O register or 1/O port to the bottom of the list.

(3) Sort by (No Display list display sequence change button)

Sort by ———

MHame |
Addresz |

This button selects the sequence in which peripheral I/O registers and 1/O ports are displayed in the No

Display list.
Pressing the <Name> button sorts the registers and ports into alphabetical order. The <Address>

button sorts them into address order.

Name Displays in alphabetical order.

Address Displays in address order.

Function buttons

OK Reflects the selection in this dialog box inlOR window and closes this dialog
box.

Cancel Cancels the changes and closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.
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Add 1/0 Port dialog box

This dialog box is used to register an I/O port to be added to the IOR window.

Figure 7-45 Add I/O Port Dialog Box
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Cancel |
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This section explains the following items:

« Opening

« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Select [Option] ->[Add I/O Port...] from the menu bar
(or press Alt+O, and P in that order).

Explanation of each area

The Add I/O Port dialog box consists of the following areas:

1)
)
®)
(4)
(5)

I/O Port List: (/O port selection area)

Name: (I/O port name specification area)
Address: (I/0 port address specification area)
Access (access size specification area)

Read / Write (access attribute specification area)
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(1) /O Port List: (/0O port selection area)

150 Port List:

This area lists the I/0 ports currently registered.
If a new I/O port is registered, it is added to this list. In addition, an I/O port already registered can be

selected and changed or deleted.

(2) Name: (I/O port name specification area)

Mame: ||
This area is used to specify an I/O port name to be added. An I/O port name can be up to 15

characters long.

(3) Address: (I/O port address specification area)

Address: I

This area is used to specify the address of the I/O port to be added.

Only an address in one of these areas can be specified: Target area, IOR area

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.

(4) Access (access size specification area)

Aooess
’V % Byte 0 Half Word € Wiord

This area is used to specify the access size of the I/O port to be added.

Byte 8 bits (default)
Half Word 16 bits
Word 32 bits
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(5) Read / Write (access attribute specification area)

Read & Write

[ Read Only [ Wikite Only

[ Read Protect

This area is used to specify the access attribute of the I/O port to be added.

In the default condition, all the attributes are not checked (i.e., the 1/O port can be both read and

written).
Read Only Read only
Write Only Write only

Read Protect

Read-protected

Function buttons

OK Reflects the result of addition in IOR window and closes this dialog box.
Cancel Cancels changes and closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.

Add Adds an I/O port of the specified address.

Change Changes the setting of the 1/0 port selected in 1/O Port List.

Delete Deletes the I/O port selected in 1/0 Port List.
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Trace window

The Trace window displays the trace results.

This window is only in the active status and is updated when a break occurs or step execution is
performed. The source file can also be displayed with the trace results (refer to "Normal display and mixed
display").

The tracer is enabled by selecting [Option] -> [Tracer On] from the menu bar.

To manipulate the tracer during program execution, select [Run] -> [Tracer Start/Stop] from the menu bar.

For details of the trace function, refer to "Trace function".

Figure 7-46 Trace Window

Search.. I < I i I Refresh I Close I
Frame Time Addresg Data Status Addregs Dats Status ExtProbe Diszhszm
[32747 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a ;l
[32748 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a
[32745 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a
[32750 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a
[32751 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a
[32752 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a
[32753 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a
[32754 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a
[32755 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a _|
[32756 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a v
[32757 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a -
[32758 3 000005A2 BEOEEE0E BRM1 1] br _maintix21a T
kIl o

This section explains the following items:

* Opening
» Explanation of each area
 Functions often used (right-click menu)
¢ Function buttons
* Related operations
» To make the trace function usable
 To set trace control mode
« To set a section trace event and quality trace event
« To change the display start position
 To search trace data
* To clear trace data

 To turn on/off the tracer during program execution

224 User's Manual U16217EJ1VOUM



CHAPTER 7 WINDOW REFERENCE

« For pick up display

 To display the source text (mixed display mode)

 To select the display item and change the display radix
« To execute DMA trace

« To set a time tag counter, count rate, and total time tag

Opening

This window can be opened as follows:

¢ Click the TrW button.

« Select [Browse] -> [Trace] from the menu bar
(or press Alt+B, and T in that order).

Explanation of each area

The Trace window consists of the following areas:
(1) Point mark display area
(2) Trace mode display area

(3) Trace result display area

(1) Point mark display area
This area displays Event setting status.
If an execution event or access event is set at the corresponding trace address, the mark
corresponding to the type of the event is displayed.
The mark displayed is not that during trace but an event mark that is set when the trace result is

displayed.

(2) Trace mode display area
This area displays the types of trace modes.

If a qualify trace condition is satisfied while a section trace condition is satisfied, 'Q" is displayed.

D Delay frame

M DMA access frame
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(3) Trace result display area

(al (b} tcl {d} (el (f)
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This area displays the trace results.

This area has two display modes: Normal display and mixed display. In addition, Jump Function and
Trace Result with Linking Window can be used in this area.

Whether each of the following sub-areas is displayed or not can be selected in the Trace Data Select
dialog box.

(a) Frame (trace frame number display)

This area displays trace frame numbers.

(b) Time (time tag display)

This area displays how many clocks the target chip has required since execution of the preceding trace
contents was started until execution of the current trace contents is started. As the display contents,
display of the number of clocks or display of time can be selected in the Trace Data Select dialog box.
In addition, the division rate of the number of counts can be selected up to 1M in the Extended Option
dialog box.

The number of clocks and time tag value correspond as follows:

Table 7-22 Number of Clocks and Time Tag Value

Number of Time Tag Value
Clocks Division rate 1 Division rate 2 Division rate 4 Division rate 8
1 1 1 1 1
2 2 2 5 5
3 3 2 5 )
4 4 3 5 5
5 5 3 5 5
6 6 4 3 5
7 7 4 3 )
8 8 5 3 5
9 9 5 3 5

If <Add Up Timetag> is checked, the total is displayed.

Caution 65535 is displayed in the case of an overflow.
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(c) Address Data Status (fetch access display)

This area displays the result of fetching the program.

The display contents of Address and Data differ depending on the Status display.
Status

The following types of statuses are available:

Program fetch display

BRM1 Fetching of first byte of first instruction after branch
A line is displayed in blue for emphasis if the fetched address is the top of a
symbol.

M1 Fetching of first byte of instruction

Blank Fetching of sixth or eighth bytes of instruction,
or invalid fetch on occurrence of interrupt
* With IE-703102-MC, IE-V850E-MC or IE-V850E-MC-A

Snap display

SNAP Snap display

Reference  When a 6-byte or 8-byte instruction code is displayed, the first 4 bytes are displayed in the
first frame, and the other bytes are displayed in the second and third frames. If two
instructions are executed at the same time, one frame is displayed on two lines. The
instruction code at the lower address is displayed on the first line and the instruction code at

the higher address is displayed on the second line.

Address Data

Displays addresses and data. The display contents differ as follows, depending on the Status display.

Program fetch display

Address Displays the fetch address

Data Displays the fetch data

Snap display

Item Snap Type Display Contents

Address Register Register name
Peripheral I/O register Peripheral I/O register name
Memory Memory address

Data Register Register value
Peripheral I/O register Peripheral I/O register value
Memory Memory contents
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(d) Address Data Status (data access display)
This area displays the result of accessing data.

Data access by DMA or REFRASH cannot be traced.

Status
R Data read
W Data write

(e) ExtProbe (external sense data display)
This area displays the input level of the external sense clip during a trace.

Each bit corresponds to an external sense clip number as follows:

Table 7-23 Correspondence Between External Sense Data and External Sense Clip

External Sense Data Display External Sense Clip No.
bit 7 No.7
bit 6 No.6
bit 5 No.5
bit 4 No.4
bit 3 No.3
bit 2 No.2
bit 1 No.1
bit 0 No.0

Only when the IE-703102-MC, IE-V850E-MC or IE-V850E-MC-A is connected to the ID850, eight
external sense clips are used; otherwise four external sense clips are used. If four external sense clips
are used, the higher 4 bits are always fixed to O.

(f) DisAsm (mnemonic display)

This area displays the result of disassembly (only when the status of fetch access display is BRM1 or
M1).

To display instruction codes when two instructions are simultaneously executed, one instruction is

displayed on the first line, and the other instruction is displayed on the second line.

Normal display and mixed display

In the normal display mode, only the trace result is displayed.
In the mixed display mode, the source file is also displayed along with the trace result.
If a program code corresponds on the program fetch address to be displayed, a source file line is

displayed before the line indicating the result of tracing that program fetch address.
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Frame Time Address Data Status Address Dats Status ExtProbe DisAsm

32757 3 000005A2 BEOSEE0S BRM1 o0 br _maintix21a ;I

32758 3 000005.%3%!;85%%65 BRH1 o0 br _maintix21a

32755 3 000005.%3%!;85%%65 BRH1 o0 br _maintix21a

32760 3 000005.%3:%!5:85%%65 BRH1 o0 br _maintix21a
whilell);

The source file line is displayed, emphasized in green.

The display mode can be alternately changed by selecting [View] -> [Mix] from the menu bar.

Caution The mixed display mode is valid only when the load module has been downloaded and
symbol information is read, and when a fetch address, fetch data, fetch status, or result of

disassembly is displayed.

Jump function
This function allows you to jump to the Source window, Assemble window, Memory window or
Coverage window, using the cursor position as a jump pointer (refer to "Jump Function").

To jump from the Trace window, the jump pointer changes as follows, depending on the area in which

the cursor is positioned:

Table 7-24 Cursor Position and Jump Pointer

Cursor Position Jump Pointer

Access Address Display Area Access address
(If the jump destination is the Source window or Assemble
window, the fetch address is always used as the jump pointer.)

Access Data Display Area

Access Status Display Area

Other Fetch address

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.

In this way, the same function can be used more easily than with the normal procedure.

Move... Moves the display position.

Opens the Trace Move dialog box.
Trace Clear Clears the trace data.
Select Selects the contents to be displayed.

Opens the Trace Data Select dialog box.

Pick Up Performs the setting for pickup display.
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Off Does not pick up and display (default).

Search Picks up and displays a frame that satisfies the search condition.

Snap Picks up and displays a snap frame.

BRM1 Picks up and displays the first M1 fetch frame after a program branch.
Mix Specifies whether the results of assembly are displayed in mixed display

mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Window Synchronize

Links the Trace window with the following windows:

Source Text

Links the Source window.

Assemble Links the Assemble window.
Memory Links the Memory window.
Coverage Links the Coverage window.

Source Text

Displays the corresponding source text and source line, using the data value
at the cursor position as the jump destination address.

If no line information exists at the jump destination address, however, you
cannot jump.

Opens the Source window.

If an active Source window is open, that window is displayed in the forefront
(so that it can be manipulated).

Assemble Disassembles and displays starting from the jump destination address
specified by the data value at the cursor position.
Opens the Assemble window.
If an active Assemble window is open, that window is displayed in the
forefront (so that it can be manipulated).

Memory Displays the memory contents starting from the jump destination address
specified by the data value at the cursor position.
Opens the Memory window.
If an active Memory window is open, that window is displayed in the
forefront (so that it can be manipulated).

Coverage Displays the coverage measurement results starting from the jump

destination address specified by the data value at the cursor position.
Opens the Coverage window.

If an active Coverage window is open, that window is displayed in the
forefront (so that it can be manipulated).

Function buttons

Search... Opens the Trace Search dialog box and searches or picks up trace results.

The searched result will be highlighted in the Trace window.

This button cannot be selected when a snap frame or BRM1 frame is picked up and
displayed.

This is the same operation as selecting [View] -> [Search...] from the menu bar.

<< Searches forward (upward on screen) for a trace result that satisfies the search
condition set in the Trace Search dialog box.
This button cannot be selected while pickup display is being performed.
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>> Searches backward (downward on screen) for a trace result that satisfies the search
condition set in the Trace Search dialog box.
This button cannot be selected while pickup display is being performed.

Refresh Updates the contents of the window with the latest data.

Close Closes this window.

Related operations

To make the trace function usable
Select and check [Option] -> [Tracer On] from the menu bar. To invalidate the tracer, select [Tracer On]

again and remove the check mark.

To set trace control mode

Select [Run] -> [Tracer Control Mode] from the menu bar and select one of the following modes:

Non Stop Goes around the trace memory and overwrites data from the oldest
frame (default).

Full Stop Goes around the trace memory and then stops the tracer.

Full Break Goes around the trace memory and then stops the tracer and
program execution. * Displayed only when IE-703102-MC, IE-
V850E-MC or IE-V850E-MC-A is used.

To set a section trace event and quality trace event

Use the Trace dialog box which can be opened by clicking the Trc button.

To change the display start position
Use the Trace Move dialog box that can be opened by selecting right-click menu -> [Move...] in the

Trace window.

To search trace data
Select right-click menu -> [Pick Up] -> [Off] in the Trace window and click the <Search...> button. The

Trace Search dialog box will be opened, enabling trace results to be searched.

To clear trace data
Select the right-click menu -> [Trace Clear] in the Trace window.

This will clear the trace buffer (display contents of the Trace window).

To turn on/off the tracer during program execution
To temporarily stop coverage, select [Run] -> [Tracer Stop] from the menu bar during program
execution. To resume tracer operation, select [Tracer Start].
This operation can be performed only while the program is being executed.

It cannot be performed if the tracer function is disabled (when [Option] -> [Tracer On] is not checked).

For pick up display

Only specific trace data can be picked up and displayed in the Trace window.
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A snap frame, M1 fetch frame, and picking up a frame that satisfies a given search condition can be
selected as pickup conditions.

To pick up and display a snap frame or M1 fetch frame

Select right-click menu-> [Snap/BRM1] in the Trace window. A snap frame or M1 fetch frame will be
picked up and displayed in the Trace window.

To pick up and display only a frame that satisfies the search condition

Select right-click menu -> [Search] in the Trace window and click the <Search> button. The Trace

Search dialog box will be opened, enabling data to be picked up to be set.

To display the source text (mixed display mode)

Select the right-click menu -> [Mix] in the Trace window.

To select the display item and change the display radix

Use the Trace Data Select dialog box, which can be opened by selecting the right-click menu ->
[Select...] in the Trace window.

The display radix can be changed in the fetch data display area and access data display area.

To execute DMA trace

In addition to the normal trace, the results of a DMA trace can be collected, but only when the IE-
V850E-MC or IE-V850E-MC-A is used. Select [Option] -> [DMA Trace] from the menu bar. Set [DMA
Trace] to ON. DMA trace will be executed, taking precedence over memory access by the program.
The frame marked [M] in the trace mode area in the Trace window is the frame traced by the DMA

trace.

To set a time tag counter, count rate, and total time tag

Use the Extended Option dialog box, which can be opened by selecting [Option] -> [Expanded

Option...] from the menu bar.
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Trace Search dialog box

This dialog box is used to search or pick up trace data in Trace window.

This dialog box is used to search trace data if it is opened by selecting [View] -> [Pick Up] -> [Off] from the

menu bar. It is used to pick up and display trace data if it is opened by selecting [View] -> [Pick Up] ->

[Search] from the menu bar.

By setting each item and then clicking the <Find Next> button, searching can be started.

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Trace window can be used

for the search.

Caution  The Trace Search dialog box cannot be called if picking up snap frames and the first M1 fetch

frame (BRM1) after program branch is specified using the menu bar or in Trace Data Select

dialog box.

Figure 7-47 Trace Search Dialog Box
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This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

When Trace window is the current window

¢ Click the <Search> button.
(or press Ctrl+G).

User's Manual U16217EJ1VOUM

233




CHAPTER 7 WINDOW REFERENCE

« Select [View] -> [Search...]
(or press Alt+V, and S in that order).

Explanation of each area

The Trace Search dialog box consists of the following areas:
(1) Event Status (status selection area)
(2) Access Size (access size selection area)
(3) Address, Mask (address setting area)
(4) Data, Mask (data setting area)
(5) Exp Probe, Mask (external sense data setting area)
(6) Scan Whole Region (search condition specification area)
(7) Direction (search direction specification area)

(8) Frame (search range specification area)

(1) Event Status (status selection area)

Event Status:

This area is used to set and select a status condition.
A status condition can also be specified in abbreviated form. Uppercase and lowercase characters are
not distinguished.

If a status condition is omitted, all frames (All status) are searched.

Table 7-25 Types of Status Conditions

Status Abbreviation Meaning
All status ALL All frames (default)
BRM1 Fetch BRM1 First M1 fetch after program branch
M1 Fetch M1 M1 fetch (including BRM1)
R/W RW Data read/write (including R, W)
Read R Data read
Write w Data write

(2) Access Size (access size selection area)

Locess Size:

I Biyte LI

This area is used to set and select an access size condition.

By specifying an access size condition, the access width of a data condition to be detected by an
access event is determined.

An access size condition can also be specified in abbreviated form. Uppercase and lowercase
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characters are not distinguished.

Table 7-26 List of Access Size Conditions (Trace)

Size Abbreviation Meaning

Byte B Searches for a data condition with 8-bit width (only during 8-hit
access).

Half Word HW Searches for a data condition with 16-bit width (only during 16-
bit access).

Word W Searches for a data condition with 32-bit width (only during 32-
bit access).

No Condition NC Does not search based on access size (nothing can be input to
the Data area).

Bit 1 Searches for a data condition with 1-bit width (only during 8-bit
access).
In this case, a search is made for a data condition with 1-bit
width. Because of the operation of the emulator, access to a bit
is not directly detected; the debugger searches a dummy bit
access by internally setting address conditions and data
conditions as follows:
Input example:
Address: FE20.1
Data: 1
Setting of trace search
Address: fe20
Data: 00000010B
Mask: 11111101B
If another bit of the same address is accessed or if all the 8 bits
of the same address are accessed, therefore, an event is
detected in accordance with the specified status if the address
and bit match the specified value of [address.bit].

Caution  If an access event is specified as a status condition, the alternative of Bit is not displayed. If

Bit or 1 is specified, an error occurs.

If no access size condition is specified, a judgment is automatically made from the address condition

and data condition, and the following is set:

« Bit if the address condition is set in bit units

« Byte if the address condition is set in 8-bit units

« Half Word if the address condition is set in 16-bit units

» Word if the address condition is set in 32-bit units

« No Condition if no data condition is specified
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(3) Address, Mask (address setting area)

Address: I - I hask: I

Address, which sets an address value and Mask, which sets the mask value of an address value, are

set as address conditions.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying
Symbols"). The default radix for inputting a numeric value is hexadecimal.

Both the address and mask may be omitted.

The following can be set:

Table 7-27 Settable Range of Address Condition

Settable range Condition
0 =< address value =< OxFFFFFFFF None
0 =< mask value =< OXFFFFFFFF None

Address
Set an address condition.

The following can be set:

Set Point Set a value to only the lower address, or set the same value to the lower
address and the higher address.
Mask can be set.

Set Range Set a value to the lower address and the higher address.
Mask cannot be set.

Setting of Bit Set a value to only the lower address, or set the same value to the lower
address and the higher address. Specify a value in the form of
address.bit.

Mask cannot be set.

The value of bit, which indicates the bit position, must be 0 =< bit =< 7.

Mask
Set a mask value for an address value (only when a point is specified).

The address value of a bit whose mask value is 1 may be 0 or 1.

Example 1:
Address 0x4000 to 0x4000
Mask OxFF

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.
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(4)

Example 2:
Address 0x4000 to 0x4000
Mask 0x101

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.

Data, Mask (data setting area)

Data: I hask: I

Data, which sets an data value, and Mask, which sets the mask value of an data value, are set as data

conditions.
The default radix for inputting a numeric value is hexadecimal.
Both the data and mask may be omitted.

The settable range differs as follows depending on the access size condition specified in the Access

Size area.
Table 7-28 Settable Range of Data Condition
Access Size Settable range
Byte 0 =< data value =< OxFF
0 =< mask value =< OXFF
Half Word 0 =< data value =< OxFFFF
0 =< mask value =< OXFFFF
Word 0 =< data value =< OXFFFFFFFF
0 =< mask value =< OxFFFFFFFF
Bit Data value =0or 1
Mask value = Cannot be specified.
Data

Set a data value. Specify a value within the settable range.

A symbol or expression can be also specified by a symbol or expression (refer to "Table 7-15
Specifying Symbols").

Mask

Set a mask value for the data value.

When a mask is set, the data value for the bit whose mask value is 1 may be O or 1.

The data value for a bit whose mask value is 1 may be 0 or 1.

Example 1:
Data 0x4000
Mask OxFF

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.
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Example 2:
Data 0x4000
Mask 0x101

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.

Exp Probe, Mask (external sense data setting area)

Ext Probe: I Mask: I

This area is used to set an external sense data condition.

External sense data is the input pin level of the external sense clip attached to the emulation probe
connected to the in-circuit emulator (refer to "Table 7-23 Correspondence Between External Sense
Data and External Sense Clip").

External sense data conditions include Ex Probe, which sets an external sense data value, and Mask,
which sets the mask value of an external sense data value.

The default radix for inputting a numeric value is hexadecimal. Both data and mask may be omitted.

Settable range of the external sense data condition is as follows:

Table 7-29 Settable Range of External Sense Data Condition

Settable Range Condition
0 <= Adress value <= OxFF None
0 <= Mask value <= OxFF None
Exp Probe

Specify an external sense data value.

Set the high input pin level of the external sense clip to 1, and the low input level to O.

Caution  Only when the IE-703102-MC, IE-V850E-MC or IE-V850E-MC-A is connected to the 1D850,

eight external sense clips are used; otherwise four external sense clips are used. If four

external sense clips are used, the higher 4 bits are always fixed to 0.

Mask
Set a mask value for the external sense data.

The data value for a bit whose mask value is 1 may be 0 or 1.

Example 1:
Ext Probe 0x8
Mask Ox7

With this setting, the condition is satisfied if the data is 0x8 to OxF.
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Example 2:
Ext Probe 0x8
Mask 0x5

With this setting, the condition is satisfied if the data is 0x8, 0x9, OxC, or 0xD.

(6) Scan Whole Region (search condition specification area)

[ Scan Whole Region

This area is used to specify whether the specified range is fully searched or not.

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)

(7) Direction (search direction specification area)

Direction
’7 0 Up % Down

This area is used to specify the direction of the search.

Up Forward search.
Searches data forward (upward on screen) from the current position
of the cursor.

Down Backward search (default).
Searches data backward (downward on screen) from the current
position of the cursor.

(8) Frame (search range specification area)

Frame: I - I

This area is used to specify a frame number to be searched.
For how to specify a frame number, refer to "Table 7-14 Frame Number Specification Format".

The default radix for inputting a numeric value is decimal.

Function buttons

Find Next Searches the specified data in accordance with a given condition.
If the specified frame is found as a result of a search, it is highlighted. To
continue searching, click this button again.
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Set Find Sets the specified condition as the search condition and closes this dialog
box.
Pick Up Picks up according to the specified condition of data search.

(Stop (during search))

If a frame that satisfies the condition is found as a result of a search, it is
picked up. To pick up a frame that satisfies a different condition, press this
button again.

Cancel

Closes this dialog box.

Help

Opens the Help window.
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Trace Data Select dialog box

This dialog box is used to select items to be displayed in the Trace window.

Figure 7-48 Trac

e Data Select Dialog Box

W Memory Sccess Sddress
[¥ Memary Access Data
W Memory Socess Status
[+ External Probe

¥ Pick Up Off

{7 Pick Up Search Frame
) Pick Up Snap Frame
{7 Pick Up BRM1 Frame

—ltem — Radix
[+ Frame Instruction Fetch Data: HE: -*
¥ Timetag |_F Clock _r' Time Memory Access Data HE -
W Instruction Fetch Address
E::t | Probe: HE:
[# Instruction Fetch Data TIEnAT RS =
¥ Instruction Fetoh Status FPick Up

¥ DisAssemble
o] 4 I Cancel Bestore

Help

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

When Trace window is the current window

« Select [View] -> [Select...] from the menu bar
(or press Alt+ V, and E in that order).

Explanation of each area

The Trace Data Select dialog box consists of the following areas:

(1) Item (trace display item selection area)

(2) Radix (trace display radix selection area)

(3) Pick Up (pickup selection area)
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(1) Item (trace display item selection area)

¥ Timetag |_F Clock iﬁ Time
¥ Instruction Fetch Address

¥ Instruction Fetch [Data

¥ Instruction Fetch Status

v Memory Access Address

v hemary Access Data

v Memory Access Status

w External Probe

ARXEA

W Dizf=semble

This area is used to select items to be displayed in the Trace window. Displaying the following items

may or may not be selected. The field checked is displayed.

Frame Frame number display field
Timetag Time tag display field
Whether the clock or time is displayed can be selected.
Clock...Clock display (default)
Time...Time display
Instruction Fetch Address Fetch address display field
Instruction Fetch Data Fetch data display field
Instruction Fetch Status Fetch status display field
Memory Access Address Access address display field
Memory Access Data Access data display field
Memory Access Status Access status display field
External Probe External sense data display field
DisAssemble Disassemble display field

(2) Radix (trace display radix selection area)

FRadix

Instruction Fetch Data: HE -
Memary Access Data: HEx -
External Probe: HEx -

This area is used to select the radix in which data is to be displayed. Displaying the following items

may or may not be selected.

Display field

Instruction Fetch Data Fetch data display field
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Memory Access Data Access data display field

External Probe External sense data display field
Display radix

HEX Hexadecimal display

DEC Displays decimal numbers.

OCT Displays octal numbers.

BIN Displays binary numbers.

(3) Pick Up (pickup selection area)

Pick Up
% Pick Up Off

{7 Pick Up Search Frame
{7 Pick Up Snap Frame
{7 Pick Up BRM1 Frame

This area is used to select a pick up condition.

Pick Up Off No pick up display

Pick Up Search Frame Picks up and displays a frame that satisfies the search condition.
Pick Up Snap Frame Picks up and displays a snap frame.

Pick Up BRM1 Frame Picks up and displays the first M1 fetch frame after a program branch.

Function buttons

OK Reflects the results of selection in this dialog box in Trace window.
Cancel Closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.
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Coverage window

244

This window displays the coverage results.

The coverage results are displayed only in the range specified in the Coverage-Address dialog box.

Coverage measurement is performed by selecting [Option] -> [Coverage ON].

While the program is

executed, coverage measurement is manipulated by [Run] -> [Coverage Start/Stop] from the menu bar.

The Coverage window has two window statuses: Active Status and Static Status.

Caution The coverage data collected when the IE-V850E-MC or IE-V850E-MC-A is used is only

execution data.

Figure 7-49 Coverage Window
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This section explains the following items:

* Opening

Explanation of each area

Functions often used (right-click menu)

Function buttons

Related operations

To clear the overage result

To change the display bytes

To search the coverage results

To change the display start position

To specify the coverage measurement range

To make the coverage measurement function usable

To turn on/off coverage during program execution
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Opening

This window can be opened as follows:

¢ Click the Cov button.

« Select [Browse] -> [Coverage] from the menu bar
(or press Alt+B, and O in that order).

* Select [Jump] -> [Coverage] from the menu bar
(or press Alt+J and C in that order, or Ctrl+l).

Explanation of each area

The Coverage window consists of the following areas:
(1) Addr (address display area)
(2) 01234... (coverage display area)

(1) Addr (address display area)

Addr

islelelalalalale
Lagelalelaleliiel
islelelolalal=ge
Lagelalelaladeyal
islelelolalal 2o
OO0 50
islelelalalel T
Lagelalelalelryel
islelelolalar b
iagelalelalal-yal
j=jejelelalay e

This area displays coverage addresses.

(2) 01234... (coverage display area)

e
m

x|

L[

W ERHE DA

Ad

o R
ol I e b e g | L
M e M F |
AR M E W
M P RS G
R

R ol Sl o Sl T
R R o Y
e U I B
U ST
R I T IR T
MME R F M0

[44]pr | 4

RN N AR
T o e e | P

This area displays the coverage results.

To select a display mode, use the [View] menu.
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Table 7-30 Status List of Coverage Data

In 1-byte display mode

Display Meaning

Neither execute, read, nor write

Execute only

Read only

Write only

Read and write only

Execute and read only

#|o | > | D] x

Execute and write only

% Execute, read, and write

In 64-/1024-byte display mode

Display Meaning

Neither execute, read, nor write any addresses in the 64-/1024-byte range

Execute all addresses in the 64-/1024-byte range

Read all addresses in the 64-/1024-byte range

Write all addresses in the 64-/1024-byte range

Read and write all addresses in the 64-/1024-byte range

Execute and read all addresses in the 64-/1024-byte range

#| | > s| 0| X

Execute and write all addresses in the 64-/1024-byte range

% Execute, read, and write all addresses in the 64-/1024-byte range

This area has a jump function and a function to link the trace display.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button. In this way, the same function can be used more easily than with the normal

procedure.
Move... Moves the display position.

Opens the Address Move dialog box.
1Byte Displays in 1-byte units (default).
64Bytes Displays in 64-byte units.
1024Bytes Displays in 1024-byte units.
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Source Text Displays the corresponding source text and source line, using the data value at
the cursor position as the jump destination address.

If no line information exists at the jump destination address, however, you cannot
jump.

Opens the Source window.

If an active Source window is open, that window is displayed in the forefront (so
that it can be manipulated).

Assemble Disassembles and displays starting from the jump destination address specified
by the data value at the cursor position.

Opens the Assemble window.

If an active Assemble window is open, that window is displayed in the forefront
(so that it can be manipulated).

Memory Displays the memory contents starting from the jump destination address
specified by the data value at the cursor position.

Opens the Memory window.

If an active Memory window is open, that window is displayed in the forefront (so
that it can be manipulated).

Clear... Clears the coverage measurement results.
Opens the Coverage-Clear dialog box.

Select... Selects the coverage measurement range as a space of 1 MB or more.
Opens the Coverage-Address dialog box.

Condition... Sets a coverage efficiency measurement condition.
Opens the Coverage-Condition Setting dialog box.

Efficiency... Displays coverage efficiency.
Opens the Coverage-Efficiency View dialog box.

Function buttons

Search... Opens the Coverage Search dialog box and searches a coverage result.
The searched result will be highlighted in the Coverage window.
This button is valid only in the 1-byte display mode.

<< Searches forward (upward on screen) for a coverage result that satisfies the
search condition set in the Coverage Search dialog box, starting from the
address at the cursor position.

This button is displayed as the <Stop> button during a search.

This button is valid only in the 1-byte display mode.

>> Searches backward (downward on screen) for a coverage result that satisfies
the search condition set in the Coverage Search dialog box, starting from the
address at the cursor position.

This button is displayed as the <Stop> button during a search.

This button is valid only in the 1-byte display mode.

Stop (during search) | Stops searching.

Refresh Updates the contents of the window with the latest data.

Close Closes this window.
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Related operations

To make the coverage measurement function usable

Select and check [Option] -> [Coverage On] from the menu bar. To disable coverage, select

[Coverage On] again.

To specify the coverage measurement range
Use the Coverage-Address dialog box that can be opened by selecting right-click menu -> [Select...] in

the Coverage window. A measurement range of 1 MB can be selected from a list.

To change the display start position

Use the Address Move dialog box that can be opened by selecting right-click menu -> [Move...] in the

Coverage window.

To set and display the coverage efficiency display condition
Use the Coverage-Condition Setting dialog box, which can be opened by selecting right-click menu ->
[Condition...] in the Coverage window.
As the address condition in which coverage efficiency is to be measured, an address range or a

function can be specified.

The coverage efficiency status is displayed in the Coverage-Efficiency View dialog box, which can be

opened by selecting right-click menu -> [Efficiency...] in the Coverage window.

To turn on/off coverage during program execution
To temporarily stop coverage, select [Run] -> [Coverage Stop] from the menu bar during program
execution. To resume operation, select [Coverage Start].
This operation can be performed only while the program is being executed.

It cannot be performed if the coverage function is disabled (when [Option] -> [Coverage On] is not

checked).

To search the coverage results

Use Coverage Search dialog box, which can be opened by clicking the <Search...> button in the

Coverage window. Data is not searched in a non-mapped area.

To clear the overage result

Use the Coverage-Clear dialog box that can be opened by selecting right-click menu -> [Clear...] in the

Coverage window.

When the coverage measurement result is cleared, the contents of the Coverage window and

Coverage-Efficiency View dialog box are initialized.

To change the display bytes
The display bytes can be changed by selecting right-click menu -> [1Byte/64Byte/1024 Byte] in the

Coverage window.
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Coverage Search dialog box

This dialog box is used to search coverage results in the Coverage window.

This dialog box can be called only in the 1-byte display mode.

By setting each item and then clicking the <Find Next> button, searching can be started.

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Coverage window can be
used for the search.

Searching cannot be executed in a non-mapped area.

Caution The coverage data collected when the IE-V850E-MC or IE-V850E-MC-A is used is only

execution data.

Figure 7-50 Coverage Search Dialog Box

W Execute = Read [$] Zat Find |
Wirite [i0] [¥ Execute x Wiite [#]

Cancel |
Fead x Wiite [8] [ Execute x Read = Wirite [3]
Direction ————————— Help |

i Up % Down

O0O0R

[ Scan Whale Region ’7
Address: I - I

This section explains the following items:

« Opening
< Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:
When the Coverage window is the current window
* Click the <Search...> button.

(or press Ctrl+G).

« Select [View] -> [Search...]
(or press Alt+V, and S in that order).
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Explanation of each area

The Coverage Search dialog box consists of the following areas:
(1) Search data specification area
(2) Scan Whole Region (search condition specification area)
(3) Direction (search direction specification area)

(4) Address (search range specification area)

(1) Search data specification area

: [ Execute [¥]
[ Read [E] [+ Execute x Read [§]
[ eite [ [¥ Execute = Wiite [#]

[ Read «Wirite [A] [ Execute x Read x Write []
Specify a search condition by checking any of the check boxes in this area.
If two or more check boxes are checked, the specified address is searched when any of the conditions

of the check boxes is satisfied (OR search).

No Use [.] Neither execute, read, nor write
Read [R] Read only

Write [W] Write only

Read x Write [A] Read and write

Execute [X] Execute only

Execute x Read[$] Execute and read

Execute x Write [#] Execute and write

Execute x Read x Write [%0] Execute, read, and write

(2) Scan Whole Region (search condition specification area)

[T Scan Whaole Region

This area is used to specify whether the specified range is fully searched or not.

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)

(3) Direction (search direction specification area)

Direction
’7 0 Up % Down

This area is used to specify the direction of the search.
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Up Forward search.
Searches data forward (upward on screen) from the current position
of the cursor.

Down Backward search (default).

Searches data backward (downward on screen) from the current
position of the cursor.

(4) Address (search range specification area)

Addrass: I

This area is used to specify the address to be searched.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.

Function buttons

Find Next Searches the specified data in accordance with a given condition.
If the specified character string is found as a result of a search, it is
highlighted. To continue searching, click this button again.

Set Find Sets the specified condition as the search condition and closes this dialog

box.

Stop (during search)

Stops searching.

Cancel Closes this dialog box.
This button is displayed as the <Stop> button while data is being searched.
Help Opens the Help window.
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Coverage-Clear dialog box

This dialog box is used to clear the coverage measurement results in a specified address range.

As a result, the contents of the Coverage window and Coverage-Efficiency View dialog box are initialized.

Caution The coverage data collected when the IE-V8B50E-MC or IE-V850E-MC-A is used is only

execution data.

Figure 7-51 Coverage-Clear Dialog Box

Address Range: Im - IEIxFFFFF

o] 8 I Cancel | Eestn:urel Help |

This section explains the following items:

* Opening
« Explanation of each area

* Function buttons

Opening

This dialog box can be opened as follows:

« Select [Option] -> [Caverage] -> [Clear...] from the menu bar
(or press Alt+O, O, and L in that order).

Explanation of each area

The Coverage-Clear dialog box consists of the following areas:

(1) Address Range (address specification area)

(1) Address Range (address specification area)

dddress Range: |Osctfennn - |Ouetfelfi
This area is used to specify the addresses whose coverage results are to be cleared.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.
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Function buttons

OK Clears the coverage result in the address range specified in Address Range.

Stop (while cleared) | Stops clearing the coverage result.

Cancel Closes this dialog box.
This button is displayed as the <Stop> button while the coverage result is
being cleared.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Coverage-Address dialog box

This dialog box is used to select the coverage measurement range to be displayed in the Coverage
window.

Coverage measurement is executed within the specified address range.

The selectable coverage measurement range is as follows:

e With IE-703002-MC

Any 1 MB space of addresses 0x000000to OxFFFFFF
(Default: 0x000000 to OXOFFFFF

* With IE-703102-MC, IE-V850E-MC or IE-V850E-MC-A, |E-V850ES-G1
Any 1 MB space of addresses 0x0000000to Ox3FFFFFF
(Default: 0x0000000 to OXOOFFFFF

Caution The coverage data collected when the IE-V850E-MC or IE-V850E-MC-A is used is only

execution data.

Figure 7-52 Coverage-Address Dialog Box

1FFFFF
— ZFFFFF
F00000 — SFFFFFR
4222050 — 4FFFFF
S000:00 — SFFFFFR
GOOO00 — &FFFFF ¥

o] 4 I Cancel | Help |

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [Option] -> [Caverage] -> [Select...] from the menu bar
(or press Alt+O, O, and S in that order).
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Explanation of each area

The Coverage-Address dialog box consists of the following areas:

(1) Address Range (address selection area)

(1) Address Range (address selection area)

Address Renge

iNsTelalatel
200000
BO00000
Eyelelalsiel
=lelelalatel
(zielelalale]

1FFFFF
ZFFFFF
EFFFFF
4FFFFF
ZFFFFF
GFFFFF T

This area is used to select any 1 MB space.

The selected coverage measurement range is set by clicking the <OK> button.

Function buttons

OK Validates the coverage measurement range selected in Address Range.
Cancel Closes this dialog box.
Help Opens the Help window.

User's Manual U16217EJ1VOUM

255



CHAPTER 7 WINDOW REFERENCE

Coverage-Condition Setting dialog box

This dialog box is used to specify the contents (condition) to be displayed in the Coverage-Efficiency

View dialog box

Up to 16 conditions can be registered.

Caution The coverage data collected when the IE-V8B50E-MC or IE-V850E-MC-A is used is only

execution data.

Figure 7-53 Coverage-Condition Setting Dialog Box

0 ]8 | W ey | Bestore | Help I

Surwey List

OscF 000 - Oxffe0ff | Clear |
samp le. out$sub . clt_comp_char Delete |

Inzert

Address Rangs:  [Dxffe000 - |Owitentt

Function: Isa mple.outsub.clt_comp_char LI

Survery Condition
’7 % Execute " Fead 7 Wi ite oAl

This section explains the following items:

« Opening
« Explanation of each area
« Specifying

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [Option] -> [Caverage] -> [Candition...] from the menu bar
(or press Alt+O, O, and O in that order).

« Click the <Condition> button in Coverage-Efficiency View dialog box.
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Explanation of each area

The Coverage-Condition Setting dialog box consists of the following areas:

@)

)

@)

(1) Survey List (selected list display area)
(2) Address Range, Function (address condition specification area)

(3) Survey Condition (status condition specification area)

Survey List (selected list display area)

Survey List

Owffelll) - Oxffelff
zame e, out $=ub. of_comp_char

This area displays a list of the conditions currently selected.

Address Range, Function (address condition specification area)

Address Rangs:  [0xff=000 - |Oxtfenfi

Function: Isamp|e.nut$sul:u.-:#_-:nmp_char ;I
This area specifies an address condition for the coverage efficiency.
An address condition can be specified in two ways. To specify a condition as an address range, use

Address Range. To specify a condition as a function, use Function.

Address An address can be also specified by a symbol or expression (refer to
"Table 7-15 Specifying Symbols"). The default radix for inputting a
numeric value is hexadecimal.

Function A function can be specified by selecting from the drop-down list or by
inputting from the keyboard. Specify a function name that has been
registered to the load module file.

Survey Condition (status condition specification area)

Survery Condition
’7 {* Execute {7 Fead 0 Wik ite Al

This area is used to select a status condition for the coverage efficiency.

Execute Percentage of program execution

Read Percentage of memory read

Write Percentage of memory write

All Percentage of program execution, or memory read or write
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Specifying

To set a display condition for the coverage efficiency

1 Open the Coverage-Condition dialog box.
Select [Option] -> [Coverage] -> [Condition...] from the menu bar

2 Specify Survey Condition (in Survey Condition (status condition specification area)).
Select Execute if a function is specified.

3 Specify Survey Condition (in Address Range, Function (address condition specification area)).
Specify Address Range or Function (in the address condition specification area).

4  Click the <Insert> button.

To delete a display condition for the coverage efficiency

1 Opens Coverage-Efficiency View dialog box.
Select [Option] -> [Coverage] -> [Condition...] from the menu bar

2 Select the condition to be deleted from Survey List (Survey List (selected list display area)).

3 Click the <Delete> button.

Function buttons

OK Closes this dialog box.

View Displays coverage efficiency.
Opens Coverage-Efficiency View dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.

Clear Clears the contents of Survey List Survey List (selected list display area).
Delete Deletes the selected address range or function name from Survey List Survey

List (selected list display area).

Insert Registers the address range or function name specified in Address Range or
Function Address Range, Function (address condition specification area) to
Survey List Survey List (selected list display area).
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Coverage-Efficiency View dialog box

This dialog box displays the coverage efficiency of the coverage results in the range specified in the

Coverage-Condition Setting dialog box.

Caution The coverage data collected when the IE-V8B50E-MC or IE-V850E-MC-A is used is only

execution data.

Figure 7-54 Coverage-Efficiency View Dialog Box

i H Condition | Hzlp |
Survey List Fezultz (%)

Ot t2000 - Oxffelft ki 0.0
samp e, out $sub. cff_comp_char{  100.0

| ]

This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [Option] -> [Caverage] -> [Efficiency...] from the menu bar
(or press Alt+O, O, and E in that order).

¢ Click the <View> button in Coverage-Condition Setting dialog box.

Explanation of each area

The Coverage-Efficiency View dialog box consists of the following areas:

(1) Survey List (coverage range display area)
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(2) Results(%) (coverage efficiency display area)

(1) Survey List (coverage range display area)

Survey List

Oxffe000 - Oxffelff

zamp e, out$sub. ol _comp_char

| >
This area displays the coverage efficiency measurement range.

The area specified in Coverage-Condition Setting dialog box is displayed in this area.

If a function name is specified, "program name$file name#function name" is displayed.

(2) Results(%) (coverage efficiency display area)

Results ()

0.0
100.0

This area displays the coverage efficiency.

The coverage efficiency indicates how many specified statuses (execution, read, and write) are

included in the measurement range, as a percentage (refer to "Table 7-30 Status List of Coverage
Data").

Function buttons

OK Closes this dialog box.

Condition Sets the displayed contents of the coverage efficiency.
Opens Coverage-Condition Setting dialog box.

Help Opens the Help window.
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Event Manager

This window is used to display, enable or disable, and delete various event conditions.
It is also used to register the various event conditions and manage the event conditions for setting them.
Up to 256 conditions can be registered as event conditions or various event conditions. However, the

number of event conditions that can be used (enabled) at the same time is limited as follows:

Table 7-31 Maximum Number of Valid Events for Each Event Condition

Event
IE Using Eventlink | Break | Trace | Snapshot | Stub | Timer
Execution | Access
IE-703002- 14 8 3ab. 22 1b 16 12
MC
IE-703102- 14 8 3a.b. 22 10 16 3a
MC
IE-V850E-MC | 144 8 3ab. 22 1b 16 3a
or IE-V850E-
MC-A, IE-
VB850ES-G1
a. Including the Run-Break event. Since a timer event condition may use one event link condition internally, the
number of the event condition which can be used may diminish.
b. Since a section trace event condition uses one event link condition internally, the number of the event
condition which can be used may diminish.
C. The relationship between a snap shot event and a stub event is exclusive.
d. For event before execution: up to 4 events. For event after execution: up to 10 events.

The event before execution can be used only for the break event condition.

Figure 7-55 Event Manager

= Event Mana ==1g

Open I Dizable I Delate Deleta All I Infa... I Close

[TJ[Trc00002 |
o000 | ) e o1
[E][ Exo000z | [B][ time_n02 ]

This section explains the following items:

« Opening
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« Explanation of each area
« Functions often used (right-click menu)
¢ Function buttons

 To save/restore event information

To enable/disable an event

» To change the display sequence of event icons

To display details of event condition
* To delete an event

« To manage a software break event
« To create an event condition

 To create an event link condition

» To set an event condition and event link condition as various event condition

Opening

This window can be opened as follows:

¢ Click the Mgr button.

« Select [Event] -> [Event Manager] from the menu bar
(or press Alt+N, and M in that order).

In the Source window
Move the cursor to the source line in the source text display area where an event is set, or to the

disassemble line in the mixed display mode.

« Select [View] -> [Event?] from the menu bar
(or press Alt+V, and E in that order).

In the Assemble window

Move the cursor to the line in the mnemonic display/change area where an event is set.

« Select [View] -> [Event?] from the menu bar
(or press Alt+V, and E in that order).

In the Event dialog box

 Click the <Manager> button
(or press Alt+G).

In the Event dialog box

« Click the <Manager> button.
(or press Alt+M).

Explanation of each area

The Event Manager consists of the following areas:
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(1) Eventdisplay area

(2) Event details display area

(1) Eventdisplay area
[When list is displayed]

Trc00002
(B[ koot | [E][ time ol |
[E][Ewtooonz | [B][ time_o02 |

L ]

The event display area displays the icons (event icons) of the registered event, event link, break event,

trace event, snapshot event, stub event, and timer event conditions.

An event icon consists of a mark indicating the type of event, and an event name.

By selecting the right click menu -> [Detail], the details can be displayed (refer to "Event details display
area").

The meaning of each mark is as follows:

Table 7-32 Marks of Event Icon

Mark Meaning
E. Event condition
L. Event link condition
B. Break event condition
T. Trace event condition
S. Snapshot event condition
u. Stub event condition
Ti. Timer event condition

The color of the character on the mark indicates the set status of the event.

Table 7-33 Color of Character on Mark and its Meaning

Character Mark Meaning
Color
Red E. L. Indicates that the various event condition using this event condition

or event link condition is enabled.

B. T. Ti. U. S. | Indicates that this various event condition is enabled.
This various event occurs when its condition is satisfied.
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Table 7-33 Color of Character on Mark and its Meaning

Character

Color Mark Meaning

Black E. L. Indicates that this various event condition using this event condition
or event link condition is disabled.

B. T.Ti. U. S. | Indicates that this various event condition is disabled.
This various event does not occur even when its condition is
satisfied.

Yellow E. L. Indicates that the symbol specified for this event is held pending
because it cannot be recognized by the program currently loaded.

B.T. Ti. U. S. | Indicates that this various event is held pending.
The various event does not occur even when its condition is
satisfied.

This area also has the following four functions:

Jump function
If the selected icon is that of an event condition, you can jump to the Source window, Assemble
window, Memory window, or Coverage window, using an address condition as the jump pointer. You
can jump easily by using the right click menu.

The jump pointer will be as follows, depending on the set address condition.

Table 7-34 Address Condition and Jump Pointer

Setting of Address Condition Jump Pointer
Setting as a point Specified address
Setting as a range Lower address

(Point address before the mask if a mask is specified)

Setting as a bhit Address at the bit position

The jump destination window will be displayed from the jump pointer.

Open function
Opens the event setting dialog box corresponding to the selected event condition. Each setting dialog
box displays the contents of the selected event condition.

Operation

 Double-click the icon, or click the <Open> button with selecting the icon.
Enable status selection function
The event corresponding to the selected icon can be enabled or disabled.
The break, trace, snapshot, stub, and timer events (but not the event and event link conditions) can be
manipulated via their icons.
Operation

1 Click on the mark of the icon using the left mouse button.

2 Click the <Enable> or <Disable> button.
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If the event is enabled, it is disabled (black); if the event is disabled, it is enabled (red). The < Enable>
button is displayed if the icon of an event that is disabled is selected; the <Disable> button is displayed

if the icon of an event that is enabled is selected.

Deletion function
The registered event and set contents of the selected icon can be deleted.

Operation

1 Select anicon. Two or more icons can be selected by using Shift and Ctrl keys. To select all the
icons, select [View] -> [Select All] from the menu bar.

2 Click the <Delete> button or press the DEL key.

Caution  An event condition or event link condition can be deleted only when it is not being used for
another event condition. If it is being used for another event, delete the event that is using
the event condition or event link condition, and then delete the event condition or event link

condition.

(2) Event details display area

[In detailed display mode]

[S]E [&]main. cHE2[Dxdde) =
[SIEX [4]main.cH#34{0xdbe]

[GTw [E] [A]time_over|0x100410)

[BJE +t00001 =
[BJE 400002

[E][ time_o02 ] |[Btime_o1 -

This area displays the detailed information corresponding to each event icon.

This area is displayed only in the detailed display mode.

Contents are displayed by using the following key information as a separator.

Table 7-35 Separator for Displaying Event Details

Key Information Contents

Event condition

[S] Status condition
[Z] Access size condition
[A] Address condition

Symbol or expression: (actual address)
[D] Data condition

Symbol or expression: (actual address)
[E] External sense data condition
[M] Mask condition

Event link condition
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Table 7-35 Separator for Displaying Event Details

Key Information

Contents

[P1] - [P4]

Event link condition on "n"th line

[D]

Disable condition

Break condition

[B]

Break condition

Trace condition

[M] Trace mode

[D] Delay Count

[S] Trace start condition
[E] Trace end condition
[Q] Qualify trace condition

Timer condition

[S] Timer measurement start condition
[E] Timer measurement end condition
[F] Timer measurement frequency

[U] Timer measurement unit

snapshot condition

[SN] Snapshot condition
[R] Register condition
[M] Memory condition
Symbol or expression: (actual address)
[Z] Access size condition
[G] Peripheral I/O register condition

Stub condition

[SU]

Stub condition

[Al

Jump Address
Symbol or expression: (actual address)

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button. In this way, the same function can be used more easily than with the normal

procedure.

Sort By Name

Displays icons in the order of event names.

Sort By Kind

Displays icons in the order of event types.

266
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Unsort Does not sort icons (default).
Detail Displays the details.
Overview Displays a list (default).

Source Text

Displays the corresponding source text and source line, using the position of the
selected event as the jump destination address.

If no line information exists at the jump destination address, however, you cannot
jump.

Opens the Source window.

If an active Source window is open, that window is displayed in the forefront (so
that it can be manipulated).

Assemble Displays the Assemble window from the position of the selected event, which is
used as the jump destination address.
Opens the Assemble window.
If an active Assemble window is open, that window is displayed in the forefront
(so that it can be manipulated).

Memory Displays the memory contents from the position of the selected event, which is
used as the jump destination address.
Opens the Memory window.
If an active Memory window is open, that window is displayed in the forefront (so
that it can be manipulated).

Coverage Displays the coverage measurement result from the position of the selected

event, which is used as the jump destination address.

Opens the Coverage window.

If an active Coverage window is open, that window is displayed in the forefront (so
that it can be manipulated).

Function buttons

New... Opens the dialog box to create new event condition.
By clicking each button, the corresponding event setting dialog box can be
opened (with the new event name set). After the event setting dialog box has
been opened, this dialog box is closed.
Open Opens the event setting dialog box corresponding to the selected event condition.
Each setting dialog box displays the contents of the selected event condition.
This button is invalid if no event condition is selected or if two or more event
conditions are selected.
The Enter key performs the same operation.
Enable/ Enables or disables the selected various event condition (except event conditions
Disable and event link conditions).
This button is invalid if an enabled/disabled event condition is not selected.
Delete Deletes the selected event condition.
When an event condition or an event link condition is to be deleted, an error
occurs and the event condition or event link condition cannot be deleted if the
event is used as a various event condition.
This button is invalid if no event condition is selected.
Delete All Deletes all event conditions except software break conditions.
Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event names.
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Sort by Sorts events into name order.
Name
Sort by Kind Sorts events into type order.
Unsort Displays events in the order in which they have been registered without sorting
the events.
Detail Sets the detailed display mode.
Overview Sets the list display mode.
Cancel Closes this dialog box (same as ESC key).
Close Closes this window.

Related operations

To save/restore event information
Use this window as the current window, and open the View File Save dialog box by selecting [File] ->
[Save As...] from the menu bar.
To restore the set status of an event, open the View File Load dialog box by clicking the Open button.

By loading an event setting file (*.evn), the previously set event information can be restored.

To enable/disable an event
An event can be enabled or disabled by clicking the mark of the event icon to be changed. By clicking
Enable (red), the event can be disabled (black): by clicking Disable (black), the event can be enabled
(red).

This change can be also performed on the Event Manager or in each event setting dialog box.

To change the display sequence of event icons

Select the right-click menu -> [Sort B Name/Sort By Kind/Unsort] on the Event Manager.

To display details of event condition
Select the right-click menu -> [Detail] on the Event Manager.

By selecting [Overview], the list can be displayed again.
To delete an event

Select the icon of the event to be deleted, and click the <Delete> button.

Caution  An event condition or event link condition cannot be deleted if it is being used for an event.

Delete the event first, and then delete the event condition or event link condition.

To manage a software break event
Use the Software Break Manager, which is opened by selecting [Event] -> [Software Break Manager]

from the menu bar.

To create an event condition

Create an event condition in the Event dialog box, which can be opened by clicking the Evn button. In
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addition, an event condition that is created when a hardware break is set in the source can also be

used (refer to "Breakpoint setting/deletion function").

To create an event link condition
Create an event link condition in the Event Link dialog box, which can be opened by selecting [Event] -

> [Event Link] from the menu bar.

To set an event condition and event link condition as various event condition
Set an event condition or event link condition as a various event condition in the Break dialog box,
Trace dialog box, Snap Shot dialog box, Stub dialog box, or Timer dialog box, which can be opened by
clicking the corresponding button, such as <Break...> and <Trace...> in the Event dialog box or Event
Link dialog box.
By dragging and dropping the event condition to be set from the Event Manager area at the lower part
of the screen to the condition setting area on each event setting dialog box, the event condition can be
easily set.

Each event setting dialog box can also be opened by selecting from the [Event] menu.

User's Manual U16217EJ1VOUM 269



CHAPTER 7 WINDOW REFERENCE

Software Break Manager

This window is used to display, enable or disable, and delete software breaks.
Up to 100 software break events can be enabled at the same time.
Software breakpoints cannot be set in this window; they can be set in the Source window or Assemble

window.

Figure 7-56 Software Break Manager

nare Break Manager

Enable Disable || Delete | Dalete ALL|| Close |
Mame | Brk | File#iLine / Symbal+Offset | Address |
Swb 00001 e main.ci6d Ox3485
Swb00002 main.ci70 0x36BE
Swb 00005 main.cia0 Qx93

The section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This window can be opened as follows:

« Select [Event] -> [Software Break Manager] from the menu bar
(or press Alt+N, and M in that order).

Explanation of each area

The Software Break Manager consists of the following areas:
(1) Name (event name display area)
(2) Brk (break mark display area)
(3) File#Line / Symbol+Offset (breakpoint display area)
(4) Address (address display area)
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@)

Name (event name display area)

Mame

Swb0000 1
Swhb00002
Swhb00003

This area displays the names of registered events, and the check boxes that indicate whether each
event is enabled or disabled.

An event name is displayed in the form of Swb+[number] in the default condition. It can be changed
to an alphanumeric string of up to 256 characters.

To change an event name, select and click a name. Then directly edit the name. To set the editing,
press the Enter key.

When an event is enabled, the check box is checked.

Furthermore, the name jumps to the Source window by double-clicking an event name if the event
name corresponds to the source line, whereas the name jumps to the Assemble window if it does not

correspond to the source line.

Reference By clicking Name (on the label), the character strings of the displayed items can be

)

@)

compared and sorted lexicographically (in alphabetical order). Whether the character
strings are compared or sorted in ascending or descending order can be alternately

selected by clicking the mouse.

Brk (break mark display area)

Erk.

The >' mark is displayed for a software break event that is set at the current PC position (so that the

software break event that caused a break can be easily identified).

File#Line / Symbol+Offset (breakpoint display area)

File#Line & SymboHOffzat
main.cicd
main.c#70

main.c#I0

This area displays the location at which a software break event was set as follows:

If the event corresponds to the source line. Program$file name#line number

If the event dose not correspond to the source line. | Program$file name#symbol+offset

Events are evaluated based on this when a symbol is re-downloaded.
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Reference

By clicking File#Line/Symbol+Offset (on the label), the character strings of the displayed
items can be compared and sorted lexicographically (in alphabetical order). Whether the
character strings are compared or sorted in ascending or descending order can be

alternately selected by clicking the mouse.

(4) Address (address display area)

Address

PRt
D:3BE
D35

This area displays the address at which a software break event is set.

Reference

By clicking Address (on the label), the numeric values of the displayed items can be
compared and sorted. Whether the values are compared or sorted in ascending or

descending order can be alternately selected by clicking the mouse.

Function buttons

Enable Enables the selected event.

Disable Disables the selected event.

Delete Deletes the selected event.

Delete ALL Deletes all the set software break events.
Close Closes this window.
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Event dialog box

Registers and displays event conditions.

An event condition registered in this dialog box will be automatically registered to the Event Manager.

As an event condition, one event can be set for two or more event conditions (break, trace, snapshot,
stub, timer, and event link).

Up to 256 event conditions can be registered. However, the number of event conditions that can be
simultaneously used is limited (refer to "Table 7-31 Maximum Number of Valid Events for Each Event

Condition").

Caution Event conditions used for break, snapshot, and stub cannot be used for trace and timer,
including those that are used via event link. Similarly, the event conditions used for trace and
timer cannot be used for break, snapshot, and stub, including those that are used via event
link.

An event condition for which an address range is specified internally uses two event
conditions. Therefore, the number of event conditions that can be used decreases by the

number of event conditions for which an address range is specified.

Figure 7-57  Event Dialog Box

Ewvert m |
0] 4 I Mews I Sat | Clear | Cancel | Help
Event Mame: I LI Ewent Link..

Event Status: I'l.l'l.l'rite LI Break....

Access Size: I'I.I'I.I'Drd LI Trace..

Addrass: Irnain.c#time_nver Snap Shot..
- | Stub.

Data: I hla=k: I Timer...
Ext Probe: I hask: I

Manager

Shrink, <4<

il

Event Manager:

[E.][Ext00001 | [E ][ Evtononz | [T.][ Tre0001 | [E][ time_o01 | Qpan
[B][ Erkoooo1 | [E][ Brknoonz | [T.][ Treoo00z | [B])[ time_o02 | [——

_}I Infa...

il

This section explains the following items:

« Opening
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« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

In normal mode
If the Event dialog box is opened as follows, an event condition can be registered without its purpose

being specified.

* Click the Evn button.

« Select [Event] -> [Event...] from the menu bar
(or press Alt+N, and E in that order).

In select mode
If the <OK> button is pressed when the Event dialog box has been opened as follows, an event
condition can be registered in the setting dialog box from which this dialog box was opened.
« In each event setting dialog box
Click the <Add Event> button.
(or press Alt and E in that order).

In the select mode, the setting dialog box from which the Event dialog box was opened is displayed
on the title bar.

Explanation of each area

The Event dialog box consists of the following areas:
(1) Event Name (event name setting area)
(2) Event Status (status selection area)
(3) Access Size (access size selection area)
(4) Address (address setting area)
(5) Data, Mask (data setting area)
(6) ExtProbe, Mask (external sense data setting area)

(7) Event Manager (event manager area)

(1) Event Name (event name setting area)

Ewvent Mame: | LI

This area is used to set a event name.

Directly input an alphanumeric string of up to eight characters as a name.
To display the contents of an already created event condition, select from the drop-down list.
In the select mode, the selected event condition can be set in the event condition setting area of the

setting dialog box that called the Event dialog box.
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The mark on the left of this area indicates the utilization status of events (refer to "Table 7-33 Color of
Character on Mark and its Meaning"). The gray E. mark indicates that the event condition is being

edited and has not been registered yet.

Event Status (status selection area)

Ewvent Status: I".'"."rite LI

This area is used to select a status condition.

By specifying a status condition, the type of the execution event and an access event is determined (if
an execution event is specified, nothing can be input to the Access Size, Address Mask, and Data
areas).

The status conditions that can be specified are listed below. A status condition can also be specified in
abbreviated form.

Uppercase and lowercase characters are not distinguished in the input status condition.

Table 7-36 List of Status Conditions

<Execution event>

Status Abbreviation Meaning
Execution EX Program execution
Before Execution EX-B Program execution (break before execution) &
With IE-V850E-MC or IE-V850E-MC-A

a. Multiple events can be set for Before Execution, however, up to 2 events can be enabled. It can be used only

for break event conditions. An address range cannot be specified to it.

<Access event>

Status Abbreviation Meaning

R/W RwW Data read/write

Read R Data read

Write w Data write

Access AC All access statuses

R/W(Data not Equal) RWND Data read/write
(An event occurs only if a data condition is not
satisfied.)
* Displayed only when V850E is selected

Read(Data not Equal) RND Data read
(An event occurs only if a data condition is not
satisfied.)

* Displayed only when V850E is selected

Write(Data not Equal) WND Data write

(An event occurs only if a data condition is not
satisfied.)

* Displayed only when V850E is selected
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Acocess Sige:

(3) Access Size (access size selection area)

I".'"."u:-rd

-]

This area is used to set and select an access size condition.

By specifying an access size condition, the access width of a data condition to be detected by an

access event is determined.

The access size conditions that can be specified are listed below. An access size condition can also

be specified in abbreviated form. Uppercase and lowercase characters are not distinguished in the

input access size condition.

Table 7-37 List of Access Size Conditions (Event)

Size Abbreviation Meaning

Byte B Detects data condition with 8-bit width (only during 8-bit access).

Half Word HW Detects data condition with 16-bit width (only during 16-bit
access).

Word W Detects data condition with 32-bit width (only during 32-bit
access).

No Condition NC Does not detect access size (nothing can be input to the Data
area).

Bit 1 Detects data condition with 1-bit width (only during 8-bit access).

In this case, a data condition is detected with 1-bit width.
Because of the operation of the emulator, access to a bit is not
directly detected; the debugger detects a dummy bit access by
internally setting address conditions and data conditions as
follows:

Input example:
Address: fe20
Data: 1

Setting to emulator)
Address: fe20

Data: 00000010B
Mask: 11111101B

If another bit of the same address is accessed or if all the 8 bits
of the same address are accessed, therefore, an event is
detected in accordance with the specified status if the address
and bit match the specified value of [address.bit].

When data is written to a bit, all the 8 bits are read/written. If read or read/write is specified as the

status, an event occurs if a read operation is performed at this time if the value of the specified

[Address.bit] matches.

If no access size is specified, judgment is automatically made from the address condition and data

condition, and the following is set:

« Bit if the address condition is set in bit units

« Byte if the address condition is set in 8-bit units

« Half Word if the address condition is set in 16-bit units
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» Word if the address condition is set in 32-bit units

* No Condition if no data condition is specified

(4) Address (address setting area)

Address: I maincitime_over

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.
Settable range

0 =< data value =< OxFFFFFFFF

Address

Set an address condition (lower address - higher address).

The following can be set:

Set Point Set a value to only the lower address, or set the same value to the lower
address and the higher address.

Set Range Set a value to the lower address and the higher address.

To change the event condition used, a range must be specified after
changing the event condition if a range is specified before the change.
Similarly, if a range is not specified before the change, a range cannot be
specified for an address condition.

Set Bit Set a value to only the lower address, or set the same value to the lower
address and the higher address. Specify a value in the form of
address.bit.

The value of bit, which indicates the bit position, must be 0 =<bit =<7.

(5) Data, Mask (data setting area)

Data: I hlask: |

Data, which sets an data value, and Mask, which sets the mask value of an data value, are set as data

conditions.
The default radix for inputting a numeric value is hexadecimal.
Both the data and mask may be omitted.

The settable range differs as follows depending on the access size condition specified in the Access

Size area.
Table 7-38 Settable Range of Data Condition
Access Size Settable range
Byte 0 =< data value =< OxFF
0 =< mask value =< OxFF
Half Word 0 =< data value =< OxFFFF
0 =< mask value =< OXFFFF
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Table 7-38 Settable Range of Data Condition

Access Size Settable range

Word 0 =< data value =< OXFFFFFFFF
0 =< mask value =< OXFFFFFFFF

Bit Data value =0 or 1
Mask value = Cannot be specified.

Data

Set a data value. Specify a value within the settable range.

A symbol or expression can be also specified by a symbol or expression (refer to "Table 7-15
Specifying Symbols").

Mask

Set a mask value for the data value.

When a mask is set, the data value for the bit whose mask value is 1 may be 0 or 1.

The data value for a bit whose mask value is 1 may be 0 or 1.

Example 1:
Data 0x4000
Mask OxFF

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.

Example 2:
Data 0x4000
Mask 0x101

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.

(6) Ext Probe, Mask (external sense data setting area)

Ext Probe: I hlask: |

This area is used to set an external sense data condition.

External sense data is the input pin level of the external sense clip attached to the emulation probe
connected to the in-circuit emulator (refer to "Table 7-23 Correspondence Between External Sense
Data and External Sense Clip").

External sense data conditions include Ex Probe, which sets an external sense data value, and Mask,
which sets the mask value of an external sense data value.

The default radix for inputting a numeric value is hexadecimal. Both data and mask may be omitted.

Table 7-39 Settable Range of External Sense Data Condition

Settable Range Condition

0 <= Address value <= 0xFF None
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Table 7-39 Settable Range of External Sense Data Condition

Settable Range

Condition

0 <= Mask Value <= 0xFF

None

Exp Probe

Specify an external sense data value.

Set the high input pin level of the external sense clip to 1, and the low input level to O.

Caution  Only when the IE-703102-MC, IE-V850E-MC or |IE-V850E-MC-A is connected to the 1D850,

eight external sense clips are used; otherwise four external sense clips are used.

external sense clips are used, the higher 4 bits are always fixed to 0.

Mask

Set a mask value for the external sense data.

The data value for the bit whose mask value is 1 may be 0 or 1.

If four

Example 1:
Ext Probe 0x8
Mask Ox7

With this setting, the condition is satisfied if the data is 0x8 to OxF.

Example 2:
Ext Probe 0x8
Mask 0x5

With this setting, the condition is satisfied if the data is 0x8, 0x9, OxC, or 0xD.

(7) Event Manager (event manager area)

Event Manager:

[E.][Evt00001 ] [E ][ Evtooonz | [T.][ Tre00001 | [E.][ time_oD1 ]

[B][ Erkoooot | [E][ Brkooonz | [T.)[ Tredonoz | [B][ time_o2 ]

0

This area displays a list of break, trace and other registered events.

In this area, the following operations can be performed.

Displaying set contents

Select an event and click the <Open> button or double-click the event. The setting dialog box

corresponding to the selected event will be opened and the set contents of the event will be displayed.

Delete

A selected event can be deleted by selecting the icon of the event and clicking the <Delete> button or

pressing the DEL key while focussing on the event manager area.
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Changing display mode and sorting

The display mode of and sorting in the event manager area can be selected by clicking the <Info...>

button.

Function buttons

Setting-related buttons

OK

Automatically registers the event condition being edited, if any, and closes this
dialog box.

In the select mode

An event condition is selected and the setting dialog box (indicated on the title
bar) that called the Event dialog box is displayed again. If the calling dialog box
has already been closed, the select mode is returned to the normal mode, and
the Event dialog box is not closed. Otherwise, this dialog box will be closed.

New

Newly creates an event condition in this dialog box.
An event name is automatically created and a new event condition is prepared.

Set

(when a new
event is created
or an event is

Registers each event condition. Because the dialog box is not closed even
after an event has been registered, new event conditions can be registered.
In the select mode

An event condition is selected. If there is an event being edited, it is

changed) automatically registered and selected.

Clear Clears the contents of the event condition.

(when an eventis | This button is displayed when an event condition has not been edited.
not edited) This button and the <Restore> button are alternately displayed.
Restore Restores the contents of an edited event condition.

(when an event is
edited)

If an event condition not registered is displayed, all the fields other than the
event name field are blank or the default values are set.
This button and the <Clear> button are alternately displayed.

Cancel Closes this dialog box.

Close Even if an event condition is being edited, it is not registered and the dialog box
is closed.
<Cancel> is displayed if a condition is not created, changed, or deleted;
<Close> is displayed if it is.

Help Opens the Help window.

Buttons for opening each event setting dialog box

Event Link... Opens the Event Link dialog box.
Break... Opens the Break dialog box.
Trace... Opens the Trace dialog box.
Snap Shot... Opens the Snap Shot dialog box.
Stub... Opens the Stub dialog box.
Timer... Opens the Timer dialog box.
Manager Opens the Event Manager.

Buttons in event manager area
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Shrink <<< Turns off display of the event manager area.

(When area is At this time, the size of the dialog box is reduced.

displayed)

Expand >>> Displays the event manager area.

(When areais not | At this time, the size of the dialog box is expanded.

displayed)

Open Opens the event setting dialog box corresponding to the selected event

(When only one
event is selected)

condition. Each setting dialog box displays the contents of the selected event
condition.
The Enter key performs the same operation.

Remove Deletes the selected event condition.

(When event is When an event condition or an event link condition is to be deleted, an error

selected) occurs and the event condition or event link condition cannot be deleted if the
event is used as an event condition.

Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event
names.

Sort by Name Sorts events into type order.

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting
the events.

Detail Sets the detailed display mode.

Overview Sets the list display mode.,

Cancel Closes this dialog box (same as ESC key).
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Event Link dialog box

This dialog box is used to register and display event link conditions.

A event link condition registered in this dialog box will be automatically registered to the Event Manager.

An event link condition is an event condition that is generated only if the user program is executed in the
sequence specified by a set event condition.

Up to four sequences can be specified.

executed, however, the event conditions that have so far been satisfied are initialized, and the event

If a disable condition is detected while the program is being

conditions are detected again starting from the first event condition.

condition are detected at the same time, the disable condition takes precedence.

An event link condition can be used for multiple various event conditions. The following various event

conditions can use event link conditions:

If a link condition and a disable

Table 7-40 Various Event Conditions for Which Event Link Condition Can Be Use

Using |E Break Trace Snapshot Stub Timer
9 condition condition condition condition condition

IE-703002-MC OK & OK P NG NG OK
IE-703102-MC OK & OK P NG NG OK
IE-V850E-MC or IE- OK & OK b NG NG OK
V850E-MC-A, IE-

V850ES-G1
a. An event link condition which is used for a break event condition cannot be used for a trace or timer event

condition. Alternately,

b. It cannot be used for a qualify condition or section trace condition.

Up to 256 event link conditions can be registered. However, the number of event link conditions that can

be simultaneously used (valid) is limited (refer to "Table 7-31 Maximum Number of Valid Events for Each

Event Condition").
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Figure 7-58 Event Link Dialog Box
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This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

In normal mode
If the Event Link dialog box is opened as follows, an event link condition can be registered without its
purpose being specified.

« Select [Event] -> [Event Link...] from the menu bar
(or press Alt+N, and L in that order).

In select mode
If the <OK> button is pressed when the Event Link dialog box has been opened as follows, an event
link condition can be registered in the setting dialog box from which this dialog box was opened.
« In each various event setting dialog box
Click the <Add Link...> button.
(or press Alt+L, and L in that order).

In the select mode, the setting dialog box from which the Event Link dialog box was opened is
displayed on the title bar.
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Explanation of each area

The Event Link dialog box consists of the following areas:
(1) Link Name (event link name setting area)
(2) Phasel, Phase2, Phase3, Phase4 (link condition setting area)
(3) Disable (disable condition setting area)
(4) Pass Count (pass count setting area)

(5) Event Manager (event manager area)

(1) Link Name (event link name setting area)

Lirk. Mame: [L]{Lrkooons |

This area is used to set a event link name.

Directly input an alphanumeric string of up to eight characters as a name.

To display the contents of an already created event link condition, select from the drop-down list.

In the select mode, the selected event condition can be set in the event kink condition setting area of
the setting dialog box that called the Event Link dialog box.

The mark on the left of this area indicates the utilization status of event link condition (refer to "Table 7-
33 Color of Character on Mark and its Meaning"). The mark "L" in gray indicates that an event link

condition is being edited and has not been registered yet.

(2) Phasel, Phase2, Phase3, Phase4 (link condition setting area)

Phase 1: l;:;. Phase 2 |:> Phase 3: l::) Phase 4:

w0001 ] e evomnos ] [ wooort ] e ez ] )

= = = =
This area is used to specify the sequence in which event conditions and events are detected.
Set Phase 1 -> Phase 2 -> Phase 3 -> Phase 4, in that order. Phase 4 does not have to be set.
in this case, an event occurs when the event condition set for the last phase has been detected. An
event condition can be set for only Phase 1 or the same event condition can be set for two or more
Phases.
The number of event conditions that can be set for each Phase in this area is up to 10. However, the
total number of event conditions settable in this area, including those set in the Disable area, is 22 (14

execution events* and eight access events).

Note If the IE-V850E-MC or |IE-V850E-MC-A is used, the 14 execution events* include 10 events

before execution (can be used only for break) and after execution.
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Setting event condition in each area

@)

(4)

(©)

Select an event condition in the Event Manager area, and click the <Add> button or drag and drop an
event condition. An event link condition can also be set by dragging and dropping not only in this
dialog box, but also in the Event Manager area of each various event setting dialog box or the Event
Manager.

In addition, the Event dialog box can be opened in "select mode" by clicking the <Add Event...> button,
and the event condition to be set can be selected.

In the event condition setting area in this dialog box, an event condition can be alternately copied or

moved by dragging and dropping.

« If an event condition is dropped only by the mouse, it is moved.
« If an event condition is dropped with the Shift key held down, it is moved.

« If an event condition is dropped with the Ctrl key held down, it is copied.

Disable (disable condition setting area)

Disable: ;I

=
This area is used to set an event condition that invalidates the event conditions that have so far been

satisfied (refer to "Setting event condition in each area").

The number of event conditions that can be set in this area is up to 10.

Pass Count (pass count setting area)

Pass Count:
This area is used to set a pass count condition (settable range: 1 to 32767).
A pass count condition specifies how many times an event condition must be satisfied during user
program execution before a given condition is satisfied.
If the pass count is set to 1, the condition is satisfied as soon as the event condition is satisfied.

If no pass count is specified, 1 is assumed.

Event Manager (event manager area)

Event Manager:

This area displays a list of break, trace and other registered various event conditions.
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For details, refer to "Event Manager (event manager area)".

Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this
dialog box.
In the select mode
An event condition is selected and the setting dialog box (indicated on the title
bar) that called the Event Link dialog box is displayed again. If the calling
dialog box has already been closed, the select mode is returned to the normal
mode, and the Event dialog box is not closed. Otherwise, this dialog box will be
closed.

New Newly creates an event link condition in this dialog box.
An event link condition name is automatically created and a new event link
condition is prepared.

Set Registers the various event condition. Because the dialog box is not closed

(when a new even after an event has been registered, new event link conditions can be

event link is registered.

created or an In the select mode

event link is An event condition is selected. If there is an event being edited, it is

changed) automatically registered and selected.

Clear Clears the contents of the event link condition.

(when an eventis | This button is displayed when an event link condition has not been edited.

not edited) This button and the <Restore> button are alternately displayed.

Restore Restores the contents of an edited event link condition.

(when an event is
edited)

If an event link condition not registered is displayed, all the fields other than the
event name field are blank or the default values are set.
This button and the <Clear> button are alternately displayed.

Cancel Closes this dialog box.

Close Even if an event link condition is being edited, it is not registered and the dialog
box is closed.
<Cancel> is displayed if a condition is not created, changed, or deleted;
<Close> is displayed if it is.

Help Opens the Help window.

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an
event condition to be set. The event condition will be added to the area
selected when the < Add Event...> button is pressed.

Other... Opens the dialog box for selecting the event type.

By pressing each of the above buttons, each event setting dialog box can be
opened in the new creation status.

Buttons in event manager area

Shrink <<<
(When area is
displayed)

Turns off display of the event manager area.
At this time, the size of the dialog box is reduced.
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Expand >>> Displays the event manager area.

(When area is not | At this time, the size of the dialog box is expanded.

displayed)

Open Opens the event setting dialog box corresponding to the selected event

(When only one
event is selected)

condition. Each setting dialog box displays the contents of the selected event
condition.
The Enter key performs the same operation.

Remove Deletes the selected event condition.

(When event is When an event condition or an event link condition is to be deleted, an error

selected) occurs and the event condition or event link condition cannot be deleted if the
event is used as a various event condition.

Add Sets additionally the event condition or event link condition selected in the
event manager area to setting area with a focus. The area to be set additionally
is the area which was selected when this button was selected.

Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event
names.

Sort by Name Sorts events into type order.

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting
the events.

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Break dialog box

This dialog box is used to register, set, and display break event conditions.

A break event condition registered in this dialog box will be automatically registered to the Event
Manager.

A break event condition automatically becomes valid when it has been registered.

Up to 256 break event conditions can be registered. However, the number of break event conditions that
can be simultaneously used is limited (refer to "Table 7-31 Maximum Number of Valid Events for Each
Event Condition"). If the maximum number of break event conditions that can be used at the same time is
exceeded or if the number of event conditions or event link conditions used exceeds the maximum limit,
therefore, register a break event condition in the disabled state.

If [Run] -> [Ignore Break Point] is selected from the menu bar, a break event condition does not operate

even if it is valid.

Figure 7-59 Break Dialog Box

ok [ mMew | Disable Clear || Cancel || Hel |
Bresk Mame: v| | Add Event.
Break Event: Add Lirk..
Remaove

ﬂ _>| Shrirk, << |

Event Manager:

[E ][ Ew0n0o1 | [E ][ Evtooonz | [T.][ Treoooat J|[E][ time_odt | £dd |
[BJ[ Erkoooot | [B.][ Bkoo00z | [T.][ Tre00002 | [E][ time_o02 | Info. |

4] ] Other. |

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons
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Opening

This dialog box can be opened as follows:

¢ Click the Brk button.

« Select [Event] -> [Break...] from the menu bar

(or press Alt+N, and B in that order).

Explanation of each area

The Break dialog box consists of the following areas:

1)

)

(1) Break Name (break event name setting area)
(2) Break Event (break condition setting area)

(3) Event Manager (event manager area)

Break Name (break event name setting area)

Break Mame: Im ;I

This area is used to set a break event name.

Directly input an alphanumeric string of up to eight characters as a name.

To display the contents of an already created event condition, select from the drop-down list.

The mark on the left of this area indicates the utilization status of events (refer to "Table 7-33 Color of
Character on Mark and its Meaning"). The gray mark indicates that an event condition is being edited
and has not been registered yet.

By clicking the left mark, an event condition can be validated or invalidated.

Break Event (break condition setting area)

Break Ewent:

This area is used to set an event condition for break.
The number of event conditions that can be set in this area, combining execution events and access

events, is as follows:

Table 7-41 Number of Events Settable in Break Condition Setting Area

IE Using Total (execution/access)
IE-703002-MC 22(14/8)
IE-703102-MC 22(14/8)
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Table 7-41 Number of Events Settable in Break Condition Setting Area

IE Using Total (execution/access)

IE-V850E-MC or IE-V850E-MC- | 22(142/g)
A, IE-V850ES-G1

a. Event before execution:4, Event after execution:10

The number of event link conditions explained in Maximum Number of Valid Events for Each Event
Condition can be used as long as the number of event conditions does not exceed the maximum

number of event conditions simultaneously usable.

Setting event condition and event link condition in each area
Select an event condition or event link condition in the Event Manager area, and click the <Add>
button or drag and drop an event condition or event link condition. An event condition or event link
condition can also be set by dragging and dropping not only in this dialog box, but also in the Event
Manager area of each event setting dialog box and from the Event Manager.
In addition, Event dialog box or Event Link dialog box can be opened in "select mode" by clicking the
<Add Event...> or <Add Link...> button, and the event condition or event link condition to be set can be
selected.
In the event condition setting area in this dialog box, an event condition can be alternately copied or

moved by dragging and dropping.

« If an event condition is dropped only by the mouse, it is moved.
« If an event condition is dropped with the Shift key held down, it is moved.

« If an event condition is dropped with the Ctrl key held down, it is copied.

(3) Event Manager (event manager area)
This area displays a list of break, trace and other registered events.

For details, refer to "Event Manager (event manager area)".

Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this
dialog box. The event condition becomes valid as soon as it has been
registered.

New Newly creates an event condition in this dialog box.

An event name is automatically created and a new event condition is prepared.

Set Registers each event condition. Because the dialog box is not closed even after
(when a new an event has been registered, new event conditions can be registered. Each
event is created event condition becomes valid as soon as it has been registered.

or an event is If an already registered event condition is displayed, the <Enable> or <Disable>
changed) button is alternately displayed.
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Enable/Disable Validates (enables) or invalidates (disables) the selected event condition.
(when a However, event conditions and event link conditions cannot be enabled or
registered eventis | disabled.

displayed) This button and the <Set> button are alternately displayed.

Clear Clears the contents of the event condition.

(when an eventis | This button is displayed when an event condition has not been edited.

not edited) This button and the <Restore> button are alternately displayed.

Restore Restores the contents of an edited event condition.

(when an event is
edited)

If an event condition not registered is displayed, all the fields other than the
event name field are blank or the default values are set.
This button and the <Clear> button are alternately displayed.

Cancel Closes this dialog box.

Close Even if an event condition is being edited, it is not registered and the dialog box
is closed.
<Cancel> is displayed if a condition is not created, changed, or deleted;
<Close> is displayed if it is.

Help Opens the Help window.

Buttons for opening each event setting dialog box

Add Event...

Opens the Event dialog box in the select mode, and selects or newly creates an
event condition to be set. The event condition will be added to the area
selected when the < Add Event...> button is pressed.

Add Link...

Opens the Event Link dialog box in the select mode, and selects or newly
creates an event link condition. The event link condition will be added to the
area selected when the <Add Link...> button is pressed.

Other...

Opens the Select Event Type dialog box.
By pressing each of the above buttons, each event setting dialog box can be
opened in the new creation status.

Buttons in event manager area

Shrink <<< Turns off display of the event manager area.

(When area is At this time, the size of the dialog box is reduced.

displayed)

Expand >>> Displays the event manager area.

(When areais not | At this time, the size of the dialog box is expanded.

displayed)

Open Opens the event setting dialog box corresponding to the selected event

(When only one
event is selected)

condition. Each setting dialog box displays the contents of the selected event
condition.
The Enter key performs the same operation.

Remove Deletes the selected event condition.

(When event is When an event condition or an event link condition is to be deleted, an error

selected) occurs and the event condition or event link condition cannot be deleted if the
event is used as an event condition.

Add Sets additionally the event condition or event link condition selected in the
event manager area to setting area with a focus. The area to be set additionally
is the area which was selected when this button was selected.

Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event
names.
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Sort by Name

Sorts events into name order.

Sort by Name

Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting
the events.

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Trace dialog box

This dialog box is used to register, set, and display trace event conditions.

In this dialog box, the following types of trace event conditions can be set:

< Event condition for delay trigger
« Event condition for starting section trace
< Event condition for ending section trace

« Event condition for qualify trace

To use the above trace event conditions, select [Run] -> [Cond. Trace ON] from the menu bar.

A trace event condition registered in this dialog box will be automatically registered to the Event Manager.

A trace event condition automatically becomes valid when it has been registered.

Up to 256 trace event conditions can be registered. However, the number of trace event conditions that
can be simultaneously used is only 1 (refer to "Table 7-31 Maximum Number of Valid Events for Each Event
Condition").

If the maximum number of trace event conditions that can be used at the same time is exceeded or if the
number of event conditions or event link conditions used exceeds the maximum limit, therefore, register a

trace event condition in the disabled state.

Figure 7-60 Trace Dialog Box
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This section explains the following items:

Opening

Explanation of each area
Function buttons
Related operations

» To set delay count

Opening

This dialog box can be opened as follows:

Click the Trc button.

Select [Event] -> [Trace...] from the menu bar
(or press Alt+N, and T in that order).

Click the <Trace> button in the Event dialog box
(or press Alt+T in that order).

Explanation of each area

The Trace dialog box consists of the following areas:

@)

294

(1) Trace Name (trace event name setting area)

(2) Delay Trigger (delay trigger condition setting area)

(3) Section Start, Section End (section trace range condition setting area)
(4) Qualify (qualify trace condition setting area)

(5) Event Manager (event manager area)

Trace Name (trace event name setting area)

Trace Mame: Im LI

This area is used to set a trace event name.

Directly input an alphanumeric string of up to eight characters as a name.

To display the contents of an already created event condition, select from the drop-down list.

The mark on the left of this area indicates the utilization status of events (refer to "Table 7-33 Color of
Character on Mark and its Meaning"). The gray mark indicates that an event condition is being edited
and has not been registered yet.

By clicking the left mark, an event condition can be validated or invalidated.
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(2) Delay Trigger (delay trigger condition setting area)

@)

a.

Delay Trigger:

]

This area is used to set an event condition for a delay trigger.

To set a delay count, use Delay Count dialog box that can be opened by selecting [Event] -> [Delay
Count...] from the menu bar.

The number of event conditions that can be set in this area, combining execution events and access

events, is as follows:

IE Using Total (execution/access)
IE-703002-MC 22(14/8)
IE-703102-MC 22(14/8)

IE-V850E-MC or IE-V850E-MC- | 18(10/8)
A, IE-V850ES-G1

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop

it in this area. For details, refer to "Setting event condition and event link condition in each area".
Section Start, Section End (section trace range condition setting area)

Section Start Section End:

This area is used to set event conditions for starting and stopping a section trace.

By setting a trace start event condition as Section Start and a trace end event condition as Section
End, a section trace (zone trace) can be performed.

The number of event conditions that can be set in this area, combining execution events and access

events, is as follows:

IE Using Total (execution/access)
IE-703002-MC 22(14/8) &

IE-V850E-MC or IE-V850E-MC- | 1g(10/g) &
A, IE-V850ES-G1

Only event after executions can be used as execution events.

The number of event link conditions explained in Maximum Number of Valid Events for Each Event
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Condition can be used as long as the number of event conditions does not exceed the maximum
number of event conditions simultaneously usable.
To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop

it in this area. For details, refer to "Setting event condition and event link condition in each area".

(4) Qualify (qualify trace condition setting area)

Caalify:

This area is used to set an event condition for a qualify trace.

In a qualify trace, a trace is performed only when a trace condition is satisfied.

If two or more events are set, trace is performed when each event occurs.

The number of event conditions that can be set in this area, combining execution events and access

events, is as follows:

IE Using Total (execution/access)
IE-703002-MC 22(14/8) &
IE-703102-MC 22(14/8) &

IE-V850E-MC or IE-V850E-MC- | 1g(10/g)
A, IE-V850ES-G1

a. An event link condition cannot be used.

The number of event link conditions explained in Maximum Number of Valid Events for Each Event
Condition can be used as long as the number of event conditions does not exceed the maximum
number of event conditions simultaneously usable.

Note that an event link condition cannot be set.

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop

it in this area. For details, refer to "Setting event condition and event link condition in each area".

(5) Event Manager (event manager area)

Event Manager:

[E.][Evt00001 ] [E ][ Evtooonz | [T.][ Tre00001 | [E.][ time_aD1 ]
[B][ Erkoooot | [E][ Brkooonz | [T.)[ Treoonoz | (B[ time_oi2 ]

ol

This area displays a list of break, trace and other registered various event conditions.

For details, refer to "Event Manager (event manager area)".
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Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this
dialog box. The event condition becomes valid as soon as it has been
registered.

New Newly creates an event condition in this dialog box.

An event condition name is automatically created and a new event condition is
prepared.

Set Registers the various event condition. Because the dialog box is not closed

(when a new even after an event has been registered, new event conditions can be

event link is registered. Each event condition becomes valid as soon as it has been

created or an registered.

event link is If an already registered event condition is displayed, the <Enable> or <Disable>

changed) button is alternately displayed.

Enable/Disable Validates (enables) or invalidates (disables) the selected event condition.

(when a However, event conditions and event link conditions cannot be enabled or

registered eventis | disabled.

displayed) This button and the <Set> button are alternately displayed.

Clear Clears the contents of the event condition.

(when an eventis | This button is displayed when an event condition has not been edited.

not edited) This button and the <Restore> button are alternately displayed.

Restore Restores the contents of an edited event condition.

(when an event is
edited)

If an event condition not registered is displayed, all the fields other than the
event name field are blank or the default values are set.
This button and the <Clear> button are alternately displayed.

Cancel Closes this dialog box.

Close Even if an event condition is being edited, it is not registered and the dialog box
is closed.
<Cancel> is displayed if a condition is not created, changed, or deleted;
<Close> is displayed if it is.

Help Opens the Help window.

Buttons for opening each event setting dialog box

Add Event...

Opens the Event dialog box in the select mode, and selects or newly creates an
event condition to be set. The event condition will be added to the area
selected when the < Add Event...> button is pressed.

Add Link...

Opens the Event Link dialog box in the select mode, and selects or newly
creates an event link condition. The event link condition will be added to the
area selected when the <Add Link...> button is pressed.

Other...

Opens the dialog box for selecting the event type.
By pressing each of the buttons, each various event setting dialog box can be
opened in the new creation status.

Buttons in event manager area

Shrink <<< Turns off display of the event manager area.
(When area is At this time, the size of the dialog box is reduced.
displayed)

Expand >>> Displays the event manager area.

(When areais not | At this time, the size of the dialog box is expanded.
displayed)
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Open Opens the various event setting dialog box corresponding to the selected event
(When only one condition. Each setting dialog box displays the contents of the selected event
event is selected) condition.

The Enter key performs the same operation.

Remove Deletes the selected event condition.
(When event is When an event condition or an event link condition is to be deleted, an error
selected) occurs and the event condition or event link condition cannot be deleted if the

event is used as a various event condition.

Add Sets additionally the event condition or event link condition selected in the
event manager area to setting area with a focus. The area to be set additionally
is the area which was selected when this button was selected.

Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event
names.

Sort by Name Sorts events into type order.

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting
the events.

Detail Sets the detailed display mode.

Overview Sets the list display mode.,

Cancel Closes this dialog box (same as ESC key).

Related operations

To set delay count
To set a delay count, use Delay Count dialog box, which can be opened by selecting [Event] -> [Delay
Count...] from the menu bar.

The set delay count is valid for trace event conditions for which a delay trigger event is set.
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Snap Shot dialog box

This dialog box is used to register, set, and display snapshot event conditions.

A snapshot event condition registered in this dialog box will be automatically registered to the Event

Manager.

A snhapshot event condition automatically becomes valid when it has been registered.

Up to 256 snapshot event conditions can be registered.

However, the number of snapshot event

conditions that can be simultaneously used is one including the stub event condition (refer to "Table 7-31

Maximum Number of Valid Events for Each Event Condition").

If the maximum number of break event conditions that can be used at the same time is exceeded or if the

number of event conditions or event link conditions used exceeds the maximum limit, therefore, register a

break event condition in the disabled state.

Caution The ID850 uses hardware breaks to control the operation of the snapshot from the host

computer. Therefore, the timing at which the snapshot event occurs differs depending on the

setting of the break mode ("break before execution" and "break after execution" :

"Extended Option dialog box").

disrupted depends on the load of Windows on the host computer.

Figure 7-61 Snap Shot Dialog Box (with Register Selected)
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This section explains the following items:
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« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [Event] -> [Snap Shot...] from the menu bar

(or press Alt+N, and S in that order).

« Click the <Snap Shot...> button in the Event dialog box.

(or press Alt and S in that order).

Explanation of each area

The Snap Shot dialog box consists of the following areas:

@)

)

(1) Snap Name (snapshot event name setting area)
(2) Snap Event (snapshot condition setting area)
(3) Select (snap data selection area)

(4) Snap data setting area

(5) Snap Entry (snap data display area)

(6) Event Manager (event manager area)

Snap Name (snapshot event name setting area)

Snap Mame:

This area is used to set a snapshot event name.

Directly input an alphanumeric string of up to eight characters as a name.

To display the contents of an already created event condition, select from the drop-down list.

The mark on the left of this area indicates the utilization status of events (refer to "Table 7-33 Color of
Character on Mark and its Meaning"). The gray mark indicates that an event condition is being edited
and has not been registered yet.

By clicking the left mark, an event condition can be validated or invalidated.

Snap Event (snapshot condition setting area)

Snap Event:

[E) ot ]

This area is used to set an event condition for the snapshot.

In the snapshot condition setting area, only one event condition and one event link condition can be

set.
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@)

(4)

To set an event condition or event link condition, drag the icon of the event to be set from the Event
Manager area, and drop it in this area. For details, refer to "Setting event condition and event link

condition in each area".

Select (snap data selection area)

Select

{% Register
10 Reg
0 Memary

This area is used to select type of data subject to snapshot.
By selecting a data type, the item to be displayed in the snap data setting area on the right of this area

changes in accordance with the selected area.

Item in Right Area (Snap Data Setting Area)

Data Type Contents
Register A register can be registered. | Register Name
1/0 Reg A peripheral 1/O register can | 1/0 Reg Name

be registered.

Memory Memory can be registered. Memory Address , Memory Display

Snap data setting area

This area is used to register, change, or delete snap data.

The snap data registered, changed, or deleted in this area is reflected in the Snap Entry area.

If snap data is selected in the Snap Entry area, the contents of the selected snap data are displayed in
this area.

As snap data, up to 16 registers, peripheral I/O registers, and memory addresses each can be
registered; therefore, a total of 48 registers, peripheral 1/0O registers, and memory addresses can be
registered.

This area displays different items, as follows, depending on the item selected in the Select field.

When Register is selected

Register Mame: IRS(SF‘J *I Raztore |

Changs | Dalate |

Register Name (register name setting area)

This area is used to specify a register name.

To specify a register name, select a register name from the drop-down list.

Program registers and system registers can be specified. Uppercase and lowercase characters are
not distinguished.

A register name can be specified as both a function name and an absolute name.
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Note that all register names are displayed in uppercase characters in the Trace window, in the form of

‘absolute name (function name)'.

When 1/O Reg is selected

I£0 Reg Mame: P4 - Restore |

Insert | Qhangel Dalate |

I/O Reg Name (peripheral I/O register name setting area)

This area is used to specify a peripheral 1/O register name.

To specify a register name, either directly input one to the text box, or select one from the drop-down
list.

Only the peripheral I/O registers that can be read can be specified. Uppercase and lowercase
characters are not distinguished.

The peripheral I/0 bit names and the I/O port name registered in the Add I/O Port dialog box cannot be
specified.

Note that all the register names are displayed in uppercase characters in the Trace window.

When Memory is selected

Memory Address: I - I Restors |
Memory Display: || vI Inzart | Change Delete |

Memory Address (memory address setting area)

This area is used to specify an address range of the memory (settable range: 0 <= address <=
OXFFFFFFFF).
Start address - End address

If a value is input as only the start address and specifying the end address is omitted, it is assumed

that the same value as the start address is specified as the end address. If the specified address

range cannot be divided by the access size, the address range is rounded up to a range that can be

divided by the access size.

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.

If addresses are registered or changed in this area by using expressions or symbols, the converted

address values are displayed in the Snap Entry area along with the specified expressions and

symbols.

In the Trace window, only the converted address values are displayed.

Memory Display (memory display size setting area)

This area is used to specify the access size of memory snap data.
To specify the access size, either directly input the size or select the size from the drop-down list.

Uppercase and lowercase characters are not distinguished.
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Access Size Abbreviation Contents
Byte B Snapshot of memory in 8-bit units
Half Word HW Snapshot of memory in 16-bit units
Word W Snapshot of memory in 32-bit units

Buttons to manipulate snap data

The following buttons are used to register, change, and delete snap data.

Insert Registers snap data.
The registered snap data is inserted and displayed at the selected position in

the Snap Entry area.

Change Changes the contents of the snap data selected in the Snap Entry area to
the contents of the snap data specified in this area.

Delete Deletes the snap data selected in the Snap Entry area.
The DEL key performs the same operation.

Restore Restores the contents in the Snap Entry area.

(5) Snap Entry (snap data display area)

Snap Entry:

R1
P2

This area displays a list of registered snap data.

The registered snap data is written into the tracer when a snapshot event occurs.

If snap data is selected in this area, the contents of the selected snap data are displayed in each
setting area.

Snap data is displayed as follows:

Register snap data:

R1 Register name
R3(SP)

Peripheral 1/0O register snap data:

PO Peripheral I/O register name
P1
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Memory snap data:

OxFFEO00,HW

OxXFFE100-0xFFE10f

Start address <symbol expression> - End address <symbol
expression>, Access size

Event Manager:

(6) Event Manager (event manager area)

[EJ[Ext00001 ] [E ][ Evtooonz | [T][ Tre00001 |[E][ time_a01 ]|[S.][Srel

[B][ Brkoodot | [6.][ Brkooanz | [T.)[ Treo0002 ] [E.][ time_o02

<

| o

This area displays a list of break, trace and other registered various event conditions.

For details, refer to "Event Manager (event manager area)".

Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this
dialog box. The event condition becomes valid as soon as it has been
registered.

New Newly creates an event condition in this dialog box.

An event condition name is automatically created and a new event condition is
prepared.

Set Registers the various event condition. Because the dialog box is not closed

(when a new even after an event has been registered, new event conditions can be

event link is registered. Each event condition becomes valid as soon as it has been

created or an registered.

event link is If an already registered event condition is displayed, the <Enable> or <Disable>

changed) button is alternately displayed.

Enable/Disable Validates (enables) or invalidates (disables) the selected event condition.

(when a However, event conditions and event link conditions cannot be enabled or

registered eventis | disabled.

displayed) This button and the <Set> button are alternately displayed.

Clear Clears the contents of the event condition.

(when an eventis | This button is displayed when an event condition has not been edited.

not edited) This button and the <Restore> button are alternately displayed.

Restore Restores the contents of an edited event condition.

(when an event is
edited)

If an event condition not registered is displayed, all the fields other than the
event name field are blank or the default values are set.
This button and the <Clear> button are alternately displayed.

Cancel
Close

Closes this dialog box.

Even if an event condition is being edited, it is not registered and the dialog box
is closed.

<Cancel> is displayed if a condition is not created, changed, or deleted; <
Close> is displayed if it is.
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Help

Opens the Help window.

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an
event condition to be set. The event condition will be added to the area
selected when the <Add Event...> button is pressed.

Add Link... Opens the Event Link dialog box in the select mode, and selects or newly
creates an event link condition. The event condition will be added to the area
selected when the <Add Link...> button is pressed.

Other... Opens the dialog box for selecting the event type.

By pressing each of the buttons, each various event setting dialog box can be
opened in the new creation status.

Buttons in event manager area

Shrink <<< Turns off display of the event manager area.

(When area is At this time, the size of the dialog box is reduced.

displayed)

Expand >>> Displays the event manager area.

(When areais not | At this time, the size of the dialog box is expanded.

displayed)

Open Opens the various event setting dialog box corresponding to the selected event

(When only one
event is selected)

condition. Each setting dialog box displays the contents of the selected event
condition.
The Enter key performs the same operation.

Remove Deletes the selected event condition.

(When event is When an event condition or an event link condition is to be deleted, an error

selected) occurs and the event condition or event link condition cannot be deleted if the
event is used as a various event condition.

Add Sets additionally the event condition or event link condition selected in the
event manager area to setting area with a focus. The area to be set additionally
is the area which was selected when this button was selected.

Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event
names.

Sort by Name Sorts events into type order.

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting
the events.

Detail Sets the detailed display mode.

Overview Sets the list display mode.,

Cancel Closes this dialog box (same as ESC key).
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Stub dialog box

This dialog box is used to register, set, and display stub event conditions.

A stub event condition registered in this dialog box will be automatically registered to the Event Manager.

A stub event condition automatically becomes valid when it has been registered.

Up to 256 stub event conditions can be registered. However, the number of stub event conditions that
can be simultaneously used is one including the snap shot event condition (refer to "Table 7-31 Maximum
Number of Valid Events for Each Event Condition”). If the maximum number of stub event conditions that
can be used at the same time is exceeded or if the number of event conditions or event link conditions used

exceeds the maximum limit, therefore, register a stub event condition in the disabled state.

Caution To use the stub event, set After (break after execution) under Break condition (break mode
setting area) in the Extended Option dialog box.
Note that the ID850 uses hardware breaks to control the operation of the stub from the host
computer. The time during which real-time execution is disrupted depends on the load of

Windows on the host computer.

Figure 7-62 Stub Dialog Box

o @
o] .8 I Mew I Disable | Clear | Close | Help |
Stub Mame: [U]|stE00001 | Add Event.

Stub Ewvent: Gio to &dd Link..

Dz

i
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Bemowve

Shrink, <4<

Event Manager:

[E ][ Ewon00z | [T ][ Treooont | [E][ time_oo1 ] [5.)[ Sne000dt |
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I

Infa...

I b I Other...

This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons
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Opening

This dialog box can be opened as follows:

e Select [Event] -> [Stub...] from the menu bar
(or press Alt+N, and U in that order).

« Click the <Stub...> button in the Event dialog box.
(or press Alt+U).

Explanation of each area

The Stub dialog box consists of the following areas:

@)

)

@)

(1) Stub Name (stub event name setting area)
(2) Stub Event (stub condition setting area)
(3) Goto (jJump address setting area)

(4) Event Manager (event manager area)

Stub Name (stub event name setting area)

Stub Mame: IStI:-IIIEIEIEH L|

This area is used to set a stub event name.

Directly input an alphanumeric string of up to eight characters as a name.

To display the contents of an already created event condition, select from the drop-down list.

The mark on the left of this area indicates the utilization status of events (refer to "Table 7-33 Color of
Character on Mark and its Meaning"). The gray mark indicates that an event condition is being edited
and has not been registered yet.

By clicking the left mark, an event condition can be validated or invalidated.

Stub Event (stub condition setting area)

Stub Event:

Bz ]

This area is used to set an event condition for the stub.

In the stub condition setting area, only one event condition and one event link condition can be set.
To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop

it in this area. For details, refer to "Setting event condition and event link condition in each area".

Go to (jump address setting area)

Gio to

_main

This area is used to specify the top address of the function that is executed when a stub event occurs.
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Settable range : 0 <= top address of function <= OxFFFFFFFF

An address can be also specified by a symbol or expression (refer to "Table 7-15 Specifying

Symbols"). The default radix for inputting a numeric value is hexadecimal.

To return from the specified function when a stub event occurs, describe 'JMP [r31] instruction' in the

function.

Event Manager:

(4) Event Manager (event manager area)

[E][Ewtooo0z | [T][ Treo0om | [E][ time_od1 ] [5.][Snp00001

[B.][ Erkooo0z | [T.][ Tre00a2 | [B)[ time_od2 |

This area displays a list of break, trace and other registered various event conditions.

For details, refer to "Event Manager (event manager area)".

Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this
dialog box. The event condition becomes valid as soon as it has been
registered.

New Newly creates an event condition in this dialog box.

An event condition name is automatically created and a new event condition is
prepared.

Set Registers the various event condition. Because the dialog box is not closed

(when a new even after an event has been registered, new event conditions can be

event link is registered. Each event condition becomes valid as soon as it has been

created or an registered.

event link is If an already registered event condition is displayed, the <Enable> or <Disable>

changed) button is alternately displayed.

Enable/Disable Validates (enables) or invalidates (disables) the selected event condition.

(when a However, event conditions and event link conditions cannot be enabled or

registered eventis | disabled.

displayed) This button and the <Set> button are alternately displayed.

Clear Clears the contents of the event condition.

(when an eventis | This button is displayed when an event condition has not been edited.

not edited) This button and the <Restore> button are alternately displayed.

Restore Restores the contents of an edited event condition.

(when an event is
edited)

If an event condition not registered is displayed, all the fields other than the
event name field are blank or the default values are set.
This button and the <Clear> button are alternately displayed.
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Cancel Closes this dialog box.

Close Even if an event condition is being edited, it is not registered and the dialog box
is closed.
<Cancel> is displayed if a condition is not created, changed, or deleted;
<Close> is displayed if it is.

Help Opens the Help window.

Buttons for opening each event setting dialog box

Add Event...

Opens the Event dialog box in the select mode, and selects or newly creates an
event condition to be set. The event condition will be added to the area
selected when the < Add Event...> button is pressed.

Add Link...

Opens the Event Link dialog box in the select mode, and selects or newly
creates an event link condition. The event link condition will be added to the
area selected when the <Add Link...> button is pressed.

Other...

Opens the dialog box for selecting the event type.
By pressing each of the buttons, each various event setting dialog box can be
opened in the new creation status.

Buttons in event manager area

Shrink <<< Turns off display of the event manager area.

(When area is At this time, the size of the dialog box is reduced.

displayed)

Expand >>> Displays the event manager area.

(When areais not | At this time, the size of the dialog box is expanded.

displayed)

Open Opens the various event setting dialog box corresponding to the selected event

(When only one
event is selected)

condition. Each setting dialog box displays the contents of the selected event
condition.
The Enter key performs the same operation.

Remove Deletes the selected event condition.

(When event is When an event condition or an event link condition is to be deleted, an error

selected) occurs and the event condition or event link condition cannot be deleted if the
event is used as a various event condition.

Add Sets additionally the event condition or event link condition selected in the
event manager area to setting area with a focus. The area to be set additionally
is the area which was selected when this button was selected.

Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event
names.

Sort by Name Sorts events into type order.

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting
the events.

Detail Sets the detailed display mode.

Overview Sets the list display mode.,

Cancel Closes this dialog box (same as ESC key).
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Timer dialog box

This dialog box is used to display the execution time measurement result, and register and set timer
event conditions.

A timer event condition that has been registered in this dialog box is automatically registered to the Event
Manager.

The execution time measurement result is displayed when the set timer event condition is selected.

A timer event condition automatically becomes valid when it has been registered.

Up to 256 timer event conditions can be registered. The number of timer event conditions that can be
simultaneously used (validated) is limited (refer to "Table 7-31 Maximum Number of Valid Events for Each
Event Condition").

If the maximum number of timer event conditions that can be used at the same time is exceeded or if the
number of event conditions or event link conditions used exceeds the maximum limit, therefore, register a

timer event condition in the disabled state.

Run-Break event
Run-Break is a timer event name given to a timer event condition that measures the execution time
from execution to break. This timer event name is registered in the default condition and the execution
time can be displayed by selecting it in the Timer Name area in this dialog box.
The Run-Break event for the ID850 is included in the number of timer events simultaneously usable;
therefore, it is always valid and can be used if the maximum number of timer events has not been
reached.

A timer event condition is satisfied only when the timer is valid.

Figure 7-63 Timer Dialog Box

] 4 I My | St | Restares | Cancel | Help |

Timear Mame: IHun-Break LI Add Ewent.. |

Start Event; End Ewent: Add Link.. |

I I Total: 3990 nsec Opean |
Time

Bemowve |

I hd I Shrink €24

Initialigel Capy | Wiew Allways |

Evert Manager:

[E][ Exto0a0 | [E][ Ewooonz | [T.][ Treoo0t | [E][ time_od1 ] [5.][ Snp0a0ot | Add
[e)[ Brkooont | [B.])[ Brkooooz | [T.][ Treno00z | (B[ time_o02 ] (][ 5tb00001 | Info. |

_;I ther... |
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This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Click the Tim button.

« Select [Event] -> [Timer...] from the menu bar
(or press Alt+N, and | in that order).

¢ Click the <Timer... > button in the Event dialog box.
(or press Alt+l).

Explanation of each area

The Timer dialog box consists of the following areas:
(1) Timer Name (timer event name setting area)
(2) Start Event, End Event (timer condition setting area)
(3) Time (timer display unit selection area)
(4) Execution time display area

(5) Event Manager (event manager area)

(1) Timer Name (timer event name setting area)

Timer Mame: IHun— Ereaak LI

This area is used to set a timer event name.

Directly input an alphanumeric string of up to eight characters as a name.

To display the contents of an already created event condition, select from the drop-down list.

The timer event name [Run-Break] that displays from execution to break is registered in the default
condition, but is not displayed on the Event Manager.

The mark on the left of this area indicates the utilization status of events (refer to "Table 7-33 Color of
Character on Mark and its Meaning"). The gray mark indicates that an event condition is being edited
and has not been registered yet.

By clicking the left mark, an event condition can be validated or invalidated.
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(2) Start Event, End Event (timer condition setting area)

Start Event:

End Event:

EEEz

[Eeme]

This area is used to set an event condition for the timer.

Start Event

Set the event condition or event link condition that starts time measurement.

End Event

Set the event condition or event link condition that stops time measurement.

The number of event conditions that can be registered in the timer condition setting area is one for

each of the start and end conditions.

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop

it in this area. For details, refer to "Setting event condition and event link condition in each area".

(3) Time (timer display unit selection area)

This area is used to select the unit in which the timer measurement result is to be displayed.

nsec Nanoseconds (default)
usec Microseconds

msec Milliseconds

sec Seconds

min Minutes

clock Number of Clocks

(4) Execution time display area

Tatal: 3990 nzec

Initialigel Copy | Wiew &lhways

This area displays the result of measuring the execution time of the program.
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Total Total execution time in the measurement zone specified by start event and end
event conditions

(measurable execution time: 2 minutes 51 seconds max "°t¢ )

note  CPU clock : 25MHz, Rate : 1, Display unit: 0.1us

Buttons to manipulate execution time display area

Initialize Clears the measurement results.

Copy Copies the measurement result to the clipboard in text format.

View Always Displays the Timer Result dialog box in which the selected timer event
condition or the measurement result of Run-Break is displayed.

(5) Event Manager (event manager area)

Event Manager:

[EJ[Ew00001 ] [E ][ Evtononz | [T.)[ Tredoom | [E][ time_o01 ] [5.][ Snp00oot |
[B.][ Brk0o0001 | [E.][ Brk00002 | [T.)[ Tre00002 | [E.][ time_oD2 ] [U.][ SthDo0OT |

0

This area displays a list of break, trace and other registered various event conditions.

For details, refer to "Event Manager (event manager area)".

Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this
dialog box. The event condition becomes valid as soon as it has been
registered.

New Newly creates an event condition in this dialog box.
An event condition name is automatically created and a new event condition is
prepared.

Set Registers the various event condition. Because the dialog box is not closed

(when a new even after an event has been registered, new event conditions can be

event link is registered. Each event condition becomes valid as soon as it has been

created or an registered.

event link is If an already registered event condition is displayed, the <Enable> or <Disable>

changed) button is alternately displayed.

Enable/Disable Validates (enables) or invalidates (disables) the selected event condition.

(when a However, event conditions and event link conditions cannot be enabled or

registered eventis | disabled.

displayed) This button and the <Set> button are alternately displayed.
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Clear Clears the contents of the event condition.

(when an eventis | This button is displayed when an event condition has not been edited.
not edited) This button and the <Restore> button are alternately displayed.
Restore Restores the contents of an edited event condition.

(when an event is
edited)

If an event condition not registered is displayed, all the fields other than the
event name field are blank or the default values are set.
This button and the <Clear> button are alternately displayed.

Cancel Closes this dialog box.

Close Even if an event condition is being edited, it is not registered and the dialog box
is closed.
<Cancel> is displayed if a condition is not created, changed, or deleted;
<Close> is displayed if it is.

Help Opens the Help window.

Buttons for opening each event setting dialog box

Add Event...

Opens the Event dialog box in the select mode, and selects or newly creates an
event condition to be set. The event condition will be added to the area
selected when the < Add Event...> button is pressed.

Add Link...

Opens the Event Link dialog box in the select mode, and selects or newly
creates an event link condition. The event link condition will be added to the
area selected when the <Add Link...> button is pressed.

Other...

Opens the dialog box for selecting the event type.
By pressing each of the buttons, each various event setting dialog box can be
opened in the new creation status.

Buttons in event manager area

Shrink <<< Turns off display of the event manager area.

(When area is At this time, the size of the dialog box is reduced.

displayed)

Expand >>> Displays the event manager area.

(When areais not | At this time, the size of the dialog box is expanded.

displayed)

Open Opens the various event setting dialog box corresponding to the selected event

(When only one
event is selected)

condition. Each setting dialog box displays the contents of the selected event
condition.
The Enter key performs the same operation.

Remove Deletes the selected event condition.

(When event is When an event condition or an event link condition is to be deleted, an error

selected) occurs and the event condition or event link condition cannot be deleted if the
event is used as a various event condition.

Add Sets additionally the event condition or event link condition selected in the
event manager area to setting area with a focus. The area to be set additionally
is the area which was selected when this button was selected.

Info... Opens the Select Display Information dialog box.

This dialog box is used to change the display mode and rearrange event
names.
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Sort by Name

Sorts events into type order.

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting
the events.

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Timer Result dialog box

This dialog box displays the result of measuring the execution time.

It displays the timer event condition set in the Timer dialog box and the result of measuring the execution
time of [Run-Break].

The Timer Result dialog box corresponds to a timer event condition or [Run-Break] on a one-to-one
basis, and two or more of this dialog box can be simultaneously opened. Up to 257 Timer Result dialog
boxes can be opened, of which 256 correspond to timer event conditions and one corresponds to [Run-
Break].

However, the number of timer event conditions that can be simultaneously measured is up to the number
of timer event conditions that can be simultaneously used (refer to "Table 7-31 Maximum Number of Valid

Events for Each Event Condition").

Figure 7-64 Timer Result Dialog Box

Timer = Rurn—Ereak

Tatal: 3990 nszec

Initialigel Copy |

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select a timer event condition or Run-Break in the Timer dialog box
Click the <View Always> button.
(or press Alt+V).

Explanation of each area

The Timer Result dialog box consists of the following areas:

(1) Execution time display area

(1) Execution time display area

This area displays the result of measuring the execution time of the program (refer to "Execution time
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display area").

Function buttons

Initialize Clears the measurement results.

Copy Copies the measurement result to the clipboard in text format.
Close Closes this dialog box.

Help Opens the Help window.
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Delay Count dialog box

This dialog box is used to set or display delay count values.
By setting a delay count value, a trace can be executed the number of times specified by the delay count
value after the delay trigger event condition set in the Trace dialog box has been satisfied. The program

can be executed and the tracer can be stopped.

Figure 7-65 Delay Count Dialog Box

elay Count

Delay Count 0] S

o] 4 I Bestore | Cancel I Help |

This section explains the following items:

« Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

¢ Select [Event ] -> [Delay Count...] from the menu bar
(or press Alt+N and Y in that order).

Explanation of each area

This dialog box consists of the following areas:

(1) Delay Count (delay count setting area)

(1) Delay Count (delay count setting area)

Delay Count ] =

T

This area is used to set or display a delay count value (unit: frames).

The settable range is 0 (default) to 32767.
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Function buttons

OK Sets the specified delay count and closes this dialog box.
Restore Restores the previous delay count.

Cancel Closes this dialog box.

Help Opens the Help window.
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Reset Debugger dialog box

This dialog box is used to initialize the debugger, emulation CPU, and symbol information.

Specify what is to be initialized by using the check box. In the default condition, the debugger is
initialized.

Figure 7-66 Reset Debugger Dialog Box

[T Target CPU

Do wou want to reset 7

o] I Cancel Help

This section explains the following items:

* Opening
« Explanation of each area

¢ Function buttons

Opening

This dialog box can be opened as follows:

« Select [Eile] -> [Debugger Reset...] on the menu bar
(or press Alt+F, and R in that order).

Explanation of each area

The Reset Debugger dialog box consists of the following areas:

(1) Reset subject selection area

(1) Reset subject selection area

[+ iDebuggeri

Err o

[ Symbal
[ Target CPU

This area is used to select what is to be initialized.
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Debugger Initializes the debugger (default).
Symbol Initializes the symbol information.
Target CPU Initializes the emulation CPU.

Function buttons

OK Initializes the debugger, symbol information, or CPU.
Cancel Ignores the setting and closes this dialog box.
Help Opens the Help window.
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About dialog box

This dialog box displays the version information of the debugger and in-circuit emulator (the year is
displayed in 4 digits).

The following version information is displayed:

« Product version of debugger
« Version of device file

* Version of GUI

« Version of debugger DLL

» Version of assembler DLL

* Version of executor

 Version of monitor

Figure 7-67 About Dialog Box

Akt

MEC Imtegrated Debugger IDES0
“Wersion PR DR

Was0[uPDT03002] Mo

WESO |E Debugger Hi [He—sH-3]
WEE0 Debugger PR D=
WESD Asmd Disasm 00 DW=
WEAD Executer w0

WEAO Monitor W00

Copyright (21 NEC Corporation 1993-200%
All rights reserved by MEC Carporation.

This section explains the following items:

* Opening

¢ Function buttons

Opening

This dialog box can be opened as follows:

* Select [Help]->[About]
(or press Alt+H, and A in that order).
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Function buttons

OK Closes this dialog box.
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Exit Debugger dialog box

This dialog box is used to select whether the current debug environment is saved to a project file or not

before terminating the debugger.

It can be specified in the Debugger Option dialog box that the debugger is terminated without this

confirmation dialog box being opened.

Figure 7-68 Exit Debugger Dialog Box

D850

Thig will end vour Debugeger zeszion.
Do wou want to zave the zettings in the project file 7

Mo | Cancel |

Reference If an attempt is made to terminate the debugger while the user program is being executed,

the following message is displayed and the program execution can be stopped.

1D850

@ ifb00: Uzer proeram iz running. Do you want to stop user program?

<Yes> button is selected

Execution of the user program is stopped and then the Exit Debugger dialog box is displayed.
If it is specified in the Debugger Option dialog box that the Exit Debugger dialog box is not to
be displayed, however, the debugger is terminated.

<No> button is selected

Execution of the user program is not stopped and the Exit Debugger dialog box is not

displayed. The debugger is not terminated.

This section explains the following items:

« Opening

¢ Function buttons

Opening

This dialog box can be opened as follows:
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« Select [Eile] -> [Exit] from the menu bar
(or press Alt+F, and X in that order).

¢ Press the Alt+F4 keys simultaneously.

« If forcible termination, such as to terminate the application, has been executed on the task list that
terminates Windows.

Function buttons

Yes Saves the current debug environment to a project file, closes all the windows, and
terminates the debugger.

If a project file name is not specified, the Project File Save dialog box is opened. If
the < Cancel> button is selected on the Project File Save dialog box, the
environment is neither saved to a project file nor is the debugger terminated.

If a project file is loaded or saved during debugger operation, this button has the
default focus.

No Closes all the windows and terminates the debugger.

If a project file is not loaded or saved during debugger operation, this button has the
default focus.

Cancel Closes this dialog box without executing anything.
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Console window

This window is used to input commands that control the debugger.

Because the key bind is Emacs-like, the accelerator key is not acknowledged if the Console window is
active.

However, the F1 key displays the help of the Console window.

While the Console window is open, an error message window with only an <OK> button is displayed in
the Console window.

Refer to "COMMAND REFERENCE" for details on the command specifications.

Figure 7-69 Console window

aw onsole

Main console display active
[nectools3Z2) 1 % address main
0x388

[nectools3Z) 2 % address main +1
Ox389

(nectools3z) 3 % |

This section explains the following items:

« Opening

Opening

This window can be opened as follows:

« Select [Browse] -> [Console] from the menu bar
(or press Alt+B, and N in that order).
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This section explains the command functions of the ID850 in detail.

8.1 Command Line Rules

The specification of command lines has the following rules:

« Command name, option, and argument are specified for command line.

« To divide words, a space (space key or tab key) is used.

* At the end of a line, a line feed character or a semicolon is used.

* When a command name and an option are entered to the point of identifiability, they are recognized.

« In script, command names have to be entered completely.

Command format

command -options argl arg2 arg3 ...

8.2 Command List

The list of ID850 commands is shown in Table 8-1 and Table 8-2 .

Table 8-1 List of Debugger Control Commands

Command Name Function

address Evaluation of address expression
Converts the address expression specified with expression into address.

assemble Disassemble/line assemble (a)
Assembles the character strings specified with code from the address
specified with address.

batch Executing batch (with echo)
Executes in batch displaying files specified with scriptname on the screen.

breakpoint Setting/deletion of breakpoint (b)
Operates breakpoint specified with options and address.

cache Setting of cache
Sets | cache and D cache.

dbgexit Terminating debugger
Terminates the debugger.

download Download of files (1)
Downloads files specified with filename according to options.

extwin Creation of expansion window
Creates expansion window with scriptfile.

finish Returning from function
Executes until it returns to the program that called the current function.

go Continuous execution (g)
Executes program continuously.
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Table 8-1 List of Debugger Control Commands

Command Name Function
help Display of help
Displays help of Dcl.
hook Setting of hook
Sets the procedure for hook with scriptfile.
ie Display/setting of IE register
This command depends on the IE.
jump Jump to window (j)
Displays the window specified with options.
map Setting/deletion of memory mapping
Sets, deletes, and displays memory mapping.
mdi Setting of expansion window
Sets the size and title name of the expansion window.
memory Display/setting of memory (m)
Sets value in the memory of the address specified with address according to
options.
module Display of the list of files and functions
Displays the list of files and functions of the load module specified with
progname.
next Procedure step (n)
Executes the procedure steps.
refresh Redrawing of window
Redraws the window and updates the data.
register Display/setting of register value and 1/O register value
Sets value in the register specified with regname.
reset Reset
Resets CPU, debugger or symbols.
run Reset and execution of CPU (r)
Resets program and executes it.
step Step execution (s)
Executes step execution.
stop Stop execution
Stops the program forcibly.
upload Upload
Saves the memory data or coverage data within the specified range in a file.
version Display of the version information
Displays the version information of the debugger.
watch Display/setting of variables (w)
Displays and sets the variables.
where Trace of stack
Executes the back-trace of the stack.
wish Start of Tclet
Starts the script using Tk (Tclet).
xcoverage Operation of coverage

Operates coverage.
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Table 8-1 List of Debugger Control Commands

Command Name

Function

xtime Operation of timer
Operates timer.
xtrace Operation of tracer

Operates tracer.

Table 8-2 List of Console/Tcl Commands

Command Name

Function

alias Creation of another name

cd Change of directory

clear Clears the screen

echo Echo

exit Close/end

history Display of history

Is Display of files

pwd Check of the directory

source Execution of batch

time Measurement of time for commands
tkcon Console control

unalias Deletion of another name

which Display of the command path or another name

Other commands

Based on Tcl/Tk 8.1
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8.3 List of Variables

« dcl(chip) - Chip name read only

« dcl(prifile) - Project file name read only
« dcl(srcpath) - Source path read only

« dcl(ieid) - IE type read only

« dcl(iestat) - IE status read only

« dcl(bkstat) - Break status read only

« env(LANG) - Language

 dcl_version - Dcl version read only

8.4 List of Packages

« fcltest - Restoration test
¢ cwind - Automatic window control

« BWidget - Toolkit

8.5 Key Bind

¢ tcsh + emacs like
« Complement of command name [Tab]
« Complement of file name [Tab]

HTML help [F1]

8.6 Expansion window

The expansion windows can be created using Tk.
In the expansion windows, Widget is allocated with ".dcl' as a root instead of ".".
When the following script files are allocated in bin/idtcl/tools/, an expansion window is added on selecting

[Browse] -> [Others] from the menu bar.

The mdi command, an exclusive command for expansion windows, has been added.

# Sample.tcl

wm protocol .dcl WM_DELETE_WINDOW { exit }
mdi geometry 100 50

button .dcl.b -text Push -command exit

pack .dcl.b

In expansion windows, Tk menu commands cannot be used because of the restrictions of MDI windows.

8.7 Callback Procedure

Expansion windows can hold dcl_asyncproc procedures called by asynchronous messages.
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}

proc dcl_asyncproc {mid} {
if {$mid == 19} {
redraw

The asynchronous message ID is passed for the argument of the dcl_asyncproc procedure.

The message IDs are shown below:

Table 8-3 Message ID

Message ID

Meaning

After changing configuration

10

After registering event

11

After deleting event

12

Before executing

13

After breaking

14

After resetting CPU

15

After resetting debugger

17

After changing extended option

18

After changing debugger option

19

After downloading

20

After changing memory or register

36

Before starting tracer

37

After stopping tracer

38

Before starting coverage

39

After stopping coverage

40

Before starting timer

41

After stopping timer

42

After clearing trace

45

After resetting symbol

8.8 Hook Procedure

A hook can be set in the debugger using the hook procedure.

The hook procedures are shown below:

BeforeDownload

AfterCpuReset

Hook before downloading

Hook after resetting CPU
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BeforeCpuRun Hook before starting execution

AfterCpuStop Hook after breaking

By using hook procedures, register values can be changed before downloading programs or after
resetting the CPU.

An actual example of the procedure is shown below. A hook is valid till the debugger is closed.

[When hook is set with debugger control command]

1 Create script file a. with an editor.
2  Start up the ID850, select [Browse] menu -> [Console], and open the Console window.

3 Ifthe script file is executed in the window as below, the hook in the script file is set.
%hook test.tcl

[When hook is set on downloading of project file]

1 Create script file a. with an editor.

Caution Be sure that the script file name is the same as the project file.
Example:
The script file corresponding to test.prj is test.tcl.

Allocate test.prj, test.pri, and test.tcl in the same directory.

2 Start up the ID850 and read test.prj.
The hook in the script file is set.

An example of the contents of a script file is shown as below (using the ICE for the V850E/MS1).

proc BeforeDownload {} {
register MM 0x7
register PMC8 Oxff
register PMC9 Oxff
register PMCX 0xe0

}

proc AfterCpuReset {} {
register MM 0x7
register PMC8 Oxff
register PMC9 Oxff
register PMCX 0xe0

}
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8.9 Related Files

« Executes when the aliases.tcl console is opened.
Sets the default alias etc.

« Executes when the project file name.tcl project is opened.
The hook of BeforeDownload, AfterCpuReset, BeforeCpuRun and AfterCpuStop can be used.

¢ Executes when the load module name.tcl load module is downloaded.
The hook of BeforeDownload, AfterCpuReset, BeforeCpuRun and AfterCpuStop can be used.

8.10 Cautions

* The separator for file and path is a slash (/).
* When a console or an expansion window is active, the accelerator key cannot be acknowledged.
« When a console is open, error messages are output to the console.

* When the [F1] key on the console is pressed, the HTML format help is opened (not opened from the
menu).

« To terminate the command forcibly, close the console.

« The execution of external commands (DOS commands) is OFF by default.
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8.11 Commands

In this section, each command is explained using the format shown below.

Command name

Gives a brief explanation of the function of the command.

Name

Describes the command name.

Input format

Describes the input format of the command.

Functions

Explains the functions of the command.

Usage example

Shows an example of the usage of the command.
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address

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

address - Evaluation of address expression

Input format

address expression

Functions

Converts the address expression specified by expression into address.

Usage example

(IDCON) 1 % address main
Oxaa

(IDCON) 2 % address main+1
Oxab
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assemble

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

assemble - Disassemble/line assemble

Input format

assemble ?options? address ?code?

Functions

Assembles the character strings specified by code from the address specified by address.
When '." is specified for address, it is understood as an address continuing from the immediately previous

assemble.
When code is omitted, it is assembled from the address specified by address.

The followings are options. They are ignored for assembly.

-code Command code is also displayed. It is ignored for assembly.

-number number number line is displayed. It is ignored for assembly.

Usage example

(IDCON) 1 % assemble -n 5 main

0x000000aa B7 PUSH HL
0x000000ab B1 PUSH AX
0x000000ac 891C MOVW AX,SP
0x000000ae D6 MOVW HL,AX
0x000000af A100 MOV A#0H

(IDCON) 2 % assemble main mov a,b

(IDCON) 3 % assemble . mov a,b
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batch

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

batch - Executing batch (with echo)

Input format

batch scripthname

Functions

Executes in batch with displaying files specified by scriptname on the screen.

Nesting is possible.

Usage example

(IDCON) 1 % clear
(IDCON) 2 % batch bat_file.tcl
(IDCON) 3 % tkcon save a:/log.txt
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breakpoint

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

breakpoint - Setting/deletion of breakpoint

Input format

breakpoint ?options? ?address1? ?address2?
breakpoint -delete brkno

breakpoint -enable brkno

breakpoint -disable brkno

breakpoint -information

Functions

Operates the breakpoint specified by options and address.
If a breakpoint can be set correctly, the breakpoint number is returned.

The following are options:

338

-software A software break is specified.

-hardware A hardware break is specified (default).
-execute The address execution break is set (default).
-beforeexecute The break before address execution is set.
-read An address data read break is set.

-write An address data write break is set.

-access An address data access break is set.

-size size The access size is set (8, 16, or 32).

-data value The data condition is set.

-datamask value

-extprobe value

The data mask is set.

The external sense data condition is set.
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-extprobemask value
-passvalue
-information

-delete

-disable

-enable

Usage example

The external sense data mask is set.
The path count is set.
The list of breakpoints is displayed.

The breakpoint whose number is specified is deleted.

The breakpoint whose number is specified is disabled.

The breakpoint whose number is specified is enabled.

(IDCON) 1 % breakpoint main

1

(IDCON) 2 % breakpoint -i

1 Brk0O0001 enable rammon.c#17

(IDCON) 3 % breakpoint -software sub

2

(IDCON) 4 % breakpoint -i

1 Brk0O0001 enable rammon.c#17

2 Brk00001 enable rammon.c#8

(IDCON) 5 % breakpoint -disable 2

(IDCON) 6 % breakpoint -i

1 Brk00001 enable rammon.c#17

2 Brk00001 disable rammon.c#8

(IDCON) 7 % breakpoint -delete 1
2 Brk00001 disable rammon.c#8
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cache

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

cache - Setting of cache

Input format

cache
cache config ?-icache itype? ?-dcache dtype?

cache clear ?-icache bool? ?-dcache bool?

Functions

When config is specified for the subcommand, the cache type is set.
When clear is specified for the subcommand, whether cache clear is to be done by EXEC, or not, is set
(default is clear)

When subcommand or below is omitted, the current status is displayed.

itype is selected from the following:

NB85E212 NB85E212 is used.
NB85E213 NB85E213 is used.
nouse Not used (default).

dtype is selected from the following:

NB85E252 NB85E255 is used.
NB85E263 NB85E263 is used.
nouse Not used (default).
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Usage example

(IDCON) 1 % cache config -i NB85E212 -d NB85E252
(IDCON) 2 % cache

i-cache: NB85E212

d-cache: NB85E252

(IDCON) 3 % cache clear -i false

(IDCON) 4 % cache

i-cache: NB85E212 (persist)

d-cache: nouse
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dbgexit

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

dbgexit - Terminating debugger

Input format

dbgexit ?options?

Functions

Terminates the debugger.

The following are options:

-saveprj Project is saved on terminating debugger.

Usage example

(IDCON) 1 % dbgexit -savepr;j
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download

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

download - Download of files

Input format

download ?options? filename ?offset?

Functions

Downloads file specified by filename according to options.
If offset is specified, the address is shifted by the offset (if the data is in binary format, the load start

address is specified for offset).

-binary Binary format data is downloaded.

-coverage Coverage data is downloaded.

-append Additional download is executed.

-nosymbol Download is executed. Symbol information is not read.
-reset CPU is reset after download.

-information Download information is displayed.

Usage example

(IDCON) 1 % download test.Imf
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extwin

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

extwin - Creation of expansion window

Input format

extwin scriptfile

Functions

Creates expansion window with scriptfile.

Usage example

(IDCON) 1 % extwin d:/foo.tcl
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finish

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

finish - Returning from function

Input format

finish

Functions

Executes until it returns to the program that called the current function.

Usage example

(IDCON) 1 % finish
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go

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

go - continuous execution

Input format

go ?options?

Functions

Executes the program continuously. When -waitbreak is specified, it waits for the program to stop.

The following are options:

-ignorebreak Breakpoint is ignored.

-waitbreak The command waits for the program to stop.

Usage example

IDCON) 1 % go -w
( g
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help

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

help - Display of help

Input format

help

Functions

Displays Dcl help.

Usage example

(IDCON) 1 % help
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hook

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

hook - Setting of hook

Input format

hook scriptfile

Functions

Sets the procedure for hook with scriptfile.

Usage example

(IDCON) 1 % hook d:/foo.tcl
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The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

ie - Display/setting of IE register

Input format

ie reg address ?value?

ie dcu address ?value?

Functions

The ie command depends on the IE.

When reg is specified for the subcommand, referencing and setting of the IE register is executed.

Usage example

(IDCON) 1 % ie reg 0x100 1
(IDCON) 2 % ie dcu 0x100 1
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jump

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

jump - Jump to window

Input format

jump -source -line filename ?line?

jump ?options? address

Functions

Displays the window specified by options.

-source

-assemble

-memory

-coverage

-line

Usage example

The Source window is displayed from the address specified by address.

The Assemble window is displayed from the address specified by
address.

The Memory window is displayed from the address specified by
address.

The Coverage window is displayed from the address specified by
address.

The command is moved to the line specified by ine.

(IDCON) 1 % jump -s main

(IDCON) 2 % jump -s -l mainfile.c 10

(IDCON) 3 % jump -m array
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map

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

map - Setting/deletion of memory mapping

Input format

map options address1 address2 ?accsize?

Functions

Sets, deletes, and displays memory mapping.
The access size of 8, 16, or 32 is specified by accsize (the default is 8).

The following are options:

-erom Alternate ROM is mapped.

-eram Alternate RAM is mapped.

-target Target area is mapped.

-protect I/O protect area is mapped.

-rrm The starting address in the real-time RAM monitor area is set (only for
V850).

-clear All the settings for the mapping are deleted.

-information Refer to the setting for the mapping.

Usage example

(IDCON) 1 % map -i

1: 0 Ox7fff 8 {IROM}

2: 0x8000 0x87ff 8 {Target RRM}
3: 0x8800 0x9fff 8 {Target}

4: 0xa000 0xf7ff 8 {NonMap}
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5: 0xf800 Oxfaff - {NonMap}

6: 0xfb00 Oxfedf 8 {Saddr}

7: OxfeeO Oxfeff 8 {Register}

8: Oxff00 Oxffff 8 {SFR}

(IDCON) 2 % map -erom 0x100000 Ox1Offff
(IDCON) 3 % map -c
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mdi

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

mdi - Setting of expansion window

Input format

mdi geometry ?x y? width height

mdi title string

Functions

Sets the size and title name of the expansion window.

The command can be used only from the expansion window.

Usage example

(IDCON) 1 % mdi geometry 0 0 100 100
(IDCON) 2 % mdi title foo
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memory

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

memory - Display/setting of memory

Input format

memory ?options? address ?value?

memory ?options? -fill address1 address2 value

memory ?options? -copy address1 address2 address3

Functions

Sets value in the memory of the address specified by address according to options.

If value is omitted, display the value of the memory of the address specified by address.

If -fill is specified, value is filled from address1 to address?2.

If -copy is specified, data from address1 to address?2 is copied to address3.

The following are options:

-byte
-halfword
-word

fill

-Copy

-noverify

Usage example

Displayed/set in one-byte units (default).
Displayed/set in halfword units.
Displayed/set in word units.

The data is filled in.

The data is copied.

Verification is not executed on writing.

(IDCON) 1 % memory 100
0x10
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(IDCON) 2 % memory 100 2
(IDCON) 3 % memory 100

0x02

(IDCON) 4 % memory -fill 0 1ff O
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module

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

module - Display of the list of files and functions

Input format

module progname ?filename?

Functions

Displays the list of files and functions of the load module specified by progname.
If filename is not specified, the list of files is displayed.

If filename is specified, the list of functions of the specified files is displayed.

Usage example

(IDCON) 1 % module rammon.Imf

1: rammon.c

(IDCON) 2 % module rammon.Imf rammon.c
1: rammon.c subl

2: rammon.c main
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next

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

next - Procedure step

Input format

next ?options?

Functions

Executes the procedure steps. If functions are called, the step stops after executing function.

The following are options:

-source Command is executed in source line units (default).

-instruction Command is executed in command units.

Usage example

(IDCON) 1 % next -i
(IDCON) 2 % next -s
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refresh

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

refresh - Redrawing of window

Input format

refresh

Functions

Redraws the window and updates the data.

Usage example

(IDCON) 1 % batch foo.tcl
(IDCON) 2 % refresh
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register

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

register - Display/setting of register value and I/O register value

Input format

register ?options? regname ?value?

Functions

Sets value in the register specified with regname.
If value is omitted, displays the value of the register specified by regname.

The following are options:

-force Compulsory reading is executed.

Usage example

(IDCON) 1 % register pc
0x100

(IDCON) 2 % register pc 200
(IDCON) 3 % register pc
0x200
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reset

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

reset - Reset

Input format

reset ?options?

Functions

Resets the CPU, debugger or symbols.
If options are omitted, the CPU is reset.

The following are options:

-cpu CPU is reset (default).
-debugger Debugger is reset.
-symbol Symbol is reset.
-event Event is reset.

Usage example

(IDCON) 1 % reset
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run

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

run - Reset and execution of CPU

Input format

run ?options?

Functions

Resets the program and executes it.
If -waitbreak is not specified, the command does not wait until the program stops.

The following are options:

-waitbreak The command waits for the program to stop.

Usage example

(IDCON) 1 % run
(IDCON) 2 % run -w
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step

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

step - Step execution

Input format

step ?options?

Functions

Executes step execution.
If functions are called, the command stops at the head of the functions.

The following are options:

-source The command is executed in source line units (default).

-instruction The command is executed in command units.

Usage example

(IDCON) 1 % step -i
(IDCON) 2 % step -s

362 User's Manual U16217EJ1VOUM



CHAPTER 8 COMMAND REFERENCE

stop

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

stop - Stop executing

Input format

stop

Functions

Stops the program forcibly.

Usage example

(IDCON) 1 % run
(IDCON) 2 % stop
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upload

The following items are explained here.

Name

Input format

Functions

Usage example

Name

upload - Upload

Input format

upload ?options? filename address1 address2

Functions

Saves the memory data or coverage data within the specified range in a file.

The following are options:

Usage example

-binary
-coverage
-intel
-motorola
-tektronix

-force

The data is saved in binary format.

The coverage data is saved.

The data is saved in Intel HEX format (default).
The data is saved in Motorola HEX format.
The data is saved in Tektronix HEX format.

The file is overwritten.

(IDCON) 1 % upload -b foo.hex 0 Oxffff
(IDCON) 2 % upload -c -f foo.cov 0 Oxffff
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version

The following items are explained here.

* Name
« Input format
¢ Functions

» Usage example

Name

version - Display of the version information

Input format

version

Functions

Displays the version information of the debugger.

Usage example

(IDCON) 1 % version

GUI : E2.00y [31-May-99]

Devicefile : 78K0[uPD780034] E1.01a
Debugger : 78K/0 Debugger E2.50c [02-Apr-99]
Executer : 78K/0 Executer E1.3c

Packet translator : 78K/0 Packet E2.00w
Assembler : 78K/0 Asm/Disasm E1.15a [01-Apr-99]
Tcl/Tk :8.1.1
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watch

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

watch - Display/setting of variables

Input format

watch ?options? variable ?value?

Functions

Displays and sets the variables.

The following are options:

-binary The value is displayed in binary digits.

-octal The value is displayed in octal digits.

-decimal The value is displayed in decimal digits.

-hexdecimal The value is displayed in hexdecimal digits.

-string The value is displayed in character strings.

-sizeof The size, instead of the value, of variables is displayed in decimal digits.

Usage example

(IDCON) 1 % watch var

0x10

(IDCON) 2 % watch -d var

16

(IDCON) 3 % watch array\[0\] Oxa
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where

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

where - Trace of stack

Input format

where

Functions

Executes the back-trace of the stack.

Usage example

(IDCON) 1 % where

1: test2.c#sub2(int i)#13
2: test.c#num(int i)#71
3: test.c#main()#82
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wish

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

wish - Startup of Tclet

Input format

wish scripthname

Functions

Starts up the script using Tk (Tclet).

The expansion window can be created with Tclet.

Usage example

(IDCON) 1 % wish test.tcl
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xcoverage

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

xcoverage - Operation of coverage

Input format

xcoverage option

Functions

Operates coverage.

The following are options:

-start The coverage starts on executing the program.
-stop The coverage stops on executing the program.
-clear The coverage memory is cleared.

Usage example

(IDCON) 1 % xcoverage -start
(IDCON) 2 % xcoverage -stop
(IDCON) 3 % xcoverage -clear
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xtime

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

xtime - Operation of timer

Input format

xtime option

Functions

Operates timer.

The following are options:

-start Timer starts on executing the program.
-stop Timer stops on executing the program.
-gobreak Time from Go to Break is displayed with clock.

Usage example

(IDCON) 1 % xtime -start
(IDCON) 2 % xtime -stop
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xtrace

The following items are explained here.

* Name
« Input format
¢ Functions

« Usage example

Name

xtrace - Operation of tracer

Input format

xtrace -dump ?-append? frameno ?filename?

xtrace -start
xtrace -stop
xtrace -clear
xtrace -addup bool

xtrace -mode mode

Functions

Operates tracer.

The following are options:

-start
-stop
-clear

-dump

-append
-addup bool

-mode mode

The tracer starts on executing the program.
The tracer stops on executing the program.
The trace data is dumped (default).

The dump result is redirected to the console window.

If the file name is specified, the dump result is written in the file.

The dump result is added to a file.
Whether the time tag is integrated or not is selected.

The trace control mode (any one of: all, cond, nonstop, fullstop,

fullbreak, delaystop, delaybreak, machine, or event) is selected.
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Usage example

(IDCON) 1 % xtrace -start

(IDCON) 2 % xtrace -stop

(IDCON) 3 % xtrace -dump 3

01685 2 000000BC M1 br _sub2+0x2
_01686 4 0000009A BRM1 st.w r6, 0x8[sp]
_01687 3 0000009E BRM1 st.w r0, 0x0[sp]
(IDCON) 4 % xtrace -clear

(IDCON) 5 % xtrace -addup true
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This appendix explains the input conventions of the following items:

Character set

Symbols

Numeric Values

Expressions and Operators

A.1 Character set

The characters listed in Table A-1 can be used as the character set.

The characters listed in Table A-2 can be used as special characters.

Specify a line number as an integer constant, starting from 1.

Table A-1 Usable Character Set

Classification

Character

Alphabetic Uppercase characters: ABCDEFGHIJKLMNOPQRSTUVXWZ
characters Lowercase characters:abcdefghljklmnopgrstuvxwz
Numerals 0123456789
Character @_
equivalent to
alphabetic
character
Table A-2 List of Special Characters

Character Name Usage
( Left parenthesis Changes operation order.
) Right parenthesis Changes operation order.
+ Plus Addition operator or positive sign
- Minus Subtraction operator or negative sign
* Asterisk Multiplication operator or indirect reference operator
/ Slash Division operator
% Percent Remainder operator
~ Tilde Complement operator

Vertical line Bit sum operator
A Circumflex Bit difference operator
& Ampersand Bit product operator or address operator

Left bracket

Array subscript operator or base register specification symbol
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Table A-2 List of Special Characters

Character Name Usage

] Right bracket Array subscript operator or base register specification symbol
Period Direct member operator or bit position specifier

, Comma Delimiter between operands

A.2 Symbols

The following rules apply to symbols:

1 A symbol consists of characters Ato Z, ato z, @, _ (underbar), . (period), and 0 to 9.
2 A symbol must start with a character other than numerals 0 to 9.
3 Uppercase characters (A to Z) and lowercase characters (a to z) are distinguished.

4 A symbol must be no more than 256 characters long (if a symbol of more than 265 characters is
defined, only the first 256 characters are valid).

5 A symbol is defined by loading a load module file.

6 Symbols are classified into the following types by the valid range:
- Global symbol (assembly language, C language)
- Static symbol (C language)
In-file static symbol
In-function static symbol
- Local symbol (C language)
In-file local symbol
In-function local symbol
In-block local symbol

7 The following symbols are available for each language used:
- Assembly language
Label name
- C language
Variable name (including pointer function name, enumeration type variable name, array name,
structure name, and union name)
Function name, label name
Array element, structure element, union element, bit field (if the symbol is an array, structure, or
union)

8 A symbol can be described instead of an address or numeric value.

9 The valid range of a symbol is determined based on the source debug information when the source
file is assembled or compiled.

10 Describe only the symbol name of a global symbol.

11 A local symbol is expressed in pairs with a file name.
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Numeric Values

The following four types of numeric values can be used. The input format of each type is as shown
below.

The suffix (bold) and the alphabetic characters of hexadecimal numbers may be uppercase or lowercase
characters. If the first character is A to F, 0 must be prefixed to it.

In the input field of the debugger, decimal numbers or hexadecimal numbers are alternately selected,

depending on the default radix.

Table A-3 Input Format of Numeric Values

numeric value Input format

Binary number nY
n...nY (n=0,1)

Octal number noO
n...nO (n=0,1,2,3,4,5,6,7)
nQ
n..nQ (n=0,1,2,3,4,5,6,7)

Decimal number n

n...n

nT

n...nT (n=0,1,2,3,4,5,6,7,8,9)

Hexadecimal numbers n

n...n

nH

n...nH

0oxn

oxn...n (n=0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F)

Expressions and Operators

Expressions
An expression consists of constants, register names, IOR names, and symbols coupled by operators.
If an IOR name, label name, function name, or variable name is described as a symbol, an address is
calculated as the value of the symbol.
The elements making up an expression, except operators, are called terms (constants and labels).

Terms are called the first term, the second term, and so on, starting from the left.

Operators

The following operators of the C language can be used:

Table A-4 List of Operators

Symbol Meaning Explanation

Operators

+ Addition Returns the sum of the first and second terms.
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Table A-4 List of Operators

Symbol Meaning Explanation

- Subtraction Returns the difference between the first and second terms..

* Multiplication Returns the product of the first and second terms.

/ Division Divides the value of the first term by the value of the

second term, and returns the integer of the result.

MOD Remainder Divides the value of the first term by the value of the

% second term, and returns the remainder of the result.

- sign Unary operator Returns 2's complement of the value of the term.
(negative)

+ sign Unary operator Returns the value of the term.
(positive)

Logical operator

NOT Negation Logically negates each bit of the term, and returns the

~ result.

AND Logical product Obtains the logical product of the values of the first and

& second terms on each bit, and returns the result.

OR Logical sum Obtains the logical sum of the values of the first and

| second terms on each bit, and returns the result.

XOR Exclusive logical Obtains the exclusive logical sum of the values of the first

N

sum

and second terms on each bit, and returns the result.

Shift operator

SHR Right shift Shifts the value of the first term by the value (number of

>> bits) of the second term to the right, and returns the result.
As many 0Os as the number of shifted bits are inserted in the
higher bits.

SHL Left shift Shifts the value of the first term by the value (hnumber of

<< bits) of the second term to the left, and returns the result.
As many Os as the number of shifted bits are inserted in the
lower bits.

Byte separation operator

HIGH Higher byte Of the lowest 16 bits of the term, returns the higher 8 bits.

LOW Lower byte Of the lowest 16 bits of the term, returns the lower 8 bits.

Word separation operator

HIGHW Higher word Of the 32 bhits of the term, returns the higher 16 bits.
LOoww Lower word Of the 32 bits of the term, returns the lower 16 bits.

Other

( Left parenthesis Performs the operation in () before the operation outside (

)

Right parenthesis

)

"and ') are always used in pairs.

Rules of operation

Operations are performed according to the priority of the operators.
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Table A-5 Operator Priority

Priority Operators
1 Higher | (,)
2 + sign, - sign, NOT, , HIGH, LOW, HIGHW, LOWW
3 *,1,, MOD, %, SHR, >>, SHL, <<
4 +, -
5 AND, &
6 Lower OR, |, XOR, »

If the priorities of the operators are the same, the operation is performed from the left toward the

right.

Performs the operation in () before the operation outside ().

Each term in an operation is treated as unsigned 32-bit data.

All operation results are treated as unsigned 32-bit data.

If an overflow occurs during operation, the lower 32 bits are valid, and the overflow is not detected.

Terms

To describe a constant for a term, the following numeric values can be described.

Table A-6 Range of Radixes

Radix

Range

Binary number

0Y <=value <= 1111111111111111111111111111111Y (32 digits)

Octal number

00 <=value <= 377777777770

Decimal number

-2147483648 <= value <= 4294967295
(A negative decimal number is internally converted into a 2's
complement.)

Hexadecimal numbers

OH <= value <= OFFFFFFFH

User's Manual U16217EJ1VOUM

377



APPENDIX B TERMINOLOGY

The major terms used throughout this manual are as follows:

Current window

Delimiter (separator)
* Program

* File

* Function

e Structure

« Stack frame number

e Line

B.1 Terminology

Current window
The current window is the window you are now in and operating by means of key input and menu

selection.

Delimiter (separator)
The following separators can be used as the delimiter of file names, function names, variable names,

and line numbers.

Table B-1 Delimiter

Delimiter Meaning
# Used as a separator of file names, variable names, function names, and line
numbers.
$ Used as a separator of load module names, file names, variable names, and
function names.

Program
A program is the execution unit to be debugged. The debugger manages each one of the load module
files specified on downloading as a program.
To specify a program name, use a load module file name on downloading.
Current program
The current program is the program that contains the instruction currently breaking execution
(instruction indicated by the PC).

When specifying a file in the current program, the program name may be omitted.

File
Up to 127 characters can be handled in a file name with path.

Depending on the type of file, however, a file name of more than 127 characters can be specified.
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Current file
The current file is the source file that contains the instruction currently breaking execution (instruction
indicated by the program counter (PC)).

When specifying a line or function in the current file, the file name may be omitted.

Function
Indicates the functions constituting a C source program.
Current function
The current function is the function that contains the instruction currently breaking execution
(instruction indicated by the program counter (PC)).

When accessing a local variable in the current function, specifying the function name may be omitted.

Structure
Structures and unions in C language are called structures.

The name structure is used if a structure or union variable is used without members explicitly specified.

Stack frame number

The stack frame number is a decimal integer starting from 1 and is assigned to the stack contents.
The shallower the nesting level of the stack, the higher the number. A function having a stack number

one less than that of a certain function is the function that calls the certain function.

Line
A line is specified in order to identify one line in the source file.

Specify a line number as an integer constant, starting from 1.
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This appendix explains messages displayed in the Error/Warning dialog box of the debugger.

C.1  Error/Warning Messages from

C. 1. 1 Display format of
Messages are generated and output to the Error/Warning dialog box when "information that should be
informed to users (fatal error, syntax error, and warning or questions)" is detected while the debugger is
executing processing.

The product name is displayed on the title bar of the dialog box.

Figure C-1 Error/Warning Messages

10850 |

& F3005: Illegal condition.

There are three types of messages in the debugger (fatal error message, syntax error message, and

warning message or question message).

A : Fatal error messages
When a fatal error is detected in the debugger, a message is output to the Error dialog box

before aborting the processing and terminating the debugger.

F : Syntax error messages
When a syntax error is detected in the debugger, a message is output to the Error dialog box

before aborting the processing. At this time, opened windows and dialog boxes are closed.

W : Warning message or gquestion message
When a warning or question is detected in the debugger, a message is output to the Warning

dialog box before aborting the processing.

C. 1. 2 Fatal error messages
A list of the messages that are output when fatal errors are detected while the debugger is executing
processing is shown below in numerical order.

A0101: Can not find initialization file (expc.ini).

A0102: Host name not found.
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A0105:

1) Necessary files may be damaged. Reinstall the device file.

A0106:

Failed in reading device file (d3xxx.800).

lllegal data received.

1) Check the power of the in-circuit emulator, cable connections, and setting of the interface board and

restart the debugger.

A01a0:

No response from the evachip. Please confirm the signal of the CLOCK or RESET, WAIT,

HLDRQ and so on.

1) Check the power of the in-circuit emulator, cable connections, and setting of the interface board and

restart the debugger.

AOlal:

AOla2:

AOla3:

AOla4:

AO0la5:

AO0la6:

AO01a8:

AO4al:

A0600:

1) There is not enough system memory. Close the applications being executed and the open files.

A1000:

A1001:

A1002:

A1005:

A1007:

Failed in reading ie703000.ie.

Break board is not connected.

Emulation board is not connected.

Board configuration of ICE is not consistent.

POD/EM1 board is not connected.

Executor is running.

Failed in reading initialization file (expc.ini).

Not enough memory for emulation.

Not enough memory for buffer.

Failed in initializing ICE.

No entry exists for specified number.

Can not relocate internal RAM.

lllegal relocation address.

Not enough memory on ICE.
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A1008: Not enough memory for tables.

1) There is not enough system memory. Close the applications being executed and the open files.

A1009: Already initialized.

Al1l00a: Not initialized.

A1015: Programmable-IOR does not exist.

A10ff: Can not communicate with ICE.

Aldbe:  Error occurred inside debugger.

A2001: lllegal address.

A2009: Device file is damaged or error is in file.

A200b: Can not copy.

A200c:  Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

A20ff: Can not communicate with ICE.

A2222: lllegal condition.

A3012: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

A30ff: Can not communicate with ICE.

A4011: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

A4018: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

A5000: lllegal device file type.

A5001: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.
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A5002: Can not open device file.

A5003: Reading of device file went wrong.

A5004: Can not close device file.

A5005: lllegal device file format.

1) Necessary files may be damaged. Reinstall the device file.

A5006: Failed in initializing ICE.

A5007: Device file has broken or error is in a file.

A500c: Failed in reading expc.ini.

A500d: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

A5300: lllegal device file type.

A5301: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

A5302: Can not open database file.

1) Necessary files may be damaged. Reinstall the debugger and device file.

A5303: Reading of database file went wrong.

A5304: Can not close database file.

A5305: lllegal database file format.

1) Necessary files may be damaged. Reinstall the debugger or simulator, and device file.

A5306: Database information has been already initialized.

A5307: Database information does not exist.

A7012: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.
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A70fe:  Bus hold error.

1) CPUis in the bus-hold status. Reset the debugger.

AT70ff: Can not communicate with ICE.

A7f03:  Failed in canceling RUN/STEP.

A9000: Specified register symbol does not exist.

A9001: Specified register symbol ID does not exist.

A9003: lllegal condition.

A9004: Too large register size.

Aa005: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

AaOOb: Can not close file.

Aa00c: Failed in reading file.

1) The file is damaged or does not exist. Recreate the file.

Aa010: Can not communicate with ICE.

Aa013: Reading of file went wrong.

Ab009: Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

Ab00d: Current function does not exist.

AbOOe: Current line does not exist.

Ab0Of:  Tag not found.

Ab010: Failed in loading symbol table.

Ab011: lllegal line number.

Ab015: Reading of file went wrong.
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1) The file is damaged or does not exist. Recreate the file.

Ab016:

1) The file is damaged or does not exist. Recreate the file.

Ab017:

1) The file is damaged or does not exist. Recreate the file.

Ab019:

AbOla:

AbOlc:

Ab023:

Ab024:

AbO2a:

Ab030:

Can not open file.

Failed in writing file.

Reading of file went wrong.

Can not close file.

Too many entries of the task kind .

Current stack frame is not active.

Different section.

Can not communicate with ICE.

Monitor timed out.

1) Check the power of the in-circuit emulator, cable connections, and setting of the interface board and

restart the debugger.

Ab031:

Ab032:

Ab033:

Ab039:

AbO3a:

AbO41:

Ac002:

Ac003:

1) The file is damaged or does not exist. Recreate the file.

Already set in memory.

Out of scope.

LP is not stored.

Failed in loading debug information.

No more section information.

Specified file is not load module.

Can not close file.

Reading of file went wrong.
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Ac004:

Ac009:

Reading of file went wrong.

Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

Ac010:

AdO000:

Ad001:

Can not communicate with ICE.

Error occurred inside debugger.

Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

Ad002:

Ad003:

Ae008:

Failed in reading initialization file (expc.ini).

ICE is not connected.

Not enough memory

1) There is not enough system memory. Close the applications being executed and the open files.

Af000:

Not enough memory.

1) There is not enough system memory. Close the applications being executed and the open files.

C. 1. 3 Syntax error messages

386

A list of the messages that are output when syntax errors are detected while the debugger is executing

processing is shown below in numerical order.

F0002:

F0100:

F0103:

F0104:

F0200:

This feature is not supported.

Can not communicate with ICE. Please confirm the installation of the device driver for the PC

interface board.

Data transfer to ICE is timed out. Please confirm the power of ICE, connection of the interface

cable, or I/O address of the PC interface board.

Data receive from ICE is timed out. Please confirm the power of ICE, connection of the

interface cable, or I1/0O address of the PC interface board.

No mapped address was accessed.
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1) External memory could not be accessed, as it is not set. Change the register values necessary for
accessing the external memory using the IOR window or Hook Procedure before download (Refer to

"Changing the register values necessary for accessing the external memory").

F02a0: Bus hold error.
1) CPU s in the bus-hold status. Reset the debugger.

F02a2: Can not compulsory break.

F02d2: Not enough memory for trace-buffer.

FO0300: User program is running.

F0301: User program is being breaked.

F0302: User program is being traced.

F0303: Not traced.

F0304: Trace memory is not set.

FO0306: No trace block exists.

F0307: No event condition exists.

FO0308: No timer measurement is done.

FO0309: No trigger frame exists.

FO030a: Tracer is being stopped.

FO30b: Specified snap-event has not been registered.

FO030c: Specified stub-event has not been registered.

FO030d: Timer is running.

FO030e: Memory copy area is overlapped.

FO30f:  Trace has been already set.
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F0310: Event condition is not set.

F0311: Too many valid timer event conditions.

F0312: Specified timer event is not set.

F0313: illegal map range.

1) Check the setting in "Memory Mapping (mapping setting area)" in the Configuration dialog box.

When mapping to external memory has been performed, change the register values necessary for

accessing the external memory using the IOR window or Hook Procedure before download (Refer to

"Changing the register values necessary for accessing the external memory").

F0315: Delay trigger cannot set with trace full mode.

FO03al: Step execution is being done.

FO03a2: Timer and Tracer are running.

F03d0: Back-trace is being executed.

FO03d1l: Back-trace is being stopped.

F03d2: Back-trace execution point overrun oldest frame.

FO03d3: Register status or Memory status cannot be set up other than Phasel of event link.

FO03d4: No back-trace information exists.

FO03d5: Last command can not be backstepped.

F0400: lllegal condition.

1) Settings of the used in-circuit emulator and those of the Configuration dialog box may not match.

Check the Chip selection of "Chip (Emulation CPU selection area)".

F0401: Result of timer measurement overflowed.

F0402: Too many event conditions with path count.

F0403: Too many address range conditions.

F0404: Too many simultaneously-usable-event conditions.
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FO0405: Too many snap-events.

F0406: Too many stub-events.

F0407: Too many initialization data.

F0408: Too large search data (> 16 byte).

F0409: Too large search data (> search range).

FO040a: Too many Linking-event conditions.

FO04a0: Too many software breaks (> 100).

FO04a2: Too many partition of bus size.

FO04a3: Too many execution-event conditions.

FO4a4: Too many bus-event conditions.

FOb61: Section Trace event conditions overflow.

FOc00: Monitor file read error.

1) Necessary files may be damaged. Reinstall the debugger.

FOc20: Guarded area can not be accessed.

FOc40: Status of effective event conditions cannot be changed.

FOc41l: Coverage testis being executed.

FOc60: Event before execution cannot be set up other than break conditions.

FOc61l: Can not register event numbers which can not be used for hardware break.

FOc62: Event numbers reserved for hardware breaks can not be used.

FOca0: Can not communicate with ICE. Please confirm the power of ICE, connection of the interface

cable, or I/O address of the PC interface board.
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FOcal: Monitor file not found.

1) Necessary files may be damaged. Reinstall the debugger.

F1003: lllegal relocation address.

F1004: lllegal condition

F1006: lllegal address.

F100b:  User program is running.

F100c: Different bus size has been already specified.

F100d: Too large bus size.

F100e: Too large bus partition size.

F100f:  Targetis not turned on.

F1010: lllegal map range.

F1011: Failed in setting internal ROM and RAM.

F1012: This feature is not supported.

F1013: No terminal name.

F1016: Programmable-IOR does not movable.

1) Necessary files may be damaged. Reinstall the latest device file.

F2000: lllegal I/O register name.

F2002: User program is running.

F2003: lllegal I/O register number.

F2004: lllegal bit number.

F2006: Hidden I/O register was specified.

F2007: 1/O register of ban read/write was specified.
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F2008: 1/O register not existing was specified.

F200a: lllegal value specified for I/O register.

F3000: No mapped address was accessed.

1) The allocation addresses of the program and the addresses of the debugger may not match.

Set the mapping to the external memory in "Memory Mapping (mapping setting area)" in the

Configuration dialog box according to the allocation addresses specified in the link directive file on

compilation. When mapping to external memory has been executed, change the register values

necessary for accessing the external memory using the IOR windowor Hook Procedure before

download (Refer to "Changing the register values necessary for accessing the external memory").

F3001: Memory has different value.

F3002: lllegal start address.

F3003: lllegal end address

F3004: lllegal start address and end address.

F3005: lllegal condition.

F3006: User program is running.

F3007: Verification error.

F3008: No condition specified.

F3009: Parameter size does not align with access size alignment.

F300a: Specified address does not align with access size alignment.

F300b: Source address does not align with access size alignment.

F300c: Destination address does not align with access size alignment.

F300d: lllegal end address.

F300e: Different access size in specified area.
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F300f: Different access size both in source and destination areas.

F3010: Different access size in destination area.

F3011: Different access size, source & destination.

F3013: Failed in writing DMM.

F3014: Oveflowed mapping area.

F3015: Processing was interrupted.

F3016: This feature is not supported.

F4000: Can not delete specified event.
1) The specified event cannot be deleted as it is being used under another condition. Invalidate it for

other usages before deleting.

F4001: lllegal table number.

F4002: lllegal start address.

F4003: lllegal end address.

F4004: lllegal status.

F4005: lllegal data.

F4006: Specified event number has been already used.

F4007: Too many same events are registered.

F4008: Specified event has not been registered.

F4009: lllegal data size.

F400a: lllegal mode.

F400b: Setting value is inaccurate.

F400c: Event link conditions cannot be used for section trace conditions.
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F400d:

F400e:

F400f:

F4010:

F4012:

F4014:

F4015:

F4016:

F4017:

F4019:

F401a:

F401b:

F401d:

F401e:

F401f:

F4020:

F4021:

F4022:

F4023:

F4024:

Too many identical events are registered (>= 32767).

Specified event condition does not exist.

lllegal event link condition.

Function not found.

Timer is being disabled.

Can not use software break.

Can not use event condition specifying address range.

Can not change event condition.

Can not access word at odd address.

This feature is not supported.

No Event.

Can not use tag-event.

Start event and end event of timer are not made to the same setup.

Too many trace-events.

Path count cannot be set up.

Address range cannot be set up in event before execution.

Event conditions number overflow.

Software DMM conditions number overflow.

Real-time call conditions number overflow.

Software break call conditions number overflow.
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F4318: lllegal memory bank setting.

F5008: Can not open device file.

1) Necessary files may be damaged. Reinstall the device file.

F5009: Can not open ie703000.ie.

F500a: Specified device file is illegal version.

1) Necessary files may be damaged. Reinstall the device file.

F5308: Can not open specified database file.

1) Necessary files may be damaged. Reinstall debugger or simulator.

F5309: Specified database file is illegal version.

1) Necessary files may be damaged. Reinstall the debugger or simulator, and the device file.

F6000: Current function does not exist.

F6001: lllegal symbol name.

F6002: lllegal condition.

F6003: lllegal function name.

F6004: Overflowed output buffer size.

F6005: lllegal expression.

F7000: lllegal mode.

F7001: User program is running.

F7002: User program has been stopped.

F7003: Trace enabled.

F7004: Trace memory is not set.

F7005: Function return address does not exist, can not do step execution.

F7801: End waiting state of step execution was canceled.
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F7802:

F7f00:

F7f02:

F7f04:

F7f05:

F8000:

F8001:

F8002:

F8003:

F8004:

F9002:

F9005:

Fa001:

Fa002:

Fa003:

Fa004:

Fa006:

Fa007:

Fa008:

Fa009:

End waiting state of step execution was canceled.

Aborted step execution.

Suspended step execution.

Can not execute non-mapped area.

This feature is not supported.

Specified file was not found.

lllegal line number.

Current information is not set.

lllegal address.

This feature is not supported.

lllegal value.

This feature is not supported.

lllegal expression.

Start address is bigger than the end address.

lllegal source path.

Too long expression.

lllegal argument.

lllegal program number.

Source path is not set.

File not found.

User's Manual U16217EJ1VOUM

395



APPENDIX C MESSAGES

FaOOa: Can not open file.

1) The file is damaged or does not exist. Recreate the file.

Fa00d: Not source file of load module.

Fa0Oe: lllegal line number.

FaO0o0f: Variable does not exist.

Fa0l1l: Can not access register.

Fa012: Can not access memory.

Fa014: It was going to open the binary file.

Fa015: Can not get temporary path.

1) Thediskis full. Delete or move unnecessary files and increase the available memory in the disk.

Fa016: Can not create temporary file.

1) Thediskis full. Delete or move unnecessary files and increase the available memory in the disk.

Fa0l17: Can not remove temporary file.

Fa020: This feature is not supported.

Fa021: Symbol assigned to register cannot be specified.

Fb000: lllegal command line.

Fb001l: Program information does not exist in specified load module file.

Fb002: File not found.

Fb003: Function not found.

Fb004: Selected load module different from kind(Chip) was loaded.

Fb005:  Symbol not found.

1) The address could not be found. Specify a location holding address information.

Fb008: lllegal expression.
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Fb0Oa: lllegal symbol in load module file.

FbOOb:  Current program does not exist.

Fb0Oc: Current file does not exist.

Fb012: Too large line number.

FbOlb: Too long load module file name.

Fb01d: Address not found.

FbO1f: Can not find structure member.

Fb020: Can not find value.

Fb021: No debug information exists in load module file.

1) To create a load module with appended debug information, execute build in build mode of Debug

Build.

Fb022: lllegal line number.

Fb026: Too many array dimensions (> 4).

Fb027: Found end of file.

1) The specified file may be damaged. Recreate the file.

Fb028: This feature is not supported.

Fb029: lllegal address.

Fb02b: Can not stack trace with current PC value.

Fb02c: Too many blocks for one function.

Fb02d: lllegal argument.

Fb02e: The file does not exist in the SOURCE PATH.

1) On stopping the program, the source that the debugger tried to display could not be found. Check if

the path connects to the source (using "Source Path (source path specification area)" in the
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Debugger Option dialog box), or check if the source is in the same directory as the out file. Refer to

the Assemble window on which the error message is displayed, and check if the corresponding path

connects.

Fb0O2f:  Information has been deleted because of optimization.

Fb034: Return execution from present PC position cannot be performed.

Fb037: Too Many Line-Numbers Information.

Fb038: Compiler version mismatch.

1) Recreate the load module with the latest compiler.

Fb040: Specified file is not load module.

1) Thisis not a linker output file. Source debug cannot be executed with the load module before output

from the linker. Specify the load module output from the linker.

Fb32e: lllegal port number.

Fb32f:  lllegal port name.

Fb330: lllegal port position.

Fb331: lllegal increment number.

Fb332: Port for memory bank is not set.

Fb333: lllegal bank number.

Fb334: Areafor memory bank is not set.

Fc001: Can not open file.

1) The file is damaged or does not exist. Recreate the file.

Fc005: lllegal file type.

Fc006: Kind(Chip) of load module is illegal.

Fc007: Specified file is not load module.

1) Thisis not a linker output file. Source debug cannot be executed with the load module before output

from the linker. Specify the load module output from the linker.
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Fc008: Specified load module file (ELF) is old version.

FcOOa: No mapped address was accessed.

FcOOb: Load module is not loaded.

Fc00c: lllegal argument.

Fc00d: User program is running.

FcO00e: User program is being traced.

FcOO0f:  Interrupted.

Fc011: lllegal load module file format.

Fc012: Check sum error.

Fc013: Too wide address range to upload (> 1M byte).

Fc014: Failed in writing file.

1) The file is damaged or does not exist. Recreate the file.

Fc015: lllegal program number.

Fc016: Load information is full.

Fc018: Specified file is not load module.

1) Thisis not a linker output file. Source debug cannot be executed with the load module before output

from the linker. Specify the load module output from the linker.

Fc019: Failed in writing memory.

FcOlb: Programmable-IOR address not specified.

1) Necessary files may be damaged. Reinstall debugger or simulator.

Fc100: This feature is not supported.

Fd004: Can not find Dynamic Link Library.
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Fe000: lllegal argument.

Fe001: lllegal start address.

Fe002: lllegal end address.

Fe003: Too large size.

Fe004: Can not open file.

1) The file is damaged or does not exist. Recreate the file.

Fe005: Failed in reading file.

1) The file is damaged or does not exist. Recreate the file.

Fe006: Reading of file went wrong.

Fe007: Failed in writing file.

1) The file is damaged or does not exist. Recreate the file.

Fe009: lllegal file format.

FeOOa: Verification error.

Fe010: This feature is not supported.

Ff001l:  [XXX] not found.

Ff004:  Missing parameter.

Ff005: lllegal function name.

Ff006: lllegal number.

Ff007:  Start address is bigger than end address.

Ff008:  lllegal symbol or expression.

Ff009:  [XXX] This file is illegal type.

Ff100: Disk cannot write or full.
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Ff101:

Ff102:

Ff103:

Ff104:

Ff105:

Ff201:

Ff202:

File not found.

File not Create.

Old project file version.|

lllegal project file format.

This file is a project file for [XXX].Please select a correct file.

Memory mapping error.

Verify error.

1) External memory could not be accessed, as it is not set. Change the register values necessary for

accessing the external memory using the IOR window or Hook Procedure before download (Refer to

"Changing the register values necessary for accessing the external memory").

Ff301:

Ff306:

Ff307:

Ff308:

Ff309:

Ff30a:

Ff30b:

Ff30c:

Ff30d:

Ff30e:

Ff310:

Ff312:

The symbol being used on the event condition can't be evaluated.

This name is too long.

There is the same name in other kinds.

An address can't be omitted.

lllegal address mask.

lllegal data mask.

lllegal ext probe mask.

lllegal ext probe data.

lllegal pass count.

lllegal register name.

Illegal delay count.

[XXX] is already there.
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Ff313:  Event number already exist.

Ff314: Event name is not set.

Ff315: [XXX] is already there.

Ff316: Max number of enabled [XXX] event is over. Please disable other enabled [YYY] event.

Ff317: Max number of set event is over.

Ff3le: lllegal start address.

Ff31f: lllegal end address.

Ff350:  There is a phase which event are not in the middle.

Ff351: The same event is contained in Link and Disable.

Ff352:  An eventisn't specified.

Ff400:  Coverage mapping error.

Ff500:  lllegal symbol.

Ff501: lllegal value.

Ff502:  lllegal parameter.

Ff503:  Max number of symbol is over.

Ff504: This variable cannot be set as a break.

1) Break cannot be set for the following variables.

* Local variables, static variables
« Array variables, member variables of structures/unions
« Register/peripheral IOR

« Variable expressions

Ff802:  All events are deleted. because the use of external probe was changed.

Ff803:  This event address is invalid on current configuration.
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Ff804: Invalid PC value.

Ff805:  Cannot set temporary break on this address.

Ff806: External data is being used by Debugger.

Ff900: lllegal I/O port name.

Ff901:  Memory mapping error.
1) The specification of the address is illegal. The addresses that can be specified are in either the
Target area or IOR area. Check in "Address: (I/O port address specification area)" in theAdd 1/0

Port dialog box.

Ff902: lllegal access size.

Ff903: lllegal access type.

Ff904: There is the same name.

Ffa00:  The [XXX] function of current program on PC position not found.
1) The symbol specified in main() label: in "Startup Routine (start-up symbol setting area)" in the
Debugger Option dialog box could be found. Set a symbol of the main routine of the program.

Default is _main.

Ffa0l:  The line information on PC position not found.
1) The source file corresponding to program counter (PC) value when the program was stopped could
not be found. The following reasons are possible.

1 The source file exists in a location that the source path does not connect to.
2 The program stopped where the source files, such as library or RX, do not exist.

3 The program looped, jumped to an address that is not used by the program, and stopped there.

Ffc00: Help window cannot be started. Please install HTML Help environment with reference to a

users manual.

Ffff: Interrupted.

C. 1. 4 Warning message or question message
A list of the messages that are output when warnings or questions are detected while the debugger is

executing processing is shown below in numerical order.
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WO03a0:

W1014:

W2005:

W200d:

W4013:

W401c:

W500b:

W7010:

W7011:

WhbO01le:

Wb036:

Wb042:

Whb335:

Wc017:

WcO0la:

WcO1c:

Target is not turned on.

Data is not exist.

1/0 register of Read Protect attribute was specified.

No initialize data for SFR.

Access size is different from its mapped bus size.

Software break can not be set on this area.

Specified device file does not relocate IRAM.

No source information exists.

Unknown result of step execution.

No debug information (not compiled in Debug Build mode).

Out of variable region.

Symbol module is not initialized.

Too long symbol name.

Symbol information is duplicated, please reset symbols.

No mapped address was accessed.

Programmable IOR address mismatch.

1) Necessary files may be damaged. Reinstall the debugger or simulator.

Wc01d:

Wf002:

Wf003:

404

Selected load module different from kind(Chip) was loaded.

Not found [XXX]. Search from the beginning?

Already exceed search region.
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Wf106:

Wf107:

Wf108:

Wf109:

Wf200:

Wf203:

Wif300:

Wf302:

Wif303:

Wif304:

Wf305:

Wi311:

Wif325:

Wf326:

Wf401.:

Wf600:

Wf601:

CPU in the Project File was Changed. You must exit the debugger for the new CPU. Do you
exit the Debugger?

CPU in the Project File was Changed. Do you start the Debugger with this CPU?

Selected project file different [YYY] from chip [XXX] was opened. Does it open, although the

chip cannot be changed?

Project Manager cannot be used with the debugger of this version. Please use PMplus.

No differences encountered.

When a program is running, while rewriting a memory, program execution stops for a moment.

Do you wish to rewrite a memory?

Would you like to save the changes made in [XXX]?

Delete: [XXX]

[XXX] is edited. Delete: [YYY]?

[XXX] is edited. Save: [YYY]?

[XXX] is already exist. Do you replace it?

Only one [XXX] can be enabled. Do you make this [YYY] to enable?

User program is running. Do you want to stop user program for a moment and set it?

User program is running. Do you want to stop user program for a moment and delete it?

Clear coverage?

Save project file?

When connecting the target system, please turn on the target system.

1) When atarget is not connected, simply click the <OK> button.

Wf602:

Wf700:

Please change a MODE mask condition or connect the target system.

Do you want to download Load Module File?
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Wf905: [XXX] is already exist. Do you replace it?

Wf906: Would you like to register the change made in [XXX]?

Wfb00: User program is running. Do you want to stop user program?
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Debugging can be efficiently executed by using special function keys.

Note that, in the following explanation, ordinary key representation (generic key representation) is used

because the key representation differs depending on the type of keyboard.

Table D-1 through Table D-8 list the functions of the respective keys.

Function List of Special Function Keys

Table D-1 Function List of Special Function Keys

Key

Function

BackSpace

Deletes one character before the cursor and moves the cursor to the position of
the deleted character.
At this time, the character string following the cursor moves forward.

Delete

Deletes one character after the cursor and move the character string following the
cursor forward.

Deletes a various event condition selected in the Event Manager or each event
dialog box.

Deletes the data selected in the Watch window.

Insert

Alternately selects the insert mode and overwrite mode in the Source window and
Assemble window. However, this key is invalid in the Memory, Register, and IOR
windows, and only the overwrite mode can be used as an input mode.

PrintScreen

Loads the entire display screen to the clipboard as a bitmap image (function of
Windows).

Esc Closes the pull-down menu.
Closes the modal dialog box.
Restores the input data.

Alt Moves the cursor to the menu bar.

End Moves the cursor to the end of the line.

Home Moves the cursor to the beginning of the line.

PageUp Scrolls the screen one screen up. The cursor also moves up to the top of the
screen.

PageDown Scrolls the screen one screen down. The cursor also moves up to the top of the
screen.

Space Inserts one blank character.

Tab Moves the cursor to the next item.

Up arrow key

Moves the cursor up.
If the cursor is at the bottom of the screen, scrolls the screen up one line at a time.

Down arrow key

Moves the cursor down.
If the cursor is at the top of the screen, scrolls the screen down one line at a time.

Right arrow key

Moves the cursor to the left.
If the cursor is at the leftmost position on the screen, scrolls the screen one column
to the right.

User's Manual U16217EJ1VOUM 407




APPENDIX D KEY FUNCTION LIST

Table D-1 Function List of Special Function Keys

Key

Function

Left arrow key

Moves the cursor to the right.
If the cursor is at the rightmost position on the screen, scrolls the screen one
column to the left.

Enter

Sets the input data.
Presses the default push button.

D.2 Function List of Function Keys

Table D-2 Function List of Function Keys

Key Function

F1 Opens the Help window.

F2 Forcibly stops program execution.
Same function as [Run] -> [Stop] on the menu bar.

F3 Resets the emulation CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.

F4 Resets the emulation CPU and executes the program.
Same function as [Run] -> [Restart] on the menu bar.

F5 Executes the program.
Same function as [Run] -> [Go] on the menu bar.

F6 Executes the program to the cursor position in the Source or Assemble window.
Same function as [Run] -> [Come Here] on the menu bar

F7 The user program is real-time executed until execution returns.
Same function as [Run] -> [Return Out] on the menu bar

F8 Step execution.
Same function as [Run] -> [Step In] on the menu bar.

F9 Sets a breakpoint at cursor position in Source or Assemble window.
Same function as [Run] -> [Break Point] on the menu bar.

F10 Next step execution.
Same function as [Run] -> [Next Over] on the menu bar.

F11 Sets or deletes a software breakpoint.

Same function as [Run] -> [Software Break Point] on the menu bar.

D. 3 Function List of Special Function Keys (Shift + key)

408

Table D-3 Function List of Special Function Keys (Shift + key)

Key Function
End Expands the selection range to the end of the line.
Home Expands the selection range to the beginning of the line.

Left arrow key

Expands the selection range one character to the left.
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Table D-3 Function List of Special Function Keys (Shift + key)

Key Function

Right arrow key | Expands the selection range one character to the right.

D.4 Function List of Function Keys (Shift + key)

Table D-4 Function List of Function Keys (Shift + key)

Key Function

F6 Executes the program from the cursor position in the Source or Assemble window.
Same function as [Run] -> [Start From Here] on the menu bar.

F9 Resets the emulation CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.

D.5 List of Special Function Keys (Ctrl + key)

Table D-5 List of Special Function Keys (Ctrl + key)

Key Function

End Displays the last line.
The cursor will also move to the last line.

Home Displays the first line.
The cursor will also move to the first line.

Left arrow key Moves the cursor one word to the left.
If the cursor at the leftmost position on the screen, scrolls the screen one column

to the right.

Right arrow key | Moves the cursor one word to the right.
If the cursor at the rightmost position on the screen, scrolls the screen one column

to the left.

D.6 Function List of Function Keys (Ctrl + key)

Table D-6 Function List of Function Keys (Ctrl + key)

Key Function
F5 Ignores break points being set, and executes the program.
Same function as [Run] -> [Ignore break points and Go] on the menu bar.
F9 Sets the address at the cursor position in the Source window or Assemble window
to the PC.

Same function as [Run] -> [Change PC] on the menu bar.
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D. 7 Function List of Control Keys (Ctrl + key)

Table D-7 Function List of Control Keys (Ctrl + key)

Key

Function

Selects all the events registered to the Event Manager.
Same function as [View] -> [Select All Event] on the menu bar in the Event Manager.

Copies a selected character string and saves it to the clipboard buffer.

Disassembles and displays the results from the jump destination address specified by
the data value selected in the current window.Opens the Assemble window.
Same function as [Jump] -> [Assemble] on the menu bar.

Opens the source file displayed in the active Source window with the editor specified
by the PM plus when the PM plus is running.
Same function as [Edit] -> [Edit Source] on the menu bar.

Performs a search.Opens the search dialog box corresponding to the current window.
Same function as [View] -> [Search...] on the menu bar.

Displays the memory contents from the jump destination address specified by the data
value selected in the current window.Opens the Coverage window.
Same function as [Jump] -> [Coverage] on the menu bar.

Moves the display position. Opens the Source Move, Address Move, or Trace Move
dialog box, depending on the current window.
Same function as [View] -> [Move...] on the menu bar.

Displays the memory contents from the jump destination address specified by the data
value selected in the current window. Opens the Memory window.
Same function as [Jump] -> [Memory...] on the menu bar.

Loads a view file, source file, or text file.

Opens the View File Load dialog box. The operation will differ depending on the
extension of the file.

view file: Displays the file in the corresponding window.

Others: Displays the file in the Source window.

Same function as [File] -> [Open...] on the menu bar.

Saves the data displayed in the current window to the view file.
Same function as [View] -> [Save...] on the menu bar.

Displays the corresponding source text and source line, using the data value selected
in the current window as the jump destination address. Opens the Source window.
Same function as [Jump] -> [Source Text] on the menu bar.

Pastes the contents of the clipboard buffer to the text cursor position.

Temporarily displays the contents of the specified data.
Opens the Quick Watch dialog box.
Same function as [View] -> [Quick Watch...] on the menu bar.

Cuts a selected character string and saves it to the clipboard buffer.
Same function as [Edit] -> [Cut...] on the menu bar.
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D.8 List of Special Function Keys (Ctrl + Shift + key)

Table D-8 List of Special Function Keys (Ctrl + Shift + key)

Key Function

Left arrow key Expands the selection range one word to the left.

Right arrow key Expands the selection range one word to the right.
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A

About dialog box -+ 322

Active status --- 50

Add I/O Port dialog box --- 221
Add Watch dialog box --- 194
address --- 327, 335

Address Move dialog box --- 128
All trace ---41

ASCII display --- 167

assemble --- 327, 336
Assemble Search dialog box --- 162
Assemble window --- 156

Auto Load --- 109

Auto load --- 32, 98

Auto save --- 98, 107

B

Balloon watch function --- 44, 144, 188
batch --- 327, 337

Break condition --- 93

Break dialog box --- 288

Break function --- 39

breakpoint --- 327, 338

Breakpoint for read/write access --- 188
Breakpoint setting/deletion function --- 141
Browse dialog box --- 126

Build mode --- 30

C

cache --- 327, 340

Callback procedure --- 330

Change Watch dialog box --- 198
Character set --- 373

Color of character on event mark --- 263
Come function --- 36, 39, 148
Command --- 17, 326

Command line --- 327

Command list --- 327

Command reference --- 327
Compulsion read --- 213, 215
conditional trace --- 41

Configuration dialog box --- 27, 78
Console window --- 326

Contents Saved to Project File --- 105
Coverage measurement function --- 42
Coverage Search dialog box --- 249
Coverage window --- 244
Coverage-Address dialog box --- 254
Coverage-Clear dialog box --- 252
Coverage-Condition Setting dialog box -+ 256
Coverage-Efficiency View dialog box --- 259
Current window --- 378

D
Data display format --- 186
dbgexit --- 327, 342

Debugger Option dialog box --- 95
Debugging environment --- 35
Delay count --- 318

Delay trigger --- 295

Delay trigger trace --- 42
Delimiter --- 378

Device file --- 19

Disable condition --- 285

Display color of breakpoint --- 142
Display files --- 45

Displaying Event Details -+ 265
DMA trace --- 232

download --- 327, 343

Download dialog box --- 117

Drag & drop function --- 150, 151
dummy DMM function --- 169

E

emulation ROM --- 35

Error message -+ 380
Error/warning message --- 380
Event after execution --- 150
Event condition --- 38

Event dialog box --- 273

Event display mark --- 143
Event function --- 37

Event link condition --- 38

Event Link dialog box --- 282
Event Manager --- 261

Exit Debugger dialog box --- 324
Expressions --- 375

Extended Option dialog box --- 90
extwin --- 327, 344

F

Fail-safe break --- 40

Fatal error message -+ 380

File --- 378

finish --- 327, 345

Flow of debugging operations --- 48
Font --- 98

Font dialog box --- 103

Format of file that can be downloaded ---

Format of specifiable file --- 121
Full break --- 42

Full stop --- 42

Function --- 379

G
-g option --- 19
go --- 327, 346
H

hardware break --- 299, 306
help --- 328, 347
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hook --- 328, 348
Hook procedure --- 331
Host machine --- 18

|

I/0 Port --- 213, 221

I/O protect --- 35

ie --- 328, 349

lllegal access break --- 40
In-circuit emulator --- 18
in-circuit emulator --- 18
Information files --- 46
initialized --- 320

Input conventions --- 373
Installing --- 20

Internal RAM --- 34

IOR Select dialog box --- 218
IOR window --- 213

J

JMP [r31] --- 43

jump --- 328, 350

Jump address --- 307
Jump function --- 51, 148

K
Kanji code --- 99
Key function list --- 407

L

Linking window --- 52

Load module list dialog box --- 124
Load/save function --- 45

Local Variable window, --- 201

M
Main window --- 27, 57
map --- 328, 351
mapping function --- 34
Mapping unit --- 86
Marks of Event Icon --- 263
mask --- 84, 237, 278
Mask value --- 279
Maximum number of valid events --- 261
mdi --- 328, 353
memory --- 328, 354
Memory Compare dialog box --- 177
Memory Compare Result dialog box --- 179
Memory Copy dialog box -+ 175
Memory Fill dialog box --- 173
Memory manipulation function --- 44
Memory Search dialog box --- 170
Memory window --- 165
Menu bar --- 60
Messages --- 380
Display format --- 380, 406
Fatal error message --- 380
Syntax error message --- 380, 386

Warning message or question message
--- 380, 403
Mixed display --- 146, 228
mnemonic --- 228
module --- 328, 356

N

next --- 328, 357

Non map break --- 40

Non-mapped area --- 249
Non-real-time execution function --- 36
Non-stop -+ 42

Normal mode --- 274, 283

o

Offset setting --- 119

Online assembly --- 156
Operating environment --- 18
Operating system --- 19
Operators --- 375

P

Pass count --- 285
Pick up --- 243
Pickup display --- 231
PM plus --- 30

Point mark area --- 141, 157
Product ID --- 22

Program --- 378

Program code --- 143, 144
Program counter setting --- 148
Program execution function --- 35
Program register --- 209
Programmable IOR --- 43

Project file --- 35, 98, 324

Project File Load dialog box --- 108
Project File Save dialog box --- 105

Q
Qualify trace --- 42, 296
Quick Watch dialog box --- 190

R

RAM sampling function --- 46
Range of radixes --- 377

Real-time execution --- 36

real-time internal RAM sampling function ---
refresh --- 328, 358

register --- 328, 359

Register manipulation function --- 44
Register Select dialog box --- 211
Register window --- 208

Registering debugger --- 30

reset --- 328, 360

Reset Debugger dialog box --- 320
Right-click menu --- 56

run --- 328, 361

Run-Break event --- 44, 310
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S
Section trace --- 42, 295
Select mode --- 274, 280, 283, 286

Selecting debugger --- 30

Setting event condition in each area ---

Setting files -+ 46
Show offset --- 100
Snap data --- 301

Snap Shot dialog box --- 299
Snapshot function --- 43
software break --- 40
Software Break Manager
Source Move dialog box
Source Path --- 96
Source Search dialog box ---
Source window --- 139
Specification of scope --- 195
Specifying Symbols --- 137
Stack frame --- 205, 379
Start function --- 36, 148
Start-up symbol --- 100
Static status --- 50

Status bar --- 75

step --+ 328, 362

stop --- 328, 363

Structure --- 379

Stub dialog box -+ 306

Stub function --- 43

Symbol To Address dialog box --- 136
Symbols --- 374
Syntax error message
System register --- 209

153

.-+ 380, 386

T
Tab size --- 99

target --- 34

Terminology --- 378

Time measurement function --- 44
Time tag --- 91, 226

Timer event --- 44

Timer Result dialog box ---
Toolbar - 57

Trace condition --- 41
Tracer control mode --- 231
Trace Data Select dialog box ---
Trace dialog box --- 293

Trace function --- 40
Trace memory --- 41
Trace Move dialog box
Trace Search dialog box
Trace window --- 224
Tracer control mode --- 42

316

241

]

Unconditional trace --- 41
Uninstalling --- 25
upload --- 328, 364
Upload dialog box --- 121

414

285

\%

Verify check --- 93
version --- 328, 365
View file --- 45

View File Load dialog box
View File Save dialog box

w

Warning message --- 380

Warning message or question message

--- 380, 403
watch --- 328, 366
Watch function --- 44, 149
Watch symbol setting --- 101

Watch window --- 183
where --- 328, 367
Window lists --- 53

Window reference -+ 53
wish --- 328, 368
Write-protect break --- 40

X

xcoverage -+ 328, 369
xtime --- 329, 370
xtrace --- 329, 371
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