To our customers,

Old Company Name in Catalogs and Other Documents

On April 1%, 2010, NEC Electronics Corporation merged with Renesas Technology
Corporation, and Renesas Electronics Corporation took over all the business of both
companies. Therefore, although the old company name remains in this document, it is a valid
Renesas Electronics document. We appreciate your understanding.

Renesas Electronics website: http://www.renesas.com

April 1%, 2010
Renesas Electronics Corporation

Issued by: Renesas Electronics Corporation (http://www.renesas.com)

Send any inquiries to http://www.renesas.com/inquiry.
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Notice

All information included in this document is current as of the date this document isissued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful atention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

Y ou should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. Y ou are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any lossesincurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. Y ou should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the devel opment of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errorsin or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific”. The recommended applications for each Renesas Electronics product depends on the product’ s quality grade, as
indicated below. Y ou must check the quality grade of each Renesas Electronics product before using it in aparticular
application. You may not use any Renesas Electronics product for any application categorized as “ Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not bein any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as “ Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “ Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home electronic appliances, machine tools; personal electronic equipment; and industrial robots.
“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.
“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or heathcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose adirect threat to human life.
Y ou should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,
especialy with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physica injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as aresult of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sdes office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics’ as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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Keep safety first in your circuit designs!

. Renesas Technology Corp. puts the maximum effort into making semiconductor products better and
more reliable, but there is always the possibility that trouble may occur with them. Trouble with
semiconductors may lead to personal injury, fire or property damage.

Remember to give due consideration to safety when making your circuit designs, with appropriate
measures such as (i) placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or
(iii) prevention against any malfunction or mishap.

Notes regarding these materials

. These materials are intended as a reference to assist our customers in the selection of the Renesas
Technology Corp. product best suited to the customer's application; they do not convey any license
under any intellectual property rights, or any other rights, belonging to Renesas Technology Corp. or
a third party.

. Renesas Technology Corp. assumes no responsibility for any damage, or infringement of any third-
party's rights, originating in the use of any product data, diagrams, charts, programs, algorithms, or
circuit application examples contained in these materials.

. All information contained in these materials, including product data, diagrams, charts, programs and
algorithms represents information on products at the time of publication of these materials, and are
subject to change by Renesas Technology Corp. without notice due to product improvements or
other reasons. It is therefore recommended that customers contact Renesas Technology Corp. or
an authorized Renesas Technology Corp. product distributor for the latest product information
before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.
Renesas Technology Corp. assumes no responsibility for any damage, liability, or other loss rising
from these inaccuracies or errors.

Please also pay attention to information published by Renesas Technology Corp. by various means,
including the Renesas Technology Corp. Semiconductor home page (http://www.renesas.com).

. When using any or all of the information contained in these materials, including product data,
diagrams, charts, programs, and algorithms, please be sure to evaluate all information as a total
system before making a final decision on the applicability of the information and products. Renesas
Technology Corp. assumes no responsibility for any damage, liability or other loss resulting from the
information contained herein.

. Renesas Technology Corp. semiconductors are not designed or manufactured for use in a device or
system that is used under circumstances in which human life is potentially at stake. Please contact
Renesas Technology Corp. or an authorized Renesas Technology Corp. product distributor when
considering the use of a product contained herein for any specific purposes, such as apparatus or
systems for transportation, vehicular, medical, aerospace, nuclear, or undersea repeater use.

. The prior written approval of Renesas Technology Corp. is necessary to reprint or reproduce in
whole or in part these materials.

. If these products or technologies are subject to the Japanese export control restrictions, they must
be exported under a license from the Japanese government and cannot be imported into a country
other than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the
country of destination is prohibited.

. Please contact Renesas Technology Corp. for further details on these materials or the products
contained therein.







IMPORTANT INFORMATION
READ FIRST

* READ thisuser's manual before using thisemulator product.
« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully under stand its mechanism.

Emulator Product:
Throughout this document, the term "emulator product” shall be defined as the following
products produced only by Renesas Technology Corp. excluding all subsidiary products.

e Emulator station

e User system interface cables

e PCinterface board

e Optional SIMM memory module
e Optiona board

The user system or a host computer is not included in this definition.

Purpose of the Emulator Product:

This emulator product is a software and hardware development tool for systems employing the
Renesas microcomputer (hereinafter referred to asthe MCU). This emulator product must only be
used for the above purpose.

Limited Applications:

This emulator product is not authorized for usein MEDICAL, atomic energy, aeronautical or
space technology applications without consent of the appropriate officer of a Renesas sales
company. Such useincludes, but isnot limited to, use in life support systems. Buyers of this
emulator product must notify the relevant Renesas sales offices before planning to use the product
in such applications.

Improvement Policy:

Renesas Technology Corp. (including its subsidiaries, hereafter collectively referred to as
Renesas) pursues a policy of continuing improvement in design, performance, and safety of the
emulator product. Renesas reserves the right to change, wholly or partialy, the specifications,
design, user's manual, and other documentation at any time without notice.

Target User of the Emulator Product:

This emulator product should only be used by those who have carefully read and thoroughly
understood the information and restrictions contained in the user's manual. Do not attempt to use
the emulator product until you fully understand its mechanism.

It is highly recommended that first-time users be instructed by usersthat are well versed in the
operation of the emulator product.
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LIMITED WARRANTY

Renesas warrants its emulator products to be manufactured in
accordance with published specifications and free from defectsin
material and/or workmanship. Renesas, at its option, will repair or
replace any emulator products returned intact to the factory,
transportation charges prepaid, which Renesas, upon inspection,
determine to be defective in material and/or workmanship.

The foregoing shall constitute the sole remedy for any breach of
Renesas warranty. See the Renesas warranty booklet for details on
the warranty period. Thiswarranty extends only to you, the original
Purchaser. It isnot transferable to anyone who subsequently purchases
the emulator product from you. Renesasis not liable for any claim
made by athird party or made by you for athird party.

DISCLAIMER

RENESAS MAKES NO WARRANTIES, EITHER EXPRESS OR
IMPLIED, ORAL OR WRITTEN, EXCEPT AS PROVIDED
HEREIN, INCLUDING WITHOUT LIMITATION THEREOF,
WARRANTIESASTO MARKETABILITY, MERCHANTABILITY,
FITNESS FOR ANY PARTICULAR PURPOSE OR USE, OR
AGAINST INFRINGEMENT OF ANY PATENT. IN NO EVENT
SHALL RENESASBE LIABLE FOR ANY DIRECT, INCIDENTAL
OR CONSEQUENTIAL DAMAGES OF ANY NATURE, OR
LOSSES OR EXPENSES RESULTING FROM ANY DEFECTIVE
EMULATOR PRODUCT, THE USE OF ANY EMULATOR
PRODUCT, OR ITSDOCUMENTATION, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES. EXCEPT AS
EXPRESSLY STATED OTHERWISE IN THISWARRANTY,
THISEMULATOR PRODUCT ISSOLD "ASIS", AND YOU
MUST ASSUME ALL RISK FOR THE USE AND RESULTS
OBTAINED FROM THE EMULATOR PRODUCT.

RENESAS




State Law:

Some states do not allow the exclusion or limitation of implied warranties or liability for
incidental or consequential damages, so the above limitation or exclusion may not apply to you.
Thiswarranty gives you specific legal rights, and you may have other rights which may vary from
State to state.

The Warranty is Void in the Following Cases:

Renesas shall have no liability or legal responsibility for any problems caused by misuse,
abuse, misapplication, neglect, improper handling, installation, repair or modifications of the
emulator product without Renesas' prior written consent or any problems caused by the user
system.

All Rights Reserved:

This user's manual and emulator product are copyrighted and all rights are reserved by
Renesas. No part of this user's manual, all or part, may be reproduced or duplicated in any form,
in hard-copy or machine-readable form, by any means available without Renesas prior written
consent.

Other Important Things to Keep in Mind:

1. Circuitry and other examples described herein are meant merely to indicate the characteristics
and performance of Renesas' semiconductor products. Renesas assumes no responsibility for
any intellectual property claims or other problems that may result from applications based on
the examples described herein.

2. Nolicenseisgranted by implication or otherwise under any patents or other rights of any third
party or Renesas.
Figures:

Some figures in this user's manua may show items different from your actual system.

Limited Anticipation of Danger:

Renesas cannot anticipate every possible circumstance that might involve a potential hazard.
The warnings in this user's manual and on the emulator product are therefore not all inclusive.
Therefore, you must use the emulator product safely at your own risk.

m
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SAFETY PAGE
READ FIRST

* READ thisuser's manual before using this emulator product.

« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully understand its mechanism.

DEFINITION OF SIGNAL WORDS

A This is the safety alert symbol. Itis used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

A DANGER DANGER indicates an imminently hazardous situation which, if not

avoided, will result in death or serious injury.

A WARNING WARNING indicates a potentially hazardous situation which, if not
avoided, could result in death or serious injury.

|A CAUTION | CAUTION indicates a potentially hazardous situation which, if not
avoided, may result in minor or moderate injury.

| CAUTION | CAUTION used without the safety alert symbol indicates a
potentially hazardous situation which, if not avoided, may result
in property damage.

NOT E emphasizes essentia information.
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AWARNING

Observe the precautions listed below. Failure to do so
will result in a FIRE HAZARD and will damage the user
system and the emulator product or will result in
PERSONAL INJURY. The USER PROGRAM will be
LOST.

1. Do not repair or remodel the emulator product by
yourself for electric shock prevention and quality
assurance.

2. Always switch OFF the E6000 emulator and user system
before connecting or disconnecting any CABLES or
PARTS.

3. Always before connecting any CABLES, make sure that
pin 1 on both sides are correctly aligned.

4. Supply power according to the power specifications and
do not apply an incorrect power voltage. Use only the
provided power cable.

RENESAS




CAUTION

This equipment has been tested and found to comply
with the limits for a Class A digital device, pursuant to part 15
of the FCC Rules. These limits are designed to provide
reasonable protection against harmful interference when the
equipment is operated in a commercial environment. This
equipment generates, uses, and can radiate radio frequency
energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio
communications. Operation of this equipment in a residential
area is likely to cause harmful interference in which case the
user will be required to correct the interference at his own
expense.

A
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I ntroduction

The E6000 emulator is an advanced realtime in-circuit emulator, which allows programs to be developed and debugged
for the H8S family microcomputers.

The E6000 emulator can either be used without a user system, for developing and debugging software, or connected viaa
user system interface cable to a user system, for debugging user hardware.

High-performance Embedded Workshop (hereafter referred to as HEW) is a Graphical User Interface intended to ease the
development and debugging of applications written in C/C++ programming language and assembly language for Renesas
microcomputers. Itsaim is to provide a powerful yet intuitive way of accessing, observing and modifying the debugging
platform in which the application is running.

HEW is apowerful development environment for embedded applications targeted at Renesas microcontrollers. The main
features are:

« A configurable build engine that allows you to set-up compiler, assembler and linker options via an easy to use
interface.

« Anintegrated text editor with user customizable syntax coloring to improve code readability.
« A configurable environment to run your own tools.

« Anintegrated debugger which allowsyou to build and debug in the same application.

« Version control support.

HEW has been designed with two key aims; firstly to provide you, the user, with a set of powerful development tools and,
secondly, to unify and present themin away that is easy to use.
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About This Manual

This manual is comprised of two parts: HEW Part and Emulator Debugger Part.

HEW Part: Information on the basic “look and feel” of the HEW and customizing the HEW environment,
and detail of the HEW’ s build function.

Emulator Debugger Part: Preparation before use, EG000 emulator functions, debugging function, tutorial, and hardware
and software specifications of the E6000 emulator.

This manual does not intend to explain how to write C/C++ or assembly language programs, how to use any particular

operating system or how best to tailor code for the individua devices. These issues are left to the respective manuas.

Microsoft®, MS-DOS, Windows®, Windows NT® are registered trademarks of Microsoft Corporation.

Visual SourceSafeis atrademark of Microsoft Corporation.

IBM isaregistered trademark of International Business Machines Corporation.

All brand or product names used in this manual are trademarks or registered trademarks of their respective companies or
organizations.

Document Conventions
This manual uses the following typographic conventions:

Tablel Typographic Conventions

Convention Meaning
[Menu->Menu Option] Bold text with *->" is used to indicate menu options
(for example, [File->Save As...]).
FILENAME.C Uppercase names are used to indicate filenames.
“enter this string” Used to indicate text that must be entered (excluding the “” quotes).
Key + Key Used to indicate required key presses. For example, CTRL+N means

press the CTRL key and then, whilst holding the CTRL key down,
press the N key.

2 When this symbol is used, it is always located in the left hand margin.
It indicates that the text to its immediate right is describing “how to”

(The “how to” symbol) .
do something.

Components

Check all the components described in the component list unpacking. If the components are not complete, contact a
Renesas sdles office.

RENESAS
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1. Overview

The functions for HEW version V.3.01.04 are explained in this manual . This chapter describes the fundamental
concepts of the High-performance Embedded Workshop. It isintended to give users who are new to Windows®
applications, filling in the detailsthat are required by later chapters.

11 Workspaces, Projectsand Files

Just as aword processor allows you to create and modify documents, the High-performance Embedded
Workshop allows you to create and modify workspaces. A workspace can be thought of as a container of
projects and, similarly, a project can be though of as a container of project files. Thus, each workspace contains
one or more projects and each project contains one or more files. Figure 1.1 illustrates this graphically.

WORKSPACE

Figure 1.1: Workspaces, Projectsand Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library a the same time. Projects
can aso be linked hierarchically within aworkspace, which means that when one project is built al of its“child”
projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace and then add
filesto that project before we can actually do anything.
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12 The Main Window

The HEW main window appears as shown in figure 1.2.
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Figure 1.2: HEW Main Window

There are three main windows; the workspace window, the editor window and the output window. The
workspace window shows the projects and files which are currently in the workspace, the editor window
provides file viewing and editing facilities and the output window shows the results of a various processes (e.g.
build, version control commands and so on).

121 TheTitle Bar

Thetitle bar displays the name of current activate project and file. It also contains the standard minimize,
maximize and close buttons. Click the minimize button to minimize the HEW on the Windows® task bar. Click
the maximize button to force HEW to fill the screen. Click the close button to close the HEW (this has the same
effect as selecting [File->EXxit] or pressing AL T+F4).

122 The Menu Bar

The menu bar contains eleven menus: File, Edit, View, Project, Options, Build, Debug, Memory, Tools, Window
and Help. All of the menu options are grouped logically under these headings. For instance, if you wanted to
open afile then the file menu is where you will find the right menu option, if you wanted to set-up atool then the
tools menu is the correct selection. The following sections will cover the functions of the various menu options,
as they become relevant. However, at this stage, it is worth taking a few moments to familiarize yourself with the
options that each menu provides.
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123 The Toolbars

The toolbars provide a shortcut to the options, which you will use the most often. There are ten default toolbars:
Bookmarks, Debug, Debug Run, Editor, Search, Standard, Templates, Version Control, Difference, and Map (as
shown in figure 1.3 to 1.12). Toolbars can be created, modified and removed viathe [Tools->Customize...]
menu option (see chapter 6, “ Customizing the Environment”, for further information).

Mext Bookmark  Previous Bookmark

Toegle Bookmark Glear All Bookmarks

n&a®

Figure 1.3: Bookmarks T oolbar

TCL Toalkit View Disassembly
Command Line Print the Dizazsembly window
Enable/Disable Breakpaint Radix Connect to debug platform

Toegle Breakpoint Dizconnect debug platform

ELIISCEIE Y.

Figure 1.4: Debug Toolbar

Rezet GPU Step Over

Go to Gursor Step Out
Reset Go S5et PG to Gursor
GID Stlep Halt DIEipIa\,-' e
1

ERELEEGEL & OO @ N

Figure 1.5: Debug Run Toolbar

Save File Copy  Match Braces
Open File Save All Cut Paste Ihzert Template

MHew File Frint Toeele Bookmark

DEEG S|4 B@|{Tm

Figure 1.6: Editor Toolbar

Find in Files Find Mext

| Search String Find ‘ Find Previous
| | |

Cay Istring vl Tt

Figure 1.7: Search Toolbar
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Figure 1.8: Standard Toolbar

Template Selection
Define Template Ihzert Template

| |
“r ITempIateD j T ‘

Figure 1.9: Templates Toolbar

Add File (=) Check Out Fileis)
Remove Fileis) Check In File(z)
Get Filets) Show Status

| |
BE &S a @

Figure 1.10: Version Control Toolbar

lgnore white space
Compare files

Fitid rest

Find previous
Find previous difference

Fird next difference
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Figure 1.11: Difference Toolbar

M]ap

\

Figure 1.12: Map Toolbar

RENESAS




When the Standard toolbar or atoolbar is docked, it has a control bar as shown in figure 1.13 (i). If you want to
move the docked Standard toolbar, click and drag its control bar to the new location. Figure 1.13 (i) showsthe
Standard toolbar when it is docked and figure 1.13 (ii) shows the Standard toolbar when it is floating.

s [oetu =] [oebua Sllag o=

i 2 | e =] [Debug =2 |1

Figure 1.13: Standard Toolbar, Docked and Floating

2 Todock atoolbar:

1. Double-click on the title bar of afloating toolbar.

or:

2. Dragthetitle bar of afloating toolbar and draw it toward an edge of a docked window, menu bar, toolbar
or the HEW main frame, on whose edge you would like to dock the window, until the shape of the
floating bar changes.

2 Tofloat atoolbar:

1. Double-click on the control bar of a docked toolbar.

or:

2. Drag the control bar of adocked toolbar and draw it away from the edge of the HEW main frame and
from an edge of the other docked windows, toolbar.

124 The Workspace Window

The “Workspace’ window has three panes. The “Projects’ tab shows the current workspace, projects and files
(figure 1.14). Y ou can quickly open any project file or dependent file by double clicking on its corresponding

icon.

< Workspace _[O] =

Ellﬁ Demo
EI@ Demo
B2 Assembly source file

OB lowllsic
B3 C source file

H dbsctc
Demo.c
intpro.c
lowesic.c
resetprg.c

-[C] Dependencies

Mavigation Tab

Templates Tab

Project Tab ——‘
N @Pmiects IE Templates I QNa\tigaﬁon I

Figure 1.14: Workspace Window Projects Tab
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The “Navigation” tab provides jumpsto various textual constructs within your project’ s files. What is actually

displayed within the navigation tab depends upon what components are currently installed. Figure 1.15 shows

ANSI| C functions. See chapter 2, “Build Basics’, for more information on the “Workspace” window.

The “Templates’ tab displays template settings. See 4.12, “ Templates’, for more information about a template.

- Workspace

I [=] E3
[

4
2] Projects J E] Terplates | “_ Navigation |

Figure 1.15: Workspace Window Navigation Tab

2 Toallow the “Workspace” window or the “ Output” window docking:
Click the right mouse button anywhere inside the “Workspace” window or the “ Output” window. Then a

pop-up menu will be displayed. If [Allow Docking] is checked, docking is allowed; otherwise, docking is not
alowed. Select [Allow Docking] to check or uncheck it.

When [Allow Docking] is checked, you can dock awindow to the edge of the HEW main window or to the edge
of another docked window. Alsoif [Allow Docking] is checked, you can float them “above” the other HEW
windows or outside the HEW main window. Figure 1.16 (i) shows a docked “Workspace” window, and figure
1.16 (ii) shows afloating “Workspace” window.

=l < 'Workspace [_[Ofx
=3 Demo 1= =13 Dema
B m . B
= a Asgzembly source file =123 Assembly source file
& C e [H] lowhdsre
a

dbect.c
Dermo.c:
intprg.c
lowsre.c
resetprg.c
shik.c
vecttbl.c
-[[ Dependencies

i i & Projects IE Templates ] o avigaion I

E| 24 C source file

resetprg.c
shik.c b
2] wecttblc =l

i N @Pm.jem_x IE Templates ] “=_ Mavigation I

Figure 1.16: Workspace Window, Docked and Floating
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When the “Workspace” window or the “ Output” window is docked, it has a control bar as shown in figure 1.17.
If you want to move a docked window, click and drag its control bar to the new location.

'Close' bution

1 |

Figure 1.17: Control Bar of Docking Window

2 To dock the “Workspace” window or the “Output” window:

[Allow Docking] must be checked on the pop-up menu of the window to dock the “Workspace” window or

the “Output” window. (The pop-up menu will be displayed when you click the right mouse button anywhere

inside the window.) Then you have two ways to dock the window.

1. Double-click on the control bar of a floating window.

or:

2. Dragthetitle bar of afloating window and draw it toward an edge of a docked window, menu bar or
toolbar, or the HEW main frame, on whose edge you would like to dock the window, until the shape of
the floating window changes.

2 Tofloat the “Workspace” window or the “Output” window:

[Allow Docking] must be checked on the pop-up menu of the window to float the “Workspace” window or
the “Output” window. (The pop-up menu will be displayed when you click the right mouse button anywhere
inside the window.) Then you have two waysto float the window.

1. Double-click on the control bar of a docking window.
or:

2. Drag the control bar of adocked window and draw it away from the edge of the HEW main frame and
from an edge of the other docked windows, menu bar or toolbar.

2 To hidethe “Workspace” window or the “ Output” window:

Click on the close button, which islocated in the top right corner of the window. Or push the right mouse
button anywhere inside a floating window and select [Hide] on the pop-up menu.

2 Todisplay the “Workspace’ window or the “ Output” window:
Select [View->Workspace] or [View->Output], respectively.

125 The Editor Window

The editor window is where you will work with the files of your project. The HEW allows you to have many
files open at one time, to switch between them, to arrange them and to edit them in whichever order you want to.
By default, the editor window is displayed in a notebook style, where each text file has a separate tab (as shown
in figure 1.18).

The editor contains a gutter on the left-hand side of the window. The standard column allows the user to
configure the position of bookmarks and software breakpoints quickly and easily.

If you are unsure what purpose a column has or what the information it is displaying isif you place the cursor
over the column atool tip is displayed showing itsidentity.
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#include <stddef h:
#include <stdio. h:
#include "sbrk h"

srsoconst size t _sbrk_sizes % Specifies the minimum unit of */
% the defined heap area */

extern char *_slptr;

=tatic union {

long dummy ; <% Dumny for 4-byte boundary *
char heap[HEAPSIZE]: -#* Declaration of the area nanaged *
SE by shrk =*-

theap area
=tatic char #*brk={char *)&heap_ares:-* End address of area a==igned

-

S shrk :Data write

S Eeturn values:Start address of the assigned area (Pasz=s)

SE -1 (Failure)

-

char #sbrk{unsigned long size) <% h=z=igned area size *.

char =p;

if (brk+=sizerheap_area. heap+HEAPSIZE) ~* Enpty area size *®  |w
K1l »

<l esetprgc | < dbscte  wlE shrk.c I

Figure 1.18: Editor Window

The editor window can be customized viathe “Format Views’ dialog box, which can be invoked viathe [T ools-
>Format Views...] menu option. This dialog allows you to configure fonts, colors, tabs and so on for the editor
window. It also alowsthe user to change the look of other views, which have beeninstalled by HEW. If you
would prefer to use your favorite editor rather than the HEW internal editor then specify your aternativein the
“Options’ dialog box, which can be invoked via the [Tools->Option...] menu option. For further details on how
to use and configure the editor, refer to chapter 4, “Using the Editor”.

126 The Output Window

The “Output” window by default hasfour tabs on display. The “Build” tab shows the output from any build
process (e.g. compiler, assembler and so on). If an error is encountered in a source file then the error will be
displayed in the build tab along with the source file name and line number. To quickly locate a problem, double
click on the error to jump to the source file and line.

L=lx

| 4[]\ Build £ Debug },Find in Files /i Version Control f

Figure 1.19: Output Window

The “Debug” tab shows the output from any debugger process. Any debug component that needs to display
information will send its output to this window.
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The“Find in Files’ tab displaysthe results of thelast “Find in Files’ action. To activate find in files, select the
[Edit->Find in Files...] menu option, the toolbar button. For further details on how to use find in files, refer to
chapter 4, “Using the Editor”.

The “Version Control” tab displays the results of version control actions. Thetab isonly displayed if aversion
control system isin use. For further details on version control, refer to chapter 7, “Version Control”.
127 The Status Bar

The status bar displays information asto the current state of the HEW. Figure 1.20 shows the eight sections of
the status bar.

Displays HEW status messages Virtual desktop Read-only status Line rumber Insettion mode Mum Lock
Column number | Caps Lock.
Ready EE [Defaulti deskiop  [Read-write |ezfa7 4 [ms HUM Al

Figure 1.20: StatusBar

13 TheHelp System

The help menu is the rightmost menu on the HEW menu bar. It contains the menu option “ Contents’ which,
when selected, takes you to the main HEW help window.

To obtain help on specific dialogs click on the context sensitive help button, which islocated in the top right-
hand corner of each dialog box (as shown in figure 1.21).

K E:

Context sensitive help button
Cancel butten

Figure 1.21: Help Button

When thisis clicked, the mouse pointer will change to a pointer with a question mark above it. Whilst the mouse
pointer isin this state, click on the part of the dialog box that you require assistance on.

Alternatively, select the control that you require help for and then press the F1 key.
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14 Launching the HEW

To run the HEW, open the “ Start” menu of Windows®, select “Programs’, select “ Renesas High-performance
Embedded Workshop” and then select the shortcut of the HEW. By defaullt, the “Welcome!” dialog box shown
in figure 1.22 will be displayed.

Welcomel EHE
— Dptions:
y {* Create a new project workspace:
Cancel |
" Open a recent project workspace: Administration... |
é IC:\Hew\demo\demn.hws j
=

g " Browse to another project workspace

Figure 1.22; Welcome! Dialog

To create a new workspace, select “Create a new project workspace”, and click “OK”. To open one of recent
project workspaces, select “Open arecent project workspace”, select a workspace from the drop-down list, and
click “OK”. The recent project workspace list digplays the same information as that seen in the workspace most
recently used filelist. Thislist appears on the file menu. To open aworkspace by specifying aworkspace file
(\HWSfile), select “Browse to another project workspace”, and click “OK”. To register atool to or unregister a
tool from the HEW, click the “Administration...” button (see chapter 5, “Tool Administration” for details).
Click the “Cancel” button to use the HEW without opening a workspace.

15 Exiting the HEW

The HEW can be exited by selecting [File->EXxit], pressing AL T+F4 or by selecting the close option from the
system menu. (To open the system menu, click the icon at the upper-left corner of the HEW title bar.) If a
workspace is open then the same workspace closedown procedure is followed as described in the previous
section.

16 Component System Overview

The HEW allows the user to extend the HEW functionality by adding additional componentsto the system. This
is achieved by registering the component in the Tools Administration dialog box. These components can add
windows, menus and toolbars to the HEW system. Examples of the components are the debugger and builder
components of HEW. The debugger component adds all of the menus and toolbars associated with the debugger
and the builder component does the same for the build functionality. The components you have registered in the
system will modify the look and feel of HEW. In some cases you may not have some of the menus which you
can seeinthismanual. For instance if the debugger component is not installed you will not have the “ Debug”
menu in the HEW main window.

10
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2. Build Basics

This chapter explains the genera basic functions of the HEW whilst the more advanced features can be found in
chapter 3, “ Advanced Build Features’.

2.1 The Build Process

The typical build processisoutlined in figure 2.1. This may not be the exact build process, which your
installation of HEW will use as it depends upon the tools that were provided with your installation of HEW (e.g.
you may not have acompiler for instance). In any case, the principles are the same - each step or phase of the
build takes a set of project files and then builds them, if all succeeds then the next step or phase is executed.

k& suio B

L—P>1  COMPILER

Source Files

W

ASSEMBLER
Assembler
Source Files
Project
L» LINKER Object
Files
Library
Files ‘

Load
Module

Figure2.1: Typical Build Process

In the example shown in figure 2.1 the compiler is the first phase, the assembler is the second phase and the
linker isthe third and final phase. During the compiler phase, the C/C++ source files from the project are
compiled in turn, during the assembler phase, the assembler source files are assembled in turn. During the linker
phase all library files and output files from the compiler and assembler phases are linked together to produce the
load module. This module can then be downloaded and used by the debugger functionality in HEW.

The build process can be customized in several ways. For instance, you can add your own phase, disable a phase,
delete phases and so forth. These advanced build issues are | eft to chapter 3, “ Advanced Build Features'. In this
chapter, only the general principles and basic features will be detailed.

11
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2.2 Project Files

In order for the HEW to be able to build your application, you must first tell it, which files should be in the
project, and how each file should be built (figure 2.2).

Add Project Files
Remove Project Files

Debug: ON " |

Optimize: OFF Set Compiler Options

List File: YES c
Source Files

Debug: OFF = T

Optimize: OFF Set Assembler Options

List File: YES Assembler
Source Files

Debug: ON =

Sil ent? YES Set Linker options j‘

Map File: YES Library

Files

Figure 2.2: Editing a Project
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221 Adding Filesto a Project

Before you can build your application you must first inform the High-performance Embedded Workshop, which

filesit is composed of.

2 Toadd afilesto aproject:

1. Select [Project->Add Files...], or click the right mouse button on a project icon in the “Projects’ tab of
the “Workspace” window and select [Add Files...] from the pop-up menu (see figure 2.3), or press INS

when the “Workspace” window is selected.

Zipen dbsck.c

Build dbsct.c

Build Oplions 4

Add Files., .. IMS
Remove Files, .

Exchude Build dbsct.c

Wersion Control r

Configure Yigw...

Show Differences. ..

’T Allovs Dacking
Hide

Properties

Figure 2.3: Projects Tab Pop-up Menu

2. The“Add" dialog will be displayed.
3. Select thefilg(s), that you want to add and then click “Add”.

RENESAS
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There are anumber of other ways to add new filesto the project. These are described below:

¢ Clicking right button on an open file in the editor window displays a pop-up menu option (figure 2.4). If the
fileisaready in the project then the “Add File to Project” menu option isdisabled. Selecting the“Add File
to Project” then adds the file to the current project.

Build File "dbsct.c"

Inskank Watch

uk Chrl+x
Copy Chrl+C
Easte L
Add File To Project 4
Eind... Zhrl+F
Find In Files. .. F4
Replace... Chrl4+H
Goko Line. ., Chrl+E
{1 Match Braces Shift+ckrl+m
Bookmarks 4
Templates 4
Toggle Breakpoint Fa
ﬂ Enatleibisatle Breakpoint s

Define Column Format. ..

Columns 4

Go To Cursor

Set PC Here

Display PC

G0 To Disassembly

Figure 2.4: Editor Window Pop-up Menu

¢ Inthe HEW itisaso possibleto “Drag and Drop” files from Windows® Explorer onto the workspace
window. These fileswill be automatically added to the project and are displayed in the folder in which they
were dragged to.

Note: If you add afileto aproject when it isan unrecognized file type then it will still be added to the project.
Certain functions will be disabled with reference to this file. When thisfile is double clicked in the workspace
window instead of opening the file in the editor the open operation is passed to Windows® operating system.
The default open operation isthen carried out asif the file was opened in Windows® Explorer. To view the
current defined extensions use the “ File Extensions’ dialog (see the section on file extensions later in this
chapter).
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222 Removing Filesfrom a Project
Files can be individually removed from a project, selections of files can be removed or all files can be removed.

2 Toremovefiles from aproject:
1. Select [Project->Remove Files...], or click the right mouse button on a project icon in the “Projects’ tab
of the “Workspace” window and select [Remove Files...] from the pop-up menu (see figure 2.5). The
“Remove Project Files’ dialog will be displayed (figure 2.6).

Open dbsck.c

Build dbsct.c

Build Options 4

#Add Files. ., INS

Remove Files, ..,

Exclude Build dbsck.c

Wersion Control 4

Configure Wiew, ..

Show Differences...

’T Al Docking
Hide:

Properties

Figure 2.5: Projects Tab Pop-up Menu

Remove Project Files

EE
Praject files:
c:\hew' demodemo
-|:;: e’ ] Cancel |
inibgct. o [z vhewh demobdema)
intprg. src [cshessdemohderna] Femave |
resetprg. arc [z vhewh demobdema) —
shrk.c [z hewhdema'dema]
stackect gro [z vhewh demobdema) Remave Al |
vectthbl zro [z hewhdema'dema]

N — i

Figure 2.6: Remove Project Files Dialog
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2. Select the file or files which you want to remove from the “Project files” list.
3. Click the “Remove” button to remove the selected files or click “Remove All” to remove al project files.
4. Click “OK” to remove the files from the project.

2 Toremove selected files from a project:

1. Select thefiles, which you want to remove, in the “ Projects’ tab of the “Workspace” window. Multiple
files can be selected by holding down the SHIFT or CTRL key.

2. Pressthe DEL key. Thefileswill be removed.

223 Excluding a Project File from Build
A filein aproject can be individually excluded from build on a configuration by configuration basis.

2 Toexcludeafilein aproject from build:
1. Push theright mouse button on afile, which you want to be excluded from build, in the “ Projects” tab of
the “Workspace” window.
2. Select [Exclude Build file], where <file> is the selected file, from the pop-up menu (figure 2.5). Then a
red cross will be put on the file’ sicon, and the file will be excluded from build.

224 Including a Project Filein Build
An excluded file can be included in the project again.

2 Toinclude afile which has been excluded from build:

1. Push theright mouse button on afile, which has been excluded from build, on the “ Projects’ tab of the
“Workspace” window.

2. Select [Include Build file ], where <file> is the selected file, from the pop-up menu. Then ared cross will
be removed from the file'sicon, and the file will be included in build.
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2.3 File Extensions and File Groups

The HEW can identify files by their extension. The system defines certain extensions depending upon the tools,
which are being used. For example, if you are using a compiler then the .c extension will be in the “C source
file’ group and be used asinput to the compiler phase (figure 2.1, Typica Build Process). Additionally, the
HEW allows you to define your own extensions. For example, if the project you are developing uses assembler
source files the default extension may be .src. If you would like to use a different extension instead of .src

(e.g. .asm) then you can define a new extension and request that the HEW treatsit in the same way asa.srcfile.

File extensons and file groups can be viewed and modified viathe “File Extensions’ dialog (figure 2.7). Thisis
invoked by selecting [Project->File Extensions...]. Thisdidog displaysall of the extensions and file groups,
which are defined within the current workspace.

Extension | Group - Ok I

D *.abs Absalute file

*.inc Assembly include fils Cancel |

E+iis Assembly list file A
*.src Aszzembly source file ==
[E+n C header fila Remove |
[E]#1st o list file -

*.c C source file Open with...
*.hpp G+ header file

G4+ list file
Cit+ source file

CPU information file

Forandad accambhs sowes -Fil.=.| _ILI
»

Figure 2.7: File Extensions Dialog

The “File Extensions’ list shown in figure 2.7 is divided into two columns. On the left are the file extensions
themselves, whilst on the right are the file groups. Many file extensions can bel ong to the same group. For
example, assembler source files may have several extensionsin asingle project (e.g. .src, .asm, .mar etc) as

shown in figure 2.8.
.SRC .ASM .MAR ‘ .LIB .LPF

Assembler source files C source files Library files

Figure 2.8: File Extensionsand Groups

When creating a new extension you should consider whether the extension belongs to agroup, which is already
defined, or whether you need to create anew file group. If you are adding a completely new type of file then you
will want to create anew file group. This process is described below.
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To create anew file extension in anew file group:

. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed

(figure 2.7).

. Click the“Add..."” button. The “Add File Extension” dialog will be displayed (figure 2.9).
. Enter the extension, which you want to define into the “File extension” field. It is ot necessary to type

thedot ( . ) character. Thedrop list containsall extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

. Select the “Extension belongs to a new group” option and enter a description, which definesthis new file

group.
At this stageit is possible to change the associated application. There are four available choicesin the
“Open” with drop list. These are listed below:

e Editor
« None
e Other

*  Windows default

If the editor is selected, the open file function in the workspace window causes the file to be opened in the
HEW editor. If noneis selected then the open operation is disabled when the open file function is
attempted. Selecting “Other” alows you to configure an another tool for the open file operation. See“To
associate an application with a file group” for more details. If the “Windows default” option is selected
then the open file function in the workspace window passes the open file to the Windows operating
system. Thisthen selectsthe default behavior for thisfile extension as defined in Windows® Explorer.

. Click “OK” to add the extension to the “File Extensions” list.

Add File Extensin 2 x|

— Eile extension: I
Eile extension oK
" Il:-:l "I

— File group:

Cahicel |

{~ Extension belongs to an egisting group:
| &bsolute file =]

' Eutension belongs to a new aroup:
ITth

—Aszociated application:
Open "Text' with;
Windows default ﬂ

Add.
Hodifi.. |
EETE

Bemave
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Figure 2.9: Add File Extension Dialog (New Group)
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If you want to create a new extension because your project uses a different extension from those accepted by the
HEW. For example, a phase might by default use the extension .asm but the HEW only recognizes .src. Then
you need to create a new extension and add it to an existing file group. This process is described below.

°

To create anew file extension in an existing file group:

. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed

. Click the“Add..."” button. The “Add File Extension” dialog will be displayed (figure 2.10).

. Enter the extension, which you want to define into the “File extension” field. It is ot necessary to type
the period ( . ) character. The drop list contains all extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

. Select the “Extension belongs to an existing group” option and select which group you would like to add
this new extension.

. Click “OK” to add the extension to the “ File Extensions’ list.

Add File Extension

— Eile extenzion:

" Iasm vl

Cahicel |

— File group:

¢ Extension belongs to an egisting group:

I.t’-‘-.ssembly zource file

™ Extension belongs to a new aroup:

=

—&zzociated application:

Hpemn group withs

Editar =

Bemave

Add.
Hodifi.. |
EETE

Figure 2.10: Add File Extension Dialog (Existing Group)

In addition to opening a file with the editor, the “ File Extensions” dialog allows you to associate any application
with any file group so that when you double click on afilein the “Projects’ tab of the “Workspace’ then the
appropriate application islaunched with the file. Figure 2.11 shows the association between a word processor
and the extension .DOC.

RENESAS
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File Extensi

Extension | Group AI Ok I

[El*Iep G+ list file

Teadt editer —-@ *.cpp G+t source file Cance| |

D*.cpu CPU information file

Wierd processer — B % doc Documents £dd..
*.exp Expanded assembly source file [ |
Librarian G ik Libeary fil

B Library list file Open with...
*.sct Library =ection list file
*_map Linkage map file
*.fsy Linkage symbal file

Mo applivation —— +.0bj Ohject file

Hlur Drarearazead ( cnres fila b
4 |

Figure 2.11: File Groupsand Applications

2 To associate an application with afile group:
1. Select the file group to be associated from the “ File Extensions’ dialog (figure 2.11).
2. Click the“Open with...” button. The “Modify File Extension” dialog will be displayed (figure 2.12).

Group:

i i
Linkage map file
—Associated application: Cancel |

Open " Linkage map file™ with:

Mane j

Edlitor

Other
Windows default e clify.

Bemuye

Figure 2.12: Modify File Extension Dialog
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3. Select “None’ to remove any association, select “Editor” to open thistype of filein the internal/external
editor or select “Other” if you want to open thistype of file with a specific application.

If you select “Other” then you can select from any previously defined application from the drop-down list
or specify anew application.

Click “Add..."” to define anew application. The “Add Application” dialog will be displayed (figure 2.13).
Enter the name of the tool into the “Name” field. Enter the full path to the tool in the “ Command” field
(do not include any parameters). Enter the parameters that are required to open afilein the “Parameters’
field. Be sure to use the $(FULLFILE) placeholder to specify the location file (see appendix C,
“Placeholders’, for more information on placeholders and their uses). Enter the initia directory, in which
you would like the application to run, into the “Initia directory” field. Click “OK” to create the
application.

Add Application

[ 2] %]

I Cancel

Command [exchuding parameters):

I Ll Browsze. . |

Parameters:
| i3

Initial directan:

I Ll Browse. .. |

Figure2.13: Add Application Dialog
Click “Modify..."” to modify an application. The “Modify Application” dialog will be displayed. This

dialog isthe same asthe “Add Application” dialog described above except that the “Name” field isread
only. Modify the settings as desired and then click “OK”.

4. Click “OK” to set the application for the selected file group.
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24 Specifying How to Build a File

Once you have added the necessary files to the project the next step isto instruct the HEW on how to build each
file. To do this, you will need to select a menu option from the “ Options” menu. The contents of this menu
depend upon which tools you are using.

2 To set optionsfor abuild phase:
1. Select the options menu and find the phase whose options you would like to modify. Select this option.
2. A dialog will be invoked which alows you to specify the options.
3. After making your selections, click “OK” to set them.

To obtain further information, use the context sensitive help button or select the area in which you need
assistance and then press F1.
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25 Build Configurations

The HEW allowsyou to store al of your build optionsinto a build configuration (figure 2.14). This means that
you can “freeze” all of the options and give them aname. Later on, you can select that configuration and all of

the options for all of the build phaseswill be restored. These build configurations also alow the user to specify
debugger settings for abuild configuration. This means that each configuration can be targeted at a different end

platform. (See Emulator Debugger Part in this manual, for further information).

Figure 2.14 shows three build configurations; “ Default”, “MyDebug” and “MyOptimized”. In thefirst
configuration, “ Default”, each of the phases (compile and assemble) are set to their standard settings. In the
second configuration, “MyDebug”, each of the files are being built with debug information switched on. In the
third configuration, “MyOptimized”, each of the files are being built with optimization on full and without any
debug information. The devel oper of this project can select any of those configurations and build them without
having to return to the options dialogs to set them again.

"Default" "MyDebug" "MyOptimized"
Configuration Configuration Configuration
=S Debug: ON Debug: ON Debug: OFF
- Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | H List File: NO | H ListFile: NO | H
C
Source Files
= Debug: OFF Debug: ON Debug: OFF
Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | H List File: NO | H ListFile: NO | H
Assembler
Source Files
C:\MyProject\Default C:\MyProject\MyDebug C:\MyProject\MyOptimized

Figure 2.14: Configurationsand File Options
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251 Selecting a Configuration
The current configuration can be select in two ways:
Either:

1. Select it from the drop down list box (figure 2.15) in the toolbar.
2. Theconfiguration is selected.

I Release

Figure 2.15: Toolbar Selection
or:

1. Select [Options->Build Configurations...]. Thiswill invoke the “Build Configurations’ Dialog (figure
2.16).

Build Configurations

Build configurations: 0k
Release Cancel |
Add...

Eemnowe |

LCurrent configuration;

Debug ﬂ

Figure 2.16: Build Configurations Dialog

2. Select the configuration that you want to use from the “ Current configuration” drop down list.
3. Click “OK” to set the configuration.
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252 Adding and Deleting Configurations

Y ou can add a new configuration by copying settings from another configuration or delete a configuration. These
three tasks are described below.

2 Toadd anew configuration:
1. Select [Options->Build Configurations...] to display the “Build Configurations® dialog (figure 2.16).
2. Click the“Add..."” button. The “Add Configuration” dialog will be invoked (figure 2.17).

Add Configuration E

Configuration name: IM}'EDHHQ
Cancel
Bagzed on configuration; IDebug j 4|

Configuration direchony: c:hhewidemohdemoiMyConfig

Figure 2.17: Add Configuration Dialog

3. Enter the new configuration name into the “Configuration name” field. Asyou enter the new
configuration name, the directory underneath changes to reflect the configuration directory that will be
used. Select one of existing configurations, from which you want to copy a configuration, out of the drop-
down list of the “Based on configuration” field. Click “OK” on both dialogs to create the new
configuration.

2 Toremove aconfiguration:
1. Select [Options->Build Configurations...] to display the “Build Configurations® dialog (figure 2.16).
2. Select the configuration that you want to remove and then click the “Remove” button.
3. Click “OK” to close the “Build Configurations’ dialog.
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2.6 Building a Project

The outline of the build processis shown in figure 2.1.

26.1 Building a Project

The build option only compiles or assembles those files that have changed since the last build. Additionally, it
will rebuild source filesif they depend upon afile that has changed since the last build. For instance, if thefile
“test.c” #include' sthe file “header.h” and the latter has changed since the last build, the file “test.c” will be
recompiled.

2 To perform abuild:
Select [Build->Build] or click the build toolbar button () or press F7 or click the right mouse button on a
project iconin the “Projects” tab of the “Workspace” window and select [Build] from the pop-up menu.

The build all option compiles and assembles all sourcefiles, irrespective of whether they have been modified or
not, and links all of the new object files produced.

2 Toperformabuild al:

Select [Build->Build All], or click the build all toolbar button (), or click the right mouse button on a
project icon in the “Projects” tab of the “Workspace” window and select [Build All] from the pop-up menu.

262 Building Individual Files
The High-performance Embedded Workshop lets you build project filesindividually.

° Tobuild an individud file:
1. Select the file which you want to build from the project window.

2. Select [Build->Build Filé], click the build file toolbar button (8) or press CTRL+F7 or click the right
mouse button on afileicon in the “ Projects’ tab of the “Workspace” window and select [Build <file>]
from the pop-up menu.
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2.6.3 Stopping a Build
The High-performance Embedded Workshop allows you to halt the build process.

2 To stop abuild:

1. Select [Build->Stop Build] or click the stop build toolbar button (#%). The build will be stop after the
current file has been built.

2. Wait until the message “ Compiler Finished” appearsin the “Output” window before continuing.
2 Toforcibly terminate a current tool
1. Select [Build->Terminate Current Tool]. The HEW will attempt to stop the tool immediately.

Note: Do NOT assume that any output from the tool you terminated isvalid. It is recommended that you delete
any output files produced and ensure that the phase is executed again.

2.6.4 Building Multiple Projects
The High-performance Embedded Workshop lets you build multiple projects and configurations at once.

2 Tobuild multiple projects:

1. Select [Build->Build Multiple]. Thefigure displayed in figure 2.18.

2. Thebuild multiple gives you the choice of which projects and configurations should be built. To select
which projects and configurations need to be built select the check box next to the project —
configuration combination you want to build. For example, in figure 2.18 if you wanted to build the
entire “hewtest2” project you would check the “hewtest2-Debug” and the “hewtest2-Release” selections
and leave all other check boxes unchecked.

3. When you are happy with your chosen selection click the build button and the HEW will then build the
projects and configurations you have chosen.

4.  If youwant to build all the projects, which you choose, you click the build all button.

5. Results from the build are displayed in the build window in the same way as the normal build process.

Build Multiple E2

[ hewtest1-Debug -
[ |hewtest1-Release

[ 1hewtest2-Debug Build Al

[ |hewtest2-Release
[ hewtest3-Debug
C | |
[ |hewtest3-Release anes
[ hewtestd-Debug

[ |hewtestd-Release
[ hewtesth-Debug

[ hewtesta-Release _ILI
1 | | »

Figure 2.18: Build Multiple Dialog
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2.6.5 The Output Window

When atool executes (i.e. compiler, assembler, linker etc.) its output is displayed in the “ Output” window. If any
of the tools produce any errors or warnings then they are displayed along with the source file name and the line
number at which the error islocated. To quickly locate a specific bug, double click on agiven error/warning to
invoke the current editor.

2.6.6 Controalling the Content of the Output Window

It is often useful to display extrainformation (such as the command line options that are being applied to afile)
during abuild. The HEW allows you to specify whether or not you want such options displayed in the “ Output”
window during a build, build al or build file operation viathe “ Tools Options” dialog.

2 Toview or hide extrainformation during a build:

1. Select [Tools->Options...]. The“Options’ dialog will be displayed.

2. Select the “Build” tab (figure 2.19).

3. Set the three check boxesin the “ Show” group as follows. “Command line” controls whether the
command line is shown as each tool is executed. “ Environment” controls whether the environment is
shown as each tool is executed. “Initial directory” controls whether the current directory is shown as each
tool is executed.
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Build |Edit0r | wiotkspace | Confimation | Metwork |

—Ermars and warnings:

[ Stop build if the number of emors exceeds: I 1]

[ Stop build if the number of warnings excesds: I 0

 Show:
v

¥ Environment

I Initial directon

¥ Mark out of date files

r— Makefile build
Carrmand [excluding parameters]:
[HEWDIR\hmake. eve Ll e |

[ Use makefile build spstem

Makefile aptions:

| i3

I akefile path

|$[WEIFEKSF'DIFE]'\make\$[F'F|DJEI:TNﬁ3«ME].mak Ll Erowse... |

™| Generate makefile before build commences

Ok, I Cancel

Figure 2.19: Options Dialog Build Tab
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2.6.7 Displaying out of date filesin the wor kspace window

Files updated later than the file generated by the previous build (i.e. out of date files) are marked in the
workspace window. In figure 2.20 below, file "demo.c" is out of date.

When you click build next time thisfile will be re-built. Thisis also displayed for dependent projects of the
current project.

The view of these filesis updated whenever something that affects the build occurs, e.g. options changing, file
addition, dependencies changing, files modified, etc.

|
ER=) demo)

B- a Aszsembly source file
E intprg. src

o (] ol sre

E wectthl src

o |#] vhandler sre
B2 C source file

- [H] dbscte

2] lowsiec
E resetprg.c
E shrk.c
I'_'I a Download modules
demo. abs
E| ea Dependenmes
~[B envinc
lowsnz. b
shrk h
stackscth
vect.ing

_@Prniectsl@Templates ]€|Na\tigati0n I

Figure 2.20: Displaying out of date files

2 Todisplay out of date filesin the workspace window:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed.
2. Select the “Build” tab (figure 2.19).
3. Check the“Mark out of date files’ check box.
4. Click OK.
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2.7 File Dependencies

A typical project will contain dependencies between files, for example, one C file may “#include” one or more
header files. In complex projects, source files will include (or depend upon) others and this can quickly become
difficult to manage. However, the HEW provides a dependency scanning mechanism whereby all filesin a
project are checked for dependencies. Once compl ete, the project window will display an up-to-date list with al
the project file dependencies.

2 Toupdate a project’ s dependencies:
Select [Build->Update All Dependencies] or click the right mouse button on a project icon in the “ Projects’
tab of the “Workspace” window and select [Update All Dependencies] from the pop-up menu.

Initialy, the dependenciesfor al files are contained within the “ Dependencies’ folder (figure 2.21.i).

2.8 Configuring the Wor kspace Window

If you click the right mouse button anywhere inside the “ Projects’ tab of the “Workspace” window, a pop-up
menu will be invoked. Select the “Configure View...” menu option to modify the way in which information is
displayed. The following four sections detail the effect of each option on the “Configure View” diaog.

281 Show Dependencies under Each File

If you select “ Show dependencies under each file”, the dependent files are shown under the including source file
asaflat structure, i.e. the files themsel ves become folders (figure 2.21.ii). If this option is not selected then a
separate folder contains all dependencies (figure 2.21.i).

; < i L
E"@ Demo E--@ Demo
B T oo
Ea Agzembly source file E| {3 Assembly source file
i 2] lowivl.ere | (4] lowid.sre
E| ej C source file 29 C source file
i . dbsct.c dbsct.c
. Demo.c Demo.c
. intpra.c intpra.c
lowsrc.c wecth
resetpr.c lowisrc. o
shrk.c lowysre. b
i . vecttbl.c resetpra.c
E| eﬂ Dependencies stackscth
= lowesrc.h shrk.c
~[2] shikh shrk h
~[5] stackscth Bl |[£] vecttble
vecth vecth
@ijeck IE Templates I €|Namgaﬁon I @ijem IE Tenplates I €|Na\ﬂgaﬁon I

Figure 2.21: Dependencies under Each File

31
RENESAS




282 Show Standard Library Includes

By default, any dependent files found in standard include paths will not be shown (figure 2.22.i). For example, in
C code, if you write an include statement such as “#include <stdio.h>" then stdio.h will not be listed asa
dependent file. To view such system include files, select the “ Show standard library includes’ option (figure
2.22.ii).

O T XTI = B

=8 I@ Demo == @ Demo
E| 23 Aszembly source file E| a Assembly source file
cl.zrc [ cl.src
EI a C zource file

EI 29 C source file

hcfg o 3] hwckg.c
intv.c: inty.c
main.c mait. o
shrk.c i shrk.c
23 Dependencies EI a [Dependencies
stoldef b
-2 stdinh
2] projects l ] Templates | 1 Navigation I ) Projects l ] Termplates | ] Mavigation I

Figure2.22: Standard Library Includes

283 Show File Paths

If “Show file paths’ is selected, all of the filesin the project window are shown with their full path, i.e. froma
drive letter (figure 2.23).

<& Workspace !E[ ﬁ

E source file
C:\Hew2\DematDemaoihwefg.c
C:AHew2\DemohDemotinty.c
C:AHew2\Demo\Demakmain. ¢

o [#] CAHew2\Demo'\Demeohshik.c
------ 23 Dependencies

N @ijectx l @ Templates I €|Na\rigaﬁon I

Figure 2.23; File Paths Shown
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284 Sort filesby time order
When this option is selected the workspace window is then sorted into file time stamp order.
If files are updated after selecting this option, manually update the order of thesefiles.

2 To manually update the file order:
1. Select “Refresh order” in the pop-up menu on the “ Projects’ tab of the “Workspace” window.

29 Setting the Current Project

A workspace can contain more than one project but only one of the projects can be active at any time.  This
active project is the one, which build actions and debug operations can be performed on. It isalso possibleto
change the builder or debugger options for the project. This active project is shown as bold characters.

2 To set aproject asthe current project:
1. Select anon-active project from the “Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Set as Current Project] option.
or:
1. Select the project, which you want to make active from the [Project->Set Current Project] sub-menu.
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210 Inserting a Project into a Workspace

When aworkspace is created, it contains only one project but, after it is created, you can insert new or existing
projects into a workspace.

2 Toinsert anew project into a workspace:

1. Select [Project->Insert Project...]. The “Insert Project” diaog will be displayed (figure 2.24).

2. Setthe“New Project” option.

3. Click OK. The “Insert New Project” dialog will be invoked.

4. Enter the name of the new workspace into the “Name” field. This can be up to 32 charactersin length and
contain letters, numbers and the underscore character. Asyou enter the project name the HEW will add a
subdirectory for you automatically. This can be deleted if desired.

5. Click the“Browse...” button to graphically select the directory in which you would like to create the
project. Alternatively, you can type the directory into the “Directory” field manually.

6. The“Project type” list displaysall of the available project types (e.g. application, library etc.). Select the
type of project that you want to create from thislist.

7. Click “OK” to create the project and insert it into the workspace.

Inzert Project EHE
Inser
; Cancel |

~ Existing project:

Erowse.. |

Figure 2.24: Insert Project Dialog

2 Toinsert an existing project into aworkspace:
1. Select [Project->Insert Project...]. The “Insert Project” dialog will be displayed.
2. Setthe “Existing Project” option.
3. Enter thefull path of the project database file (HWP file) into the edit field or click “Browse...” to
search for it graphicaly.
4. Click “OK” toinsert the existing project into the workspace.

34
RENESAS




211  Specifying Dependencies between Projects

The projects within aworkspace can be dependent upon one another so that when one project is built, all its
dependent projects are built first. Thisis useful if another project uses one of the othersin the workspace. For
example, imagine that a workspace contains two projects. Thefirst project isalibrary that isincluded by an
application project. In this case the library must have been built and up to date before the second application can
build correctly. To achieve this situation we can specify the library as a dependent (i.e. child) project of the
application project. Thiswould then allow thelibrary to be built first if it is out-of-date.

When adependent project is built the HEW attempts to match the configuration in the dependent project with
that of the current project. This meansthat if the current configuration is “Debug” then the HEW will attempt to
build the “Debug” configuration in the dependent project. If this matched configuration does not exist then the
HEW will use the configuration that was last used in the dependent project.

2 To make projects depend upon another:
1. Select [Project->Dependent Projects]. The “ Dependent Projects’ dialog will be displayed.(figure 2.25)
2. Select the project to which you would like to add dependents to. When you do this, the “ Dependent
projects’ list will display al of the projectsin the workspace (excluding the selected project).
3. The“Dependent projects’ list has a check box for each project listed. Set the associated check boxesto
make those projects depend upon the selected project.
4. Click “OK” to confirm the new project dependencies.

Dependent Projects EHE

Froject:
I main_project j

Cancel |

Dependent projects:

|

Figure 2.25; Dependent Projects dialog
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212  Removing a Project from a Workspace

2 Toremove aproject from aworkspace:
1. Select the project from the “Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the [Remove Project] option.

3. Dialog box isdisplayed. You confirm to remove the project. In the “Options’ dialog box of the “Tools”
menu, you can select this confirmation is performed or not.

Note: Y ou cannot remove the current project from the workspace.

213 Loading/unloading a Project into/from a Workspace

2 Toload aproject into aworkspace:

1. Select the project from the “Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the [Load Project] option.

2 Tounload aproject from aworkspace:

1. Select anon-active project from the “Projects’ tab of the “Workspace” window and click the right mouse
button to invoke a pop-up menu.

2. Select the [Unload Project] option.

Note: You canload or unload plural projects at atime.
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2.14 Relative projects pathsin the workspace

In the High-performance Embedded Workshop when you add a project to the workspace you can choose to add
the project to the workspace using arelative path. This allows you to position a project above the workspace
directory and it will still be relocated correctly if you relocate the HEW workspace. The project is always
relative to the workspace o if the project is one directory above the workspace before it is moved the HEW will
try to find the project in the same relative location after the relocation procedure. Thisis especially useful if you
are using a project shared between more than one workspace.

In older versions of the HEW this project would not have been relocated and would have still tried to access the
original project path. The older version of the HEW could only relocate the projects, which werein a
subdirectory of the workspace directory. Thisis gtill the standard behavior for the High-performance Embedded
Workshop.

2 To change aprojects relative path flag:
1. Select the project in the workspace window.
2. Right click and then select properties.
3. Click the“Project relative file path” checkbox to switch on or off the relative file path feature. (figure

2.26)
4. Click“OK”.

Properties EHE
Mame: IDEmD oK. I
Location; CAHewhDemosDemohDemo. hvp
Last modified: 10:19:42, Thureday, June 12, 2003
CPU family: SuperH RISC engine
Toal chain: Hitachi SuperH RISC engine Standard Toalchain
Wersion: 7120
™ Froject relative file path

Figure 2.26: Properties Dialog
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215 User foldersin the workspace

In the High-performance Embedded Workshop it is possible to add folders to your workspace window. This
alowsyou to logicaly group your filesinto certain areas within a project. The folder can be set to any name and
thisisentered in adialog.

2 Toadd auser folder:

1. Select the project on the “ Projects’ tab of the workspace window.

2. Right click and then add folder.

3. Enter thenameand click OK.

4. You can now drag and drop filesinto this folder to group them logically.
2 Toremoveauser folder:

1. Select the folder on the “Projects’ tab of the workspace window.

2. Right click and then select Remove folder. Note that the folder must be empty and that the delete key
can also be used instead of the pop-up.

2 To modify auser folder name:
1. Select the folder on the “ Projects’ tab of the workspace window.
2. Right click and then select Modify folder name.
3. Enter the new namein the dialog.
4. Click “OK".
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3. Advanced Build Features

This chapter explains the advanced build concepts.

31 The Build Process Revisited

Chapter 2, “Build Basics’ began by describing the build process in terms of a compiler, an assembler and a
linker (figure 2.1). Thiswill be the case for most ingtallations of the High-performance Embedded Workshop.
However, if you want to begin changing the build process (e.g. adding and removing phases) then it isimportant
to understand more about the way in which abuild functions.

311 What isa Build?

Building a project means applying a set of tools upon certain input filesin order to produce the desired output.
Thus, we apply a compiler upon C/C++ source filesin order to create object files, we apply an assembler upon
assembler source filesin order to create object files and so forth. At each step or “phase” of the build, we apply a
different tool upon a different set of input files. Figure 3.1 presents another view of the build process.

&4 seGIN EE

_ owser > |

Phase 1 Input Files ‘ Phase 1 Output Files
7 FHASEE %
Phase 2 Input Files ’ Phase 2 Output Files

Phase 3 Output Files

Phase 3 Input Files

_ owsex > |
}

Phase X Input Files Phase X Output Files

Figure 3.1: Build Process
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The High-performance Embedded Workshop provides the ability to change this build process viaits “ Build
Phases” dialog, which can be, accessed via the [Options->Build Phases...] (figure 3.2). On theleft-hand side
are the phases that are defined in the current project (Figure 3.2 shows a standard set of build phases). The
remainder of this chapter details the various functions that the “Build Phases’ diaog provides.

Build Phazes E

Build Order | Build Fie Order | File Mappings |

Build phaze order;

[w]SH CAC++ Librany Generator
[w]SH CAC++ Compiler

[w]SH Agzembler o,
[w] DptLink.er

Eemave
ayve ln

i e [

4 I I _,I Impaoirt..

FLEHE )

ak. | Cahicel |

Figure 3.2: Build Phases Dialog

40
RENESAS



3.2 Creating a Custom Build Phase

If you want to execute another tool before, during or after a standard build process then this can be achieved by
creating your own (i.e. custom) build phase.

Select [Options->Build Phases...] to invoke the “Build Phases’ dialog (figure 3.2) and then click the “Add...”
button. This will invoke the new build phase wizard dialog (figure 3.3a).

Thefirst step (as shown in figure 3.3a) asks whether you want to create an entirely new phase or whether you
want to add a system phase. A system phase isa“ready made” phase which isalready defined within the
toolchain you are using (e.g. compiler, assembler, linker, librarian, etc.) or a utility phase (e.g. file copy,
complexity analyzer etc.).

The“Add an existing system phase” button isinactive if no more system phases are available. Select the “Create
anew custom phase” button to create your own build phase.

Mew Build Phase - Step 1 of 4 [ 7] x|

What tupe of phaze would pou like to add ¥

&% Create a new custom phase

) Sdd | ar existing sustem phases

Syztem Phase | Yerzion |

< Hiask: | Mewut » | Cancel

Figure 3.3a: New Build Phase Dialog (Step 1)
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The second step (figure 3.3b) asks what type of phase you would like to create. There are two choices: multiple
or single. When amultiple phase is executed, the command is applied to each file in the project of acertainfile
group. For example, if you set the input file group to be C source files then the command will be executed once
for each C sourcefile in the project. A single phase is executed once at most during a build.

Mew Build Phase - Step 2 of 4 EHE
Y

WWhat type of phaze would you like to create?

* Multiple phaze:

The command iz applied to each file in a file group.
An example of thiz type of tool iz a compiler or azgembler.

Select input file group:

"~ Single phase:

The command iz only ever executed once per build,
An example of thiz twpe of tool iz a linker.

< Back | Ment » | Cancel

Figure 3.3b: New Build Phase Dialog (Step 2)

Theinput file group list contains the current file groups defined for the project. It is possible to define multiple
input file groups by selecting the “Multiple Groups...” entry in theinput file group list. Selecting thislist entry
displaysthediaog in figure 3.3c.

Select Groups

[ Agzembly zource file ;I
[ 1Binary file

[1C header file Cancel
[1C list file
vl zource file

[ C++ header file

o
=
]

[ 1Expanded aszembly source file _ILI
4 I I 3

Figure 3.3c: Modify multipleinput file groups

Once this choice has been made the input file group selection is displayed as “Multiple Groups...” Thisdialog
alows the user to choose multiple input file groups for the custom phase being added to the project. To select a
file group check the box next to the file groups name. One or more file groups can be selected in this dialog.
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Thethird step (figure 3.3d) requests the fundamental information about the new build phase. Enter the name of
the phase into the “ Phase name” field. Enter the location of the program file into the “Command” field (do not
insert any command line options as these options are specified viathe [Options] menu of the HEW menu bar).
Specify the default options for the phase (i.e. what options you would like new files to take when added to the
project) into the “Default options’ field. If you have a preferred directory in which you would like this program
to run from (i.e. where you want the current working directory to be set to before the tool is executed) then enter

itinto the “Initia directory” field.

Mew Build Phase - Step 3 of 4
)

Phaze name:

IMyPhase

LCommand [excluding parameters):

Ic: Stoolshmytool exd

Default options:

|$[FULLFILE]

Initial directong:

|$[EDNFIGDIF|]

Ll Browse. .. |
2
Ll Browse. .. |

< Back |

Ment » |

Cancel |

Figure 3.3d: New Build Phase Dialog (Step 3)
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The fourth and final step (figure 3.3€) alows you to specify any environment variables, which the phase requires.

Mew Build Phase - Step 4 of 4 EHE

[Does the command require any environment varables to be sat?

If g0, enter them inta the list below:

ENv=1024
e |
Herove |
KN — o

[ Bead Dutput On Fly

< Back | Finizh | Cancel |

Figure 3.3e: New Build Phase Dialog (Step 4)

To add anew environment variable click the “Add...” button (the dialog shown in figure 3.4 will be invoked).
Enter the variable nameinto the “Variable” field and the variable’svaue into the “Value” field and then click
“OK” to add the new variable to the list of the fourth step. To modify an environment variables select the
variablein the list and then click the “Modify...” button. Make the required changesto the “Variable” and
“Vaue” fields and then click “OK” to add the modified variable to the list. To remove environment variables
select the variable that you want to remove from the list and then click the “Remove” button.

Environment ¥ariable

" ariable:

[PaTH

Walue:

Flaceholder
PopUp MMenuy

Ic:'\dos,‘c:'\m_l,ltools,'c:\windows;c:'\temp L}

Figure 3.4: Environment Variable Dialog

If the tool you are adding can display its output as the tool is running then use the * Read Output On Fly’ option.
Thiswill display the tool output as each line of output happens. If thisoption is set to off then the HEW will
store al output, which is being displayed by the tool, and display it in the output window when the tool has
finished its operation. This can be a problem when the tool is running an operation that might take many
minutes, asit is difficult to see the progress of the current execution.

Note: Using ‘Read Output On Fly’ can cause problems when using certain tools on certain operating systems.
If you are having problems with tools locking up or freezing in HEW then uncheck the ‘Read Output On
Fly’ option.

Click the “Finish” button to create the new phase. By default the new phaseis added to the bottom of the “Build
Phase Order” list in the “Build Order” tab of the “Build Phases’ dialog (Figure 3.2).
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3.3 Ordering Build Phases

In astandard build (shown in figure 3.5), you could add a phase at four different positions: before the compiler,

before the assembler, before the linker or after the linker. Y ou may place your own custom phases or move
system phases to any position in the build order. It isimportant to remember that if the output of your custom

phase can be input into another phase then the phase order must be correct if the build isto behave as intended.

<

COMPILE

}

ASSEMBLE

}

LINK

glz

[ o]
<o

Figure 3.5: Typical Build Process

The build phase dialog provides facilities for ordering build phases via the “Build Phases’ dialog. It has two tabs,
which are concerned with the ordering of phases. “Build Order” and “Build File Order”. And then you can click

"OK" button.
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331 Build Phase Order

The “Build Order” tab (figure 3.6) displays the current order in which phases will be executed when the build

currently enabled. By clicking this box, the phase can be toggled on or off.

Build Phazes E

Build Order | Build Fie Order | File Mappings |

Build phaze order;

H

[w]SH CAC++ Librany Generator Add..

[w]SH CAC++ Compiler ;

[W5H Aszembler Lol |
R
ayve ln |
i e [ |
4 I I _,I Impaoirt.. |

ak. | Cahicel |

Figure 3.6: Build Phases Dialog Build Order Tab
In addition the following operations can be performed:

2 Toremove aphase:
1. Select the phase that you would like to remove.
2. Click the “Remove” button.
3. Click the"Yes' button, if a confirmation dialog box.
2 Toview the properties of a system phase:
1. Select the system phase that you would like to examine.
2. Click the“Modify...” button.
3. System properties are shown asdialog box. Click the“OK” button.
2 To move aphase:
1. Select the phase that you would like to move.
2. Click the“Move Up” or “Move Down” button.
2 Toimport aphase:
1. Click theimport button. A dialog isdisplayed which allows the user to browse to an existing project to
import a custom phase from.

2. Choose the location of the project you wish to import a custom phase from. Once selected adialogis
displayed which lists the custom phases in the imported project.

3. Onceyou have decided which phase to import highlight it in the list and then click OK. The phase will
then be added to the build phases dialog at the bottom of the build order.
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2 To modify acustom phase:

1. Select the custom phase that you would like to modify.
2. Click the“Modify..."” button. The modify phase dialog will be invoked with the “Command” tab selected
(figure 3.7).
3. Change the contents of the fields as appropriate.
4. Setthe “Don’'t check for input file(s) existence before executing” check box if you don’t want the HEW
to abort the execution of the phaseif any of the input filesdon't exi<t.
Set the “Read Output On Fly” check box if you want to display the command output to stdout during
command execution.
Modify MyPhase EE
Command | Envirnnmentl
LCaommand [excluding parameters):
IC:\lools\mytool.e:de Ll Browsze. . |
Initial directony:
[$CONFIGDIR) Ll Brawse.. |
[ Don't check for input file(s) existence before executing
[~ Eead Output On Fly
ak. I Cancel
Figure 3.7: Modify Phase Dialog Command Tab
5. Select the “Environment” tab (figure 3.8) to edit the environment settings for the phase.
6. Usethe“Add...”, “Moadify...” and “Remove” buttons to add, modify and remove environment variables.
The operation is the same as discussed in the previous section.
7. Click “OK” when all modifications have been made.
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Modify MyPhaze

Command — Erwironment |

Enwironment settings:

PATH=c:"dozc: Mools
SHOWALL=FALSE
EMV=1024

T adifin. |
HEmove |

Ok

| Cancel |
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Figure 3.8: Modify Phase Dialog Environment Tab
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332 Build File Phase Or der

If you were to select a C source file from the “Workspace” window and then activate [Build->Build File] (or
press ££2) you would expect the file to be compiled. Likewise, if you were to select an assembly source file from
the workspace window and then activate [Build->Build File] you would expect the file to be assembled. The
connection between file group and which phase(s) to execute is managed by the “Build File Order” tab of the
“Build Phases’ didog (figure 3.9).

Build Phaszes E E2

Euild Order  Build File Order | File: b appings I

File group: Phasze order:
Aszembly source file [w|Campiler
(v MyPhaze @

C++ zource file

- @

| -1
ak I Cancel |

Figure 3.9: Build Phases Dialog Build File Order Tab

Thelist displaysall of the current phases that will be executed when the build file operation is selected upon the
file group shown in the “File group” list box. In figure 3.9 the “ C sourcefile” file group is selected and the
“Compiler” and “MyPhase” phases are associated with it.

Entriesin the “Phase order” list, of the “Build File Order” tab, are added automatically as new entries are added
to the “Build Order” tab. For example, if you were to add a phase which takes C source files as input then this
phase will be automatically added to the list of phases to execute when a build file operation is applied toa C
source file. If you don’t want a certain phase to execute when [Build->Build Fil€] is selected then clear the
check box to theleft of the phase name in the “ Phase order” list.
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34 Setting Custom Build Phase Options

Once you have defined a custom phase, you will want to specify the command line options that should be used
when it is executed. Each defined phase has a menu option on the [Options] menu. To specify options for that
phase select it. The dialog that will be invoked depends upon whether the custom phase selected was a multiple
or single phase (according to the selection of phase type in figure 3.3b).

Phasel... Options 2=
IDBbUQ j E'IDti'I'nlelut|:n.Jt Files | Dependent Files
Bl @ hewtest = LCommard:
B3 C source file Ip:'\_hew-files'\Dos&windnws executables\CMDLINE EXE
: . hewtest.c
imitsct.c Options:
Ophions:
& FUULLFILE
shrk.c il )
[E] vecttblc
------ D Drefault Options
[]—--@ hewtest]
[]—--@ hewtest2
=- @ hewtest3
- C zource file

Placeholder:

[E] hewtestac .

" ile path + name Inzer
initsct.c = IFI th j ;l
intprg.c

shrk.c =
1 ' | v

ak. I Cahicel |

Figure 3.10: Custom Options Dialog

Thedialog in figure 3.10 is a custom phase options dialog. The implementation of which is dightly different
depending on whether you are using amultiple or single shot phase. On the left-hand side is the project and file
list. Itispossibleto select multiple projects and filesin the same way as Windows® explorer to modify the
options for more than one selection. On the right-hand side are the 3 optionstabs. Thisiswhere you set the
options that you want to apply to the selected file(s). You can aso choose which configuration information is
being viewed from the configuration list on the upper left of the diadlog box. Each configuration islisted along
with a special entry named “Multiple configurations...”. If you select multiple configurationsthen adialog is
displayed which allows you to select more than one configuration. This method is used throughout HEW for
modifying multiple configurations at once.
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34.1 Options Tab

The “Options’ tab (figure 3.11) alows you to define the command line options that will be passed to the phase.
The “Command” field displays the command, which was entered when you defined the phase (figure 3.3d).
Enter into the “Options’ field the command line arguments that you would like to pass to the command. If you
want to insert a placeholder, select the relevant placeholder from the “Placeholder” drop-down list box and then
click the “Insert” button. For a detailed description of placeholders see appendix C, “Placeholders’.

Ophions |Dutput FiIesI Dependent Filesl

LCommand:
IE:'\Hew\TooIchains'\Hitachi'\SH'\E'I MBIMYLbr. exe

Options:
-sub=${COMNFIGDIR ) buildlib. sub

Placehalder:

- - " | rt bt
Canfiguration directary j Inzert :I—— fzleaceko:;er

Ok I Cancel |

Figure 3.11: Custom Options Options Tab

34.2 Output FilesTab

The “Output Files’ tab (figure 3.12) is where you can specify the output file or filesthat will be produced by the
phase. Before each file is passed into this phase, the HEW checks that the output files are of aless recent date
than the input file. If so, the phase will be executed for that file (i.e. input files have been modified since the
output file or fileswere last produced). If the files are up to date then the phase will not be executed.

Note: If no output files are specified, the phase will execute regardless.
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Options  Output Files | Dependent Files

Add...

Todify... |
Remove |

N -1
ak. I Cancel

Figure 3.12: Custom Options Output Files Tab

2 Toadd an output file:
1. Click “Add...”. The“Add Output File" dialog will be invoked (figure 3.13).
2. Enter thefile path or browseto it using the “Browse...” button.
3. Click “OK” to add this output file to the list.

Placeholder popup menu

Add COutput File

Ll Browse.. | Cancel |

Figure 3.13: Add Output File Dialog

2 To modify an output file:
1. Select the output file that you would like to modify.

2. Click “Modify..."”. The“Modify Output File” dialog, which isthe same as figure 3.13 except the title,
will be invoked.

3. Modify the fields as required and then click the “OK” button to add the modified entry back to thelist.
2 Toremovean output file:

1. Select the output file that you would like to remove.

2. Click the “Remove” button.
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343 Dependent FilesTab

The “Dependent Files’ tab (figure 3.14) is where you can specify the dependent files that are needed by the
phase. Before each fileis passed into this phase, the HEW checks that the dependent files are of a more recent
date than the input file. If so, the phase will be executed for that file (i.e. dependent files have been modified
since the input file or files were last modified). If not, the phase is not executed for the files.

Dptionsl Dutput Files  Dependent Files |

SICONEIGDIR Add..
${CONFIGDIRVFilet obj

$[COMFIGDIR]NFile?. obj ;
${CONFIGDIRYFiles. abj gl |
c:hHewhw orksphProject\D ebugiFile1.obj

o \Hewvw orksphProject\D ebug'File2, obj Remowve |
c:hHewhw orksphProject\D ebugiFile3.obj

o \Hewvw orkephProject\D ebug'Filed. obj

Figure 3.14: Dependent Files Tab in Custom Options
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2 To add adependent file:
1. Click “Add...”. The“Add Dependent File” dialog will be invoked (figure 3.15).
2. Enter thefile path or browseto it using the “Browse...” button.
3. Click “OK” to add this output file to the list.

Flaceholder popup menu

Add Deperdert File 2 x

Ll Browse.. | Cancel |

Figure 3.15: Add Dependent File Dialog

2 To modify adependent file:
1. Select the dependent file that you would like to modify.

2. Click “Modify...". The “Modify Dependent File” dialog, which is the same as figure 3.15 except the title,
will be invoked.

3. Modify the fields as required and then click the “OK” button to add the modified entry back to thelist.
2 Toremove adependent file:

1. Select the dependent file that you would like to remove.

2. Click the “Remove” button.
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35 File Mappings

By default, the filesinput to a phase are only taken from the project, i.e. all project files of the type specified in
the “ Select input file group” drop-down list on the “New Build Phase” dialog (figure 3.3b). If you would like a
phase to take files output from a previous phase (i.e. intermediate files) then you must define thisin the “File
Mappings’ tab of the “Build Phases’ dialog (figure 3.16).

Build Phases 2 x|

Build Order | Build File Order ~ File Mappings |

Intermediate file mappingz for build;

Source | Destination | File Group
SH Agzembler OptLinker Object file

Add...
SH CAC++ Compiler SH &ssembler  Aszembly source file todify... |
SH C/C++ Compiler OptLinker Object file —

SH C/C++ Library Generator - OptLinker Library file

4] | Ol

Figure 3.16: Build Phases Dialog File Mappings Tab
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A file mapping states that you would like the HEW to pass output files of a certain type produced by one phase
(referred to as the source phase) to another phase (referred to as the destination phase). Such intermediate files
are passed in addition to the project files.

2 Toadd afile mapping:

1
2.

Click “Add...". The “Define File Mapping” dialog will beinvoked (figure 3.17).

Select the file group, which you want to pass between the phases from the “File group” drop-down list
box.

Select the source phase (i.e. which phase generates the files) from the “ Source phase” drop-down list box.

Select the destination phase (i.e. which phase takes these files) from the “ Destination phase” drop-down
list box.

Click “OK" to create the new mapping.

Define File Mapping 7] x|

Eile group: -DK

[ Obiect file [~ Cancel |
Source phaze:

ISH Azzambler j

Liestination phaze;

Figure 3.17: Define File Mapping Dialog

2 To modify afile mapping:

1

2
3.
4
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Select the mapping to be modified.

. Click “Modify..."” button. The “Define File Mapping” dialog will be invoked (figure 3.17).

Modify the options as necessary.

. Click “OK” to commit the changes.
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3.6 Controlling the Build

By default, the High-performance Embedded Workshop will execute all of the phasesin abuild and only stop if
afatal error is encountered. You can change this behavior by setting the controls on the “Build” tab of the
“Options’ dialog (figure 3.18).

Build |Edit0r | wiotkspace | Confimation | Metwork |

—Ermars and warnings:

[ Stop build if the number of emors exceeds: I 1]

[w Stop build if the number of warnings excesds: I 10

 Show:

[ Command line [ Initial directon

[ Environment [~ Mark out of date files
r— Makefile build

Carrmand [excluding parameters]:

[SHEWDIR hake. =ve L| Erm— |

[ Use makefile build spstem

Makefile aptions:

| il

I akefile path

I$[WEIHKSF'DIH]'\make\$[F'F|DJEETNQME].mak Ll Erowse,.. |

™| Generate makefile before build commences

Ok, I Cancel

Figure 3.18: Options Dialog Build Tab

Select [Tools->Options...] to invoke the dialog. If you want to stop the build when a certain number of errors
are exceeded then set the “ Stop build if the no. of errors exceed” check box and then specify the error count limit
in the edit field to the right. If you want to stop the build when a certain number of warnings are exceeded then
set the “ Stop build if the no. of warnings exceed” check box and then specify the warning count limit in the edit
field to theright.

Note:  Irrespective of what these controls are set to, the build will always hdlt if afatal error is encountered.

In addition to specifying error and warning count limits, the “Build” tab also alows you to request that the
command line, environment and initial directory of each execution should be displayed. Check the appropriate
check boxes as necessary.
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37 L ogging Build Output

If you would like to write the results of each build to file then invoke the “ Customize” dialog by selecting [Tools
-> Customize...] and select the “Log” tab (figure 3.19). Set the “ Generate log file” check box and then enter the
full path of thelog fileinto the “Path” field or browseto it graphically by clicking the “Browse...” button.

Customize

Figure 3.19: Tools Customize Dialog Log Tab
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3.8 Changing Toolchain Version

If two or more versions of the same toolchain are registered in the HEW, you can choose a version of the
toolchain on the “ Change Toolchain Version” dialog shown in Figure . To invoke the dialog, select [T ools-

>Change Toolchain Version...]. Choose one of the versions from the “ Toolchain versions’ drop-down list and
click the “OK” button to enforce your choice.

Change Toolchain Yersion 2=

Toolchain name: Hitachi SuperH RISC engine
Current wersion: 7110 Gancel |

GRU Family: Informatiar... |
Toolchair: IHitachi SuperH RISC engine Standard j
Toolchain version: |8-°-1 0 j
Toolchain build phases:

Build phaze | YYersion |

CiptLinker 200z

5H Azgembler 6.0.00

SH CAC++ Campiler 2.001

SH GAC++ Library Generator 3001

Figure 3.20: Change Toolchain Version Dialog

To show information of tool chain components select atool from the “Toolchain build phases’ list on the
“Change Toolchain Version” dialog and click the “Information...” button. Then atool information dialog (figure
3.21) will show you the information of the tool. Click the “Close” button to close the dialog.

SH C/CH++ Compiler Information 2 x|
Infarmation:
High-perfarmance Embedded workshop ;I

SuperH RISC engine CAC++ Compiler Wer, 8.0.01
[c1992, 2002 Renezas Techhology Carp.
[£)1992,2002 Hitachi Software Engineering Co. Ltd.

Figure 3.21: Toolchain Information Dialog
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3.9 Using an External Debugger

The High-performance Embedded Workshop can launch an externa debugger tool. If you want to use another
debugger then you must add it to the Tools menu.

The “Debugger” tab of the“ Customize” dialog (figure 3.22a, figure 3.22b, figure 3.22c) is where the external
debugger related information is configured. Y ou may wish to use an older version of the debugger if certain
targets are not currently supported in the new environment. Invoke it by selecting [T ools->Customize...] and
then selecting the “Debugger” tab.

Thefirst choice to make is which debug tool you would like to use from the “ External debugger selected” drop-
down ligt.

“Hitachi Debugger Interface (version 4.x or greater)”: Use the HDI
“Mitsubishi PD debugger”: Use the PD debugger

“Other external debugger”: Use the other debugger

“Non selected”: Not use the external debugger

Once this has been selected the external debugger must be configured.

2 TousetheHDI:
1. Setsthelocation of the HDI executable. This must be version HDI 4.0 or greater, otherwise its behavior
is not guaranteed.
2. Setsthelocation of the session file. Thistellsthe HDI which session to load when it islaunched.
3. Setsthelocation of the download module.

Cuskornize ﬂﬂ
Toolbarz Eommandsl Menu I Placeholders  Debugger |Lng I Help I

External debugager selected:

Hitachi D'ebugger [nterfac 1 4.1 or greater]

— Debugger zettings

HO location:

I Ll Browsze... |
Seszsion file:
I Ll Browsze. . |

Cownload module;

Ll Browsze... |

ak I Cancel |

Figure 3.22a: External debugger selected — HDI
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2 To usethe PD debugger:

1.
2.

Sets the location of the PD debugger executable.

Setsthe location of the PD profilefile. Thistellsthe PD debugger which session to load when itis

launched.

Sets the command line option. Thisfield allows additional options to be specified which can modify the

behavior of the external debugger.
Sets the location of the download module.

Cuskornize

Toolbarz Eommandsl Menu I Placeholders  Debugger |Lng I Help I

External debugager selected:

ki PO debugger

— Debugger zettings
BD debugger location;

PD profile file location:

Command line optiorns;

Cownload module;

N

ak I Cancel |

Figure 3.22b: External debugger selected — PD debugger
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2 To usethe other external debugger except on the HDI or the PD debugger:
1. Setsthelocation of the external debugger executable.

2. Setsthe command line option. Thisfield allows additional options to be specified which can modify the
behavior of the external debugger.

3. Setsthelocation of the download module.

Cuskomize ﬂ il

Toolbars Eommandsl Menu I Placeholders Debugger |L|:|g I Help I

Entemal debugger selected:

— Debugger settings
E sternal debuagaer location:

I Ll Browsze. . |

Command line optiorns;

| il

Download module:

Ll Browsze. . |

Ok, I Cancel |

Figure 3.22c: External debugger selected — External debugger except on the HDI or the PD debugger

Click the “Launch External Debugger” toolbar button to invoke the externa debugger:

7

After abuild, if the download module has been updated, the HEW will switch back to the debugger to enable
immediate debugging. Whilst using the debugger, double clicking in any source window will switch back to the
HEW with the source file open at the line, which was double clicked. This operation is not possible with the
“Other external debugger”.
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3.10 Generating a Makefile

The HEW alows you to generate a makefile, which can be used to build parts of your workspace without HEW.
Thisis particularly useful of you want to send a project to a user who does not have the HEW or if you want to
version control an entire build, including the make components.

Thisversion of HEW also supports the integration of the generated makefile and toolsinto the HEW framework.
Thisalowsyou to click build menu or toolbar button and then launch the makefile rather than the normal
internal HEW build process. For further information, refer to the “ Using a makefile inside the HEW system”
section later in this chapter.

2 To generate amakefile:

1. Ensurethat the project, which you want to generate a makefile for, isthe current project.

2. Ensurethat the build configuration that you want to build the project with is the current configuration.

3. Select [Build->Generate Makefile...].

4. Select theradio button, which isrelevant for your makefile. (See figure 3.23.)

5. Ensure you have selected the correct makefile format. HEW is capable of generating GNUMake,
HMake and NMake compatible files.

6. The use static sub-command files check box will generate separate command filesin the make
destination directory. Thisisdifferent to the normal style where the sub-command files are generated by
the maketool. In the case of the GNUMake file format this must be switched on.

7. Checking “ Scan dependencies whil st building makefile” will force a dependency scan to ensure the
makefile creation is up to date.

8. Click “OK".

2|

Generate makefile for;

& the current configuration in the cunently active project

Cancel

i

= all configurations in the curently active project

" all configurations in all loaded projects in the curent workspace

Iakefile format: | HM ake j

[ Use static sub-command files

¥ Scan dependencies whilst building make file

Figure 3.23: Generate M akefile Dialog
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The HEW will create a subdirectory “make” within the current workspace directory and then generate the
makefileinto it. It is named after the selection, with a.mak extension for exampl e the current project and
configuration (e.g. project_debug.mak). The executable HMAKE.EXE, located in the HEW installation directory,
is provided for you to execute the makefiles generated by the HEW. It is not intended to execute makefiles,
which have been user modified. For further details on HMAKE, refer to Appendix F, “HMAKE User Guide”.

2 To execute amakefile:
1. Open acommand window and change to the “make” directory where the makefile was generated.
2. Execute HMAKE. Its command lineis HMAKE.EXE <makefile>.

Note: The degree portability of a generated makefile is entirely dependent upon how portable the project itself
is. For example, any compiler options, which include full paths to an output directory or include file
directory, will mean that, when given to another user with a different installation, the build will probably
fail. In general use placeholders wherever possible —using a full, specific path should be avoided when
possible.
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3.11 Using amakefileinsidethe HEW system

The HEW aso allows you to configure the internal build to use a particular make file rather than the internal
HEW system when build is clicked.

The standard HEW integrated build should be fine for al of your building requirements. However in some cases
you may feel the need to use makefiles rather than relying on the HEW internal make system. The techniquesto
do this are described below:

= To set-up the internal makefile execution:

1. Create abase HEW workspace in which to launch your makefilein. It makes senseif thisisthe same
toolchain as the one to be used in your makefile. Although thisisnot essential.

2. Click on[Tools->Optiong].

3. Click thebuild tab (figure 3.24).

4.  Select the makefile command, which should be used. By default thisis set to the Renesas make tool
shipped with HEW. Thisiscaled HMAKE.exe and is located in the HEW installation directory
"$(HEWDIR)".

5. Click the "Use makefile build system" check box. Thistells the HEW that when the build button is
clicked that makefile should be executed rather than the internal build.

6.  Setup the makefile path. This defaults to the location, which HEW will generate makefilesto. This
item is configuration based so you can have a different makefile for each configuration.

Note:

Y ou do not need to use a makefile generated by HEW. It can be any format as long as your make tool
supportsit.

7.  Setup the makefile options. HMAKE allows the user to specify project or configuration selection
options so that different builds can be launched from the samefile. Again thisitem is configuration
based so you can have a different makefile options for each configuration. For further details on
HMAKE, refer to Appendix F, "HMAKE User Guide", "F.1.3 Parameters’.

8. Thefinal option isthe generate make file before build. Thiswill launch the default make file creation
utility before the makefileis executed. This means the makefile will always be up to date with the
HEW project system.

9. Click OK to save the changes.
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2|

Cptions

Buid |Editor | wiorkspace | Confirmation | Hebwark |

— Ermars and warnings:

™ Stop build if the number of ermors exceeds: I 1]

[ Stop build if the number of wamings exceeds: I 0

— Shawe

I Command line [ Initial directory

[ Enwironment [ Mark out of date files
— Makefile build

Command [excluding parameters]):
|$[HEWDIF|]\hmake.e:-ce ) | Browse. .. |

¥ Use makefils build system

Makefile options:
fr il
I akefile path;

[$1w/ORKSPDIRmake\$PROJECTAME L mak ﬂ e |

¥ Generate makefile before build commences

QK I Cancel

Figure 3.24: Option Dialog Build tab

Once this system is setup the build button, menu and keyboard shortcuts are linked to the makefil e tool
execution. All output is directed to the output window asin the case of the normal build. If you areusing a
toolchain supported by HEW errors and warnings can be double-clicked to jump to the source files. The help
link should also be supported. Note when using the HM AKE.exe system the build all button will passa
command to HMAKE to force are-build al operation. When using GNUMake thisis not supported.
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3.12  Customizing the HEW linkage or der

Object module are linked as alphabetical order in HEW default. Y ou can specify the linkage order, if you wish to.

> To switch on manual linkage order facilities:
1. Click the[Build->Linkage Order...] menu item.
2. Onthedialog displayed click the Use custom linkage order check box (figure 3.25).

3. Then you can move the objectsinto whichever order you need. Simply select the module and click the
up and down buttons to position it in the desired location.

4. Each module has adifferent icon depending on whereit originated.
5. Click OK to verify and save the settings.

Linkage order

[ Use custom linkage order: Ok
Object order: Cancel |
D main. obj
[ resetprg.obi M
D intprg. obj T — |
Itermediate file— 1] runtime_library. ib
File: in project ————— & projectname. ib

Uzer library from options

LR user_edit_options. lib

LCurrent configuration;
IDebug j Copy to...

J

Figure 3.25: Linkage order Dialog

When you are using multiple configurationsit is likely that the linkage order will be very similar. To do this
effectively you can copy the current settings in the dialog to other configurations. This is described below:

2 To copy the linkage order from one configuration to another:
1. Click the[Build->Linkage order...] menu item.

2. Select the configuration you wish to copy in the current configuration list. This defaults to the currently
loaded configuration.

3. Click the Copy to... button this displays a dialog and asks you which one of the configurationsin the
current project you wish to copy the current linkage order to. Select a configuration and click OK.

4. Click OK to verify and save the changes.
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4. Using the Editor

This chapter describes how to use the editor that is provided with the High-performance Embedded Workshop.

4.1 The Editor Window

The editor window (figure 4.1) contains the file windows that are being viewed or edited. Only one window is
active at anytime. This window is called the active window (or current window) and itstitle bar will appear a
different color from that of the others (“dbsct.c” is the active window in figure 4.1). All text operations such as
typing, pasting text and so forth only affect the active window. To switch to another source file window (i.e. to
make some other window the active window) there are a number of methods:

¢« Clickonitifitisvisible.

¢ PressCTRL+TAB to cycle through the windows one after another.

¢ Select the window by name from the “Window” menu.

¢ Selectitstab at the bottom of the editor window.

When afile has been edited, an asterisk (*) is appended to the window’ s title bar. The asterisk remains there
until thefileis saved. The asterisk isalso removed if dl of the edited changes are undone in the current window.

e 3
i
e 3
i
e 3
i
e 3
i

| v

FILE cdb=ct o

DATE ‘Thu, Jun 26, 2003
DESCRIPTION :Setting of B.RE Section
CPU TYFPE :

Thi=z file i= generated by Reneszas Project Generator (Ver. 3.0).

fpragna =ection SDSEC
=ztatic const struct {

char *rom_s=: <% Start addres=s of the initialized data =e
char #rom_e; <% End address of the initialized data =sect
char *ram_s=: <% Start addres=s of the initialized data =e
}IDTBL[ 1= 4 -
] »
0 resetprgc < dbsche |2 sbrkec

Figure 4.1: Editor Window
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4.2 Working with Multiple Files

The file areais where you will work with the files of your project. The editor allows you to have many files open
at onetime, to switch between them, to arrange them in different configurations and to edit them in whichever
order you want to. The operations that you can perform upon the windows are typical of most Windows®
applications and they can be found under the [Window] menu:

¢ [Window->Cascade]
Arrange all open windows so that they overlap, with the top left of each window visible.
¢ [Window->Tile Horizontally]
Arrange all open windows in sequence (horizontally) so that they occupy the entire editor window with no
overlapping edges.
e [Window->Tile Vertically]
Arrange all open windows in sequence (vertically) so that they occupy the entire editor window with no
overlapping edges.
¢ [Window->Arrange | cons]
Line up al minimized windows at the bottom of the editor window.
¢ [Window->Close All]
Close all open editor windows.

The files within the editor can be displayed in a“notebook” style. This means that each file has a separate tab
associated with it to aid in navigating between files.

2 To show filesin notebook:
1. Select [Tools->Options...]. The “Tools Options” dialog box will be displayed. Select the “Editor” tab.
2. Set the “Show filesin notebook” check box as appropriate.
3. Click “OK” for the new settings to take effect.

421 The Editor Toolbars

The editor has four related toolbars: Editor, Search, Bookmarks and Templates. They provide a shortcut to the
functions of the editor, which you will use most often. The following sections describe each buttons function.

422 Editor Toolbar Buttons

O New File

The new file button creates a new source file window with a default name. When you save thefile, you can
specify your own filename.

= Open File

Click thisbutton if you want to open afile. It invokes a standard file chooser - select the file which you want to
open and then click “Open”.
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= Save File

Saves the active source file.

i Save All Files

Saves dl of thefilesin the editor.

= Print File

To print the contents of the current window, click this button.

& Cut

Clicking this button will remove the current text selection and place a copy of it onto the Windows® clipboard
(it can be pasted back to afile with a paste operation).

Copy

This button allows you to copy the current text selection into the Windows® clipboard.

li! Paste

The paste button copies the contents of the clipboard into the active window at the position of the insertion

cursor.

it Match Braces

The match braces button highlights text between braces of type{ }, [ ] and (). Thisis particularly useful when
attempting to find out the structure of C/C++ code blocks which are opened with { and closed with }. To useit,
select the open brace to match from, or place the cursor beforeit, and then click this button. For further
information on brace matching, refer to the “ Brace Matching” section later in this chapter.

ar Insert Template

Toinsert apre-defined template at the current cursor position, click thistoolbar button. The “Insert Template”
dialog box will be invoked. Select atemplate name and then click OK. For further information on templates,
refer to the “ Templates’ section later in this chapter.

) Toggle Bookmark

The High-performance Embedded Workshop editor provides standard bookmark capabilities. To set a bookmark,
select the line to mark and click this button (a green mark will then appear in the blank on the left side of the
editor window). To remove a bookmark, select the line to remove a bookmark and click this button (the mark in
the blank on the left side of the editor window will disappear). For further information on bookmarks, refer to the
“Bookmarks’ section later in this chapter.
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423  Search Toolbar Buttons
Gy Find in Files

To search several filesfor atext string then click this button. All find results are displayed in the “Find in Files”
tab of the “Output” window. For further information, refer to the “ Searching and Navigating Through Files’
section later in this chapter.

i) Find

Click thisbutton if you want to find a certain text string in the current file. It invokes a find dialog box where
you can specify the search parameters.

iy Find Next
Finds the next occurrence of the current search string.

'@a Find Previous

Finds the previous occurrence of the current search string.

424 Bookmarks Toolbar Buttons

) Toggle Bookmarks

Sets abookmark at the current line or clears abookmark at the current line.
& Next Bookmark

Jumps to the next bookmark in the current file from the current line.

ﬁﬁ Previous Bookmark

Jumps to the previous bookmark in the current file from the current line.

B Clear All Bookmarks

Clears all bookmarksin the current file.

425 Templates Toolbar Buttons
‘I’ Define Template
Specify template text for subsequent insertion.

T Insert Template

Insert the template selected in the drop-down list at the current cursor position.
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4.3 Standard File Operations

431 Creating a New File

2 Tocreate anew editing window:
Select [File->New] or click the new file toolbar button ([1) or press CTRL +N.

The window will be given an arbitrary name by default. You can provide a new name when you save the file.

432 Saving aFile

2 To save the contents of an editing window:
1. Ensure that the window, whose contents you want to save, is the active window.
2. Select [File->Save] or click the save file toolbar button (i) or press CTRL +S.

3. If thefile has not been saved before, afile save dialog box will be displayed. Enter a filename, specify a
directory and then click OK to create the file with the name given, in the directory specified.

4. |f thefile has been saved before, then the file will be updated (no dialog box will be displayed).
2 To savethe contents of an editing window under anew name:

1. Ensure that the window, whose contents you want to save, is the active window.

2. Select [File->Save As...].

3. Afilesavedialog box will be displayed. Enter a filename, specify a directory and then click OK to create
the file with the name given, in the directory specified.

433 Saving all Files

2 To save the contents of every open editor window:
1. Select [File->Save All] or click the save all files toolbar button ().

2. If any of thefiles has not been saved before, afile save dialog box will be displayed. Enter a filename,
specify adirectory and then click OK to create the file with the name given, in the directory specified.

3. If any of thefiles have been saved before, then the file will be updated (no dialog box will be displayed).
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434 Openinga File

2 Toopenafile:

1. Select [File->Open...] or click the open file toolbar button (&) or press CTRL +O.

2. Anopen file dialog box will be displayed. Use the directory browser (on the right) to navigate to the
directory in which the file you want to open islocated. Use the “Files of type” combo box to select the
type of file you want to open (or set it to “All Files (*.*)" to see every filein adirectory).

3. Onceyou havelocated the file select it and click “Open”.

The High-performance Embedded Workshop keeps track of the last four files that you have opened and adds
them to the file menu under the “Recent Files’ sub-menu. This gives you a shortcut to opening files which you
have used recently.

2 Toopen arecently used file:
Select the [File->Recent Files] menu option and from this sub-menu select the desired file.

Y ou can also open afileviathe “Projects’ tab of the “Workspace” window. Either double click the file you want
to open or select it, click the right mouse button (to invoke a pop-up menu) and then choose the [Open <file>]
menu option (where <file> isthe name of the file selected).

435 Closing Files

2 Tocloseindividual files select one of the following methods:
1. Double click on the editor window’ s system menu (located at the top left of each window when not
maximized).
2. Click on the editor window’ s system menu (located at the top left of each window when not maximized)
and select the “Close” menu option.
3. Ensure that the window that you want to close is the active window and then press CTRL +F4.
4. Ensure that the window that you want to close is the active window and then select [File->Close].
5. Click on the close button (located at the top right of each window when not maximized).
2 Tocloseal windows at once:
Select [Window->Close All].
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4.4 Editing a File

The High-performance Embedded Workshop editor supports standard editing functionality. Thisis available
through the usual methods (i.e. the menu, toolbar and keyboard shortcuts) and is additionally supported viaa
pop-up menu (or local menu) that islocal to each editor window. To invoke it, place the pointer in an open

window and click the right mouse button. Table 4.1 outlines the basic operations that are provided by the editor.

Table4.1 Basic Editing Operations
Operation Effect Action
Cut Removes highlighted text and places it on the Click the cut toolbar button
Windows® clipboard Select [Edit->Cut]
Select [Cut] - local menu
Press CTRL+X
Copy Places a copy of the highlighted text into the  Click the copy toolbar button
Windows® clipboard Select [Edit->Copy]
Select [Copy] - local menu
Press CTRL+C
Paste Copies the contents of the Windows® Click the paste toolbar button
clipt_)pard into t_he ac?ive window at the Select [Edit->Paste]
position of the insertion cursor
Select [Paste] - local menu
Press CTRL+V
Delete Removes highlighted text (it is not copied to  Select [Edit->Clear]
the Windows® clipboard) Select [Clear] - local menu
Press Delete
Select All Selects (i.e. highlights) the entire contents of  Select [Edit->Select All]
the active window Select [Select All] - local menu
Undo Reverses the last editing operation Select [Edit->Undo]
Select [Undo] - local menu
Press CTRL+Z
Redo Repeats the last “undone” editing operation Select [Edit->Red0]

Select [Redo] - local menu
Press CTRL+Y
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4.5

Sear ching and Navigating through Files

The High-performance Embedded Workshop editor provides find, replace and file navigation functionality. The
following three sections detail how to use these features.

451

Finding Text

2 To search for text in the current file:

1
2.

3.

Ensure that the window, whose contents you want to search, is the active window.
Position the insertion cursor at the point from which you want to start your search.

Select [Edit->Find...], press CTRL +F, select [Find...] from the editor window’ s local menu or click the
find toolbar button (#]). The“Find” dialog box will be displayed (figure 4.2).

Find EHE

Find what: |string 2 Find Next |
[ Match whole word only Direction——— Cancel |

[ Match case ' Up
& Down

[ Regular expression

9.

Figure4.2: Find Dialog

Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find what” field.
If you would like to search for character string as a whole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to
Appendix B, “Regular Expressions’ for further information.
The “Direction” radio buttons allow you to select the direction of the search. Selecting “Down” means
that the search will be performed from the insertion cursor towards the bottom of the file. Selecting “ Up”
means that the search will be performed from the insertion cursor towards the top of the file.
Click the “Find Next” button to begin the search. Click “Cancel” to stop the find action.

The High-performance Embedded Workshop editor also allows you to search for a string across many files.
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452

Finding Text in Multiple Files

2 Tosearch for text in many files:

1.

Select [Edit->Find in Files...], select [Find in Files...] from the editor window’ s local menu or click the
find in files toolbar button (). The “Find in Files’ dialog box will be displayed (figure 4.3).

Find In Files E E2

Find: IM wStruct find

Cancel

In filesfypes: I".c;".cpp;".er:p;".fs_l,J;".h;".hpp;".inc;".lis;".lp -

ik

Directary Ic: Whewt demaohdemno Browse...

[ Match case ¥ Search sub directories

[ Regular expressions

Figure 4.3: Find in Files Dialog

Enter the text that you want to search for into the “Find” field, or select a previous search string from the
drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find” field.
Enter the file extensions of the files you would like to search into the “In files/types’ field. If severa
extensions are specified be sure to separate them with a semicolon (e.g. *.c;*.h).
Enter the directory in which you would like to search filesinto the “ Directory” field. Alternatively you
may browse to the desired directory graphically if you click the “Browse...” button.
If you would like to search the directory specified and all directories below it then check the “ Search sub
directories’ check box. If you just want to search the single directory specified in the “Directory” field
then ensure that this check box is not checked.
If you would like to search for character string as a whole word then check the “Match case’ check box.
When this option is not selected, the search will be for any string that is matched by the search string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
Click “Find” to begin the search. Any matches found will be displayed in the “Find in Files’ tab of the
“Output” window. To jump to an instance of the string, double click on the desired entry in the “ Output”
window.
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453 Replacing Text

Replacing text is similar to finding text, as discussed in the previous section. The difference is that when the text
is found you have the option to replace it with other text.

2 Toreplacetextin afile:

1. Ensure that the window, whose contents you want to replace, is the active window.

2. Position theinsertion cursor at the point from which you want to start your search.

3. Select [Edit->Replace...], press CTRL +H or select [Replace...] from the editor window’s local menu. A
replace diaog box will be displayed (figure 4.4).

4. Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the replace operation, the selected text will
be automatically placed into the “Find what” field.

5. Enter the text that you want to replace the search string with into the “ Replace with” field, or select a
previous replace string from the drop-down list box.

21

Find what: |String LI Find Mewxt I
Replace with: |numeric =] Feplace |
[~ Match whale ward anly Replace In———— Replace All |

[~ Match case = Selection

[~ Reeular expression i+ Whale file Cancel |

&l open files

Figure 4.4: Replace Dialog

6. If you would like to search for character string as awhole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.

7. 1f you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.

8. If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to
appendix B, “Regular Expressions’ for further information.

9. If youclicked “Find Next”, the editor will search for the first occurrence of the search string. Click
“Replace” if you want to replaceit. Click “Replace All” to replace all occurrences or click “Cancel” to
stop the replace action. If you select “ Selection” in “Replace In”, selected range of the text is replaced. If
you select “wholefile”, the whole files are replaced. If you select all open files, all filesthat are
currently open in the editor have the replace operation carried out on them.
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454

Jumping to a Specified Line

2 Tojumptoalineinafile

1
2.

Ensure that the window, whose contents you want to replace, is the active window.

Select [Edit->Goto Line...], press CTRL+G. or select [Goto Line...] from the editor window’s local
menu. A goto line dialog box will be displayed (figure 4.5).

Enter into the dialog box the number of the line that you want to go to, and then click “OK”.

The insertion cursor will be placed at the start of the line number specified.

Line number |1
ak I Cancel |

Figure 4.5: Goto Dialog
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4.6 Bookmarks

When working with many large files at atime, it can become difficult to locate specific lines or areas of interest.
Bookmarks enable you to specify lines that you want to jump back to at a subsequent time. One example of its
useisin alarge C file where you may want to set a bookmark on each function definition. Once a bookmark has
been set, it exists until it is removed or thefileis closed.

°

To set abookmark:
1. Placetheinsertion cursor on the line to mark.
2. Select [Edit->Bookmarks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->T oggle Bookmark] from the local menu or click the toggle bookmark toolbar button (& ).

3. A green mark appearsin the blank on the left side of the line to indicate the presence of an active
bookmark.

To remove a bookmark:

1. Placetheinsertion cursor on the marked line.

2. Select [Edit->Bookmarks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->T oggle Bookmark] from the local menu or click the toggle bookmark toolbar button (&3 ).

3. The mark will be removed and the line will return to normal text.

To jump to the next bookmark in afile:

1. Ensurethat the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmarks->Next Bookmark], press F2 or select [Bookmarks->Next Bookmark] from
the local menu or click the next bookmark toolbar button ( |ffi ).

To jump to the previous bookmark in afile:

1. Ensurethat the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmar ks->Pr evious Bookmark], press SHIFT+F2 or select [Bookmar ks->Previous
Bookmark] from the local menu or click the previous bookmark toolbar button ( |§.‘| ).

To remove al bookmarksin afile:

1. Ensure that the window, whose bookmarks you want to remove is the active window.

2. Select [Edit->Bookmarks->Clear All Bookmarks] or select [Bookmar ks->Clear All Bookmarks]
from the local menu or click the clear all bookmarks toolbar button ( ] ).

4.7 Printing a File

°
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Toprint afile:
1. Ensure that the window, whose contents you want to print, is the active window.
2. Select [File->Print...], or click the print toolbar button (&) or press CTRL +P.
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4.8 Configuring Text Layout

The following sections detail how to set-up the layout of the text within the editor windows.

481 Page Set-up

When you print afile from the High-performance Embedded Workshop editor, the settingsin the print dialog
box affect the way in which the file is printed (e.g. double or single sided). Control over how thetext is
formatted on the page can a so be controlled via the page set-up option. This allows you to specify the margins
(top, bottom, left and right) of your printouts. It is often necessary to set this because some printers cannot print
to the edges of an A4 page. Furthermore, some users have their own layout requirements (e.g. alarge left hand
margin so that code can be placed in an A4 binder).

2 To set-up the page margins:
1. Select [File->Page Setup...]. The“Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the edit fields the margins required (set the “inch” or “mm” radio buttons to set the
measurements).

3. Click “OK” for the new settings to take effect.

td arging

Lt [@ Bgh: [0
Top: ID— Bottom: ID—

' |nch " mm
Header:
i
Footer:
| i
¥ ‘wiap Text

ak I Cahicel |

Figure 4.6: Page Setup Dialog
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2 To set-up the page header and footers:

1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the header and footer edit fields the text required to be displayed. All norma placeholders are
available along with page numbering, text justification and date fields. These are al expanded before
the page isto be printed.

3. Click “OK” for the new settings to take effect.

2 To set-up print wrapping
1. Select [File>Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).
2. Click the wrap text check box. This switches on the wrap text facility when printing so no text is
truncated and everything isvisible.
3. Click “OK” for the new settings to take effect.
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482 Changing Tabs

2 Tochangetab size:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7)).
2. Enter into the“Tab size” field the number of desired tabs.
3. Click “OK” for the tab setting specified to take effect.

2|

Build ~ Editor |W0rkspace Confirmationl Networkl

— Spacing:

Use spaces as tabs Tab size: | G

v Enable auto indentation

- General:
¥ Save files before executing any tocls [v Show files in notebook
™ Prompt before saving files [¥ Enable syntax caloring
[V Enable Smart-edit for C++ files [V Enable taoltip watch

r— External editar:

™ Use extemal editar:

| Hadify.. |

(]4 I Cancel

Figure 4.7: Options Dialog Editor Tab

When aTAB key is pressed in the editor atab character isusually stored in the file. However, sometimesitis
preferable to store spaces instead. The representation of tab characters can be controlled viathe “ Options” diaog.

2 To use spaces as tabs:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Setthe “Use spaces astabs’ check box as appropriate.
3. Click “OK” for the tab setting specified to take effect.
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483 Auto Indentation

When you press return in a standard editor the insertion cursor will move to the next line down, at the first
column (i.e. against the left hand side of awindow). Auto Indentation is a feature which, when return is pressed,
places the insertion cursor on the next line (as before) but under the first non-white space character of the
previousline. This enables you to type neat C/C++ or assembler code faster as you don’'t have to type leading
spaces or tabs yourself.

Figure 4.8 illustrates two examples. Thefirst (i) shows the effect of pressing return when the auto indentation
feature is disabled - the insertion cursor returnsto the left-hand side of the window on the next line. When the
line“int z=20" istyped, it is not aligned with the previous two lines. The second example (ii) shows the effect of
pressing return when auto indentation is enabled - the insertion cursor drops underneath the “i” of the previous
line. Now, when theline “int z=20" istyped, it is automatically aligned (i.e. automatically indented).

void myfunction{void)
{
int x=5;
inty=10;
=

int z=20;

void myfunction(void)
{
int x=5;
inty=10;
LA
int z=20;

i) Auto Indentation Disabled

ii) Auto Indentation Enabled

Figure 4.8: Effect of Auto Indentation

2 To enable/disable Auto Indentation:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable auto indentation” check box accordingly.
3. Click “OK” for the setting of the auto indentation check box to take effect.
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4.9 Splitting a Window

The High-performance Embedded Workshop editor allows you to split atext window into two. Figure 4.9 shows
the split bar button which islocated just underneath the maximize button at the top right hand corner of any text
window.

Figure4.9: Split Bar Button

2 To split awindow:
Double click on the split bar button to split the window in half or click on the split bar button, keep the button
pressed, move the mouse down and then release the mouse button at the point you want to split the window.

2 To adjust the position of the split bar:

Click on the split bar itself, keep the button pressed then move the bar to the new position and then release
the button.

2 Toremove the split bar:
Double click on the split bar or move the split bar to the top or bottom of the window.
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410 Configuring Text

The following sections detail how to change the appearance of the text displayed in the editor windows.

410.1 ChangingtheEditor Font

The High-performance Embedded Workshop allows you to specify the font to be used in itsinternal editor. All
editor windows, regardless of thefile type, use the same font.

2 To change the editor font:

1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed. Select the Source icon
in the tree (figure 4.10).

2. Select the desired font from the “Font” list.
3. Select the size of the font from the “ Size” list.
4, Click “OK” to confirm the new editor settings.
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Figure 4.10: Format Views Dialog Font Tab

86
RENESAS




411  Syntax Coloring

To enhance code readability, the HEW editor can display specific strings (i.e. keywords) in different colors. For
instance, C source code comments could be shown in green and C types (e.g. int) could be shown in blue.

The coloring method used can be specified on afile group by file group basis. For example, you can define
different color schemes for a C sourcefiles, text files, map files or even your own files.

2 Tochange existing colors:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.
2. Select theitem underneath theicon in the tree you wish to modify the colour for. This should be the file
type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-processor).
3. Select the“Colour” tab.

4. Modify the “Foreground” and “Background” color lists as desired. The color “SYSTEM” refersto the
current window foreground and background settings in control panel.
5. Click “OK” for the new colors to take effect.

2 To create new keyword groups:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.
2. Select thefile typein the tree to which you wish to add the new keyword group.

3. Click “Add..."” underneath the tree. The “ Add Category” dialog box will be displayed (figure 4.11). Enter
the name of the keyword group in the “ Category Title” field, then click “OK” to create the new keyword

group.

Add Category HE

Categony Title: 0k I
fi
Cancel |

Figure 4.11: Add Category Dialog

2 To create new keywords:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.

2. Select theitem underneath the source view icon in the tree you wish to modify the syntax highlighting
for. This should be thefile type (e.g. C source file) and correct keyword group (e.g. identifier or pre-
processor).

3. Select the“Keywords’ tab (figure 4.12).
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Figure 4.12; Format Views Dialog K eywords Tab

4. Click the“Add...” button to add a keyword. Then the “ Add Keyword” dialog (figure 4.13) will be
launched. Specify akeyword in the “Keyword” field and click “OK” to close the dialog. To remove a
keyword, select the keyword and click the “Remove” button.

Add Kepword EHE

Kewward:
I Cancel |

Figure 4.13: Add Keyword Dialog

When you create anew file, syntax coloring will not be active as anew file does not initially have an extension
(new files are named arbitrarily by the editor without an extension). In order to activate syntax coloring, you
must save the new file with a name, which has one of the above extensions.

2 To disable/enable syntax coloring:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Setthe “Enable syntax coloring” check box as necessary and then click “OK”.
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412 Templates

When developing software it is often necessary to enter the same text repeatedly, for instance, when typing a
function definition, for loop or acomment block for afunction. The High-performance Embedded Workshop
editor allows you to specify ablock of text (or template), which can be inserted into the currently active editor
window. Thus, once atemplate has been defined, it can be automatically inserted without the need to re-enter it
manually.

4121 Defining a Template

2 Todefine atemplate:
1. Select [Edit->Templates>Define Templates...], select [Templates->Define Templates...] from the
local menu, or click on the define template toolbar button ( I ). The dialog shown in figure 4.14 will be
displayed.

Define Templates

;I Cancel

Bemove

f Lt

Uszer [nput

-

Kl
Shartcuts:

| rr

Figure 4.14: Define Template Dialog

2. Click “Add". A dialogisdisplayed that asks you to enter your chosen template name. This name must
be unique otherwise a duplicated template name message will be displayed and the template will not be
added.

3. If you want to modify an existing template use the “ Template name” drop down menu to select which
template you want to modify.

4. Enter thedesired text into the “ Template text” text area. Y ou can copy text from another editor window
and then pasteit into thisdialog using CTRL +V.

5. There are 10 shortcut keys reserved for templates. |f you want to designate one of these select the key in
the drop list at the bottom of the edit template dialog. These range from CTRL+0 to CTRL+9.

6. Enter the following placeholder to insert specia information when the template is inserted:
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Table4.2 PlaceholdersUsed in Templates

Menu Entry

Placeholder

Replaced With

File path + name

$(FULLFILE)

Filename (including full path)

File name $(FILENAME) Filename (excluding path including extension)
File leaf $(FILELEAF) Filename (excluding path and extension)
Workspace name $(WORKSPNAME) Workspace name

Project name $(PROJECTNAME) Project name

Line number $(LINE) First line number of template insertion

Time $(TIME) Current time

Date, text $(DATE_TEXT) Current date in text form

Date, day/month/year

$(DATE_DMY)

Current date, in dd/mm/yy form

Date, month/day/year

$(DATE_MDY)

Current date, in mm/dd/yy form

Date, year/month/day

$(DATE_YMD)

Current date, in yy/mm/dd form

User name

$(USER)

Current windows user

Cursor position

$(CURSOR)

Insertion cursor — Positions the cursor in this
position after template has been inserted

7. Enter the $(CURSOR) character to specify where the insertion cursor isto be placed after the template
has been inserted. If thisis not specified then the insertion cursor will be placed after the last character in
the template (asin anormal paste operation).

User Input

When defining atemplateit is possible to define a user input field. Using the following placehol der specifies
this $(USERINPUT<n:1-10>|" <some text>"). The nisanumber, which identifies the user input identifier.
These placeholders can be added manually but the user input button on the define templates dial og adds these
placeholdersin an automated manner. When the template isinserted into afile adialog is displayed which
alows you to enter some custom text for each of thesefields. Thistext is then inserted instead of the
placeholder. You can define ten of these user input fields.

Figure 4.15 shows alist of templates, which islocated on the “ Templates’ tab of the “Workspace” window.
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Figure 4.15: Templatesview

Any new templates, which have been added to the HEW, are displayed under the templates folder. The
toolchain templates folder is for templates, which are read only and have been provided for use in the HEW
system by the current toolchain. Templatesin thisview can be dragged for insertion into an editor file. Itisaso
possible to drag an area of text from the editor into the templates folder for quick template creation. Right
clicking on this view displays a pop-up so that you can quickly add a new template, remove the current selection
and edit the current selection.

4122 Deleting a Template

2 Todeeteatemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu or click on the define template bookmark toolbar button ( “Ir ). The dialog shown in figure
4.14 will be displayed.

2. Usethe Template name drop down list to select the name of the template you wish to remove and then
click the “Remove” button.

3. Clicking “OK” saves the template changes and dismisses the dialog.
4123 Insertinga Template

2 Toinsert atemplate:

1. Select atemplate in the toolbar, then click the insert template toolbar button (T ), select [Edit->
Templates->Insert Template...] or select [Templates-> | nsert Template...] from the loca menu. The
dialog is dismissed and the chosen template is added to the current editor window.

Note: It isalso possibleto use the defined keyboard shortcut or drag the template from the templates
view.
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4124 BraceMatching.

Complicated source code can often become unwieldy, especially when blocks of C code are deeply nested within
each other or when complex logic statements are expressed within an ‘if’ clause. To help in such situations, the
High-performance Embedded Workshop editor provides a match brace feature which highlights text between
bracesof type{ }, () and[].

2 Tofind amatching brace:
1. Either highlight the open brace to match from or place the cursor beforeiit.

2. Click the match braces toolbar button (1 1), press SHIFT+CTRL +M, select [Edit->Match Braces] or
select [Match Braces] from the local menu.

To check the structure of an entire file, place the cursor at its start and then repeatedly invoke the match brace
operation. The editor will successively highlight each pair of bracesin turn until there are no more to match.
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413  Editor Column management

The editor in HEW has the ability to manage columns apart from the main editor column. These can be added
and used by debugger feature. Y ou can choose the column to display/undisplay.

«#- tutorial.c —10l x|
#include <no_float.h> ZI
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
void main{void);
void sort{long =a);
void change({long *a);
extern void srand{unsigned int);
0x00000alc void main(void)
0=00000a16
long a[18], min, max;
long j;
int i;
0x00000a18 srand(1);
0=00000a20 | printf("### Data Input H#H#\n");
0x00000aZc for{ 1=0; i€18; i++ )¢
0x00000azZe j = rand{};
0x00000a36 if(j < )¢
0=00000a38 i=-i;
0=00000a3a alil = j;
0=00000a44 printF("a[%d]=%1d\n",i,a[i]);
H
0x00000a62 sort(a);
0x00000a66 printf (=== Sorting results =xx\n");
0=00000a72 For{ i=B; i<18; i++ )¢
0=00000a7 4 printf("a[%d]=%1d\n",i,a[i]);
H -
" i mrA1. i

Figure 4.16: Editor columns

2 Toswitch off acolumnin al sourcefiles:
1. Right click on the editor window.
2. Click the “Define Column Format...” menu item.
3. The“Globa Editor Column States” dialog is displayed (figure 4.17).
4

The“Check status’ shows whether the column is enabled or not. If itischecked it is enabled if the
check box is gray this means that in some files the column is enabled and in other filesit is not.

5. Click “OK” for the new column settings to take effect.

2 To switch off acolumn in one source files:
1. Right click on the editor window, which you wish to remove a column from, and the editor pop-up is
displayed.
2. Click the Columns menu item and a cascaded menu item appears. Each column isdisplayed in this pop-
up menu. If the column isenabled it hasatick next to itsname. Clicking the entry will toggle whether
the column is displayed or not.
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Global Editor Column States

[w] Coverage
[w] E ditar
[w]Source Address

Cancel |

Figure 4.17: Global column state Dialog

414  Enabletooltip watch

Select [Tools->Options...] and then select the “Editor” tab (figure 4.7). By checking “Enable tooltip watch”,
you can use the Tooltip Watch feature, the quickest way to look at a variable in the source program.

2 Toview atooltip watch on the Editor window:
1. Display the source file containing the variable that you want to examine on the Editor window (figure

418).

2. Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near the
variable showing avalue of that variable.

0x00002 054 sort (&) ; ZI
0x0000205a printf ("*** Sorting re:
0x0000Z066 for( i=0; i<10; i++ ) {
0x0000Z06e printf (Malsd] =% 1dy:
i

0x0000zZ090 mip==l0l -
Ox00002092 e 2X00000000 J
0x0000zZ094 min = 0;
Ox0000z2096 max = 0;
0x00002095 change (a) ;
0x=x0000209e min = al[9]:;
0x=x00002 00 max = al0];

-
[« ;IJ

2 democ I

Figure 4.18: Viewing a tooltip watch
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5. Tools Administration

Y ou control the components, which can be used by the High-performance Embedded Workshop viathe “Tools
Administration” dialog (figure 5.1), which isinvoked via [Tools->Administration...]. Modification of the
“Tools Administration” dialog box is only possible when no workspace is open, while only reference is possible
when aworkspace is open.

Tools Administration EE3

Regiztered components:

(1] 4 I
Component Werzion ﬂ Cancel |

=L

Ela Syztem Toolz .
[ta] Call'walker 11 Begister... |

&g H Series Librarian Interface 11 ;
) Mapview 10 Wrireister |
----- (23 Utility Phases :
B3 Debugger Components ﬂl
# Binary File Object Reader 1.0 ot |
ElfCvwarf2 object reader 20 =
Generic Cache \-"iewl ECH 1.0 Search disk.. |
Generic Coverage Wiew ECX 1.0
P Generic Event View ECX 1.0 Toal infnrmatinn...l
Generic Image Wiew ECH 1.0

-
= = msemrne [0S i B0 1n i
« [ ¥ Uninstaller... |

™ Show all componets

Current HE™ tools databaze location:

Il::'\Hew Fadify. |

Figure5.1: Tools Administration Dialog
There are five standard types of component:

¢ Toolchains - aset of build phases (e.g. compiler, assembler, and linker). These components provide the build
capability.

« System Tool - an application (.EXE), which can be launched from the “Tools” menu. They are often
provided as extra applications, which support the toolchain (e.g. an external debugger like the Hitachi
Debugging Interface (HDI) or an interactive graphical librarian).

« Utility Phase - a“ready made’ build phase which supports some specific build functionality (e.g. analyze
complexity of source code, count lines of source code, etc.). These components provide added functionality
to the build that is not toolchain specific.

« Debugger Component —acomponent that supports some specific debugger functionality (e.g. Target
platform, Object reader, etc).

¢ Extension Component —acomponent that provides key functionality in a certain area of the HEW system.
These components cannot be unregistered when installed (e.g. The HEW builder, debugger and flash
support).
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5.1 Tool Locations

The HEW maintains the locations of HEW compatible components automatically as each new tool isinstalled.
After installation, the HEW stores information about the component (including its location) — thisis referred to
asregistration. Although initial registration is automatic, during the course of development or if you want to
manage the tools being used in your projects more effectively, you may need to register components yourself.
The remainder of this chapter discusses registration and how it affects you.

52 HEW Registration Files (*.HRF)

When a HEW compatible component (i.e. toolchain, system tool or utility phase) isinstalled, part of its
installation will include afile with the extension .HRF (figure 5.2.i). Thisfile, named a“HEW Registration File”,
describes the component to the HEW. The process of registration refers to loading a component’s .HRF file into
the tools administration dialog (figure 5.2.ii).

i. INSTALL ii. REGISTER
%7 cA cA
MyTool MyTool
MYTOOL.HRF D MYTOOL.HRF [
. ’ HEW
bin E bin
E etc e etc
help help

Figure5.2: HRF File Location and Registration

In order to use a component with HEW it must first be registered. The “Tools Administration” dialog (figure 5.1)
shows al currently registered components. To accessit, ensure no workspaces are open and then select
[Tools->Administration...]. If you attempt to access tools administration when there is a workspace open the
tools administration dialog is opened but cannot be modified. When HEW isingtalled by default any new tools
are automatically registered.

HEW storestool information in atool database file. By default thisis created in the HEW application directory,
however if you are working in a network environment this directory may be set to another location. Itispossible
to change the tool directory location.

2 To change the toolslocation:

1. Select [Tools->Administration...].

2. Click the“Modify” button for the “ Current HEW tools database location” field.
3. Select the directory under which the new tool is located, then click “OK”.
4

Thiswill switch the directory and change the tool location to the new directory. It will be necessary to
scan for any new toolsthat may bein thislocation thisis achieved by using the scan disk or register tool
functionality.
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53 Registering Components

The HEW will automatically attempt to register any new components installed since the last time it was invoked.
However, in some circumstances you may need to register components yourself.

531 Sear ching Drives for Components

In some casesit is useful to search adrive for HEW compatible components. Thisis especially useful if the
HEW installation was deleted or corrupted as it can recreate your tool information instantly.

2 To search for components:

1. Click the“Search Disk...” button on the “Tools Administration” dialog (figure 5.1). The “ Search Disk for
Components’ dialog will be displayed (figure 5.3).

omponents
o . Close
Select the directony in which to begin the search:
IDZ'\HBW3 Browsze.
W Include subfalders Start

Located components:

Carmpanent Wersion | HAF Location = Register
Generic TCL Toolkit Wiew ECH 1.0 DV H =l

i Hfrs

HewT argetServer 1.0 [ Hew 4S5 pster Reaister Al
SuperH RISC engine Standard Toolchain 20,10 DoAHew3WToolsh
b aprvig 1.0 DA Hew 4 Toolsh
H Series Librarian Interface 11 DA Hewz\Toolsh
H&5.H8/300 Standard Toolchain E.01.0  DAHew3\Toolsh

Call i alker 11 D:'\Hew3\TDDE\IILI
1| | 3

Search Statuz: 51 file(z] found

Figure 5.3: Search Disk for Components Dialog

2. Enter thedirectory in which you would like to search into the top field or browse to it graphically by
clicking the “Browse...” button.

3. Check the “Include subfolders” check box if you would like to search the directory specified and all
directories below it.

4. Click the “Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.

5. Theresults of the search are shown in the “Located components” list. Select a component and click
“Register” to register anindividua component or click “Register All” to register all located components.

6. Click “Close” to exit the dialog.
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532 Registering a Single Component

The HEW alows you to navigate directly to a single component in order to register it. The HEW Registration
File (*.HRF) islocated in the root directory of a component’sinstallation.

2 To register acomponent:
1. Click the“Regigter...” button on the “Tools Administration” dialog. A standard file open dialog will be
launched with itsfile filter set to “HEW Registration Files (*.hrf)".
2. Navigate to the .HRF file of the component you would like to register, select it and then click “ Select”.
3. A dialog will be invoked which displaysinformation regarding the selected tool. Click “Register” to
confirm that you want to register the tool or click “Close” to abort the operation.

54 Unregistering Components

The components, which are registered with the HEW, affect the way in which it behaves. For example, every
compatible system tool, which is registered, will be added to the tools menu when anew project is created.
Sometimes this may not be desirable. If so, open the “Tools Administration” dialog, select the component from
the “Registered components’ list and then click the “Unregister” button. A dialog will be invoked which asks
you to confirm this action. Click “Yes’ to confirm the action.

Note:  Unregistering a component does not remove itsinstallation from hard disk. It smply removes the
information, which the HEW was storing about that component (i.e. it “disconnects’ it from the HEW).
The action can be easily reversed at anytime by registering the tool (see above). If you want to remove a
component from the hard disk (i.e. uninstall a component) then refer to the section “Uninstalling
Components” later in this chapter.
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55  Viewing and Editing Component Properties

To view information regarding a component, select it from the “ Registered components” list and then click the
“Properties’ button. The properties dialog will be displayed with the “ General” tab selected (figure 5.4). Thistab

displays the name, version and location of the selected component. None of the information on thistab is
editable.

SuperH RISC engine Standard Toolchain 8.0, 1.0 Propert 2 x|
General | Information | Ervironment

Marme : SuperH RISC engine Standard Toolzchain
Yergion 8.01.0

Location : D Hew 4 Tools\RenesazhShha_0 1

Cancel |

Figure 5.4: Properties Dialog General Tab

Select the “ Information” tab to view any information about the component (figure 5.5). This may include
copyright information, enhancements, bug fixes, user notes and so on.

SuperH RISC engine Standard Toolchain §.0.1.0 Properk llil

General  Infarmation | Emvironment

Infiormation:

High-perfarmatnice Embedded Workshop ﬂ
SuperH RISC engine Standard Toolchain [Ver. 8.0.1.0]

SuperH RISC engine C/C++ Library Generator [Ver. 3.0.01)
SuperH RISC engine CAC++ Compiler MvWer, 3.0.02]

Cancel |

Figure5.5: Properties Dialog I nformation Tab

Notethat if the tool has a compatibility issue the problem may be reported in this information edit field.
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Select the “Environment” tab, if it exists, to view and edit a component’ s environment settings (figure 5.6). This
dialog is most commonly used to modify the environment of atoolchain.

SuperH RISC engine Standard Toolchain &.0.1.0 Prop ﬂﬂ

General | Information  Enviranment

Ervironment variables:

PATH=D:"HewToolz\RenezashShy8_0_1\bin
SHC_IMC=D:\Hew3h T oolshRenezazhShh8_01kinchude
SHC_LIB=D:"Hew3\T oolz\FenesashShi8_0_1%bin
SHC_TMP=CADOCUME~TVADMINI1ALOCALS ~1 5T emp

N I i
ak I Cancel |

T odifi..

it

Femove

Figureb5.6: Properties Dialog Environment Tab

To add anew environment variable, click the“Add...” button (the dialog shown in figure 5.7 will be invoked).
Enter the variable name into the “Variable” field, the variable'svalue into the “Vaue” field and then click “OK”
to add the new variable to the “ Environment” tab. Placeholder pop-up menus are included to ensure that the
environment can be specified as flexibly as possible. For adetailed description of placeholders see appendix C,
“Placeholders”.

To modify an environment variable, select the variable that you want to modify from the “ Environment” tab and
then click the “Modify...” button. Make the required changesto the “Variable” and “Vaue” fields, and then
click “OK" to add the modified variable to the “ Environment” tab. To remove an environment variable, select it
and then click the “Remove’ button.

Environment ¥ariable

" ariable:
e
Cahicel |

Ic:'\dos,‘c:'\m_l,ltools,'c:\windows;c:'\temp [ 3 I| gﬁiﬁgﬁ;

Walue:

Figure5.7: Environment Variable Dialog
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5.6 Uninstalling Components

The HEW provides a built in uninstaller method, which can remove unregistered components.

2 Touninstall acomponent:

1. Select [Tools->Administration...].
2. Click ontheuninstaller button. The “Uninstall HEW Tool” dialog isinvoked (figure 5.8).

Uninstall HEW Tool

Select the directory in which to begin the search for bools;

W Include subfalders Start

Located Toalz which can be uninstalled:

Close

Browse. .

Companent

| Wergion | Inztallation Directorny Wriratall

1

| HE

Search Status:

[dle

Figure5.8: Uninstall HEW Tool

3. Enter thedirectory in which you would like to search into the top field or browse to it graphically by

clicking the “Browse..

." button.

4. Check the “Include subfolders’ check box if you would like to search the directory specified and all

directories below it.

5. Click the “Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.

6. Theresults of the search are shown in the “Located Tools which can be uninstalled” list. Select a
component and click “Uningtall” to uninstall acomponent.

7. Click “Exit” to exit the dialog.

A component may only be uninstalled if it isnot currently registered with the HEW. If you attempt to uningtall a
tool, which is registered, then the dialog shown in figure 5.9 will be displayed. In such acase, you must return to
the “Tools Administration” dialog via[Tools->Administration...], unregister the tool and then invoke the tool

uninstaller again.
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High-performance Embedded Work shop

&L

Hitachi SuperH RISC engine Standard Toolchain 7.1. 2.0 is cunently regiztered; pou may not uninstall a tool that is registered with HE W,

Fleage uge the adminiztration dialog to unregister the Tool.

Figure5.9: Unable to Uninstall Tool

If atoal is not registered with the HEW then the dialog shown in figure 5.10 will be displayed when the
“Unregister” button is clicked. This confirmation diaog displays al of the files and folders that will be deleted.
If you are certain that these files and folders can be deleted then click the “Yes” button. To abort the uninstall
click the “No” or “Cancel” buttons.

Confirmation

The fallowing files and folders will be deleted:

c:\hewh T oolchaingHitachib SHYS1 Dhshe toalchain, hif
c:hhewh T oolchains\HitachihSHYAT 0Vzample
c:\hewhT oolchaingHitachibSHYA1 Dhinclude:

cMhews T oolchainghHitachibSHYET 0B

c:\hewh T oolchaingHitachit SHYS1 04bin

o Mhewh T oolchainghHitachib SHYET Dhew

c:\hewh T oolchaingHitachit SHYS1 D\binhdwicry.exe
cMhewh T oolchainghHitachibSHYET Dhbintashe, exe
c:\hewhT oolchaingHitachib SHYS1 D\binhshcasm.exe
c:hhewhT oolchains\HitachihSHYS1 0%binhshoerr. mag
c:\hewhT oolchaingHitachib SHYS1 D\binhshcerr, off
cMhewh T oolchainghHitachibSHYET Dibintsheit exe

= \hewh T oolchaingdHitachit SHYET D4bintzhogen. exe
c:hhewh T oolchains\HitachihSHYS1 0%binhshchlp. mzg
c:\hewh T oolchaing'Hitachit SHYS1 0\binhshemd]. exe
c:hhewh T oolchains\HitachihnSHYAT 0Mbinhshopep. exe

Are you sure you want to delete the above files and folders?

|

Cancel |
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Figure 5.10: Confirmation Dialog
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5.7

Technical Support Issues

The “Tools Administration” dialog is also capable of displaying information regarding “hidden” system
components. These are part of the HEW itself that cannot be unregistered/registered manually. If you check the

“Show all components’ check box on the tools administration dialog, extra component folders are displayed (see
figure 5.11).

Toolz Adminiztration

Regiztered components:

(2] Estension Components

----- 3 Communication Tools

- Svstem Extension Components
-7 Project Generators

----- 3 Project Generators - Custom
[—]a Wergion Control System

Custom VS 20
Microzaft Visual SourceS afe 5.0/6.0 30
223 Toolchain Support

%] HBS5 HE/300 Toolchain Supporter 258 =

in S upporter

¥ Show all components

Current HE™ tools databaze location:

Il::'\Hew

(1] 4
CDITIF'D”EYII I Yersion ﬂ Carcel
----- L3 Utility Phases
#-[Z] Debugger Components

Begister...
Wrrearster
Properties. ..
Exmart.,
Search dizgk...
Toal infarmatiar....

Uninztaller...

Todify...

b ERRLRLE e

Figure5.11: All Components Shown

When seeking technical support, you may be asked to give detail s about some or all of these components. To do
S0, open the respective folder, select acomponent and click the “Properties’ button. The properties dialog that
will be invoked behavesin the same way as discussed previoudy in this chapter, with the exception that thereis

no

Environment” tab.

The HEW aso has a feature, which outputs tool information regarding the registered componentsto afile. This
alows you to retrieve information on the entire HEW system. Thisinformation can then be sent to your
technical support contact if you are experiencing problems with the HEW.

2 Tooutput tool information:

1. Click the[Tools->Administration] menu item.

Click the “Tool information...” button. A standard windows file save dialog is displayed.

2.
3. Choosethefilelocation and click OK.
4

A fileis created in the chosen location with the current registered tool setup of the HEW.
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If any of the components have problems these can be seen in the tools administration dialog. If theicon hasan

additional icon this explains the problem. There are two additional iconsthat can be displayed. If acomponent
isfound but cannot be used due to it being an old version or another dependent component is not available then
theiconin figure 5.12 is used to show this. If the component is not located where the registration file saysitis

then theicon in figure 5.13 is used to show this.

Reaqistered components:

Component

~%5¢ 1AR TINY-SERIES (H8/300HN)
#. SuperH RISC engine Standard T

EI |n|:-r|-| nlcl_\. ﬂl"li'lil"lﬂ EI‘:F‘n":rl-l Ti'n'.

Figure5.12; Incompatible component found icon

----- Ha5 HE/300 Senes Simulator Target Platfarm 2.0
----- Hton Embedded Monitar Flatform 1.0
fon Intel Hex Recard Obiect Header 1.0

Figure5.13: Component not found icon
Note:
If the tool has one of these errorsthen it is possible to get more information by the following method:

2 To get tool error feedback:
1. Click the[Tools->Administration] menu item.

2. Select thetool inthelist that has an issue.
3. Click “Properties...”
4, Select theinformation tab and scroll the edit field to the bottom.
5. Thereason for the problem will be displayed in this area.
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5.8

On-Demand components

The HEW version 3.0 onwards has the concept of on-demand components. These components are not
automatically loaded by the application or the debugger component. These components can be loaded by the
user or as part of the project generation process.

2 Toload or unload an on-demand component manually:

1. Click the[Project->Components...] menuitem.
2. The component gallery dialog isdisplayed. Thisisdisplayed in figure 5.14.
3. Select the component you wish to load. Click theload button. The components image should change to
the loaded state.
4. If you wish to unload a component. Select the component. Click the unload button. The components
image should change to the unloaded state.
5. Click OK to verify the changes.
x
[Sta]I-Yelcl | 2| projects
=23 Application Estensions QK. |
Loaded component E ITROM comporent
-|gf) OSEFK component Cancel |
Unloaded companent @ Custarn memory view component
Irntermediate state companent 1. Pin view component
Load |
Figure5.14: Component Gallery
Note:

Each project in your workspace can have different components loaded and unloaded. If you have multiple
projects you can use the “Multiple projects...” and “All projects’ items to change a components |oad status over
more than one project. If you select acombination which means the component is loaded in one project and not
anther then the intermediate state icon is displayed.
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59  Custom Project Types

The [Project->Create Project Type...] menuitem in HEW allows you to create a template for your project.
This menu item takes the settings of the current project and then creates a project type for you. The user can
specify the name of the new type and style of the project generation wizard. Once created these project types
appear in the “Tools Administration” dialog and are initially hidden in the system components part of the tools
administration tree. To export one of the custom project generators select the “ Export” button on the “ Tools
Administration” dialog. The execution environments of the custom project generators are packaged on the
execution file that can beinstalled. When thisfileisexecuted on the target user’s machine, the custom project
generator isinstalled.

Once created custom project type will then appear in the New workspace dialog and can be used to create
identical copies of your project.

2 To create custom project generator:
1. Open the workspace that contains the project you wish to convert into a custom project generator.
2. Settheproject you wish to convert asthe current project.
3. Click the[Project->Create project type...] menu item.
4. Thefollowing diaog is displayed:

21

What title would vou like to be uged for the new
praoject type’?

CurrentProjectame

Frojects generated uzing the new type wil

include all of the filez in the project directory

and below. Would pou like to include the

contents of the configuration directaries?
% ‘Yes please

Mo thanks

Wiew directones to be included...

Approw. size of generatar: 581 63KEB

< Back I Ment » Finizh Cancel

Figure 5.15: New project type wizard — Step 1 Dialog

5. Theedit field is set to the current projects name. This will become the name of the new project
generator project type that will appear in the new workspace dialog. Change the contents of the fields
as appropriate.

6. At thisstage you can choose to include the configuration directories or not. In thiscaseit isnormal to
not include the contents of these directories because normally these are only intermediate files.

7. Thenclick next. Thefollowing dialog is displayed.
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2
What tupe of generator would you like?
' Mo dialog

™ |nformation dialog with default bitmap

Browse... |

What leon would wou like to be uzed?

" Information dialog with bitmap:

%' The default icon

" Anicon contained in the fils:

I Browse... |
Image: I@

Approw. size of generatar: 581 63KEB

¢Back | Hew> | Finish

Figure 5.16: New project type wizard — Step 2 Dialog

8. At thisstage you can change the wizard graphic and the project icon. By default no dialog is displayed
for thiswizard. When you wish to display “Project information” dialog box, you should either
information dialog with default bitmap or information dialog with bitmap. This selection affects to
show icon in the “ Project information” dialog.

9. You can also decide to change theicon for the project type at this stage. The default icon is shown but
you can choose to use your own custom icon and this will be displayed on the new workspace dialog.

10. When you are happy with the setup of the generator click finish. If you click “Next” button, Step 3
dialog box is shown.
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Wihat tert would pou like digplaged on the
generatar dialog?

Dizplaying project information

" o

Approw. size of generatar: 581 63KEB

< Back | Hewt > I Finizh I Cancel |

Figure5.17: New project type wizard — Step 3 Dialog

11. You can enter project information. It will be shown “Project information” in Project information dialog
box.

12. You can click “Finish” button. Now the generator will be created in the HEW\system\pgc directory in
your HEW installation. It will also automatically appear in the new workspace dialog.
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Y ou can see a new project type (In this example, “ Current Project Name”) after creating by custom project
generator.

2lx
Frojects |
@ Application I\-_\-"orkspace Mame:
= -
Demonstratllon . B ez
@ Empty dpplication
T@ Irnpart b ak efile I
G Library Directony:
ID:\HewS Browse. . |
LCPL farnily:
ISuperH RISC engine j
T ool chain:
IHitachi SuperH Standard j
Froperties. .. |
Ok I Cancel

Figure 5.18: New Project Workspace Dialog
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Y ou can select a project type and enter workspace and project name then click, OK. This dialog contents come
from “Project type wizard - Step 2” and step 3 setting.

Ix

Project information

Froject informatian:

Dizplaving project information

L of

<Back | Heio | Ensn |

Caricel

Figure5.19: Project information Dialog
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These can then be exported from the HEW system and be given to other users you need to use your project.

2 To export a custom project generator to another user:

1. Click on[Tools->Administration].
2. Check the “Show dl components’ checkbox.
3. Expand the “Project Generators— Custom” folder.
4,  Select the custom project generator you wish to export.
5. Click the “Export..."” button.
Tools Adm 21x|
Registered components: ’T‘
Compaonent Wersion Cancel
- Toolchains |
I:I---D Syztem Tools -
----- (2 Utility Phazes Register... |
-1 Debugger Components -
I:I---D Extenzion Components Unregister |
----- D Cammunication Tools B .
- Swstem Etenzion Components L{tles...l
-0 Project Generatars Bt |
Ela Project Generators - Custom ==
- m CurrentProjecttame . E———— |
Fe- [ Wersion Control Spstem —
-0 Toolchain Support Toal information...l
E-(Z Definition Parser -
P | | ﬂ Uninstaller. .. |
¥ Show all components
Current HEW tools database location:
|D:\Hew3 Madify... |
Figure 5.20: Tool Administration Dialog
6. You should enter export directory for custom project generator and click “Export” button. HEW creates

some files. When another HEW usesits project, it needs al files under your specified directory.

21x
Drirectory to export bo [must be empty or not exist); Expart

D 5HewWE wpart Browse... I
Cancel |

Figure5.21: Export Custom Project Generator Dialog
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Thiswill export the required files along with a“ Setup.exe” file which can be then be executed on another HEW.
Thiswill ask the location of the new users HEW and when Install is clicked the project generator will be added
to their HEW system.

;"j.- Install cuskam generator

wéhat iz the location of the HEW executable?
CA\HewIWHEW 2 exe

Figure 5.22: Install custom generator Dialog

Once compl eted the project type will appear in the new workspace dialog.

Note:

A custom project generator can only be used in aHEW which is the same or greater version. If you attempt to
use the project generator in an old HEW an error message will be reported.

If your project generator contains a different toolchain to the destination HEW then this will be upgraded when
the project isfirst created.
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6.  Customizing the Environment

6.1 Customizing the Toolbar

The High-performance Embedded Workshop provides 2 standard toolbars as detailed in chapter 1, “ Overview”.
In addition to these, you may also construct your own toolbars via the “ Customize” dialog (figure 6.1).

Customize il ﬂ

Toolbars | Cnmmandsl Menu I F'Iaceholdersl Debuggerl Lag | Help I

v Show Tooltips Mew...

Beset |

Toolbar name:

Editor

ak I Cahicel

Figure 6.1: Customize Dialog Toolbars Tab

2 To create anew toolbar:
1. Select [Tools->Customize...]. Thedialog shown in figure 6.1 will be displayed.
2. Click the“New...” button. The dialog shown in figure 6.2 will be displayed.
3. Enter the name of the new toolbar into the “Toolbar name” field.
4. Click “OK" to create the new toolbar.

New Toolbar

Toolbar nanme:
IMyTu:u:uIbatI
Cancel |

Figure 6.2: New Toolbar Dialog
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When anew toolbar is created it will appear undocked (i.e. “floating”) and empty.

2 To add buttonsto atoolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “ Commands’
tab (see figure 6.3).
2. Browse the available buttons by selecting the button categories from the “ Categories’ list. Select a button
from the “Buttons” areato display information on its operation.
3. Click and drag a button from the dialog onto the toolbar.

2%

Toolbars Commands |Menu I F'Iaceholdersl Debuggerl Lag | Help I

Cateqaries: r— Buttons

|Standard D@nﬁ|§|%g
Debug 0T @

Search

[rebug Run
Bookmark z
Templates
Difference
Wergion Control
tdap

Select a cateqary, then click a button to see itz description. Crag the button
to any toolbar

— Dezcription

ak I Cahicel

Figure 6.3: Customize Dialog Commands Tab
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To remove buttons from atoolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “ Commands’

tab (see figure 6.3).
2. Click and drag a button from the toolbar onto the “Buttons’ area.
To remove a user defined toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the user-defined toolbar from the “ Toolbars” list, and the “Reset” button in figure 6.1 changes to

the “Delete” button. Then click the “Delete” button.

To reset a standard toolbar back to itsorigind state:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the standard toolbar from the “Toolbars” list and then click the “Reset” button.

To show or hide toolbar tooltips:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Set the “Show Tooltips’ check box as desired.

To modify the toolbar name of atoolbar created by a user:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Inthe“Toolbars’ list, select atoolbar, which has been created by a user and whose name you want to
modify.

3. Modify the name of the toolbar in the “ Toolbar name” filed.
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6.2

Customizing the ToolsMenu

The“Tools’ menu can be customized to include your own menu options.

2 To add anew menu option:

1

Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the“Menu” tab
(seefigure 6.4). Thefirst thing for you to decide is whether you are adding a global application wide
tool (“Application widetools.”), which will be availableto all of your workspaces. Or whether you wish
to add a workspace wide tool (“Workspace wide tool:”), which is only valid for the current workspace.
Once you have made the choice choose the relevant section of the dialog.

)

7 x|

Toolbars | Commands  Menu |F'Iaceho|ders| Debuggerl Log |Help I

Customize

Application wide tools:

Mame | Werzion |

T adify..

II

Hemowve

Wiorkspace wide tools:

M arne | Wergion | Add..
Hitachi Mapwiew 1.0
Hitachi H Series Librarian Interface 11 fadify..

Hitachi Call ‘W alker 11

Remove

i

ak I Cahicel |

N o o~ w
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Figure 6.4: Customize Dialog Menu Tab

Click the“Add..."” button (the dialog shown in figure 6.5 will be invoked). If you would like to add an
existing system tool to the menu then select the “ Select from existing system tools” radio button, choose
the tool from the drop-down list and then click “OK”.

Enter the name of the toal into the “Name” field.

Enter the command, excluding arguments, into the “Command” field.

Enter any arguments that you would like to pass to the command into the “ Arguments” field.
Enter aninitia directory in which you would like the tool to run, into the “Initial directory” field.
Click “OK” to add the menu option to the “Tools’ menu.
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Add Tool EHE

& Define new uger toal 0k |

— Tool details:
Cahicel
Marme :
IEHpIorer
Command :
I$[WINDIF|]'\e>:pInrer.e>:e p | Browse... |
Argurnents
| i3
Initial directaorn
|$[TEMF'DIF|] )| Brawse... |

" Select from existing system tools;

IHitachi rd apview [wersion 1.0] ﬂ

Figure 6.5: Add Tool Dialog

New menu options are added to the bottom of thelist (i.e. bottom of the tools menu). The order of menu options
in the “Tools” menu can also be modified.

2 To modify amenu option:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).
2. Select the menu option that you would like to modify and then click the “Modify...” button.
3. Make the desired changes on the “Modify Tool” diaog (figure 6.6) and then click “OK”.

ModifyT ool EHE3

Cancel |
Command :
I$M|ND|H]'\BHD|DIBLBHE Ll Emwse,_,l
Arguments ;
| 2
Initial directaorn
[$TEMFDIR] R Ernwse...l

Figure 6.6: Modify Tool Dialog

2 Toremove amenu option:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).
2. Select the menu option that you would like to remove and then click the “Remove” button.
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6.3 Configuring the Help System

The High-performance Embedded Workshop provides context sensitive help within the editor window. In other
words, if you select some text in the editor window and then press F1, the High-performance Embedded
Workshop will attempt to locate help on that selected item. The help files, which will be searched, arelisted in
the “Help” tab of the “Customize” dialog.

2 Toaddanew helpfile:
1. Select [Tools->Customize...]. Thedialog shown in figure 6.1 will be displayed. Select the “Help” tab
(seefigure 6.7).

Customize il ﬂ

Toolbarsl Cnmmandsl Menu I Placehalders Debuggerl Laog Help |

Help files:
Degcription | File Name | Add.

C/C++ Standard Library Help - d:\hew3Woaolshrenesa...
Bemave |

Ciefault help file;
C/C++ Standard Library Help |

ak I Cahicel |

Figure 6.7: Customize Dialog Help Tab

2. Click the“Add...” button. The“Add Help File” dialog will be displayed (figure 6.8).

Enter adescription of the help fileinto the “Title” field.

4. Enter thefull path of the help file into the “Path” field (or browse to it graphically by clicking on the
“Browse...” button).

5. Click “OK” to define the new help file.

w

Add Help File

Title:

= OF.

IF'rogramming inANSIC —l
Cahicel |

Path:

Ic:kfiles'\helpkansi.hlp Browsze. I

Figure 6.8: Add Help File Dialog
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To make ahelp file the default choice, select it from the “ Default help file” drop-down list or set it to “(None)” if
you would like to be prompted for a help file when F1 is pressed.

6.4 Specifying Wor kspace Options

The High-performance Embedded Workshop allows you to control several aspects of a workspace viathe
“Options’ dialog (figure 6.9). To invoke it select [T ools->Options...], and select the “Workspace” tab.

21X

Build I Editor  Workspace | Cnnfirmationl Networkl

[ ‘Open last workspace at stat-up

¥ Eestore files on opening workspace

™ Display workspace information dialog on opening workspace
[~ Save workspace befare executing any toaks

[ Prompt before saving workspace

¥ Prompt before saving session

v Save futo-Recovery info every |1EI j minutes

Default directary far new work spaces:

ID:'\HEWE Browsze. |

Ok, I Cancel

Figure 6.9: Options Dialog Workspace Tab

The following sections explain the options available on this tab.
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6.4.1 Open last workspace at start-up

Set this check box if you would like the High-performance Embedded Workshop to automatically open the last
workspace you opened when it is launched.

6.4.2 Restore the files on opening wor kspace

When you close aworkspace, the HEW stores, which files were open. When you open a workspace, the HEW
can restore (i.e. open) the same files so that you can continue your session in exactly the same state as when you
left it. If you would like the files associated with a workspace to be opened when you open a workspace then set
this check box.

6.4.3 Display wor kspace information dialog on opening wor kspace

When many workspaces are being used, it is sometimes difficult to remember exactly what was contained within
each workspace. To help resolve this, the High-performance Embedded Workshop allows you to enter atextual
description of each workspace.

2 To enter aworkspace description:

1. Select the workspace icon from the “ Projects’ tab of the ”Workspace” window.

2. Click the right mouse button to invoke the pop-up menu and then select the “Properties’ option. The
dialog shown in figure 6.10 will be displayed.

3. Enter the description into the “ Information” field.

4. Check the “ Show workspace information on workspace open” check box if you want a workspace
properties dialog to be launched on opening a workspace. This check box has the same role asthe
“Display workspace information dialog on opening workspace”’ on the “Workspace” tab of the “Options’
dialog.

5. Click “OK” to save the description on the “Information” dialog. Click the “Cancel” button not to save the
description.

120
RENESAS



Workzpace Properties E E

Mame: IDemn ] i
Location: C:AHew2\DemohDemo. s
Last modified: 23:06:54, Friday, June 20, 2003 ﬂl
CFU farnily: SuperH RISC enaine
Tool chain: Hitachi SuperH Standard

Information;

Mo work space information available ;I

¥ Show workspace information on waorkspace open

Figure 6.10: Workspace Properties Dialog

When aworkspace is opened, the High-performance Embedded Workshop can display thisinformation so that it
is possible to determine whether the workspace is the desired workspace. To display thisinformation on opening
aworkspace, set the “ Display workspace information dialog on opening workspace” check box.

6.4.4 Save wor kspace befor e executing any tools

To force the High-performance Embedded Workshop into saving the current workspace before executing any
build phases (i.e. build, build all or build file operations) or version control commands set the “ Save workspace
before executing any phases’ check box.

6.4.5 Prompt befor e saving wor kspace

In addition to the above check box, set thisto prompt before saving.

6.4.6 Prompt before saving session

Checking this option will force the High-performance Embedded Workshop into displaying a prompt before the
session is saved to disk.
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6.4.7 Save auto-recovery info

When you click this option, every ten minutes (as default) HEW saves workspace, project and session
temporality. Any changes you have made will be saved to temporary files.

If you open your workspace and the following dialog is displayed it means that the last time the workspace was
used problems were encountered. To recover the files check the checkbox alongside the filenames you wish to
recover and click OK. Clicking cancel will discard the auto-recovery files and load from the original files.

kspace Auko-R il il

HE'w failed to shutdown carrectly the last time you used thiz
workzpace. Would pou like to recover the following files, rather
than uze the saved versions?

Filzname | Directony

demaonstration. hwz  ci\hew3hdemanstration
deranstration bwp o \hewIhdemanstrationhdemanstrat
defaultzeszionhsf  o\hew3hdemonstrationtdemonstrati
simzessionzh-2hsf  c\hew3hdemaonstration.demanstrati

Cahicel |

Figure 6.11: HEW Workspace Auto-Recovery Dialog

6.4.8 Default directory for new wor kspaces

When anew workspace is created the High-performance Embedded Workshop invokes the “New Workspace”
dialog. One of the fields on this diaog is the directory in which the new workspace will be created. By default,
thisisthe HEW installation directory. However, if you would like to set this default directory to another location
(e.g. “C:\Workspaces') then enter the desired directory into the field or browse to it graphically viathe

“Browse...” button.
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6.5 Using an External Editor

The High-performance Embedded Workshop allows you to use an external editor. Once an external editor has
been specified, it will be launched when the following actions are performed:

Double clicking on afilein the “ Projects’ tab of the “Workspace” window.
Double clicking on an entry in the “Navigation” tab of the “Workspace” window.
Double clicking on an error/warning in the “Build” tab of the “Qutput” window.
Double clicking on an entry in the “Find in Files’ tab of the “ Qutput” window.
Selecting the [Open <file>] option from the “Workspace” windows pop-up menu.
Clicking the “Launch Editor” toolbar button.

To specify an external editor:

1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 6.12).

Build ~ Editor |Workspace| Confirmationl Networkl

— Spacing:

¥ Enable auto indentation

Tab size: I 4

— General:
¥ Save files before executing any tools ¥ Show files in notebook,
[~ Prompt before zaving files ¥ Enable syntax coloring
¥ Enable Smart-edit for C++ files ¥ Enable tooltip watch
— External editar;

[ Use external editor;

| ity |

o]

Canicel

Figure 6.12: Options Dialog Editor Tab
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2. Check the “Use external editor” check box.
The “External Editor” dialog will be displayed (figure 6.13).

External Editor EHE
Cammand:
IC:\WINDDWS'\NDtepad.eHe Browsze. | QK |
Argumentz to open file; Cancel |
[sFULLFILE) Ll
Arguments ta open file at line:
[$(FULLFILE] m

Figure 6.13; External Editor Dialog

3. Enter the path of the executable (without any arguments) into the “Command” field.
4. Enter the arguments required to open afileinto the “ Arguments to open file” field. Use the $(FULLFILE)
placeholder to represent the path of the file to be opened.

5. Enter the arguments required to open afile at a specific line into the “ Arguments to open file at line” field.
Use the $(FULLFILE) placeholder to represent the path of the file to be opened and the $(LINE)
placeholder to represent the line number at which the cursor should be initially positioned.

6. Click “OK” to define the editor.

Note: When using an external editor be aware of the following issues:

« Each timeyou invoke the externd editor, in whichever way, a separate instance of the editor will be launched.
¢ You musgt save your own files before you perform abuild file, build or build al operation.
« |If debugging the external editor will not be used.

6.6 Customizing File Save

The High-performance Embedded Workshop allows you to customize file save on the “ Editor” tab of the
“Options’ dialog (figure 6.12). To open the tab, select [Tools->Options...] and click the “Editor” tab.

The following sections explain the options related to file save.

6.6.1 Save files befor e executing any tools

To force the High-performance Embedded Workshop into saving edited files before executing any build phases
(i.e. build, build al or build file operations) or version control commands, set the “ Save files before executing
any tools’ check box.

6.6.2 Prompt before saving files

In addition to the above check box, set thisto prompt before saving.
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6.7 Using Custom Placeholders

Throughout the High-performance Embedded Workshop the user can use a number of pre-defined placeholders
for directory definitions. For example the user can use the “$(PROJDIR)” variable to signify the current HEW
project directory. Thismakesit much easier to relocate projects and keep al of the paths correct.

The High-performance Embedded Workshop also has the ability to define custom placeholders. This meansyou
can enter your own custom placeholder definition and decide upon its directory value. Once defined this
placeholder becomes available throughout the rest of the HEW system.

The placeholders can be defined on an application wide level so the placeholders are available to all workspaces
and projects that use the HEW. The other method of defining the placeholders is using the workspace wide
custom placeholders this means the placeholders can only be used in the current workspace. Thislistisonly
available when you have a workspace open.

|-

X

Customize

Toolbarsl Cnmmandsl Menu  Flaceholders | Debuggerl Lag | Help I

Application wide custom placeholders:

Flaceholder | Directory |

T adify..

II

Hemowve

Wiorkspace wide cugtom placeholders:
Placeholder | Directary | Add..

Fdifi..

i

Remove

ak I Cahicel |

Figure 6.14: Customize Dialog Placeholder Tab
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2 To add acustom placeholder:

1

Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the
“Placeholders’ tab (figure 6.14).

Choose whether you need to use an “Application wide custom placeholder” or “Workspace wide custom
placeholder”. Click “Add” on the adjacent button to the list you require.

The dialog, add “New Custom Placeholder” diaog is displayed. (figure 6.15)

In the fields provided choose a suitable name for the placeholder and a description of what the
placeholder means.

Then choose adirectory, which relates to this placeholder. It is possible to use placeholders that are
already defined in this field such as $(PROJDIR).

Mew Custom Placeholder [ %]
Placehalder:
I Cancel |

Drescription:

Diirectory:

I Browse... |
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Figure 6.15: New Custom Placeholder Dialog
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6.8 Using the wor kspace and project log facilities

The HEW 3.0 has workspace and project logging facilities integrated into the application. These facilities can be
switched on viathelog tab on the Tools customize dialog. This option is especialy useful when the network
databaseisin operation. Thisis because user names and changes are logged to thisfile. Thisdialogisshownin
figure 6.16.

When the workspace log is clicked any workspace changes will be logged to afile with the same name as the
workspace with a“.log” extension. Thisfilewill be located in the same directory as the workspace file.

When the generate log for projectslog is clicked any projects in the current workspace that have changes made
to them will be logged to afile with the same name as the project with a“.log” extension. Thisfile will be
located in the same directory as the project file.

Thelog file is updated when the workspace is saved.

Customize il il

Toolbarsl Cnmmandsl Menu I Flacehalders | Debugger Lo |He|p I

I Ll Browse, .. |

[ Generate workspace log

[~ Generate log for projects

Ok, I Cancel

Figure 6.16: Tools customize log tab

6.9 Using the virtual desktop

HEW has implemented the concept of the virtual desktop. This allows window configurations to be defined that
can be switched with the click of abutton. When a particular button is clicked the windows are hidden or
displayed depending on the current settings of that window configuration.

It is possible to have a maximum of 4 desktop configurationsin use. When the session is saved the window
positions for each configuration are saved to the session file. You can then switch simply between each
configuration to gain access to the other windows. The toolbars and windows are dependent on the virtual
desktop configuration. Source files are independent of the virtual desktop system and will remain in view.
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=) To rename your configuration to a more meaningful name:

Click the [Window->Virtual Desktop] menu item. Select is cascaded menu.

Select the Desktop Manager dialog.

Select the window configuration you wish to change the name for.

Click the rename button. Enter the new meaningful name in the edit field and click OK.
Click OK to keep the changes and revert to the HEW main window.

o s~ w NP

=) To switch desktop configurations:
There are a number of waysto switch desktop configuration. The first and easiest method is using the virtual
desktop buttons located on the status bar. These are shown in figure 6.17.

Ox0000Z012 for{ i=0; i<10; i++ )4
O0x0000Z201a J = rand(]:
Ox0000Z022 if{y = O0){

«NANNZN7 A 1= -3 _ILI
4 »

% democ l

b Wersion Contral "
% [Build deskrop [Read-write [z9138 4

Figure 6.17: Desktop button

In this example the selected desktop is number 1. This has been given the name "Build" by the user. Its
description is seen in the edit box to the right on the buttons. Clicking a different desktop selects that button and
changes the description control. Once clicked HEW then |oads the windows in the new configurations style.

Another method of changing the desktop configuration is as follows:

1. Click the [Window->Virtual Desktop] menuitem. Select is cascaded menu.
2. Then select the desktop configuration you wish to view on thismenu. The selected item isticked.
3. Select the menu item and the setup is altered automatically.

Note:

If the configuration has never been used then HEW will copy the current window configuration to the new
configuration. 'Y ou can then modify this setup. When you save the session it will store the positions of your
windows for each window configuration.
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7. Version Control

The High-performance Embedded Workshop provides facilities for connecting to a version control tool. Some of
the reasons why version control tools are used with a project are:

* To maintain the integrity of a project.
* To store each stage of aproject.
« Toenabledifferent users to co-develop aproject by controlling revisionsto its source files.

Figure 7.1l illustrates atypical project where aversion control system isin use. This shows three users who al
use the same-shared network drive to exchange source code. The version control system provides access and
updates to the source files.

NETWORK

Figure 7.1: Version Control
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7.1 Selecting a Version Control System

Initidly, the version control sub-menu will appear as shown in figure 7.2. At thistime only the [Version
Control -> Select...] option is available because a version control system is not yet active for the current
workspace.

Tools ‘Window  Help

Adminiskration. .. j c
Change Toolchain Yersion... j d
on Cantral Select...
. Zonfigure, . .
Custarnize. ..
Options. .. (e Al IFileds)
_ @. Remayve Filels)
Farmat views. .. &
o aet Filels)
)& Launch External Debugger... g Eheck Gut File(s)
4F Launch Slawe HEW. .. B Check In File(s)

@_ Status of Filels)

Show Differences. ..

Hitachi Mapview
Hitachi H Series Librarian Interface
Hitachi Call W alker

Figure 7.2: Version Control Sub-Menu

2 To select aversion control system:

1. Select [Version Control->Sdlect...]. The dialog shown in figure 7.3 will be displayed. Thisdialog lists
all of the supported version control systems.

2. Select the desired version control system from the “Version control systems’ list and click the “ Select”
button. The “Current version control system” is changed to reflect the new selection.
3. Click the“OK” button to confirm the selection.
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Select Yersion Control System 2=

Yerzion control syztems: 0k

C |
Microzoft Visual SourceSafe 5.0/6.0
[Mane]

Cahicel

Select

g

Cunrent version control system;

[Mone)

Figure 7.3: Select Version Control System Dialog

Note:  Only those version control systems, which have been installed with the HEW, will appear in the “ Select
Version Control System” dialog (figure 7.3).

Once aversion control tool is selected you will notice that the [Version Control->Configure...] option has now
become available.

The next chapter discusses the usage of the custom version control system.
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8.  Using the Custom Version Control System

The custom version control system is a configurable addition to the High-performance Embedded Workshop,
which alows you to connect to aversion control system aready installed on your machine. To clarify further,
the High-performance Embedded Workshop does not provide a version control tool itself, only a means by
which you can integrate the version control system, which you use into your workspaces and projects.

8.1 Defining Version Control Menu Options

The custom version control system allows you to invoke aversion control command either by selecting an
option from the [Tools-> Version Control] sub-menu or by clicking aversion control toolbar button. When
either of these actions are performed, the associated commands are executed and the output is displayed in the
“Version Control” tab of the “Output” window.

2 To execute aversion control menu option or toolbar button:

1. Select whichever items you would like to apply the version control command to from the “Workspace”
window. This may include aworkspace, project(s), folder(s) and file(s). When the command is selected,
al of the fileswill be extracted from the selected items and passed, in turn, to the version control
command. For example, if you select the workspace icon then all of thefilesin all of the projectswill be
passed, in turn, to the version control command. Thiswill include any system files. For exampleif you
select the project item then

2. Select the required menu option from the [Tools->Version Control] sub-menu or click the desired
version control toolbar button.

The custom version control support alows you the most flexibility in specifying how aversion control systemis
to be used. To configureit, select [Version Control->Configure...]. The“Version Control Setup” dialog will be
displayed (figure 8.1).
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¥ersion Control Setup 2=

Commands | Projects | General |

Systern menu options and toolbar buttons:

Bidd File(s) fodifi... |
Check In File(z)

Check Out File(z)

Get Filelz)

Femove File(z]
Statuz of File(s]

4] | >

Uger menu options:

T odifi..
Hemave

Mowve up

Ll

fione dawn

QK I Cancel | Enport... | Import... |
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Figure 8.1: Version Control Setup Dialog Commands Tab
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The “Commands’ tab contains two lists of menu options. Thefirst list, “ System menu options and toolbar
buttons’, represents those menu options which always appear on the version control sub-menu. These menu
options also have an associated toolbar button on the version control toolbar. The second list, “User menu
options”, represents those additional user defined options which are added to the bottom of the version control
sub-menu. Figure 8.2 shows the structure of the version control sub-menu.

Options... |
Select..
Configurs..
[ Add Filels)
@: Remove Filals) Systern
& Gt Filals) Diefinect
& Check Out Filels) Cption
B Check In Fila(s
@ Status of Filels) L(‘_’
) ) Lser
Hiztory of Filalz) Diefined]
Unda Check out of Filels) Opticn

Figure 8.2: Version Control Sub-Menu

811 System menu options and toolbar buttons

In order to invoke commands from the toolbar or the system defined options of the [T ools->Version Control]
sub-menu, you must first define the associated commands that should be executed when they are activated. The
names of the options and their intended action are listed in table 8.1.

Table8.1: System Menu Option

Option Description

Add File(s) Add selected file(s) to version control system.

Remove File(s) Remove selected file(s) from version control system.

Get File(s) Get a read only local copy of the selected file(s) from version control system.

Check In File(s) Put back, i.e. update, the selected file(s) in version control system with the
local copy.

Check Out File(s)  Get a writable local copy of the selected file(s) from version control system.

Status of File(s) View the status of the selected file(s).
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2 To modify asystem menu/ toolbar option:

1.
2.

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

Select the option to be modified from the “ System menu options and toolbar buttons” list and then click
the “Modify...” button. The dialog shown in figure 8.3 will be displayed. This figure shows adialog
when “Add File(s)” has been selected for example.

Commands are added viathe “Add...” button. See the section, “ Defining Version Control Commands’,
later in this chapter for further information.

Close the “ Define Command for “<command>"" dialog by clicking “OK”".
Close the “Version Control Setup” dialog by clicking “OK”.

Define Commands For “Add File[z]"

LCommands :

Cancel

&dd
flmdifi.
Eemave

e i

HARA-

I mwE datr
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Figure 8.3: Modify System Menu Option (Example)

RENESAS




8.1.2 User menu options

Y ou can create as many user defined menu options as you like, name them how you want and define their order
in the menu. User defined menu options do not appear on the version control toolbar.

2 To create anew version control menu option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
2. Click the“Add..” button. The didog shown in figure 8.4 will be displayed.
3. Enter the name of the menu option into the “Option” field.
4

. Commands are added to the menu option viathe “Add...” button. See the section, “ Defining Version
Control Commands”, later in this chapter for further information.

Closethe “Add Menu Option” didog by clicking “OK”.
6. Closethe“Version Control Setup” dialog by clicking “OK”.

o

Add Menu Option E E2
Opticn
= Ok
Cancel |
Commands:

Add.
flmdifi.
Eemave

e i

e

I mwE datr

Figure 8.4: Add Menu Option Dialog
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2 Toremove an existing version control menu option:

1.
2.

3.

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

Select the menu option to be removed from the “User menu options” list and then click the “ Remove’
button.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To modify an exigting version control menu option:

1
2.

3.
4.

Select [Version Control->Configure...]. Thedidog shown in figure 8.1 will be displayed.

Select the menu option to be modified from the “User menu options” list and then click the “Modify...”
button beside the list. The dialog shown in figure 8.4 will be displayed. (Thetitle of the dialog is“Modify
Menu Option”.)

Modify the commands as hecessary and then click “OK”.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To change the ordering of version control menu options:

1.
2.

138

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
Select the menu option to be moved and then click the “Move up” and “Move down” buttons as
necessary.

Close the “Version Control Setup” dialog by clicking “OK”.
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8.2

Defining Version Control Commands

Commands are defined when the “Add...” or “Modify...” buttons are clicked on the dialogs shown in figure 8.3
and figure 8.4. In either case, the dialog shown in figure 8.5 isinvoked.

Add Command E E2

— Command :

Yerzion control egecutabls ©
IV:\VSS\WIN32\SS.EHE Browse... |
— Cancel |

Arguments :
IHistor_l,J $WCDIR)AHFILEMAME] Y HUSERMAME)$PASS ﬂ

Initial directary :

[s(FILEDIR) ﬂ E— |

— Executable return code

¥ Fetun code of executabls is not meaningful

¢ Command has failed if the return code s [ro Equal T j IIJ

Figure 8.5: Add/M odify Command Dialog

2 To define acommand:

1

Enter the full path of the command into the “Version control executable” field or browse to it graphicaly
by clicking the “Browse...” button.

Enter the arguments for the command into the “ Arguments” field.

Enter the initial directory in which you would like to run the executable from into the “Initial directory”
field or browse to it graphically by clicking the “Browse...” button. In most cases this should be set to the
“$(FILEDIR)" placeholder, i.e. execute the command from the same directory asthefile.

4. Set the “Executable return code” options as described in the following section.

821

Click “OK"” to define the new command.

Executablereturn code

If the return code of the command(s) can be used to indicate a failure then you should select the “Command has
failed if the return codeis’ option and set the two fields to the right as required.

If the “Command has failed if the return code s’ option is selected then the HEW will check the return code of
each command to determine whether a failure occurred. If so, no further commands will be executed and any
other processes which would follow the commands (e.g. build) will not be executed.

If the “Return code of toal is not meaningful” option is selected then the HEW will not check the return code of
each. Consequently, all commands will execute regardiess.
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8.3 Specifying Arguments

It is obvious that arguments must be specified correctly, otherwise the version control tool executed will not
function as intended. However, it is also important, when using custom version control support, to specify the
argumentsin aflexible way as a single version control command can be applied to more than onefile. To
facilitate this, the “ Arguments’ field has a placeholder button (refer to appendix C, “Placeholders’, for anin
depth discussion of placeholders) which, when clicked on, invokes a pop-up menu of available placeholders
(figure 8.6). An explanation of each placeholder and how their values are derived can be found in table 8.2,
Arguments Field Placehol ders.

Uset login name

User login password
“ersion contral directary
Camment
Filz path + nams
Filename
Filz lzaf
File extension
Filz directary
Configuration directary
Praoject directary
Wiorkspace directory
Temp directory
Command directory
Windaows directary
Windaows system directory
Wiorkspace names
Project name

Configuration nams

Figure 8.6: Arguments Field Placeholder Pop-up Menu
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Table 8.2: Arguments Field Placeholders

Placeholder Value and How its Determined

User login name Current user login (“General” tab)

User login password Current user password (“General” tab)

Version control directory “Virtual” version control mapping (“Projects” tab)
Comment Comment specified before command execution
File path + name Full path and name of file involved in operation
Filename Filename (including extension) of file involved
File leaf Filename (excluding extension) of file involved
File extension Extension of file involved in operation

File directory Directory of file involved in operation
Configuration directory Current configuration directory

Project directory Current project directory

Workspace directory Current workspace directory

Temp directory Temporary directory

Command directory Version control executable directory

Windows directory Directory where Windows® is installed
Windows system directory Directory where Windows® system files exist
Workspace name Current workspace name

Project name Current project name

Configuration name Current configuration name

8.3.1 Specifying File L ocations

When referring to afile’ s location, be sure to use a placeholder, otherwise the command will only relateto a
hardwired file. For example, let’simagine that a version control executable has been selected which usesa—-GET
command to obtain aread only copy of afile. The “Arguments’ field could be specified as:

-CGET “c:\vc\files\project\min.c”

However, when executed, this command can only ever get the file MAIN.C. To resolve this problem, HEW uses
a system of placeholders and directory mappings. The latter tell the HEW which “working” directories (i.e.
where source files are being worked on) map to which “controlled” directories (i.e. where the source files are
stored in the version control system). Mappings between these two directory systems can be specified via the
“Projects’ tab of the ”Version Control Setup” dialog (figure 8.7).
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¥ersion Control Setup 2=

Commands  Frojests | Generall

Shiow details far project : IF'lDiecH j

r— Details :

Werzion control directony mappings

Source Directory | Werzion Control Directony Add... |

chworkhapplicationhproject]  whwehawhapphproject]

c:hworkhapplicationh o whvwchawhapphan b odify.. |

o wworkhzhared whwch ot zhared —
Eemowve |

JE i

Enrvironment ;
Add..
I odify.

[

Eemove

QK I Cancel Enport... Import...

Figure 8.7: Version Control Setup Dialog Projects Tab

2 To define a new mapping:

1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, and the dialog shown in figure 8.7 will be displayed.

2. Click the“Add..."” button that is next to the “Version control directory mappings’ list. The dialog shown
in figure 8.8 will be displayed.

3. Enter the source (i.e. “working”) directory into the “ Source directory” field or browse to it graphically by
clicking the “Browse...” button.

4. Enter the version control directory (i.e. “controlled”) directory into the “Version control directory”.

Yerzion Control Directory Mapping EE

Source directany : ak.
Ic:\work\shared ﬂ Browse... I Cancel

Werzion control directony

il

I:-t:'wc\sw\shared

Figure 8.8: Version Control Directory Mapping Dialog
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2 To modify an existing mapping:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be modified from the “Version control directory mappings’ list and then click the
“Modify...” button. The dialog shown in figure 8.8 will be displayed.
3. Make the necessary changes to the two directories and then click “OK” to confirm the edits.
2 To remove an existing mapping:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.

2. Select the mapping to be removed from the “Version control directory mappings’ list and then click the
“Remove” button.

Once the mappings have been defined you can use the “Version control directory” placeholder, $(VCDIR), to
represent the directory in which the project fileis stored. Consider the scenario shown in figure 8.9. Here are
three directories, which are mapped from a shared version control drive (X:\) to aloca drive where the
development is being done (C:\).

LOCAL - G:\ Mapped To NETWORK - X:\

- =

C:\work\application\project1 X:\we\sw\app\project1

- =

C:\work\application\src X:\o\sw\app\src

& =

C:\work\shared Xi\ve\swishared

Figure 8.9: Example Mappings

Now let’ simagine that a version control executable has been selected which uses a—GET command to obtain a
read only copy of afile. In order to get al of the filesin a project we need to use the following command:

- GET “$(VCDI R)\ $( FI LENAMVE) "

When the HEW executes the command for a given project file, it will replace $(VCDIR) for the equivalent
version control directory in the file mapping.

For example, suppose FILEL.C islocated at:
c:\work\application\projectl\filel.c
If the get command is applied to FILEL.C then:

(2) x:\vc\sw\app\projectl is substituted for $(VCDIR) asthisis the version control directory mapping for
c:\work\application\projectl.

(2) FILEL.C is substituted for $(FILENAME).
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Project File: C:\work\application\projectl \ filel.c

Arguments: $(VCDIR) \ $(FI LENAME)

1) )

Command: X:\vc\swhapp\projectl \ filel.c

Figure 8.10: Example of Substitution

8.3.2 Specifying Environment
Select the “Projects’ tab of the “Version Control Setup” dialog to view the current settings (figure 8.7).

To add anew environment variable click the“Add...” button beside the “ Environment” list (the dialog shown in
Figure will beinvoked). Enter the variable name into the “Variable” field, the variable’ s value into the “Value’
field and then click “OK” to add the new variable to the “ Environment” list.

Environment ¥arnable EHE

iulr‘arialgle :
Cancel |

Walue

| Placeholder
I 4 | popUp Menu

Figure 8.11: Environment Variable Dialog

To modify an environment variable, select the variable that you want to modify from the “ Environment” list and
then click the “Modify...” button beside it. Make the required changes to the “Variable” and “Vaue” fieldsand
then click “OK” to add the modified variable back to the list. To remove an environment variable, select the
variable that you want to remove from the “Environment” list and then click the “Remove” button beside it.
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8.3.3 Specifying Comments

If acommand contains the placeholder “$(COMMENT)” then the HEW will request that you enter the comment
when the command is executed (viathe dialog as shown in figure 8.12).

Pleaze Enter Comment E E2

File: c:vhewhdemotdemo'sbrk.c -
Ok
Cancel |
LCormrment :

[ Apply comment to all files

Figure 8.12: Please Enter Comment Dialog

Y ou may specify a comment for each file or, if you would like to specify the same comment for al files, check
the “Apply comment to all files’ check box before clicking “ OK”.
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8.34 Specifying a User Name and Password

Most version control toolswill require you to pass a user name and password on the command linein order to
keep files secure and to keep a record of which files were changed by which users. The custom version control
support provides two placeholders “User login name”, $(USERNAME), and “User login password”,
$(PASSWORD). When the command is executed, these placeholders will be replaced with the current settingsin
the “General” tab of the “Version Control Setup” dialog (figure 8.13).

¥ersion Control Setup 2=

Cnmmandsl Projects  General |

r— Execution :
v Prompt before executing command

™ Funin DOS Window ¥ Close DOS windoyw on exit

[ Use forward slash ' as version control directary delimiter

r— User details ;
e : JHARK

xxxRERR

Password ;

r— Canfiguratian file:
Current versioh contral configuration file:

CAHewhProjectProject] . bve

QK Cancel Enport... Import...

Figure 8.13; Version Control Setup Dialog General Tab
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In order to give the $(USERNAME) and $(PASSWORD) fields a value you will first need to login. If you have
not logged in before acommand is executed which uses either of these placeholders then you will be prompted
to do so before the command can be executed.

2 Tologin (i.e. specify auser name and password):
1. Clickthe“Login...” button. The dialog shown in figure 8.14 will be displayed.
Enter your user name into the “User name” field.
Enter your password into the “Password” field.
Re-type your password again into the “ Confirm password by retyping it below” field.
Click “OK” to set the new user name and password. If there is any inconsistency between the two
versions of the password which you entered then you will be requested to type your password again.

o w D

[ EHE
U=er name oK, I
JHARE
I Cancel |

Pagzword ;

LCaonfirm pazsword by retyping it below :

Ixxxxxx

Figure8.14: Login Dialog
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8.4 Controlling Execution

The “General” tab of the “Version Control Setup” dialog (figure 8.13) allows you to control the way in which
the version control tool is executed. It also showsthe full path to the current version control configuration file.

84.1 Prompt befor e executing command

If this check box is set then, before any version control commands are executed, adialog is displayed (figure
8.15) which lists all of the filesinvolved in the operation. Files may be deselected by clearing the associated
check box. Clicking “OK” will apply the command to each of the selected files. Clicking “Cancel” will abort the
operation.

History HE

Files -
= -DK
[w] demo.c

[z vhewh demobdema)

[w] zbirke. [z vhewh demobdema) Cancel |
W] wecttbl zre (o shewhdemobdema]

K I— 2

Figure 8.15: Command Prompt Dialog

8.4.2 Run in DOS Window

By default, the output of the version control commandsis redirected to the “Version Control” tab of the “ Output”
window. If you would rather run each command in a separate DOS window then set this check box.

843 Useforward slash ‘/” asversion control directory delimiter

By default, when the HEW substitutes the placeholder $(VCDIR) it uses the backward slash character ‘\' to
divide directories. However, if the version control system you are using uses a forward slash character (e.g.
Visual SourceSafe) to divide directories then set the “ Use forward slash */* as version control directory
delimiter”.
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85 Importing and exporting a Set-up

Each workspace can have a different version control set-up. The HEW allows you to store the version control
settings independently so that you can import them into other workspaces. This greatly reduces the amount of
timeit takes to configure the same version control settings across several workspaces.

2 Toexport aversion control set-up:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Click the “Export..." button. A standard file save dialog will be displayed. Browse to the directory in
which you would like to save the configuration.

3. Enter the name of the file and then click “OK”.

2 Toimport aversion control set-up:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
2. Click the“Import..." button. A standard file open dialog will be displayed. Browse to the * .HVC file
which you would like to import.
3. Select thefileand then click “OK”.
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9. Using Visual SourceSafe

The High-performance Embedded Workshop provides specific support for the Visual SourceSafe version control
system. At the time of writing, the HEW can only attach to versions 5.0 and 6.0 of Visual SourceSafe.

The Visua SourceSafe version control system associates a project in your workspace with aproject inside a
Visual SourceSafe database. It allows you to quickly invoke the standard commands either by selecting an option
from the [T ools->Version Control] sub-menu or by clicking aversion control toolbar button.

9.1 Attaching Visual SourceSafeto a Workspace

The following sections describe how you can associate Visua SourceSafe with your current workspace.

9.11 Selecting Visual Sour ceSafe
First, you need to select Visual SourceSafe as the version control system.

2 Touse Visua SourceSafe 5.0 or 6.0:

1. Select [Tools->Version Control->Select...]. The“Sdlect Version Control System” dialog will be
displayed (figure 7.3) which lists @l of the supported version control systems.

2. Select the“Visua SourceSafe 5.0/6.0" entry from the Version Control Systems list and click the “ Select”
button.

3. Click “OK” to confirm the selection. The SourceSafe Login dialog is displayed (figure 9.1).

4. Enter your Visua SourceSafe logininto “Username” and password into “ Password”.

5. Enter into Database path the full path to the Visual SourceSafe database (i.e. SRCSAFE.INI) into which
you would like to add this project.

6. Click “OK”. The“Create SourceSafe Project” dialog isinvoked (figure 9.2).

7. The“Project name” field displays the name of the project (i.e. folder) to be created in the database. If
necessary you can change this name to another.

8. Thetree underneath the “ Project name” field shows the structure of the database specified in step 6.
Select the folder into which you would like to create the folder specified in the “ Project name” field.

9. Click “OK”".

10. HEW will require you to repeat steps 7-9 for as many projects as are present in the current workspace.

SourceS5 ale Login

eemame: I
Pagzword: I ﬂl

Databaze path: I Browsze. . |

Figure9.1: SourceSafe L ogin Dialog
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Create Source5afe Project EHE

Project name:
Ipmiect

Cancel |
$/project

-

||

Figure 9.2: Create SourceSafe Project dialog

The HEW has now created the necessary projects within Visual SourceSafe and sets-up the version control
toolbar and menu for immediate access. However, although the Visua SourceSafe projects themselves have
been created, no files have been added to them.

9.12 Adding filesto Visual SourceSafe

The previous section has only established the mappings between the project directory on your hard disk (i.e. the
working directory) and the project directory in Visual SourceSafe (i.e. the controlled directory). Although the
project directory (and any subdirectories) on your hard disk may contain many source files whereas the directly
its mapped to in Visua SourceSafe will beinitially empty.

Firstly, you must select Visual SourceSafe as the version control system.

° Toaddafileor filesto Visual SourceSafe:

1. Select thefile(s), which you would like to add to Visua SourceSafe. You may also select afile folder,
project folder, aworkspace folder or combination thereof. When selecting the project or workspace
folder then the system files will be added to the selected file list. For example, selecting the project folder
will also add the project fileto thefilelist. If the project file isthen checked out and the version is newer
than when it was last |oaded you will be asked whether you want to reload the project.

2. Click the Add Files toolbar button ( @?) or select the [Tools->Version Control->Add Files] menu

option.

When you add files to Visua SourceSafe the local versionsin your working directory will become read only. To
check that the add files operation was carried out as you expected, or to quickly review the status of all of the
filesin aproject:

1. Select the project folder whose files you want to check.
2. Click the Status of Filestoolbar button ( @. ) or select the [Tools->Version Control->Status of Files]
menu option.

3. Thestatus of each file will be displayed in the “Version Control” tab of the “ Output” window. The
information shown includes whether the file is added to the project, if the file is checked out and, if it is
checked out, who did so.
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9.2 Visual SourceSafe commands
The following 8 operations are avail able:

* Add afileto version control

* Removeafile from version control

* Get aread only copy of afileor files

« Check out aread/write copy of afileor files (i.e. for editing)

« Check inapreviously checked out file or files (i.e. update Visual SourceSafe with the edits made)
« Undo aprevioudy check out operation on afile or files (i.e. cancel any edits made)*

* View the status of afile

¢ View the history of afile*

*These commands can only be accessed viathe [T ools->Version Control] sub-menu whereas all of the other
commands can be accessed from both the toolbar and menu.

9.21 Removing a File from Version Control

Although files appear in your HEW project (in the “Projects’ tab of the “Workspace” window, Visua
SourceSafeis not necessarily controlling them.

2 Toremoveafile or files from Visual SourceSafe:

1. Select thefile(s), which you would like to remove from Visual SourceSafe. Y ou may also select afile
folder, project folder, aworkspace folder or combination thereof.

2. Click the Remove Files toolbar button ( @' ) or select the [Tools->Version Control->Remove Files]
menu option.

9.2.2 Getting a Read Only Copy of a Filefrom Version Control

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. However, it is possible for any user to obtain aread only copy of any file.

2 Toget aread only copy of afileor files from Visua SourceSafe:
1. Select thefile(s), which you would like to get from Visua SourceSafe. Y ou may also select afile folder,
project folder, aworkspace folder or combination thereof.

2. Click the Get Filestoolbar button ( % ) or select the [Tools->Version Control->Get Files| menu
option.
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9.2.3 Checking Out a Writable Copy of a File from Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. This can only be done if another user does not already check out the file or files
in question.

2 To check out awritable copy of afileor files from Visual SourceSafe:

1. Select thefile(s), which you would like to check out from Visual SourceSafe. You may also select afile
folder, project folder, aworkspace folder or combination thereof.

2. Click the Check Out Files toolbar button ( %1 ) or select the [Tools->Version Control->Check Out
Files] menu option.

3. When the operation is finished the file has ared tick next to itsname. This means you as the current
user of HEW has checked it out.

9.24 Checking In a Writable Copy of a Fileinto Version Control

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users.

2 Tocheck in editsmadeto afileor filesin Visua SourceSafe:
1. Select thefile(s) upon which you would like to check back into Visual SourceSafe. You may also select a
file folder, project folder, a workspace folder or combination thereof.

2. Click the Check In Filestoolbar button ( 2 ) or select the [Tools->Version Control->Check 1n] menu
option.

9.25 Undoing a Check Out Operation

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users. However, if the check out operation was carried out by mistake, or perhaps
isno longer required, then the operation can be undone.

2 Toundo acheck out of afile or filesfrom Visua SourceSafe:

1. Select the file(s) upon which you would like to undo a previous check out operation. Y ou may also select
afile folder, project folder, a workspace folder or combination thereof.

2. Select the [Tools->Version Control->Undo Check Out] menu option.
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9.2.6 Viewing the Status of a File

Although files appear in your HEW project (in the Projects tab of the Workspace window), Visua SourceSafeis
not necessarily controlling them. Of those files, which are being controlled by Visua SourceSafe, some will be
checked in and others will be checked out (i.e. being edited by auser). The status command displays the current
status of afile or file(s).

2 Toview the status of afileor filesin Visua SourceSafe:
1. Select the filg(s) whose status you would like to view. Y ou may also select afile folder, project folder, a
workspace folder or combination thereof.
2. Click the Status of Filestoolbar button ( @ ) or select the [Tools->Version Control->Status of Files]
menu option.

3. If afilehasabluetick next to it auser different to you has checked it out.

9.2.7 Viewing the History of a File

Visual SourceSafe controls the edits to the filesin its projects and allows you to view the complete history of
these edits right back to the time that the file wasfirst added to the project.

2 Toview the history of afile or filesin Visual SourceSafe:

1. Select thefile(s) whose history you would like to view. Y ou may aso select afile folder, project folder, a
workspace folder or combination thereof.

2. Select the [Tools->Version Control->Show History] menu option.
9.3 Visual SourceSafe Integration Options

Y ou can control the way in which the history and status commands are displayed by selecting [Tools->Version
Control->Configure...].

To display the results of a history command in adialog box then check the “Display dialog box for history”
check box or clear it if you would rather display the output in the “Version Control” tab of the “Output” window.
To display the results of a status command in adialog box then check the “Display dialog box for file status’
check box or clear it if you would rather display the output in the “Version Control” tab of the “Output” window.
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10. Network Facilities

10.1 Overview

The High-performance Embedded Workshop is capable of sharing workspaces and projects across a network.
Thisallows usersto concurrently work on shared projects and see each other’ s changes as they happen. This
system can be used in conjunction with version control. The major difference with using this system is that each
user can modify and update the workspace and project without making all of the other users reload their project
and potentially lose all their changes.

This system isimplemented by making one of the machines attached to the network the server machine. All
other client machines then use the service this machineis providing. So if one of the client machines adds a new
file, the server machineisnotified. The server then notifies al other clients the action has taken place. This
structure is shown below in figure 10.1.

Metvwoarked workspace and project.

Metwork

Server

B Networked_Data_Example
-3 Metworked_Data_Example
{1 Debug

#-_ SimDebug 5H-2

Metwork access

Al files are under the netwark
zervice's control. These include
the warkspace, project, session
and source files.

1 1
‘ | | ‘ ‘ | Cliert= do not access data directly
weith the workspace and project
files onthe network. The clients cannot
directly communicate with each ather
either. All communication is directed
through the server machine.

Figure 10. 1: Network database access structure

The network system allows users to be given accessrightsto files. This allows the project administrator to make
sure the only people who can modify the project and source files are allowed to do so. This might allow the
administrator to limit each user to only have write capabilities for their own area of the project, other areas
would be read only. This could limit any potentia conflict or damage one user could do to other areas of the
project. Theselimitations can be set to anumber of different levels. Thisisoutlined later in this section.

Note: Certain operationsarelocked when other clientsare carrying them out. Thismeansthat if one
machineis currently changing the toolchain options all of the other machines can only seeread only
versions of this data.

Note:  The performance of HEW does suffer when using the network facilities. If workingin a small
team it might be more suitable to use the single user mode and version control.
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1011

Enabling networ k access

2 Touse network access:

1
2.
3.

10.1.2

Select [Tools->Options]. The HEW tools options dialog is displayed.
Select the network tab. Thisisdisplayed in figure 10.2.

Click the enable network access checkbox. This should add an administrator to the system without a
password. The administrator isthe only user that can add additional usersto the system and change user
access rights. The administrator has the highest level of access.

Before leaving the network dialog the administrator must set their password. It is not possible to leave
thisdialog until thisiscompleted. Thisis described below.

Setting the administrator user’s password

2 To set the password:

1

© N o g M wDN

158

Continue from the previous sections steps.

Click the password button. This should have been enabled when the network data access was enabled.
The password dialog isdisplayed. Thisisshown in figure 10.3.

The user nameisread only inthetop field. Inthiscaseit should be Admin.

Type the new password into both of the fields and click OK.

This should set the user and password on the [Tools->Options] network tab.

It isnow possible to leave the [Tools->Options] dialog.

When the dialog is closed you are asked if you want to save the workspace and then re-openit. Thisis
because the workspace must be re-opened in the shared access mode. |f the changes are not saved then
they will belost.

When the workspace is re-opened a dialog is displayed which asks you to log back into the system.
Once you have logged in adiaog is displayed which shows your current access rights. For exampleif
you are the admin user the level will be administrator. When thisdialog is closed the HEW server
window is opened and the network facilities are enabled.
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optons 2|

Build | E ditor I Workspacel Confirmation  Metwork |

[” Enable network data access

Metwork database access:

Login.. |
Uszer:
Pazsward .. |
Pazsword:

Aooess rights...l

Select zerver..

J

Ok I Cancel

Figure 10. 2: Initial setup of Network tab

x
IAdmin
Cancel |
Pazzword:

f
LCanfirmn pazzward by retyping below:

Figure 10. 3: Change password dialog
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10.1.3

Adding new usersto the system

The initial setting of the network database adds an administrator user and a guest user to the system. The
following levels of access are possible in the HEW system:

¢« Administrator:

Full accessto every aspect of HEW. The user can add and remove users from the projects and
change accessrights. The administration user can change the workspace and project files and aso
the source files.

¢ Full read/write access:

The workspace and project files can be modified, as can the sourcefiles. But it isnot possibleto
change user access rights from this access level.

* Read/writefile access:
Only the source files can be modified. All project settings can only be viewed not modified.
¢ Read only:

All source files and project files can only be viewed as read only. Nothing can be modified.

When any user opens a network-enabled project they must type in their user name and password. Until thisis
done no access can be granted. Once entered the user is given one of the levels of access as seen above.

2 Toadd anew user to the system:

1

o w D

Log in with a user who has administrator access rights. The process for doing thisis described above.
Select [Tools->Options]. The HEW tools options dialog is displayed.

Select the network tab. Thisisdisplayed in Figure 10.2.

Click the access rights button. The dialog displayed in Figure 10.4 is displayed.

Click the add button. Thelog in dialog isdisplayed. Thisallowsyou as the administration user to add
anew log in name and password. Normally the password should be set to some default text or left
blank. Then click OK.

Once OK isclicked the user is added with read only rights. To change the access level select the user
you wish to modify and then click the required radio button. Then click OK to save the access rights
changes.

2 Toremove an existing user to the system:

160
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Log in with a user who has administrator access rights. The process for doing thisis described above.
Select [Tools->Options]. The HEW tools options dialog is displayed.

Select the network tab. Thisisdisplayed in Figure 10.2.

Click the access rights button. The dialog displayed in Figure 10.4 is displayed.

Select the user you wish to remove in the userslist.

Press the remove button.

Then click OK to save the access rights changes.
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El@ @ Usger access rights |
b @ best
Lzers Access level 2dd
Adrmin
Guest R
Bemove |
- ACCess:
& Administratar

 Full read/wite access
€ ReadAwrite file access anly

" Fead only access

QK. I Cancel

Figure 10. 4: User accessrights dialog

10.1.4 Changing your password

To change your password:
1. Log intothe HEW network database you are changing your password for. Select [T ools->Optiong].
The HEW tools options dialog is displayed.

Select the network tab. Thisisdisplayed in Figure 10.2.

Click the password button.

Enter your new password and confirm it in the second edit box.
Click OK.

Then click OK to save the password change.

o 0~ WD

10.1.5 Usingthe network HEW service

When you connect to a networked project for the first time the HEW automatically connects you to the correct
network HEW service. Thisisdefined using machine name. If the service cannot be found using the machine
name in the workspace then the dialog displayed in figure 10.5 is shown. Simply type or browse to the machine
where the service islocated and click OK. If you want to be the server machine then leave the radio button on
its default selection, use local machine.
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Select Server Location ﬂ E

% se local machine
™ Use netwark maching Cancel |

Access;
LComputer name:

|| Browse. . |

Figure 10. 5: Select machine name

If you have previoudly been the server of a workspace then the following message will be displayed when you
attempt connection to another machine. Thisdialog is displayed in figure 10.6. Clicking OK then connects your
machine to the new location.

High-Performance Embedded Workshop [ |

& ‘workspace is registered to be shared on computer 'PAQDDSSZ', pou are registered to run server locally, do you want to change your server registration.

Cancel

Figure 10. 6: Select machine name

Note:  If the network is running multiple HEW workspaces with the network service enabled then a user can
only access one of them at onetime. The only instance when thisis not the case isif the same machineis
serving al of the network workspaces.
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11. Difference View

The High-performance Embedded Workshop has an integrated difference view. Thisview allows detailed
difference comparisons to be made with local files on the drive and a so with filesin the version control system.
In the HEW version 3.0 onwards the Visual SourceSafe component has this facility.

The difference window can be invoked two ways. Thefirst is from the show differences menu item on the tools
menu. The second is viathe workspace window pop-up with the same name. When using the pop-up menu the
current file selection is automatically added to the edit box. Clicking the show differences menu item displays

the dialog shown below in figure 11.1.

-« Difference

File: iry version contral

cvhewsprojects\myprojectsmyprojecthdbsct.c

1 #pragma section §DSEC
12 gztatic const struct {

18 char *rom_s; /* 8tart address of tl
tL] char *rom_e; /* End address of the
2 char *ram_s; /* gtart address of t}

2 }DTBL[]= {h

2z {__sectop("D"), _ secend("D"), _ sectop(’
L {__sectop("$AB3BD"), _ secend ("$ABIED")
EERTAE {_ _sectop("$AE316D") , _ secend("SABS1¢
*tie

¥ f#pragma section §ESEC
% gtatic const struct {
28 char *b_s;

0 char *h_e;

# }BTEL[]= {

= I mectani"RMY

/* gtart address of nc
/* End address of non-

secend (TRTI Y -

| |

=Bl

1? $pragma section SDSEC
15 gtatic const struct

18 char *rom_s; /* Start address of the :
2 char *rom e; /* End address of the in:
an char *ram s; /* gtart address of the :
a

JDTBL[]= {
a {__sectop("D"), _ secend("D"), _ sectop("R"
EL {_ sectop("$ABEBD"), _ secend("SAESSD"),

s

a5
i

7 fpragma section SBSEC

% static const struct |

2 char *h_s;

EL) char *h_e;

3 }BETEL[]= |

{__sectop("$aB31&D") _secend("SABSléD"-

/* gtart address of non-:
/* End address of non-in:

ol

Figure 11. 1: Differenceview

2 To perform adifference comparison with two files on your local drive:
1. Select [Tools->Show Differences...]. The difference compare files didog is displayed. Thisisshown

infigure 11.2.

2. Ensure the compare with file on drive radio button is enabled.
3. Enter thefirst and second file to compare. Y ou can either select a previous difference comparison or

browse to anew file.

4. Clicking the advanced button displaysthe dialog in figure 11.3. Thisalows you to perform the
difference comparison without taking white space into account. Click OK when you are finished with

this options dialog.
5. Click compare.

6. Thedifferenceview isdisplayed. The two files being compared are loaded into each side of the split
view. Their names are at the top of each window.

2 To perform adifference comparison with alocal file and afile in SourceSafe:
1. Ensurethe SourceSafe component is enabled. Also note that the file must be have been added into the

version control system.

2. Select [Tools->Show Differences...]. The difference compare files dialog is displayed. Thisis shown

infigure 11.2.

3. Ensurethe compare with version control radio button is enabled.
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4. Enter thefirst file to compare. You can either select a previous difference comparison or browse to a
new file.

5. Clicking the advanced button displaysthe dialog in figure 11.3. Thisallows you to perform the
difference comparison without taking white space into account. Click OK when you are finished with this
options dialog.

6. Click Compare.

7. Thedifference view isdisplayed as shown in figure 11.1.

Compare files

Reference file;

|K:\HEW2D\HEW LINEXEWwin'Release v | Browse.. |

" Compare with file on drive

Compare

Cancel

Advanced...

Elel

Tarqget file:

j Browse,.. |

* Compare with version contrak

Figure 11. 2: Difference compare files dialog

Compare Files - Advanced Options x|
"Advanced:

Figure 11. 3: Difference advanced options dialog

The difference view functionality can be accessed in two different ways. The difference view hasits own
toolbar thisis shownin figure 11.4. Thisfunctionality can aso be accessed via the difference window right
mouse button pop-up. Thisis shownin figure 11.5.

lgnare white space
Compare files

Find rext

Find previous
Find previous difference

Find next difference

Fd o dd 2 T &

Figure 11. 4: Difference toolbar
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Pl Compare...

Ewpont results to file...

L |gnore whitespace

@ Find
'& Find previous
# Find nest

F+ Previous difference
et difference

Refresh comparizon

Figure11. 5: Difference popup menu
The functionality for each menu item is described below:

* Compare: This opens anew compare window so that some new files can be comapred and the
differences displayed.

» Export resultsto file: This opens a dialog which allows you to choose afile to export the current
difference resultsto atextual format.

» Ignore white space: The ignore white space option which is on the advanced options dialog can be
toggled viathis menu item.

* Find: Displaysastandard find dialog. This usesthe same find dialog asthe HEW editor.
» Find next: Finds the next string that meets the find requirements.

» Find previous: Finds the next previous string that meets the find requirements.

* Previous Difference: Automatically jumps the view to the next previous difference.

* Next Difference: Automatically jumps the view to the next difference.

* Refresh comparison: Refreshs the view to manually run the difference comparison again. This can be
used if either file has been modified since the last comparison.

The difference window also allows the colours in the view to be customised. This procedure is outlined below:

2 To changethe colors viewed in the difference window:
1. Select [Tools->Format Views...]. The format views dialog is displayed.
2. Expand the difference view. Thedialog is shown and looks the same as figure 11.6.

3. Select the category you want to change. The color display tab is displayed and allows modification.
The categories available are Left hand side moved lines, Left hand side different lines, Right hand side
moved lines and Right hand side different lines,

4. Click OK to keep the changes.
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Coverage
= 10

‘5] Fegister
= TCL Toolkit
] Event

Text

Frafile
Statuz
Label
temary

Output

fddl ity

LHS Different Lines .
LHS Moved Lines | Courier Neww
RHS Different Lines
RHS Moved Lines
Selected Text

Performance Analyzis

=] Font |

Fant

Paint Size

I'I1 ‘l

21

Hemave

HEW Semple Text

Cancel
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Figure 11. 6: Format viewsdialog
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12. Technical Support

The High-performance Embedded Workshop has a number of integrated technical support features.

2 To check for HEW product updates or service packs:
1. Select [Help->Technical support->Check website for updates].
2. Your default web browser isinvoked and defaults to the HEW download page for your region.
3. Browsethisareafor HEW updates to fix bugs or add new features.

Occasionally you may experience some unforeseen problems with the HEW application. |f a problem does
occur that results in a application crash the HEW bug tracking program will be invoked automatically. This
alows you to compile a bug report and this can then be sent to your technical support contact in avariety of
ways. Itisalso possibleto invoke this tracker program manualy. Thisis described below:

2 Tocreate and send a HEW bug report:

1
2.

Select [Help->Technical support->Create Bug Report].

Detailed information is generated from your HEW system. This may take sometime. The bug report
dialog isthen displayed. Thisisshownin figure 12.1.

It is possible to then add additional information concerning the exact issue you have found in the large
edit box.

Once you are happy with your report, you can choose the method of sending the report in the submit
drop list. You can print it, email it, or saveitto adisk.

Then click submit. Thiswill send the report by the selected method.
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Subrit & B

Y'ou may submit a Bug Report through e-mail, or by conventional means.

The box below contains information gathered from pour machine, and any additional information
about the state of the software if a crazh occurred.

R&M Information :

Load : EE

Total Rk 536,379,392 bytes
Free Rak : 391,581,696 bytes
Page File : 1,309,028,352 bytes
Fage File Free : 1.204,385,856 bytes
Tatal Yirtual : 2.147.352 576 bytes
irtual Free : 250,084,864 bytes

Froject D etails :

Mo project information awailable

Please type a description of the problenm you wish to repart:

Ll

—How would you like to submit the report?

Submit I

N I

Cancel |

Frint j
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Figure 12. 1: Submit bug report dialog
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13. Navigation facilities

The High-performance Embedded Workshop has a number of integrated navigation facilities. The navigation
window islocated alongside the project and templates window. Thisview is shown below in Figure 13.1.

H|

Mavigation entries

L) AMIMAL

ED M avigation categary

- dema Project
- a% CShark

----- @) CShark()
----- @) ~CShark[]

- g% CCrocodie
----- @) CCrocadile(]
----- @) ~CCrocodilel)
----- @) GetClaszMamelvaoid]
----- agl m_nLiveinia/ater
----- &) m_nSharpTeeth
- g% CFish Clasz name
----- &) CFizhi)
----- &) ~CFish()
----- &) GetClassM ame(void) Class members
----- &) m_nLiveiraater
- o CGreafwhite
----- @) Chreafwhite()
----- @) ~Chreatwhitel]
----- ) FeedTheShark[CCrocodile” myGoat)
----- @) FeedTheShark[CFish* myFishpFood)
----- &) FeedTheShark(char® pszOtherT ppe)
[
[

----- @) FeedTheShark[CHorzse® myHorseyFood)
----- @) FeedTheShark[CPerson® myFPerzonFood] j

Project | Templates Mavigation I

Figure 13.1: Navigation view

The navigation view contains categories for all supported navigation types. In HEW 3.0 the following
navigation components are supported as standard:

* C Defines: All #definesfor C and C++ source files are displayed.
¢ CFunctions: All ANSI C standard functions are for C source files displayed.
e C++ Classes: All classes, functions and members are displayed for C++ sourcefiles.

Each category isdisplayed in the top level of the view. Underneath each category each project in the workspace
is displayed. Then the items belonging to that particular project are displayed below the project icon.
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It is possible to disable scanning for certain navigation categoriesif you do not require the information.

2 To switch off anavigation category:
1. Right click on the Navigation window. The pop-up menu displayed in figure 13.2 is shown.

2. Select the“ Select Categories...” menu item.
3. Thedidogin figure 13.3 isdisplayed.
4. Uncheck any categories you are not interested in seeing definitions for.
5. Click OK.

G0 ko Declaration

150 ko Definition

Configure Yigw...

Seleck Categories., ..

’T Al Docking
Hide:
Figure 13. 2: C++ Navigation pop-up menu
Select Categories E

Pleasze zelect the categories to zcan for

V|C Defines -
[w|C Functions Cancel |
(w|C++ Clazzes

Figure 13. 3: C++ Navigation select categories dialog

Note: The navigation items ar e displayed gradually asthefilesare scanned. Thismeansit may take some
timeif therearemany filesto fully complete the Navigation view update.

Filesarerescanned when they are saved. Thismeansthat navigation information will not be available for
new classes and functions until thefileor filesare saved.
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13.1 C++ Navigation component

The C++ navigation component is the most complicated of the three supported navigation components. It
supports the following structures in the view for C++ source files. The basic structure of the information is
shown below in figure 13.4.

B
) AMIMAL =]
E...[“_:"[:++ Claszes C++ navigation categary title
- dema Project name
- o CPerson

aw CCrocodils
CCrocodileShark
CFizh Clazs name
CHorze
Chd arnrmal
CReptile

- ChGreatwhite
----- @) Chreafwhite()

----- @) ~Chreatwhitel]

----- @) FeedTheShark[CCrocodile” myGoat

----- @) FeedTheShark[CFish* npFizhyFood .

----- &7 FeedTheShark[char® pez0therT ppe ————— Class Member functiors
[
[

----- @) FeedTheShark[CHorze® myHaorseyF
----- @) FeedTheShark[CPerson® nyPerzan
----- @) FeedTheShark[void)
----- @) GetClaszMamelvaoid]
..... &gl m_nDangerous Protected member wariable
..... agl m_nlaws Private member varable

----- @) m_stiMame ]
- (@] Globals Global variables and
. functions Folder

----- @) theap_area

----- @ AINT “ectors]] il
1| | 3
Project I Templates Mavigation I

Figure 13. 4: C++ Navigation information

The C++ navigation view uses a number of icons to describe the type of function or variable the icon belongs too.
These arelisted in the table bel ow:
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Description

Public member function

Protected member function

Private member function

Public member variable

Protected member wvanable

Private member variable

olelclefe]e]

Figure 13. 5 C++ Navigation Icons

The navigation view allows you to move around your source code quickly and efficiently. Double clicking on a
navigation item by default jumps you to the associated navigation items definition. Normally the definitionis
found in the source file and the declaration is found in the header file.

This default behavior can be modified for this action. This can be achieved via the configure view dialog. The
configure view dialog modifies the way datain the Navigation view is displayed.

2 To configure the C++ navigation views data:
1. Right click on a C++ navigation item in the navigation window. The pop-up menu displayed in figure
13.2 isshown.

2. Select the“Configure view” menuitem.
3. Thedidogin figure 13.6 isdisplayed.
4. Decidewhat items you wish to modify and click OK to accept the changes.

Configure Yiew x|

v Jump to definition on double-click

QK. I Cancel

Figure 13. 6 C++ Configure view dialog

The following items are available on the configure view dialog.
«  Group by access: Thisoption groups the display of public, protected and private member variables and
functions together in the Navigation view.
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Jump to definition on double click: By default this option is checked. If thisoption is switched off then
adialog is displayed which asks you where you wish to jump. Y ou rather than HEW resolve the
ambiguity. Thisdialog isshownin figure 13.7.

Select Query Location |

Select the query to jump to:

Go ta Declaration [Manimal k', line 12)
Go ta Definition ["animal.h", line 12]

Cancel |

Figure 13. 7 Select Query L ocation dialog

Another useful facility isthe capability of viewing the base or derived classes for a certain selection.

2 Toview the Base or derived classes

1
2.
3.

Select the class that interests you in the Navigation view.

Right click and view the pop-up menu.

To see the derived classes for the selection click the “ Show Derived Classes’ menu item. To seethe
base classes for the selection click the “ Show Base Classes’ menu item.

Depending on the selection adidog is displayed which shows the class structure selected in an
expanded tree format.

Click Close to close this dialog once you have the information you require.
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13.2  C Function and #defines navigation components

These components smply add the function and #define definitions to the Navigation view. It isthen possible to
jump to these definitions by double clicking on the label you wish to view.

Es
=[] G Defines - = ctlefine T_ﬂvigatinn
B8] demo = categary titls
Iﬁ@ #ilefine

----- ) FLMAX

----- &7 FLMIN

----- 0 HEAPSIZE
----- ) INT_OFFSET
----- ) IOSTREAM

----- &0 STOOUT ) o

=-(] G Functions L function navigation
= Iﬁ dema categony fithe

o Hsbrk ANSI C function

----- &) GLOSEALL

""" a7 IMIT IOLIB 4
4| | »

@ijects J @ Templates I @:INa\rigaﬁun I_

Figure 13. 8 C Function and #defines navigation information
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14. Smart Editor

Another feature of the High-performance Embedded Workshop isits smart edit facility. Thisisenabled by
default for all C++ sourcefiles. Thisfeature allowsthe HEW editor to access C++ navigation information and
provide auto-completion help when using C++ classes and member functions.

2 Toview the Smart edit satus:

1

2.
3.
4

Click on the [T ools->Options] menu item.
Select the “Editor” tab of the tools options dialog.

Thediaogin figure 14.1 isdisplayed. The “Enable Smart-edit for C++ files’ should be checked.

Click OK.

Build ~ Editor |W’0rkspace Eonfirmationl Networkl

21|

— Spacing:

Tab size: I 4

V¥ Enable auto indentation

— General:

¥ Save files before executing any tools V' Show files in natebook

™ Prompt before saving files [V Enable syntax coloring

¥ Enable Smart-edit far C++ files ¥ Enable tooltip watch

— Extemal editar:

™ Use external editor;

| iy |

o1

Cancel

Figure 14.1: Options Dialog Editor Tab

With this option switched on if you are working on a C++ file the smart-edit capability should be enabled.

Note: If the C++ Class navigation category has been switched off the Smart-edit capability of HEW will
not be active.

During normal usage the following editor operations will make the smart edit facilities visible.

°

If you are using an object and are trying to access the membersusing the . or ‘->'. If you do thisa

pop-up will be displayed which may help you select the correct member more efficiently than typing.
Whilst typing the pop-up will keep track of the keys you have pressed to help your selection. If you press

RENESAS

175




return then the currently selected member will be added. This pop-up isalso used when using the ‘::’
method and it isdisplayed in figure 14.2.

2 If you aretrying to use a C++ function then the dialog in Figure 14.3 is displayed when the first open
bracket is entered. Thisdiaog allows you to see what functions are available for the current object.
Selecting the function automatically enters the remaining parameters for you.

finclude "greatwhite h"
wold main{woid];

wvold mainfwvoid)

CGreatWhite claws;
claws . m_n

y Ein nage S
agim_nDangerous

Egim_nFins

aglm_nlaws

& m_nLeqgs

A m_nLiveinater
Egim_nlives

“]m_nSea

e = -

Figure 14.2: Smart-edit member selection

finclude "greatwhite h"

wold main{woid];

wvold mainfwvoid)
CGreatWhite nyfish:
nviish . FeedTheSharl(

ink FeedTheshark{CFish* myFishywFood) ;I
T ink FeedThesShark{CHorse* myvHorsevFood)

int FeedThesha  myPersonFood) J

ink FeedTheshark{char* psaOtherTywpe) LI

Figure 14.3: Smart -edit function selection
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Note: Smart-edit auto completion may not pop-up for avariety of reasons. HEW can only provide help
when the file has been scanned by the navigation component. For thisto work thefile must have been

saved.
Another issueisthat #defines are not considered so this meansthat redundant ar eas of code may till be

visible.
Another important consideration isif the syntax of your codeisincorrect the smart editor may not be able
to parseyour code correctly and the smart edit functionality will fail. In this case no pop-up will be

displayed.
Please note that Smart-edit does not support macro usage.
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Emulator Debugger Part
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Section1l Overview

11 Features

The breakpoint, memory map, performance, and trace can be set through the dial og box.
O Intuitive user interface

0 Online help

0 Common display and operability

Supported host interfaces

The PCI interface, PC card (PCMCIA) interface, USB interface, or LAN interface can be used for connecting
to the host computer.

Realtime emulation
Realtime emulation of the user system is enabled at the maximum operating frequency of the CPU.
Excellent operability

Using the HEW enables user program debugging using a pointing device such asamouse. The HEW
enables high-speed downloading of load modulefiles.

Various debugging functions

Various break and trace functions enable efficient debugging. Breakpoints and break conditions can be set
by the specific window, trace information can be displayed on a window, and command-line functions can be
used.

Memory access during emulation
During emulation, the memory contents can be read and modified.
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12 Warnings

CAUTION

READ the following warnings before using the emulator product.
Incorrect operation will damage the user system and the emulator
product. The USER PROGRAM will be LOST.

1. Check al components against the component list after unpacking the emulator.
2. Never place heavy aobjects on the casing.
3. Do not place the emulator in places where:

¢ Thetemperature becomes high such asin direct sunlight or near a heater. For details, refer to section 1.3,
Environmental Conditions.

¢ Thetemperature or humidity changes greatly.

e Thereisalot of dust.

* Thereisalot of vibration. For details, refer to section 1.3, Environmental Conditions.
Protect the emulator from excessive impacts and stresses.

Only supply the specified voltage and power-supply frequency.

When moving the emulator, take care not to vibrate or damageit.

After connecting the cable, check that it is connected correctly. For details, refer to section 2, Preparation
before Use. Supply power to the connected equipment after connecting all cables. For the supplying
procedures, refer to section 2.7, System Check. Cables must not be connected or disconnected while the
power ison.

N o gk
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13 Environmental Conditions

CAUTION

Failure to do so will cause illegal operation in the user system, the
emulator product, and the user program.

Observe the conditions listed in table 1.1 when using the emulator.

Tablel.1 Environmental Conditions

Item Specifications

Temperature Operating: +10°C to +35°C
Storage: —-10°C to +50°C

Humidity Operating: 35% RH to 80% RH, no condensation
Storage:  35% RH to 80% RH, no condensation
Vibration Operating: 2.45 m/s’ max.
Storage: 4.9 m/s” max.

Transportation: 14.7 m/s’ max.

Ambient gases  No corrosive gases may be present

14 Emulator Exter nal Dimensions and M ass

Tablel.2 Emulator External Dimensionsand Mass

Item Specifications
Dimensions 219 x 170 x 54 mm
Mass Approximately 1,000 g
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Section 2 Preparation before Use

21 Emulator Preparation

Unpack the emulator and prepare it for use as follows:

A WARNING

READ the reference sections shaded in figure 2.1 before using the
emulator product. Incorrect operation will damage the user system and
the emulator product. The USER PROGRAM will be LOST.

Reference

Unpack the emulator Component list
I

Check the components against
the component list

Section 3
Set up the emulator

- Insert the optional board
- Install the HEW
- Connect the interface cable

Turn on the user system Section 4
(Only when the user system is connected)

Turn on the emulator
1

Start the HEW

Setup

Activation

Figure2.1 Emulator Preparation Flowchart

2.2 Installing Emulator’s Software

Toingtall the HEW, refer to the Setup Guide for the EG000 Emul ator supplied together with the emulator.

RENESAS

183




2.3 Connecting to the User System
To connect the emulator to a user system, proceed as follows:

e Connect the user system interface cable head to the user system.
* Plug the cable body into the emulator.
¢ Plug the cable body into the cable head.

For details of these steps, refer to the User System Interface Cable User's Manual.

Figure 2.2 gives details of the connectors provided on the emulator.

EB000 < PCinterface cable

connector
User system M\

interface connector

I < Power connector

External probe —> <~ Power switch
connector T ?
Screw Screw

Figure2.2 E6000 Emulator Connectors

231 Example of Connecting the User System Interface Cable Head to the User System

Screw (x 4)

RN
¥

] User system interface
| cable head

Figure2.3 Example of Connecting User System I nterface Cable Head to User System

« Ensurethat all power is off to the emulator and the user system.
* Insert the cable head into the socket on the user system.

Note: Depending upon the package, it may be possible to orientate this cable head in any position on the socket,
so care should be taken to correctly identify pin 1 on the emulator and socket when installing.
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Screw the cable head to the socket with the screws provided. Progressively tighten the screws in the sequence
shown in figure 2.4 until all are ‘finger tight'.

© 06

<1

® @

Figure2.4 Sequenceof Screw Tightening

Note: Be careful not to over-tighten the screws as this may result in contact failure on the user system or

damage the cable head. Where provided, use the ‘ solder lugs' on the QFP socket to provide extra
strength to the emulator/user system connection.

232 Plugging the User System Interface Cable Body into the Emulator

Plug the cable body into the emulator, taking care to insert it straight, and push it firmly into place.

User system interface cable body

User system interface cable head

© = \—’- -
=0 T
\ = Emulator

User system interface cable

Figure2.5 Plugging User System Interface Cable Body to Emulator

233 Plugging the User System Interface Cable Body into the Cable Head

Plug the cable body into the cable head on the user system.
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24 Power Supply

241  AC Adapter

The AC adapter supplied with the emulator must be used at all times.

24.2 Polarity

Figure 2.6 shows the polarity of the power-supply plug.

5V (outside)

GND (inside)

Figure2.6 Polarity of Power Supply Plug

243 Power Supply Monitor Circuit

The emulator incorporates a power supply monitor circuit which only lights the red LED when a voltage higher
than 4.75 V is supplied. If this LED is not illuminated, you should check the emulator voltage level. An input
voltage lessthan 4.75 V could indicate that enough current cannot be supplied to the emulator.

Note: Use the provided AC adapter for the emulator.

25 SIMM Memory Module

E6000 emulator’ s optional SIMM memory modules are available which provide emulation memory for user
code without needing a user system. The optional SIMM memory modules are available in different memory
size, but all are partitioned into four equal banks. These banks can be rel ocated on page boundaries anywherein
the user area. Note that, however, some products do not support the SIMM memory module.

251 Optional SIMM Memory Module Configuration

The configuration of the optional SIMM memory module is controlled by the mapping RAM. Opening the
[Memory] sheet of the [System Status] window alows you to check which optional SIMM memory module, if
any, isinstalled and aso allows the four banks to be relocated to the required addresses from the [Memory
Mapping] dialog box.
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2.6 Hardware Interface

All signasaredirectly connected to the MCU in the emulator with no buffering with the exception of those
listed in section 7, Hardware Specifications Specific to This Product.

26.1 Signal Protection on the emulator
All signals are over/under voltage protected by use of diode arrays. The only exceptions being the AV . and Vref.
All ports have pull-up resistors except for analog port.

All V. pins on the cable head assembly are connected together (with the exception of the AV . pin), and are
then monitored by the emulator to detect powered user system presence.

2.6.2 User System Interface Cir cuits

The interface circuit between the MCU in the emulator and the user system has asignal delay of about 8 ns due
to the user system interface cable and it includes pull-up resistors. Therefore, high-impedance signals will be
pulled up to the high level. When connecting the emulator to a user system, adjust the user system to compensate
for propagation delays.

The following diagrams show the equivalent circuit examples of the interface signals. Theinterface circuits
depend on the MCU type. For details, refer to section 7, Hardware Specifications Specific to This Product.

2.6.3 Clock Oscillator

The oscillator circuit has been implemented on the user system interface cable head. For details on the oscillator
circuit, refer to the user's manual for each user system interface cable.

2.6.4 External Probe 1 (EXT1)/Trigger Output

An 8-pin connector, marked EXT1 (on the right under the user system interface cable connector), on the
emulator case accommodates four externa probe inputs and two trigger outputs. The pin assignment of this
connector is shown in figure 2.7.

1 | |
GND| GND |
Tuvce Tsv

OOO0OOOOO0 | exn
[ I
T 11

Probe Trigger output

Figure2.7 External Probe Connector 1
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The interface circuit for the externa probe 1 is shown in figure 2.8.

Vce
10 kQ
HD151015 External probe 1, 2, 3, 4

22 Q

Figure2.8 Interface Circuit for External Probe 1

The trigger output is controlled by event channel 8 and is an active low signal. The trigger output is available as
either TS5V (within the range from 2.5V to 5 V; does not depend on the user V level) or TUV . (the user V.
level).

26.5 External Probe 2 (EXT2)/Trigger Output

A 6-pin connector, marked EXT2 (on the left under the user system interface cable connector), on the emulator
case accommodates four trigger outputs. The pin assignment of this connector is shown in figure 2.9.

OOOOOCGD EXT2
[ 5
1]

Trigger output

Figure2.9 External Probe2 Connector

The trigger output is an active high signal which is output during the read or write cycles when a trace condition
(1 to 4) of the bus monitor function is satisfied. The trigger output is available asuser V. level. Note that,
however, some products do not support the external probe 2 (EXT2).
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2.6.6 Voltage Follower Circuit

CAUTION

1. Do not connect the user system interface cable to the emulator
without user system connection.
2. Turn on the user system before starting up the emulator.

A voltage follower circuit isimplemented on the emulator which allows the user system voltage level from the
user system to be monitored. This monitored voltage level is automatically supplied to the logic on the emulator
and is derived from the emulator power supply unit. This means that no power istaken from the user system
board.

If no user system interface cable is connected to the emulator, the emulator will operate at a specified voltage
and al clock frequencies will be available to the user. If the user system interface cable is attached, the emulator
will match the voltage supplied to the user target in all cases; i.e. even when the user V. is below the operating
voltage for the MCU. Y ou must be careful not to select an invalid clock frequency. When the emulator is
connected to the user system and the user system is turned off, the voltage follower circuit output voltage level is
0 V. Inthis case, the emulator will not operate correctly.

You can set auser V. threshold in the range Vcc max. — 0V by using the emulator configuration dialog box. If
the user V. drops below this threshold, [User System Voltage] in the [Extended Monitor] window will display
Down, otherwise OK is displayed.

33V o

threshold

User Vcc level

User Vi - ..o I
threshold oK [ [

33V

E6000
Vcec level

The user system interface
cable is not connected.

Figure2.10 VoltageLevel Monitoring (Examplefor Vcc = 3.3 V)
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2.7 System Check

When the software is executed, use the procedure below to check that the emulator is connected correctly. Here,
use the workspace for atutorial provided on the product.

Refer to section 2.9, Other Methods for Activating the Emulator, for the other activating method to create a new
project or use a workspace for the HEW of the old version.

1. Connect the emulator to the host computer.

2. Connect the user system interface cable to the connector of the emulator.
3. Turn on the emulator.

4. Activate the HEW from the [Programs] in the [Start] menu (figure 2.11).

‘Windows Update

L4 @ Tools L4

ACcessories 4 |'_§Q High-performance Embedded Warkshop Help
Documents 4 ¥ @ High-performance Embedded Workshop Read Me

High-performance Embedd shop

Settings 4

Professional

Search 4

Help

Run...

EHhenELLE

Windows 2000

Shut Dawr. ...

Figure2.11 [Start] Menu

Note: If ‘LAN Driver' isnot selected at installation, [Tools] is not displayed.
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5. The[Welcome!] dialog box is displayed.

2l
e
&' ‘Create a new project workspace Cancel |
) Mpen arecent project workspace: Administration... |
= | ]
= :
g " Browse to another project warkspace

Figure2.12 [Welcome!] Dialog Box

To use aworkspace for the tutorial, select the [Browse to another project workspace] radio button and click the
[OK] button.

When the [Open Workspace] dialog box is opened, specify the following directory:
HEW installation destination directory\Tool s\Renesas\DebugComp\Pl atform\E6000\xxxx\Tutorial

After the directory has been specified, select the following file and click the [Open] button.

Open '

2|

Look in: Ia Tutorial j - IC_QF -

Debug_HE5_z237 _ES000_Emulator _CP
Source

File: name: |Tutnrial.hws Open I
Files of type: IWorkspaces [ bwwz] ﬂ Cancel |
e

Figure2.13 [Open Workspace] Dialog Box
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When no compiler package or that of a different version isinstalled, the following message box will be displayed.

High-petformance Embedded Workshop ﬂ

Tutorial

there is mo compatible toolchain available

T'j Tool Chain 'Hitachi HES,HE/300 Standard Toolchain', version scod is missing Fram the Following praject(s)
L

Figure2.14 Message Box

6. The[E6000 Driver Details] dialog box is displayed. Thisdialog box isonly displayed at the first initiation.
When only one of interface driversis selected, this dialog box is not displayed.

Drriver: IEmuIatnr PCI Gard Driver LI
— Details
Interface: IPOI LI
Channel: IEmuIatDr PCI Card Interface ;I

= Confiuration
Canfigure... |

[~ Change driver in start up

Figure2.15 [E6000 Driver Details] Dialog Box

¢ Inthe[Driver] combo box, select the driver to connect the emulator.
« [Interface] displays the name of the interface to be connected.
¢ Click the [Close] button.
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7. Set uptheemulator. During this process, the following dialog box is displayed.

Attempting to connect the emulator.

Starting to tranzfer a firmware file.

[~ Change driver in start up

The driver program has been initialized (Emulator PGI Card Drlver)

Cloze |

Figure2.16 [Connecting] Dialog Box

8. When "Connected” is displayed in the [Output] window of the HEW, the emulator initiation is completed.

=3 Csource file

B G+ source file
I eselpig.cpp

[ Tutorial abs
E\--a Dependencies
sbrk.h
sorth
stackscth

E a Diawnload modules

K1l

E DESCRIPTIOH ‘Main Program

% Thi=z file iz generated by Hitachi Froject ™

_ol x|
<l File Edit “iew Project Options Build Debug Memory Tools ‘Window Help _|55|
ME
" p
EE=L - g =
= @ Tutorial % :Tutorial .cpp

e

ye

#ifdef _ cplusplus
extern "C" {
#endif

wolid abort{woid):
#ifdef _ cplusplus
1

#endif

#include "sort.h"
i laede e d1ib L

~ Projects [ & Templatss | ) Navigation |

<% hatorial.cpp

2connected

A * [\ Build 4, Debug A Find in Files

“ersion Control

Ready [Read-write  [1/63 It ms [ w4
Figure2.17 HEW Window
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2.8 Communication Problems

The following message box will be displayed when the emulator power is turned off or the PC interface cableis
not correctly connected.

xxxxx E6000 Ermulator ﬂ

A werification error has accurred during the transfer of a Firmware File,
This is probably because the emulator has been burned off or another emulator has been connecked,

Figure2.18 Error Message

For information on other errors, refer to the Setup Guide for the EG000 Emulator.
2.9 Other Methodsfor Activating the Emulator
Refer to section 4, Preparation before Use.

2.10 Uninstalling the Emulator’s Software

For details on uningtallation, refer to the Setup Guide for the E6000 Emulator.

194
RENESAS




Section 3 E6000 Emulator Functions

3.1 Debugging Features

311 Breakpoints

The emulator provides a comprehensive range of alternative types of breakpoints, to give you the maximum
flexibility in debugging applications and user system.

Hardwar e Break Conditions. Up to 12 break conditions can be defined using the event and range channelsin
the complex event system (CES). For more information about the hardware break conditions, see section 3.2,
Complex Event System (CES).

Program Breakpoints (PC Breakpoints): Up to 256 program breakpoints can be defined. These program
breakpoints are set by replacing the user instruction by aBREAK instruction. In target ROM, only one
breakpoint (on-chip break) can be set.

312 Trace

The emulator incorporates a powerful realtime trace facility which allows you to examine MCU activity in detail.
The reatime trace buffer holds up to 32768 bus cycles, and it is continuously updated during execution. The
buffer is configured as arolling buffer, which can be stopped during execution and read back by the host
computer without halting emulation.

The data stored in the trace buffer is displayed in both source program and assembly languages for ease of
debugging. However, if trace filtering is used, only assembly language can be displayed.

The buffer can be set up to store all bus cycles or just selected cycles. Thisis called trace acquisition and uses the
complex event system (CES) to select the parts of the program you are interested in.

It isalso possible to store all bus cycles and then just look at selected cycles. Thisiscalled tracefiltering.

313 Execution Time M easur ements

The emulator allows you to measure the total execution time, or to measure the time of execution between
specified eventsin the complex event system. You can set the resolution of the timer to any of the following
vaues:

20 ns, 125 ns, 250 ns, 500 ns, 1 ys, 2 s, 4 us, 8 s, or 16 ps.

At 20 ns the maximum time that can be measured is about six hours, and at 16us the maximum timeis about 200
days.

314 Per formance Analysis

The emulator provides functions for measuring the performance of a program. The performance of the specified
program range can be displayed either as a histogram or in percentage form. A timer resolution of 20 ns, 40 ns,
or 160 ns can be selected. In addition, the execution count of the specified program range can be measured (1 to
65535).
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315 Bus Monitoring

The emulator incorporates a bus monitoring function that monitors and displays the contents of the accessed area
in HEW windows without stopping the program execution. Up to eight blocks of 256 bytes can be monitored.

In addition, the emulator can output trigger signals from external probe 2 (EXT2) when specified addresses (four
points max.) are accessed. Note that, however, some products do not support the bus monitoring function.

3.2 Complex Event System (CES)

In most practical debugging applications, the program or hardware errorsthat you are trying to debug occur
under a certain restricted set of circumstances. For example, a hardware error may only occur after a specific
area of memory has been accessed. Tracking down such problems using simple PC breakpoints can be very
time-consuming.

The emulator provides a very sophisticated system for giving a precise description of the conditions you want to
examine, called the complex event system. This allows you to define events which depend on the state of a
specified combination of the MCU signals.

The complex event system provides a unified way of controlling the trace, break, and timing functions of the
emulator.

321 Event Channels

The event channels allow you to detect when a specified event has occurred. The event can be defined asa
combination of one or more of the followings:

¢ Address or address range

¢ Addressoutside range

* Read or Write or either

« Data, with an optional mask

¢« MCU accesstype (e.g., DMAC and instruction prefetch)

¢ MCU access area (e.g., on-chip ROM and on-chip RAM)
¢ A signd state on one or more of the four external probes

¢ A certain number of timesthat the event must be triggered
« Delay cycles after an event

Up to eight events can be combined into a sequence, in which each event is either activated or deactivated by the
occurrence of the previous event in the sequence. For example, you can cause a break if an 1/0 register iswritten
to after a specified area of RAM has been accessed.

322 Range Channels
The range channels can be set up to be triggered on a combination of one or more of the following:

¢ Address or address range (inside the range)

* Read or Write or either

« Data, with an optional mask

¢ MCU accesstype (e.g., DMAC and instruction prefetch)

¢ MCU access area (e.g., on-chip ROM and on-chip RAM)
¢ A signd state on one or more of the four external probes
« Delay cycles after an event

The complex event system can be used to control the following functions of the emulator:
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323 Breaks

Use breaks to interrupt program execution when a specified event, or sequence of events, is activated. For
example, you can set up abreak to halt execution when the program reads from one address, and then writesto
another address. The break can also optionally be delayed by up to 65535 bus cycles.

324 Timing

Y ou can set up two events and then measure the execution time of the program between the activation of the first
event and second event.

3.3 Har dwar e Features

331 Memory

The emulator provides standard emulation memory as the substitute for on-chip ROM memory and on-chip
RAM memory. When a device type or device mode without an on-chip ROM or on-chip RAM is selected, the
standard emulation memory is disabled. When debugging with only the emulator and the user program and data
are stored in an external address space, an optional SIMM memory module must be used. The optional SIMM
memory modules can be separately purchased.

The emulation memory can be mapped in 64-byte units to any number of separate memory blocksin the MCU
address space. Each memory block can be specified using the memory mapping function as user (Target) or
emulator (SIMM memory module) and, in each case, the access can be specified as read-write, read-only, or
guarded.

The definition of each type of memory is asfollows:

Table3.1 Memory Types

Memory Type Description

On-chip Uses the MCU on-chip memory.

User Accesses the user system memory.

Emulator Accesses the emulator SIMM memory module.

The contents of a specified block of memory can be displayed using the memory function. The contents of
memory can be modified at any time, even during program execution and the results are immediately reflected in
al other appropriate windows.

Note that modifying memory contents during program execution has the following time requirements:

1. MCU on-chip ROM or RAM, or emulator SSIMM memory module
The emulator modifies the memory contents by temporarily switching the memory bus to the emulator side
without stopping the user program execution. Therefore, the emulator uses the memory bus for up to 80 usin
reading of 256 bytes (25 MHz, on-chip ROM).

2. MCU on-chip I/O, DTCRAM, or user system memory
The emulator stops the user program execution, then modifies the memory contents. Therefore, the user
program stops for a maximum of 2 msin reading 256 bytes (25 MHz, emulation memory).
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332 Clocks

The clock can be specified as emulator internal clock or target clock. The frequencies that can be specified as
the emulator internal clock depend onthe MCU. For details, refer to section 8, Software Specifications Specific
to This Product.

333 Probes

External probes 1 and 2 (EXT1 and EXT2) can be connected to the emulator, to make use of signas on the user
system for break or trace. The signal for external probe 1 can be set asthe condition for the event detection
system depending on the low or high level. Sincethe signal for external probe 2 outputs high level when the
trigger setting (1 to 4) condition is matched in the bus monitor function, the signal can be used for the trigger
condition for such as an oscilloscope.

3.4 Stack Trace Function

The emulator uses the stack’ sinformation to display the name of the calling function for a function at which the
program counter is currently pointing. This function can be used only when the load module that has the
Dwarf2-type debugging information is loaded. For the usage of thisfunction, refer to section 6.17, Stack Trace
Function.

3.5 OnlineHelp

An online help explains the usage of each function or the command syntax that can be entered from the
command line window.

Select [Emulator Help] from the [Help] menu to view the emulator help.
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Section 4 Preparation before Use

4.1 Wor kspaces, Projects, and Files

Just as aword processor allows you to create and modify documents, HEW allows you to create and modify
workspaces. A workspace can be thought of as a container of projects and, similarly, aproject can be though of
as acontainer of project files. Thus, each workspace contains one or more projects and each project contains one
or morefiles. Figure 4.1 illustrates this graphically.

WORKSPACE

Figure4.1 Workspaces, Projects, and Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can aso be linked hierarchically within aworkspace, which means that when one project is built al of its“child”
projects are built first.

We need to add a project to a workspace and then add files to that project before we can actually do anything.
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4.2 Method for Activating HEW
To activate the HEW, follow the procedure listed below.

1. Connect the emulator to the host computer.

2. Connect the user system interface cable to the connector of the emulator if you use the user system interface
cable. Thisisnot necessary when you do not use the user system interface cable.

3. Turn on the emulator. Be sure to turn on the user system before supplying power to the emulator if you use
the user system.

4. Activate the HEW from [Programsg] in the [Start] menu.

5. The[Welcome!] dialog box is displayed.

— Optiors; 0K

&' ‘Create a new project workspace Cancel

) Mpen arecent project workspace: Administration...
= | ]

=

g " Browse to another project warkspace

Flt

Figure4.2 [Welcome!] Dialog Box
[Create a new project workspace] radio button: Creates a new workspace.

[Open arecent project workspace] radio button: Uses an existing workspace and displays the history of the
opened workspace.

[Browse to another project workspace] radio button: Uses an existing workspace; this radio button is used when
the history of the opened workspace does not remain.

In this section, we describe the following three ways to start up the HEW:

¢ [Create anew project workspace] - atoolchain isnot in use
¢ [Create anew project workspace] - atoolchainisin use

¢ [Browseto another project workspace]

The method to create a new workspace depends on whether atoolchain isor isnot in use. Note that this emulator
product does not include atoolchain. Use of atoolchain is available in an environment where the H8S, H8/300
series C/C++ compiler package has been installed. For details on this, refer to the manual attached to the H8S,
H8/300 series C/C++ compiler package.
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421 Creating a New Workspace (Toolchain Not Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project
workspace] radio button and click the [OK] button.

2%

— Optiors; 0K

&' ‘Create a new project workspace Cancel

% ) Mpen arecent project workspace: Administration...

| ]

Fll

g " Browse to another project warkspace

Figure4.3 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

Mew Project Workspace 2=

Projects

T orkspace Name:

Isample

Project Mame:

Isample

Diirectony:

IE:'\HBWS\sample Browsze. |

LCFU Farmily:
| HB5 HB/300 =l

Toal chain:

INone ﬂ

Properties. .. |

QK. I Cancel

Figure4.4 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,
it needs not be entered.

[Directory] edit box: Displays the directory in which the workspace will be created. Click the [Browse...]
button to select a directory name or enter adirectory namein the [Directory] edit box.

Other list boxes are used for setting the tool chain; the fixed information is displayed when the toolchain has not
been installed.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

2%

— Targets

vy EGOOD Emulator GPU 2000
G000 Emulatar CGPU 2600

Target type : I.-’-\ll Targets j

< Back I Mewut » I Finish | Cancel |

Figure4.5 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box
against the target platform and then click the [Next] button. For details on the session file, refer to section
4.4, Debug Sessions.
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4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

Target name :

ator GPU 2000

Configuration name ;

|Debue_yvyy_E6000_Emulator GP

— Detail options :

Item | Walue |

I adify |

< Back I Ment » I Firizh | Cancel |

Figure4.6 [New Project —Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] diaog box shown in figure 4.5, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next
target.

Setting of the configuration file nameis the end of the emulator settings.

Click the [Finish] button to display the [Summary] dialog box. Pressing the [OK] button activates the HEW.

5. After the HEW has been activated, the emulator is automatically connected. The message “ Connected” is
displayed on the [Debug] tab in the [Output] window to indicate the completion of connection.
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4.2.2 Creating a New Workspace (Toolchain Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project
workspace] radio button and click the [OK] button.

2%

— Optiors; 0K

&' ‘Create a new project workspace Cancel

% ) Mpen arecent project workspace: Administration...

| ]

Fll

g " Browse to another project warkspace

Figure4.7 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

Mew Project Workspace 2=
Projects |
' Appl N Wwiork space Mame;
@ Azzembly Application Isample
= .

Demonstrat_mn. Project Name:

@ Ermpty Application

& Impart Makefile Isample

G Library Diirectony:
ID:'\H e dhzample Browsze. |
LCFU Farmily:
| HB5 HB/300 =l
Toal chain:
| Hitachi G5 HB/300 Standard =l

Properties. .. |

QK. I Cancel

Figure4.8 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name. Here, enter ‘test’.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,

it needs not be entered.

[Directory] edit box: Displays the directory in which a workspace will be created. Click the [Browse...]

button to select a directory or enter the name of a directory in the [Directory] edit box.

[CPU family] combo box: Select the target CPU family.

[Tool chain] combo box: Select the target toolchain name when using the toolchain. Otherwise, select
[Nong].

[Project type] list box: Select the project type to be used.

Notes: 1. When [Demonstration] is selected in the emulator, note the followings:
The [Demongtration] is a program for the simul ator attached to the H8S, H8/300 compiler package.
To use the generated source file, delete the Printf statement in the sourcefile.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

2%

— Targets

vy EGOOD Emulator GPU 2000
G000 Emulatar CGPU 2600

Target type : I.-’-\ll Targets j

< Back I Mewut » I Finish | Cancel |

Figure4.9 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box against
the target platform and then click the [Next] button. For details on the session file, refer to section 4.4, Debug
Sessions.
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4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

2%

Target name :

Configuration name ;

|Debue_yvyy_E6000_Emulator GP

— Detail options :

Item | Walue |

I adify |

< Back I Ment » I Firizh | Cancel |

Figure4.10 [New Project — Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] diaog box shown in figure 4.9, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next

target.
Setting of the configuration file nameis the end of the emulator settings.

Complete the creation of a new workspace according to the instructions on the screen. This activates the
HEW.

5. After the HEW has been activated, connect the emulator. However, it is not necessary to connect the
emulator immediately after the HEW has been activated.
Select either of the following two ways to connect the emulator: connecting the emulator after the setting at
emulator activation or without the setting at emulator activation. For details on the connection of the
emulator, refer to section 4.5, Connecting the Emulator.
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4.2.3 Selecting an Existing Workspace

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Browse to another project

workspace] radio button and click the [OK] button.

2l x]
— Optiors;
" Create a new project workspace Cancel |
) Mpen arecent project workspace: Administration... |
= | ]
g {+ Browse to another project warkspace

Figure4.11 [Welcome!] Dialog Box

2. The [Open Workspace] dialog box is displayed. Select adirectory in which you have created a workspace.
After that, select the workspace file (.hws) and press the [Open] button.

Open Wo ce lI il
Look in: Ia zample j o IC_QF -

sample

File name:  |sample.hwe Open I
Files of type: IWorkspaces [ bwwz] ﬂ Cancel |
e

Figure4.12 [Open Workspace] Dialog Box

3. Thisactivatesthe HEW and recovers the state of the selected workspace at the timeit was saved.
When the saved state information of the selected workspace includes connection to the emul ator, the
emulator will automatically be connected. To connect the emulator when the saved state information does not
include connection to the emulator, refer to section 4.5, Connecting the Emulator.
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4.3 Setting at Emulator Activation

When the emulator is activated, the command chain can automaticaly be executed. It isalso possible to register
multiple load modules to be downloaded. The registered load modules are displayed on the workspace window.

1. Select [Debug Settings...] from the [Options] menu to open the [Debug Settings] dialog box.

Debug Settings 2l
IDefauItSessinn x| Target | Dptions |
...... @ sample Target:

Default Debug Format:

LNone: j

Cownload bodules:
File Hame | Offget Address | Form: Add...

Bemove

T odifi..

I

1] | |
QK. I Cancel |

Figure4.13 [Debug Settings] Dialog Box ([Target] Page)

2. Select the product name to be connected in the [Target] combo box.

3. Select the format of the load module to be downloaded in the [Default Debug Format] combo box, then
register the corresponding download module in the [Download Modules] list box.

4, Click the[Options] tab.
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Debug Settings llﬂ

IDefauItSessinn j Target Options
""" @ sample Carnrand batch file load timing:
I.t’-‘n.t target connection j

Command Line Batch Processing:

[ Connect up to target on debug go
v Download modules after build

[ Feset CPU after download module

Cahicel

Figure4.14 [Debug Settings] Dialog Box ([Options] Page)

The command chain that is automatically executed at the specified timing is registered. The following three
timings are available:

¢ At connecting the emulator
¢ Immediately before downloading
* Immediately after downloading

Specify the timing for executing the command chain in the [Command batch file load timing] combo box. In
addition, register the command-chain file that is executed at the specified timing in the[Command Line Batch
Processing] list box.
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4.4 Debug Sessions

The HEW stores al of your builder optionsinto aconfiguration. In asimilar way, the HEW stores your
debugger optionsin asession. The debugging platforms, the programs to be downloaded, and each target
platform’s options can be stored in a session.

Sessions are not directly related to a configuration. This means that multiple sessions can share the same
download module and avoid unnecessary program rebuilds.

Each session’ s data should be stored in a separate file in the HEW project. Debug sessions are described in
detail below.

44.1 Selecting a Session
The current session can be selected in the following two ways:

*  From the toolbar
Select a session from the combo box (figure 4.15) in the toolbar.

JJ = ||Debug j ||DefaultSessinn j | At | Iz [ |

Figure4.15 Toolbar Selection

* From the dialog box
1. Select [Options -> Debug Sessions...]. Thiswill open the [Debug Sessions] dialog box (figure 4.16).

Ok

Diebug zezsions:

DefaultS ezzion
Sessionyyyy_ERIOD_Emulator_CP Cancel
Sessionxooo_EBN00_Emulatar_CF

Bemave
Save as...

Broperties

MR

Current zezsion:
Defaults eszion j

Figure4.16 [Debug Sessions] Dialog Box

2. Select the session you want to use from the [Current session] combo box.
3. Click the [OK] button to set the session.
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442 Adding and Removing Sessions
A new session can be added by copying settings from another session or removing a session.

¢ Toadd anew empty session

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).

Check the [Add new session] radio button.

Enter a name for the session.

Click the [OK] button to close the [Debug Sessions] dialog box.

This creates a file with the name entered in step 4. If afile with this name aready exists, an error is
displayed.

o 0k wDd R

add new ] il ll

' Add new session ok I

Name: Cancel |

{* Uze an existing session file

M arme:

Isample
Seszion file path:

I Browsze |

¥ iOpen and maintain link to session file

[ Make session file ink read anly

Figure4.17 [Add new session] Dialog Box
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¢ Toimport an existing session into a new session file

1

o w DN

6.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).

Check the [Use an existing session file] radio button.

Enter a name for the session.

Enter the file name of an existing session file that you would like to import into the current project or
click the [Browse...] button to select the file location.

If the [Open and maintain link to session file] check box isnot checked, the imported new session fileis
generated in the project directory.

If the [Open and maintain link to session file] check box is checked, anew session fileis not generated in
the project directory but islinked to the current session file.

If the [Make session file link read only] check box is checked, the linked session file is used as read-only.
Click the [OK] button to close the [Debug Sessions] dialog box.

¢« Toremoveasesson

1.
2.
3.

4.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Select the session you would like to remove.

Click the [Remove] button.

Note that the current session cannot be removed.

Click the [OK] button to close the [Debug Sessions] dialog box.

« Toview the session properties

1.
2.
3.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Select the session you would like to view the properties for.
Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

ion Properties
Mame: Sesziorooo_EE000_Emulator_CF { i
Location: CAHewhzamplehsampleS ezsionseoc EBDON c I
Lastmodfied:  17:37:11, Thursday, December 12, 2002 —lance
[ Bead only
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Figure4.18 [Session Properties] Dialog Box
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To make a session read-only

1

5.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).

2. Select the session you would like to make read-only.
3.
4. Check the [Read only] check box to make the link read-only. Thisis useful if you are sharing debugger-

Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

setting files and you do not want data to be modified accidentally.
Click the [OK] button.

To save a session with adifferent name

1

o w D

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Select the session you would like to save.

Click the [Save as] button to display the [Save Session] dialog box (figure 4.19).

Specify the location to save the new file.

If you want to export the session file to another location, leave the [Maintain link] check box unchecked.
If you would like the HEW to use thislocation instead of the current session location, check the
[Maintain link] check box.

Click the [OK] button.

2lx|
Save in: Ia zample j - EF v
|1 Debug Sessionxeec_EA000_Emulatar_CP.hsf
1 Debug_yyy_EGOD0_Ermulatar_CP
|1 Debug_seos:_EAO00_Emulator_CP
"1 Release
DefaultSession. hsf
Sessionyyyy_EG000_Emulatar_CP.hsf
File hame: | Save I
Save as lupe: ISessions [*.hsf) ﬂ Cancel |

™ Maintain link
A

443

Figure4.19 [Save Session] Dialog Box

Saving Session Information

To save asession
Select [File -> Save Session].
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4.5 Connecting the Emulator
Select either of the following two ways to connect the emulator:

(8) Connecting the emulator after the setting at emulator activation

Select [Debug Settings...] from the [Options] menu to open the [Debug Settings] dialog box. It is possible to
register the download module or the command chain that is automatically executed at activation. For details
on the [Debug Settings] dialog box, refer to section 4.3, Setting at Emulator Activation.

When the dialog box is closed after setting the [Debug Settings] dialog box, the emulator will automatically
be connected.

(b) Connecting the emulator without the setting at emulator activation
Connect the emulator by simply switching the session file to one in which the setting for the emulator use has

been registered.

=10l x|

Fle Edt View Projct Options Buld Tools Window Help

CeRe @l =e0Tw|0F oeEelEyi | o8]l = & 7] 7]

e Brleeesza|mensnt L[ HEEEDT G

MR B =il
] x|
ER) v

=) sample

=423 Csource file
dbsct.e
intpra.c
resetpra.c
sample.c
sbik.c

=23 Dependencies
sbikh
stackscth

g} 3 Projects | &] Termplates | = Navigation

4[>\ Build }, Debug A Findin Files }, Versian Contral

Ready

NS [ oMz

Figure4.20 Selecting the Session File

In thelist box that is circled in figure 4.20, select the session name including the character string that has been
set in the [Target name] text box in figure 4.10, [New Project — Step 8] dialog box. The setting for using the
emulator has been registered in this session file.

After the session nameis selected, the emulator will automatically be connected. For details on the session file,
refer to section 4.4, Debug Sessions.
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4.6 Reconnecting the Emulator
When the emulator is disconnected, use the following way for reconnection:
Select [Build -> Debug -> Connect] or click the [Connect] toolbar button ( = ). The emulator is connected.

Note:  Before reconnecting the emulator, aload module must be registered to the HEW. For registration, refer
to section 4.3, Setting at Emulator Activation.

4.7 Ending the Emulator
When using the toolchain, the emulator can be exited by using the following two methods:

¢ Cancding the connection of the emulator being activated
¢ Exiting the HEW

(1) Canceling the connection of the emulator being activated
Select [Disconnect] from the [Debug] menu or click the [Disconnect] toolbar button (5 ).
(2) Exiting the HEW

Select [Exit] from the [File] menu.

A message box isdisplayed. If necessary, click the[Yes] button to save asession. After saving a session, the
HEW exits. If not necessary, click the [No] button to exit the HEW.

& Session has been madified - do you wank to save it

¥es Mo | Cancel |

Figure4.21 [Session hasbeen modified] M essage Box
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Section 5 Debugging
This section describes the debugging operations and their related windows and dialog boxes.
51 Setting the Environment for Emulation

511 Opening the [Configuration Properties] Dialog Box
Selecting [Options -> Emulator -> System...] or clicking the [Emulator System] toolbar button (@) opensthe
Configuration Properties] dialog box.

2l
General |
Device: Uzer Signalz
SEVICE: ¥ Uszer Beset enable
Mode: I."" [advanced mode, single chip) j ¥ User MMI enable
7| Gingle chin made 7| Wser Standby enatle
g ? ¥ User Bus Reguest enable
Clock: | Main1 OMHz, Sub:32kHz |
Tirmer Resolution: |125ns j

Flazhy i emony Contral; I vI

¥ Enable read and write on the flu
¥ Break on access enar
[ Enable internal ROM area write

User YCC Threshald = 400 4 | [ | |

Diriver: |EEI:II:IEI IJSE Driver
™ Change driver in start up

QK. I Cancel |

Figure5.1 [Configuration Properties] Dialog Box ([General] Page)

Thisdiaog allows the user to set conditions for the target MCU before downloading a program to the emulator.
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[General] page

evice elects the to be emulated. To use an not included in the list,
Devi Sel he MCU to b lated. T MCU included in the li
select CUSTOM to specify the functions required for this MCU. See the
hardware manual for details.
ode elects the 's operating mode.
Mod Sel he MCU* i d
oc elects the speed of the s clock and sub-clock.
Clock Sel h d of the MCU'’s clock and sub-clock

[Timer Resolution]

Selects the resolution of the timer for use in execution time measurement.
The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

[Enable read and write on the
fly]

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this check box if
you require realtime emulation.

[Break on access error]

When this box is checked, a break (the user program stops) occurs if
your program accesses a guarded memory area or writes to a write-
protected area.

[Enable internal ROM area write]

When this box is checked, writing to the internal ROM area is enabled.
For the result of writing, see the [Extended Monitor] window.

[User VCC Threshold]

Sets the voltage level for the user system.

[User Signals]

When this box is checked, the reset, NMI, standby, and bus request
signals from the user system are enabled.

[Driver]

Displays the E6000 driver that is currently installed.

[Change driver in start up]

When this box is checked, selection of a driver will be available next time
the emulator is connected.

Note: Theitemsthat can be set in thisdialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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512 Selectingan MCU Not Included in the List

Selecting [Custom] in [Device] of the [Configuration Properties] dialog box adds the [Custom Device] page to
the dialog box.

General  Custom Device

ROM: r
RaM:  [18kB =]
Fin  [120/128PinB ]
W odules
[¥ Enable DTC [+ Enable liD& A/D Conwerter
'
¥ Enable D/ Converter [V Enable IICO ~ ;reg
e
¥ Enable Refresh Controlles [ Enable 121 d
¥ Enable DMAC ¥ Enable'wDT1 SO Select
¥ Enable TPL35 ¥ Enable TMRZ-3 f sciod
" SCIN-2
[ EnableEWMH i SCI0-3
[+ Enable MuliProcesserComunication [SC11-4] f 50104

QK. | Cancel

Figure5.2 [Configuration Properties] Dialog Box ([Custom Device] Page)

Use this page to specify functions for an MCU not included in the list of MCUs. Theitems are adopted by the
device last selected.

[Custom Device] page

[ROM] Specify the internal ROM area size.

[RAM] Specify the internal RAM area size.

[Pin] Specify the product package.

[Modules] Check this box to validate on-chip peripherals.

Note: Theitemsthat can be set in thisdialog box vary according to the emulator in use. Some emulators may
not support the [Custom Device] function. For details, refer to section 8, Software Specifications
Specific to This Product, or the online help.
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513 Selecting the I nterface to be Connected

Checking [Change driver in start up] on the [Configuration Properties] diaog box allows a selection of the driver
next time the emulator is connected.

RJ7i=T E EO00 LISE Driver

— Details

Interface: I LISB interface j

Channel: I EE000 USE Interface j

— Canfiguration

Canfigure... |
[ Change driver in start up

Figure5.3 [Driver Details] Dialog Box
[Driver]: Selects the driver that connects the HEW and the emulator.
[Details): Setsthe details of the driver being connected.

[Interface]: The name of the interface to be connected. This should not be changed in this
emulator.

[Channdl]: Channél for the selected interface. This should not be changed in this emulator.
[Configuration]: Driver setting.

[Configure...]: A dialog box for setting will be displayed when the driver supports the configuration
dialog. Note that thisitem is not available with this emulator.

[Change driver in start up]:
Checking this box selects the driver when the emulator is connected the next time.
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514 Opening the [Memory Mapping] Dialog Box

Selecting [Options -> Emulator -> Memory Resource...] or clicking the [Emulator Memory Resource] toolbar
button opens the [Memory Mapping] dialog box.

Mernory Mapping ﬂ J

*

Swztern Memory Resources From Tao  Mapping Add...
SIMM Module: J 00000000 - DO03FFFF. On Chip Read-only
1ME SIkH fitted 00040000 - DOFFAFFF User Guarded
Fam Bases: OOFFBO00 - OOFFEFBF On Chip Fead-write
0 not uzed OOFFEFCO - DOFFFYFF User Guarded
1: not uzed QOFFFBE00 - DOFFFFFF On Chip Read-write Reset
2 not uged
3 ot uged Close
[<]

Target Device Canfiguration

00000000 - Q003FFFF Internal ROM J
O0FFEO0D - OOFFEFEF Internal RAM

O0FFFE00 - DOFFFF3F Intermal 10

O0FFFFEO - DOFFFFEF Intemal 10

O0FFFFCO - O0FFFFFF Intemal Rak

-]

Figure5.4 [Memory Mapping] Dialog Box

This dialog box displays the current memory map. The E6000 H8S or H8/300 series supports four blocks of user
memory. These can be 256 kbyte or 1 Mbyte each, depending on the SIMM fitted. Each block can be placed in
the address space on a 256-kbyte or 1-Mbyte boundary.

The memory mapping has a granularity of H'40 (D'64) byte. Each 64-byte block can be set to the internal
(emulation) or external memory and can be guarded (access-prohibited), write-protected or read-write.

The H8/300 series E6000 generally incorporates an emulation memory.

In the memory map, the memory can be set as an internal (emulation) or external, guarded (access-prohibited),
write-protected, or read/write in a byte unit.

[Add...]: Displays the [Edit Memory Mapping] dialog box, allowing the user to modify the address
range and attributes of a memory map.

[Modify...]: Displays the [Edit Memory Mapping] dialog box, allowing the user to modify the address
range and attributes of a memory map.

[Reset]: Resets the map memory to its default settings.

[Close]: Closes the dialog box.

The memory configuration of the device being emulated is displayed by the [Memory] sheet in the [Status]
window.

Note: Some emulators may not support the emulation memory or the memory mapping function. For details,
refer to section 8, Software Specifications Specific to This Product, or the online help.
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515 Changing the Memory Map Setting

Clicking the [Add...] button on the [Memory Mapping] dialog box or clicking the [Modify...] button after
sel ecting the information on the memory map setting you want to change opens the [Edit Memory Mapping]

dialog box.

Mapping

temong b apping

ed |

From: I

Cancel |

To I

Setting: IEIn Chip Read-write

[

Figure5.5 [Edit Memory Mapping] Dialog Box

Use this dialog box to change the address range and attributes of a memory map.

[From]: Enter the start address of the map range.
[To]: Enter the end address of the map range.
[Setting]: Enter the memory map setting.

The choices given are listed below. The User (external memory) and Emulator (emulation

memory) attributes can be modified.

¢ On-chip Read-write (Cannot be changed)
¢ On-chip Read-only (Cannot be changed)
¢ On-chip Guarded (Cannot be changed)

e User Read-write (Cannot be selected when the single chip mode is selected.)
¢ User Read-only (Cannot be selected when the single chip mode is selected.)

e User Guarded

*  Emulator Read-write
¢ Emulator Read-only
e Emulator Guarded
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52 Downloading a Program
This section describes how to download a program and view it as source code or assembly-language mnemonics.

Note: After abreak occurs, the HEW displays the location of the program counter (PC) on the editor. In most
cases, for exampleif an Elf/Dwarf2 based project is moved from its origina path (at the build), the
source file may not be automatically found. In this case, the HEW will open a source file browser dialog
box to alow you to manually locate the file. This path will then be used to update any other source files
in this debug project.

521 Downloading a Program
A load module to be debugged must be downloaded.

To download a program, select the load module from [Debug -> Download] or select [Download] from the
popup menu opened by clicking the right-hand mouse button on the load module in [Download modules] of the
[Workspace] window.

Note: Before downloading a program, it must be registered to the HEW as aload module. For registration,
refer to section 4.3, Setting at Emulator Activation.
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522 Viewing the Source Code

Select a source file name in the [Workspace] window and click [Open] in the popup menu to make the HEW
open the source file in the integrated editor. It isalso possible to display your source files by double-clicking on
their names in the [Workspace] window.

. Tukorial.cpp =|O] x|
Oxz00001038 wold tutorial{void) j
0=z00001044 {

long a[107]:

long 3@

int 1

claz=z Sanple *p _=am;
0=00001046 | i |ehs| 4 D_=am= Sample;
0xz0000104e [+ (whg for{ i=0; 1<10; i++ ){
0=00001050 |-& | <5 | i = randi):
0xz00001058 (2 if{3 < 03
0=z0000105a (B i = -3

1

0xz0000105c (e o> al[i] = 3:

1
0=z00001070 o os=amn—:sort(a);
O=z0000107a p_=zan—:>change(a);
O=z00001082 p_=zan—:=0=a[0];
0=0000108a p =am—r=l1=a[l]: -

K1 [

Figure5.6 Source Window
In thiswindow, the following items are shown on the | ft asinformation on lines.

¢ First column (Source address column): Displays the address information for the source line
e Second column (Event column): Event information (break)

e Third column (EXT.2 Trigger column): EXT.2 Trigger information

¢ Fourth column (Editor column): PC, bookmark, and breakpoint information

The Editor window is displayed in the right part of the Source window.
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Sour ce addr ess column

When a program is downloaded, an address for the current source file is displayed on the Source address column.
These addresses are helpful when setting the PC value or a breakpoint.

Event column
The Event column displays the following items:
@ : Address condition break by an event or arange channel
*®: Starts time measurement by an event channel
“&®: Ends time measurement by an event channel
= Starts a point-to-point range trace
% Ends a point-to-point range trace
®" Hdtstrace
These are also set by using the popup menu.
EXT.2 Trigger column
The EXT.2 Trigger column displays the following items:
;. EXT.2-1 trigger condition
#m. EXT.2-2 trigger condition
;. EXT.2-3 trigger condition
;. EXT.2-4 trigger condition
- Two or more EXT.2 trigger conditions
It isalso possible to set them by using the popup menu.
Editor column
Editor column displays the following items:
3 A bookmark is set.
& A PC Break is set.
5*: PC location
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To switch off acolumnin al source files

Right-click on the [Editor] window or select the [Edit] menu.

Click the [Define Column Format...] menu item.

The [Global Editor Column States] dialog box is displayed.

A check box indicates whether the column is enabled or not. If it is checked, the column is enabled. If
the check box isgray, the column is enabled in some files and disabled in others. Deselect the check box
of acolumn you want to switch off.

Click the [OK] button for the new column settings to take effect.

Global Editor Column States

[w]E=T.2 Trigger

[w]Ewent
[w] E ditor Cancel |
[w]Source Address

Figure5.7 [Global Editor Column States] Dialog Box

< To switch off acolumn in one sourcefile

1.

2.

228

Click the right-hand mouse button on the [Editor] window which contains the column you want to
remove to display the popup menu.

Click the [Columns] menu item to display a cascaded menu item. The columns are displayed in this
popup menu. If acolumnisenabled, it hasatick mark next to itsname. Clicking the entry will toggle
whether the column is displayed or not.
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523 Viewing the Assembly-L anguage Code

If there is an address at the cursor position in the [Editor] window, selecting [Go to Disassembly] in the pop-up
menu opens the [Disassembly] window.

Thefirst address displayed in the [ Disassembly] window is the address where the cursor is placed in the [Editor]
window.

If you do not have a source file, but wish to view code in the assembly-language level, either choose [View ->
Disassembly...], or click on the [ Disassembly] window’ s toolbar button .

embly =|O] x|
© void main(wvoid) ﬂ
24 while {1314
nooolo3s 40FC ERA @_main: 8
26 ¥
27}
28
29 woid tutorial{wvoid)
tutorial 01006DF3 HOV . L ER3, @-ER7
0o0o1l03c 01206DF4 STH.L {ER4-ERG ), @-5F
nooolo4o 79370028 SUB.W #H'0028 R7?
30
nooolo44 OFF3 HOV . L ER7 ER3
31 long a[l10]:
32 long 7J:
33 int i;
34 clas=s Samnple *p_sam:
35
36 p_=am= new Samnple:
G 00001046 1A80 SUE.L EE0.ERD
nooolo4s SE0O0Z000 JSR @Sample: :Samnple():24
nooolo4c OF86 MOV, L ER0.ERE
ar: for{ i1=0; 1<10; i++ )9
0000104E 1944 SUE. W R4 R4
3a8: 7 = randi():
0ooolo50 SEOOQOL11EE JSR @_rand: 24 A
RI H 4

Figure5.8 [Disassembly] Window

524 M odifying the Assembly-L anguage Code

Y ou can modify the assembly-language code by double-clicking on the instruction that you want to change. The
[Assembler] dialog box will be opened.

Assembler 2 x]

Addiezs Code Mremaonic:
00001040 79370028

ok |

Figure5.9 [Assembler] Dialog Box
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The address, instruction code, and mnemonic are displayed. Enter the new instruction or edit the old instruction
in the [Mnemonics] field. Pressing the [Enter] key will replace the memory content with the new instruction and
move on to the next instruction. Clicking the [OK] button will replace the memory content with the new
instruction and close the dialog box. Clicking the [Cancel] button or pressing the [Esc] key will close the dialog
box without modifying the memory contents.

Note: The assembly-language code being displayed is the current memory content. If the memory contents are
changed the [Assembler] didog box and the [Disassembly] window will show the new assembly-
language code, but the source file displayed in the [Editor] window will be unchanged. Thisisthe same
even if the source file contains an assembler.

525 Viewing a Specific Address

When you are viewing your program in the [Disassembly] window, you may wish to look at another area of your
program's code. Rather than scrolling through alot of code in the program, you can go directly to a specific
address. Select [Set Address...] from the popup menu, and the dialog box shown in figure 5.10 is displayed.

Set Address ﬂﬂ

Address

_main
Cancel

i

Figure5.10 [Set Address] Dialog Box

Enter the addressin the [Address] edit box and either click on the [OK] button or press the Enter key. A label
name can also be specified as the address. The [Disassembly] window will be updated to show the code at the
new address. When an overloaded function or aclass nameis entered, the [Select Function] dialog box opens for
you to select afunction. For details, refer to section 5.13.3, Supporting Duplicate Labels.

5.2.6 Viewing the Current Program Counter Address

Wherever you can enter an address or vaue into the HEW, you can also enter an expression. If you enter a
register name prefixed by the hash character, the contents of that register will be used asthe valuein the
expression. Therefore, if you open the [Set Address] dialog box and enter the expression #pc, the [Source] or
[Disassembly] window will display the current PC address. It also allows the offset of the current PC to be
displayed by entering an expression with the PC register plus an offset, e.g., #PC+0x100.
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53 Debugging with the Command Line I nterface

Use the [Command Line] window to enter text-based commands instead of window menus and commands.

531 Opening the [Command Line] Window

Choose [View -> Command Lineg] or click the [Command Line] toolbar button to open the [Command
Line] window.

- Command Line:no batch file:na log File: = IDIﬂ

Figure5.11 [Command Line] Window

Thiswindow allows the user to control the debugging platform by sending text-based commands. A series of
predefined command lines can be called from afile and the output can be recorded in afile. The command can
be executed by pressing the [Enter] key after the command isinput at the prompt (<) on the last line. For
information on the available commands, refer to appendix G, Command Lines, and the on-line help.

If available, the window title displays the current batch and log file names separated by colons.

Pressing the Ctrl + 1 or Ctrl + | keyson thelast line displays the command line previously executed.

532 Specifying a Command File

It isuseful to use acommand file when a series of predefined command lines need to be executed. Create a
command file by atext editor and write necessary command lines. The default extension of a command file
is.hdc.

Choose [Set Batch File...] from the popup menu to open the [Set Batch File] dialog box, in which the name of a
command file (*.hdc) can be specified. Clicking the [OK] button displays the specified command file name as
the window title. Clicking the [Cancel] button closes the dialog box without changing the setting.
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Set Batch File

|| LI Bromsze,. | Ok

Cancel |

Figure5.12 [Set Batch File] Dialog Box

533 Executing a Command File

Click the [Play] button in the [Set Batch File] dialog box or choose [Play] from the popup menu to execute the
command file. The [Play] menu isdisplayed in gray while the fileis running and can be used when the command
file execution stops and control returns to the user.

534 Stopping Command Execution

Choose [Stop] from the popup menu to stop command execution. The [Stop] menu becomes valid during
command execution.

535 SpecifyingaLog File

Choose [Set Log File...] from the popup menu to open the [Open Log Fil€e] dialog box, in which alog file to
store the command execution results can be specified.

Open Log File

Log File:

I LI Bromsze,. | —

Figure5.13 [Open Log File] Dialog Box

Enter the name of alog file (*.log). The logging option is automaticaly set and the name of the fileis shown on
the window title bar.

Opening aprevious log file will ask the user if they wish to append or overwrite the current log.

5.3.6 Starting or Stopping L ogging

Choose [Logging] from the popup menu to toggle logging to file on and off. When logging is active, the button
becomes effective. Note that the contents of the log file cannot be viewed until logging is completed, or
temporarily disabled by clearing the check box. Re-enabling logging will append to the log file.

537 Entering a Full Path to the File

It is recommended that the full path to afileis specified as afile name in the [Command line] window because
the current directory can be moved. However, care must be taken to enter the correct full path to afilewhenitis
entered from the keyboard. To save this trouble, a full path can be easily specified by browsing through files.
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Choose [Browse...] from the popup menu to open the [Browse] dialog box. Select afile and click [Open] to paste
the full path to the selected file to the cursor location. This option can only be used when the cursor islocated on
thelast line.

538 Pasting a Placeholder

Select a placeholder from the [Placeholder] submenu in the popup menu to paste the selected placeholder to the
cursor location. This function is only available when the cursor islocated on the last line.
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54 Viewing the Registers

If you are debugging at assembly-language level, then you will find it useful to see the contents of the CPU's
general registers. You can do this by using the [Register] window.

54.1 Opening the [Register] Window

To open the [Register] window, choose [View->CPU->Registers] or click the [Register] toolbar button ([E]).
The [Register] window opens showing all of the CPU's generd registers and the values, displayed in
hexadecimal.

egister 1ol x|
|Reglster Name |Register Walue I
RO H'0ooooooo
Rl H'oooooooo
R2 H'0ooooooo
R3 H'oooooooo
R4 H'0ooooooo
RS H'oooooooo
R& H'0ooooooo
R7 H'0oooooo1o
PC H'oooooo
CCE H'&0 I0------
WR H'0?7  ——--- 111

Figure5.14 [Register] Window

54.2 Expanding a Bit Register

If aregister isused as a set of flags at the bit level for the control of state, its one-character symbol rather than its
state indicate each bit. Double-click on the register’s name to display the [Register] dialog box and switch each
bit on or off. Checking the box for any bit specifiesit asholding a 1, while removing the check specifiesit asaO.

Walue:

[ lmask. ﬂ

[ Uzer/Imaszk Cancel |
[ |Half-carry

[ ser .IJ

Figure5.15 Expanding a Bit Register
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543 Choosing a Register to be Displayed

To choose aregister to be displayed in the [Register] window, choose [Settings...] from the pop-up menu. This
dialog box is shown in figure 5.16.

Settings ﬂﬂ

Reaqizters:

WERD C
[WIEFR1
Egg LCancel |
WIEF4
WIERS
WIERE
WIERT
[w|PC
W|CCR

Figure5.16 [Settings] Dialog Box

54.4 Splitting Up the Window Display

To vertically divide the [Register] window display into two, select [Split] from the pop-up menu and move the
split-up bar.
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545 M odifying Register Contents
To change aregister's content, open the [Register] dialog box in one of the following methods:

« Double-click the register you want to change.
e Select the register you want to change, and choose [Edit...] from the popup menu.

Register - [ERO] 7| x|

Walle:

|H'DDDDDDDD
Set ha Cancel |

IWhDIe Register j

Figure5.17 [Register] Dialog Box

Y ou can enter a number or C/C++ expression in the [Valug] field. Y ou can choose whether to modify the whole
register contents, a masked area, floating or flag bits by selecting an option from the combo box (the contents of
thislist depend on the CPU model and selected register).

When you have entered the new number or expression, click the [OK] button or pressthe [Enter] key; the didog
box closes and the new value is written into the register.

5.4.6 Using Register Contents

Use the value contained in a CPU register by specifying the register name prefixed by the “#" character, e.g.:
#R1, #PC, #R6L, or #ER3 when you are entering a value elsewhere in the HEW, for example when displaying a
specified address in the [ Disassembly] or [Memory] windows. Available register names depend on the target
MCU being emulated.

54.7 Saving the Currently Displayed Contents

The contents currently displayed in the window can be saved in atext file. Select [Save to File...] from the pop-
up menu.
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5.5

This section describes how to control memory contents, such as viewing amemory areain different formats,

Operating Memory

filling and moving amemory block, and loading and verifying aload modulefile.

551

Viewing a Memory Area

To look at amemory area, choose [View -> CPU ->Memory...] or click the[View Memory] toolbar button )

to open the [Memory] window. Thiswill open the [Format] dialog box shown in figure 5.18.

k7K

Beaqin: ok,

LCancel |

End:

|H'DDDDDDFF

Farmat:
{Byte [x1) =l

Dizplay Y alue s
IANSI character ﬂ

Bytes Count For One Line:
|16 Byte =l

Figure5.18 [Format] Dialog Box

Enter the range you want to display as an address value or an equivalent symbol in the [Begin] and [End] fields.

Select the data size and format for the display from the [Display Value As] and [Format] drop-down lists,

respectively. Select the number of bytes displayed in one line from the [Bytes Count For One Line] drop-down

list. Click the [OK] button or pressthe Enter key, and the dialog box closes and the [Memory] window opens.

The display can be scrolled within the range of the entered display start and end addresses.
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000000000
000000010
000000020
000000030
000000040
000000050
000000060
000000070
000000020
000000030
000000040
0x000000E0
0:x000000C0
000000000
0:x000000ED
0:x000000F0

oo
4B
oz
F2
&0
CE
co
T4
41
ac
a1
az
oo
Fz2
01
55

Figure5.19 [Memory] Window

Note: Each item in the [+n] column is called as the memory unit.

There are three display columns:

[Address]:

[+n]

[Vaue]:

First address of the memory data displayed on this row.

Memory data read from [Address] and ‘n’ means the offset value from thefirst address of the
row. Datais read from the debugging platform’s physical memory in the access width, and then
converted to the display width.

Datadisplayed in an alternative format.

55.2 Displaying Data in Different Formats

If you want to change the display format of the [Memory] window, select [Format] from the popup menu. The
dialog box shown in figure 5.20 is displayed.

k7K

Beaqin: ak.

LCancel |

|H'DDODOOFF

Farmat:

{Byte [x1) =l
Dizplay Y alue s

IANSI character ﬂ

Bytes Count For One Line:
|16 Byte =l

Figure5.20 [Format] Dialog Box

To display and edit memory in different widths, use the [Display Data As] combo box. For example, choose the
[Byte] option and the display will be updated to show the memory area asindividual bytes.
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The data can be converted into different formats, as shown in the [Value] column. The list of formats depends on
the data selection.

To change the number of bytes displayed on one line, use the [Bytes Count For One Ling] drop-down list. For
example, choose the [8 Byte] option and the display will be updated to show the 8-byte data on oneline.

55.3 Splitting Up the Window Display

To verticaly divide the [Memory] window display into two, select [Split] from the popup menu and move the
split-up bar.

55.4 Viewing a Different Memory Area

To change the memory area displayed in the [Memory] window, use the scroll bars. To quickly look at a new
address, use the [Format] dialog box. This can be opened by choosing [Format] from the popup menu.

Enter the new address value, and click the [OK] button or press the [Enter] key. The dialog box closes and the
[Memory] window display is updated with the data at the new address. When an overloaded function or a class
name is entered, the [Select Function] dialog box opens for you to select afunction.

555 M odifying the Memory Contents

The memory contents can be modified via the [Edit Memory] dialog box. Move the cursor on the memory unit
(according to the [Memory] window display choice) that you wish to change. Either double-click on the memory
unit or pressthe [Enter] key. The dialog box shown in figure 5.21 is displayed.

Current % alue: ak.

[HFF

LCancel |
Hew Yalue:

Figure5.21 [Edit Memory] Dialog Box

A number or C/C++ expression can be entered in the [New Value] field. After you have entered the new number
or expression, click the [OK] button or press the [Enter] key. Then the dialog box closes and the new valueis
written into memory.

The memory contents can also be modified by moving the cursor on the memory unit and entering the new value
in hexadecimal through the keyboard.

5.5.6 Selectinga Memory Range

If the memory address range isin the [Memory] window, you can select the range by clicking on the first
memory unit (according to the [Memory] window display choice) and dragging the mouse to the last unit. The
selected range is highlighted.
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55.7 Finding a Valuein Memory

To find avalue in memory, open the [Memory] window and select [Search...] from the popup menu or from the
[Memory] drop-down menu. The [Search Memory] dialog box shown in figure 5.22 is displayed.

Data:

Search Data fe:
IElyte 1) LI

[¥ Search Egqual Data [~ Search Backward

Figure5.22 [Search Memory] Dialog Box

Enter the start and end addresses of the range in which to search and the data value to search for, and select the
search format. If pattern search is selected as the search format, a byte string of up to 256 bytes can be searched
for. The end address can a so be prefixed by aplus (+); the end address will become the (start address) + (entered
value).

Search conditions other than pattern search are data match/mismatch and search direction. Note that only data
match and forward direction can be selected with pattern search.

Click the [OK] button or press the Enter key. The dialog box closes and the HEW searches the range for the
specified data. If the datais found, it is highlighted.

If the data could not be found, the [Memory] window display remains unchanged and a message box informing
that the data could not be found is displayed.

If [Search Next] is selected from the popup menu in the state where data has been found, the search will continue
from the next address.
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55.8 Fillinga Memory Areawith a Value
A value can be set as the contents of a memory address range using the memory fill function.

To fill amemory range with the same value, select [Fill...] from the popup menu of the [Memory] window or
from the [Memory] drop-down menu. The [Fill Memory] dialog box is shown in figure 5.23.

2%

LCancel |

Data:

FEormat;

{Byte [x1) =l

[ Werify

Figure5.23 [Fill Memory] Dialog Box

If an address range has been sdlected in the [Memory] window, the specified start and end addresses will be
displayed. Select aformat from the [Format] combo box and enter the data value in the [Data] field. On clicking
the [OK] button or pressing the [Enter] key, the dialog box closes and the new vaue is written into the memory
range.

5.5.9 CopyingaMemory Area

Y ou can copy a memory area using the memory copy function. Select [Copy...] from the popup menu of the
[Memory] window or from the [Memory] drop-down menu. The [Copy Memory] dialog box is opened (figure
5.24).

|
Cancel |
End:
|
Liestination:
|
Format:
IElyte 1) LI
I Merify

Figure5.24 [Copy Memory] Dialog Box
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The source start address and end address selected in the [Memory] window will be displayed in the [Begin] and
[End] fields. Checking the [Verify] check box enables copying while comparing the copy source and copy
destination. The copy unit can be selected in the [Format] combo box. Enter the destination start addressin the
[Destination] field and click the [OK] button or press the [Enter] key. Thiswill close the dialog box and copy the
memory block to the new address.

5510 Savingand VerifyingaMemory Area

A memory areain the address space can be saved into adisk file using the memory save function. Open the
[Save Memory As] dialog box by choosing [File -> Save memory...].

Save Memary 4s

2]

IBinal_l,l j
Cancel

File narme:
| =1

Start addreszs:
|H'nnnnnnnn

End Address:
|Hi00FFFFF

Access sizer

—

Figure5.25 [Save Memory As] Dialog Box

Enter the start and end addresses of the memory block that you wish to save, and a name and format for thefile.
The[File name] combo box contains the previous four file names used for saving memory.

Clicking the[...] button can open the standard [File Save As] diaog box. On clicking the [OK] button or
pressing the [Enter] key, the dialog box closes and the memory block will be saved into the disk as afile of the
specified format type. The access size for saving data can be selected from the [Access Size] drop-down list.
When the dataiis saved in memory with little endian, the order of data depends on the access size.
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A memory areain the address space can be verified using the memory verify function. Open the [V erify
Memory] dialog box by choosing [File -> Verify Memory...]. The access size at verification can be selected from

the [Access Size] drop-down list.

Werify Memory il ﬂ

File name:

Qffzet address:

Access size:

—

Figure5.26 [Verify Memory] Dialog Box

55.11 Disabling Update of the Window Contents

Automatic update of the [Memory] window contents, which is performed when user program execution stops
and in other cases, can be disabled. Thisis done by checking [Lock Refresh] in the popup menu. The [Memory]
window will be grayed.

55.12 Updating the Window Contents

The [Memory] window contents can be forcibly updated. Thisis done by checking [Refresh] in the popup menu.
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55.13 Comparing the Memory Contents

The contents of two memory blocks can be compared. Open the [Compare Memory] dialog box by selecting
[Memory -> Compare...] from the main menu or by selecting [Compare...] from the popup menu of the

[Memory] window.

Compare Memory i 3

Beein: oF

Start Compare:

Format:

IElyte 1) LI

Figure5.27 [Compare Memory] Dialog Box

Enter the comparison format ([Format]), the start address ([Begin]) and end address ([End]) of the source
memory area, and the start address ([Start Compare]) of the destination memory area. If the memory block is
aready highlighted in the [Memory] window, the start and end addresses will be automatically filled in when the

[Compare Memory] dialog box is opened.

If there is amismatch, the address where it was found is displayed in a message box.
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5514 LoadingaMemory Areafrom aFile

A file can be loaded to the debugging platform’s memory. Select [Load...] from the popup menu of the
[Memory] window to open the [Load Program] dial og box.

Load Pragram 2l
-
Cancel |
File name:

| =1

Offget address:
IH'DDDDDDDD

Arccess size:
I‘] vI

[~ Perform memory verify duing download

Figure5.28 [Load Program] Dialog Box

Enter the file format ([Format]) and the file name ([File name]). If the load address value is to be changed, enter
the offset value in the offset field ([Offset address]), otherwise enter zero.
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5.6 Viewing the /O Memory

A microcomputer contains on-chip peripheral modules. The exact number and type of periphera modules differ
between devices but the typical modules are a DMA controller, seriadl communicationsinterface, A/D converter,
integrated timer unit, bus state controller, and watchdog timer. Registers that are mapped to the microcomputer’s
address space controls the on-chip peripheral modules.

The [Memory] window enables you to look at datain continuous memory addresses as byte, word, longword,
single-precision floating-point, double-precision floating-point, or ASCII values. However, registers of different
sizes are alocated to non-continuous memory addresses in the 1/O memory. To handle this memory, the HEW
hasthe [10] window to facilitate checking and setting up of these kinds of registers.

5.6.1 Opening the [|O] Window

To open the [IO] window, select [View -> CPU -> O] or click the [View 10] toolbar button ). Modules that
match the on-chip peripheral modules organize the I/O register information. When the [10] window is first
opened, only alist of module namesis displayed.

O0EFEDE?
O00FFEDES

#-[] Interrupt Controller
#-[] Bus Controller

#-[] Data Transfer Control
#-[] I/0 Port 1

#-] I/0_Port_3

#-[] I/0_Port_4

#-] I/0_Poxrt_7

#-[] I/0_Poxrt_3

#-] I/0_Port R

#-[] I/0_Port B

#-[] I/0_Poxt C

FTA T Bart T ud
1| | 2]

Figure5.29 [10] Window

5.6.2 Expanding the I/O Register Display

To display the names, addresses, and values of the 1/0 registers, click the [+] mark at the left of the module name
or select the module name by clicking on it or using the cursor keys and press the [->] key. The module display
will expand to show the individual registers of that peripheral module and their names, addresses, and values.
Clicking the [-] mark at the |eft of the expanded module name or pressing the [<-] key will close the I/O register

display.

For adisplay inthe bit level, click the [+] mark at the left of the register name or select the register name by
clicking on it or using the cursor keys and pressthe [->] key. The register display will expand to show the names
of register bits and values. Clicking the [-] mark at the left of the expanded register name or pressing the [<-] key
will close the register bits display.

246
RENESAS



5.6.3 Manually loading an 10 file

To manually load an 10 fileright click on the [10] window and select the “Load 1O file...” menuitem on the IO
window pop-up. A standard file browser isinvoked. Simply select the file you require to load and click OK.
The IO file will be loaded into the window.

5.6.4 Modifying the |/O Register Contents

To edit the valuein an 1/O register, double-click or pressthe [Enter] key on the register to open a dialog box to
modify the register contents. When you have entered the new number or expression, click the [OK] button or
press the [Enter] key; the dialog box closes and the new value is written into the register.

5.6.5 Saving the Currently Displayed Contents

The contents currently displayed in the window can be saved in atext file. Select [Save to File...] from the pop-
up menu.
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5.7 Viewing the Current Status

Choose [View -> CPU -> Status] or click the [View Status] toolbar button to open the [Status] window and
see the current status of the debugging platform.

_|ol x|
Ttem IStatus I

Target Dewice Configuration oooooood - O0001FFFF  Internal BOM
O0FFEOOO - OOFFEFEF Internal RBAM
O0FFFE00 - OOFFFF3F Internal IO
O0FFFFe0 - OOFFFFEF Internal IO
OOFFFFCO - OOFFFFFF  Internal RBAM
System Memory Besources STMM Module:
1ME SIMM fitted
Dam Bases:

0: not used
1: not used
Z: not used
2 not used
Program MName Memory Loaded Area
- .ator_cpiTutorial.abs H'oooooooo - H'Oooooooo3
H'00000400 - H'O00004Z5
H'00001000 - H'OOOOLlS5FS
H'0000z000 - H'OOOODEZE139

[ 4]+ ]\ Memory £ Flatiorm }, Evenis f

Figure5.30 [Status] Window

The [Status] window has three sheets:

¢ [Memory] sheet

Containsinformation about the current memory status including the memory mapping resources and the
areas used by the currently loaded object file.

¢ [Platform] sheet

Containsinformation about the current status of the debugging platform, typically including CPU type and
mode; and run status.

e [Events] sheet
Containsinformation about the current event (breakpoint) status, including resource information.

Note: Theitemsthat can be set in thisdialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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5.8 Reading and Displaying the Emulator Information Regularly

Use the [Extended Monitor] window to know the changing information on the emulator no matter the user
program is running or halted.

Note:  The Extended Monitor function does not affect the execution of the user program since it monitors the
user system or the signal output from the MCU in the emulator by using the emulator’s hardware circuit.

581 Opening the [Extended Monitor] Window

Selecting [View -> CPU -> Extended Monitor] or clicking the [Extended Monitor] toolbar button ) displays
thiswindow. The interval of updating the display is approximately 100 ms during user program execution or
1,000 ms while breaking, respectively.

wded Manitar = IDIﬂ
Item Valus I
TU=zer Standbhy Inactiwve
Uszer MNMI Inactive
User Reset Inactive
Uszer Wait Inactive

TU=zer Svysten Voltage O0E
TU=zer Systen WoltageZ Dotm

Uszer Cable Not Connected
Punhing status Break = Ready
EOM Write No

Target Mode 7

Target Clock No Clock
Target Sub Clock No Clock

Figure5.31 [Extended Monitor] Window
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5.8.2 Selecting Itemsto be Displayed

Selecting [Properties...] from the popup menu displays the [Extended Monitor Configuration] dialog box.

Extended Moni nfiguration
— Update millsecond
Bunning: 100 Break: I 1000
Settings:
Iten | W alue -
|dzer Standby Inactive
Llger MM Inactive
|Jzer Reset Inactive
Ll ger ' ait Inactive
|dzer Spgtem Yoltage QK |
|Jzer Spstem Woltage2 Diown
|dzer Cable Hot Connected
Running status Break = Ready _ILI
<] | »

Figure5.32 [Extended Monitor Configuration] Dialog Box
Thisdialog box alows the user to set the items to be displayed in the [Extended Monitor] window.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

250
RENESAS



5.9 Displaying Memory Contentsin Realtime

Use the [Monitor] window to monitor the memory contents during user program execution. In the Monitor
function, the realtime operation is retained since the bus monitoring circuit of the emulator sets the read/write
signa of the MCU as atrigger and holds the address bus and data bus values to update the displayed contents of
the memory.

Up to eight points can be set by using the eight monitoring channels on the bus monitoring circuit. 1 to 256 bytes
can be monitored at one point. It is possible that a part or al of monitoring rangesis overlapped.

Note: Monitoring isimpossible for an area, such as an internal timer counter, where no internal read/write
signal is generated to update avalue.

591 Opening the [Monitor] Window

To open the [Monitor] window, select [View -> CPU -> Monitor -> Monitor Setting...] or click the [Monitor]
toolbar button to display the [Monitor Settings] dialog box.

Manikar Setting il ﬂ

onitor Setting |

Mame: Imnnitoﬂ
— Options
Address: IH'DDFFE Fan
Size [byte]: IH'2|:I j
Access [Format): IBYTE [ASCIH) j

[ Auto-Refresh at rate (ms) : ID'DDEDD

[¥ Reading the Initial ¥ alue

— Color
LChange Indicator: I Change j
Foreqround: [N |~ Background: |:||-|
[ tayfly
— Detail
lDET.t’-‘-.IL WOT SUFFORTED! Detail |
— Higtory

| [~
QK. I Cancel |

Figure5.33 [Monitor Setting] Dialog Box
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[Name]:

[Optiong]:

[Color]:

[Detail]:

[History]:

[Address]:

[Size]:

[Access):

[Auto-Refresh at rate (ms)]:

[Reading the Initial Value]:

[Change Indicator]:

[Foreground]:
[Background)]:

[Mayfly]:

Decides the name of the monitor window.

Sets monitor conditions.

Sets the start address for monitoring.

Sets the range for monitoring.

Sets the access size to be displayed in the monitor window.

Setsthe interval for acquisition by monitoring (500 ms at minimum).

Selects reading of the values in the monitored area when the monitor
window is opened.

Sets the method to update monitoring and the attribute of colors.

Selects how to display the values that have changed during monitoring
(available when [Reading the Initial Value] has been selected).
No change: No color change.

Change: Color is changed according to the [Foreground] and [Background]
options.

Gray: Those data with values that have not been changed are displayed in
gray.

Appear: A vaueisonly displayed after changed.

Sets the color used for display (available when [Change] has been selected).

Sets the background color (available when [Change] has been selected).

A check in this box selects restoration of the color of those data which have
not been updated in a specified interval to the color selected in the
[Background] option. The specified interval istheinterva for monitor
acquisition (available when [Change], [Gray], or [Appear] has been selected).

Sets the items specific to the emulator. Not used with this emulator.

Displays the previous settings.

Notes. 1. Inthisemulator, odd addressees cannot be specified as the start addresses for monitoring.
2. Selection of the foreground or background color may not be available depending on the operating

systemin use.

After setting, clicking the [OK] button displays the [Monitor] window.
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«# monitar; monitarl - H'OOFFEFAD = IDIﬂ

Address | 40| +1| +2 | +3 | +a| +5] 46| 47| Value |
OxOOFFEFAD 00 00 10 23 00 00 OB 23 .. _§....
OxOOFFEFAS 00 02 18 24 00 00 00 00 ...§....
OxOOFFEFED 57 70 00 00 00 Ol 80 74 Wp..... t
OxOOFFEFEE 00 00 10 36 00 00 04 1E ...6....

Figure5.34 [Monitor] Window
During user program execution, the display is updated according to the setting value of the auto-update interval.

Note:  Select [Refresh] from the popup menu when datais not displayed correctly after changing the address or
content of memory.

5.9.2 Changing the Monitor Settings

Selecting [Monitor Setting...] from the popup menu of the [Monitor] window displays the [Monitor Setting]
dialog box, which allows the settings to be changed.

Colors, the size of accesses, and the display format can be easily changed from [Color] or [Access] of the popup
menu.

593 Temporarily Stopping Update of the Monitor

During user program execution, the display of the [Monitor] window is automatically updated according to the
auto-update interval. Select [Lock Refresh] from the popup menu of the [Monitor] window to stop the update of
display. The characters in the address section are displayed in black, and the update of display is stopped.

Selecting [Lock Refresh] again from the popup menu cancels the stopped state.

5.9.4 Deleting the Monitor Settings

Selecting [Close] from the popup menu of the [Monitor] window to be deleted closes the [Monitor] window and
deletes the monitor settings.

595 Monitoring Variables
Using the [Watch] window refersto the value of any variables.

When the address of the variable registered in the [Watch] window exists within the monitoring range that has
been set by the Monitor function, the value of the variable can be updated and displayed.

This function allows checking the content of a variable without affecting the realtime operation.

For the [Watch] window, refer to section 5.14.3, [Watch] Window.
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5.9.6 Hiding the [Monitor] Window

When using the Monitor function to monitor the vaue of a variable from the [Watch] window, hide the
[Monitor] window for the effective use of the screen.

The current monitoring information islisted as the submenu when selecting [Display -> CPU -> Monitor]. The
list consists of the [Monitor] window name and the address to start monitoring.

When the left of thelist is checked, the [Monitor] window is being displayed.

Selecting items of the [Monitor] window you want to hide from the monitor setting list displays no [Monitor]
window and removes the check mark at the left of thelist.

To display the [Monitor] window again, select the hidden the [Monitor] window.

{2 Monitor Setting. . Shift+Chil+E

| v monitor2 - HODFFEODE
monitar] - HOOFFEFS0

windows Select. .

Figure5.35 Monitor Setting List

5.9.7 Managing the [Monitor] Window

Selecting [Display -> CPU -> Monitor -> Windows Select...] displays the [Windows Select] dialog box. In this
window, the current monitoring condition is checked and the new monitoring condition is added, edited, and
deleted in succession.

Selecting multiple monitoring conditions enables a temporary stop of update, hiding, and deletion.

Name Address
monitor? H'00FFBODS
monitor] H'00FFEF80

Add...

Edit...

Hide?

Lock Refresh? |

Remowve

Close |

Figure5.36 Selection in the[Monitor] Window
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[Add]: Adds a new monitoring condition.

[Edit]: Changes the settings of the selected [Monitor] window (disabled when selecting multiple
items).
[Lock Refresh/Unlock Refresh]:

Automatically updates or stops updating the display of the selected [Monitor] window.
[Hide/UnHide]: Displays or hidesthe selected [Monitor] window.
[Remove]: Removes the sel ected monitoring conditions.

[Close]: Closes this dialog box.

RENESAS
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510 ViewingtheLabels

When the user program that includes the debugging information is loaded, the labels are registered at that time.
The [Disassembly] window shows the first eight characters of each label instead of the corresponding address or
as apart of an instruction operand.

Note: When alabel value matches an operand, the corresponding instruction operand is replaced by the label.
If two or more |abels have the same value, the one that comes first in alphabetical order is displayed.

5.10.1 ListingLabels

Choose [View -> Symbol -> Labels] or click the [View Labels] toolbar button ) tolist al labelsdefined in
the current debug session.

-Iox

EP I Address I Name -
H'00001000 _=brk
H'00001034 _main
H'00001032 tutorial ()
H'00001104 _abort
H'0000Lll0C _ INITSCT
H'0000L1ZZ loopl
H'0000OL1ZC loopZ
H'000011ZE next loopZ
H'00001132:2 next loopl
H'00001144 loop3
H'0000L1EZ loopd
H'0000115% next loopd
H'0000115C next loop3
H'oo0olles ocperator newiunsigned long)
H'0000L1EE _ CALL_INIT
H'0000L1ED _ CALL_END
H'O0OO011E4 ocperator deleteiwvoid *)
H'0O000L1EE _rand
H'0000LlZZe _=rand
H'0000LlZ3Z $DIVLE 3
H'0o00lzzC ot negk -

A v

Figure5.37 [Labe] Window

Y ou can view symbols sorted either alphabetically (by ASCII code) or by address value by clicking on the
respective column heading.

Double-clicking in the [BP] column can set or clear a software breakpoint at the start of the function.
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5.10.2 Addingalabel

Choose [Add..] from the popup menu and open the [Add Label] dialog box to add a label:

fidd Label

Hame: || LI oK I
Address: [Hanoononn =l Gancel |

Figure5.38 [Add Label] Dialog Box

Enter the new label name into the [Name] field and the corresponding value into the [Address] field and press
[OK]. The[Add Label] dialog box closes and the label list is updated to show the new label. When an
overloaded function or a class name is entered in the [Address] field, the [Select Function] dialog box opens for
you to select afunction. For details, refer to section 5.13.3, Supporting Duplicate Labels.

5.10.3 Editingalabel

Choose [Edit...] from the popup menu and open the [Edit Label] dialog box to edit alabel:

Edit Label _main

Mame: |_main LI (0] 4 I

Address: [HanoonTa2| =l Cancel |

Figure5.39 [Edit Label] Dialog Box

Edit the label name and value as required and then press [OK] to save the modified version in the label list. The
list display is updated to show the new label details. When an overloaded function or a class nameis entered in
the [Address] field, the [Select Function] dialog box opens for you to select a function. For details, refer to
section 5.13.3, Supporting Duplicate Labels.
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5.104 Deleting alLabel

To delete alabel, select the label and choose [Delete] from the popup menu. A confirmation message box
appears:

Confirmation Reguest

Delete Label ETEL

I Don't ask this question again

o] % I Gancel i

Figure5.40 Message Box for Confirming L abel Deletion
If you click [OK], the label isremoved from thelist and the window display is updated. If the message box is not
necessary then check the [Don’t ask this question again] check box.
5.10.5 Deleting All Labels

To delete all the labels from the list, choose [Delete All] from the popup menu. A confirmation message box
appears:

Confirmation Request

Delete Al Labels

I Dor't azk this question aeain

Figure5.41 Message Box for Confirming All Label Deletion

If you click [OK], dl the labels are removed from the HEW system’s symbol table and the list display will be
cleared. If the message box is not necessary then check the [Don’t ask this question again] check box.
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5.10.6 LoadingLabelsfrom aFile

A symbol file can be loaded and merged into the HEW's current symbol table. Choose [Load...] from the popup
menu to open the [Load Symbols] dialog box:

Load Symbols
Look jr: Ia HEshut

ttl:unal.s_l,lm

File name: Imy_code.s_l,lm Open I
Files of bope: ISymboI Files [ spm) ﬂ Cancel |

Figure5.42 [Load Symbols] Dialog Box

The dialog box operates like a standard Windows® [open file] dialog box; select the file and click [Open] to start
loading. The standard file extension for symbol filesis“.sym”.

5.10.7 SavingLabelsintoaFile

Choose [Save As...] from the popup menu to open the [Save Symbols] dialog box. The [Save Symbols] dialog
box operates like a standard Windows”® [Save File As] dialog box. Enter the name for the file in the [File name]
field and click [Save] to save the HEW's current label list to a symbal file. The standard file extension for
symbol filesis“.sym”.

See appendix E, Symbol File Format, for the symbol file format.

Once afileis specified by the [Save As...] menu, the current symbol table can be saved in the same symbol file
just by choosing [Save] from the popup menu.

5.10.8  Searching for a Label

Choose [Find...] from the popup menu to open the [Find Label] dialog box:

Find Label EH

Mame: I LI CK I
™ Match Case I LI Cancel |

Figure5.43 [Find Label] Dialog Box
Enter al or part of the label name that you wish to find into the edit box and click [OK] or press the [Enter] key.
The HEW searchesthe label list for alabel name containing the text that you entered.
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Note: Only the label is stored by 1024 characters of the start, therefore the label name must not overlap
mutually in 1024 characters or less. Labels are case sensitive.

5.10.9 Searching for the Next Label

Choose [Find Next] from the popup menu to find the next occurrence of the label containing the text that you
entered.

5.10.10 Viewing the Source Corresponding to a Label

Select alabel and choose [View Source] from the popup menu to open the [Source] or [Disassembly] window
containing the address corresponding to the label.
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511  Executing Your Program

This section describes how you can execute your program's code. Y ou will learn how to do this by either running
your program continuously or stepping single or multiple instructions at atime.

511.1 Running from Reset

To reset your user system and run your program from the reset vector address, choose [Debug->Reset Go], or
click the [Go Reset] toolbar button ([EL]).

The program will run until it hits a breakpoint or a break condition is met. Y ou can stop the program manually
by choosing [Debug->Halt], or by dlicking the [Stop] toolbar button (@]).

Note: The program will start running from whatever addressis stored in the Reset Vector location. Therefore it
isimportant to make sure that this location contains the address of your startup code.

5.11.2 Continuing Run

When your program is stopped, the HEW will display an yellow arrow mark in the gutter of the linein the editor
and [Disassembly] windows that correspond to the CPU's current program counter (PC) address value. Thiswill
be the next instruction to be executed if you perform a step or continue running.

To continue running from the current PC address, click the [Go] toolbar button ), or choose [Debug->Go].

To continue running from a specified address which is not the stop address, change the PC value in one of the
following ways, and click the [Go] toolbar button or choose [Debug->Go].

¢ Changethe PC vaduein the [Register] window. Refer to section 5.4.3, Modifying Register Contents.
« Place the text cursor (not the mouse cursor) to atarget line in the [Source] or [ Disassembly] window, and
choose [Set PC Here] from the popup menu.

5.11.3 Running to the Cursor

Sometimes as you are going through your application you may want to run only asmall section of code, that
would require many single steps to execute. Y ou can do this using the Go To Cursor feature.

2 How to use the Go To Cursor

1. Make surethat a[Source] or [Disassembly] window is open showing the address at which you wish to stop.

2. Position the text cursor on the address at which you wish to stop by either clicking in the [Address] field or
using the cursor keys.

3. Choose [Go To Cursor] from the popup menu.

The debugging platform will run your code from the current PC value until it reaches the address indicated by
the cursor's position.

Notes. 1. If your program never executes the code at this address, the program will not stop. If this happens,
code execution can be stopped by pressing the Esc key, choosing [Debug->Halt], or clicking on the
[Stop] toolbar button (&)).
2. The Go To Cursor feature requires a PC breakpoint - if you have already used all those available, then
the feature will not work.
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5114 Running from a Specified Address

The[Run Program] dialog box allows the user to run the program from any address. Choose [Debug -> Run...]
to open the [Run Program] dialog box.

Run Program ﬂﬂ

Proeram Counter:

|H'DDEIEIEIEIEID|
Besget Go
Temporary PG Breakpoints:

Cahcel

iy

Figure5.44 [Run Program] Dialog Box
The following execution conditions can be specified in this dialog box:

[Program Counter]: Instruction address to start execution. Theinitial valueis
the current PC value.

[Temporary PC Breakpoints]: A temporary PC breakpoint. When execution started
by this dialog box stops, this breakpoint is cleared.

Note: The[Temporary PC Breakpoints] feature requires a PC breakpoint - if you have already used al those
available then the feature will not work.

Clicking the [Go] button starts execution according to the settings. Clicking the [Reset Go] button starts
execution from the reset vector. Clicking the [Cancel] button closes this dialog box without executing
ingtructions.
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5115 Single Step

To debug your code it is very useful to be able to step asingle line or instruction at a time and examine the effect
of that instruction on the system. In the [Source] window, then a step operation will step asingle sourceline. In
the [Disassembly] window, a step operation will step a single assembly-language ingtruction. If the instruction
calls another function or subroutine, you have the option to either step into or step over the function. If the
instruction does not perform a call, then either option will cause the debugger to execute the instruction and stop
at the next instruction.

¢ Stepping Into a Function

If you choose to step into the function the debugger will execute the call and stop at the first line or instruction of
the function. To step into the function either click the [Step In] toolbar button , or choose [Debug->Step In].

e Stepping Over a Function Call

If you choose to step over the function the debugger will execute the call and al of the codein the function (and
any function calls that that function may make) and stop at the next line or instruction of the caling function. To
step over the function either click the [Step Over] toolbar button , or choose [Debug->Step Over].

e Stepping Out of a Function

There are occasions when you may have entered a function, finished stepping through the instructions that you
want to examine and would like to return to the calling function without tediously stepping through al the
remaining code in the function. Or aternatively you may have stepped into a function by accident, when you
meant to step over it and so want to return to the calling function without stepping all the way through the
current function. Y ou can do this with the Step Out feature.

To step out of the current function either click the [Step Out] toolbar button , or choose [Debug->Step Out].
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5116 Multiple Steps

You can step several instructions at atime by using the [Step Program] dialog box. The dialog box also provides
an automated step with a selectable delay between steps. Open it by choosing [Debug-> Step...].

The [Step Program] dialog box is displayed:

3tep Program ﬂ il

Steps: |H'D000000T oK |
QE|6.'HZ|2.5 seconds j Cancel |

[ Step over calls

[ Source level step

Figure5.45 [Step Program] Dialog Box

[Steps]: Number of steps to be executed.

[Delay (seconds)]: Delay between steps when the program is automatically stepped.
0 to 3 seconds can be selected in 0.5 second units.

[Step Over Callg): Selecting this box steps over function calls.

[Source Level Step]: Selecting this box steps the program at the source level.

Clicking the [OK] button or pressing the [Enter] key starts step execution.
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5.12  Stopping Your Program

This section describes how you can halt execution of your application's code. This section describes how to do
thisdirectly by using the [Stop] button and by setting breakpoints at specific locationsin your code.

5121 Stoppingthe Program by the[Stop] Toolbar Button

When your program is running, the [Stop] toolbar button is enabled ) (ared STOP sign), and when the
program has stopped it is disabled (D) (the STOP sign is grayed out). Click on the [Stop] toolbar button, or
choose [Debug->Halt Program].

When the program has been stopped by [Stop], "User Break" is displayed in the [Debug] sheet of the [Output]
window.

5122 Standard Breakpoints (PC Breakpoints)

When you are trying to debug your program you will want to be able to stop the program running when it
reaches a specific point or pointsin your code. You can do this by setting a PC breakpoint on the line or
instruction at which to want the execution to stop. The following instructions will show you how to quickly set
and clear simple PC breakpoints. If more complex breakpoint operation is required, use the [Event] window,
which can be opened by clicking the button or choosing [View -> Code -> Eventpoints]. For details, refer
to section 5.15, Using the Event Points.

¢ To set aPC breakpoint in the [Source] window

1. Make surethat the [Disassemble] or a[Source] window is open at the place you want to set a PC
breakpoint.

2. Choose [Toggle Breakpoint] from the popup menu, or press F9, at the line showing the address at which
you want the program to stop.

3. Youwill seeared circle appear in the gutter to indicate that a PC breakpoint has been set.

4. The current breakpoint set can be enabled or disabled by using [Enable/Disable Breakpoint] in the popup
menu.

Now when you run your program and it reaches the address at which you set the PC breakpoint, execution halts
with the message "PC Break" displayed in the [Debug] sheet of the [Output] window, and the [Source] or
[Disassembly] window is updated with the PC breakpoint line marked with an arrow in the gutter.

Note:  When abreak occurs, the program stops just before it is about to execute the line or instruction at which
you set a program PC breakpoint. If you choose Go or Step after stopping at the PC breakpoint, then the
line marked with an arrow will be the next instruction to be executed.
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e Toset aPC breakpoint by using the [Breakpoints] dialog box
Selecting [Edit -> Source Breakpoint...] displays the [Breakpoints] dialog box.

Breakpointz

Cancel |
Edit Code |
Remove |
Remaove All |

Figure5.46 [Breakpoints] Dialog Box

The [Breakpoints] dialog box allows the user to view the current breakpoints set. Clicking the [Edit Code] button
displays the source where each breakpoint is set. The [Remove] or [Remove All] button deletes one or all
breakpoints, respectively. The check box of each breakpoint enables or disables the breakpoint.

* Totoggle PC breakpoints
It is possible to toggle the [PC Breakpoints] setting by either double-clicking in the [BP] column of the line
where the PC breakpoint is set or placing the cursor on the line and pressing the [F9] key. The setting to be
toggled depends on the debugging platform.
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5.13 Elf/Dwarf2 Support

The HEW supports the Elf/Dwarf2 object file format for debugging applications written in C/C++ and assembly

language for Renesas microcomputers.
Key Features

*  Sourcelevel debugging

e C/C++ operators

e C/C++ expression (casting, pointers, references, etc.)
« Ambiguous function names

¢ Overlay memory loading

e Watch - locals, and user defined

e Stack Trace

5131 C/C++ Operators
The C/C++ language operators are available:
L& N 3> <%, (), <>, <=, =5, 15, &&, |

Buffer_start + 0x1000

#R1 | B 10001101

((pointer + (2 * increment_size)) & H FFFFO000) >> D 15
I(flag N #ER4)

5132 C/C++ Expressions

Expression Examples

Obj ect . val ue /ISpecifies direct reference of amember (C/C++)
p_hj ect - >val ue /ISpecifiesindirect reference of amember (C/C++)
d ass: :val ue //Specifies reference of a member with class (C++)
*val ue /ISpecifies apointer (C/C++)

&val ue //Specifies areference (C/C++)

array[ 0] //Specifies an array (C/C++)

Cbj ect . *val ue /ISpecifies reference of a member with pointer (C++)
;. g_val ue //Specifies reference of aglobal variable (C/C++)

d ass:: function(short) //Specifiesamember function (C++)

(struct STR) *val ue /ISpecifies cast operation (C/C++)

RENESAS
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5.13.3  Supporting Duplicate Labels

In some languages, for example C++ overloaded functions, alabel may represent more than one address. When
such alabel nameisentered in adialog box, the HEW will display the [Select Function] dialog box to display
overloaded functions and member functions.

& Function il ﬂ

Select Function Mame Set Function Name

{5 ample:: sortflong *1 N
1S ample:: sort(long *, short]} |

— Counter
All Function Select Function Set Function

|2 Functions |2 Functions II:I Functions

Cancel

Figure5.47 [Select Function] Dialog Box

Select overloaded functions or member functionsin the [Select Function] dialog box. Generally, one function
can be selected at one time; only for setting breakpoints, multiple functions can be selected. Thisdialog box has
three areas.

[Select Function Name]: Displays the same-name functions or member functions and
their detailed information.

[Set Function Name]: Displays the function to be set and their detailed information.

[Counter]: [All Function] Displays the number of same-name functions
or member functions.
[Select Function] Displays the number of functions displayed
in the [Select Function Name] list box.
[Set Function] Displays the number of functions displayed
in the [Set Function Name] list box.

Selecting a Function

Click the function you wish to select in the [Select Function Name] list box, and click the [>] button. Y ou will
see the selected function in the [Set Function Name] list box. To select dl functionsin the [Select Function
Name] list box, click the [>>] button.

Deselecting a Function

Click the function you wish to deselect from the [Set Function Name] list box, and click the [<] button. To
deselect all functions, click the [<<] button. The deselected function will be moved from [Set Function Name]
list box back to the [Select Function Name] list box.
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Setting a Function

Click the [OK] button to set the functions displayed in the [Set Function Name] list box. The functions are set
and the [Select Function] dialog box closes.

Clicking the [Cancel] button closes the dial og box without setting the functions.

5.13.4 Debugging an Overlay Program
This section explains the settings for using the overlay functions.
Displaying Section Group

When the overlay modeis used, that is, when several section groups are assigned to the same address range, the
address ranges and section groups are displayed in the [Overlay] dialog box.

Open the [Overlay] dialog box by choosing [Memory->Configure Overlay].

21x
Address: Section Mame:
OOFFES00 - DOFFBEDE oK I
Cahicel |

Figure5.48 [Overlay] Dialog Box (at Opening)

Thisdialog box has two areas: the [Address] list box and the [Section Name] list box.
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The[Address] list box displays the address ranges used in the overlay mode. Click to select one of the address
rangesin the [Address] list box.

Section Mame:

R_zample oK |
R_zort

R_change Cancel |

Figure5.49 [Overlay] Dialog Box (Address Range Selected)
The[Section Name] list box displays the section groups assigned to the selected address range.
< Setting section group

When using the overlay function, the highest-priority section group must be selected in the [Overlay] dialog box;
otherwise the HEW will operate incorrectly.

First click one of the address ranges displayed in the [Address] list box. The section groups assigned to the
selected address range will then be displayed in the [Section Name] list box.

Click to select the section group with the highest-priority among the displayed section groups.

21x

Address: Section Mame:
O0FFES00 - OOFFESDE 0K I
- Cahicel |

Figure5.50 [Overlay] Dialog Box (Highest-Priority Section Group Selected)

After selecting a section group, clicking the [OK] button stores the priority setting and closes the dialog box.
Clicking the [Cancel] button closes the dialog box without storing the priority setting.

Note:  Within the address range used by the overlay function, the debugging information for the section
specified in the [Overlay] dialog box isreferred to. Therefore, the same section of the currently loaded
program must be selected in the [Overlay] dialog box.
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5.14 Viewingthe Variables

This section describes how you can look at variables in the source program.

5141 Tooltip Watch
The quickest way to look at avariablein your program is to use the Tooltip Watch feature.
2 To use Tooltip Watch:

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near the variable
containing basic watch information for that variable.

[ ] p_=amn= Sample:;
o for{ i=0; 1<10; i4++ 34
7 = rand(): [H0o003]
1f(3 < 03{
] = -1:
ali1] = 3:

Figure5.51 Tooltip Watch

5142 Instant Watch

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine and choose [Instant Watch...] from the
popup menu; the [Instant Watch] dialog box will appear and display the variable at the cursor location.

Inztant Watch

=-str [ 0x7c000038 } {steuct steBD

Figure5.52 [Instant Watch] Dialog Box

“+" shown to the | eft of the variable name indicates that the information may be expanded by clicking on the
variable name, and “-" indicates that the information may be collapsed. Clicking [Add] registers the variable in
the [Watch] window. Clicking [Close] closes the window without registering the variable in the [Watch] window.
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5143 [Watch] Window
You can view any vaue in the [Watch] window.
Opening a [Watch] Window

To open a[Watch] window, choose [View->Symbol->Watch] or click on the [Watch] toolbar button ) ifitis
visible. A [Watch] window opens. Initially the contents of the window will be blank.

A \Watch ;IEI il
Hame I Walue I Twpe
=R a {The7000024 1 oD
_____ R [0 HD0000000 { D:x7c000024 } {int)
_____ R 0] HD0000000 { D:x7c000028 } {int)
_____ R [ HD0000000 { D:x7e00002c } {int)
_____ R [ HD0000000 { D:x7c000030 } {int)
_____ R [ HD000000 { D:x7c000034 } {int)
_____ R [l HD000000 { D:x7c000038 } {int)
_____ R [l HD000000 { D:x7e00003e } {int)
_____ R [ HD0000000 { D:x7o000040 } {int)
_____ R [ HD000000 { D:x7c000044 } {int)
_____ R [ HD000000 { D:x7c000043 } {int)
...... B max HO0000000 { 0x7c00004: tint)

Figure5.53 [Watch] Window

Thiswindow allows the user to view and modify C/C++-source level variables. The contents of this window are
displayed only when the debugging information available in the absolute file (*.abs) includes the information on
the C/C++ source program. The variable information is not displayed if the source program information is
excluded from the debugging information during optimization by the compiler. In addition, the variables that are
declared as macro cannot be displayed.

The following items are displayed.

[Name]: Name of the variable
[Value]: Value and assigned location.
The assigned location isenclosed by { }.
[Typel: Type of the variable
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The [R] mark shows that the value of the variable can be updated during user program execution.

For updating of the content of the variable that has been registered in the [Watch] window, there are the
following three methods:

1. Usethe Monitor function without hating the user program
The read/write signal of the MCU is set as atrigger and holds the address bus and data bus values to update the
value of the variable.

Note:  Although the realtime operation is retained, the size and number points to be monitored are limited. For
the Monitor function, refer to section 5.9, Displaying Memory Contentsin Realtime.

2. Read the memory content directly from the HEW to update the values without halting the user program since
the bus mastership is owned by the emulator

Note: While the emulator reserves the bus mastership, the realtime operation is disabled because the CPU stops
operation. This method is only available for accessing theinternal ROM, internal RAM, and emulation
memory.

The area used here or this method may not be available depending on the emulator in use. For details,
refer to section 8, Software Specifications Specific to This Product, or [Enable read and write on the fly]
on the [General] page of the [Configuration Properties] dialog box in the online help.

3. Temporarily stops the user program and reads the memory contents

Note: The realtime operation is disabled because the user program is stopped temporarily. This method is only
available for accessing the areas (internd 1/0, DTCRAM, and user memory) other than thosein item 2
mentioned above.

It is possible to recognize the method for updating the value during user program execution according to the
color of the [R] mark.

Blue-outline[R]:  Thevariable's addressiswithin the range that has been set for the monitoring function and
the datais readabl e by using the monitoring function.

Blue [R]: An updated value of the data at this location has been read by the monitoring function.

Black-outline[R]: The variable's address is outside the range that has been set for the monitoring function and
the datais not readable by using the monitoring function.

Black [R]: A value has been updated by reading the normal data.

Notes: 1. Thisfunction can be set per variable or per element or body for structures of data.
2. Thecolor of an [R] in the [Name] column changes according to the trace and monitoring settings.
3. A vaiablethat isalocated to aregister cannot be selected for monitoring.
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Adding a Watch Item
Use the [Add Watch] dialog box in the [Watch] window to add Watch items to the [Watch] window.
< To use Add Watch from a [Watch] window:

Open the [Watch] window.
Choose [Add Watch] from the popup menu.
The[Add Watch] dialog box opens:

21|

==

aniable or expreszsion:

| _ Concel |

LCancel

Figure5.54 [Add Watch] Dialog Box

Enter the name of the variable that you wish to watch and click [OK]. The variable is added to the [Watch]

window. A variable can be dragged from the [Source] window and dropped into the [Watch] window.

Note: If the variable that you have added isalocal variable that is not currently in scope, the HEW will add it

to the [Watch] window but its value will be 'Not available now'.
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Expanding a Watch Item

If awatch item isapointer, array, or structure, then you will see aplus sign (+) expansion indicator to left of its
name, this means that you can expand the watch item. To expand a watch item, double click onit. Theitem
expands to show the elements (in the case of structures and arrays) or data value (in the case of pointers)
indented by one tab stop, and the plus sign changesto aminus sign (-). If the elements of the watch item aso
contain pointers, structures, or arrays then they will also have expansion indicators next to them.

Expansion

inclicator

Sl R B B [0 H'0D000IE { Dx00ffef80 } flong]
..... B 0] H'00001 Sfb { DwD0fFefB4 } flong]
..... B 2 H'00001 67e { 0x00ffef88 } flong]
..... B 3 H'00001 efb { DxD0fFefBc } flong]
..... B [ H'00002781 { 0x00ffef30 } flong]
..... B 5 H'00D0354 { DuD0fer34 } flong]
..... B [ H'000041 6 { 0x00ffef98 } flong]
..... B 17 H'0000446b { 0x00ffefe } flong]
..... B 9 H'000059%2 § Dx00f=fal } [long)
..... R H'0000794b { 0x00ffefad } flong]

Collapser watch F-B a { 0=00fefS0 } [lang(10]]

1| | _'I

Figure5.55 Expanding a Watch Item

To collapse an expanded watch item, double click on the item again. The item's elements will collapse back to
the single item and the minus sign changes back to a plus sign.

The watch item can be expanded for the number of levels when anumerical key from 1to 9is pressed while a
watch item is selected.
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Editing a Watch Item's Value

Y ou may wish to change the value of awatch variable, e.g. for testing purposes or if the value isincorrect due to
abug in your program. To change a watch item'’s val ue use the Edit VValue function.

< Editing awatch item's value:
Enter avalue directly in the window.

In another way, select theitem to edit by clicking on it, you will see a flashing cursor on the item.
Choose [Edit Value] from the popup menu.
The[Edit Value] dialog box opens:

Edit Value 21 x|
Expression: I[D]
Current H'00000FR { Dx00fef20 ¢
Wl ok
Hew Value: I

LCancel

Figure5.56 [Edit Value] Dialog Box

Enter the new value or expression in the [New Vaug] field and click [OK]. The [Watch] window is updated to
show the new value.
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Deleting a Watch Item

To delete awatch item, select it and choose [Delete] from the popup menu. The item is deleted and the [Watch]
window is updated.

To delete all watch items, choose [Delete All] from the popup menu. All items are del eted and the [Watch]
window is updated.

Specifying Realtime Update

The R mark shown to the left of each variable indicates whether the variable is updated in real time. When an R
mark is displayed in bold face, the value of the corresponding variable will be updated in realtime during user
program execution.

A popup menu containing the following optionsis available in the [Watch] window:

¢ Auto Update
Marks the selected variable with abold R and updates the variable in red time.
* Auto Update All
Marks al variables with bold Rs and updates all variablesin real time.
« Delete Auto Update
Marks the selected variable with an outlined R and cancels realtime update.
« Delete Auto Update All
Marks al variables with outlined Rs and cancels realtime update.

M odifying the Radix
The radix for the selected variable display can be modified by choosing [Radix] from the popup menu.
Saving the [Watch] Window Contentsin a File

To save the contents of the [Watch] window, choose [Save As...] from the popup menu; the Save As dialog box
opens. It alows the user to specify the name of afile and to save the contents of the [Watch] window in the file.
If the [Append] check box is selected, the window contents are appended to the existing file, and if it is not
selected, the existing file is overwritten.

Opening a[Memory] Window

The contents of the memory area to which the selected variable is assigned can be displayed in the [Memory]
window. Choose [Go To Memory...] from the popup menu; the [Set Address] dialog box opens, showing the
information (start address, end address, and size) of the selected variable as default. Clicking [OK] opens the
[Memory] window.
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5.144 [Locals] Window

Thelocal variables and their values can be displayed in the [Locals| window.

Opening the [Locals] Window

To open the [Locals] window, choose [View->Symbol->Locals] or click the [Locals] toolbar button ).

i H'00ffef80 { ERS } |'3n5|]
-------- i H'000a { R4 } fint)
""" p_sam 0:00ffb0d8 { ERE } [class Sample)

Figure5.57 [Locals] Window

If alocal variableis not initialized when defined, then the value of the local variable will be incorrect until
another valueis assigned to thelocal variable.

Thelocal variable values and the radix for local variable display can be modified in the same manner asin the
[Watch] window.
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5.15 Usingthe Event Points

The emulator has the event point function that performs breaking, tracing, and execution time measurement by
specifying higher-level conditions along with the PC breakpoints standard for the HEW.

5.15.1 PC Breakpoints
When the instruction of the specified addressis fetched, the user program is stopped. Up to 256 points can be set.

Note that, however, only one PC breakpoint can be set in the ROM area of the user system. This particular
breakpoint is called the on-chip breakpoint, which stops the user program after executing the instruction of the
specified address.

When it is necessary to set two or more PC breakpoints to the external ROM area of the user system, allocate
this area to the emulation memory, copy the code, and then set the PC breakpoints.

5.15.2 Event Points

Event points can be used for higher-level conditions such as the data condition as well as specification of the
single address. Up to 12 event points can be set by using event channels and range channelsin the event
detection system.

When the condition is satisfied, event points are also used as the start/end conditions for execution time
measurement or trace acquisition in addition to halting the user program. Several event points can be used to set
more complex conditions.

Note: Event points acquire the data, test conditions, and execute an action (such as halting the user program)
by the hardware circuit of the emulator. Therefore, adelay of several cycleswill occur from the
satisfaction of the condition to the execution of an action.

5.153 Event Detection System

In addition to the 4 range channels, the emulator also has 8 event channels. The event channels have more
functions (such as sequencing or counting) than the range channels.

Event Channels (Ch1to Ch8):

The emulator has 8 event channels. The event channel can be defined as a combination of one or more of the
followings:

e An address or an address range

¢ Outside of an address range

e Aread, awrite, or either

« Datawith amask specification

* Busstate

« Area

e Thevalue of four external probe signals

e Thenumber of timesthe event has occurred

¢ Thenumber of delay cycles after the event has occurred

A maximum of eight points can be used as a combination in a sequence. The program is activated or halted by an
occurrence of the previous event in each sequence.
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Range Channels (Ch9 to Ch12):

The emulator has 4 range channels. The range channel can be defined as a combination of one or more of the
followings:

¢ Anaddress or an address range

¢ Outside of an address range

* Aread, awrite, or either

¢ Datawith amask specification

¢ Busstate

*« Area

e Thevalue of four external probe signals

¢ Thenumber of delay cycles after the event has occurred

5.154 Signalsto Indicate Bus Statesand Areas

In the event detection system, signalsindicating the MCU’ s bus states and the accessed areas can be specified as
the event detection condition.

These signas are output from the MCU on the emulator; the signals to be acquired will vary according to the
emulator in use.

The signals to indicate bus states and areas are used to set the [Bus/Area] condition of the event point. They can
aso be acquired as the trace information.

The bus state signal's are also used to set the condition not to acquire the trace ([Suppress] option) and in the
Access Count Of Specified Range Measurement mode for measuring the hardware performance ([Access Type]
option).

For the trace function, refer to section 5.16, Viewing the Trace Information. For the hardware performance
function, refer to section 5.20, Analyzing Performance.

The following tables show examples of signas to indicate the bus states and areas that can be acquired by the
emulator.

Table5.1 BusState Signals Acquired by the Emulator

Bus State Trace Display (Status) Description
CPU Prefetch PROG CPU prefetch cycles
CPU Data DATA CPU data access cycles
Refresh REFRESH Refresh cycles
DMAC DMAC DMAC cycles
DTC DTC DTC cycles
Other OTHER Others
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Table5.2 AreaSignals Acquired by the Emulator

Area Trace Display (Status) Description
On-chip ROM ROM ROM

On-chip RAM RAM RAM

On-chip 1/0O 16bit 1/0-16 16-bit I/O

On-chip 1/0 8bit 1/0-8 8-bit 110

External I/O 16bit EXT-16 16-bit EXT (external)
External /O 8bit EXT-8 8-bit EXT (external)
DTC RAM RAM/DTC DTCRAM

Note: The signalsto indicate the bus states and areas vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

5.155 Opening the [Event] Window

Select [View -> Code -> Eventpoints] or click the [Eventpoints] toolbar button ) to open the [Event] window.

The [Event] window has the following three sheets:

[Breakpoint] sheet: Displays the settings made for PC breakpoints. It isalso possible to set, modify, and
cancel PC breskpoints.

[Event] sheet: Displays or sets event points.

[Trigger] sheet: Displays or setstrigger points.

5.15.6 Setting PC Breakpoints

It is possible to display, modify, and add PC breakpoints on the [Breakpoint] sheet.

M=
Type State Condition Action

Program Enahle PC=H'0O000105C(Tutorial.chp/42) Break

Program Enable PC=H'000010CE (Tutorial.cpp/53) Ereak

Program Enable PC=H'00001772 Break

s o
4| &', Breakpoint £ Event A Trigoer £

Figure5.58 [Event] Window ([Breakpoint] Sheet)
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Select [Add...] or the PC breakpoint displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Properties 21 x|
General |
~ Type Addressz
" Don'tCare @ 4ddess € Bange
Addrezs Lo [
© Event & _ |H00000000
#ddress Hi- - |H'00000000
[T Dutside Fange
- ['ata Compare Direction—
[T Compare [ Use tMazk {" Fead
Walue [
- IHD £ Wite
& Byte. € Wond
Mask IH,I:I o Elthef

ak. I Cahicel |

Figure5.59 [Breakpoint/Event Properties] Dialog Box (Setting a PC Break)
In this dialog box, select the address condition to set PC breakpoints.

[Typel: Select the type of abreakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables
or disables other pages and parts of the dialog according to the options available to that type of
breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options areinvalid.

[Event]: Set conditionsin detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.

[Address]: Set address conditions.

[AdderessLo]: Select asingle address where a PC breakpoint will be set.
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5.15.7  Setting Event Points

On the [Event] sheet, the settings for event points are displayed, modified, and added.

=
Type fdtate Condition | Action -
Chl (E) Enahle Address=H'00001064 (Tutorial.cpp/37) address bus prefetch Trace

Chz (E) Enahle Address=H'0000107E (Tutorial.cpp/45) address bus prefetch Trace

Chi (E) Enahle Address=H'000010A0 (Tutorial.cpp/4%9) address area ROM Trace

Chad (E) Enabhle Address=H'00001140 address area ROM Trace

ChS (E) Enmpty

Ché (E) Empty

Ch? (E) Eupty

Chi (E) Enpty

Che (R Empty

Ch10(R) Empty -
4| | k]
A4+ Breakpoint A Event £ Trigger /

Figure5.60 [Event] Window ([Event] Sheet)

Select [Add...] or the event point displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

The conditions for the event point are set on the [General], [Bus/Area], [Signals], and [Action] pages. The search
condition for the event point is set by multiple conditions set on these pages.

Notes: 1. Channel 8 has the trigger output function. When the condition on channel 8 is satisfied, the low-level
signa will be output from the external probe 1 (EXT1) for abuscycle.

2. When the event point is used as the condition for acquiring the trace information, select [Trace
Acquisition...] from the popup menu. For the trace function, refer to section 5.16, Viewing Trace
Information.

3. If acondition that is unavailable for arange channel is set in editing of the range channels (Ch9 to
Ch12), the selected channel is automatically replaced by an unused event channel (Chl to Ch8).

Table5.3 Conditions Unavailable for a Range Channel

Condition Related Options

Selecting outside the [Outside Range] on the [General] page
specified address range

Selecting the start or [Start Timer] and [Stop Timer] on the [Action] page
end of the execution
time measurement

Specifying the count [Required number of event occurrences] on the [Action] page
when an event occurs
(twice or more)

Specifying sequencing [Enable Sequencing] on the [Action] page
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(1) [Generd] page

The address and data conditions are set.

Breakpoint/Event Properties

2%

General | Bus / &rea | Signals | Action |

— Type
" PC Break

Address
¢ Don't Care @ Addess ¢ Range

fddress Lo [H'00000000
Address Hi - |H'00000000

™ Dutside Fange

—Data Compare Direction——
[T Compare [T Use task " Read
Walue [

- IHD " Wiite
= Byte © Waord
Mask IH'D ¢ Either

QK. I Cancel |

[Typel: Select the type of a breakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables
or disables other pages and parts of the dialog according to the options available to that type of
breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options areinvalid.

[Event]: Set conditionsin detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.

[Address]: Sets the address condition.

[Don't care]: Sets no address condition.

[Address]: Allows asingle address to be selected.

[Range]: Allows an address range to be selected.

[AdderessLo]: Set asingle address or the start of an address range (available when [Address] or
[Range] has been selected).

[AdderessHi]:  Set the end of an address range (available when [Range] has been selected).

[Outside Range]: Used to negate the range (i.e., the event will occur when the address is outside the
range). Thisisavailable when [Address] or [Range] has been selected.
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[Data Compare]: Sets the data condition.
[Compare]: Checking this box compares data.
[Use Mask]: Sets amask condition (available when [Compare] has been selected).

[Value]: Specifies the data bus value as numerics. The size of data for access can also be
selected (available when [Compare] has been selected).

[Byte]: Sets access in bytes as the condition (available when [Compare] has been sel ected).
[Word]: Sets access in words as the condition (available when [Compare] has been selected).
[Mask]: Sets avalue to be masked. Thisvalue will be ANDed with the value of the data bus

and data condition. The result will be used to compare data (available when [Use
Mask] has been selected).

[Direction]: Selects a condition with read or write cycles.
[Read)]: Sets read cycles as the condition.
[Write]: Sets write cycles as the condition.
[Either]: Sets either read or write cycles as the condition.
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(2) [Bug/Area] page

Use this page to set the bus status and the memory area being accessed.

EBreakpointfEvent Properties 71 x|

General Bus /Area | Signalsl .-’-‘«ctinnl

— Buz State —Area

™| CFU Frefetch ™ Or-chip B0k

[T CPU Data [T Or-chip Bk

[T Eefresh [T On-chip 40 16 bit
= DMAC = [rechip 140 8 hit
I~ DIC I Extermal 16 bit
[= Other [ Esternal 8 Lit

I~ DTEC R

¥ Don't Care

QK. I Cancel |

Figure5.62 [Breakpoint/Event Properties] Dialog Box ([Bus/Area] Page)

[Bus State]: Sets the bus status as the condition. When the [Don't care] check box is checked, the event will
be satisfied with any bus status.

[Ared]: Specifies the area for searching. When the [Don't care] check box is checked, the event will be
satisfied in any area.

Note: Items set for the bus state and memory access area vary according to the emulator in use. For details,
refer to section 5.15.4, Signals to Indicate Bus States and Areas.
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() [Signals] page

Use this page to set external signals.

EBreakpaint/Event Properties 71 x|

General I Bus /drea  Signals |.-’-‘«ctinn|

— Frobe 4 — Probe 3
" High " High
© Low © Low
[ : £+ Daon't Care
—Probe 2 ~Probe 1
" High " High
© Low © Low
& Don't Care & Don't Care

QK. I Cancel |

Figure5.63 [Breakpoint/Event Properties] Dialog Box ([Signals] Page)

[Probed]: Detects the status of the input probe signal 4
[High]: Detectsthe high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

[Probe3]: Detects the status of the input probe signal 3
[High]: Detectsthe high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

[Probe2]: Detects the status of the input probe signal 2
[High]: Detectsthe high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected
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[Probel]: Detects the status of the input probe signal 1
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

(4) [Action] page

Use this page to decide what action the emulator takes when the defined event occurs.

2%

General | Bus / rea | Signals Aetion

Actions

I étartTimer
[ Stop Timer

Delay after detection before break occours
Y]

buz cycles

Required number of event ococunences
|01

[ Enable Sequencing |

QK. | Cancel

Figure5.64 [Breakpoint/Event Properties] Dialog Box ([Action] Page)

[Action]: Selects an action that occurs when the event is satisfied. This cannot be used for an
event point being used as the trace acquisition condition.

[Break]: Causes abreak (stop) in the user program when the event occurs. Thisisthe
default action.

[Start Timer]: Starts the run timer (the run timer value is displayed in the [ Status] window).

[Stop Timer]: Stopsthe run timer (the run timer value is displayed in the [Status] window).

[Delay after detection before break occurs]:
Setsa 16-bit delay (in bus cycles) after the event has occurred before the action is
taken. The delay isonly applicable to break events and there is only one delay counter
in hardware, therefore only one breakpoint can have a non-zero delay. The range of
valuesis D’0to D’65,535 (only available when [Break] has been selected). This
cannot be used for an event point being used as the trace acquisition condition.
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[Required number of event occurrences):

[Enable Sequencing]:

[Configure Sequence...]:

Allows a 16-hit pass count to be set. The event must occur the specified number of
times before the action is taken. The range of valuesis D’'0 to D’'65,535.

Allows the event to take part in a sequence of events (setting this requires the event to
use an event detector).

Displays the [Event Sequencing] dialog box to allow the event sequencing to be
configured (only available when [Enable Sequencing] has been selected).

(5) [Event Sequencing] dialog box

This dialog box alows the user to define which events are triggered by other events. If thisdialog box is
accessed (directly or indirectly) from [Trace Acquisition...], only those events assigned to the trace subsystem
are displayed. If accessed from the [Eventpoint] window, only the breakpoint or timer events are shown.

Cancel |

& |z Armed By
|z Beset By

[ Mo occurence of

The fallowing events:

[E]HT 058 address

[E]H05C address count D10
[E]H1OFE address count D2
[ETH10FC address

undefined on unayvailable
undefined on unayvailable
undefined on unayvailable
unidetined or unayailable

[Event]:
[Is Armed By]:
[Is Reset By]:

[No occurrence of]:

Figure5.65 [Event Sequencing] Dialog Box

Selects an event point to be set.
Arms the selected event.
Resets the selected event.

Arms an event when the set of events being selected does not occur (only available
when [Is Armed By] has been selected).

The test of conditions on event pointsis started with the execution of the user program. The conditions on event
points have not been satisfied immediately after the execution of the user program is started.

Satisfaction of the condition on an event point allows atransition of the state to that where the condition is

satisfied.

289
RENESAS




The state where the condition is satisfied is retained until the user program is stopped or the event point is reset.

When the condition on the event point is satisfied, no action will be taken even if the condition is satisfied again.
If you want the action to be taken again, reset the event point so that the state transits to that where no condition
is satisfied.

When the user program is stopped, the states of all the event points transit to that where no condition is satisfied.

When an event point must be in the state where its condition is satisfied or not (when [No occurrence of] is
selected) as the satisfaction condition of another event point, this event point is called the arm event.

An event point can reset the tested states of conditions of other event points or itself by satisfying the condition.
Thisevent point is called areset event.

A reset event resets event points regardless of their states where the condition is satisfied or not (e.g., resetting
the pass count).

Select an event point from the [Event] combo box. To set an arm event on the selected event point, select [Is
Armed By] and check the box corresponding to each event. The [No occurrence of] check box isused to set a
condition that the arm event isin the state where its condition is not satisfied.

To set areset event on the selected event point, select [Is Reset By] and check the box corresponding to each
event.

At the bottom of the screen is a diagram showing the current sequencing of the events (figure 5.65). The Sinput
sets (arms) an event and the R input resetsit. The legend ~S indicates the event is set (armed) by the non-
occurrence of the input events.

Figure 5.65 is an example that Chl isthe arm event for Ch2, Ch3, and Ch4. Ch3 isthe arm event for Ch4. Ch2
and Ch4 are the reset events for Chl and Ch2, respectively.

To satisfy the condition of the event point having an arm event, the arm event must be in the state where the
condition is satisfied or not (when [No occurrence of] is selected). When multiple arm events exist on one event
point, one of the arm events must be in the state where the condition is satisfied or not (when [No occurrence of]
sel ected) to satisfy the condition of the event point.

Asthe condition of the arm event on one event point, either of the states where the condition is satisfied or not
should be set.

To reset an event point with areset event, the condition of the reset event must be satisfied. While the condition
of thereset point is satisfied, no event point is reset even if the condition of the reset event is satisfied again.

When multiple reset events exist on one event point, the event point is reset when the condition of one of reset
eventsis satisfied.
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5.15.8  Setting Trigger Points

Thetrigger point isan event to output a trigger when the specified address has been accessed. Up to four trigger
points can be set by using the trigger outputs (four channels) on the bus monitoring circuit of the emulator.

The settings of the trigger point are displayed and modified on the [Trigger] sheet.

(o]
Type I State I Condition I Lction

[EXT.Z-1 Enahle Addre=s=s=H'OOFFDEED Trigger output

ExT.2-2 Enahle Address=H'OOFFD404 Trigger output

[E=T.2-3 Enahle Address=H'00001140 Trigger output

[ExT.Z-4 Enahle Addre=s=s=H'OOFFEF&C Trigger output

ol | 2+
A | k[, Breakpoint & Event A Trigger

Figure5.66 [Event] Window ([Trigger] Sheet)

Selecting [Add...] or the event point and [Edit...] from the popup menu in this window displays the [Set Address
For Trigger] dialog box.

Far Trigger

Address

W Trigger: IH'DDFFDEED

¥ Trigger: IH '00FFD 404

IV Trigger: |H'nnnmmu

' Triggerd: [HOOFFEFBC

Cancel |

Figure5.67 [Set AddressFor Trigger] Dialog Box

Thisdialog box alows the user to specify the address to be accessed as the trigger output condition during the
user program execution. Enable or disable the trigger output point by checking the check box on the left in the

screen.

[Triggerl]:
[Trigger2]:
[Trigger3]:

[Trigger4]:

[Address]:

Enables the output of trigger channel 1.
Enables the output of trigger channel 2.
Enables the output of trigger channel 3.
Enables the output of trigger channel 4.

Sets the address condition of the channel.
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Notes: 1. When the condition set for the trigger output (1 to 4) is satisfied, the high-level signa will be output
from the corresponding pin (1 to 4) of the external probe 2 (EXT2) during reading or writing.

2. Some emulators may not support the trigger point. For details, refer to section 8, Software
Specifications Specific to This Product, or the online help.

5.15.9 Editing Event Points

Handlings for settings other than PC breakpoints, event points, and trigger points are common. The following
describes examples of such handling.

5.15.10 Modifying Event Points

Select an event point to be modified, and choose [Edit...] from the popup menu to open the dialog box that
corresponds the event, which allows the user to modify the event conditions. The [Edit...] menu isonly available
when one event point is selected.

5.15.11 Enabling an Event Point

Select an event point and choose [Enable] from the popup menu to enable the selected event point.

5.15.12 Disabling an Event Paint

Select an event point and choose [Disable] from the popup menu to disable the selected event point. When an
event point is disabled, the event point will remain in the list, but an event will not occur when the specified
conditions have been satisfied.

5.15.13 Deleting an Event Point

Select an event point and choose [Delete] from the popup menu to remove the selected event point. To retain the
event point but not have it cause an event when its conditions are met, use the [Disabl€] option (see section
5.15.12, Disabling an Event Point).

Note: No trigger point can be deleted. Use the [Disable] option to clear the settings.

5.15.14 Deleting All Event Paoints
Choose [Delete All] from the popup menu to remove all event points.

Note: No trigger point can be deleted. If [Delete All] is selected, the settings of all channels become disabled.

5.15.15 Viewingthe Source Linefor an Event Point

Select an event point and choose [Go to Source] from the popup menu to open the [Source] or [Disassembly]
window at address of event point. The [Go to Source] menu is only available when one event point that has the
corresponding source fileis selected.
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5.16 Viewingthe TraceInformation

The emulator acquires the results of each instruction execution into the trace buffer as trace information and
displaysit in the [Trace] window. The conditions for the trace information acquisition can be specified in the
[Trace Acquisition] dialog box.

Since trace information in bus-cyclesis acquired by the hardware circuit and stored in the trace buffer, the
realtime operation is retained. The [ Trace] window displays the content of the trace buffer, which records up to
32,768 bus cycles from the last program run and is always updated.

5.16.1 Openingthe[Trace] Window

To open the [Trace] window, choose [View -> Code -> Trace] or click the [Trace] toolbar button ).

5.16.2 Acquiring Trace Information

When the emulator does not set the acquisition condition of the trace information, all bus cycles are acquired by
default without any condition (free trace mode).

In the free trace mode, trace acquisition is started with the execution of the user program and stopped by halting
the user program. The acquired trace information is displayed in the [Trace] window.

PTR ress | Instruction | Daca\ R/m\ Area \ St.at.usl Clock | Probes | mﬂ\ IRQ7-0 Timestamp | Source Label Timestamp-Difference ‘ﬁ!
-05550 000000 0000 BD ROM DaTa 1 1111 1 11111111
-05549 000002 0400 BD ROM DATA 1 1111 1 11111111
-05545 000400 MOV. L #H'00F... 7a07 RD ROM FROG 1 1111 1 11111111 __entry(w... Power...
-05547 000402 O0ff  ED ROM FROG 1 1111 1 11111111
-05546 000404 efc) FD  ROM PROG 1 1111 1 11111111
-05545 000406 ORC.E #H'80,CCR 0480 RD ROM PROG 1 1111 1 11111111 sEt ...
-05544 000408 ISR @__INI... Ses00 RBD ROM PROG 1 1111 1 11111111 _INIT...
-05543 00040a 1l0e FD RON PROG 1 1111 1 11111111
-05542 00110e Mov.u RZ,[@-ER7 gdfz EBD ROM PROG 1 1111 1 11111111 __INL...
-05541 ffefbo 0000 WE  R... DATA 1 1111 1 11111111
-05540 ffefbe 040c WR R... DATA 1 1111 1 11111111
-05539 001110 STM. L (ER4-E... 0120 ED ROM FROG 1 1111 1 11111111
-05538 ffefba 5770 UWR R... DATA 1 1111 1 11111111
-05537 001112 6df4 FD ROM PROG 1 1111 1 11111111
-05536 001114 nov. L #H'000... 7a0d RD ROM PROG 1 1111 1 11111111
-05535 ffefbé 5770 UWR R... DATA 1 1111 1 11111111 j
Figure5.68 [Trace] Window
Thiswindow displays the following trace information items:
[PTR]: Cycle number in the trace buffer. When the most recent record is record 0, earlier

record numbers go backwards (-1, -2, ...). If adelay count has been set, the cycle
number where the trace stop condition has been satisfied is record 0. For the cycle
(during delay) executed until the trace has stopped, earlier record numbers go forward
(+1, +2, ...) the most recent record.

[Address]: Address (6-digit hexadecimal)

[Instruction]: Disassembled code of the executed instruction

[Datal: Data bus value, displayed as 2-digit or 4-digit hexadecimal

[RIW]: Whether access was read (RD) or write (WR)

[Ared]: Memory area being accessed; ROM, RAM, 8- or 16-hit I/O, 8- or 16-bit EXT

(external), or DTC RAM (not available when atime stamp is acquired)
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[Status]:

[Clock]:

[Probes]:

[NMI]:
[IRQ7-0]:

[Timestamp]:

[Source]:
[Label]:

[Timestamp-Difference]:

Bus status during this cycle; DTC operation, PROG (prefetch), Data (CPU data access
cycle), Refresh (refresh cycle), or DMAC (DMAC cycle) (not available when atime
stamp is acquired)

Number of clock cyclesin buscycle as 1 to 8. To indicate more clock cycles, “OVR”
is displayed (not available when atime stamp is acquired).

A 4-bit binary number showing the four probe pinsin the order of Probe 4, Probe 3,
Probe 2, and Probe 1 from the left (not available when atime stamp is acquired).

Status of the NMI input (not available when atime stamp is acquired)
Status of eight IRQ inputs (not available when atime stamp is acquired)

Time stamp of the record. Time stamps start from zero each time the user program is
executed. The timer resolution depends on the time stamp clock rate selected in the
trace acquisition (only available when atime stamp is acquired).

Source program
Label information that corresponds to the address (if defined)

Displays the difference from the timestamp val ue shown on the previous line (only
available when atime stamp is acquired).

Note: Itemsother than [PTR], [Address], [Instruction], [Data], [R/W], [Ared], [Status], [Probes], [Timestamp],
[Source], [Label], and [Timestamp-Difference] vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

It is possible to hide any column not necessary in the [Trace] window. Selecting a column you want to hide from
the popup menu displayed by clicking the right-hand mouse button on the header column hides that column. To
display the hidden column, select the column from the said popup menu again.
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5.16.3 Specifying Trace Acquisition Conditions

The capacity of the trace buffer islimited. When the buffer becomes full, the oldest trace information is
overwritten. Setting the trace acquisition condition allows acquisition of useful trace information and effective
use of the trace buffer. The condition is enabled by the event point to control starting, stopping, and ending the
trace acquisition. For event points, refer to section 5.15, Using the Event Points.

The trace acquisition condition is set in the [Trace Acquisition] dialog box that is displayed by selecting
[Acquisition...] from the popup menu.

The[Trace Acquisition] dialog box has the following pages:

Table5.4 [TraceAcquisition] Dialog Box Pages

Page Item

[General] Sets trace acquisition conditions.

[Stop] Sets trace stop conditions (without a delay).

[Delayed Stop] Sets trace stop conditions (with a delay).

[1] to [4] Sets the range trace (only available when the free trace mode is
disabled).

(1) [General] page

Sets trace acquisition conditions.

Trace Acquisition llil
Gereal |Stop | DelyedStop|1 |2 |3 |4 |
~Supprezzs——————— Time Stamp
[ Free Trace

Clack:

[T DIC Cycles IDisabIed vl

™ Eefiesh Cycles

— Trace Events
Event:
[101R) H7092 address =]
sdd. | Ede. Sequence... Delete | Delan |

Ok, I Cancel |

Figure5.69 [Trace Acquisition] Dialog Box ([General] Page)
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[Suppress): Acquires no trace information of the specified types of bus cycle.
[Time Stamp]:  Setsacondition for time stamping.

[Clock]: Select either from Disabled, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, 16 us, or
100 us as the resolution for time stamping. A time stamp has a 32-bit counter. At 125
ns the maximum time that can be measured is about 9 minutes, and at 100 psthe
maximum time is about 5 days.

When the counter overflows, its content will be cleared to continue counting. No time
stamp information will be acquired when Disabled is selected.

[Free Trace]: Checking this box enables the free trace mode.

When the free trace mode is enabled: Starts acquiring the dataimmediately after program
execution has been started. Only the trace hat condition is available. Therangetraceis
unavailable and four range-trace pages (1 to 4) become disabled.

When the free trace mode is disabled: Setsthe start and halt conditions of trace acquisition.

[Trace Events]: Setsevent points to be used as trace acquisition conditions.

[Event]: Liststhe event points to be used as trace acquisition conditions.
[Add...]: Adds a new event point.
[Edit...]: Changes the setting for the selected event point.

[Sequence...]:  Configures an event sequence for the event point being used as a trace acquisition
condition. To set up the sequence, an event must have been set.

[Delete]: Deletes the selected event point.

[Del All]: Deletes all event points.

Notes: 1. Thebus cyclesthat can be specified by the [Suppress] option vary according to the emulator in use.
For details, refer to section 5.15.4, Signals to Indicate Bus States and Areas.
2. Thetrace buffer is used for the time stamp information and some of the trace information. Therefore,
when the time stamp is acquired, it isimpossible to acquire the trace information other than PTR,
Address, Instruction, Data, R/W, Source, Label, Timestamp, and Timestamp-Difference.
3. If an event that is used for the range trace or trace stop function is deleted, that function becomes
disabled.
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(2) [Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed
simultaneoudly.

Trace Acquisition 1'5'

General Stop | Delayed Stnpl 1 I 2 I 3 I 4 I

— Stop Without Delay

— Events
[™ | undefined or unavailable

[™ | undefined or unavailable
[™ | undefined or unavailable
[™ | undefined or unavailable
[T undefined or unavailable
[T undefined or unavailable
[T 7EJH'107E address
[T 8(E]H'1084 address
[T undefined or unavailable
¥ 10[R) H'1092 address
[T undefined or unavailable
r

undefined or unayailable

ak I Cancel |

Figure5.70 [Trace Acquisition] Dialog Box ([Stop] Page)

[Stop Without Delay]: Defines atrace stop condition.
[Enable]: Checking this box enables atrace stop.

[Events]: Lists the event points where trace acquisition conditions have been set. If the
box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
selected).
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(3) [Delayed Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed
simultaneoudly.

Trace Acquisition 1'5'

General I Stop  Delaped Stop |1 I 2 I 3 I 4 I

— Stop with Delay

Delay Count ID"I

—Ewvents
I~ 1 [EJH0 address
[~ 2 [E] H'Oaddress
[~ 2 [E] H'Oaddress
[~ 4 [E] H'Oaddress
[T 5(EJHD address
[T E[EJHT address

Z[EJHTOVE address
B EJHT 08 address
undefined or unayailable
undefined or unayailable
undefined or unayailable
undefined or unayailable

-
-
-
-
-
-

ak I Cancel |

Figure5.71 [Trace Acquisition] Dialog Box ([Delayed Stop] Page)

[Stop With Delay]: Defines atrace stop condition.

[Enable]: Checking this box enables atrace stop.

[Delay Count]: Setsthe delay count (in bus cycles, range 1 to 65535). This function allows
you to acquire anumber of trace records after any of the specified events
occur.

[Events]: Liststhe event points where trace acquisition conditions have been set. If the

box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
selected).
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(4) [1] to [4] pages

Setsarangetrace. Thisisonly available when the free trace mode is disabled. Select either of the following four
modes: [Disabled], [Point to Point], [Range], and [Event].

* Disabled

Disables arange trace.

Trace Acquisition llil
General I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditionz
¢ Dizabled = Paint to Paint {~ Range " Event

Figure5.72 Range Trace Setting (Disabled)
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¢ Point to Point

Acquires trace information in the specified range.

Trace Acquisition 1'5'

General I Stop I Delayed Stop 1 |2 I 3 I 4 I

— Conditions

" Dizabled & Point to Paint " Range " Event

Start Address

H'0000 O7E

Stop Address

|H "000071 084,

¥ Cuclic

Cancel
Figure5.73 Range Trace Setting (Point to Point)
[Start Address]:  Address where trace acquisition starts
[Stop Address]:  Address where trace acquisition stops
[Cyclic]: When this box is checked, the event sequencing is configured so that the events reset

themselves which causes tracing to be restarted when the start event occurs after the stop event.

Sets the event points that are required to start or stop trace acquisition when the start or end addressis accessed,
respectively.

Point to Point mode is an easy method to set up the event mode. The event to start or sop trace acquisition isan
access to asingle address.

Select [Cyclic] to continue acquisition of the trace information only in the specified address range.

Note:  Thisfunction automatically configures a sequence of event points. Note, however, that an unexpected
result may arise. In such cases, modify the setting of the sequence in the [Event Sequencing] dialog box.
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*« Range

Only acquires the trace information that satisfies the specified condition.

Trace Acquisition 2 x|
General I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Dizabled ™ Point to Paint & Range " Event

Range Event Edit... |

|7 [E) H'107E address =l

Cancel

Figure5.74 Range Trace Setting (Range)

[Range Event]:  Selectsan event point for which a trace acquisition condition has been set.
[Edit...]: Changes the setting for the selected event point.

Only acquires trace information from all bus cycles that matches the condition set in the selected event. This
mode uses one event channel or range channel.
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« Event

Acquires trace information, controlling the start and end of trace acquisition with the specified condition.

Trace Acquisition 2 x|
General I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Dizabled ™ Point to Paint " Range & Event

[

|7 [E) H'107E address

Start Event Edit... |
_ e |

Stop Ewent Edi...

|8 (E) H'1084 address =l

¥ Cuclic

Cancel

Figure5.75 Range Trace Setting (Event)

[Start Event]: Selects the event point for which the condition to start trace acquisition has been set.
[Stop Event]: Selects the event point for which the condition to stop trace acquisition has been set.
[Edit...]: Changes the setting for the selected event point.

[Cyclic]: When this box is checked, the event sequencing is configured so that the events reset
themselves which causes tracing to be restarted when the start event occurs after the stop event.

Starts and stops trace acquisition when the conditions for starting and ending are satisfied, respectively. Selecting
[Cyclic] dlows a continuous acquisition of trace information that can be acquired with the specified condition.
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5.16.4  Searching for a Trace Record

Use the [Trace Find] dialog box to search for atrace record. To open this dialog box, choose [Find...] from the
popup menu.

The[Trace Find] dialog box has the following options:

Table5.5 [TraceFind] Dialog Box Pages

Page Description

[General] Sets the range for searching.

[Address] Sets an address condition.

[Data] Sets a data condition.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Selects the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the status of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the status of eight probe input signals (not available when a time

stamp is acquired).

[Timestamp] Specify the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary
according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Clicking the [OK] button after setting conditions in those pages stores the settings and starts searching. Clicking
the [Cancel] button closes this dialog box without setting of conditions.

When atrace record that matches the search conditionsis found, the line for the trace record will be highlighted.
When no matching trace record is found, a message dialog box will appear.

Only the trace information that satisfies all the conditions set in above pages will be searched.

If afind operation is successful, selecting [Find Next] from the popup menu will move to the next found item.
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(1) [General] page
Set the range for searching.

Trace Find x|
Statug I Probes I IRQ7-0
General | Address I Data I R I Area
Trace search range
Ik i [ Upward search

fLl }

Start PTR : |-32767
EndPTR : ID

0K I Cancel | Apply |

Figure5.76 [Trace Find] Dialog Box ([General] Page)
[Trace search range]: Sets the range for searching.

[Not designation]: Searches for information that does not match the conditions set in other
pages when this box is checked.

[Upward search]: Searches upwards when this box is checked.
[Start PTR]: Entersa PTR value to start a search.
[End PTR]: Enters a PTR value to end a search.

Note:  Along with setting the range for searching, PTR values to start and end searching can be set in the [Start
PTR] and [End PTR] options, respectively.
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(2) [Address] page
Set an address condition.

Trace Find x|
Status | Praobes I |IRGT-0

General Address | Data I R I Area

Setting
’7£alue g IH'FFEFSD

0K I Cancel | Apply |

Figure5.77 [Trace Find] Dialog Box ([Address] Page)

[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.
[Vaue]: Enter the address value (not available when [Don’t care] has been checked).
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(3) [Data] page
Set a data condition.

Trace Find x|
Statug I Probes I IRQ7-0

General I Address Data | RAw I Area

Setting ‘
{Ealue : |H'IZIIZIIZIIZI

0K I Cancel | Apply |

Figure5.78 [Trace Find] Dialog Box ([Data] Page)

[Don't care]: Detects no data when this box is checked.
[Setting]: Detects the specified data.

[Vaue]: Enter the data va ue (not available when [Don’t care] has been checked).
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(4) [R/W] page
Select the type of access cycles.

Trace Find x|

Status I Praobes | |IRGT-0
General I Address I Data R Al | Area

™ Dot care

e et

Setting

String : IHD j

0K I Cancel | Apply |

Figure5.79 [Trace Find] Dialog Box ([R/W] Page)

[Don't care]: Detects no read/write condition when this box is checked.
[Setting]: Detects the specified read/write condition.
[String]: Select aread/write condition (not available when [Don't care] has been checked).
RD: Read cycle
WR: Write cycle

307
RENESAS




(5) [Ared] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

Trace Find x|
Status I Praobes I |IRG7-0 |
General I Address I Data I R Area
I~ Don't care
Setting
String : I ROk j

0K I Cancel | Apply |

Figure5.80 [Trace Find] Dialog Box ([Area] Page)

[Don't care]: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition.
[String]: Select an area condition (not available when [Don't care] has been checked).

Note: Available areas vary according to the emulator in use. For details, refer to section 5.15.4, Signalsto
Indicate Bus States and Aress.
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(6) [Status] page
Select the status of abus. The selection is not available when atime stamp is acquired.

Trace Find x|
General | Addrezs I Data I R I Area
Status | Probes I IRG7-0

I Dont care
Setting
String : IPHDG j

0K I Cancel | Apply |

Figure5.81 [Trace Find] Dialog Box ([Status] Page)

[Don't care: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition.
[String]: Select abus condition (not available when [Don't care] has been checked).

Note: Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Areas.
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(7) [Probes] page
Select the status of four probe signals. The selection is not available when atime stamp is acquired.

Trace Find x|
General I Addrezs | Data | R I Area
Stalus Probes | IRQ7-0

— Setting

Probed IDon't care"l Frobe3 IDon't care"l
Probez IDon't care "I Probel IDDn't care'l

0K I Cancel | Apply |

Figure5.82 [Trace Find] Dialog Box ([Probes] Page)
[Don't care]: Detects no probe signal condition when this box is checked.
[Setting]: Detects the specified probe signal condition.
[Probed] to [Probel]: Select probe conditions (not available when [Don’t care] has been checked).
Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signal islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filker x|
General I Addrezs I Data R | Area |
Status I Frobes IRQ7-0

— Setting

IRE7 IW IRQE Don't care ¥

IRO5  [Dontcaex]  iRO4  [Dontcaex]

pgs  [omewes] a2 [prvewe]

IRE1 IW IRQ0 IW
[ o ]

ok Cancel | Apply |

Figure5.83 [Trace Find] Dialog Box ([IRQ7-0] Page)

[Don't care]: Detects no IRQ input condition when thisbox is checked.

[Setting]: Detects the specif

[IRQ7] to [IRQO]:

ied IRQ input condition.

Select IRQ input conditions (not available when [Don't care] has been
checked).

Don't care: Detects no selected |RQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.

RENESAS
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(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

Trace Find ﬂ
Generall .-’-‘«ddressl Data I FAw  Timestamp |
p i H

0K I Cancel | Apply |

Figure5.84 [TraceFind] Dialog Box ([Timestamp] Page)

[Don't care]: Detects no time stamp value when this box is checked.
[Setting]: Detects the specified time stamp value. (Every field must be filled in.)
[Value]: Enter the time stamp value.

Theformat is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, hanosecond: ns

(Not available when [Don't care] has been checked.)

5.16.5 Clearingthe Trace|Information

Select [Clear] from the popup menu to empty the trace buffer that stores the trace information. If several [Trace]
windows are open, al [Trace] windows will be cleared as they all access the same buffer.

5.16.6  Savingthe TraceInformation in a File

Select [Save...] from the popup menu to open the [Save Ag] file dialog box, which allows the user to save the
information displayed in the [ Trace] window as atext file. A range can be specified based on the [PTR] number
(saving the complete buffer may take several minutes). Note that this file cannot be reloaded into the [Trace]
window.

Note: In filtering of trace information, the range to be saved cannot be selected. All the trace information
displayed in the [Trace] window after filtering will be saved. Select afiltering range on the [General]
page in the [Trace Filter] dialog box if you want to save the selected range. For details on the filtering
function, refer to section 5.16.12, Extracting Records from the Acquired Information.
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5.16.7 Viewing the[Source] Window
The [Source] window corresponding to the selected trace record can be displayed in the following two ways:

¢ Select atrace record and choose [View Source] from the popup menu.
« Double-click atrace record

The [Source] or [Disassembly] window opens and the selected line is marked with a cursor.

5.16.8 Trimming the Source
Choose [Trim Source] from the popup menu to remove the white space from the | eft side of the source.

When the white space is removed, a check mark is shown to the left of the [Trim Source] menu. To restore the
white space, choose [Trim Source] while the check mark is shown.

5.16.9 Acquiring a Snapshot of the Trace Information

A snapshot can be acquired when you need to check the trace information during execution of the user program.
Thisisuseful for checking time stamping or probe input signals. To acquire a snapshot of trace information,
select [Snapshot] from the popup menu. Trace acquisition istemporarily stopped to display arecord of the latest
trace information, and then restarted. A snapshot of trace information is only acquired during execution of the
user program.

5.16.10 Temporarily Stopping Trace Acquisition

To temporarily stop trace acquisition during execution of the user program, select [Halt] from the popup menu.
This stops trace acquisition and updates the trace display. Use this method to check the trace information without
stopping execution of the user program.

5.16.11 Restarting Trace Acquisition

To restart trace acquisition being stopped during execution of the user program, select [Restart] from the popup
menu.
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5.16.12 Extracting Recordsfrom the Acquired | nfor mation

Use the filtering function to extract the records you need from the acquired trace information. The filtering
function allows the trace information acquired by hardware to befiltered by software. Unlike the settings made
in the [Trace Acquisition] dialog box for acquiring trace information by conditions, changing the settings for
filtering several timesto filter the acquired trace information allows easy extraction of necessary information,
which isuseful for analysis of data. The content of the trace buffer will not be changed even when the filtering
function is used. Acquiring useful information as much as possible by the [Trace Acquisition] settings improves
the efficiency in analysis of data because the capacity of the trace buffer islimited.

Use the filtering function in the [ Trace Filter] dialog box. To open the [Trace Filter] dialog box, select [Filter...]
from the popup menu.

The [Trace Filter] diaog box has the following pages:

Table5.6 [TraceFilter] Dialog Box Pages

Page Description

[General] Selects the range for filtering.

[Address] Sets address conditions.

[Data] Sets data conditions.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Sets the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the states of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the states of eight IRQ input signals (not available when a time

stamp is acquired).

[Timestamp] Specifies the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary
according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Set filtering conditions and then press the [OK] button. This starts filtering according to the conditions. Clicking
the [Cancel] button closes the [ Trace Filter] dialog box, which holds the settings at the time when the dialog box
was opened.

In filtering, only the trace information that satisfies one or more filtering conditions set in the above pages will
be displayed in the [Trace] window.

Filtering conditions can be changed several times to analyze data because the content of the trace buffer is not
changed by filtering.
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(1) [General] page
Set the range for filtering.

Trace Filker x|
Statug I Probes I IRQ7-0

General | tddess | Data | RAw | rea

r i [~ Enable Filter

[ Mot designation
Trace display range
Start PTR: I

End PTF :

ok I Cancel | Apply |

Figure5.85 [TraceFilter] Dialog Box ([General] Page)

[Don't care other pages]: Only selects the cycle number when this box is checked. Other options become

invalid.

[Enable Filter]: Enables the filter when this box is checked.

[No]: Filters information that does not match the conditions set in those pages when this
box is checked.

[Trace display range]: Sets the range for filtering.
[Start PTR]: Enters a PTR value to start filtering.
[End PTR]: Entersa PTR value to end filtering.

Note:  Along with setting the range for filtering, PTR vauesto start and end filtering can be set in the [Start
PTR] and [End PTR] options, respectively.
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(2) [Address] page
Set address conditions.

Trace Filker x|

Status | Praobes I |IRGT-0
General Address | Data I R I Area

[T Don't care
Setting
* Point [ Range

From: IH'

To: I

ok I Cancel | Apply |

Figure5.86 [TraceFilter] Dialog Box ([Address] Page)

[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.
[Point]: Specifies asingle address (not available when [Don't care] has been checked).
[Range]: Specifies an address range (not available when [Don't care] has been checked).
[From]: Enter asingle address or the start of the address range (not available when [Don't
care] has been checked).
[To]: Enter asingle address or the end of the address range (only available when [Range]
has been selected).

Note:  Along with setting the address range, the start and end of the address range can be set in the [From] and
[To] options, respectively.
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(3) [Data] page
Set a data condition.

Trace Filker x|
Statug I Probes I IRQ7-0

General I Address Data | RAw I Area

Setting
* Point [ Range

From: IH'

To: I

ok I Cancel | Apply |

Figure5.87 [TraceFilter] Dialog Box ([Data] Page)

[Don't care]: Detects no data when this box is checked.

[Setting]: Detects the specified data.
[Point]: Specifies single data (not available when [Don't care] has been checked).
[Range]: Specifies adata range (not available when [Don't care] has been checked).
[From]: Enter single data or the minimum vaue of the data range (not available when [Don’t

care] has been checked).

[To]: Enter the maximum value of the datarange (only available when [Range] has been
selected).

Note:  Along with setting the data range, the minimum and maximum values can be set in the [From] and [To]
options, respectively.
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(4) [R/W] page
Select the type of access cycles.

Trace Filker x|

Status I Praobes | |IRGT-0
General I Address I Data R Al | Area

— Setting

[IRD
I

ok I Cancel | Apply |

Figure5.88 [Trace Filter] Dialog Box ([R/W] Page)
[Don't care]: Detects no read/write condition when this box is checked.
[Setting]: Detects the specified read/write condition.

RD: Detects read cycles when this box is checked (not available when [Don't care] has
been checked).

WR:  Detectswrite cycles when this box is checked (not available when [Don't care] has
been checked).
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(5) [Ared] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

Trace Filker x|

Status I Praobes I |IRG7-0 |
General I Address I Data I R Area

i
— Setting
[CJROM -
IRaM
/016
/08
[JEXT-16
[JEXT-&
[R&M/DTC hd

ok I Cancel | Apply |

Figure5.89 [TraceFilter] Dialog Box ([Area] Page)
[Don't care]: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition (not available when [Don’t care] has been checked).

Note: Available area conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Areas.
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(6) [Status] page
Select the status of abus. The selection is not available when atime stamp is acquired.

Trace Filker x|
General | Addrezs I Data I R I Area
Status | Probes I IRE7-0
r E

— Setting
[ JPROG
[ DATA
[ |JREFRESH
[ |DMALC
DTC
[ JOTHER

ok I Cancel | Apply |

Figure5.90 [TraceFilter] Dialog Box ([Status] Page)
[Don't care]: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition (not available when [Don’t care] has been checked).

Note:  Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Areas.
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(7) [Probes] page
Select the status of four probe signals. The selection is not available when atime stamp is acquired.

Trace Filker x|
General I Addrezs | Data | R I Area
Stalus Probes | IRQ7-0

— Setting

Probed IDon't care"l Frobe3 IDon't care"l
Probez IDon't care "I Probel IDDn't care'l

ok I Cancel | Apply |

Figure5.91 [TraceFilter] Dialog Box ([Probes] Page)
[Don't care]: Detects no probe signal condition when this box is checked.
[Setting]: Detects the specified probe signal condition.
[Probed] to [Probel]: Select probe conditions (not available when [Don't care] has been checked).
Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signal islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filker x|
General I Addrezs I Data R | Area |
Status I Frobes IRQ7-0

— Setting

IRE7 IW IRQE Don't care ¥

IRO5  [Dontcaex]  iRO4  [Dontcaex]

pgs  [omewes] a2 [prvewe]

IRE1 IW IRQ0 IW
[ o ]

ok Cancel | Apply |

Figure5.92 [Trace Filter] Dialog Box ([|RQ7-0] Page)

[Don't care]: Detects no IRQ input condition when thisbox is checked.

[Setting]: Detects the specified IRQ input condition.

[IRQ7] to [IRQO]:

322

Select IRQ input conditions (not available when [Don't care] has been
checked).

Don't care: Detects no selected |RQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.
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(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

Trace Filker

0K I Cancel | Apply |

Figure5.93 [TraceFilter] Dialog Box ([Timestamp] Page)
[Don't care]: Detects no time stamp value when this box is checked.
[Setting]: Detects the specified time stamp value.
[Point]: Specifies asingle time stamp (not available when [Don't care] has been checked).
[Range]: Specifies atime stamp range (not available when [Don't care] has been checked).

[From]: Enter a single time stamp value or the minimum value of the time stamp range.
Theformat is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns
(Not available when [Don't care] has been checked.)

[To]: Enter the maximum value of the time stamp range.
The format is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, hanosecond: ns
(Only available when [Range] has been selected.)

Note:  Along with setting the time stamp range, the minimum and maximum time stamp values can be set in the
[From] and [To] options, respectively.
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5.16.13 Calculating the Differencein Time Stamping

Select [Timestamp Difference...] from the popup menu to calculate the time difference between the two points
selected by the result of tracing in acquisition of time stamp information.

Timestanp Difference 71 x|

—Select 2 line

First PTR : |'32?"E‘*r Second PTR . IU

[Timestamp difference information :

Timeztamp Difference

0000k 000min 000s O03ms 897us B75ns Get Difference
Clear |

« | 3] x|

Figure5.94 [Timestamp Difference] Dialog Box
[Select 2 ling]: Select trace records to calculate the time stamp difference.

[First PTRY]: Specifies the first pointer to measure the difference. The pointer of the line
selected on the Trace window is displayed by default.

[Second PTR]: Specifies the second pointer to measure the difference.

[Timestamp Difference]: Displays the results of calculation.

[Get Difference]: Calculates the difference between the specified two points and display itsresult in the
[Timestamp Difference] list.

[Clear]: Clears dll the resultsin the [Timestamp Difference] list.

[OK]: Closesthe dialog box. All the resultsin the [Timestamp Difference] list are cleared.
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5.16.14 Analyzing Statistical Information

Choose [Statistic] from the popup menu to open the [Statistic] dialog box and analyze statistical information
under the specified conditions.

21X
Set
Hew
Eezult |
Reszult : Ll
Condition | Amount | FTR
KN i
Figure5.95 [Statistic] Dialog Box
[Statistic Analysis]: Setting required for analysis of statistical information.
[Default]: Setsasingle input value or character string.
[Range]: Setsthe input value or character string as arange.
[Item]: Setstheitem for analysis.
[Start]: Setstheinput value or character string. To set arange, the start value must be
specified here.
[End]: Specify the end valueif arange has been set (only available when [Range] has been
selected).

[Set]: Adds a new condition to the current one.
[New]: Creates a new condition.
[Result]: Obtains the result of statistical information analysis.
[Clear]: Clears all conditions and results of statistical information analysis.
[Close]: Closes this dialog box. All the results displayed in the [Result] list will be cleared.
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Thisdialog box alowsthe user to anayze statistical information concerning the trace information. Set the target
of analysisin [Item] and the input value or character string by [Start] and [End]. Click the [Result] button after
setting a condition by pressing the [New] or [Add] button to analyze the statistical information and display its
result in the [Result] list.

Note: Inthisemulator, only [PTR] can be set as arange. Each of other items must be specified as a character
string. In analysis of statistical information, character strings are compared with those displayed in the
[Trace] window. Only those that completely match are counted. Note, however, that thistest is not case
sensitive. The number of blanks will not be cared either.

5.16.15 Extracting Function Callsfrom the Acquired Trace Information

To extract function calls from the acquired trace information, select [Function Call...] from the popup menu.
The [Function Call Display] dialog box will be displayed.

Furiction Call Display x|
Setting
Enable to display trace infarmation with function
call anlp 7
o : " Disable
ok | LCancel |

Figure5.96 [Function Call Display] Dialog Box

[Setting]: Selects whether or not to extract function calls.
[Enable]: Extracts function calls.
[Disable]: Does not extract function calls.

When [Enable] is selected, only the cycles that include function calls are extracted for display from the acquired
trace information. The content of the trace buffer is not changed by extraction of function calls. Using this
function for the result of the free trace or the trace information that includes function calls allows the user to
know the order of function calls.
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5.17  Viewingthe Function Call History

The [Stack Trace] window shows the function call history.

5.17.1 Opening the[Stack Trace] Window

To open the [Stack Trace] window, choose [View -> Code -> Stack Trace] or click the [Stack Trace] toolbar

button ().

Eind|Name Value

F func3 (short *) { O0x000000%94 )

2] param_ 3 000003 ffa { 0x00003£dE } {short*)
L local 3 D'3 { O0x00003fd4 } {unsigned long)
F funcZ (zhort *) { O0x=x00000072 3}

= param 2 0x00003ffa { O0x00003fed } (zhort*)
L local 2 D'Z { 0x00003fed } {unsigned long)
F funcl (short *) { 0x00000032e }

= param 1 0x00003ffa { O0x00003ff0 } ({(short*)
L local_1 D"l { 0x00003fex } (unsigned long)
F main() { 0x0000001Z 1}

L start D"103 §{ 0x00003ffa } {short)

Figure5.97 [Stack Trace] Window

The following items are displayed.

[Kind]: Indicates the type of the symbol.
F: Function
P: Function parameter
L: Local variable
[Name]: Indicates the symbol name.
[Value]: Indicates the value, address, and type of the symbol.

5.17.2  Viewing the Source Program

Select afunction and choose [Go to Source] from the popup menu to display, in the [Source] window, the source

program corresponding to the selected function.

RENESAS

327




5.17.3  Specifying the View

Choose [View Setting...] from the popup menu to open the [Stack Trace Setting] dialog box, which allows the
user to specify the [Stack Trace] window settings.

Mest level (1-643 IiE Eﬁ

—Dizplay symbal
[~ Parameter
[~ Local Wariable

—Diaplay Radix

{* Hexadecimal

" Decimal

© Qotal
" Binary

Cancel |

Figure5.98 [Stack Trace Setting] Dialog Box
[Nest level]: Specifies the level of function call nesting to be displayed in the [Stack Trace] window.
[Display symbol]:  Specifies the symbol types to be displayed in addition to functions.

[Display Radix]: Specifies the radix for displaysin the [Stack Trace] window.
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5.18 Displaying Memory Contentsasan I mage

The memory contents can be displayed as an image in the [Image View] window.

5181 Opening the[Image View] Window

Choose [View -> Graphic -> Image...] or click the [Image] toolbar button (@) to open the [Image Properties]
dialog box shown in figure 5.99.

Image Properties 2 x|

r— Colar Infarmation:
Tode:

Bit/Fivel ISbit[|ndE:-: Color, 'I
Sanmplitg: I‘Hﬁ4 'I

" BGR

" YChCr Format: Ichunky "I

r Buffer Infornation:

Data Address: IH ‘00000000

Ealette Address: IH'DDDDDDDD
width/Height Size[Fixel):
widh I—D Buffer Size:
ek [ HO000G000 Byt
Height; I 0

— Wiew |nformation:
—Wiew Mode:———  Fosition

% Full Size # Position: I 0
C Part Size " Pasition: I a

— Start Poszition: = idth/H efght SizelPivell:

& Top Wit | 0
" Bottom Height: I 0

ok I LCancel |

[
M

Figure5.99 [Image Properties] Dialog Box

The[Image Properties] dialog box is used to specify the display method of the [Image View] window.
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The following items are to be specified:

[Color Information]:

[Mode]:

[Bit/Pixd]:
[Sampling]:
[Format]:

[Buffer Information]:

[Data Address]:

[Palette Address]:

Specifies the color information of the image to be displayed.

Specifies the format.

[MONOCHROME]: Black and white.

[RGB]:
[BGR]:
[Y ChCr]:

R (red), G (green), and B (blue)
B (blue), G (green), and R (red)
Y (luminance), Cb (color difference for blue),
and Cr (color difference for red)

Specifies bits/pixel (valid when RGB or BGR is selected).

Specifies the format of sampling (valid when Y CbCr is selected).

Specifies chunky/planar (valid when Y CbCr is selected).

Specifies the areato store data, size, and the address of the palette.

Specifies the first address in memory of the areafor display asimage data (in

hexadecimal notation).

Specifies the first addressin memory of the color-palette data
(in hexadecimal notation; valid when “8Bit” has been selected for RGB or BGR).

[Width/Height Size]: Specifies the width and height of the image.

[View Information]:

[View Mode]:

[Start Position]:

[Position]:

330

[Width (Pixel)]:

[Height (Pixel)]:

[Buffer Size]:

Specifies the width of theimage (unlessa
prefix isincluded, values are treated as
decima numbers).

Specifies the height of the image (unless a
prefix isincluded, values are treated as
decima numbers).

Displays the size of the buffer required for
image display as obtained from the width and
height (in hexadecimal notation).

Specifies the location, size, and data start location of the part to be
displayed among the entire image.

Specifies whether display ison dl or part of the screen.

[Full Size]:
[Part Size]:

[Top]:

[Bottom]:

Theimage is displayed on the whole screen.
The imageis displayed on part of the screen.

Display of data starts at the upper-left
position.
Display of data starts at the lower-left
position.

Specifies the position on the screen from which image display isto start (vaid when

[Part Size] is selected).
[X Position]:

[Y Position]:

Specifies the X-coordinate of the start
position (unless a prefix isincluded, values
are treated as decimal numbers).

Specifies the Y -coordinate of the start
location (unless a prefix isincluded, values
are treated as decimal numbers).
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[Width/Height Size]: Specifies the height and width of an image to be displayed on part of the screen.
[Width (Pixel)]: Specifies the width of the display (unlessa
prefix isincluded, values are treated as
decimal numbers).
[Height (Pixel)]: Specifies the height of the display (unlessa
prefix isincluded, values are treated as
decimal numbers).

After the settings have been made in the [Image Properties] dialog box, clicking the [OK] button opensthe
[Image View] window.

Even &fter the [Image View] window is displayed, the display contents can be modified by opening thisdialog
box by choosing [Properties...] from the popup menu.

Figure’5.100 [Image View] Window

The memory content is displayed as an image.

5.18.2 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will alow the window contents to be automaticaly updated when
user program execution stops.
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5.18.3 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.184 Displaying the Pixel Information

Double-clicking within the window displays information on the pixel on which the mouse pointer islocated in
the [Pixel Information] dial og box.

Pixel Infarmation ﬂ ﬂ

Index Color

Color mode;

Pixel: Index Mo.135

Pozition

Buffer Size *Width: I Height: I

Image Size *Width: Height:

Figure5.101 [Pixe Information] Dialog Box
This dialog box displays pixel information on the cursor location.

[Color Mode]:  Displays the format of theimage.

[Pixe]: Displays color information on the pixel under the cursor (in decimal notation).
[Position]: Displaysthe cursor location as X and Y coordinates (in decimal notation).
[X]: X coordinate of the cursor.
[Y]: Y coordinate of the cursor.

[Buffer Size]:  Displaysthe buffer sizein decimal notation.
[Width]: Width of the buffer.
[Height]: Height of the buffer.

[Image Size]:  Displaysthe width and height of the display in decimal notation.
[Width]: Width of the display.
[Height]: Height of the display.
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5.19 Displaying Memory Contents as Waveforms

Memory contents can be displayed as waveformsin the [Waveform View] window.

5191 Opening the Waveform View Window

Choose [View -> Graphic -> Waveform...] or click the [Waveform] toolbar button ) to open the [Waveform
Properties] dialog box shown in figure 5.102.

eform Properties

Data Address:  [H'0000000D

Data Size: IBbit ﬂ Cancel |

Channel:
’7 % hono " Steren

Buffer Size:  [H'D0000000 |

Figure5.102 [Waveform Properties] Dialog Box
Specifies the waveform format. The following items can be specified.
[Data Address]: Specifies the start address of datain memory (displayed in hexadecimal).
[Data Size]: Selects 8Bit or 16Bit.
[Channdl]: Selects Mono or Stereo.
[Buffer Size]:  Specifies the buffer size of data (displayed in hexadecimal).

After the settings have been made in the [Waveform Properties] dialog box, clicking the [OK] button opensthe
[Waveform View] window.

Even after the [Waveform View] window is displayed, the display contents can be modified by opening this
dialog box by choosing [Properties...] from the popup menu.
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Figure5.103 [Waveform View] Window

Displays the memory contents as waveforms. The X axis shows the number of sampling dataand the Y axis
shows the sampling value.

5.19.2 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will allow the window contents to be automatically updated when
user program execution stops.

5.19.3 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.19.4  Zoom-In Display

Selecting [Zoom In] from the popup menu displays the waveforms with the horizontal axis enlarged.

5195 Zoom-Out Display

Selecting [Zoom Out] from the popup menu displays the waveforms with the horizontal axis reduced.

5196 Resetting the Zoom Display

Selecting [Reset Zoom)] from the popup menu displays the waveformsin its original size.

5.19.7  Setting the Zoom M agnification

In the [Zoom Magnification] submenu of the popup menu, the zoom magnification can be selected from 2, 4, or
8.

5.19.8  Setting the Horizontal Scale

In the [XScale] submenu of the popup menu, the size of the X axis can be selected from 128, 256, or 512 pixels.
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5.19.9 Non-Display of Cursor

Selecting [Clear Cursor] from the popup menu hides the cursor display.

5.19.10 Displaying the Sampling Information

Selecting [Sample Information...] from the popup menu displays the [Sample Information] dialog box.

Sample Information 2 x|

Data Size: I Bhit
Channel: I Maona
W, | H'00000310
Walue
" | H'23

Figure5.104 [Sample Information] Dialog Box

Displays the sampling information of the cursor location in the [Waveform View] window. The following
information is displayed.

[Data Size]: Displays 8bit or 16hit.
[Channdl]: Displays the data channel.

[Vaue]: [X] Displays the X axis of cursor location.

[Y] Displaysthe Y axisof cursor location (displays Y axesfor both the upper and
lower plots when Stereo is selected).
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5.20

Analyzing Performance

Use the performance analysis function to measure the rate of execution time. The performance analysis function
does not affect the realtime operation because it measures the rate of execution time in the specified range by
using the circuit for measurement of hardware performance included in the emulator.

Select either of the following five modes according to the purpose of measurement.

Table5.7

Mode

Available M easurement Modes

Description

Purpose

Time Of Specified Range
Measurement

Measures the execution time and
execution count in the specified
range.

Measurement of time taken for
processing of functions except for
that required for child functions
called from the functions.

Start Point To End Point
Measurement

Measures the execution time and
execution count between the
specified addresses.

Measurement of time taken for
processing of functions.

Start Range To End
Range Measurement

Measures the execution time
from a specified range to another
specified range.

Measurement of execution time
spent from calling of any of
sequential subroutines to calling of
any of another sequential
subroutines in a program that
includes subroutines in sequence,
such as an assembly program.

Access Count Of
Specified Range
Measurement

Measures the number of times a
specified range is accessed from
another specified range.

Measurement of the number of
times a global variable is accessed
from a specific function.

Called Count Of
Specified Range
Measurement

Measures the number of times a
specified range has called
another specified range.

Measurement of the number of
times a function is called from a
specific function.

Use eight performance channelsinstalled on the circuit for measurement of hardware performance in the
emulator for setting of conditions for measurement. Up to eight points can be set.

Note, however, that up to four points can be set in Start Range To End Range Measurement, Access Count Of
Specified Range Measurement, or Called Count Of Specified Range Measurement because two sequential points
are used for setting a condition in these modes.
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Table5.8 Mode Settingsfor Measur ement

Point
Page 1 2 3 4 5 6 7 8
Time Of Specified Range [e) le) o) o) o] (o] (o] (@]
Measurement
Start Point To End Point o) [e) o) o) o) (o] (o] (o]
Measurement
Start Range To End o) 0 [e) 0 (6] O (0] O
Range Measurement
Access Count Of [e) 0 e} 0 (e} ] (e} O
Specified Range
Measurement
Called Count Of o) 0 [e) 0 (0] O (0] O
Specified Range
Measurement

Note: O: Available
[ : Not available

Note:  Only one point isused in Time Of Specified Range Measurement and Start Point To End Point
Measurement, while two sequential points are used in Start Range To End Range M easurement, Access
Count Of Specified Range Measurement, and Called Count Of Specified Range Measurement. The
conditions that have been set will be canceled when switching these modes of different types.
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5.20.1

Opening the [Performance Analysis] Window

Choose [View -> Performance -> Performance Analysis] or click the [PA] toolbar button to open the

[Select Performance Analysis Type] dialog box.

erfarmance An

PBerformance Analyzis:

EBO00 Performance Analy

2%

LCancel

I

Figure5.105 [Select Performance Analysis Type] Window

Select [E6000 Performance Analysis] and then click the [OK] button to open the [Performance Analysis]

window.

«# Performance Ana ;[Elﬂ
Mo Newme | Condition | Rate | RUN-TIME MAX-MIN-TIME | count |
L PAl  Range H'0000L038 H'O0001108 9% OOk O0win 005 055ms 764us 160ns 1234
z PAZ  ProP H'00002068 H'O00020DA 255 OCR O0min 002 l47ms 682us 680ns OOR Ofmwin... 1234
3 PA3  RroR H'0000L038 H'O000LL08 655 OOh OOwin 00 36lns S560us d80ns 2468
4 + H'0000Z068 H' 00002135

5

6

7

8

Figure5.106 [Performance Analysis] Window

Thiswindow displays the rate of execution time in the area sel ected by the user during the last program runin

percentages, histogram, or numerical values.

It is possible to hide any column not necessary in the [Performance Analysis] window. Selecting a column you
want to hide from the popup menu displayed by clicking the right-hand mouse button on the header column
hides that column. To display the hidden column, select the column from the said popup menu again.
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5.20.2  Setting Conditionsfor Measurement

Conditions for measurement can be displayed and changed in the [Performance Analysis] window. Select a point
where a condition isto be set, and then select [Set...] from the popup menu to display the [Performance Analysis
Properties] dialog box.

Select either from the following five modes as the condition by the [Measurement Method] option:

Table5.9 Conditionsfor Measurement (Measurement Method)

[Measurement Method] Option

Time Of Specified Range Measurement

Start Point To End Point Measurement

Start Range To End Range Measurement

Access Count Of Specified Range Measurement

Called Count Of Specified Range Measurement

Set a condition for measurement according to the mode being selected. The parameters to be set depend on the
modes.

The [Performance Analysis] window has a support function to enter the address range of a function
automatically if the name of the function is entered to set an address range. Entering a function name in the
[Input Function Range] dial og box displayed by clicking the[...] button on the [Performance Analysis
Properties] dialog box automatically enters the address range of the function.

Input Function R.ange

21x
Function

Sample:: Cancel

Figure5.107 [Input Function Range] Window

Notes: 1. Entering the name of an overload function or aclass opensthe [Select Function] dialog box. Select a
function in this dialog box. For details on the dialog box, refer to section 5.13.3, Supporting
Duplicate Labels.

2. The addresses figured out are just for reference. In some cases, the end address of a function may be
different. Check the last instruction of the function in the [Disassembly] window to correct the value
set in [End Address] so that it will be the address of the last instruction (in general, the last instruction
of afunctionisaRTS instruction). A label name or an expression can be entered instead of an
address value in boxes where an address should be entered.
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(2) Time Of Specified Range Measurement

Fange Hame |F'.-’-‘«'I
Range

Start Address IH'EIEIDEIEIEIEIEI _I
End Addrezs IH'DDDDDDDD

— Common Settings of Performance(FPAl-3]

Addrezs Control Mode: PC Settings... |
Time Meazurement Unit; 160ns
Cancel |

Figure5.108 Time Of Specified Range Settings

[Range Name]: The name of the range to be measured

[Range]: The range for the Time Of Specified Range M easurement
[Start Address]: Address to start measurement
[End Address]: Address to end measurement

M easures the execution time and the execution count in the range between the start address and end address.
Starts measurement with a detected program prefetch in the range specified between the start and end addresses,
and then stops with a detected program prefetch out of the specified range. Measurement can be restarted with a
detected program prefetch in the specified range. The execution count isincremented every time the programiis
prefetched at the end address of the specified range. The execution time measured does not include the time
spent while being called from the specified range.
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(2) Start Point To End Point Measurement

Performance Analysis Pr 21|

kM eazurement Method PAT:

Start Point To End Point b

Prairt

Fange Hame |F'.-’-‘«'I

Start Address IH'EIEIDEIEIEIEIEI _I
End Addrezs IH'DDDDDDDD

Time Out : IDDh 00rnin 00z 000mz 000us 000ns

LCount

R

— Common Settings of Performance(FPAl-3]

Addrezs Control Mode: PC Settings... |

Time Meazurement Unit; 160ns

Cancel |

Figure5.109 Start Point To End Point Measurement Settings

[Range Name]:

[Point]:
[Start Address]:
[End Address]:

[Time Out]:

[Count]:

The name of the range to be measured

The range for the Start Point To End Point Measurement
Address to start measurement
Address to end measurement

The timeout value to finish measurement. When the minimum time for measurement
is 160 ns, 40 ns, or 20 ns, enter the value as follows.
Example: 1h 2min 3s 123ms 456us 789ns

If the CPU operating mode istarget, enter a hexadecimal number in 10 digits.
Example: 123456789A

A break occurs every time avalue measured in the specified range exceeds the
timeout value (not the total time). Thisisonly available for channel 1.

The count-up value used in measurement of the execution count. A break occurs
every time the execution count exceeds the count-up vaue. Thisisonly available for
channel 1.

M easures the execution time and the execution count in the range between start address and end address. Starts
measurement with a detected program prefetch at the start address, and then stops with a detected program
prefetch at the end address. The execution count isincremented every time the program is prefetched at the end
address of the specified range. The execution time measured includes the time spent while being called from the
specified range. When either from one to four pointsis selected, the maximum and minimum time in the
specified range can be measured.
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Notes: 1. When [Time Oult] is selected in the Start Point To End Point Measurement mode, the execution time
will not be measured correctly.
2. When [Time Out] and [Count] are selected, satisfaction of either of these options stops execution of
the user program (performance break).
3. Only channel 1 can be used for [Time Out] and [Count]. Use other channelsif you do not want to
select [Time Out] or [Count] in the Start Point To End Point M easurement mode.
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(3) Start Range To End Range Measurement

Perfarmance Anal roperties

Measurement Method PAT: Start Bange To End Fange Measurement

Fange Hame |F'.-’-‘«'I
Start Range End Range

Start Address IH'EIEIDEIEIEIEIEI _I Start Address IH'EIEIDEIEIEIEIEI _I
End Addrezs IH'DUUUUUUU End Address : IH'DDDDDDDD

— Common Settings of Performance(FPAl-3]

Time Meazurement Unit; 160ns

Addrezs Control Mode: PC Settings... |

Cancel |

Figure5.110 Start Range To End Range Measurement Settings

[Range Name]: The name of the range to be measured

[Start Range]: The start range for the Start Range To End Range M easurement
[Start Address]: Start address
[End Address]: End address

[End Range]: The end range for the Start Range To End Range M easurement
[Start Address]: Start address
[End Address]: End address

Starts measurement with a detected prefetch cycle in the specified start address range, and then stops with a

detected prefetch cycle in the specified end address range. The execution count is incremented every time the

program passes the end address range.
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(4) Access Count Of Specified Range Measurement

Petformance Analysis Properties

Messurement Methad PAT: unt OF Specified Range Measuement

Fange Hame |F'.&'I

Range Access Area Range

Start Addresz . |H 00000000 J Start Address H'00000000 J
End Addrezs H'000000o0 End Address : H'0000o0o0

Access Type
¥ Daon't Care

I r I r -

Common Settings of Performance(Pal-8)

Addrezs Contral Mode: Prefetch Seftings. ..

Time Meazurement Unit; 160ns

Cancel

Figure5.111 Access Count Of Specified Range M easurement Settings

[Range Name]: The name of the range to be measured
[Range]: The range for the Access Count Of Specified Range Measurement
[Start Address]: Start address
[End Address]: End address
[Access Area Rangel: The access range for the Access Count Of Specified Range Measurement
[Start Address]: Start address
[End Address]: End address
[Access Type]: The bus cycle on the access range to be measured

Measures the number of times the range specified as the access range is accessed from the range specified by the

start and end addresses. The execution count in the range is measured with Time Of Specified Range
Measurement mode.

Note: Available bus cycle conditions vary according to the emulator in use. For details, refer to section 5.15.4,

Signals to Indicate Bus States and Areas.
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(5) Called Count Of Specified Range M easurement

Fange Hame |F'.-’-‘«'I
Range Call Fange

Start Address IH'EIEIDEIEIEIEIEI _I Start Address IH'EIEIDEIEIEIEIEI _I
End Addrezs IH'DUUUUUUU End Address : IH'DDDDDDDD

— Common Settings of Performance(FPAl-3]

Addrezs Control Mode: PC Settings... |
Time Meazurement Unit; 160ns
Cancel |

Figure5.112 Called Count Of Specified Range M easurement Settings

[Range Name]: The name of the range to be measured
[Range]: The range for the Called Count Of Specified Range M easurement
[Start Address]: Start address
[End Address]: End address
[Call Range]: The range for the Called Count Of Specified Range Measurement. Asthe call range,
specify the start and end addresses of the selected subroutine.
[Start Address]: Start address
[End Address]: End address

Measures the number of times the range specified as the call rangeis called from the range specified by the start
and end addresses. The execution time in the specified range can be measured with Time Of Specified Range
Measurement mode. Asthe call range, specify the start and end addresses of the selected subroutine.
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5.20.3  Selecting the Address Detection M ode and Resolution

In measurement of hardware performance, there are two types of address detection modes. prefetch address
detection mode and PC address detection mode. Select the appropriate address detection mode according to the
measurement mode in use. The resolution can also be selected here.

To select an address detection mode and resolution, click the [Settings...] button on the [Performance Analysis
Properties] diaog box. The [Common Settings of Performance(PA1-8)] diaog box will be displayed.

Carrmon Settings of Performance(Pa1-8)

Address Control Mode Frefetch

Time Measurement Linit 160ns ﬂ Cancel |

Figure5.113 [Common Settings of Performance(PA1-8)] Dialog Box
[Address Control Mode]: Select the method to detect addresses for the rate of execution time.

PC: PC address detection mode
Prefetch: Prefetch address detection mode

[Time Measurement Unit]: Select the timer resolution to be used for measurement from 160ns, 40ns,
20ns, or Target. The timer for execution time measurement has a 40-bit
counter. At 20 ns the maximum time that can be measured is about six hours,
and at 160 ps the maximum timeis about two days. When the counter
overflows, “Timer Overflow” is displayed as the result of measurement.
When Target is selected, the counter isincremented by an input clock. The
result of measurement is displayed as 10 digitsin hexadecimal.

Select the prefetch address detection mode in Access Count Of Specified Range Measurement, and PC address
detection mode in other measurement modes. Otherwise, the result of the measurement will be incorrect.

5.20.4  Starting Performance Data Acquisition

Executing the user program clears the result of previous measurement and automatically starts measuring the rate
of execution time according to the conditions that have been set. Stopping the user program displays the result of
measurement in the [Performance Analysis] window.

5.20.5 Deleting a Measurement Condition

Select [Reset] from the popup menu with a measurement condition selected to del ete the condition.

5.20.6 Deleting All Measurement Conditions

Choose [Reset All] from the popup menu to delete al the conditions that have been set.
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Section 6 Tutorial

6.1 Introduction
The following describes the main functions of the emulator by using atutorial program.

The tutorial program is based on the C++ program that sorts ten random data items in ascending or descending
order. Thetutorial program performs the following actions:

« Themai n function repeatedly callsthet ut ori al function to repeat sorting.

e« Thetutorial function generatesrandom datato be sorted and callsthesort andt ut ori al functions
in order.

¢ Thesort function entersthe array where the random data generated by thet ut or i al function are stored,
and sorts them in ascending order.

« Thechange function then sorts the array, which was sorted in ascending order by thesor t function, in
descending order.

Thefilet ut ori al . cpp contains source code for the tutorial program. Thefile Tut ori al . abs isa
compiled load module in the Dwarf2 format.

Notes. 1. After recompilation, the addresses may differ from those given in this section.

2. Thissection describes general usage examples for the emulator. For the specifications of particular
products, refer to section 8, Software Specifications Specific to This Product, or the online help.

3. Theoperation address of Tut ori al . abs attached to each product differs according to products.
Replace the address used in this section with the relevant address in each product after checking that
it is placed on the corresponding line of the source program.

4. Inthistutorial, the H8S/2633 E6000 emulator is taken as an example. File paths or the appearance of
figures differs according to products.
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6.2 Runningthe HEW
Open aworkspace by following the procedure listed in section 4.2.3, Selecting an Existing Workspace.

Select the following directory:
HEW installation destination directory\Tool s\Renesas\DebugComp\Pl atform\E6000\2633\Tutorial

Note: Thefile path differs depending on the product. Refer to section 8.2.1, Environment for Execution of the
Tutorial Program.

Then select the file indicated below.

Open Wor o] ﬂ il
Look in: Ia Tutorial j - IC_QF -

Debug_HE5_z237 _ES000_Emulator _CP
Source

File: name: |Tutnrial.hws Open I
Files of type: IWorkspaces [ bwwz] ﬂ Cancel |
e

Figure6.1 [Open Workspace] Dialog Box

Opening this workspace automatically connects the emulator.
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6.3 Downloading the Tutorial Program

6.3.1 Downloading the Tutorial Program
Download the object program to be debugged.

¢ Select [Download modul€e] from the popupmenu opened by clicking the right-hand mouse button on
[Tutorial.abs] of [Download modules].

E@ Tutarial
=-[F Tutorial
B3 C source file
----- E dbsct.c
L[] shike
Ea C++ gource file
| [= E rezetpra.cpp
..... &) sart.cpp
] E= E tutorial. cpp
Ea Download modules

E‘E Dependencie: Download module
..... S| shik.h Cownload module (debug data only)
zorth Wnlzad module
E] stacksctb

Configure Yiew, .,

IT Allow Docking
Hide
| I |

Figure6.2 Downloading the Tutorial Program
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6.3.2 Displaying the Sour ce Program
The HEW allows the user to debug a user program at the source level.

« Double-click [Tutorial.cpp] under [C++ source file].

- _ _ _
EI@ Tutorial T[n:nld mainf{void)
E---l@ Tutorial 0=00001036 while (134
223 T source file 0=x00001034 tutorial():
. }
b
0=00001038 void tutorial{wvoid)
O=00001044 {
long a[10];
orial.cpp iirtlgi:-l :
{3 Download modules ClaSSfSamplB *p_sam:
Tutorial abs
=23 Dependencies 0=00001046 p_sans Sample:
: shik.h 0z0000104e for(.lfﬂ: 1<10,: i++ 3 f
e L
stackscth 0=00001052 ) 3= -3
0=0000105c ) ali] = 7;
0=00001070 p san—=orti{al;
0=0000107a p_=san—>rchangeia);
Oz00001082 p_san—>=0=a[0]:
0=0000108a p_san—>=1=a[l]:
0=z00001096 p_zan—rs2=al[2]
O=000010a2 D _=am—r=3=al3]
0=000010ae p zan—r=d=a[4]
0=000010ba p =amn—>=5=a[f5]
0=000010c6 p =an—r=6=alE]
O=000010d2 p =amn—>=7=a[7];
0=000010de p =amn—>=8=a[8];
0=000010=a o =samn—>=9=a[9]:;
O=000010£6 p_san;
0=000010f= T

Figure 6.3 [Source] Window (Displaying the Sour ce Program)

¢ Select afont and size that are legible if necessary. For details, refer to section 4, Using the Editor in the HEW
part.

Initially the [Source] window shows the start of the user program, but the user can use the scroll bar to scroll
through the user program and look at the other statements.
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6.4 Setting a PC Breakpoint

A PC breakpoint is a simple debugging function.

The [Source] window provides avery simple way of setting a PC breakpoint at any point in a program. For

example, to set a PC breakpoint at thesor t function call:

« Select by double-clicking the [Editor] column on the line containing the sor t function call.

jhd JP |

El@ Tutarial

Emﬁ§ Tutorial
=23 C zource file
..... g dbsctc
(3 bk
C++ zource file
(2] resetpig.cpp
g z0it.cpp
S

Download modules
Tutorial. abs
Dependencies

e [2] shikh

o [E] zorth

Lo [F] stackscth

0x00001038
0x00001044

0x00001046
0x0000104=
0x0000105%0
0x00001058
0x0000105a

0=0000105c

0=x00001070
0=0000107a

0x00001082
0=x0000108a
0=x00001096
0=x000010a2
0=z000010a=
0=z000010ba
0=z000010ck
0=z00001042
0=z000010d=
0z000010ea
0=z000010f6
0=z000010fc

woid tutoriali{void)
i
long al[l10]:
long 3
int 1i:
claz=s Sanple *p_=am:

p_=an= Sanple:
forig i=0; 1<10; i++ J{
j = rand():
1f(3 < 0)f
1 = -1
}

afi] = 3.

p_=sam—r=ortia);
p_=sam->:change(a):

p_=an—r=0=a[0]
p_=an—-r=1=a[l]
p_=an—-r=2=al]
p_=am—->=3=a[3];
p_=an—-:=sd=al4]:
p_=an—-r=5=a[5]
p_=an—-r=b=alb]
p_=an—->=7=al7]
p_=an—r=8=a[f]
p_=amn—:=9=a[9]
p_=am;

I

Figure6.4 [Source] Window (Setting a PC Breakpoint)

The symbol « will appear on the line containing the sor t function. This shows that a PC breakpoint has

been set.
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6.5 Setting Registers
Set avalue of the program counter before executing the program.

¢ Select [Registers] from the [CPU] submenu of the [View] menu. The [Register] window is displayed.

! er i m
Register Name I Register Value |
ER0 H'00000000
ER1 H'00000000
ERZ H'00000000
ER3 H'00000000
[EF.4 H'00000000
ERS H'00000000
ERG H'00000000
ER7 H'000000L0
PC H'000400
CCE H'E0 I0------
[EXE H'07 === 111

Figure6.5 [Register] Window

« To change the value of the program counter (PC), double-click the value areain the [Register] window with
the mouse. The following dialog box is then displayed, and the value can be changed. Set the program
counter to H’00000400 in thistutorial program, and click the [OK] button.

Regisker - [PC] 2x|
Walue:
IH'DDD-JDD
Set b Cahicel |
IWhoIe Reqizter j

Figure 6.6 [Register] Dialog Box (PC)
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6.6 Executing the Program

Execute the program as described in the following:

« To execute the program, select [Go] from the [Debug] menu, or click the [Go] button on the toolbar.

Figure 6.7 [Go] Button

While the program is executing, the current address bus value and the operating state of the MCU are displayed

on the status bar.

The program will be executed up to the breakpoint that has been inserted, and an arrow will appear on the
[Editor] column in the [Source] window to show the position that the program has halted, with the message

[ Break = PCBr eak] in the status bar.

Note:  When the source file is displayed after a break, a path of the source file may be inquired. The location of

the source fileisas follows:

HEW install ation destination directory\Tool s\Renesas\DebugComp\Platform

\E6000\2633\Tutorial\source

Thefile path differs according to products. If necessary, replace \2633 with another name.

0=000010358
O0=00001044

0=00001046
0=0000104=
0=00001050
0=00001058
0=0000105a

0=0000105c

0=00001070 =
0=0000107&a

0=00001082
0x0000108a
0=00001096
0x000010a2
0=z000010a=
0x000010ba
0=000010c6
O0x000010d42
0=000010de
0x000010ea
0=000010f6
0x000010fc 1

wold tutorial (woid)

long a[10];

long 3j:

int 1:

clazs Sample *p _sam;

p_=amn= Samnple;
for{ 1=0; 1<10; i++ 9
j = rand{):
1f(3 < 039
1 = -1
ali] = J:

p_san—r=zort{a):
p_samn—:rchange(a):

p_samn—:=0=a[0]
p_=am—:=l=a[1l]
p_san—r:=2=al2]
p_=am—:=z3=a[3]
p_san—:=d=a[4]:
p_san—>=5=a[8]:
p_samn—r=h=a[6];
p_=am—:=7=al[7]
p_samn—:=8=a[d]
p_=am—:=z9=a[9]
p_=am;

Figure 6.8 [Source] Window (Break Status)
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The user can see the cause of the break that occurred last time in the [Status] window.

Select [Status] from the [CPU] submenu of the [View] menu. After the [Status] window is displayed, open
the [Platform] sheet, and check the St at us of Cause of | ast break.

— (O x|
Item I Status I
Connected To: H2S5 /2237 ES000 Ewulator CPU Z000 (Emulator PCI Card Driwver!
CPTT H8E/2237

Mode 7

Clock source Main: 10MHz, Sub:3zkHz

P status EBreak

Cause of last break PC Break

Event Time Count 00k 00min 00= 000ms 000us 000n=

Parn Time Count 00k 00min 00= 000ms 9Z%us &Zins

4 I :I\ Memary ), Platform f Events f

Figure6.9 [Status] Window

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.7 Reviewing Breakpoints
The user can see dl the breakpoints set in the program in the [Event] window.

«  Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed. Select
the [Breakpoint] sheet.

-lolx
Type State | Condition I Action I

Program Enahle PC=H'O0001070(Tutorial.cpp/44) Ereak

| [>T Breakpoint £ Event } Trigoer f

Figure6.10 [Event] Window

The popup menu, opened by clicking the [Event] window with the right-hand mouse button, allows the user
to set or change breakpoints, define new breakpoints, and delete, enable, or disable breakpoints.
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6.8 Referringto Symbols
The[Label] window can be used to display the information on symbolsin modules.

Select [Label] from the [Symbol] submenu of the [View] menu. The [Label] window is displayed so that the user
can refer to the addresses of symbolsin modules.

=
EFP IAddress IName I -

H'ooooo4o00 PowerON_Reset ()

H'oooolooo _sbrk

H'00001034 _main

H'00001038 tutoriali)

H'00001104 _abort

H'oooolloc _ INITECT

H'000011Ez loopl

H'000011EC loope

H'OO0O0011zE next_loopZ

H'O000113z next_loopl —

H'00001144 loop3

H'000011&5% loopd

H'O0001158 next_loopd

H'OO0O00115C next_loop3

H'O00011&68 operator newi{unsigned long)

H'000011BE _ CALL_TINIT

H'000011E0 _ CALL_END

H'OOO011E4 operator delete{woid *)

H'0O00011EE _rand

H'00001ZE6 _srand

H'00001z23Z2 $DIVLES

H'O0o001z3C not_negx

H'O0001z44 not_negt

H'0000124E not_negs LI

Figure6.11 [Labe] Window
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6.9 Viewing Memory

When the label name is specified, the user can view the memory contents that the label has been registered in the
[Memory] window. For example, to view the memory contents corresponding to _mai n in byte size:

¢ Select [Memory ...] from the [CPU] submenu of the [View] menu to enter _nmai n in the [Start address] edit
box and +# f inthe [End address] edit box, respectively, and to select Byt e in the [Format] combo box.

Begin:

I_main

I

LCancel
End:

|+ff

Format:

[ Byte [x1) =l
Diizplay Yalue Az

IANSI character j

Butes Count For One Line:
[ 15 Byte =l

Figure6.12 [Format] Dialog Box

¢ Click the[OK] button. The [Memory] window showing the selected area of memory is displayed.

0x00001034 55 oz 40 FC o1 oo el F3 oL z0 el Fa 73 37 oo Z8
0x00001044 OF F3 1a a0 EE oa 0 o0 aF 13 132 44 EE ao 11 F0
0x00001054 17 F0 aF 23 4c oz 17 BS 17 Fd4 aF co 10 70 o0&  EO
0x000010&84 01 oa &3 23 1)) 54 73 24 oa o4 4D E0 aF BE oF ol
0x00001074 OF E0 EE an 20 &8 aF Dl aF E0 EE [al) 20 D& o1 oa
0x00001034 63 L0 o1 an &3 E0 a1 o0 &F 50 an 04 o1 ao &F E0
000001094 00 04 o1 oo EF En oo os oL oo &F E0 on os o1 on
000001044 EF En oo oc o1 oo &F E0 oo ac 01 oo &F Eo oo in
0x000010E4 01 oo &F E0 oo in o1 oo &F 50 oo 14 o1 oo EF E0
0x000010C4 00 14 oL oo &F 50 oo 1z oL oo &F E0 oo 1z 01 oo
0x00001004 &F 50 oo ic o1 oo &F E0 oo ic 01 oo &F so oo z0
0x000010E4 01 oo &F E0 oo z0 o1 oo &F 55 oo 24 o1 oo EF ES ...
0x000010F4 00 24 aF E0 EE oa 11 Eg 73 17 an 28 o1 z0 el 76 Baa® (. .mww

0x00001104 01 oo &l 73 54 70 54 70 54 70 &l FZ 01 z0 el F4 - usTpTpTpm. . .
000001114 74 oo oo ao 15 D4 Th oL oo oo 15 nC Fi oo 40 10 Hocaoa Hocooooo o.
0x00001124 01 oo &l 04 oL oo &l 23 40 oz & Di 1F D4 45 F& .om...m. @ 1.. E.

Figure6.13 [Memory] Window
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6.10 Watching Variables

Asthe user steps through a program, it is possible to watch that the values of variables used in the user program
are changed. For example, set awatch on the long-type array a declared at the beginning of the program, by
using the following procedure:

¢ Click theleft of displayed array a in the [Source] window to position the cursor.

¢ Select [Instant Watch...] with the right-hand mouse button.

The following dialog box will be displayed.

Instank Wakch i' ﬂ
F- a { Ox00fef80 } (long[10]) Close I
Add

Figure6.14 [Instant Watch] Dialog Box

¢ Click the[Add] button to add a variabl e to the [Watch] window.

[4TF T Watch1 £ Watch2 Ji Watch3 J Watchd J

Figure6.15 [Watch] Window (Displaying the Array)
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The user can aso add a variable to the [Watch] window by specifying its name.

¢ Click the [Watch] window with the right-hand mouse button and select [Add Watch...] from the popup menu.

The following dialog box will be displayed.

Add \Wakch

Yariable or expression;

i LCancel

=
Ix

Figure6.16 [Add Watch] Dialog Box

« Input variablei to[Variable or expression] edit box and click the [OK] button.

The [Watch] window will now also show the int-type variablei .

- \akch -3l =l
Mame Yalues Type |
BB a { 0xD0Ffefa0 } (lang[10]]
i H'000= { R4} [ink]

A » [ watch1 £ \Watch2 A Watch3 b Watchd f

Figure6.17 [Watch] Window (Displaying the Variable)
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The user can click mark ‘+' at the left side of array a in the [Watch] window to watch al the elements.

AW akeh

=10l |

[
1l
[2
[
[4]
13
[E]
[7]
8]
£l

{ 0wO0ffefB0 }

H'000041 26 { Dw00F =30
H'0000167e { 0x00fefS4
H'00002781 { 0x00f=fS8
H'0000446b { 0x00f=fSc
H'0000794b { 0x00fef30
H'00001 5 { 00034
H'000059e2 { x00f =93
H'00001 cfb { Dx00ffef3c
H'00003f54 { 0x00ffefal
H'00000FE { Dx00ffefad }
H'000a { R4 }

[lang(10])
[larg]
[lang)
[larng]
[larg]
[lang)
[lang]
[larg]
[lang)
[lang]
[larg]
[int]

|4k ] watch1 £ WatchZ f Watcha } Walchd f

360

RENESAS

Figure6.18 [Watch] Window (Displaying Array Elements)




6.11 Displaying Local Variables

The user can display loca variablesin a function using the [Locals| window. For example, we will examine the
local variablesinthet ut ori al function, which declaresfour local variables: a,j ,i ,and p_sam

¢ Select [Locals] from the [Symbol] submenu of the [View] menu. The [Locals] window is displayed.
The[Locals] window shows the local variablesin the function currently pointed to by the program counter,

aong with their values. Note, however, that the [Locals] window isinitially empty because loca variables are
yet to be declared.

] H'O0ifef20 { ERE } flong]

e H'000a { R4 } fint)
----- p_sarm 0=00fb0dS { ERE } [=lass Sample”)

Figure6.19 [Locals] Window

e Click mark ‘+' at the left side of array a in the [Locals] window to display the elements.
« Refer to the elements of array a before and after the execution of the sor t function, and confirm that
random data is sorted in descending order.
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6.12 Stepping Through a Program
The HEW provides arange of step menu commands that alow efficient program debugging.

Table6.1 Step Option

Menu

Command Description

Step In Executes each statement, including statements within functions.

Step Over Executes a function call in a single step.

Step Out Steps out of a function, and stops at the statement following the statement in the
program that called the function.

Step... Steps the specified times repeatedly at a specified rate.

6.12.1 Executing the [Step In] Command
The [Step In] command steps into the called function and stops at the first statement of the called function.

« To step throughthesort function, select [Step In] from the [Debug] menu, or click the [Step In] button in
the toolbar.

)

Figure6.20 [Step In] Button
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O=z00002000
0x00002006
O=z0000201c
0x00002026
O=0000202c
0x00002032
O=00002038
0x0000203e
O=00002044
0x0000204=a
O=00002050
0x00002056
O=00002060

O=00002068
Ox00002070

0x00002072
0=00002076
0x00002078
O=0000207c
0x00002080
O=00002084

0=000020=a4
O=000020=a8

O=z000020=0
0=z000020cc

Sanple: Samnple()
{

=0=0;
=1=0;
=2=0;
=3=0;
=4=0;
=5=0;
=6=0;
=7=0;
=8=0;
=9=0;
1

o vold Sample: sortlong *3)
{

long t;
int 1. 1. k. gap:

gap = 5;
while{ gap » 0 ){
for({ k=0; k<gap; k++)q
for{ i=k+gap. 1<10; i=i+gap {

for{j=i-gap: jr=k: j=j-gapi{

if{alil»ali+gapli{
t = af3].
alil = ali+gapl:
ali+gap] = t:

=l=s
breal;

h
ks
gap = gap-Z;
h

The highlighted line moves to the first statement of the sor t function in the [Source] window.

Figure6.21 [Source] Window (Step In)
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6.12.2 Executing the [Step Out] Command

The[Step Out] command steps out of the called function and stops at the next statement of the calling statement

inthe mai n function.

e Tostepout of thesort function, select [Step Out] from the [Debug] menu, or click the [Step Out] button in

the toolbar.

Figure6.22 [Step Out] Button

oh

Fle Edit bYew Project Options

- [t cpp]
id  Deb

ug Memory Tools Window Help

~loix
x|

S I - == R — Y

e “J@ 9 85 % [Dchug_£6000_HE5_2297 ] |[Gessoneennn HEs_2237 =] | A % | [ (B HJ@, & dka HJEQ MM E R T ‘

ks A7 |

BRez+4 DRy 828 |8eE|n=|o |FLaannEon.
x|

0=0000104% o_san= Sanple:
B3 Tutorial ] 0=0000104e for{ i=0; i<10; i++ )}{ zl
=1 Tutarial 0=00001050 j = rand():
B3 Csource fle 0=0000105% if(j < 03
dhsct e 0=0000105a jo= -
shik.c _
E1-E3 Cor source file 0=0000105e T EV L
-[H resetpigepp 0=00001070 ) b_san-rsort{a);
0200001072 3 [_san->change{a);
0200001082 p_san-»s0=a[0];
& 0=0000108a p_sam—»sl=a[1];
Tutorial.abs 0200001096 D san-»s2=af[2]:
=13 Dependencies 0200001042 D san->s3=a[3];
020000102 D san-»>sd=a[4]:
__ Sb':"x 0=000010ba D san—»s5-a[5]
0=000010ck o_san—>s6=a[6]:
so
stackseth 0x00001042 _sam—>s7=a[7]:
0=000010d= D_san—>s8=a[8]
0=000010=a o_san-3>s9=a[9]
0=000010£6 D_san:
0=000010£c } o
4 »
T @ er. [HETe. | <INa o ltoridlepp |23 sotepp |
2 Nams [ Walue [ Type
T { DxD0ifefE0 fonglT00)
H'ODDOORS { 0x00ffefa0 } flong)
HOD01 5ib { Du0fferB4 } flong)
HO000167e { Ox00Fef8 } long)
HODO cib { d0fterBe } flong)
HOD002781 { Cx00Fef30 } long)
HODO3654 { D:010fera4 } flong)
HOD004106 { Cu0NFef3R } flong)
HOD00446b { Ox00fFef3c } long)
HOD0053e2 { Ox00ffefal } flong)
HO000734b { Ox00efad } long)
(i

HOD0a { R4}

[A[X T watch £ Walcha } Waich3 }, Waichd /-

Break = Stepping Completed

7 s [ m

The data of variable a displayed in the [Watch] window is sorted in ascending order.
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Figure6.23 [HEW] Window (Step Out)
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6.12.3 Executing the [Step Over] Command
The[Step Over] executes afunction call as a single step and stops at the next statement of the main program.

« To step through all statementsin the change function at asingle step, select [Step Over] from the [Debug]
menu, or click the [Step Over] button in the toolbar.

Figure6.24 [Step Over] Button

=Bl x|

«7+ Ble Edit Wiew Project Options Buld Debug Memory Tools window Help =181 x|
DERE|E[me|0ro|am R —
o ”J@ 8 B o |[Debua F5000 85 _2237 7] | [SessionEen0n_ Hes_2237 =] | 74 4 | (B H@‘ &8 & k@ HJEQ B ERT 4 ‘
BRe+s D Ray @8 een|ma||s|futEnneeo.||r EE
————————————"|x]

|&

0=00001046 T_sam Sanple.
G Tutorial 0=0000104= For( i=0: i<10; i++ ) ZI
B IE Tutorial 0=00001050 j = rand():
26 ¢C 0200001058 i < )]
0200001055 3= o5
5 sbike E
020000105 B ga
E1-E3 Cor source fle = © } alil = 3:
reselpig.cpp 000001070 ™ D_sam->sort{a);
=iy 0200001075 p_sam->change(a);
op
0200001062 & p_san—>sl=a[0]:
-3 Download modules 0=0000108a T san->=l=a[1]:
-[1] Tutorisl abs 0=00001096 p_sam->=2=a[2];
143 Dependencies 000001022 D_sam->s3=a[3];
I3 sbik h 000001 0as D_san—>sd=a[4]’
o "h 0=000010ba b san—>=5=a[5]
€l 0=000010ch D_sam—>sh=al[6].
-5 stackseth 0=000010d2 p_sam->=7=a[7];
0=000010de p_sam—>s8=a[8]’
0=000010ea p_sam—>=9=a[3]’
0=000010£6 D_samn:
0=000010fc } <
Ll Ll_l
" e [ETe. | . oy [ sotopp |

[ alue [ Tuee
TOAef | Toral 1)
a1 HO000794b { 0A00ifefed } flong)
11 HO00059e2 { 0A00KFefed | fleng)
21 HODDD44Bh { 0xD0Nfef35 } flora)
13l 0004126 { 0400Fefec | flong)
a1 HODDD3f54 { D000 } flora)
i} HO0002751 { 0u0Difefd4 } flong)
6l 0007 cfb { D00fel98 } fleng)
7l HODDD1 E7e { 04D0Nfef3c } flora)
8l HO000T51b { D00ffetaD } flong)
81 HODDOOAE { 0wD0fstad } flora)
HO00a {R4} find
0]\ Watch1 /TaIchZ j Wwatera f, aiehs

Break = Stepping Completad [Read-write  [45/69 1 s [ Moz

Figure6.25 [HEW] Window (Step Over)

365
RENESAS




6.13 Forced Breaking of Program Executions
The HEW can force a break in the execution of a program.
¢ Cancd all the breaks.

« To execute the remaining sections of thet ut ori al function, select [Go] from the [Debug] menu or the
[Go] button on the toolbar.

El

Figure6.26 [Go] Button

« The program goesinto an endlessloop. To force abreak in execution, select [Halt] from the [Debug] menu
or the [Stop] button on the toolbar.

Figure6.27 [Stop] Button

6.14 Resettingthe MCU

Resetting the MCU initializes the internal 1/0 registers and makes the program counter jump to the address set in
the reset vector.

To reset the MCU, select [Reset CPU] from the [Debug] menu or the [Reset CPU] button on the toolbar.

Bij

Figure6.28 [Reset CPU] Button

To execute the program from the reset vector, select [Reset Go] from the [Debug] menu or the [Reset Go] button
on the toolbar.

Figure6.29 [Reset Go] Button

Note: Thistutorial program is executable from the reset vector.
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6.15 Break Function

The emulator’s break functions are of two types. PC breaks and breaks at event points. PC breakpoints and
event points are set in the HEW' s [Event] window.

An overview and setting of the break function are described below.

6.15.1 PC Break Function
The emulator can set up to 256 PC breakpoints.

e Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.
e Select the [Breakpoint] sheet.

_{oix
Tyne drtate | Condition I Action I

| 4] =T Breakpoint /£ Event ) Trigger J

Figure6.30 [Event] Window (Before Setting a PC Breakpoint)

¢ Click the [Event] window with the right-hand mouse button and select [Add...] from the popup menu.
¢ The [Breakpoint/Event Properties] diaog box is displayed.
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BrealpoinkfEvent Properties

General

— Type
& PC Break

" Event

21X

Address
€ Dorft Care % Addiezss ) Fange

fddress Lo [H00001082
Address Hi'  [H00000000

[ Outside Fange

— Data Compare [Nirection——;j
™ Compare ™ Wse Mask ' Bead
Walue [

- IH L € Wwite
& Bute. € Wword
hask IH'D = Either

x|

Cancel

Figure6.31 [Breakpoint/Event Properties| Dialog Box

¢ Check the [PC Break] radio button in the [Type] group box.

¢ Usethe[Source] window to refer to the address on the line that has ‘p_sam->s0=a[0];’ within the
tutorial functionand enter this addressin the [Address Lo] edit box of the [Address] group box. In this

example, enter H 00001082.

Note: Thisdialog box differs according to the product. For the items of each product, refer to section 8,

Software Specifications Specific to This Product, or the online help.

¢ Click the [OK] button.

The PC breakpoint that has been set is displayed in the [Event] window.

Twpe State Condition

Program Enable

PC=H'00001052 (Tutorial. cpp/47)

[ 4]+ ] Breakpoint £ Event }, Trigger /

Figure6.32 [Event] Window (PC Breakpoint Setting)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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¢ Close the [Event] window.

« To stop the tutorial program at the breakpoint, select [Reset Go] from the [Debug] menu.

The program runs until it stops at the breakpoint that has been set.

0=00001038
Ox00001044

0x00001046
0=0000104=
0x00001050
O0=00001058
000001052

0x0000105c

0x00001070
0=000010%=

O=z00001082
0=z0000108a
0=z00001096
0=z00001052
0=z000010as
0=z000010ba
0=z000010ckE
0=z00001042
0=z000010de
0=z000010=a
0=z000010f6
0=z000010fc

wold tutorial{void)

1

¥

long a[107]:

long 3@

int 1

claz=z Sanple *p _=am;

D_=am= Sample;
for{ i=0; 1<10; i++ ){
j = randi):
103 < 03
1 = -1
ali] = 1.

p =am—r=ortia);
p_=zan—:>change(a):

p_=zan—>=0=a[0]:
p =am—r=l1=a[l]:
p_=an—=2=al2]:
p =am—r=3=al[3];
p_=zan—>=d=a[4d]:
p =am—r=5=a[5];
p_=an—>=b6=al[6]:
p =am—r=7=al[7].
p_=an—>=8=a[8]:
p =am—r=9=a[9];
p_=amn;

Figure 6.33 [Source] Window at Execution Stop (PC Break)

The [Status] window displays the following contents:

A Skatus

=101 x|

Ttem IStatus I

Connected To:

Mode 7
Clock source
Lun status Ereak

Event Time Count
Lun Time Count

Main: 10MH=,

Cause of last break PC Ereak
O0h O0min 00s 000ms O000us O000ns
O0h O0min 00s 00lms 0%Zus S00ns

H22,72227 E6000 Emulator CPU 2000 (Emulator PCI Card Driwver)
CPUT H35/ 2237

Sub:3zkH=

AT Memaory ) Platform f Events /

Figure6.34 Displayed Contents of the [Status] Window (PC Break)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.15.2 Breaking Execution at Event Points

Setting up of an event point on event channel 1 (Chl) such that a break is triggered when the event point’s
conditions have been satisfied five timesis explained as an example of the use of event points.

¢ Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.

¢ The breakpoint that has been previoudly set must be deleted. Click the [Breakpoints] window with the right-
hand mouse button and select [Delete All] from the popup menu to delete all the breakpoints that have been
set.

¢ Click the [Event] tab.

Up to 12 event points (eight event channels and four range channel's) can be set up as independent conditions. In
this example, we are setting the condition for event channel 1.

- Event =] e

Cha [(R) Enpty
ChlO (R} Enpty
Chll iR} Enpty
Chlz (R} Enpty

4[> Breaknoint }, Event £ Trigoer f

Figure6.35 [Event] Window (Event Channel 1 [Ch1])

¢ Select thelinefor Chlin the [Event] window. Double-click on thisline that is highlighted.

« The [Breakpoint/Event Properties] dialog box is displayed.

* Make the following settingsin the boxes on the [General] page:
Select the [Event] radio button in the [Type] group box.
Select the [Address] radio button in the [Address] group box. Then use the [Source] window to refer to the
address on the line that has ‘g[i]=j;" withinthet ut ori al function and enter this address in the [Address
Lo] edit box. In this example, enter H 0000105c.

« Enter D' 5 asthe number of times the event condition isto be satisfied in the [Required number of event
occurrences] edit box on the [Action] page.
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EBreakpointfEvent Properties 2=

General | Bus / &vea | Signals | Action |

— Type Address
" PC Break " Don'tCare ™ Addess © Range

Address Lo [
& Evert & . |H'00001 05C

Address Hi - |H'00000000

[T Dutside Fange

—Data Compare Direction——
[ Compare [T WUse tdash " Bead
Walue [
- IHD  Wiite
= Bpte € Word
e IH'D {* Either

QK. I Cancel |

Figure6.36 [General] Page ([Breakpoint/Event Properties] Dialog Box)

¢ Click the [OK] button. The [Event] window is displayed, as shown below.

ol x]
Type State Condition I Action |
Chl (E) Enable Address=H'0000105C (Tutorial.cpps/42) address count D'5 Ereak

Chz (E) Empty

Ch3 (E) Eupty

Chd (E) Eupty

Chi (E) Empty

Che (E) Eupty

Ch7? (E) Eupty

Chi (E) Empty

Cha (R) Eupty

ChlOiR) Enpty

ChlliR) Eupty

ChlZiR) Eupty

[ »T' Breakpoint » Event £ Trigger £

Figure6.37 [Event] Window (Setting Completed)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Select [Reset Go] from the [Debug] menu to stop the tutorial program at breakpoints.

The program runs then stops at the condition specified under Ch1.
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Qx00001038 wvolid tutorial{void)
i

0x00001044

0=00001046 p_=amn= Sample:;
0x0000104e for{ i=0; 1<10; i++ }{
0=00001050 7 = rand{):
O0x00001058 if{j < 03
0=0000105&a i o= -3:
b

0=0000105c | 4 o> ali] = 7:

b
0=00001070 p_sam—r=ort(a):
0=x0000107a p_samn—>change{a);
0=z00001082 p_san—:=0=a[0];
0=0000108a p_=samn—r=l=a[l]:;
0x00001096 p_=am—:z2=al[2]
0=000010a2 p_samn—:=3=al3]
0=000010ae p_san—>=z=d=ald];
0=000010ba p_=sam—:r=5=a[5]:
0x000010ck p_=am—:zb=al[k];
0=00001042 p_san—:=7=al[7]
0x000010de p_=am—:=8=a[8]
0=000010ea p_samn—:=9=a[9]
0x000010fe E_=am;
0=000010f= ¥

long a[l10]:;

long 3:

int 1i:

clas=s Samnple *p_sam;

Figure 6.38 [Source] Window at Execution Stop

The [Status] window displays the following contents.

Ttem IStatus

=0l x|

Connected To:
CPTT

Mode

Clock source
Dun status

Event Time Count
Dun Time Count

H22/2237 E&E000 Emulator CPU 2000 (Emulator PCI Card Driver)

HES/ 2237

7

Main: 10MH=, Sub:3fkHz
Break

Cause of last break Complex Ewvent System

00k O0min O00s O00Oms O0COus O000ns
00k O0min O0s O00Oms 738us 750ns

4] Memary }, Platform # Events f

Figure6.39 Displayed Contents of the [Status] Window

Refer to the [Watch] window for the value of variablei . The valueis 4, indicating that the break occurred after
the condition had been satisfied five times.

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Remove the event point. Clicking the right-hand mouse button on the [Event] window displays a popup menu.
Select [Remove All] from this menu to remove all event points.
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6.16 Trace Functions

The trace functions of the emulator use the realtime trace buffer, which is able to store the information on up to
32,768 bus cycles. The content of this buffer, which is constantly updated during execution, is displayed in the
[Trace] window.

Select [Trace] from the [Code] submenu of the [View] menu to display the [Trace] window.

«# Generic Trace =101%]

PTR. | Address Instructwn‘ Data‘ R/W ‘ Araal dtatus ‘ Clock ‘ Pl:obesl HMI | IR07-0 | Timestamp | Source Label | Timestamp-Difference |

Figure6.40 [Trace] Window

When trace information is displayed in the [ Trace] window, clicking the right-hand mouse button on the [Trace]
window displays a popup menu. Select [Clear] from this menu to clear the trace information.

The following sections give an overview of the trace functions and methods for setting them.
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6.16.1 Displaying a Trace (when Time Stamping isnot Available)

The method used to specify an address as an event condition for the tracing of read/write cycles and display the
trace is described below.

(2) Clicking the right-hand mouse button on the [Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box.

Trace Acquisition ﬂﬂ

General |Sto|:- | Delayed Stopl

—Suppress—————— Time Starp
¥ Free Trace

Clock:

[~ DIC Cycles I Disabled - I

[ Refresh Cycles

— Trace Events

Ewent:

=

aod.. | Edi Sequence.. etz | [ ol |

Ok I Cancel

Figure6.41 [Trace Acquisition] Dialog Box
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(2) Register an address as an event condition for trace acquisition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box.

EBreakpaintfEvent Prop ] 2=

General | Bus / &vea | Signals | Action |

— Type Address
") PL Break: " Dgr'tCare © Addess ( Range
.............. . Addrezs Lo [

& Eveii . |H'00000000

Address Hi - |H'00000000

[T Dutside Fange

—Data Compare Direction——
[ Compare [T WUse tdash " Bead
Walue [
- IHD  Wiite
= Bpte € Word
e IH'D {* Either

QK. I Cancel

Figure6.42 [Breakpoint/Event Properties] Dialog Box

(3) Use the [Source] window to refer to the address on the line that has ‘ i]=j;’ withinthet ut ori al function
and enter this addressin the [Address L o] edit box of the [Address] group box on the [General] page of the
[Breakpoint/Event Properties] dialog box. In this example, enter H 0000105c. This address has thus been
set. Click the [OK] button to close the [Breakpoint/Event Properties] dialog box.

EBreakpaintfEvent Prop ] 2=

General | Bus / &vea | Signals | Action |

~ Type Address
") PL Break: " Dgr'tCare © Addess ( Range

fddress Lo [H'0000105C

{* Event )
Address Hi - |H'00000000
[T Dutside Fange
—Data Compare Direction——
[ Compare [T WUse tdash " Bead
Yalle IH'D

 Wiite

= Bpte € Word
Mask —HD

QK. I Cancel |

Figure 6.43 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(4) The event that has been set is now displayed in the [Event] combo box of the [ Trace Events] group box on
the [Generdl] page of the [Trace Acquisition] dialog box.

Trace AcqL 2=
General |Stl:||:| I Delayed Stnpl
—Suppress———— Time Stamp
¥ Eree Trace
[~ DMALC Cycles Clock:
I™ DIC Cycles [Disabled -]
[~ Refresh Cycles
— Trace Events
Ewent;
|3 (RIH105C address |
Edit... SequEnTE., Lelete | Dl Al |
ak | Cancel |

Figure6.44 [Trace Acquisition] Dialog Box (Adding an Event)
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(5) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages[1] to [4] to the [Trace Acquisition] dialog box.

Trace Acquisition ﬂil
General |Stop I Delayed Stopl 1 I 2 I 3 | 4 I

—Suppress———————— Time Stamp

[~ DMALC Cycles Clock:

[~ DICCycles IDisabIed -]

[ Befresh Cycles

— Trace Ewvent:
Exent:
|3 (R H105C address =]
Add.. | Ed. Sequence.. Delete | Delal |

Ok I Caticel |

Figure6.45 [Trace Acquisition] Dialog Box (Pages Added)
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(6) Select page [1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button.

Trace Acquisition ﬂil
General I Stop I Delayed Stop 1 |2 I 3 | 4 I

r— Conditions

" Disabled  Point to Paint

Fanas Event

Ok I Caticel |

Figure6.46 [Trace Acquisition] Dialog Box (Displaying Page[1])
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(7) Select the event you have registered from the [Range Event] combo box. The event is now enabled. Click the
[OK] button to complete the trace setting.

Trace Acquisition 2=
General I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Dizabled ™ Point to Paint ' Range " Event

Range Event Edit... |

9 [R] H'105C addr

ak I Cancel |

Figure6.47 [Trace Acquisition] Dialog Box (Setting Completed)

(8) Make the setting such that the break occurs after the instruction at the address on the line that has *&i]=j;’
withinthet ut ori al function (H 0000105C in this example) has been executed five times (for details on
this, refer to section 6.15.2, Breaking Execution at Event Points).

(9) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

=1glx]
PTR | Address | Instruction | Data| R/W | Area| Status | Clock | Probes| WMI | IRQ7-0 | Timestaup | Source | Label | Tinestaup-pifEerence |
00004 O010SS  EXTH.L 0 ER4 17f4 ED RGN FEOG 1 i1 11 ali] = 3:
00003 00L0Sc  EXTS.L  ER4 1764 ED RGN FROG L i1 111 ali] = 3:
0000z ADL0SS  EXTH.L  ER4 17f4 ED RGN FROG 1 i1 111 ali] = 3:
00001 0010Ss  EXTS.L  ER4 17f4 ED  RON PROG 1 i1 11111111 ali] = 3:
400000 DOL0Sc  EXTS.L  ER4 17E4 D RON  PROE L i1 111 ali] = 3:

Figure 6.48 [Trace] Window (Displaying the Result)

If you have trouble viewing a column, drag the header (vertical) bars below the title bar to adjust the width
of the column.

(10) Remove the event points that have been set and clear the trace information. Click the right-hand mouse
button on the [Event] window to display a popup menu. Select [Delete All] from this menu to remove all of
the event points that have been set. Click the right-hand mouse button on the [Trace] window to display a
further popup menu. Select [Clear] from this menu to clear the trace information.
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6.16.2 Displaying a Trace (when Time Stamping is Available)

The following procedure is for obtaining and displaying, with time stamps, trace information on cycles of
writing to memory locations in the specified address range.

(2) Clicking the right-hand mouse button on the [Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box (see figure 6.41, [Trace Acquisition] dialog
box).

(2) Register the address range for trace acquisition as an event condition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box (see figure
6.42, [Breakpoint/Event Properties] dialog box).

(3) Click the [Range] radio button in the [Address] group box on the [General] page of the [Breakpoint/Event
Properties] dialog box. Use the [Locals] window to refer to the address on the line where variable a, which is
defined withinthet ut ori al function, isallocated (H OOFFEF80 in this example) and enter this address
in the [Address Lo] edit box. Then enter an address, which is H’ 27 added to that entered in the [Address Lo]
edit box (H O0FFEFAY in thisexample), in the [Address Hi] edit box. This procedure sets the memory
range for variablea of thet ut ori al function.

(4) Click the [Write] radio button in the [Direction] group box to set awrite cycle for the specified range. This
completes the setting of a memory range. Click the [OK] button to close the [Breakpoint/Event Properties]
dialog box.

BreakpaintfEvent Properties 2=l

General | Bus / Area | Signals | Action |

~ Type Address
" PCBreak | | © DontCare © Addiess % Range

fddiess Lo [H'00FFEFS0

' Event )
Addiess Hi - [H'0OFFEFAT
[~ Outside Fange
—D'ata Compare Direction—
[~ Compare [ Uze tazk " Read
e IH'D

% Byte, € 4o
fask IH'D

ak. I Cahicel |

Figure6.49 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(5) The event that has been set in the [Event] combo box of the [ Trace Events] group box on the [General] page

of the [Trace Acquisition] dialog box is displayed.

Trace Acq

General | Stop | Delayed Stop |
— Suppress Time Starp
[~ DMALC Cycles
[~ DIC Cycles

[ Refresh Cycles

Clock:

IDisabIed 2 I

¥ Free Trace

21|

— Trace Events

Ewent:

I 9[R1HFFEF20 range to HFFEFAT write

Edi... Seguence,.,

Delete |

pelll |

=

ok |

Cancel |

Figure6.50 [Trace Acquisition] Dialog Box (Adding an Event)

(6) To enable time stamping, select 125ns from the [Clock] combo box of the [Time Stamp] group box.

Trace Acq

General | Stop | Delayed Stop |
— Suppress Time Starp
[~ DMALC Cycles
[~ DIC Cycles

[ Refresh Cycles

Clock:

¥ Free Trace

21|

— Trace Events

Ewent:

I 9[R1HFFEF20 range to HFFEFAT write

=

bdd.. | Ed. Sequence.. Dekte | Deladl |
k. I Cancel |

Figure6.51 [Trace Acquisition] Dialog Box (Time Stamping is Available)
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(7) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages [1] to [4] (see figure 6.45, [Trace Acquisition] dialog box).

(8) Select page[1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button (see figure 6.46, [Trace Acquisition] dialog box).

(9) Click the [Range Event] combo box to select the event you have registered. The event is now enabled. Click
the [OK] button to complete the trace setting.

2|

General I Stop I Delayed Stop 1 |2 I 3 I 4 I

— Conditionz

"~ Disabled = Paint to Paint {* Hange {~ Ewent

Range Event

[ o ]

Cancel |

Figure6.52 [Trace Acquisition] Dialog Box (Setting Completed)

(10) Make the setting such that the break occurs after the instruction at the address on the line that has ‘p_sam-
>g0=g[0];’ withinthet ut ori al function (H 00001082 in this example) (for details on this, refer to
section 6.15.1, PC Break Function).

(11) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

- S l=
PTR | Address | I..| Data| R/W | Area| 3...| clock | P... HmmI | IRO7-0 | Timestauwp | 5.1 1..| Timestewp-Difference |-
-DADRT £EefhD aonn R 000K 0N Tm A0S0l 7 441537 5rim DOm0 00N s s
00086 Efefsz alcs WR 0000K00CRINGD0S000na744us S00ns D000RODORINGD0S000Na000usL25ns
-DADRS Freffd aonn R 000K 00 Tm A0 50D 76 4157 Srim Dm0 Dm0 s T6ns
00084 Eferss 167 WR 0000K00IRINGN0S000na 76 5us000ns D000RODORINGD0S000Ra000usL25ns
-DADR3 Frefhn onn R 000K 0N Tm A0 S0l 7651537 5rim Dm0 Dm0 s T6ns
00082 Efefsa 2781 WR 0000K00IRINGD0S000na7E5us S00ns D000RODORINGD0S000Ra000usL25ns
-DADRL Frefic onn R 000K 0N Tm 000 S 0fm=5N S1st7 Sris Dm0 Dm0 s T6ns
00080 Efefse 2360 VR 0000K00IRINGD0S000na505uS000ns D000RODORINGD0S000Ra000usL25ns
00073 £EefsD aonn R A0A0KOATm A0S Dlm= 52 1S 37 5rim Dm0 Dm0 s T6ns
00075 Efe9z 794 VR 0000K00IRINGDN0S000na825us S00ns D000RODORINGD0S000Ra000usL25ns
00077 Frefsd aonn R A0A0KOATm AT 0lm=54ens67 5 Dm0 Dm0 s T6ns
00076 EEe9E 1580 R 0000K00IRINGD0S000na847us000ns D000RODORINGD0S000Ra000usL25ns
-DA075 Frefsn nonn R 000K 0N Tm A0 S Dlim= 56 737 5rim Dm0 Dm0 s T6ns
-00074 ffef9a 58eZ  WER 0000h000nin000s000ns867us500ns 0000h000Rin000s000ns000uslZ5ns
_nnn73 feerac nnnn_w 00Ok AN A=A aR TR S T o 4|

Figure6.53 [Trace] Window (Displaying the Result)

If you have trouble viewing a column, drag the header (vertical) bars below the title bar to adjust the width

of the column.
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(12) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse

button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
al the event points that have been set. Clicking the right-hand mouse button on the [ Trace] window
displays afurther popup menu. Select [Clear] from this menu to clear the trace information. To disable time
stamping, select Disabled in the [Clock] combo box of the [Time Stamp] group box on the [General] page
of the [Trace Acquisition] dialog box.

6.16.3 Statistics

The number of times the internal RAM has been written to can be included in the acquired trace information.

@

@

®

Make the setting such that a break occurs at the address on the line that has ‘p_sam->s0=g[0];" within the
tutorial function(H 00001082 inthisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays trace information.

Select [Statistic...] from the popup menu that is displayed when you click the right-hand mouse button on
the [Trace] window. A message box appears, indicating that the trace datais being loaded, and the
[Statistic] dialog box will be displayed.

Skatiskic

= |in
%

Eesult
[Elear,
Result :
Condition | Arnount | PTH
KN I

LClose

.

Figure6.54 [Statistic] Dialog Box
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(4) Select R/W in the [Item] combo box and enter WR in the [Start] edit box. After that, click the [New] button.
“R/W=WR" is now displayed in the [Condition] column of the [Result] list box.

— Statiztic Analysiz
* Default & Fange et
Item IHM j
Start : IWH
Beszult |
End :I
Clear |
Reszult :
Condition | Amount | FTR
R A=
KN I i
LCloze |

Figure6.55 [Statistic] Dialog Box (New Condition)
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(5) Then, select Areafrom the [Item] combo box and enter RAM in the [Start] edit box. After that, click the
[Add] button; the new condition is now added to the “R/W=WR" display in the [Condition] column of the
[Result] list box, so that it now shows*“R/W=WR & Ares=RAM”. This completes setting of the condition.

— Statiztic Analysiz

* Default & Fange

ltem : [area 4
Start |Hmv|

End |

Result

Condition | &mount__| FTR

RAw="wh & Area=RaM

KN I i
LCloze |

Figure6.56 [Statistic] Dialog Box (Condition Added)
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()

To dtart statistical analysis of the specified condition, press the [Result] button. The number of write
operations that satisfy the condition and the PTR values will be displayed.

— Statiztic Analysiz

& Default © Fange et

Item IArea j

Start : IH-&M

End | d
Clear |

Reszult :

Condition | Amount | FTR

RAw=w'R & Area=Rdhd 1114 09063, -09058, -0905;

KN I i
LCloze |

U]
®

386

Figure6.57 [Statistic] Dialog Box (Result of Analysis)

Click the[Close] button to close the [Statistic] dialog box.

Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Event] window displays a popup menu. Select [Delete All] from this menu to remove al the
event points that have been set. Clicking the right-hand mouse button on the [Trace] window displays a
further popup menu. Select [Clear] from this menu to clear the trace information.
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6.16.4 Function Calls
This mechanism is used to only collect trace information on the function calls.

(1) Makethe setting such that a break occurs at the address on the line that has ‘p_sam->s0=a[0];" within the
tutorial function(H 00001082 inthisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

(2) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the

[Trace] window then displays trace information.
(3) Select [Function Call...] from the popup menu displayed by clicking the right-hand mouse button on the
[Trace] window. The [Function Call Display] dialog box will be displayed.

Furiction Call Display x|
Setting
Enable to display trace infarmation with function
call anlp 7
" Enable

Figure 6.58 [Function Call Display] Dialog Box

(4) Click the[Enable] radio button and then the [OK] button. Only the information on function callsis now
displayed in the [Trace] window (the [Label] column’s right-side boundary has been moved to theleft in the
[Trace] window to show the function calls).

«# Generic Trace =10l
Label | prR | add...| mstruction | pata| R/W| Area| status | Clock | Probes | mmr | 1RQ7-0 |-
PomerON_Reset|) -09108 000400 MOV.L #H'00FFEFCO,ER7 7a07 RD ROM  PROG 1 1111 1 11111111
_main -03582 001034 BR Brutorial(j:8 5502 RD ROM PROG 1 1111 1 11111111
Tatoriali) -03578 001038 MOV.L ER3,B-ER7 0100 ED ROM  PROG 1 1111 1 11111111
Sample:: Sample) ~03558 002000 MOV.L ERZ,B-ER7 0100 ED ROM  PROG 1 1111 1 11111111
_shrk -03369 001000 STM.L (ER2-ER3),A-5F 0110 ED ROM PROG 1 1111 1 11111111
Sempler:sort(long *)  -Dl657 002068 STM.L (ERZ-ER3) ,@-SP 0110 ED ROM PROG 1 1111 1 11111111
Semple::change (long 7) -00459 002046 MOV.L ER3,0-ER7 0100 D ROM  PROG 1 1111 1 11111111
4 | 2

Figure6.59 [Trace] Window (Function Calls)

(5) Toreturnthedisplay inthe[Trace] window to its previous state, follow the procedure in (3) to display the
[Function Call Display] dialog box. Click the [Disable] button and then the [OK] button.

(6) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
al the event points that have been set. Clicking the right-hand mouse button on the [Trace] window displays
afurther popup menu. Select [Clear] from this menu to clear the trace information.
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6.17 Stack Trace Function
The emulator uses the information on the stack to display the function call history.

Notes. 1. Thisfunction can be used only when the load module that has the Dwarf2-type debugging
information isloaded. Such load module is supported in H8S, H8/300 C/C++ compiler V4.0 or later.
2. For details on the stack trace function, refer to the online help.

« Double-click the [Editor] columninthesort function and set a PC breakpoint.

0=z00002068 vold Sample:  =ortilong *a)
O=00002070 i
long t:
int 1. j. k. gap:
0=00002072 gap = 5:
0=00002076 while{ gap » 0 J{
0=00002078 for({ k=0; kigap. k++){
0=x0000207c for{ i=k+gap; 1<10; i=i+gap ){
0=z00002080 for{j=i—gap: j:=k; j=j—gap){
0=z00002084 [ ] if{aljlralj+gapl )i
t = alil:
0=000020=a4 al[i] = ali+gap]:
0=x000020a8 alj+gap] = t:
else
breal;
H
h
h
0=000020=0 gap = gap-2:
0=00002 02z T

Figure6.60 [Source] Window (PC Breakpoint Setting)

¢ Select [Reset Go] from the [Debug] menu.

« After the break in program execution, select [Stack Trace] from the [Code] submenu of the [View] menu to
open the [Stack Trace] window.

=10l x|

|Value |
F Samnple: ;zort(long *) { 0=x00002084 %
F tutorial() { 0=0000107a %
F maini ) { 0=00001036
F PowerCH_Reset () { O=x0000041e

Figure6.61 [Stack Trace] Window

Figure 6.61 shows that the position of the program counter is currently at the selected line of thesor t ()
function, and that thesor t () functioniscaledfromthet ut ori al () function.

To remove the PC breakpoint, double-click the [Editor] columninthesort function again.
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6.18 Performance Measur ement Function
Performance measurement by the emulator isin the following modes:

e Time Of Specified Range Measurement

e Start Point To End Point Measurement

e Start Range To End Range Measurement

e Access Count Of Specified Range Measurement
e Caled Count Of Specified Range M easurement

In thistutorial, we describe the Time Of Specified Range Measurement.

6.18.1 Time Of Specified Range M easur ement

(1) Select [Performance Analysis] from the [Performance] submenu of the [View] menu to display the [Select
Performance Analysis Type] dialog box.

Perfarmance Analysis: EB000 Performance Ana

LCancel

Figure6.62 [Select Performance Analysis Type] Dialog Box

(2) Select “E6000 Performance Analysis’ from the [Performance Analysis| combo box in the [Select
Performance Analysis Type] dialog box and click the [OK] button. The [Performance Analysis] window will
be displayed.

-« Performance Al -|O] x|
No Name | condirion | Rate RIN-TINE | mase-nrw-TIME | coune | 0-—-10---z0---
1
2
3
a
5
&
7
B
< | |

Figure 6.63 [Performance Analysis] Window
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(3) Select the line of the [Performance Analysis] window that has 1 in its[No] column and click the right-hand
mouse button to display a popup menu. Select [Set...] from this popup menu to display the [Performance
Analysis Properties] dialog box.

Performance Anal

Measurement Method PAT: Tirne OF

Fange Mame : IF'.M
Range

Start Address : IH'DDDDDDDD _I
End Address : IH'DDDDDDDD

— Commaon Settings of Perfarmance(PAT-8]

Address Control Mode; Prefetch Settings... |

Tirme Meazurement Unit: 160ns

Cahicel |

Figure 6.64 [Performance AnalysisProperties] Dialog Box

(4) Select Time Of Specified Range Measurement from the [Measurement Method PA1] combo box.
(5) The parameter settings are as follows.
. Enter “sort” in the [Range Name] edit box.
¢ Click the[...] button to the right of the [Start Address] edit box to display the [Input Function Range]
dialog box. Enter the function name “ Sample::sort (long *)” in the [Function] edit box of this dialog box
and then click the [OK] button. The corresponding addresses for the function “ Sample::sort (long *)”
will now be set in the [Start Address] and [End Address] edit boxes.

Input Function R.ange 2=

Function
|Samplezzortilong #) Cancel |

Figure6.65 [Input Function Range] Dialog Box

Note: The addresses figured out in the [Input Function Range] dialog box are just for reference. In some cases,
the end address of a function may be different. Check the last instruction of the function in the
[Disassembly] window to correct the value set in [End Address] so that it will be the address of the last
instruction (in general, the last instruction of afunction isa RTS instruction). A label name or an
expression can be entered instead of an address value in boxes where an address should be entered.
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(6) Click the [Settings...] button in the [Common Settings of Performance(PA1-8)] group box to display the
[Common Settings of Performance(PA1-8)] dialog box. Select [PC] from the [Address Control Mode] combo
box and then click the [OK] button. PC is now displayed in the [Address Control Mode] text field of the
[Common Setting of Performance(PA1-8)] dialog box.

Common Settings of PerformancelPa1-8) ll il

Address Control Maode FC -
Time Meazurement Unit I 160ns j Camee] |

Figure6.66 [Common Setting of Perfor mance(PA1-8)] Dialog Box

(7) Click the [OK] button to display the content that has been set for line 1 of the [No] column in the
[Performance Analysis] window. This completes the settings for a Time Of Specified Range Measurement.

13l x|
|pate | pum-TDE | max-mon-TEE | count | 0-—-10-—-20-——30--
1 sort Fange H'00002068 H'O000Z0D4 0% 00k O0min 00 0O0ms O00us 000ns 0

z

A 0 AW

| i
Figure 6.67 [Performance Analysis] Dialog Box (Setting Completed)

(8) Set an event point at the address on the line that has ‘p_sam->change(a);’ withinthet ut ori al function
(H 0000107 in thisexample) so that abreak occurs when the specified sor t function has been executed
three times (refer to section 6.15.2, Breaking Execution at Event Points).

(9) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Performance Analysis] window then displays the information shown below. The value shown in the [Count]
column is 3, which indicates that the sor t function has been executed three times and the execution time.

«# Performance Analysis =101l
No Name | Condition IRatE IRU'N—TIMI MAX-MIN-TIME | Count | 0---10---20---30---
1 sort Range H'0000Z088 H'00002Z0D4 18% O0h 00min O00s 000ms 352us 480ns 3 HESEEEEEH

2

&l

4

5

]

7

g

1 | i

Figure 6.68 [Performance Analysis| Dialog Box (Displaying the Result)

(10) Delete the setting for performance analysis and remove the event point. Click the right-hand mouse button
on the [Performance Analysis] window to display a popup menu. Select [Reset All] from this popup menu to
delete al of the settings. Clicking the right-hand mouse button on the [Event] window also displays a popup
menu. Select [Delete All] from this popup menu to remove all the event points that have been set.
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6.19 Monitor Function

The emulator allows monitoring of the content of specified addressesin memory during execution of the user
program. In this example, we monitor the content of the address range where variable a of thet ut ori al
function is stored.

(1) Select the [CPU] submenu from the [View] menu. Then selecting [Monitor Setting...] from the [Monitor]
submenu displays the [Monitor Setting] dialog box.

Moritor Setting 2 x|

Maonitor Setting |

MName: |monitor‘|
— Option:
Address: |H'DDDDDDDD
Size (byte]: |H'2D j
Access [Eormat): IBYTE [ASCI j

¥ Auto-Refresh at rate [ms] : ID'DDEDD

¥ Reading the Initial ¥/ alue

— Color
Chanae Indicator: I Change j
Foreground: [N |~ Background: [ ] |-|
v Mayfly
r D etail
IDETAIL WNOT SUPFORTED! Dretail |
— Histary

| [ |
QK I Cancel |

Figure6.69 [Monitor Setting] Dialog Box
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(2) Set theitemsin the [Monitor Setting] dialog box as follows:
e Enter monitorl in the [Name] edit box.
e Set the parametersin the [Options] group box as follows:
(8) Usethe[Locals] window to refer to the address on the line where variable a, which is defined within

thet ut ori al function, isalocated and enter this addressin the [Address] edit box. In this example,
enter H OOFFEF80.

(b) Enter H 50 in the [Size] edit box.
(c) Select BYTE (HEX) from the [Access| combo box.
(d) Check the [Auto-refresh at rate] check box and enter D' 00500.
(e) Check the [Reading the Initial Value] check box.
e Set the parametersin the [Color] group box as follows:
(a) Select Change from the [Change Indicator] combo box.
(b) Select red and white in the [Foreground] and [Background] combo boxes, respectively.
(c) Check the [Mayfly] check box.

Note:  Depending on the operating system in use, the foreground and background colors may not be selectable.

Monitor Setting 2=l

tonitor Setting |

Hame: |mnnitor1
r— Optiohs
Address: |H'EIEIFFEFSD
Size [bute): IH'ED j
Access [Format): IBYTE [HE=] j

¥ Auto-Refresh at rate [ms] : ID'DDEDD

[v Reading the Initial % alue

— Colar
Change Indicatar: I Change j
Foreground: _Ivl Background: |:||v|
v tdayfly
— Detai
lDETAIL MNOT SUPPORTED! [retail |
r— History

| i
ak. I Cahicel |

Figure6.70 [Monitor Setting] Dialog Box (Setting Completed)
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(3) Click the [OK] button to open the [Monitor] window.

«® monitar: monitor1 - HOOFFEFE0 ;lgl il
+D| +l| +2| +3| +4| +5| +6| +'?| +8| +9| 'Hl.l +B| +C| +D| +E| +F|
Ox0O0FFEF20 00 0o 7% 4B 00 00 55 Ez 00 00 44 &B 00 00 41 g
Ox0J0FFEF20 00 00 2*F &4 00 00 27 91 00 Qo 1 FB 00 00 16 <E
Ox00FFEFAD 00 0O 15 FE 00 00 OF F& 00 02 12 EZ& 00 00 oo0 Ao

0x0OFFEFEO 57 7?0 00 o0 00 01 &0 78 00 00 10 25 00 00 04 ILE
Ox0OOFFEFCO &4 18 eSA 12 64 18 A 18 oA 158 oA 158 ei 15 eh 13

Address

Figure6.71 [Monitor] Window

(4) Select [Reset Go] from the [Debug] menu. When the content of the address range changes with execution,
the updated values are red (i.e. the color that was selected in the [Foreground] and [Background] combo
boxes). Values will be displayed in black if they have not been updated or a certain period of time has
elapsed since the last update.

«® monitar: monitor1 - HOOFFEFE0 ;lgl il
Address | 40| +1| 42| +3| +4| +5| 46| +7| 48| +2| 42| +5] 4c| +p| +E| +F|
Ox0O0FFEF20 00 00 0 2B 00 00 1% afF 00 Qo ED &3 00 00 26 73
Ox00FFEF20 00 o020 2A E% 00 00 3 D3 00 0o 41 FC 00 00 EE EI
Ox0OFFEFAD 00 00 &4 0F 00 00 &F 44 00 02 12 E4 00 00 AR AR

0x0OFFEFEO 57 70 00 00 00 01 &0 74 00 00 10 25 00 00 04 ILE
Ox0OOFFEFCO &4 18 eSA 12 64 18 A 18 oA 158 oA 158 ei 15 eh 13

Figure6.72 [Monitor] Window (during Execution)

(5) After you have finished checking the statesin the [Monitor] window, select [Halt Program] from the [Debug]
menu to halt the program’ s execution.

6.20 What Next?
Thistutorial has described the major features of the emulator and the use of the HEW.

Sophisticated debugging can be carried out by using the emulation functions that the emulator offers. This
provides for effective investigation of hardware and software problems by accurately isolating and identifying
the conditions under which such problems arise.
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Section 7 Hardware Specifications Specific to This Product

This section describes the hardware specifications on the H8S/2612 E6000 emulator.

7.1 H8S/2612 E6000 Emulator Specifications
The H85/2612 E6000 emulator supports the system development using the following microcomputers:

« H8S/2612 group

711 Supported MCUs and User System Interface Cables

See the development support tool catal og for the MCU type names and packages supported by the EG000
emulator and for the combination of the E6000 user system interface cables and optional boards.

712 Operating Voltage and Frequency Specifications

Table 7.1 shows examples of the MCU operating voltage and frequency specifications supported by the EG000

emulator. If the emulator is used in an environment that exceeds the operating voltage range and operating
frequency range guaranteed for the MCU operation, hormal emulator operation is not guaranteed.

Table7.1 Operating Voltage and Frequency Specifications

Operating Frequency
MCU Types Operating Voltage (V) (® (MHz)

H8S/2612 group 45-55 4-20

NOTE

For details on the operating voltage and frequency specifications,
refer to the MCU’s hardware manual.
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7.2 User System Interface

All user system interface signals are directly connected to the MCU in the emulator with no buffering except for
those listed below which are connected to the MCU through contral circuits:

* NMI

» RESET

« MD2,MD1, MDO
« XTAL

« EXTAL

* SIBY

« WAIT

721 Signal Protection

All user system interface signals are protected from over- or under-voltage by use of diode arrays except for the
AVcc and Vref.

The Vcc pins (except for the AVcc pin) at the head of the user system interface cable are connected together.
The emulator monitors the voltage level of the Vcc pins and displays the power-supply status in the [Extended
Monitor] window.

722 User System Interface Circuits

The interface circuit between the MCU in the emulator and the user system has a signal delay of about 8 ns due
to the user system interface cable. And high-impedance signals will be pulled up to the high level by pull-up
resistors. When connecting the emulator to a user system, adjust the user system hardware to compensate for
propagation delays.

Default:

Vce
47 kQ
47 Q
MCU User system
interface cable
Figure7.1 Default User System I nterface Circuit
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Mode Pins(MD2, MD1 and MDO), NMI, WAIT, and STBY: The NMI signal isinput to the MCU through
the emulator control circuit. Therising/faling time of the NMI signal must be 8 ng'V or less. The mode pinsare
only monitored. The CPU mode depends on the configuration settings of the HEW.

control
circuit

Emulator

47 kQ

Vcc

47 Q
User system

interface cable

Figure7.2 User System Interface Circuit for MD2, MD1, MDO, NMI, WAIT, and STBY

RESET:
Vce
Emulator 47 kQ % % 47 Q
control - mA——O0 User system
circuit é interface cable
Figure7.3 User System Interface Circuit for RESET
PBO:
Vce
Emulator % 47Q User system
control MWV—0 PBO jnterface cable
circuit é
MCU
Figure7.4 User System Interface Circuit for PBO
PB1-PB7:

% 47 Q User system
Wv—0 PB1-PB7 nterface cable

Vce
QS3384
Emulator ]
control
circuit L |
QS3384
MCU

Figure7.5 User System Interface Circuit for PB1-PB7
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ANO-AN11, AVcc, AVssand Vref:

AVce
User system
Mcu ANO-ANTT interface cable
AVss
0.022uF
O AVce
0 Vref User system
mceu (L1 3 1 O Vre interface cable
127 KO
1 1 "1 oAvss
0.022 uF 0.022 uF

Figure7.6 User System Interface Circuit for ANO-AN11, AVcc, AVssand Vref Signals

7.3 Differ ences between M CU and Emulator

When the emulator isturned on or initialized, or the system is reset, there are some differencesin theinitial
valuesin some of the general registers between the MCU and the emulator as shown in table 7.2.

Table7.2 Initial Value Differ ences between MCU and Emulator

Status Register E6000 Emulator MCU
Power-on/ PC Reset vector value Reset vector value
initialized EROto ER6  Undefined Undefined
ER7 (SP) H'10 Undefined
CCR The I mask is set to 1 and the The | mask is set to 1 and the
other bits are undefined other bits are undefined
Reset command PC Reset vector value Reset vector value
EROto ER6  Undefined Undefined
ER7 (SP) H'10 Undefined
CCR The | mask is set to 1 and the The | mask is set to 1 and the
other bits are undefined other bits are undefined

731 A/D Converter and D/A Converter

Dueto the use of auser system interface cable, thereis a slight degradation in the A/D and D/A conversion than
that quoted in the Hardware Manual for the MCU being emulated.
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Section 8 Software Specifications Specific to This Product

This section describes the software specifications of the H8S2612 E6000 emulator.

8.1 Softwar e Specifications of the H8S2612 E6000 Emulator

Information specific to this emulator is given below.

811 Target Hardware

This emulator software conforms to the H8S/2612 E6000 emulator (HS2612EPI61H).

8.1.2 Selectable Platform

The debugging platform selectable in this emulator is as follows. The MCUs that can be emulated vary
according to the debugging platform sel ected.

Table8.1 Selectable Target Platform

Debugging Platform Remark

H8S/2612 E6000 Emulator CPU 2600  For emulation of the MCUs that have the H8S/2600 CPU as the
core.

RENESAS
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8.1.3 [Configuration Properties] Dialog Box ([General] Page)

Items that can be set in thisdialog box are listed below.

2|

Gieneral |

Uger Signals
¥ User Beset enable

Mode: I'." {advanced mode, single chip) LI R User NMI enable
e i e I~ User Standby enable

Glock:  |Main10MHz

Device:

Timer Resolution: |‘I 28hs

L L L

Flash Memaory Gontral: |

[+ Enable read and write on the fly
[¥ Break on access error
[~ Enable internal ROM area write

User VGG Threshold = 350w 4| o i

Diriver: |Emu|at0r PCI Card Driver

[~ Change driver in start up

OF. I Cancel

Figure8.1 [Configuration Properties] Dialog Box ([General] Page)
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[General] page

[Device] Selects the MCU to be emulated. To use an MCU not included in the list,
select [Custom] to specify the functions required for this MCU. See the
hardware manual for details.

[Mode] Selects the MCU's operating mode.

[Clock] Selects the speed of the MCU's clock.

[Timer Resolution]

Selects the resolution of the timer for use in execution time measurement.
The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

[Enable read and write on the
fly]

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this box if you
require realtime emulation.

- When accessing the internal ROM, internal RAM, or emulation memory

HEW accesses the memory directly as the bus mastership is released to
the emulator without breaking the user program. The MCU waits for
approximately 80 us while operating at 20 MHz.

- When accessing the internal /O, DTCRAM, or user memory

Memory is accessed with breaking the user program. This pause is
approximately 2 ms while operating at 20 MHz.

When the internal RAM is disabled, an access to this area is not available
during the user program execution.

Note:

When the content of the memory is modified during the user program
execution (e.g. modification in the [Memory] window or by the
MEMORY_EDIT command), HEW reads the content to update the value.

HEW also reads the memory content when the content has been updated
by operations such as selecting [Memory -> Refresh]. In this case, the
content of memory is read and then updated in each of the windows.

To prevent unnecessary reading of the memory content, close the
window displaying the memory content (such as the [Memory] or
[Disassembly] window) or make the settings so that the content will not
be updated.

The [Monitor] window, or the [Watch] window that satisfies the conditions
listed below displays the memory content. Note that, however, opening
these windows does not prevent realtime operation because the method
of updating the memory content in these windows is different.

Conditions:
1. Registered symbols are only allocated to general-purpose registers.

2. Registered symbols are only allocated to the monitor range set by the
[Monitor] function (the mark R is colored in blue).

3. Registered symbols are comprised of those with the conditions 1 and 2
listed above.

[Break on access error]

When this box is checked, a break (the user program stops) occurs if
your program accesses an access-prohibited area or writes to a write-
protected area.
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[General] page (cont)

[Enable internal ROM area write]  When this box is checked, writing to the internal ROM area is enabled.
For the result of writing, see the [Extended Monitor] window.

[User VCC Threshold] Sets the voltage level for the user system. [Down] will be displayed in
[User System Voltage] of the [Extended Monitor] window when the actual
user VCC (PVCC when the H8S/2612 E6000 Emulator CPU debugging
platform is selected) of the target system is lower than the specified
value.

[User Signals] When this box is checked, the reset and NMI signals from the user
system are enabled. Note that the standby signal is always invalid
because the hardware standby function is not supported. However, the
status of the signal can be checked in the [Extended Monitor] window.

[Driver] Displays the E6000 driver that is currently installed.

[Change driver in start up] When this box is checked, selection of a driver will be available next time
the emulator is connected.

The MCUs selectable by the [Device] option and options that depend on the MCUs are listed below. To emulate
an MCU with a description in the Expansion Hardware column, connect the correct expansion hardware.

Table8.2 Environment for the H8S/2612 E6000 Emulator CPU 2600 Debugging Platform

[Device] Option  [Mode] Option [Clock] Option Expansion Hardware
Custom The MCU previously selected

H8S/2616 7 (advanced mode, single chip) Main: 10 MHz None

H8S/2614 Target Main: 20 MHz

H8S/2612 Main: Target

H8S/2611 Main: Target/2

Notes: 1. Target in [Mode] is only available when the target system is connected.
2. Target and Target/2 in [Clock] are only available when the target system is connected.
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8.14 [Configuration Properties] Dialog Box ([Custom] Page)

Items that can be set in thisdialog box are listed below.

General  Custom Device

RO t: [~ Enable Flash memary

RAM: |4KE =]

Firc |100Ping =l

— Modules
¥ Enable DTG [~ Enable kDA — £/D Gonverter ——
[~ Enable DA Converter [~ Enable ICQ :i greg
ree

[~ Enable Refresh Gontroller [ Enable IG1
[~ Enable DMA