To our customers,

Old Company Name in Catalogs and Other Documents

On April 1%, 2010, NEC Electronics Corporation merged with Renesas Technology
Corporation, and Renesas Electronics Corporation took over all the business of both
companies. Therefore, although the old company name remains in this document, it is a valid
Renesas Electronics document. We appreciate your understanding.

Renesas Electronics website: http://www.renesas.com

April 1%, 2010
Renesas Electronics Corporation

Issued by: Renesas Electronics Corporation (http://www.renesas.com)

Send any inquiries to http://www.renesas.com/inquiry.
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Notice

All information included in this document is current as of the date this document isissued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful atention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

Y ou should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. Y ou are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any lossesincurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. Y ou should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the devel opment of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errorsin or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific”. The recommended applications for each Renesas Electronics product depends on the product’ s quality grade, as
indicated below. Y ou must check the quality grade of each Renesas Electronics product before using it in aparticular
application. You may not use any Renesas Electronics product for any application categorized as “ Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not bein any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as “ Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “ Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home electronic appliances, machine tools; personal electronic equipment; and industrial robots.
“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.
“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or heathcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose adirect threat to human life.
Y ou should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,
especialy with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physica injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as aresult of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sdes office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics’ as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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Cautions

Keep safety first in your circuit designs!

1.

Renesas Technology Corporation puts the maximum effort into making semiconductor
products better and more reliable, but there is always the possibility that trouble may occur
with them. Trouble with semiconductors may lead to personal injury, fire or property damage.
Remember to give due consideration to safety when making your circuit designs, with
appropriate measures such as (i) placement of substitutive, auxiliary circuits, (ii) use of
nonflammable materia or (iii) prevention against any malfunction or mishap.

Notes regarding these materials

1

These materials are intended as a reference to assist our customers in the selection of the
Renesas Technology Corporation product best suited to the customer's application; they do not
convey any license under any intellectual property rights, or any other rights, belonging to
Renesas Technology Corporation or athird party.

Renesas Technology Corporation assumes no responsibility for any damage, or infringement
of any third-party's rights, originating in the use of any product data, diagrams, charts,
programs, algorithms, or circuit application examples contained in these materials.

All information contained in these materials, including product data, diagrams, charts,
programs and algorithms represents information on products at the time of publication of these
materials, and are subject to change by Renesas Technology Corporation without notice due to
product improvements or other reasons. It is therefore recommended that customers contact
Renesas Technology Corporation or an authorized Renesas Technology Corporation product
distributor for the latest product information before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.
Renesas Technology Corporation assumes no responsibility for any damage, liability, or other
loss rising from these inaccuracies or errors.

Please al so pay attention to information published by Renesas Technology Corporation by
various means, including the Renesas Technology Corporation Semiconductor home page
(http://www.renesas.com).

When using any or &l of the information contained in these materials, including product data,
diagrams, charts, programs, and algorithms, please be sure to evaluate al information as a total
system before making a final decision on the applicability of the information and products.
Renesas Technology Corporation assumes no responsibility for any damage, liability or other
loss resulting from the information contained herein.

Renesas Technology Corporation semiconductors are not designed or manufactured for use in
adevice or system that is used under circumstances in which human lifeis potentialy at stake.
Please contact Renesas Technology Corporation or an authorized Renesas Technology
Corporation product distributor when considering the use of a product contained herein for any
specific purposes, such as apparatus or systems for transportation, vehicular, medical,
aerospace, nuclear, or undersearepeater use.

The prior written approval of Renesas Technology Corporation is necessary to reprint or
reproduce in whole or in part these materials.

If these products or technologies are subject to the Japanese export control restrictions, they
must be exported under alicense from the Japanese government and cannot be imported into a
country other than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or
the country of destination is prohibited.

Please contact Renesas Technology Corporation for further details on these materials or the
products contained therein.




IMPORTANT INFORMATION
READ FIRST

* READ thisuser's manual before using this emulator product.

* KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully under stand its mechanism.

Emulator Product:
Throughout this document, the term "emulator product” shall be defined as the following
products produced only by Renesas Technology Corp. excluding al subsidiary products.

e Emulator
e User system interface cable

The user system or a host computer is not included in this definition.

Purpose of the Emulator Product:

This emulator product is a software and hardware development tool for systems employing the
Renesas microcomputer. This emulator product must only be used for the above purpose.

Limited Applications:

This emulator product is not authorized for use in MEDICAL, atomic energy, aeronautical or
space technology applications without consent of the appropriate officer of a Renesas sales
company. Such useincludes, but is not limited to, usein life support systems. Buyers of this
emulator product must notify the relevant Renesas sales offices before planning to use the product
in such applications.

Improvement Policy:

Renesas Technology Corp. (including its subsidiaries, hereafter collectively referred to as
Renesas) pursues a policy of continuing improvement in design, performance, and safety of the
emulator product. Renesas reserves the right to change, wholly or partially, the specifications,
design, user's manual, and other documentation at any time without notice.

Target User of the Emulator Product:

This emulator product should only be used by those who have carefully read and thoroughly
understood the information and restrictions contained in the user's manual. Do not attempt to use
the emulator product until you fully understand its mechanism.

Itis highly recommended that first-time users be instructed by users that are well versed in the
operation of the emulator product.

RENESAS



LIMITED WARRANTY

Renesas warrants its emulator products to be manufactured in
accordance with published specifications and free from defectsin
material and/or workmanship. Renesas, at its option, will replace any
emulator products returned intact to the factory, transportation charges
prepaid, which Renesas, upon inspection, shall determine to be

defective
in material and/or workmanship. The foregoing shall constitute the sole
remedy for any breach of Renesas' warranty. See the Renesas warranty
booklet for details on the warranty period. This warranty extends only
to you, the original Purchaser. It is not transferable to anyone who
subsequently purchases the emulator product from you. Renesas is not
liable for any claim made by athird party or made by you for athird

party.
DISCLAIMER

RENESAS MAKES NO WARRANTIES, EITHER EXPRESS OR
IMPLIED, ORAL OR WRITTEN, EXCEPT ASPROVIDED
HEREIN, INCLUDING WITHOUT LIMITATION THEREOF,
WARRANTIESASTO MARKETABILITY, MERCHANTABILITY,
FITNESS FOR ANY PARTICULAR PURPOSE OR USE, OR
AGAINST INFRINGEMENT OF ANY PATENT. IN NO EVENT
SHALL RENESASBE LIABLE FOR ANY DIRECT, INCIDENTAL
OR CONSEQUENTIAL DAMAGES OF ANY NATURE, OR
LOSSES OR EXPENSES RESULTING FROM ANY DEFECTIVE
EMULATOR PRODUCT, THE USE OF ANY EMULATOR
PRODUCT, OR ITSDOCUMENTATION, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES. EXCEPT AS
EXPRESSLY STATED OTHERWISE IN THISWARRANTY,
THISEMULATOR PRODUCT ISSOLD "ASIS", AND YOU
MUST ASSUME ALL RISK FOR THE USE AND RESULTS
OBTAINED FROM THE EMULATOR PRODUCT.

RENESAS




State Law:

Some states do not alow the exclusion or limitation of implied warranties or liability for
incidental or consequential damages, so the above limitation or exclusion may not apply to you.
This warranty gives you specific legal rights, and you may have other rights which may vary from
state to state.

The Warranty is Void in the Following Cases:

Renesas shall have no liability or legal responsibility for any problems caused by misuse,
abuse, misapplication, neglect, improper handling, installation, repair or modifications of the
emulator product without Renesas’ prior written consent or any problems caused by the user
system.

All Rights Reserved:

This user's manual and emulator product are copyrighted and al rights are reserved by
Renesas. No part of this user's manual, all or part, may be reproduced or duplicated in any form,
in hard-copy or machine-readable form, by any means available without Renesas’ prior written
consent.

Other Important Things to Keep in Mind:

1. Circuitry and other examples described herein are meant merely to indicate the characteristics
and performance of Renesas’ semiconductor products. Renesas assumes no responsibility for
any intellectual property claims or other problems that may result from applications based on
the examples described herein.

2. Nollicenseis granted by implication or otherwise under any patents or other rights of any third
party or Renesas.
Figures:

Some figuresin this user's manual may show items different from your actual system.

Device names:

Sections 1 to 6 of the Debugger Part in this user’s manual use H8S/xxxx as an example of the
device names.
Limited Anticipation of Danger:

Renesas cannot anticipate every possible circumstance that might involve a potential hazard.
The warningsin this user's manual and on the emulator product are therefore not al inclusive.
Therefore, you must use the emulator product safely at your own risk.

1
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SAFETY PAGE
READ FIRST

* READ thisuser's manual before using this emulator product.

*« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully under stand its mechanism.

DEFINITION OF SIGNAL WORDS

A This is the safety alert symbol. Itis used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

A DANGER DANGER indicates an imminently hazardous situation which, if not

avoided, will result in death or serious injury.

A WARNING WARNING indicates a potentially hazardous situation which, if not
avoided, could result in death or serious injury.

|A CAUTION l CAUTION indicates a potentially hazardous situation which, if not
avoided, may result in minor or moderate injury.

| CAUTION l CAUTION used without the safety alert symbol indicates a

potentially hazardous situation which, if not avoided, may result
in property damage.

NOT E emphasizes essential information.

RENESAS



A WARNING

Observe the precautions listed below. Failure to do so
will result in a FIRE HAZARD and will damage the user
system and the emulator product or will result in
PERSONAL INJURY. The USER PROGRAM will be
LOST.

1. Do not repair or remodel the emulator product by
yourself for electric shock prevention and quality
assurance.

2. Always switch OFF the host computer and user system
before connecting or disconnecting any CABLES or
PARTS.

3. Connect the connectors in the user system and in the
user interface cable by confirming the correct direction.

RENESAS




Warnings on Emulator Usage

Be sure to read and understand the warnings below before using this emulator. Note that these are
the main warnings, not the complete list.

A WARNING

Always switch OFF the host computer and user system
before connecting or disconnecting any CABLES or PARTS.

Failure to do so will result in a FIRE HAZARD and will
damage the user system and the emulator product or will
result in PERSONAL INJURY. The USER PROGRAM will be
LOST.

CAUTION

Place the host computer and user system so that no
cable is bent or twisted. A bent or twisted cable will impose
stress on the user interface leading to connection or contact
failure.

Make sure that the host computer and the user system
are placed in a secure position so that they do not move
during use nor impose stress on the user interface.

VI
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High-performance Embedded Workshop User's Manual

I ntroduction

The High-performance Embedded Workshop (HEW) is a powerful development environment for
embedded applications targeted at Renesas microcomputers. The main features are;

* A configurable build engine that allows you to set-up compiler, assembler and linker options
viaan easy to use interface.

* Anintegrated text editor with user customizable syntax coloring to improve code readability.
* A configurable environment to run your own tools.

« Anintegrated debugger which allows you to build and debug in the same application.

e Version control support.

The High-performance Embedded Workshop has been designed with two key aims; firstly to
provide you, the user, with a set of powerful development tools and, secondly, to unify and present
them in away that is easy to use.

RENESAS



High-performance Embedded Workshop User's Manual

About This Manua
This manual is comprised of three parts: HEW Part, Debugger Part, and appendix.
HEW Part: Information on the basic “look and feel” of the HEW and customizing
the HEW environment, and detail of the HEW’ s build function.
Debugger Part: E10A Emulator Functions, Preparation before Use, Preparations for
Debugging, Debugging, and Tutorial.
Appendix: Troubleshooting, Regular Expressions, Placeholders, 1/0 File Format,

Symbol File Format, Window Functions, Command-Line Functions,
and Notes on HEW.

This manual does not intend to explain how to write C/C++ or assembly language programs, how
to use any particular operating system or how best to tailor code for the individual devices. These
issues are | eft to the respective manuals.

Microsoft” and Windows™ are registered trademarks of Microsoft Corporation.
Visual SourceSafeis atrademark of Microsoft Corporation.
IBM isaregistered trademark of International Business Machines Corporation.

All brand or product names used in this manual are trademarks or registered trademarks of their
respective companies or organizations.

Document Conventions
This manual uses the following typographic conventions:

Tablel Typographic Conventions

Convention Meaning
[Menu->Menu Option] Bold text with ‘->" is used to indicate menu options
(for example, [File->Save As...]).
FILENAME.C Uppercase names are used to indicate filenames.
“enter this string” Used to indicate text that must be entered (excluding the “” quotes).
Key + Key Used to indicate required key presses. For example, CTRL+N means

press the CTRL key and then, whilst holding the CTRL key down,
press the N key.

) When this symbol is used, it is always located in the left hand margin.
It indicates that the text to its immediate right is describing “how to”

(The “how to” symbol) .
do something.
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1. Oveview

This chapter describes the fundamental concepts of the High-performance Embedded Workshop.
It isintended to give users who are new to Windows® extra help, filling in the details that are
required by later chapters.

11 Workspaces, Projectsand Files

Just as aword processor alows you to create and modify documents, the High-performance
Embedded Workshop allows you to create and modify workspaces. A workspace can be thought

of asacontainer of projects and, similarly, a project can be though of as a container of project files.
Thus, each workspace contains one or more projects and each project contains one or more files.

Figure 1.1 illustrates this graphically.
C
C
C

WORKSPACE

Figure 1.1: Workspaces, Projects and Files

Workspaces allow you to group related projects together. For example, you may have an
application that needs to be built for different processors or you may be developing an application
and library at the same time. Projects can aso be linked hierarchically within aworkspace, which
means that when one project is built all of its“child” projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace
and then add files to that project before we can actually do anything.
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12

The Main Window

The HEW main window appears as shown in figure 1.2.

:E'Bdemo - High-performance Embedded Workshop - [resetprg.c] [_ (O] %]
15|

<+ Eile Edit View Project Options Buld Tools

Window Help

S NI = h T — Y e —

EfELEE BN 6 b i B L
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= | - | [ e =

S . . =
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o Le[8 stacksetsic
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s/ _INIT_IOLIB(): s U=ze SIH I-0
<< errno=0; << Remowe the comment when you uses
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s/  HardwareSetup(): #« Uze Hardware Setup
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& sbikh )
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- s _CALT, EHD{ ) << Remowe the comment when vou use,
ijectsl Mavigation | 4 »
E|
v
Build /, Debug ) Find in Files }, Version Caontrol f
Fieady |Read-write  [14/88 |21 [INS 7

Figure 1.2: HEW Main Window

There are three main windows; the workspace window, the editor window and the output window.
The workspace window shows the projects and files which are currently in the workspace, the

editor window provides file viewing and editing facilities and the output window shows the results
of avarious processes (e.g. build, version control commands and so on).
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1.2.1 TheTitleBar

Thetitle bar displays the name of the currently open workspace, project and file. It also contains
the standard minimize, maximize and close buttons. Click the minimize button to minimize the
HEW on the windows start bar. Click the maximize button to force HEW to fill the screen. Click
the close button to close the HEW (this has the same effect as selecting [File->EXxit] or pressing
ALT+F4).

1.2.2 The Menu Bar

The menu bar contains nine menus: File, Edit, View, Project, Options, Build, Tools, Window and
Help. All of the menu options are grouped logically under these headings. For instance, if you
wanted to open afile then the file menu is where you will find the right menu option, if you
wanted to set-up atool then the tools menu is the correct selection. The following sections will
cover the functions of the various menu options, as they become relevant. However, at this stage,
it isworth taking afew moments to familiarize yourself with the options that each menu provides.

1.2.3 TheToolbars

The toolbars provide a shortcut to the options, which you will use the most often. There are eight
default toolbars: Bookmarks, Debug, Debug Run, Editor, Search, Standard, Templates, and
Version Control (as shown in figure 1.3 to 1.10). Toolbars can be created, modified and removed
viathe [T ools->Customize...] menu option (see chapter 6, “ Customizing the Environment”, for
further information).

MWext Bookmark — Prewvious Bookmark

Toeele Bookmark Clear All Bookmarks

n@o®

Figure 1.3: Bookmarks Toolbar

Toegle Breakpoint Gommand Line
Enable /Disable Breakpoint
WView Dizassembly

| Radix
|

&1 B L8 2

Figure 1.4: Debug Toolbar
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Feset GPU Step Over

Gio to Cursar Step Ot
Rezet Go Set PG to Gursor
GID | Step Halt |
| 1
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Figure 1.5: Debug Run Toolbar
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Figure 1.6: Editor Toolbar
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Figure 1.7: Search Toolbar
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Figure 1.8: Standard T oolbar
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Figure 1.9: Templates Toolbar
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Figure 1.10: Version Control Toolbar

When the Standard toolbar or atoolbar is docked, it has a control bar as shown in figure 1.11 (i). If
you want to move the docked Standard toolbar, click and drag its control bar to the new location.
Figure 1.11 (i) shows the Standard toolbar when it is docked and figure 1.11 (ii) shows the
Standard toolbar when it is floating.

i JJ@@“Debug ﬂ|71||E'|E|

Standard

) @

g % |[Dstug o mE

Figure 1.11: Standard Toolbar, Docked and Floating

2 Todock the menu bar or atoolbar:
1. Double-click on thetitle bar of afloating menu bar or toolbar.
or:

2. Drag thetitle bar of afloating menu bar or toolbar and draw it toward an edge of a docked
window, menu bar, toolbar or the HEW main frame, on whose edge you would like to dock
the window, until the shape of the floating bar changes.
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2 Tofloat the menu bar or atoolbar:
1. Double-click on the control bar of adocked menu bar or toolbar.
or:

2. Drag the control bar of adocked menu bar or toolbar and draw it away from the edge of the
HEW main frame and from an edge of the other docked windows, menu bar or toolbar.

124 The Workspace Window

The “Workspace” window when the HEW is launched only hasasingle pane. Thisisthe
“Projects’ tab. If aworkspace is opened then the workspace window displays two default tabs.
The “Projects’ tab shows the current workspace, projects and files (figure 1.12). Y ou can quickly
open any project file or dependent file by double clicking on its corresponding icon.

El@ demo

EI@ Projectl
Ela Praject Files

cl.=re

E| main.c
E| sh_hwofac
sh_intwv.sro

IS

Dependencies

] filelh

Mavigation tab

Projects tab —4——

| @ Projects l @] Mavigation I

Figure 1.12: Workspace Window Projects Tab

The “Navigation” tab provides jumps to various textual constructs within your project’sfiles.
What is actually displayed within the navigation tab depends upon what components are currently
installed. Figure 1.13 shows ANSI C functions. See chapter 2, “Build Basics’, for more
information on the “Workspace” window.
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__main(]

“] hw_initializel)

] log_emorf+0RD &)
#_] main(]

4] SCI0_ISR_ERI()
“] SCI0_ISR_R=I)
] SCI0_ISR_TEI
] SCIO_ISR_T=I0)
4] SCI_ClearBuffers()
4] SC_GetBlackl)

&1 5CI_GetR :-:E! ueSize()

@ Projects “ | MNavigation l_

Figure 1.13: Workspace Window Navigation Tab

To allow the “Workspace” window or the “ Output” window docking:

Click the right mouse button anywhere inside the “Workspace” window or the “ Output”

window. Then a pop-up menu will be displayed. If [Allow Docking] is checked, docking is
allowed; otherwise, docking is not allowed. Select [Allow Docking] to check or uncheck it.

When [Allow Docking] is checked, you can dock awindow, atoolbar or a menu bar to the edge of
the HEW main window or to the edge of another docked window. Also if [Allow Docking] is
checked, you can float them “above” the other HEW windows or outside the HEW main window.
Figure 1.14 (i) shows a docked “Workspace” window, and figure 1.14 (ii) shows a floating
“Workspace” window.

o ||
E@ dema
- B e
S @ Project] @@ Projectl
B- a Project Files & a A s
- ollsre raject Files
BET .- T O I I cl.sre

main.c
sh_hwctec

s sh_intw.src

. main.c

: zh_hwete.c

sh_intw.src

Mavigation tab
Projects tab — |

N @ijecls l “_] Mawigation I

N @ Projects l @]Nauigaﬁnn I

f

Figure 1.14: Workspace Window, Docked and Floating
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When the “Workspace” window or the “Output” window is docked, it has a control bar as shown
in figure 1.15. If you want to move a docked window, click and drag its control bar to the new
location.

'Close' button

A |

Figure 1.15: Control Bar of Docking Window

2 Todock the “Workspace” window or the “Output” window:
[Allow Docking] must be checked on the pop-up menu of the window to dock the
“Workspace” window or the “ Output” window. (The pop-up menu will be displayed when you

click the right mouse button anywhere inside the window.) Then you have two ways to dock
the window.

1. Double-click on the control bar of afloating window.
or:

2. Drag thetitle bar of afloating window and draw it toward an edge of a docked window,
menu bar or toolbar, or the HEW main frame, on whose edge you would like to dock the
window, until the shape of the floating window changes.
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2 Tofloat the “Workspace” window or the “Output” window:

[Allow Docking] must be checked on the pop-up menu of the window to float the
“Workspace” window or the “ Output” window. (The pop-up menu will be displayed when you
click the right mouse button anywhere inside the window.) Then you have two ways to float
the window.

1. Double-click on the control bar of adocking window.
or:

2. Drag the control bar of a docked window and draw it away from the edge of the HEW main
frame and from an edge of the other docked windows, menu bar or toolbar.

2 To hide the “Workspace” window or the “Qutput” window:
Click on the close button, which is located in the top right corner of the window. Or push the
right mouse button anywhere inside a floating window and select [Hide] on the pop-up menu.
S Todisplay the “Workspace” window or the “Output” window:
Select [View->Workspace] or [View->Output], respectively.
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1.25 The Editor Window

The editor window is where you will work with the files of your project. The HEW allows you to
have many files open at one time, to switch between them, to arrange them and to edit themin
whichever order you want to. By default, the editor window is displayed in anotebook style,
where each text file has a separate tab (as shown in figure 1.16).

The editor contains a gutter on the left-hand side of the window. The gutter in HEW can be
configured to contain many columns. Each column can refer to a different component’s capability.
In figure 1.16 the editor is displayed with the debugger address column and the standard column.
The standard column allows the user to configure the position of bookmarks and software
breakpoints quickly and easily.

II"HH!HHMHH?HHHHHHH!HHHHlHHHHlG?HHHHG*!HHH!HHMHH?HHHHHN?HHHHHlHHHHlG?HHHH!*!HHH!HH#!HHG*!HH!*?HWHH!*!HH!*H{WHHG*}

JSw FILE tzbrk.c L
i DATE tThu, 4ug 16, 2001 wS
J# DESCRIPTION :Program of =sbrk ®S
f#  CPU TYPE 1EHT020 #
ik *f
;* This file is zenerated by Hitachi Project Generator (Yer.2.1). m;
E #®

R RS 4 L L S 0 AR MR 4 RS s e

finclude <{stddef.h>
Tinclude <stdia.h>
tinclude "sbrk.h”

extern char #_slptr;
extern void srand{unzizned int): b

ztatic union {

long  dummy ; 4 Dummy for 4-byte boundary #/
char heap[HEAPSIZE]: /# Declaration of the area managed %/
i by shrk #f

theap_area :

static char #brk=(char #)kheap_area; /% End addresz of area assizned w/

4

f*****Hﬂ**HHIG***Hﬂ**Hﬂ*HHIHHHHIG*HHIG***Hﬂ**Hﬂ*HHIHHHHIG*HHIG?k**Hﬂ**HHIGHHIHH*********************illl
.3

=k resetprec | 2 disctc < shrkc I

Figure 1.16: Editor Window

The editor window can be customized viathe “Format Views™ dialog box, which can be invoked
viathe [Tools->Format Views...] menu option. This dialog allows you to configure fonts, colors,
tabs and so on for the editor window. It also alows the user to change the look of other views,
which have been installed by HEW. If you would prefer to use your favorite editor rather than the
HEW internal editor then specify your alternative in the “Options” dialog box, which can be

10
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invoked viathe [T ools->Option...] menu option. For further details on how to use and configure
the editor, refer to chapter 4, “Using the Editor”.

126 The Output Window

The “Output” window by default has four tabs on display. The “Build” tab shows the output from
any build process (e.g. compiler, assembler and so on). If an error is encountered in a source file
then the error will be displayed in the build tab along with the source file name and line number.
To quickly locate a problem, double click on the error to jump to the source file and line.

x|
=

| [A]» ] Buitd £ Debug } Find in Files }, Version Cantral /

Figure 1.17: Output Window

The “Debug” tab shows the output from any debugger process. Any debug component that needs
to display information will send its output to this window.

The“Find in Files’ tab displaysthe results of thelast “Find in Files’ action. To activate find in
files, select the [Edit->Find in Files...] menu option, the toolbar button. For further details on
how to usefind in files, refer to chapter 4, “Using the Editor”.

The“Version Control” tab displays the results of version control actions. The tab is only displayed
if aversion control system isin use. For further details on version control, refer to chapter 7,
“Version Control”.

11
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1.2.7 The Status Bar

The status bar displays information as to the current state of the HEW. Figure 1.18 shows the

seven sections of the status bar.

Displays HEW stals messages.

Read only stalis e nurmber. Column nutmier
Ihzertion Made.
|
Ready |Read-write — [2f4 1 1S | 4

Caps lock. Mum lock,

Figure 1.18: StatusBar
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13 The Help System

The help menu is the rightmost menu on the HEW menu bar. It contains the menu option
“Contents” which, when selected, takes you to the main HEW help window.

To obtain help on specific dialogs click on the context sensitive help button, which islocated in
the top right-hand corner of each dialog box (as shown in figure 1.19).

]

Context sensitive help bution
Cancel buthen

Figure 1.19: Help Button

When thisis clicked, the mouse pointer will change to a pointer with a question mark aboveit.
Whilst the mouse pointer isin this state, click on the part of the dialog box that you require
assistance on.

Alternatively, select the control that you require help for and then press the F1 key.
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14 Launching the HEW

To run the HEW, open the “ Start” menu of Windows®, select “Programs”, select “High-
performance Embedded Workshop” and then select the shortcut of the “High-performance
Embedded Workshop 2”. By default, the “Welcome!” dialog box shown in figure 1.20 will be

displayed.

Welcomel EE |

— Options:
& Create a new project workspace
Cancel |
" Open a recent project workspace: &drministration. .. |
ﬂ IE:HHedeemquemn.hws j
= :
g " Browse to another project workspace

Figure 1.20: Welcome! Dialog

To create anew workspace, select “ Create a new project workspace”, and click “OK”. To open
one of recent project workspaces, select “Open arecent project workspace”, select aworkspace
from the drop-down list, and click “OK”. The recent project workspace list displays the same
information as that seen in the workspace most recently used filelist. Thislist appearson thefile
menu. To open aworkspace by specifying aworkspace file (HWSfile), select “ Browse to
another project workspace”, and click “OK”. To register atool to or unregister atool from the
HEW, click the “Administration...” button (see chapter 5, “Tool Administration” for details).
Click the “Cancel” button to use the HEW without opening a workspace.

15 Exiting the HEW

The HEW can be exited by selecting [File->Exit], pressing AL T+F4 or by selecting the close
option from the system menu. (To open the system menu, click the icon at the upper-left corner of
the HEW title bar.) If aworkspace is open then the same workspace closedown procedure is
followed as described in the previous section.

14
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16 Component System Overview

The HEW allows the user to extend the HEW functionality by adding additional componentsto
the system. Thisis achieved by registering the component in the Tools Administration dia og box.
These components can add windows, menus and toolbars to the HEW system. Examples of the
components are the debugger and builder components of HEW. The debugger component adds all
of the menus and toolbars associated with the debugger and the builder component does the same
for the build functionality. The components you have registered in the system will modify the
look and feel of HEW. In some cases you may not have some of the menus which you can seein
thismanual. For instance if the debugger component is not installed you will not have the
“Debug” menu in the HEW main window.

15
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2. Build Basics

This chapter explains the general functions of the HEW whilst the more advanced features can be
found in chapter 3, “Advanced Build Features’.

2.1 The Build Process

The typical build processis outlined in figure 2.1. This may not be the exact build process, which
your installation of HEW will use as it depends upon the tools that were provided with your
installation of HEW (e.g. you may not have a compiler for instance). In any case, the principles
are the same - each step or phase of the build takes a set of project files and then builds them, if all
succeeds then the next step or phase is executed.

B suo B

COMPILER

C
Source Files

ﬂ—' ASSEMBLER
ET

Assembler

/ Source Files

Project

LINKER Object
Files
Library
Files ‘
Load
Module

Figure 2.1: Typical Build Process

In the example shown in figure 2.1 the compiler is the first phase, the assembler is the second
phase and the linker is the third and final phase. During the compiler phase, the C sourcefiles
from the project are compiled in turn, during the assembler phase, the assembler source files are

17
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assembled in turn. During the linker phase all library files and output files from the compiler and
assembler phases are linked together to produce the load module. This module can then be
downloaded and used by the debugger functionality in HEW.

The build process can be customized in several ways. For instance, you can add your own phase,
disable a phase, delete phases and so forth. These advanced build issues are |eft to chapter 3,
“Advanced Build Features’. In this chapter, only the general principles and basic features will be
detailed.

18
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2.2 Project Files

In order for the HEW to be able to build your application, you must first tell it, which files should
be in the project, and how each file should be built (figure 2.2).

]

Add Project Files

Remove Project Files

A

Debug: ON
Optimize: OFF
List File: YES
Debug: OFF
Optimize: OFF
List File: YES
Debug: ON
Silent: YES
Map File: YES

Set Compiler Options

Set Assembler Options

Project

0
M

Source Files

4

Set Linker options

Assembler
Source Files

|
i

Library
Files

Figure 2.2: Editing a Project
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221 Adding Filesto a Project

Before you can build your application you must first inform the High-performance Embedded
Workshop, which filesit, is composed of.

2 Toadd afilesto aproject:

1. Select [Project->Add Files...], select [Add Files...] from the “Workspace” window’s pop-
up menu (see figure 2.3), or press | NS when the “Workspace” window is selected.

Figure 2.3: Project Pop-up Menu

2. The“Add” diaog will be displayed.
3. Select thefilg(s), that you want to add and then click “Add”.

20
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There are anumber of other ways to add new files to the project. These are described below:

e Clicking right button on an open file in the editor window displays a pop-up menu option
(figure 2.4). If thefileisalready in the project then the “Add File to Project” menu option is
disabled. Selecting the “Add File to Project” then adds the file to the current project.

Build File “dbsctc”

Ciut Ctr |+
Ciopy Ctrl+G
Pazte Ctr |+

Eddll Eile T Brajest

Find... Citrl+F
Find In Filez.. Fd
Feplace Ctrl+H
Gioto Line Ctrl+G
Match Braces Citrl+M
Book marks 3
Templates 3
Toeele Breakpoint Fa

Eratiey et e Bre skt GrlFED

Figure 2.4: Editor Window Pop-up Menu

* IntheHEW itisaso possible to “Drag and Drop” files from Windows Explorer onto the
workspace window. Thesefileswill be automatically added to the project and are displayed
in the folder in which they were dragged to.

Note: If you add afile to a project when it is an unrecognized file type then it will still be added
to the project. Certain functions will be disabled with reference to thisfile. When thisfileis
double clicked in the workspace window instead of opening the file in the editor the open
operation is passed to Windows operating system. The default open operation is then carried out
asif thefile was opened in Windows Explorer. To view the current defined extensions use the
“File Extensions’ dialog (see the section on file extensions later in this chapter).

21
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222 Removing Files from a Project

Files can be individually removed from a project, selections of files can be removed or al files can
be removed.

2 Toremove files from a project:

1. Select [Project->RemoveFiles...], or select [Remove Files...] from the “Projects’ tab’s
pop-up menu in the Workspace window (see figure 2.5). The “Remove Project Files”
dialog will be displayed (figure 2.6).

Figure 2.5: Projects Tab Pop-up Menu

22
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Remove Project Files

FProject files:

initzct.c
intprag. sro
rezetprg.src
zhrk.c
stacksct zrc
vectthl src

[\ hewhdemotderno]

Shewhdernodemo
[e:\hewhdemohdema]
[e:hewhdemotdema)
[e:\hewhdemohdema]
[e:\hewhdemohdema]
[e:\hewhdemohdema]
[e:\hewhdemohdema]

| ol

Q.
Cancel
Femove

Femove Al

il

Figure 2.6;: Remove Project Files Dialog
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2. Select thefile or files which you want to remove from the “ Project files’ list.
3. Click the “Remove’ button to remove the selected files or click “Remove All” to remove
al project files.
4, Click “OK” to remove the files from the project.
S Toremove selected files from a project:

1. Select thefiles, which you want to remove, in the “Projects’ tab of the “Workspace”
window. Multiple files can be selected by holding down the SHIFT or CTRL key.

2. Pressthe DEL key. Thefileswill be removed.

24
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223 Excluding a Project File from Build

A filein aproject can be individually excluded from build on a configuration by configuration
basis.

2 Toexclude afilein aproject from build:
1. Push the right mouse button on afile, which you want to be excluded from build, in the
“Projects’ tab of the “Workspace” window.

2. Select [Exclude Build file], where <file> is the sel ected file, from the pop-up menu
(figure 2.5). Then ared crosswill be put on thefile'sicon, and the file will be excluded
from build.

224 Including a Project Filein Build
An excluded file can be included in the project again.

2 Toinclude afile which has been excluded from build:
1. Push the right mouse button on afile, which has been excluded from build, on the
“Projects” tab of the “Workspace” window.
2. Select [Include Build file], where <file> is the selected file, from the pop-up menu. Then
ared cross will be removed from the file'sicon, and the file will be included in build.

2.3 File Extensions and File Groups

The HEW can identify files by their extension. The system defines certain extensions depending
upon the tools, which are being used. For example, if you are using a compiler then the .c
extension will be in the “ C source file” group and be used as input to the compiler phase (figure
2.1, Typical Build Process). Additionally, the HEW allows you to define your own extensions. For
example, if the project you are developing uses assembler source files the default extension may
be .src. If you would like to use a different extension instead of .src (e.g. .asm) then you can
define anew extension and request that the HEW treats it in the same way asa .srcfile.

25
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File extensions and file groups can be viewed and modified viathe “File Extensions’ dialog
(figure 2.7). Thisisinvoked by selecting [Project->File Extensions...]. This dialog displays al of
the extensions and file groups, which are defined within the current workspace.

File Extensions

Extension | Group - 0]4 I
D*.abs Absolute file

*.inc Aszembly include file Cancel |
[Ep*is Szsembly list file

*.src Aszembly source file Add..
[E*h C header file Remove |
EEIE  list file -

*.c C zource file Open with..

*.hpp C+t header file

EEA S+ list file

CH++ source file

D*.cpu CPU information file

E?Jknvn Frrmandad sccamhbb caivea f;lnl -
L | *

Figure 2.7: File Extensions Dialog

The “File Extensions” list shown in figure 2.7 is divided into two columns. On the left are thefile
extensions themselves, whilst on the right are the file groups. Many file extensions can belong to
the same group. For example, assembler source files may have several extensionsin asingle
project (e.g. .src, .asm, .mar etc) as shown in figure 2.8.

Assembler source files C source files Library files

Figure 2.8: File Extensionsand Groups

When creating a new extension you should consider whether the extension belongs to a group,
which is aready defined, or whether you need to create anew file group. If you are adding a

26
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completely new type of file then you will want to create a new file group. This processis
described below.

RENESAS
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2 To create anew file extension in anew file group:

28

1

Select [Project->File Extensions...] from the menu bar. The “File Extensions’ diaog will
be displayed (figure 2.7).
Click the“Add...” button. The “Add File Extension” dialog will be displayed (figure 2.9).
Enter the extension, which you want to define into the “File extension” field. It is not
necessary to typethe period ( . ) character. Thedrop list contains al extensions that are
undefined in the current project. Selecting one of these extensions will add the text to the
file extension field automatically.
Select the “Extension belongs to a new group” option and enter a description, which
defines this new file group.
At thisstageit is possible to change the associated application. There are four available
choicesin the “Open” with drop list. These are listed below:

«  Editor
* None
e  Other

e Windows default

If the editor is selected, the open file function in the workspace window causes the file to
be opened in the HEW ediitor. If noneis selected then the open operation is disabled when
the open file function is attempted. Selecting “Other” allows you to configure an another
tool for the open file operation. See “To associate an application with a file group” for
more details. If the “Windows default” option is selected then the open file function in the
workspace window passes the open file to the Windows operating system. This then
selects the default behavior for this file extension as defined in Windows Explorer.

Click “OK” to add the extension to the “File Extensions” list.
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Add File Ext

—FEile extension:
" I j Cancel |

—File group:

* Extension belongs to an existing group:

[Atsolute file =l

" Extension kelongs to a new groum:

—Associated application:
Open " Absolute file™ with:
Windows default j

| =0 =

Ii

Figure 2.9: Add File Extension Dialog (New Group)

If you want to create a new extension because your project uses a different extension from those
accepted by the HEW. For example, a phase might by default use the extension .asm but the
HEW only recognizes .src.  Then you need to create a new extension and add it to an existing file
group. This processis described below.

29
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S To create anew file extension in an existing file group:

1

Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will
be displayed (figure 2.7).

Click the “Add...” button. The “Add File Extension” dialog will be displayed (figure 2.10).
Enter the extension, which you want to define into the “File extension” field. It is not
necessary to type the period ( . ) character. The drop list contains all extensions that are
undefined in the current project. Selecting one of these extensions will add the text to the
file extension field automatically.

Select the “Extension belongs to an existing group” option and select which group you
would like to add this new extension.

Click “OK” to add the extension to the “ File Extensions”’ list.

Add File Extenzion

—FEile extension:
- lasm -
* Cancel |

—File group:

* Extension belongs to an existing group:

If‘-\ssembly source file j

" Extension kelongs to a new groum:

—Associated application:

Open “ Assermbly source file”™

Edior

Flee [iFes

II

| =0 =
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Figure 2.10: Add File Extension Dialog (Existing Group)
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In addition to opening afile with the editor, the “File Extensions’ dialog allows you to associate
any application with any file group so that when you double click on afile in the “ Projects’ tab of
the “Workspace” then the appropriate application is launched with the file. Figure 2.11 shows the
association between aword processor and the extension .DOC.

File Extenszions

Extension | Giroup AI 64 I
*.lpp G+ list file

Teat editer —‘@ *.cpp CH+ =zource file Cance| |
D*.cpu CPU information file

Wierd precesser —— W + doc Documents £dd..
*.exp Expanded assembly source fila Flamawve |
Librarizan -@*.Iib Library file =
EE Library list file Bl i
*.sct Library section list file
*.map Linkage map file
*.fsy Linkage symbal file
Me applisation ——H ] *.obj Ohject file

S Prarenraszad (M cmwes fila i
g il

Figure 2.11: File Groups and Applications

S To associate an gpplication with afile group:
1. Select thefile group to be associated from the “File Extensions” dialog (figure 2.11).

2. Click the “Open with...” button. The “Modify File Extension” dialog will be displayed
(figure 2.12).
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Modify File Extension

Group

Linkage map file

—Associated application: ﬂl

Open " Linkage map file™ with:

Mare j

Editor

Other
Windows default Winclify

BE e

Figure 2.12: Modify File Extension Dialog

3. Select “None’ to remove any association, select “Editor” to open thistype of filein the
internal/external editor or select “Other” if you want to open this type of file with a specific
application. If you select “Other” then you can select from any previously defined

application from the drop-down list or specify a new application.

4. Click “Add...” to define anew application. The “Add Application” dialog will be

displayed (figure 2.13).

Add Application K E |
Hame:
I Cancel |

Command [excluding parameters);

I Ll Browse. . |

Paramneters:

| il

nitial directony;

1
I ll Browse. .. |

Figure 2.13: Add Application Dialog
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5. Enter the name of the tool into the “Name” field. Enter the full path to the tool in the
“Command” field (do not include any parameters). Enter the parameters that are required to
open afilein the “Parameters’ field. Be sure to use the $(FULLFILE) placeholder to
specify the location file (see appendix C, “Placeholders’, for more information on
placeholders and their uses). Enter the initial directory, in which you would like the
application to run, into the “Initial directory” field. Click “OK” to create the application.

6. Click “Modify...” to modify an application. The “Modify Application” dialog will be
displayed. Thisdialog is the same as the “Add Application” dialog described above except
that the “Name” field isread only. Modify the settings as desired and then click “OK”.

7. Click “OK” to set the application for the selected file group.
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24 Specifying How to Build a File

Once you have added the necessary files to the project the next step is to instruct the HEW on how
to build each file. To do this, you will need to select a menu option from the “ Options” menu. The
contents of this menu depend upon which tools you are using. For example, if you are using a
compiler, assembler and linker then there will be three menu options, each one referring to one of
thetools.

© To set optionsfor a build phase:
1. Select the options menu and find the phase whose options you would like to modify. Select
this option.
2. A dialog will beinvoked which allows you to specify the options.
3. After making your selections, click “OK” to set them.

To obtain further information, use the context sensitive help button or select the areain which you
need assistance and then press F1.
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25 Build Configurations

The HEW allows you to store all of your build optionsinto a build configuration (figure 2.14).
This means that you can “freeze” all of the options and give them aname. Later on, you can select
that configuration and all of the options for all of the build phases will be restored. These build
configurations also allow the user to specify debugger settings for a build configuration. This
means that each configuration can be targeted at a different end platform. (See Debugger Part in
this manual, for further information).

Figure 2.14 shows three build configurations; “ Default”, “MyDebug” and “MyOptimized”. In the
first configuration, “ Default”, each of the phases (compile and assemble) are set to their standard
settings. In the second configuration, “MyDebug”, each of the files are being built with debug
information switched on. In the third configuration, “MyOptimized”, each of the files are being
built with optimization on full and without any debug information. The developer of this project
can select any of those configurations and build them without having to return to the options
dialogsto set them again.

"Default" "MyDebug" "MyOptimized"
Configuration Configuration Configuration
[ — [ — [ —
Debug: ON Debug: ON Debug: OFF
Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | H List File: NO | H List File: NO | H
C
Source Files
] ] ]
Debug: OFF Debug: ON Debug: OFF
Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | - List File: NO | List File: NO |
Assembler
Source Files
C:\MyProject\Default C:\MyProject\MyDebug C:\MyProject\MyOptimized

Figure 2.14: Configurationsand File Options
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251 Selecting a Configuration
The current configuration can be set in two ways:
Either:

1. Select it from the drop down list box (figure 2.15) in the toolbar.

I Releaze j

Figure 2.15: Toolbar Selection
or:

1. Select [Options->Build Configurations...]. Thiswill invoke the “Build Configurations’
Dialog (figure 2.16).

Build Configurations

Build configurations: Ok

Releaze Cancel

=
2
5
I
=
\_ \_IH
%

Hemmve

Current configuration;

Debug j

Figure 2.16: Build Configurations Dialog

2. Select the configuration that you want to use from the “ Current configuration” drop down list.
3. Click “OK” to set the configuration.
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252 Adding and Deleting Configurations

Y ou can add a new configuration by copying settings from another configuration or delete a
configuration. These three tasks are described bel ow.

S Toadd anew configuration:

1. Select [Options->Build Configurations...] to display the “Build Configurations” dialog
(figure 2.16).
2. Click the“Add...” button. The“Add Configuration” dialog will beinvoked (figure 2.17).

Add Configuration E |
Configuration name; IM.'r'E'I'f'IﬁEI

Cancel
Bazed on configuration: I Debug j —l

Configuration directan: o hhewhdemobdemouConfig

Figure 2.17: Add Configuration Dialog

3. Enter the new configuration name into the “ Configuration name” field. Asyou enter the
new configuration name, the directory underneath changes to reflect the configuration
directory that will be used. Select one of existing configurations, from which you want to

copy aconfiguration, out of the drop-down list of the “Based on configuration” field. Click

“OK” on both dialogs to creste the new configuration.

S Toremove aconfiguration:

1. Select [Options->Build Configurations...] to display the “Build Configurations’ dialog
(figure 2.16).

2. Select the configuration that you want to remove and then click the “Remove” button.
3. Click “OK” to close the “Build Configurations” dialog.
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2.6 Building a Project

The outline of the build processis shown in figure 2.1.

2.6.1 Building a Project

The build option only compiles or assembles those files that have changed since the last build.
Additionally, it will rebuild sourcefilesif they depend upon afile that has changed since the last
build. For instance, if the file “test.c” #include' s the file “header.h” and the latter has changed
since the last build, the file “test.c” will be recompiled.

2 Toperform abuild:
mouse button on a project icon in the “Projects” tab of the “Workspace” window and select
[Build] from the pop-up menu.

The build all option compiles and assembles all source files, irrespective of whether they have
been modified or not, and links all of the new object files produced.

2 Toperformabuild al:

Select [Build->Build All], or click the build all toolbar button (&), or click the right mouse
button on a project icon in the “Projects” tab of the “Workspace” window and select [Build
All] from the pop-up menu.

Both the build and the build all will terminate if any of the project files produce errors.

262 Building Individual Files
The High-performance Embedded Workshop lets you build project files individually.

2 Tobuild anindividual file:
1. Select thefile which you want to build from the project window.

2. Select [Build->Build File], click the build file toolbar button (:2) or press CTRL+F7 or
click the right mouse button on afileicon in the “Projects’ tab of the “Workspace” window
and select [Build <file>] from the pop-up menu.
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2.6.3 Stopping a Build
The High-performance Embedded Workshop allows you to halt the build process.

2 Tostopabuild:

1. Select [Build->Stop Build] or click the stop build toolbar button (#%). The build will be
stop after the current file has been built.

2. Wait until the message “Build Finished” appearsin the “ Output” window before continuing.
2 Toforcibly terminate a current tool

1. Select [Build->Terminate Current Tool]. The HEW will attempt to stop the tool
immediately.

Note: Do NOT assume that any output from the tool you terminated is valid. It is recommended
that you delete any output files produced and ensure that the phase is executed again.

264 Building Multiple Projects

The High-performance Embedded Workshop lets you build multiple projects and configurations at
once.

2 To build multiple projects:

1. Select [Build->Build Multiple]. The figure displayed in figure 2.18.

2. Thebuild multiple gives you the choice of which projects and configurations should be
built. To select which projects and configurations need to be built select the check box
next to the project — configuration combination you want to build. For example, in figure
2.18if you wanted to build the entire “hewtest2” project you would check the “hewtest2-
Debug” and the “hewtest2-Release” selections and leave al other check boxes unchecked.

3. When you are happy with your chosen selection click the build button and the HEW will
then build the projects and configurations you have chosen.

4. If you want to build all the projects which you choose, you click the build al button.

5. Resultsfrom the build are displayed in the build window in the same way as the normal
build process.
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Build Multiple E |

[ |hewtest]-Debug -
[ hewtest]1-Release

[ |hewtests-Debug -
[ hewtest2-Release
[ |hewtest3-Debug
[ hewtest3-Releaze
[ |hewtestd-Debug
[ hewtestd-Releaze
[ |hewtestS-Debug

[ hewtesth-Release - |
4 I I 3

Cancel

[

Figure 2.18: Build Multiple Dialog

2.65 The Output Window

When atool executes (i.e. compiler, assembler, linker etc.) its output is displayed in the “ Output”
window. If any of the tools produce any errors or warnings then they are displayed along with the
source file name and the line number at which the error is located. To quickly locate a specific bug,
double click on agiven error/warning to invoke the current editor.

2.6.6 Controlling the Content of the Output Window

It is often useful to display low-level information (such as the command line options that are being
applied to afile) during a build. The HEW allows you to specify whether or not you want such
options displayed in the “ Output” window during a build, build all or build file operation via the
“Tools Options” dialog.

S Toview or hide extrainformation during a build:
1. Select [Tools->Options...]. The “Options” dialog will be displayed.
2. Select the “Build” tab (figure 2.19).

3. Set the three check boxesin the “ Show” group as follows. “Command line’ controls
whether the command line is shown as each tool is executed. “Environment” controls
whether the environment is shown as each tool is executed. “Initia directory” controls
whether the current directory is shown as each tool is executed.
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Options

Euild lEditu:ur ] Wnrkxpace] Ennfirmatinn]

Errors and warnings:

[ Stop build if the no. of emors exceed:

[ Stop build if the no. of warnings exceed:

Show:
[ Command line
[ Enwironment

[ Initial directony

0k, | Cancel

Figure 2.19: Options Dialog Build Tab

2.7 File Dependencies

A typical project will contain dependencies between files, for example, one C file may “#include”
one or more header files. In complex projects, source files will include (or depend upon) others
and this can quickly become difficult to manage. However, the HEW provides a dependency
scanning mechanism whereby dl filesin a project are checked for dependencies. Once complete,
the project window will display an up-to-date list with all the project file dependencies.

2 To update a project’s dependencies:
Select [Build->Update All Dependencies] or click the right mouse button on a project icon in
the “Projects’ tab of the “Workspace” window and select [Update All Dependencies] from
the pop-up menu.
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Initialy, the dependencies for al files are contained within the “Dependencies’ folder (figure
2.20.0).

2.8 Configuring the Workspace Window

If you click the right mouse button anywhere inside the “Projects’ tab of the “Workspace”
window, a pop-up menu will beinvoked. Select the “ Configure View...” menu option to modify
the way in which information isdisplayed. The following four sections detail the effect of each
option on the “ Configure View” dialog.

281 Show Dependencies under Each File

If you select “ Show dependencies under each file”, the dependent files are shown under the
including source file as aflat structure, i.e. the files themselves become folders (figure 2.20.ii). If
this option is not selected then a separate folder contains all dependencies (figure 2.20.i).

i El@ demo L El@ demo
E@ Projectl = Projectl

=23 Project Files i |E] elsre
- j cllsr EI

3 main.c

main.c

(5] tilelh
] shrkc file2h
: j sh_hwcfec sbrk.c

i g sh_intw.sre o |E] shbhwefec
El'a Dependencises “[E] sh_intw.sre

~[Z] fileth
L [g] file2h

N @ Projects l @] Mavigation I N @ Projects l “ | Mawvigation I

Figure 2.20: Dependencies under Each File
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282 Show Standard Library Includes

By default, any dependent files found in standard include paths will not be shown (figure 2.21.i).
For example, in C code, if you write an include statement such as “#include <stdio.h>" then
stdio.h will not be listed as a dependent file. To view such system include files, select the “ Show
standard library includes” option (figure 2.21.ii).

L El@ demao = El@ demo
E@ Projectl E@ Projectl
El'a Praject Files E'a Praoject Files
- cl.src - [F] elsre
main.c =] mainc
. - shrk.z =] sbrkc
- sh_hwefg.c =| sh_bhweigc
S sh_intw.sro s | Z] sh_intwsro
E'a Dependencies

=] stddefh
i | ] stdich

N @ Projects l ] Mavigation I N @ Projects l “ | Mawvigation I

Figure2.21: Standard Library Includes
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2.8.3 Show File Paths

If “Show file paths” is selected, al of the filesin the project window are shown with their full path,
i.e. from adrive letter (figure 2.22).

El@ c:vhewhdernohdemo. bws
EI@ Projectl
B3 Project Files

----- C:A\Hew'demohdemohcl. 2o

% Hewhdernohdemohmain, o
----- C:A\Hew'demohdemohsbrk. o
5 Hewdernohdernohsh_hwetg.c
o C:A\Hew'demohdemohsh_inty. zrc

N 3] Projects l = | Mavigation I

Figure 2.22: File Paths Shown

29 Setting the Current Project

A workspace can contain more than one project but only one of the projects can be active at any
time. Thisactive project isthe one which build actions and debug operations can be performed
on. Itispossibleto change the builder or debugger options for the project. An active project is
displayed in bold.

2 Toset aproject asthe current project:
1. Select the project from the “Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Set as Current
Project] option.
or:

1. Select the project, which you want to make active from the [Pr oj ect->Set Current
Proj ect] sub-menu.

210 Inserting a Project into a Workspace

When aworkspace is created, it contains only one project but, after it is created, you can insert
new or existing projects into a workspace.
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2 Toinsert anew project into aworkspace:

1. Select [Project->Insert Project...]. The “Insert Project” dialog will be displayed (figure
2.23).

2. Setthe“New Project” option.

3. Click OK. The“Insert New Project” dialog will be invoked.

4. Enter the name of the new workspace into the “Name” field. This can be up to 32
charactersin length and contain letters, numbers and the underscore character. As you enter
the project name the HEW will add a subdirectory for you automatically. This can be
deleted if desired.

5. Click the“Browse...” button to graphically select the directory in which you would like to
create the project. Alternatively, you can type the directory into the “ Directory” field
manually.

6. The“Project type” list displays all of the available project types (e.g. application, library
etc.). Select the type of project that you want to create from this list.

7. Click “OK” to create the project and insert it into the workspace.

Note:  When anew project is being inserted, the CPU family and tool chain cannot be specified
as these properties are already defined by the workspace (i.e. al projects within the same
workspace target the same CPU family and toolchain).

Inzert Project EE |

Cancel |

" Existing project;

Brawse.. |

Figure 2.23: [Insert Project] Dialog
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S Toinsert an existing project into a workspace:
1. Select [Project->Insert Project...]. The “Insert Project” dialog will be displayed.
2. Set the “Existing Project” option.
3. Enter the full path of the project database file (HWP file) into the edit field or click
“Browse...” to search for it graphically.
4. Click “OK” toinsert the existing project into the workspace.

Note:  When an existing project is being inserted into a workspace, the CPU family and tool
chain upon which that project is based must match those of the current workspace. If they
do not then the project cannot be inserted into the workspace.

211  Specifying Dependencies between Projects

The projects within a workspace can be dependent upon one another so that when one project is
built, al its dependent projects are built first. Thisisuseful if another project uses one of the
othersin the workspace. For example, imagine that a workspace contains two projects. The first
project isalibrary that isincluded by an application project. In this case the library must have
been built and up to date before the second application can build correctly. To achievethis
situation we can specify the library as a dependent (i.e. child) project of the application project.
Thiswould then allow the library to be built first if it is out-of-date.

When a dependent project is built the HEW attempts to match the configuration in the dependent
project with that of the current project. This meansthat if the current configuration is * Debug”
then the HEW will attempt to build the “Debug” configuration in the dependent project. If this
matched configuration does not exist then the HEW will use the configuration that was last used in
the dependent project.

S To make projects depend upon another:

1. Select [Project->Dependent Projects]. The “Dependent Projects’ dialog will be
displayed.(figure 2.24)

2. Select the project to which you would like to add dependents to. When you do this, the
“Dependent projects” list will display all of the projects in the workspace (excluding the
selected project).

3. The*Dependent projects” list has a check box for each project listed. Set the associated
check boxes to make those projects depend upon the sel ected project.

4. Click “OK” to confirm the new project dependencies.
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Dependent Projects

[ 2]
I main_project j
Cancel |
Dep
[ Jdepend02
44| o

Figure 2.24Dependent Projects dialog
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212 Removing a Project from a Workspace

2 Toremove aproject from aworkspace:

1. Select the project from the “Projects’ tab of the “Workspace” window and click the right
mouse button to invoke a pop-up menu.

2. Select the[Remove Project] option.

or:

1. Select the project from the “Projects’ tab of the “Workspace” window.
2. Pressthe DEL key.

Note:  You cannot remove the current project from the workspace.

2.13  Loading/Unloading a Project to/from a Workspace

2 Toload aproject to aworkspace:

1. Select the project that has been unloaded from the “ Projects’ tab of the “Workspace’
window.

2. Click the right mouse button to invoke a pop-up menu and select the [L oad Project] option.

2 Tounload aproject from aworkspace:
1. Select the active project from the “ Projects’ tab of the “Workspace” window.

2. Click the right mouse button to invoke a pop-up menu and select the [Unload Pr oj ect]
option.

Note: Itispossibleto select severa projects at the same time and load or unload all of them.
Thisis more efficient than loading or unloading each of the projectsindividually.
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2.14  Relative Projects Pathsin the Workspace

In the High-performance Embedded Workshop when you add a project to the workspace you can
choose to add the project to the workspace using arelative path. This allows you to position a
project above the workspace directory and it will still be relocated correctly if you relocate the
HEW workspace. The project is always relative to the workspace so if the project is one directory
above the workspace before it is moved the HEW will try to find the project in the same relative
location after the relocation procedure. Thisis especially useful if you are using a project shared
between more than one workspace.

In older versions of the HEW this project would not have been rel ocated and would have still tried
to access the original project path. The older version of the HEW could only relocate the projects,
which were in a subdirectory of the workspace directory. Thisis till the standard behavior for the
High-performance Embedded Workshop.

2 To change aprojects relative path flag:
1. Select the project in the workspace window.
2. Right click and then select properties.

3. Click the “Project relative file path” checkbox to switch on or off the relative file path
feature. (figure 2.25)

4, Click “OK".
demo._c Properties 7| x|
Mame: demo.c
Loc:ation: C:AHewtdemotdematdemo.c
Cancel |
Lazt modified:  16:03:44, Monday, March 11, 2002

[ Project relative file path

Figure 2.25: Properties Dialog
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3. Advanced Build Features

This chapter explains the more advanced build concepts.

31 The Build Process Revisited

Chapter 2, “Build Basics’ began by describing the build process in terms of a compiler, an
assembler and alinker (figure 2.1). Thiswill be the case for most installations of the High-
performance Embedded Workshop. However, if you want to begin changing the build process (e.g.
adding and removing phases) then it isimportant to understand more about the way in which a
build functions.

311 What isa Build?

Building a project means applying a set of tools upon certain input filesin order to produce the
desired output. Thus, we apply a compiler upon C/C++ source filesin order to create object files,
we apply an assembler upon assembler source filesin order to create object files and so forth. At
each step or “phase” of the build, we apply a different tool upon a different set of input files.
Figure 3.1 presents another view of the build process.
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B seon 2

]

PHASE 1

-0

Phase 1 Input Files

}

Phase 1 Output Files

~]—

PHASE 2

-0

Phase 2 Input Files

}

Phase 2 Output Files

]

PHASE 3

-0

Phase 3 Input Files

Phase 3 Output Files

~]—

PHASE X

-0

Phase X Input Files

}

Phase X Output Files

Figure 3.1: Build Process

The High-performance Embedded Workshop provides the ability to change this build process via
its“Build Phases’ dialog, which can be, accessed viathe [Options->Build Phases...] (figure 3.2).
On the left-hand side are the phases that are defined in the current project (Figure 3.2 shows a
standard set of build phases). The remainder of this chapter details the various functions that the
“Build Phases” dialog provides.
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Build Phazes

Build Order | Build File Order | File Mappings |

Build phaze order:

[w]SH C/C++ Library Generator
[w|SH C/C++ Compiler

[w]SH Agzzembler

[w| O ptLinker

o

fadity.
Hemoye
fEwe

i EwE [ Et

L

Irnpaoit...

)4

| Cancel |

Figure 3.2: Build Phases Dialog
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3.2 Creating a Custom Build Phase

If you want to execute another tool before, during or after a standard build process then this can be
achieved by creating your own (i.e. custom) build phase.

Select [Options->Build Phases...] to invoke the “Build Phases’ dialog (figure 3.2) and then click
the “Add...” button. Thiswill invoke the new build phase wizard dialog (figure 3.3a).

Thefirst step (as shown in figure 3.3a8) asks whether you want to create an entirely new phase or
whether you want to add a system phase. A system phase isa“ready made” phase whichis
aready defined within the toolchain you are using (e.g. compiler, assembler, linker, librarian, etc.)
or autility phase (e.g. file copy, complexity anayzer etc.).

The“Add an existing system phase” button isinactive if no more system phases are available.
Select the “ Create a new custom phase” button to create your own build phase.

Mew Build Phase - Step 1 of 4 K E

Wwhhat type of phaze would you like to add 7

@ Create a new custom phase

£ Sdd & evisting epsten phase:

Systemn Phase | Y ergion |

< Hack | Hest » | Cancel

Figure 3.3a: New Build Phase Dialog (Step 1)
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The second step (figure 3.3b) asks what type of phase you would like to create. There are two
choices: multiple or single. When a multiple phase is executed, the command is applied to each
file in the project of a certain file group. For example, if you set the input file group to be C source
files then the command will be executed once for each C source file in the project. A single phase

is executed once at most during a build.

Mew Build Phase - Step 2 of 4 K E
N

Wwhhat tppe of phaze would you like to create’?

& Multiple phase:

The command iz applied ta each file in a file group.
A example of thiz tvpe of tool iz & compiler or azzembler.

Select input file group:

C zource file

" Single phase:

The command iz only ever executed once per build,
A example of thiz type of tool iz a linker.

< Back | Hest » | Cancel

Figure 3.3b: New Build Phase Dialog (Step 2)

Theinput file group list contains the current file groups defined for the project. It is possibleto
define multiple input file groups by selecting the “Multiple Groups...” entry in the input file group
list. Selecting thislist entry displaysthe dialog in figure 3.3c.
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Select Groups

[ |Azzembly zource file
[ ]Binary file

[IC header file

1L list file

(w|C zource file

[ ]C++ header file
[IC++ ligt file

ML ++ source file
[ ICPU information file

[ Expanded aszembly zource file 'l
4 I I 3

=

Cancel

i

Figure 3.3c: Modify multiple input file groups

Once this choice has been made the input file group selection is displayed as “Multiple Groups...

”

This dialog allows the user to choose multiple input file groups for the custom phase being added
tothe project. To select afile group check the box next to the file groups name. One or morefile

groups can be selected in thisdialog.
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The third step (figure 3.3d) requests the fundamental information about the new build phase. Enter
the name of the phase into the “Phase name” field. Enter the location of the program file into the
“Command” field (do not insert any command line options as these options are specified viathe
[Options] menu of the HEW menu bar). Specify the default options for the phase (i.e. what
options you would like new files to take when added to the project) into the “Default options”
field. If you have a preferred directory in which you would like this program to run from (i.e.
where you want the current working directory to be set to before the tool is executed) then enter it
into the “Initial directory” field.

Mew Build Phase - Step 3 of 4 HE
)

Phasze name:
IM wPhasze

Command [excluding parameters):
Ic:'\tu:u:uls'\m_l,ltu:u:ul.e:-:el | 3 | Browse. . |

Default options:

[${FULLFILE) Ll

Initial directony:

[${CONFIGDIR | Bomwse. |

¢ Back | Mest » | Cancel |

Figure 3.3d: New Build Phase Dialog (Step 3)

57

RENESAS




High-performance Embedded Workshop User Manual

The fourth and final step (figure 3.3€) allows you to specify any environment variables, which the
phase requires.

Mew Build Phase - Step 4 of 4 K E

Does the command require any environment variables to be zet?

If 2o, enter them into the lizt below;

ErN=1024

ity |
Eemoye |

KN — i

[ Bead Output O Fly

< Back | Finizh | Cancel

Figure 3.3e: New Build Phase Dialog (Step 4)

To add anew environment variable click the “Add...” button (the dialog shown in figure 3.4 will
be invoked). Enter the variable nameinto the “Variable” field and the variable’' s value into the
“Value” field and then click “OK” to add the new variable to the list of the fourth step. To modify
an environment variables select the variable in the list and then click the “Modify...” button.
Make the required changes to the “Variable” and “Value” fields and then click “OK” to add the
modified variable to the list. To remove environment variables select the variable that you want to
remove from the list and then click the “Remove” button.
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Environment ¥anable E E |
Wariable:
= OF.
o ok |
Cancel |

Walue:

. - b - | Flazehelder
Iu:.'xu:lu:us,n:.'xrn_l,ltu:u:uls,c.'xwmdu:uws,u:.'xtemp Ll s

Figure 3.4: Environment Variable Dialog

If the tool you are adding can display its output as the tool is running then use the * Read Output
On Fly’ option. Thiswill display the tool output as each line of output happens. If thisoptionis
set to off then the HEW will store all output, which is being displayed by the tool, and display it in
the output window when the tool has finished its operation. This can be a problem when the tool
is running an operation that might take many minutes, asit is difficult to see the progress of the
current execution.

Note: Using ‘Read Output On Fly’ can cause problems when using certain tools on certain
operating systems. If you are having problems with tools locking up or freezing in HEW
then uncheck the ‘Read Output On Fly’ option.

Click the “Finish” button to create the new phase. By default the new phase is added to the bottom
of the “Build Phase Order” list in the “Build Order” tab of the “Build Phases’ dialog (Figure 3.2).

3.3 Ordering Build Phases

In astandard build (shown in figure 3.5), you could add a phase at four different positions: before
the compiler, before the assembler, before the linker or after the linker. Y ou may place your own
custom phases or move system phases to any position in the build order. It isimportant to
remember that if the output of your custom phase can be input into another phase then the phase
order must be correct if the build is to behave as intended.
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(—
| «
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()

®

LINK

°£I

Figure 3.5: Typical Build Process

The build phase dialog provides facilities for ordering build phases via the “Build Phases’ diaog.
It has two tabs, which are concerned with the ordering of phases: “Build Order” and “Build File
Order”.
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331 Build Phase Order

The “Build Order” tab (figure 3.6) displays the current order in which phases will be executed

indicates whether or not it is currently enabled. By clicking this box, the phase can be toggled on
or off.

Build Phases HE|
Build Order | Build File Order | File Mappings |

Build phaze order:

[w]SH C/C++ Library Generator
[w|SH C/C++ Compiler

[w]SH Agzzembler fadity.
[w| O ptLinker

Hemoye
fEwe

i EwE [ Et

4 I I ﬂ Irnpaoit...

L

(] | Cancel |

Figure 3.6: Build Phases Dialog Build Order Tab
In addition the following operations can be performed:

2 Toremove aphase:
1. Select the phase that you would like to remove.
2. Click the “Remove” button.
S Toview the properties of a system phase:
1. Select the system phase that you would like to examine.
2. Click the“Modify...” button.
S Tomove aphase:
1. Select the phase that you would like to move.
2. Click the“Move Up” or “Move Down” button.
S Toimport aphase:
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Click theimport button. A dialog is displayed which alows the user to browse to an
existing project to import a custom phase from.

Choose the location of the project you wish to import a custom phase from. Once selected
adiaog is displayed which lists the custom phases in the imported project.

Selecting a phase name and then clicking properties displays the custom phase details.
This allows you to decide whether the phase does the functionality you require.

Once you have decided which phase to import highlight it in the list and then click OK.
The phase will then be added to the build phases dialog at the bottom of the build order.
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2 To modify acustom phase:

1
2.

Select the custom phase that you would like to modify.

Click the “Modify...” button. The modify phase dialog will be invoked with the
“Command” tab selected (figure 3.7).

Change the contents of the fields as appropriate.

Set the “Don’t check for input file(s) existence before executing” check box if you don’t
want the HEW to abort the execution of the phase if any of the input filesdon’t exist.

Modify MyPhase [ 2] %] |

Command | Environment I

LCommand [excluding parameters]:

ICZ"-.tDEﬂS"-.I‘I‘I_','tDCILEHE ﬂ Browse. .. |

Initial dirgcton:

[$ICONFIGDI] | Browss. |

[ Don't check: far input file[z) existence befaore executing

™ Read Output O Fly

(] I Cancel

Figure 3.7: Modify Phase Dialog Command Tab

Select the “Environment” tab (figure 3.8) to edit the environment settings for the phase.

Usethe“Add...”, “Modify...” and “Remove” buttons to add, modify and remove
environment variables. The operation is the same as discussed in the previous section.

Click “OK” when all modifications have been made.
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Modify MyPhase [ 2] %] |

Command Envhnnmentl

Ervironment zettings:

PATH=c: \dozc: vhools
SHOWALL=FALSE
EMY=1024

|
T

o Edifin.

HEmEvE

ok |

Cancel |
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Figure 3.8: Modify Phase Dialog Environment Tab
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3.3.2 Build File Phase Order

If you were to select a C source file from the “Workspace” window and then activate [Build-
>Build File] (or press &) you would expect the file to be compiled. Likewise, if you were to
select an assembly source file from the workspace window and then activate [Build->Build File]
you would expect the file to be assembled. The connection between file group and which phase(s)
to execute is managed by the “Build File Order” tab of the “Build Phases’ dialog (figure 3.9).

Build Phases EHE |

Build Order  Build File Order | File M appingz |

File group: Phasze order:
Azzembly zource file [w] Compiler
[v] M yPhase @

C++ zource file

A @

KN i
K. I Cancel |

Figure 3.9: Build Phases Dialog Build File Order Tab

Thelist displays all of the current phases that will be executed when the build file operation is
selected upon the file group shown in the “File group” list box. In figure 3.9 the “C source file’
file group is selected and the “ Compiler” and “MyPhase” phases are associated with it.

Entriesin the “Phase order” list, of the “Build File Order” tab, are added automatically as new
entries are added to the “Build Order” tab. For example, if you were to add a phase which takes C
source files as input then this phase will be automatically added to the list of phases to execute
when abuild file operation is applied to a C sourcefile. If you don’t want a certain phase to
execute when [Build->Build Fil€] is selected then clear the check box to the I€eft of the phase
namein the “Phase order” list.
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34 Setting Custom Build Phase Options

Once you have defined a custom phase, you will want to specify the command line options that
should be used when it is executed. Each defined phase has a menu option on the [Options] menu.
To specify options for that phase select it. The dialog that will be invoked depends upon whether
the custom phase selected was a multiple or single phase (according to the selection of phase type
in figure 3.3b).

Phasel... Dptions ed |
IDebug ﬂ Optionz | Dutput Files | Dependent Files
B- I@ hewtest = Command:
= a C zource file Ip:\_hew-files'\Dus&winduws executables\CMDLIME EXE
' . hewtest. o
|n|t$|:t|: Options:
: . $[FULLFILE)
= S E]| vecttblc
------ D Default Options
EEI---I@ hiewtest]
EEI---IE hewtest2
EIIE hewtestd
- a C zource file Placeholder

= . hewkestd.c -
ile: path + name - Inzer
----- iritzct.c | | |F| th =] Insert |
i intprg.c

5 shrk.c: =
1| ' | o]

] I Cancel |

Figure 3.10: Custom Options Dialog

Thediaog in figure 3.10 is a custom phase options dialog. The implementation of which is
dlightly different depending on whether you are using a multiple or single shot phase. On the left-
hand side is the project and filelist. It is possible to select multiple projects and filesin the same
way as Windows explorer to modify the options for more than one selection. On the right-hand
side are the 3 options tabs. Thisiswhere you set the options that you want to apply to the selected
file(s). You can also choose which configuration information is being viewed from the
configuration list on the upper left of the dialog box. Each configuration is listed along with a
special entry named “Multiple configurations...”. If you select multiple configurations then a
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dialog is displayed which allows you to select more than one configuration. This method is used
throughout HEW for modifying multiple configurations at once.

34.1 Options Tab

The “Options’ tab (figure 3.11) allows you to define the command line options that will be passed
to the phase. The “Command” field displays the command, which was entered when you defined
the phase (figure 3.3d). Enter into the “ Options’ field the command line arguments that you would
like to pass to the command. If you want to insert a placeholder, select the relevant placeholder
from the “Placeholder” drop-down list box and then click the “Insert” button. For a detailed
description of placeholders see appendix C, “Placeholders’.

Options | Oluatput Filesl Dependent Filesl

LCommand:
IE:\H e T oolchainzhHitachihSHAYE1DMBIMALEr. exe

Options:
-ub=$[CONFIGDIR] buildlib. zub

Flacehalder:

- - - Imsert butte
Configuration directary j Inzert :I—— f-:r:-leasel'nrder

] I Cancel |

Figure 3.11: Custom Options Options Tab

342 Output FilesTab

The *“Output Files” tab (figure 3.12) is where you can specify the output file or files that will be
produced by the phase. Before each file is passed into this phase, the HEW checks that the output
files are of aless recent date than the input file. If so, the phase will be executed for that file (i.e.
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input files have been modified since the output file or files were last produced). If the files are up
to date then the phase will not be executed.

Note: If no output files are specified, the phase will execute regardless.

Options  Output Files | Dependent Files

Dutput files:

SHCOMFIGD R hublibes. b

Add...
Modify. . |

Hemove

KN i
(] I Cancel

Figure 3.12: Custom Options Output Files Tab

S Toadd an output file:
1. Click“Add...”. The“Add Output File” dialog will be invoked (figure 3.13).
2. Enter thefile path or browse to it using the “Browse...” button.
3. Click “OK” to add this output file to the list.

68

RENESAS




High-performance Embedded Workshop User Manual

Add Cutput File

Flaceholder popup menu

Figure 3.13: Add Output File Dialog

S To modify an output file:

1. Select the output file that you would like to modify.
2. Click “Modify...”. The “Modify Output File’ dialog, which isthe same as figure 3.13

except the title, will be invoked.

3. Modify thefields as required and then click the “OK” button to add the modified entry

back to the list.
S Toremove an output file:

1. Select the output file that you would like to remove.

2. Click the “Remove’ button.
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343 Dependent Files Tab

The “Dependent Files” tab (figure 3.14) is where you can specify the dependent files that are
needed by the phase. Before each file is passed into this phase, the HEW checks that the
dependent files are of amore recent date than the input file. If so, the phase will be executed for
that file (i.e. dependent files have been modified since the input file or files were last modified). If
not, the phase is not executed for thefiles.

Options | Output Files  Dependerit Files |

&dd..

$ICONFIGDIR]MFilek.obj
FCOMFIGDIR]MFile? . obj :
${COMFIGDIR)Filed obj Modify.. |
o \HewhworkephProjecth D ebughFilel.obj
o \HewdworkephProjecth D ebughFileZ. obj Femove |
c:\HewwiorkspProjectsDebug'File 3. abj

o \HewhworkephProjecth D ebughFiled. obj

Figure 3.14: Dependent Files Tab in Custom Options
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S To add adependent file:
1. Click “Add...”. The“Add Dependent File” dialog will beinvoked (figure 3.15).
2. Enter thefile path or browse to it using the “Browse...” button.
3. Click “OK” to add this output file to the list.

Placeholder popup menu

Add Deperdent File 21

Ll Browse.. I Cancel |

Figure 3.15: Add Dependent File Dialog

2 To modify adependent file:
1. Select the dependent file that you would like to modify.

2. Click “Modify...”. The “Modify Dependent File” dialog, which is the same as figure 3.15
except the title, will beinvoked.

3. Modify thefields as required and then click the “OK” button to add the modified entry
back to the list.

S Toremove adependent file:
1. Select the dependent file that you would like to remove.
2. Click the “Remove’ button.
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35 File Mappings

By default, the filesinput to a phase are only taken from the project, i.e. al project files of the type
specified in the “ Select input file group” drop-down list on the “New Build Phase” dialog (figure
3.3b). If you would like a phase to take files output from a previous phase (i.e. intermediate files)
then you must define thisin the “File Mappings™ tab of the “Build Phases” dialog (figure 3.16).

Build Phases HE|

Build Order I Build File Order ~ File Mappings |

Intermmediate file mappings for build;

Source | Dezstination | File Group | Add
Azzembler Linker Object fle
Compiler Linker Object file Fladif.,

Hemmve

il

0k Cancel

Figure 3.16: Build Phases Dialog File Mappings Tab
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A file mapping states that you would like the HEW to pass output files of a certain type produced
by one phase (referred to as the source phase) to another phase (referred to as the destination
phase). Such intermediate files are passed in addition to the project files.

© To add afile mapping:

1
2.

Click “Add...”. The “Define File Mapping” dialog will be invoked (figure 3.17).

Select the file group, which you want to pass between the phases from the “File group”
drop-down list box.

Select the source phase (i.e. which phase generates the files) from the “ Source phase” drop-
down list box.

Select the destination phase (i.e. which phase takes these files) from the “ Destination
phase” drop-down list box.

Click “OK” to create the new mapping.

Define File Mapping EE |
File group:
| Obiect file = Cancel_|
Source phase:
I.-'l'-.ssembler j

Destination phaze:

Figure 3.17: Define File Mapping Dialog

S To modify afile mapping:

1.

Select the mapping to be modified.

2. Click “Modify...” button. The “Define File Mapping” dialog will be invoked (figure 3.17).
3.
4, Click “OK” to commit the changes.

Modify the options as necessary.
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3.6 Controlling the Build

By default, the High-performance Embedded Workshop will execute all of the phasesin a build
and only stop if afatal error is encountered. Y ou can change this behavior by setting the controls
on the “Build” tab of the “Options” dialog (figure 3.18).

Options E

Build lEditu:ur ] Wurkspace] Eu:unfirmatiu:un]

Errarz and warnings:

[ iStop build if the no. of ermors excesd:
[+ Stop build if the no. of warmings exceed: 10
Show:

[ Command line
[ Erwironment

[ Iritial direchany

(] | Cancel

Figure 3.18: Options Dialog Build Tab

Select [Tools->Options...] to invoke the dialog. If you want to stop the build when a certain
number of errors are exceeded then set the “ Stop build if the no. of errors exceed” check box and
then specify the error count limit in the edit field to the right. If you want to stop the build when a
certain number of warnings are exceeded then set the “ Stop build if the no. of warnings exceed”
check box and then specify the warning count limit in the edit field to the right.
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Note: Irrespective of what these controls are set to, the build will always halt if afatal error is
encountered.

In addition to specifying error and warning count limits, the “Build” tab also allows you to request
that the command line, environment and initial directory of each execution should be displayed.
Check the appropriate check boxes as necessary.

3.7 L ogging Build Output

If you would like to write the results of each build to file then invoke the “ Customize” dialog by
selecting [Tools -> Customize...] and select the“Log” tab (figure 3.19). Set the “ Generate log
file” check box and then enter the full path of the log file into the “ Path” field or browse to it
graphically by clicking the “Browse...” button.

Costomize B

Tu:uc:ll:uarsl Eu:ummandsl b e I Debugger Log |HEI|:| I

¥ Generate log file;

Path:

I$[‘WIZ|HKSPDIHMMDHKSF‘N&ME].IDQ{ Ll Browse... |

QF. I Cancel

Figure 3.19: Tools Customize Dialog L og Tab
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3.8 Changing Toolchain Version

If two or more versions of the same toolchain are registered in the HEW, you can choose a version
of the toolchain on the “Change Toolchain Version” dialog shown in Figure . To invoke the dialog,
select [Tools->Change Toolchain Version...]. Choose one of the versions from the “ Available
versions” drop-down list and click the* OK” button to enforce your choice.

Change Toolchain Yersion

T oolchain name: Hitachi SuperH RISC engine

Current wversion; B.0A Cancel

Sevailable verzions: IE 0.4

| rfarmation

M.

Toolchain build phases: (700

Build phaze | Yerzion |
OptLinker V.08
SH Azzembler A.0B
SH C/AC++ Compiler .04
SH C/C++ Library Generator 1.04

Figure 3.20: Change Toolchain Version Dialog

To show information of toolchain components select atool from the “Toolchain build phases” list
on the “Change Toolchain Version” dialog and click the “Information” button. Then atool
information dialog (figure 3.21) will show you the information of the tool. Click the “ Close”
button to close the dialog.
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5H C/C++ Compiler Information EE

Infarmation:

SuperH RISC engine CAC++ Compiler Yer. 7.0 ;l
Capyright [C] 1992,2000 Hitachi,Ltd. Hitachi Saftware Engineering Ca.,Ltd.
Licenzed Material of Hitachi,Ltd. Hitachi Software Engineering Co.,Ltd)

f o

Figure 3.21: Toolchain Information Dialog

3.9 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. If you want to
use another debugger then you must add it to the Tools menu (as described in chapter 6,
“Customizing the Environment”).

The “Debugger” tab of the “Customize” dialog (figure 3.22) iswhere the HDI-related information
isconfigured. You may wish to use an older version of the debugger if certain targets are not
currently supported in the new environment. Invoke it by selecting [T ools->Customize...] and
then selecting the “Debugger” tab.
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Costomze L EE]
Tu:uull:uarsl Eummandxl Menu  Debugger | Log I Help I

¥ Use external debugger

HDI location (4.0 ar greater):

IE:HH e HOISAS IMASH Y H L e ll Browsze. .. |

Sezzion file;

|$[EDNFIGDIH]H$[F'F|DJEET MNAME) hds Ll Browse... |

Download module;

I$[EDNFIGDIH]H$[PHDJEET MAME]. abd Ll Browse... |

(] I Cancel

Figure 3.22: Customize Dialog Debugger Tab

When an external debugger is used, check ‘Use external debugger’ and then set the following
items. Firstly, the location of the HDI executable must be specified. This must be version 4.0 or
greater otherwise the behavior is not guaranteed. The second item of datais the session file. This
tells HDI which session to load when it is launched. Finally, the location of the download module

isrequired. Thisalowsthe HEW to automatically switch to HDI when the download module
changes after abuild.
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Click the “Launch External Debugger” toolbar button to invoke HDI with the specified session
file:

After abuild, if the download module has been updated, the HEW will switch back to HDI to
enable immediate debugging. Whilst using HDI, double clicking in any source window will switch
back to the HEW with the source file open at the line which was double clicked.

3.10 Generating a Makefile

The HEW allows you to generate a makefile, which can be used to build parts of your workspace
without HEW. Thisis particularly useful of you want to send a project to a user who does not
have the HEW or if you want to version control an entire build, including the make components.

S Togenerate a makefile:
1. Ensure that the project, which you want to generate a makefile for, is the current project.

2. Ensure that the build configuration that you want to build the project with is the current
configuration.

3. Select [Build>Generate M akefile].

4. Once this menu has been selected a dialog is displayed which asks the user what parts of
the workspace need to be added to the make file. (See figure 3.23.)

5. Select the radio button which is relevant for your make file and then click OK.

Generate make file

X
£ {Far the cument configuiation in the curmently active projeck

™ For all configurations in the curmently active project Cancel

™ For all configurations and all projects in the current workspace

Figure 3.23: Generate makefile Dialog

The HEW will create a subdirectory “make” within the current workspace directory and then
generate the makefile into it. It is named after the selection, with a.mak extension for example the
current project and configuration(e.g. project_debug.mak). The executable HMAKE.EXE, located
in the HEW installation directory, is provided for you to execute the makefiles generated by the
HEW. It is not intended to execute makefiles, which have been user modified.

2 To execute amakefile:
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Open a command window and change to the “make” directory where the makefile was
generated.

Execute HMAKE. Its command lineis HMAKE.EXE <makefile>.

The degree portability of a generated makefileis entirely dependent upon how portable the
project itself is. For example, any compiler options, which include full paths to an output
directory or include file directory, will mean that, when given to another user with a
different installation, the build will probably fail. In genera use placeholders wherever
possible —using afull, specific path should be avoided when possible.
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4.  Using the Editor

This chapter describes how to use the editor that is provided with the High-performance
Embedded Workshop.

4.1 The Editor Window

The editor window (figure 4.1) contains the file windows that are being viewed or edited. Only
one window is active at anytime. Thiswindow is called the active window (or current window)
and itstitle bar will appear a different color from that of the others (“dbsct.c” is the active window
in figure 4.1). All text operations such as typing, pasting text and so forth only affect the active
window. To switch to another source file window (i.e. to make some other window the active
window) there are a number of methods:

e Clickonitifitisvisible.

e PressCTRL+TAB to cycle through the windows one after another.
e Select the window by name from the “Window” menu.

» Selectitstab at the bottom of the editor window.

When afile has been edited, an asterisk (*) is appended to the window’ s title bar. The asterisk
remains there until thefile is saved. The asterisk isalso removed if al of the edited changes are
undone in the current window.
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=

3% 1
<% FILE cdb=sct .o

<% DATE :Thu, Aug 1s,. 2001

<% DESCRIPTION :Setting of B.R Section

<% CPU TYPE (SH7020

Fe

<% Thi= file i= generated by Hitachi Project Generator (Ver. 2. 1).
2

ke

#pragma section $DSEC
=ztatic con=t struct {

char *rom_=;
char #*rom_e;
char *ram_s=:

FDTBL[]= 1

##% Start address of the initialized data =se
<% End address of the initialized data =ect
<% Start address of the initialized data ==

»

-

resetprg.c < dbecte [ shike
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Figure4.1: Editor Window
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4.2 Working with Multiple Files

Thefile areais where you will work with the files of your project. The editor allows you to have
many files open at one time, to switch between them, to arrange them in different configurations
and to edit them in whichever order you want to. The operations that you can perform upon the
windows are typical of most Windows® applications and they can be found under the [Window]
menu:

* [Window->Cascade]
Arrange all open windows so that they overlap, with the top left of each window visible.
e [Window->Tile Horizontally]

Arrange al open windows in sequence (horizontally) so that they occupy the entire editor
window with no overlapping edges.

o [Window->TileVertically]

Arrange al open windows in sequence (vertically) so that they occupy the entire editor
window with no overlapping edges.

e [Window->Arrange | cons]

Line up all minimized windows at the bottom of the editor window.
* [Window->Close All]

Close all open editor windows.

The files within the editor can be displayed in a*“notebook” style. This means that each file hasa
Separate tab associated with it to aid in navigating between files.

2 To show filesin notebook:

1. Select [Tools->Options...]. The “Tools Options’ dialog box will be displayed. Select the
“Editor” tab.

2. Set the “Show filesin notebook” check box as appropriate.
3. Click “OK” for the new settings to take effect.

4.2.1 The Editor Toolbars

The editor has four related toolbars: Editor, Search, Bookmarks and Templates. They provide a
shortcut to the functions of the editor, which you will use most often. The following sections
describe each buttons function.

422 Editor Toolbar Buttons

0O New File
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The new file button creates a new source file window with a default name. When you save thefile,
you can specify your own filename.

= Open File

Click this button if you want to open afile. It invokes a standard file chooser - select the file which
you want to open and then click “Open”.

= Save File
Saves the active sourcefile.
=] Save All Files

Saves dl of thefilesin the editor.

=] Print File

To print the contents of the current window, click this button.

3 Cut

Clicking this button will remove the current text selection and place a copy of it onto the
Windows® clipboard (it can be pasted back to afile with a paste operation).

Copy
This button allows you to copy the current text selection into the Windows® clipboard.
(& Paste

The paste button copies the contents of the clipboard into the active window at the position of the
insertion cursor.

iy Find

Click this button if you want to find a certain text string in the current file. It invokes afind dialog
box where you can specify the search parameters.

Cly Find in Files

To search severa filesfor atext string then click this button. All find results are displayed in the
“Find in Files” tab of the “Output” window. For further information, refer to the “ Searching and
Navigating Through Files” section later in this chapter.
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I M atch Braces

The match braces button highlights text between braces of type{ },[ ] and (). Thisis particularly
useful when attempting to find out the structure of C/C++ code blocks which are opened with

{ and closed with }. To useit, select the open brace to match from, or place the cursor before it,
and then click this button. For further information on brace matching, refer to the “ Brace
Matching” section later in this chapter.

ar Insert Template

Toinsert a pre-defined template at the current cursor position, click this toolbar button. The
“Insert Template” dialog box will be invoked. Select atemplate name and then click OK. For
further information on templates, refer to the “ Templates’ section later in this chapter.

i Toggle Bookmark

The High-performance Embedded Workshop editor provides standard bookmark capabilities. To
set abookmark, select the line to mark and click this button (a green mark will then appear in the
blank on the left side of the editor window). To remove a bookmark, select the line to remove a
bookmark and click this button (the mark in the blank on the left side of the editor window will
disappear). For further information on bookmarks, refer to the “Bookmarks’ section later in this
chapter.
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423  Search Toolbar Buttons
Gy Find in Files

To search severdl filesfor atext string then click this button. All find results are displayed in the
“Find in Files’ tab of the “Output” window. For further information, refer to the “ Searching and
Navigating Through Files’ section later in this chapter.

iy Find

Click this button if you want to find a certain text string in the current file. It invokes afind dialog
box where you can specify the search parameters.

ﬁ' Find Next

Finds the next occurrence of the current search string.

ﬁ Find Previous

Finds the previous occurrence of the current search string.

424 Bookmarks Toolbar Buttons

] Toggle Bookmarks

Sets abookmark at the current line or clears a bookmark at the current line.
o  Next Bookmark

Jumps to the next bookmark in the current file from the current line.

' Previous Bookmar k

Jumps to the previous bookmark in the current file from the current line.

ﬁ Clear All Bookmarks

Clears all bookmarksin the current file.

425 Templates Toolbar Buttons

Ir Define Template
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Specify template text for subsequent insertion.

r Insert Template

Insert the template selected in the drop-down list at the current cursor position.
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4.3 Standard File Operations

431 Creating a New File

S To create anew editing window:
Select [File->New] or click the new file toolbar button (1) or press CTRL+N.

The window will be given an arbitrary name by default. Y ou can provide a new name when you
savethefile.

4.3.2 Saving a File

S To savethe contents of an editing window:
1. Ensure that the window, whose contents you want to save, is the active window.

2. Select [File->Save] or click the save file toolbar button (&) or press CTRL +S.

3. If thefile has not been saved before, afile save dialog box will be displayed. Enter a
filename, specify adirectory and then click OK to create the file with the name given, in
the directory specified.

4, If thefile has been saved before, then the file will be updated (no dialog box will be
displayed).

2 To savethe contents of an editing window under a new name:
1. Ensure that the window, whose contents you want to save, is the active window.
2. Select [File->Save As...].

3. A filesavedialog box will be displayed. Enter afilename, specify adirectory and then
click OK to create the file with the name given, in the directory specified.
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4.3.3 Saving all Files

2 To savethe contents of every open editor window:

1. Select [File->Save All] or click the save all files toolbar button (fg).

2. If any of thefiles has not been saved before, afile save dialog box will be displayed. Enter
afilename, specify adirectory and then click OK to create the file with the name given, in
the directory specified.

3. If any of thefiles have been saved before, then the file will be updated (no dialog box will
be displayed).

434 Opening a File

S Toopenafile

1. Select [File->Open...] or click the open file toolbar button (&) or press CTRL +O.

2. An open file dialog box will be displayed. Use the directory browser (on the right) to
navigate to the directory in which the file you want to open is located. Use the “Files of
type” combo box to select the type of file you want to open (or set it to “All Files (*.*)" to
see every filein adirectory).

3. Onceyou have located the file select it and click “Open”.

The High-performance Embedded Workshop keeps track of the last five files that you have
opened and adds them to the file menu under the “ Recent Files’ sub-menu. This gives you a
shortcut to opening files which you have used recently.

S Toopen arecently used file:
Select the [File->Recent Files] menu option and from this sub-menu select the desired file.

Y ou can also open afileviathe “Projects’ tab of the “Workspace” window. Either double click
the file you want to open or select it, click the right mouse button (to invoke a pop-up menu) and
then choose the [Open <file>] menu option (where <file> is the name of the file selected).
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4.35 Closing Files

° Tocloseindividua files select one of the following methods:
0 Double click on the editor window’s system menu (located at the top left of each window
when not maximized).
O Click on the editor window’ s system menu (located at the top left of each window when
not maximized) and select the “Close” menu option.

0 Ensurethat the window that you want to close is the active window and then press
CTRL+F4.

0 Ensurethat the window that you want to close is the active window and then select
[File->Closg].
O Click onthe close button (located at the top right of each window when not maximized).
2 Tocloseall windows at once:
Select [Window->Close All].
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4.4 Editing aFile

The High-performance Embedded Workshop editor supports standard editing functionality. Thisis
available through the usual methods (i.e. the menu, toolbar and keyboard shortcuts) and is
additionally supported via a pop-up menu (or local menu) that islocal to each editor window. To
invoke it, place the pointer in an open window and click the right mouse button. Table 4.1 outlines
the basic operations that are provided by the editor.

Table4.1 Basic Editing Operations
Operation Effect Action
Cut Removes highlighted text and places it on the Click the cut toolbar button
Windows® clipboard Select [Edit->Cut]
Select [Cut] - local menu
Press CTRL+X
Copy Places a copy of the highlighted text into the  Click the copy toolbar button
Windows® clipboard Select [Edit->Copy]
Select [Copy] - local menu
Press CTRL+C
Paste Copies the contents of the Windows® Click the paste toolbar button
clipboard into the active window at the Select [Edit->Paste]
position of the insertion cursor
Select [Paste] - local menu
Press CTRL+V
Delete Removes highlighted text (it is not copied to  Select [Edit->Clear]
the Windows® clipboard) Select [Clear] - local menu
Press Delete
Select All Selects (i.e. highlights) the entire contents of ~ Select [Edit->Select All]
the active window Select [Select All] - local menu
Undo Reverses the last editing operation Select [Edit->Undo]
Select [Undo] - local menu
Press CTRL+Z
Redo Repeats the last “undone” editing operation Select [Edit->Red0]

Select [Redo] - local menu
Press CTRL+Y

RENESAS

91



4.5

High-performance Embedded Workshop User Manual

Sear ching and Navigating through Files

The High-performance Embedded Workshop editor provides find, replace and file navigation
functionality. The following three sections detail how to use these features.

451

Finding Text

2 To search for text in the current file:

1
2.

3.

Ensure that the window, whose contents you want to search, is the active window.
Position the insertion cursor at the point from which you want to start your search.
Select [Edit->Find...], press CTRL +F, select [Find...] from the editor window’s local

menu or click the find toolbar button #]). The “Find” dialog box will be displayed (figure
4.2).

Find HE|

Find what: [string =l Find Next |
™ Match whale word only Direction—— Cancel |

[ Match caze C Up
& Down

[™ Regular expression
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Figure4.2: Find Dialog

Enter the text that you want to search for into the “Find what” field, or select a previous
search string from the drop-down list box. If you select text before invoking the find
operation, the selected text will be automatically placed into the“Find what” field.
If you would like to search for character string as a whole word then check the “Match
whole word only” check box. When this option is not selected, the search will be for any
string that is matched by the search string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and
lower case letters) then check the “Match case” check box.
If your search string uses regular expressions then check the “ Regular expressions’ check
box. Refer to Appendix B, “Regular Expressions’ for further information.
The “Direction” radio buttons allow you to select the direction of the search. Selecting
“Down” means that the search will be performed from the insertion cursor towards the
bottom of the file. Selecting “Up” means that the search will be performed from the
insertion cursor towards the top of thefile.
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9. Click the“Find Next” button to begin the search. Click “Cancel” to stop the find action.

The High-performance Embedded Workshop editor aso allowsyou to search for a string across
many files.
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452 Finding Text in Multiple Files

S To search for text in many files:

1. Select [Edit->Find in Files...], select [Find in Files...] from the editor window’s local
menu or click the find in files toolbar button (5gl). The “Find in Files’ dialog box will be
displayed (figure 4.3).

Find In Files HE|

Find

Find: IM_I,IStruu:t

Cancel

In filez/types: I".u:;".cpp;*.e:-:p;*.fs_l,l;*.h;*.hpp;“.inc;*.lis;*.lp

1l

Directary Iu::'xhew'xdemu:u'xdemu:u Browse. ..

[ Match case W Search sub directonies

[ Regular expressions

Figure4.3: Find in Files Dialog

2. Enter the text that you want to search for into the “Find” field, or select a previous search
string from the drop-down list box. If you select text before invoking the find operation, the
selected text will be automatically placed into the “Find” field.

3. Enter thefile extensions of the files you would like to search into the “In files/types” field.
If several extensions are specified be sure to separate them with acomma (e.g. *.c,*.h).

4. Enter the directory in which you would like to search filesinto the “Directory” field.
Alternatively you may browse to the desired directory graphically if you click the
“Browse...” button.

5. If you would like to search the directory specified and all directories below it then check
the* Search sub directories” check box. If you just want to search the single directory
specified in the “ Directory” field then ensure that this check box is not checked.

6. If you would like to search for character string as a whole word then check the “Match
case” check box. When this option is not selected, the search will be for any string that is
matched by the search string.

7. 1f you would like your search to be case sensitive (i.e. to distinguish between upper and
lower case letters) then check the “Match case” check box.

8. Click “Find” to begin the search. Any matches found will be displayed in the“Find in
Files’ tab of the “Output” window. To jump to an instance of the string, double click on
the desired entry in the “ Output” window.
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453 Replacing Text

Replacing text is similar to finding text, as discussed in the previous section. The differenceis that
when the text is found you have the option to replace it with other text.

S Toreplacetextin afile:

1. Ensure that the window, whose contents you want to replace, is the active window.

2. Position the insertion cursor at the point from which you want to start your search.

3. Select [Edit->Replace...], press CTRL+H or select [Replace...] from the editor window’s
local menu. A replace dialog box will be displayed (figure 4.4).

4. Enter the text that you want to search for into the “Find what” field, or select a previous
search string from the drop-down list box. If you select text before invoking the replace
operation, the selected text will be automatically placed into the“Find what” field.

5. Enter the text that you want to replace the search string with into the “Replace with” field,
or select a previous replace string from the drop-down list box.

Feplace 21 x

Find what: [strine ~|
Replace with: frumeric | Replace |

[~ Match whale word anly Replace lh————— Replace Al |

[ Match caze ! Belection

[~ Reeular expression f* Whale file ﬂl
= Al open files

Figure 4.4: Replace Dialog

6. If you would like to search for character string as a whole word then check the “Match
whole word only” check box. When this option is not selected, the search will be for any
string that is matched by the search string.

7. If you would like your search to be case sensitive (i.e. to distinguish between upper and
lower case |etters) then check the “Match case” check box.

8. If your search string uses regular expressions then check the “Regular expressions’ check
box. Refer to appendix B, “Regular Expressions’ for further information.

9. If you clicked “Find Next”, the editor will search for the first occurrence of the search
string. Click “Replace” if you want to replace it. Click “Replace All” to replace all
occurrences or click “Cancel” to stop the replace action. If you select “ Selection” in
“Replace In”, selected range of the text is replaced. If you select “wholefile”, the whole
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filesarereplaced. If you select al open files, al filesthat are currently open in the editor
have the replace operation carried out on them.

454 Jumping to a Specified Line

S Tojumptoalineinafile:
1. Ensure that the window, whose contents you want to replace, is the active window.

2. Select [Edit->Goto Line...], press CTRL+G. or select [Goto Line...] from the editor
window’slocal menu. A goto line dialog box will be displayed (figure 4.5).

3. Enter into the dialog box the number of the line that you want to go to, and then click “OK”.
4. Theinsertion cursor will be placed at the start of the line number specified.

Goto E E

Line number I'I
0k, I Cancel |

Figure 4.5: Goto Dialog

4.6 Bookmarks

When working with many largefiles at atime, it can become difficult to locate specific lines or
areas of interest. Bookmarks enable you to specify lines that you want to jump back to at a
subsequent time. One example of itsuseisin alarge C file where you may want to set a bookmark
on each function definition. Once a bookmark has been set, it exists until it isremoved or the file
is closed.

S To set abookmark:
1. Placetheinsertion cursor on the line to mark.
2. Select [Edit->Bookmarks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button
(=)
3. A green mark appearsin the blank on the left side of the line to indicate the presence of an
active bookmark.

9 Toremove abookmark:
1. Placetheinsertion cursor on the marked line.
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. Select [Edit->Bookmarks->T oggle Bookmark], press CTRL+F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button

().

. The mark will be removed and the line will return to normal text.
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S Tojump to the next bookmark in afile:

1. Ensure that the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmarks->Next Bookmark], press F2 or select [Bookmar ks->Next
Bookmark] from the local menu or click the next bookmark toolbar button ( ﬁ ).

S Tojump to the previous bookmark in afile:

1. Ensurethat the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmarks->Previous Bookmark], press SHIFT+F2 or select
[Bookmar ks->Previous Bookmark] from the local menu or click the previous bookmark
toolbar button ( ﬁ% ).

< Toremoveal bookmarksin afile:
1. Ensure that the window, whose bookmarks you want to remove is the active window.
2. Select [Edit->Bookmarks->Clear All Bookmarks] or select [Bookmarks->Clear All

Bookmarks] from the local menu or click the clear all bookmarks toolbar button ( 2).

4.7 Printing aFile

S Toprintafile
1. Ensure that the window, whose contents you want to print, is the active window.
2. Select [File->Print...], or click the print toolbar button (&) or press CTRL+P.
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4.8 Configuring Text Layout

The following sections detail how to set-up the layout of the text within the editor windows.

48.1 Page Set-up

When you print afile from the High-performance Embedded Workshop editor, the settingsin the
print dialog box affect the way in which thefile is printed (e.g. double or single sided). Control
over how the text is formatted on the page can also be controlled via the page set-up option. This
alows you to specify the margins (top, bottom, left and right) of your printouts. It is often
necessary to set this because some printers cannot print to the edges of an A4 page. Furthermore,
some users have their own layout requirements (e.g. alarge left hand margin so that code can be
placed in an A4 binder).

S To set-up the page margins:
1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the edit fields the margins required (set the “inch” or “mm” radio buttons to set
the measurements).

3. Click “OK” for the new settings to take effect.

Page Setup E
Margin:

Left: |IE Bight: |n—
Top: ID— Bottom: ID—

&+ |nch " mm
Header:
| 1
Footer:
| 13
Ok I Cancel |

Figure 4.6: Page Setup Dialog
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S To set-up the page header and footers:

1
2.

100

Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).

Enter into the header and footer edit fields the text required to be displayed. All normal
placeholders are available along with page numbering, text justification and date fields.
These are al expanded before the page is to be printed.

Click “OK” for the new settings to take effect.
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482 Changing Tabs

° Tochangetab size:

1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “ Editor” tab
(figure 4.7)).

2. Enter into the“Tab size” field the number of desired tabs.
3. Click “OK” for the tab setting specified to take effect.

S 1]

Buid  Editar |Wurkspace| Eu:unfirmatiu:unl

Tab size: I 4

— General:
V¥ Save files before executing any tools [ Show files in notebook
™ Prompt before saving files ¥ Enable syntax coloring
— External editor:

[T Use external editor:

| el |

(] I Cancel

Figure 4.7: Options Dialog Editor Tab

When aTAB key is pressed in the editor atab character is usually stored in the file. However,
sometimesit is preferable to store spaces instead. The representation of tab characters can be
controlled viathe “Options’ diaog.

2 To use spaces as tabs:
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1. Select [Tools->Options...]. The “Options” dialog will be displayed. Select the “Editor” tab
(figure 4.7).

2. Set the “Use spaces astabs’ check box as appropriate.

3. Click “OK” for the tab setting specified to take effect.

483 Auto Indentation

When you press return in a standard editor the insertion cursor will move to the next line down, at
the first column (i.e. against the left hand side of awindow). Auto Indentation is a feature which,
when return is pressed, places the insertion cursor on the next line (as before) but under the first
non-white space character of the previous line. This enables you to type neat C/C++ or assembler
code faster as you don’t have to type leading spaces or tabs yourself.

Figure 4.8 illustrates two examples. Thefirst (i) shows the effect of pressing return when the auto
indentation feature is disabled - the insertion cursor returns to the left-hand side of the window on
the next line. When the line “int z=20" istyped, it is not aligned with the previous two lines. The
second example (ii) shows the effect of pressing return when auto indentation is enabled - the
insertion cursor drops underneath the “i” of the previous line. Now, when the line “int z=20" is
typed, it is automatically aligned (i.e. automatically indented).

void myfunction(void) void myfunction(void)
{ {
int x=5; int x=5;
int y=10; int y=10;
Y= =0
int z=20; int z=20;
i) Auto Indentation Disabled i) Auto Indentation Enabled

Figure 4.8: Effect of Auto Indentation

2 To enable/disable Auto Indentation:

1. Select [Tools->Options...]. The “Options” dialog will be displayed. Select the “Editor” tab
(figure 4.7).

2. Set the “Enable auto indentation” check box accordingly.
3. Click “OK” for the setting of the auto indentation check box to take effect.
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4.9 Splitting a Window

The High-performance Embedded Workshop editor allows you to split atext window into two.
Figure 4.9 shows the split bar button which islocated just underneath the maximize button at the
top right hand corner of any text window.

Figure4.9: Split Bar Button

S Tosplit awindow:

Double click on the split bar button to split the window in half or click on the split bar button,
keep the button pressed, move the mouse down and then rel ease the mouse button at the point
you want to split the window.

S To adjust the position of the split bar:

Click on the split bar itself, keep the button pressed then move the bar to the new position and
then release the button.

S Toremove the split bar:
Double click on the split bar or move the split bar to the top or bottom of the window.
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4.10 Configuring Text

The following sections detail how to change the appearance of the text displayed in the editor
windows.

4.10.1 Changing the Editor Font

The High-performance Embedded Workshop allows you to specify the font to be used in its
internal editor. All editor windows, regardless of the file type, use the same font.

2 To change the editor font:

1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed. Select the
Source icon in the tree (figure 4.10).

2. Select the desired font from the “Font” list.
3. Select the size of the font from the “ Size” list.
4, Click “OK” to confirm the new editor settings.
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Format Yiews EE |

= ] Source |~ Fort |

i [§ Selected Test
i O Test

-2 Assembly include file
[0 Azzembly list file
-2 Assembly source file Fart
|23 C header file
-2 Clist file

-2 C source file
-2 Ca+ header file
[ Tt list file

-2 C+ source file I-“:I jv
|20 Expanded assembly :
-2 He file |
|23 Library information File
-2 Linkage map file

: |23 Linkage symbal file |+
« | |
S i e 0k | Cancel

HEW Samnple Text

Figure4.10: Format Views Dialog Font Tab

411  Syntax Coloring

To enhance code readability, the HEW editor can display specific strings (i.e. keywords) in
different colors. For instance, C source code comments could be shown in green and C types (e.g.
int) could be shown in blue.

The coloring method used can be specified on afile group by file group basis. For example, you
can define different color schemes for a C sourcefiles, text files, map files or even your own files.

2 To changeexisting colors:
1. Select[Tools->Format Views...]. The “Format Views’ dialog will be displayed.

2. Select the item underneath the icon in the tree you wish to modify the colour for. This
should be the file type (e.g. C source file) and correct keyword group (e.g. identifier or
pre-processor).

3. Select the“Colour” tab.
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4, Modify the “Foreground” and “Background” color lists as desired. The color “ System”
refers to the current window foreground and background settings in control panel.

5. Click “OK” for the new colors to take effect.

S To create new keyword groups:
1. Select[Tools->Format Views...]. The “Format Views’ dialog will be displayed.
2. Select thefiletypein the tree to which you wish to add the new keyword group.

3. Click “Add...” underneath the tree. The “ Add Category” dialog box will be displayed
(figure 4.11). Enter the name of the keyword group in the “ Category Title” field, then click
“OK” to create the new keyword group.

Add Category EE
Categony Title: (] I

fl
Cancel |

Figure4.11: Add Category Dialog

S To create new keywords:
1. Select[Tools->Format Views...]. The“Format Views’ dialog will be displayed.

2. Select the item underneath the source view icon in the tree you wish to modify the syntax
highlighting for. This should be the file type (e.g. C source fil€e) and correct keyword
group (e.g. identifier or pre-processor).

3. Select the “Keywords’ tab (figure 4.12).
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Format Yiews EE |

El-[F] Source = I:u:uh:uurl Font  Kepwords | Enmmentsl

|:| All

|:| Azzembly include file

fel- [ Aissembly st file _ — : :

|:| Aszzembly source file case : :

-2 C header file continue

[ Clist file defaul ﬂl

=2 I:l C zource file di:'

o [ Comrments F,::E

¢ [} |Contral goto

. 1 Declaration i

..... [y Operator retgmh

- ) PreProcessor fvﬂitlg

~[[3 C#+ header file

-2 T list file

- C++ source file

|:| Expanded azzembly :

|:| He file = HEW Samnple Text
e

pdd | Modiy | Bemove | ok | Cancel |

Figure 4.12: Format Views Dialog Keywords Tab

4. Click the“Add...” button to add a keyword. Then the “Add Keyword” dialog (figure 4.13)
will be launched. Specify a keyword in the “Keyword” field and click “OK” to close the
dialog. To remove akeyword, select the keyword and click the “Remove” button.

Add Keyword EHE

Keyword: oK

| |
Cancel

Figure 4.13: Add Keyword Dialog

When you create anew file, syntax coloring will not be active as a new file does not initially have
an extension (new files are named arbitrarily by the editor without an extension). In order to
activate syntax coloring, you must save the new file with aname, which has one of the above
extensions.
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2 Todisable/enable syntax coloring:

1. Select [Tools->Options...]. The “Options” dialog will be displayed. Select the “Editor” tab
(figure 4.7).
2. Set the “Enable syntax coloring” check box as necessary and then click “OK”.

108

RENESAS



High-performance Embedded Workshop User Manual

412 Templates

When developing software it is often necessary to enter the same text repeatedly, for instance,
when typing afunction definition, for loop or acomment block for a function. The High-
performance Embedded Workshop editor allows you to specify a block of text (or template) which
can be inserted into the currently active editor window. Thus, once a template has been defined, it
can be automatically inserted without the need to re-enter it manualy.

412.1 Defining a Template

2 Todefine atemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define
Templates...] from the local menu, press CTRL+T or click on the define template toolbar
button (I’ ). The dialog shown in figure 4.14 will be displayed.

2. Click“Add". A didogisdisplayed that asksyou to enter your chosen template name.
This name must be unique otherwise a duplicated template name message will be
displayed and the template will not be added.

3. If you want to modify an existing template use the “ Template name” drop down menu to
select which template you want to modify.

4, Enter the desired text into the “ Template text” text area. Y ou can copy text from another
editor window and then pasteit into thisdialog using CTRL +V.

5. Enter the following keywords to insert special information when the template is inserted:

Menu Entry Placehol der Replaced With
Time $(TIME) Current time
DateasDMY $(DATE_DMY) Current date, in dd/mm/yy form
DateasMDY $(DATE_MDY) Current date, in mm/dd/yy form
Date as YMD $(DATE_YMD) Current date, in yy/mm/dd form
Date as Text $(DATE_TEXT) Current date in text form
Line $(LINE) First line number of template insertion
User $(USER) Current windows user
File $(FULLFILE) Name of the file
Filename $(FILE) Name and full path of thefile
Project Name $(PROINAME) Current project name
Workspace Name $(WORK SPNAME) Workspace name
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Cursor position $(*) Insertion cursor — Positions the cursor
in this position after template has been
inserted

6. Enter the $(") character to specify where the insertion cursor isto be placed after the
template has been inserted. If thisis not specified then the insertion cursor will be placed
after the last character in the template (asin anormal paste operation).

Define Template EH |

| =
d Cancel

add...

Hemmve

| o

Figure 4.14: Define Template Dialog

4122 Deletinga Template

2 Todeete atemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define
Templates...] from the local menu, press CTRL+T or click on the define template
bookmark toolbar button ( Ir ). The dialog shown in figure 4.14 will be displayed.

2. Usethe Template name drop down list to select the name of the template you wish to
remove and then click the “Remove” button.

3. Clicking “OK" saves the template changes and dismisses the dia og.
4123 Insertinga Template

S Toinsert atemplate:

1. Select atemplatein the toolbar, then click the insert template toolbar button (T ), select
[Edit-> Templates->Insert Template...] or select [Templates-> Insert Template...] from
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the local menu. The dialog is dismissed and the chosen template is added to the current
editor window.

4124  BraceMatching.

Complicated source code can often become unwieldy, especially when blocks of C code are
deeply nested within each other or when complex logic statements are expressed within an *if’
clause. To help in such situations, the High-performance Embedded Workshop editor provides a
match brace feature which highlights text between braces of type{ }, () and[].

S Tofind amatching brace:
1. Either highlight the open brace to match from or place the cursor beforeiit.

2. Click the match braces toolbar button ({ }), press CTRL +B, select [Edit->Match Braces]
or select [Match Braces] from the local menu.

To check the structure of an entire file, place the cursor at its start and then repeatedly invoke the
match brace operation. The editor will successively highlight each pair of bracesin turn until there
are no more to match.
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4.13  Editor Column management

The editor in HEW has the ability to manage columns apart from the main editor column. These
can be added and used by debugger feature. Y ou can choose the column to display/undisplay.

4 tutorial.c ] 3
#include <no_float.h> ZI
#include <stdio.h>
#include <math.h>
#include <{stdlib.h>
void main{uvoid);
void sort{long =a);
void change{long =a);
extern void srand{unsigned int);
0x00000a0c void main{void)
0x00000al6 {
long a[18], min, max;
long j;
int i;
000000218 srand(1);
0x00000a20 & printf("#t# Data Input #E#\N");
0x00000a2c for{ i=0; ic10; i++ )¢
0x00000a2e j = rand();
0x00000236 if(j < )¢
0=00000238 j = -i:
H
0=00000a3a a[i] = j:
0x00000244 printf(“a[%d]=%ld\n",i,a[i]};
H
0x00000a62 sort{a);
0=00000266 printf("=xx Sorting results =xx\n");
0x00000a72 for{ i=8; i<18; i++ }{
000000274 printf(“a[%d]=%1d\n",i,a[i]);
¥ v
. min _ armi. i

Figure 4.15: Editor columns

S Toswitch off acolumnin al source files:
1. Right click on the editor window.
2. Click the “Define Column Format...” menu item.
3. The*“Global Editor Column States’ dialog is displayed.
4

The " Check status’ shows whether the column is enabled or not. If it ischeckeditis
enabled if the check box is gray this means that in some files the column is enabled and in
other filesit is not.

5. Click “OK” for the new column settings to take effect.
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2 To switch off acolumn in one source files:

1

2.

Right click on the editor window, which you wish to remove a column from, and the
editor pop-up is displayed.
Click the Columns menu item and a cascaded menu item appears. Each columnis

displayed in this pop-up menu. If the column is enabled it has atick next to its name.

Clicking the entry will toggle whether the column is displayed or not.

Global Editor Column States

[w|Coverage
[w] E ditar

[w]Source Address Cancel |

Figure 4.16: Global column state Dialog
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5. Tools Administration

Y ou control the components, which can be used by the High-performance Embedded Workshop
viathe “Tools Administration” dialog (figure 5.1), which isinvoked via[T ools-
>Administration...]. Modification of the “ Tools Administration” dialog box is only possible
when no workspace is open, while only reference is possible when a workspace is open.

Tools Administration ed

Registered components: 0k I
Companent I Mersion =
; S *h E.0.0
5‘ R Beqister... |

L . Urreqish |

{f‘ Hitachi H Series Librarian Interface 1.1 e
----- . . Hitachi Call W alker 1.0 Eroperties |
-3 Utility Phases
=23 Debugger Components Expart... |

----- =] Generc Label View ECx 1.0 =

..... =] Monitor platform 1.0 Search disk... |
----- =] SHZCRU 1.0 i
..... =] Generic [0 Yiew ECX 10 T ool information. . |

----- =] SRecord ohject reader 1.0

I'—'Ilﬁ F wtenzinmn Camnnnenbs I _lﬂ Uninstaller... |
4 4 -

[~ Show all components

Current HEMW toolz databasze location:

Id:\hew20\e:-:e\win\dehug Modify... |

Figure5.1: Tools Administration Dialog (Example)
There are five standard types of component:

e Toolchain - aset of build phases (e.g. compiler, assembler, and linker). These components
provide the build capability.

e System Tool - an application (.EXE) which can be launched from the “Tools” menu. They are
often provided as extra applications, which support the toolchain (e.g. an externa debugger
like the High-performance Embedded Workshop 2 (HEW2) or an interactive graphical
librarian).
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« Utility Phase - a“ready made” build phase which supports some specific build functionality
(e.g. analyze complexity of source code, count lines of source code, etc.). These components
provide added functionality to the build that is not toolchain specific.

« Debugger Component —a component that supports some specific debugger functionality (e.g.
Target platform, Object reader, etc).

« Extension Component — a component that provides key functionality in a certain area of the
HEW system. These components cannot be unregistered when installed (e.g. The HEW
builder, debugger and flash support).
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51 Tool Locations

The HEW maintains the |ocations of HEW compatible components automatically as each new tool
isinstalled. After installation, the HEW stores information about the component (including its
location) —thisisreferred to asregistration. Although initial registration is automatic, during the
course of development or if you want to manage the tools being used in your projects more
effectively, you may need to register components yourself. The remainder of this chapter discusses
registration and how it affects you.

52 HEW Registration Files (*.HRF)

When a HEW compatible component (i.e. toolchain, system tool or utility phase) isinstalled, part
of itsinstallation will include afile with the extension .HRF (figure 5.2.i). Thisfile, named a
“HEW Registration File”, describes the component to the HEW. The process of registration refers
to loading a component’s .HRF file into the tools administration dialog (figure 5.2.ii).

i. INSTALL ii. REGISTER
cA\ c:\
—@ MyTool MyTool
| MYTOOL.HRF ||| MYTOOL.HRF |
—{/—7 bin E —{/—7 bin HEW
—@ etc —@ etc
—@ help —@ help

Figure5.2: HRF File L ocation and Registration

In order to use a component with HEW it must first be registered. The “Tools Administration”
dialog (figure 5.1) shows all currently registered components. To access it, ensure no workspaces
are open and then select [T ools

->Administration...]. If you attempt to access tools administration when there is a workspace
open the tools administration dialog is opened but cannot be modified. When HEW isinstalled by
default any new tools are automatically registered.
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HEW storestool information in atool database file. By default thisis created in the HEW
application directory, however if you are working in a network environment this directory may be
set to another location. It is possible to change the tool directory location.

2 To changethetools location:

1. Select[Tools->Administration...].

2. Click the“Modify” button for the “ Current HEW tools database location” field.
3. Select the directory under which the new tool is located, then click “OK”.
4

Thiswill switch the directory and change the tool location to the new directory. It will be
necessary to scan for any new tools that may be in thislocation this is achieved by using
the scan disk or register tool functionality.
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53 Registering Components

The HEW will automatically attempt to register any new components installed since the last time
it was invoked. However, in some circumstances you may need to register components yourself.

531 Sear ching Drives for Components

In some casesit is useful to search adrive for HEW compatible components. Thisis especialy
useful if the HEW installation was deleted or corrupted asit can recreate your tool information

instantly.
S To search for components:

1. Click the “Search Disk...” button on the “Tools Administration” dialog (figure 5.1). The
“Search Disk for Components” dialog will be displayed (figure 5.3).

Search Dizk for Components

: : : : Cloge
Select the directory in which to beain the zearch: —
Iu::'xhew

Browse. ..

W Include subfolders Start

Located components:

.

Component Yerzion | HRF Location Begister
Hitachi SuperH RISC engine Standard Toolz...  5.1.0 ::hew T oolch -
Hitachi HES HE/300 Standard Toolchain 30a0  cihew\Toolch | Aedster sl
Hitachi H Series Librarian Interface 1.0 c:ihewh T oolck

Cygruz GHMUPo SH w382 chewhToolch

[&F ICCHE Toolchain 1.23a  chewhToolch

J | N

Search Status: 5 file(z] found

Figure5.3: Search Disk for Components Dialog

2. Enter the directory in which you would like to search into the top field or browse to it
graphically by clicking the “Browse...” button.

3. Check the “Include subfolders’ check box if you would like to search the directory
specified and all directories below it.
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Click the “ Start” button to begin the search. During the search, the “ Start” button will
change to a“ Stop” button. Click the “ Stop” button to halt the search at any time.

The results of the search are shown in the “Located components” list. Select a component
and click “Register” to register an individual component or click “Register All” to register
all located components.

Click “Close” to exit the dialog.
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5.3.2 Registering a Single Component

The HEW allows you to navigate directly to a single component in order to register it. The HEW
Registration File (*.HRF) is located in the root directory of acomponent’sinstallation.

S Toregister acomponent:

1. Click the “Register...” button on the “ Tools Administration” dialog. A standard file open
dialog will be launched with itsfilefilter set to “HEW Registration Files (*.hrf)".

2. Navigate to the .HRF file of the component you would like to register, select it and then
click “Select”.

3. A dialog will beinvoked which displays information regarding the selected tool. Click
“Register” to confirm that you want to register the tool or click “Close” to abort the
operation.

54 Unregistering Components

The components, which are registered with the HEW, affect the way in which it behaves. For
example, every compatible system tool, which is registered, will be added to the tools menu when
anew project is created. Sometimes this may not be desirable. If so, open the“Tools
Administration” dialog, select the component from the “Registered components” list and then
click the “Unregister” button. A dialog will be invoked which asks you to confirm this action.
Click “Yes’ to confirm the action.

Note:  Unregistering a component does not remove itsinstallation from hard disk. It simply
removes the information, which the HEW was storing about that component (i.e. it
“disconnects’ it from the HEW). The action can be easily reversed at anytime by
registering the tool (see above). If you want to remove a component from the hard disk (i.e.
uninstall a component) then refer to the section “ Uninstalling Components” later in this
chapter.
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55  Viewing and Editing Component Properties

To view information regarding a component, select it from the “ Registered components” list and
then click the “Properties’ button. The properties dialog will be displayed with the “ General” tab
selected (figure 5.4). Thistab displays the name, version and location of the selected component.
None of the information on thistab is editable.

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 Properties HE

| Infarmation I E nwironment I

Hitachi SuperH RISC engine Standard
Yersion ; 51.0
Location ; o hhewh T oolchaing \HitachitSHYS10

k. I Cancel |

Figure5.4: Properties Dialog General Tab

Select the “Information” tab to view any information about the component (figure 5.5). This may
include copyright information, enhancements, bug fixes, user notes and so on.
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Hitachi SuperH RISC engine Standard Toolchain 5.1.0 Properties HE

General | Information | E nwiranment I

|nformation;
Hitachi SuperH RISC enagine Standard Toolchain Wer. 5.1.0 ﬂ

CAC++ Compiler Ver. 5.1

Agzember Wer, 4.2

OptLinker  “er. 1.1

[Linkage Editor Yer. .00 ;I

k. I Cancel |

Figure 5.5: Properties Dialog I nformation Tab
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Select the “Environment” tab, if it exists, to view and edit a component’ s environment settings
(figure 5.6). Thisdialog is most commonly used to modify the environment of atoolchain.

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 Properties EE

Generall Information  Environment |

Enviru:unment varnables:

SHE e e e

SHC_TMP=c\TEMP b odify... |
N | _PI Remove |

Figure5.6: Properties Dialog Environment Tab

To add anew environment variable, click the “Add...” button (the dialog shown in figure 5.7 will
be invoked). Enter the variable name into the “Variable” field, the variable€' s value into the
“Value’ field and then click “OK” to add the new variable to the “Environment” tab. Placeholder
pop-up menus are included to ensure that the environment can be specified as flexibly as possible.
For a detailed description of placeholders see appendix C, “Placeholders’.

To modify an environment variable, select the variable that you want to modify from the
“Environment” tab and then click the “Modify...” button. Make the required changes to the
“Variable” and “Vaue’ fields, and then click “OK” to add the modified variable to the
“Environment” tab. To remove an environment variable, select it and then click the “Remove”
button.

Environment ¥anable EE |
Wariable:
= 0k
s 0K
Cancel |

Walue:

. - b - | Flazehelder
Iu:.'xu:lu:us,c.'xrn_l,ltu:u:uls,c.'xwmdu:uws,c.'xtemp 3 ] s

Figure5.7: Environment Variable Dialog
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5.6 Uninstalling Components
The HEW provides a built in uninstaller method, which can remove unregistered components.

S Touninstall acomponent:
1. Select[Tools->Administration...].
2. Click on the uninstaller button. The “Uninstall HEW Tool” dialog isinvoked (figure 5.8).

Uninstall HE¥ Tool x|

Cloge

Select the directony in which to begin the zearch for tools;
d:hew i

Browse. .

W Include subfolders Start

Located Toalz which can be uninstalled:

Component | Werzion | |nztallation Directony Wiriztall

| b

1 | 0

Search Statuz  |dle

Figure5.8: Uninstall HEW Tool

3. Enter the directory in which you would like to search into the top field or browse to it
graphically by clicking the “Browse...” button.

4, Check the “Include subfolders’ check box if you would like to search the directory
specified and all directories below it.

5. Click the“ Start” button to begin the search. During the search, the “ Start” button will
change to a“ Stop” button. Click the “ Stop” button to halt the search at any time.

6. The results of the search are shown in the “Located Tools which can be uninstalled” list.
Select acomponent and click “Uninstall” to uninstall a component.

7. Click “Exit” to exit the dialog.
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A component may only be uninstalled if it is not currently registered with the HEW. If you
attempt to uninstall atool, which is registered, then the dialog shown in figure 5.9 will be
displayed. In such a case, you must return to the “Tools Administration” dialog via[T ools-
>Administration...], unregister the tool and then invoke the tool uninstaller again.

ToolUninztaller

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 iz curently registered: you may not uninstall a tool that iz registered with
HE".

Fleaze use HEW to unregister the Tool and then select "Retry to uninstall,

I:ancell

Figure5.9: Unableto Uninstall Tool

If atool is not registered with the HEW then the dialog shown in figure 5.10 will be displayed
when the “Unregister” button is clicked. This confirmation dialog displays all of the files and
foldersthat will be deleted. If you are certain that these files and folders can be deleted then click
the“Yes’ button. To abort the uninstall click the “No” or “Cancel” buttons.
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Confirmation EE |

The fallawing filez and folders will be deleted:

cihew T oolchaing \HitachihSHAET Dzample

o hhewt T oolchaing \HitachitSHYT DNinclude
c:ihewh T oolchaing‘\HitachihSHAET0Mib

o hhewt T oolchaing \HitachitSHYST04bin

o hhewt T oolchaing HitachitSHYET 04hew

o hhewt T oolchaing HitachibSHYT 08 binhdwfcry. exe
o hhewt T oolchaing \HitachitSHYT 0Nbinhshc. exe
cihewh T oolchaing\HitachihSHAE1 04bintshoazm. exe
o hhewt T oolchaing HitachitSHYT 0Nbinhshcer. maeg
o hhewt T oolchaing HitachitSHYST 08binhshcerr. off

o hhewt T oolchaing \HitachitSHYT 0Nbinhshcfit exe

o hhewt T oolchaing'HitachitSHYAT 0hbinhshooen. exe
cihew' T oolchaing\HitachihSHAWET 04bintshchip. mag
o hhewt T oolchaing HitachitSHYAT 0Nbinhsbcmdl exe
c:ihew T oolchaing‘\HitachihSHAE1 D\bintshepep.exe ;I

o hhewt T oolchaing HitachitSHYAT 0Nehe toolchain, bef j

Are you sure you want to delete the above files and folders?

Figure 5.10: Confirmation Dialog
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5.7 Technical Support Issues

The*“Tools Administration” dialog is also capable of displaying information regarding “hidden”
system components. These are part of the HEW itself that cannot be unregistered/registered
manually. If you check the “Show all components” check box on the tools administration dialog,
extra component folders are displayed (see figure 5.11).

Tools Administration e

Registered components: ok I
Component Wersion =]
s Cancel |
[ Systemn Tools
[Z3 Utility Phazes .
Beaqister...

(21 Debugger Companents &I
3 EHh.ansmn Components i regie |
a_ Froject Generators

Hitachi SH Project Generator Er |
|20 Project Generatars - Custam —
= a Werzion Control System Expoit |
Custom VTS 20 -
' oolchain Support Search disk... |

21

Hitachi SH Toolchain Suppaorter

-5 Definition Parser Tool information... |

Lf®] Custom Parser 1.0

il Uninstaller... |
1| | B

¥ Shaw all components

Current HEWY toals databaze location:

Id:\hew2ﬂ'\e:-:e'\win'\debug kodify. . |

Figure5.11: All Components Shown

When seeking technical support, you may be asked to give details about some or al of these
components. To do so, open the respective folder, select a component and click the “ Properties”
button. The properties dialog that will be invoked behaves in the same way as discussed
previously in this chapter, with the exception that there is no “ Environment” tab.

The HEW also has afeature, which outputs tool information regarding the registered components
to afile. Thisalowsyou to retrieve information on the entire HEW system. Thisinformation can
then be sent to your technical support contact if you are experiencing problems with the HEW.
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2 To output tool information:
1. Click the [Tools->Administration] menu item.
2. Click the“Tool information...” button. A standard windows file save dialog is displayed.
3. Choosethefilelocation and click OK.
4. A fileiscreated in the chosen location with the current registered tool setup of the HEW 2.
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5.8 Custom Project Types

The [Project->Create Project Type...] menuitemin HEW allows you to create a template for
your project. This menu item takes the settings of the current project and then creates a project
type for you. The user can specify the name of the new type and style of the project generation
wizard. Once created these project types appear in the “ Tools Administration” dialog and are
initially hidden in the system components part of the tools administration tree. To export one of
the custom project generators select the “Export” button on the “Tools Administration” dialog.
The execution environments of the custom project generators are packaged on the execution file
that can beinstalled. When thisfile is executed on the target user’s machine, the custom project
generator isinstalled.
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6. Customizing the Environment

6.1 Customizing the Toolbar

The High-performance Embedded Workshop provides 2 standard toolbars as detailed in chapter 1,

“Overview”. In addition to these, you may also construct your own toolbars via the “ Customize’
dialog (figure 6.1).

Costomize B
| Eummandxl henu I Del:uuggerl Log I Help I
Toolbars:
2 E ditor ¥ Shaw Tooltips Mew...
[w|Search
[+ T ermplates Beset |
[w]D'ebug

[w]'erzion Control

aalEar fanme:
Editor

(] I Cancel

Figure 6.1: Customize Dialog Toolbars Tab

2 To create anew toolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.
2. Click the“New..."” button. The dialog shown in figure 6.2 will be displayed.

3. Enter the name of the new toolbar into the “Toolbar name” field.

4, Click “OK” to create the new toolbar.
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Mew Toolbar EHE3

Toolbar narme: 0K

IM uT oolbar |

Cancel

Figure 6.2: New Toolbar Dialog
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When anew toolbar is created it will appear undocked (i.e. “floating”) and empty.

< To add buttons to a toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the

“Commands” tab (seefigure 6.3).
2. Browse the available buttons by selecting the button categories from the “Categories” list.
Select a button from the “Buttons” areato display information on its operation.

3. Click and drag a button from the dialog onto the toolbar.

Costomze——————— EE

Toolbars  Commands | henu I Del:uuggerl Log I Help I

Categaries: — Buttons

Dot NEHE & 2@
Standard Ml Eﬁ|{} T co

Search

Debug Run
Yerzion Control
Bookmarks
Templates

Select a category, then click a button to see its description. Drag the button
to arw taolbar

Drezcription
Open an exizting docurnent

(] I Cancel

Figure 6.3: Customize Dialog Commands Tab
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2 Toremove buttons from atoolbar:

1. Select [Tools->Customize...]. The diaog shown in figure 6.1 will be displayed. Select the
“Commands” tab (see figure 6.3).

2. Click and drag a button from the toolbar onto the “Buttons” area.
S Toremove auser defined toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the user-defined toolbar from the “Toolbars’ list, and the “Reset” button in figure
6.1 changesto the “Delete” button. Then click the “Delete” button.

S Toreset astandard toolbar back to its original state:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the standard toolbar from the “Toolbars” list and then click the “Reset” button.
2 To show or hide toolbar tooltips:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Set the “Show Tooltips’ check box as desired.
2 To modify the toolbar name of atoolbar created by a user:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Inthe“Toolbars’ list, select atoolbar, which has been created by a user and whose name
you, want to modify.

3. Modify the name of the toolbar in the “ Toolbar name” filed.
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6.2 Customizing the Tools Menu
The “Tools’ menu can be customized to include your own menu options.

S To add anew menu option:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select
the“Menu” tab (see figure 6.4). Thefirst thing for you to decide is whether you are
adding a global application wide tool (“Application wide tools:”), which will be available
to al of your workspaces. Or whether you wish to add a workspace wide tool
(“Workspace wide tool:"), which is only valid for the current workspace. Once you have
made the choice choose the relevant section of the dialog.

Costomize B

Tu:uc:ll:uarsl Commands  Menu |Del:uugger| Log I Help I

Application wide tools:

Mame I Yersion I

A Edity.

Hemoye

Workzpace wide tools:
M ame | Wersion | Add

f Gt

B EmmE

T
[ s
[
[ e

k. | Cancel |

Figure 6.4: Customize Dialog Menu Tab

2. Click the“Add...” button (the dialog shown in figure 6.5 will be invoked). If you would
like to add an existing system tool to the menu then select the “ Select from existing system
tools’ radio button, choose the tool from the drop-down list and then click “OK”.
Alternatively, if you would like to add a tool of your own then follow the remaining steps.
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3. Enter the name of the tool into the “Name” field.
4. Enter the command, excluding arguments, into the “Command” field.

5. Enter any arguments that you would like to pass to the command into the “Arguments’
field.

6. Enter aninitial directory in which you would like the tool to run, into the “Initial directory”
field.

7. Click “OK” to add the menu option to the “Tools" menu.

Add Tool EE |

¥ Define new user ool 0k |

— Tool details:
Mame :

Cancel

IE:-:pIu:urer

Command ;

|$["-.-'-.-"|ND|H]"-.EH|:I|DFELEHE ﬂ Browsze... |

Arguments ;

| il

Iritial directary :

[$(TEMPDIR] ] Biowse. |

= Select from existing system toals:

IHitau:hi b apriew [werzion 1.0] j

Figure 6.5: Add Tool Dialog

New menu options are added to the bottom of the list (i.e. bottom of the tools menu) by default.
The order of menu optionsin the “Tools” menu can also be modified.

S To modify amenu option:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the
“Menu” tab (seefigure 6.4).
2. Select the menu option that you would like to modify and then click the “Modify...” button.
3. Make the desired changes on the “Modify Tool” dialog (figure 6.6) and then click “OK”.
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ModifyT ool EE
Canicel |
Command ;
|$["-.-'-.-"|ND|H]"-.EH|:I|DTELEHE ll Browze... |
Arguments ;

| i3

Initial directony ;

[$(TEMPDIR) | Bows |

Figure 6.6: Modify Tool Dialog

S Toremove amenu option:
1. Select [Tools->Customize...]. The diaog shown in figure 6.1 will be displayed. Select the
“Menu” tab (seefigure 6.4).
2. Select the menu option that you would like to remove and then click the “Remove” button.

6.3 Configuring the Help System

The High-performance Embedded Workshop provides context sensitive help within the editor
window. In other words, if you select some text in the editor window and then press F1, the High-
performance Embedded Workshop will attempt to locate help on that selected item. The help files,
which will be searched, are listed in the “Help” tab of the “ Customize” dialog.

S Toadd anew help file:
1. Select [Tools->Customize...]. The diaog shown in figure 6.1 will be displayed. Select the
“Help” tab (seefigure 6.7).
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Costomze——————— EE

Tu:uull:uarsl Eummandxl henu I Del:uuggerl Log Help |
Help files:
Dezcription | File Mame Add...
BEmmve |
l | B
Default help file;
INDne j
ak I Cancel |

Figure 6.7: Customize Dialog Help Tab

. Click the“Add...” button. The“Add Help File" dialog will be displayed (figure 6.8).
. Enter adescription of the help file into the “Title” field.

. Enter the full path of the help file into the “Path” field (or browse to it graphically by
clicking on the “Browse...” button).

. Click “OK” to define the new help file.
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Add Help File HE
Title:
= k.
IF'ru:ugramming inAMSIC _l
Cancel |
Path:

Iu::"sfileshhelp'xansi.hlp Browse. .. I

Figure 6.8: Add Help File Dialog
To make a help file the default choice, select it from the “Default help file” drop-down list or set it
to “(None)” if you would like to be prompted for ahelp file when F1 is pressed.
6.4 Specifying Wor kspace Options

The High-performance Embedded Workshop allows you to control several aspects of aworkspace
viathe “Options’ dialog (figure 6.9). To invoke it select [Tools->Options...], and select the
“Workspace” tab.
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Options

Buld | Editer ‘Workspace | Canfimation |

[ iDpen last warkspace at start-upg

[+ Bestors files on opening work space
[ Dizplay waorkspace infarmation dislag on opening workspace
[ Save workspace before executing any bools

[ Prompt before zaving workspace

Default directon for new workspaces:

C:ihew2 Browze...

QF. | Cancel

Figure 6.9: Options Dialog Workspace Tab

The following sections explain the options available on this tab.

6.4.1 Open last workspace at start-up

Set this check box if you would like the High-performance Embedded Workshop to automatically
open the last workspace you opened when it is launched.

6.4.2 Restorethe files on opening wor kspace

When you close a workspace, the HEW stores, which files were open. When you open a
workspace, the HEW can restore (i.e. open) the same files so that you can continue your session in
exactly the same state as when you left it. If you would like the files associated with a workspace
to be opened when you open aworkspace then set this check box.
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Display wor kspace information dialog on opening wor kspace

When many workspaces are being used, it is sometimes difficult to remember exactly what was
contained within each workspace. To help resolve this, the High-performance Embedded
Workshop allows you to enter atextual description of each workspace.

S To enter aworkspace description:

1
2.

Select the workspace icon from the “Projects’ tab of the "Workspace” window.

Click the right mouse button to invoke the pop-up menu and then select the “Properties’
option. The dialog shown in figure 6.10 will be displayed.

Enter the description into the “Information” field.

Check the “ Show workspace information on workspace open” check box if you want a
workspace properties dialog to be launched on opening a workspace. This check box has
the same role as the * Display workspace information dialog on opening workspace” on the
“Workspace” tab of the “Options’ dialog.

Click “OK” to save the description on the “Information” dialog. Click the “ Cancel” button
not to save the description.

Workzpace Properties E |

M ame: demn !
Location: C:hhewhprojecthrdhdemohdemo. hws
Last modified  16:08:58. Thursday, August 16, 2001 e |
CPL Farnily: SuperH RISC engine
T ool chain: Hitachi SuperH Standard

Infarmation:

Mo workzpace information awvailable ;I

W Show workspace information on workspace open

Figure 6.10: Workspace Properties Dialog

When aworkspace is opened, the High-performance Embedded Workshop can display this
information so that it is possible to determine whether the workspace is the desired workspace. To
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display thisinformation on opening aworkspace, set the “ Display workspace information dialog
on opening workspace” check box.

6.4.4 Save wor kspace befor e executing any tools

To force the High-performance Embedded Workshop into saving the current workspace before
executing any build phases (i.e. build, build &l or build file operations) or version control
commands set the “ Save workspace before executing any phases’ check box.

6.4.5 Prompt befor e saving wor kspace

In addition to the above check box, set thisto prompt before saving.

6.4.6 Default directory for new workspaces

When anew workspace is created the High-performance Embedded Workshop invokes the “New
Workspace” dialog. One of the fields on this dialog is the directory in which the new workspace
will be created. By default, thisis the root directory. However, if you would like to set this default
directory to another location (e.g. “ C:\Workspaces”) then enter the desired directory into the field
or browseto it graphically viathe “Browse...” button.

6.4.7 Prompt befor e saving session

Checking this option will force the High-performance Embedded Workshop into displaying a
prompt before the session is saved to disk.
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6.5 Using an External Editor

The High-performance Embedded Workshop allows you to use an external editor. Once an
external editor has been specified, it will be launched when the following actions are performed:

« Double clicking on afile in the “Projects’ tab of the “Workspace” window.

* Double clicking on an entry in the “Navigation” tab of the “Workspace” window.
* Double clicking on an error/warning in the “Build” tab of the “Output” window.

« Double clicking on an entry in the “Find in Files’ tab of the “Output” window.

» Selecting the [Open <file>] option from the “Workspace” windows pop-up menu.
e Clicking the “Launch Editor” toolbar button.

S To specify an external editor:
1. Select [Tools->Options...]. The “Options”’ dialog will be displayed. Select the “Editor” tab
(figure 6.11).
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Options

Figure 6.11: Options Dialog Editor Tab

144

RENESAS




High-performance Embedded Workshop User Manual

2. Check the “Use external editor” check box.
The “External Editor” dialog will be displayed (figure 6.12).

E xternal Editor EH |

LCommarid:

IE:HWINDDWSHNDtEpad.EHE Browse. .. | K |
Argurnents to oper file: Cancel |
[FULLFILE) Ll

Arguments ko open file at line:

|$[FLILLFILE] |L|

Figure 6.12: External Editor Dialog

3. Enter the path of the executable (without any arguments) into the “Command” field.

4. Enter the arguments required to open afile into the “ Argumentsto open file” field. Use the
$(FULLFILE) placeholder to represent the path of thefile to be opened.

5. Enter the arguments required to open afile at a specific line into the “ Arguments to open
fileat ling’ field. Use the $(FULLFILE) placeholder to represent the path of thefile to be
opened and the $(LINE) placeholder to represent the line number at which the cursor
should beinitialy positioned.

6. Click “OK” to define the editor.
Note: When using an external editor be aware of the following issues:

« Each time you invoke the external editor, in whichever way, a separate instance of the editor
will be launched.
e You must save your own files before you perform a build file, build or build all operation.

6.6 Customizing File Save

The High-performance Embedded Workshop allows you to customize file save on the “ Editor” tab
of the “Options’ dialog (figure 6.11). To open the tab, select [Tools->Options...] and click the
“Editor” tab.

The following sections explain the options related to file save.
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6.6.1 Save files befor e executing any tools

To force the High-performance Embedded Workshop into saving edited files before executing any
build phases (i.e. build, build al or build file operations) or version control commands, set the
“Save files before executing any tools’ check box.

6.6.2 Prompt before saving files

In addition to the above check box, set thisto prompt before saving.
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6.7 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. If you want to
use another debugger then you must add it to the “Tools” menu.

The “Debugger” tab of the “Customize” dialog (figure 6.13) iswhere the HDI-related information
isconfigured. You may wish to use an older version of the debugger if certain targets are not
currently supported in the new environment. Invoke it by selecting [T ools->Customize...] and
then selecting the “Debugger” tab.

e
Tu:uc:ll:uarsl Eu:ummandsl Menu — Debugger | Log I Help I

¥ Usze external debugger

HOI lozation 4.0 ar greater):

II::'\Hew‘\HDIE'\SIM"\SH'\Hdi.EHE | 3 | Erowze... |

Sezzion file;
|$[EDNFIGDIH]H$[PF|DJEET MAME] hds Ll Browse. .. |

Download module;

I$[EDNFIGDIH]H$[PHDJEET MAME]. abd Ll Browse... |

QF. I Cancel

Figure 6.13: Customize Dialog Debugger Tab

To use an external debugger, check the “Use external debugger” checkbox and specify the items
described below. There are three items of information, which need to be specified. Firstly, the
location of the HDI executable must be specified. This must be version 4.0 or greater otherwise
the behavior is not guaranteed. The second item of datais the session file. Thistells HDI which
session to load when it is launched. Finally, the location of the download moduleis required. This
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alows the HEW to automatically switch to HDI when the download module changes after a build.
Click the “Launch External Debugger” toolbar button to invoke HDI with the specified session
file.

After abuild, if the download module has been updated, the HEW will switch back to HDI to
enable immediate debugging. Whilst using HDI, double clicking in any source window will switch
back to the HEW with the source file open at the line which was double clicked.
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6.8 Using Custom Placeholders

Throughout the High-performance Embedded Workshop the user can use a number of pre-defined
placeholders for directory definitions. For example the user can use the “$(PROJDIR)” variable to
signify the current HEW project directory. This makes it much easier to relocate projects and
keep al of the paths correct.

The High-performance Embedded Workshop a so has the ability to define custom placeholders.
This means you can enter your own custom placeholder definition and decide upon its directory
value. Once defined this placeholder becomes available throughout the rest of the HEW system.

The placehol ders can be defined on an application wide level so the placeholders are available to
all workspaces and projects that use the HEW. The other method of defining the placeholdersis
using the workspace wide custom placeholders this means the placeholders can only be used in the
current workspace. Thislist isonly available when you have a workspace open.

Customize EH

Toolbarsl Commandsl Menu  Flaceholders |Debugger| Log | Help I

Application wide custom placehalders:

Flaceholder | Directory |

Fladiti.

Hemove

| i
[ s

Workspace wide custom placeholders:
Placeholder | Directaory I Add...

FEdifil,.

Hemove

|

ak. | Cancel |

Figure 6.14; Customize Dialog Placeholder Tab

2 To add acustom placeholder:
149

RENESAS




High-performance Embedded Workshop User Manual

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select
the “Placeholders’ tab (figure 6.14).

2. Choose whether you need to use an “ Application wide custom placeholder” or
“Workspace wide custom placeholder”. Click “Add” on the adjacent button to the list
you require.

3. Thediaog, add “New Custom Placeholder” dialog is displayed. (figure 6.15)

4. Inthefields provided choose a suitable name for the placeholder and a description of what
the placeholder means.

5. Then choose a directory, which relates to this placeholder. It ispossible to use
placeholders that are aready defined in this field such as $(PROJIDIR).

Mew Custom Placeholder E
Placehalder:
I Cancel |

Description:

Diirecton:

I Browse... |

Figure 6.15: New Custom Placeholder Dialog

6.9 Using Confirmation Dialog Boxes

The HEW alows users to specify many items for confirmation even in a single operation. These
items are usually set by default. However, it may be annoying to handle the confirmation dialog
boxes if you take the same operation several times. Use the [Confirmation] page of the [Options]
dialog box to control those confirmation dialog boxes.

S Toview the content of [Display confirmation dialogs for]:
1. Select [Tools->Options...]. Then select the “Confirmation” tab (figure 6.16).
2. ltemsto be confirmed are listed in the dialog box.
3. Totoggle acheckmark for an item, select the checkbox on the left of theitem’s name.
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Build | Editer | Workspace Gonfirmation

— Display confirmation dialoes for:

wsplagh Screen
[w|Dizplay Welcome dialog
[ JLoad Program

[ Unload Program

[ JSave Memary
wilnitialize Tareet

[w| Download modules after build
[w|Load memory

[wierify memory

[wSave memory

[WIFill memory

W Test memory

w|Delete All Labels
w|Delete Label

[ ILoading Labels

= Set Al |
Clear Al |

[

(0] I LCancel

Figure 6.16: Confirmation Page for Optional Dialog Boxes

151

RENESAS




High-performance Embedded Workshop User Manual

152

RENESAS



High-performance Embedded Workshop User Manual

7. Veason Control

The High-performance Embedded Workshop provides facilities for connecting to a version control
tool. Some of the reasons why version control tools are used with a project are:

e To maintain the integrity of a project.
« To store each stage of a project.
* To enable different users to co-develop a project by controlling revisions to its source files.

Figure 7.1 illustrates atypical project where aversion control system isin use. This shows three
users who all use the same-shared network drive to exchange source code. The version control
system provides access and updates to the source files.

NETWORK

Figure 7.1: Version Control
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7.1 Selecting a Version Control System

Initialy, the version control sub-menu will appear as shown in figure 7.2. At thistime only the
[Version Control -> Select...] option is available because aversion control system is not yet
active for the current workspace.

Window  Help

Adrministration. . vlﬂl ﬁ' 'ﬁ

[Ehatme aalehai e,

—

Yerzion Caontrol Select...
[Eorfigure...
Cuztomize... fighrs
Options. . (e Lol Filefs]
7| fi
)1 Launeth External ebugger.. [?' _Eml:!\-'e l=Lz)
S EEE
Format Wiews. . ﬂ.-' [Ehech Wt Eles]

e ) =
(&) Status of Filefs]

Figure7.2: Version Control Sub-Menu

9 To sdlect aversion control system:

1. Select [Version Control->Select...]. The dialog shown in figure 7.3 will be displayed.
Thisdialog listsal of the supported version control systems.

2. Select the desired version control system from the “Version control systems” list and click
the “Select” button. The “Current version control system” is changed to reflect the new
selection.

3. Click the“OK” button to confirm the selection.
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Select Yerzion Control System HE

Werzion control spstemns: Ok

Cuztom Y5

Cancel

Select

il

Current version control system:

Mone

Figure 7.3: Select Version Control System Dialog

Note:  Only those version control systems which have been installed with the HEW will appear
in the “ Select Version Control System” dialog (figure 7.3).

Once aversion control tool is selected you will notice that the [Version Control->Configure...]
option has now become available.

The next chapter discusses the usage of the custom version control system.
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8. Using the Custom Version Control System

The custom version control system is a configurable addition to the High-performance Embedded
Workshop, which alows you to connect to a version control system already installed on your
machine. To clarify further, the High-performance Embedded Workshop does not provide a
version control tool itself, only a means by which you can integrate the version control system,
which you use into your workspaces and projects.

8.1 Defining Version Control Menu Options

The custom version control system allows you to invoke aversion control command either by
selecting an option from the [Tools-> Version Control] sub-menu or by clicking aversion control
toolbar button. When either of these actions are performed, the associated commands are executed
and the output is displayed in the “Version Control” tab of the “Output” window.

2 To execute aversion control menu option or toolbar button:

1. Select whichever items you would like to apply the version control command to from the
“Workspace” window. This may include aworkspace, project(s), folder(s) and file(s).
When the command is selected, all of the fileswill be extracted from the selected items and
passed, in turn, to the version control command. For example, if you select the workspace
icon then al of thefilesin all of the projects will be passed, in turn, to the version control
command. Thiswill include any system files. For example if you select the project item
then

2. Select the required menu option from the [Tools->Version Control] sub-menu or click the
desired version control toolbar button.

The custom version control support allows you the most flexibility in specifying how aversion
control system isto be used. To configure it, select [Version Control->Configure...]. The
“Version Control Setup” dialog will be displayed (figure 8.1).
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Yersion Control Setup

Commands l F'rnieu:ls] Generall

Systemn menu optiohs and toolbar buttons ;

Check In File(s
Check Out File(s)
Get Filg(s)
Femave File(z)
Stabus of File[s)

Uszer menu options ;

K E

Madify...

Ok,

Cancel

Espoat...

[mpart,..

Figure8.1: Version Control Setup Dialog Commands Tab
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The“Commands’ tab contains two lists of menu options. Thefirst list, “ System menu options and
toolbar buttons”, represents those menu options which always appear on the version control sub-
menu. These menu options also have an associated toolbar button on the version control toolbar.
The second list, “User menu options’, represents those additional user defined options which are

added to the bottom of the version control sub-menu. Figure 8.2 shows the structure of the version
control sub-menu.

Options... |
“Wersion Contral Selact..
Configure...
(i Add File(s)
@: Remaove Fileis)
Syatern
& Get Filels) Defined
& Check Out Filels) Ciptien
B Check In File(s)
Status of Filelz)
@ = \_\"{
. . Llser
History of Filelz) Diefined
Undo Check out of Filals) Cipticn

Figure 8.2: Version Control Sub-Menu

811 System menu options and toolbar buttons

In order to invoke commands from the toolbar or the system defined options of the [T ools-
>Version Control] sub-menu, you must first define the associated commands that should be

executed when they are activated. The names of the options and their intended action are listed in
table 8.1.
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Table 8.1: System Menu Option

Option Description

Add File(s) Add selected file(s) to version control system.

Remove File(s) Remove selected file(s) from version control system.

Get File(s) Get a read only local copy of the selected file(s) from version control system.

Check In File(s) Put back, i.e. update, the selected file(s) in version control system with the
local copy.

Check Out File(s)  Get a writable local copy of the selected file(s) from version control system.

Status of File(s) View the status of the selected file(s).

2 To modify asystem menu/ toolbar option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Select the option to be modified from the “ System menu options and toolbar buttons” list
and then click the “Modify...” button. The dialog shown in figure 8.3 will be displayed.
This figure shows a dialog when “ Add File(s)” has been selected for example.

3. Commands are added viathe “Add...” button. See the section, “Defining Version Control
Commands’, later in this chapter for further information.

4. Closethe“Define Command for “<command>"" dialog by clicking “OK".
5. Closethe“Version Control Setup” dialog by clicking “ OK”.
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Define Commands for “Add File[z]"

LCommands : oK

Cancel

i,
Hemoye
i EwE i

i e a o

MARREL

Figure 8.3: Modify System Menu Option (Example)
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8.1.2 User menu options

Y ou can create as many user defined menu options as you like, name them how you want and
define their order in the menu. User defined menu options do not appear on the version control
toolbar.

S To create anew version control menu option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
2. Click the“Add..” button. The dialog shown in figure 8.4 will be displayed.
3. Enter the name of the menu option into the “Option” field.
4, Commands are added to the menu option viathe “Add...” button. See the section,
“Defining Version Control Commands’, later in this chapter for further information.
Close the “Add Menu Option” dialog by clicking “OK”.
6. Closethe“Version Control Setup” dialog by clicking “ OK”.

o

Add Menu Option EHE
o [ o |
= ak

Cancel |

LCommands:

Add... |

A Edifin.. |

Hemmve |

G e i |

e e |

Figure 8.4: Add Menu Option Dialog
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2 Toremove an existing version control menu option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Select the menu option to be removed from the “User menu options” list and then click the
“Remove’ button.

3. Closethe“Version Control Setup” dialog by clicking “ OK”.
2 Tomodify an existing version control menu option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
2. Select the menu option to be modified from the “User menu options” list and then click the
“Madify...” button beside the list. The dialog shown in figure 8.4 will be displayed. (The
title of the dialog is“Modify Menu Option™.)
3. Modify the commands as necessary and then click “OK”.
4. Closethe “Version Control Setup” dialog by clicking “OK”.
2 To changethe ordering of version control menu options:
1. Select [Version Control->Configure...]. Thedialog shown in figure 8.1 will be displayed.

2. Select the menu option to be moved and then click the “Move up” and “Move down”
buttons as necessary.

3. Closethe“Version Control Setup” dialog by clicking “ OK”.
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8.2 Defining Version Control Commands

Commands are defined when the “Add...” or “Modify...” buttons are clicked on the dialogs
shown in figure 8.3 and figure 7.4. In either case, the dialog shown in figure 8.5 is invoked.

Add Command EHE |

— Command ;

Yerzion control executable

IV:\VSS'\WINBE'\S T.EHE Browsze. . |
Cancel |

Arquments :
IHistu:ur_l,l FYCDIR)AHFILEMAME] -YEUSERMAME] $PASS ﬂ

Iritial directony ;

[$FILEDIR] | Browse |

— Executable return code

% Retum code of executable iz not meaningful

= Command has failed if the retun code iz [1o Equal Ta j II:I

Figure 8.5: Add/Modify Command Dialog

S To define acommand:
1. Enter the full path of the command into the “Version control executable” field or browse to
it graphically by clicking the “Browse...” button.
2. Enter the arguments for the command into the “ Arguments” field.

3. Enter theinitial directory in which you would like to run the executable from into the
“Initial directory” field or browse to it graphically by clicking the “Browse...” button. In
most cases this should be set to the “$(FILEDIR)” placeholder, i.e. execute the command
from the same directory asthefile.

4. Set the “Executable return code” options as described in the following section.
5. Click “OK” to define the new command.
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8.21 Executablereturn code

If the return code of the command(s) can be used to indicate a failure then you should select the
“Command has failed if the return codeis’ option and set the two fields to the right as required.

If the “Command has failed if the return codeis’ option is selected then the HEW will check the
return code of each command to determine whether afailure occurred. If so, no further commands
will be executed and any other processes which would follow the commands (e.g. build) will not
be executed.

If the “Return code of tool is not meaningful” option is selected then the HEW will not check the
return code of each. Consequently, all commands will execute regardless.
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8.3 Specifying Arguments

It is obvious that arguments must be specified correctly, otherwise the version control tool
executed will not function as intended. However, it is aso important, when using custom version
control support, to specify the arguments in aflexible way as asingle version control command
can be applied to more than one file. To facilitate this, the “Arguments’ field has a placeholder
button (refer to appendix C, “Placeholders’, for an in depth discussion of placeholders) which,
when clicked on, invokes a pop-up menu of available placeholders (figure 8.6). An explanation of
each placeholder and how their values are derived can be found in table 8.2, Arguments Field
Placeholders.

Uzer login name

Uzer login passward
“Wersion control directory
Camment
File path + name
Filenams
File leaf
File extension
File directary
Configuration directary
Praject directary
Warkspace directory
Temp directory
Cammand directary
Windows directory
Windows system directory
Warkspace name
Praject name

Configuration name

Figure 8.6: Arguments Field Placeholder Pop-up Menu
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Table 8.2: ArgumentsField Placeholders

Placeholder Value and How its Determined

User login name Current user login (“General” tab)

User login password Current user password (“General” tab)

Version control directory “Virtual” version control mapping (“Projects” tab)
Comment Comment specified before command execution
File path + name Full path and name of file involved in operation
Filename Filename (including extension) of file involved
File leaf Filename (excluding extension) of file involved
File extension Extension of file involved in operation

File directory Directory of file involved in operation
Configuration directory Current configuration directory

Project directory Current project directory

Workspace directory Current workspace directory

Temp directory Temporary directory

Command directory Version control executable directory

Windows directory Directory where Windows® is installed
Windows system directory Directory where Windows® system files exist
Workspace name Current workspace name

Project name Current project name

Configuration name Current configuration name

8.3.1 Specifying File L ocations

When referring to afile' s location, be sure to use a placeholder, otherwise the command will only
relate to a hardwired file. For example, let’simagine that a version control executable has been
selected which uses a—GET command to obtain aread only copy of afile. The “Arguments’ field
could be specified as:

-CET “c:\vc\files\project\min.c”

However, when executed, this command can only ever get the file MAIN.C. To resolve this
problem, HEW uses a system of placeholders and directory mappings. The latter tell the HEW
which “working” directories (i.e. where source files are being worked on) map to which
“controlled” directories (i.e. where the source files are stored in the version control system).

M appings between these two directory systems can be specified via the “Projects’ tab of

the ”Version Control Setup” didog (figure 8.7).
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Yersion Control Setup EE

Commands FProjects |General|

Show detailz for project I Projectl j

— Detailz :

Wersion control directory mappings

Source Directony | Yerzion Control Directon Add...

cworkhapplicationhprojectl  «wohawhapphprojectl

ook \applicationhsrc whwohawhapphanc by, |

c:work hshared wwchawtshared —
Hemuve |

1] | 0

E nvironment :

&dd..

f i

e

Eemawe

(] I Cancel Expaort... Impart...

Figure 8.7: Version Control Setup Dialog Projects Tab

S To define anew mapping:

1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
Select the “Projects” tab, and the dialog shown in figure 8.7 will be displayed.

2. Click the“Add...” button that is next to the “Version control directory mappings’ list. The
dialog shown in figure 8.8 will be displayed.

3. Enter the source (i.e. “working”) directory into the “ Source directory” field or browse to it
graphically by clicking the “Browse...” button.

4. Enter the version control directory (i.e. “controlled”) directory into the “Version control
directory”.
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Yerzion Control Directory Mapping EE |

Source directony : ] I
Iu::'xwu:urk'xshared ﬂ Emwge___l Cancel |

Wersion control directaory :

I:-::'w::'xsw'xshared

Figure 8.8: Version Control Directory Mapping Dialog
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2 To modify an existing mapping:
1. Select [Version Control->Configure...]. Thedialog shown in figure 8.1 will be displayed.
Select the “Projects” tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be modified from the “Version control directory mappings’ list and
then click the“Maodify...” button. The dialog shown in figure 8.8 will be displayed.
3. Make the necessary changes to the two directories and then click “OK” to confirm the edits.
2 Toremove an existing mapping:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
Select the “Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be removed from the “Version control directory mappings’ list and
then click the “Remove” button.

Once the mappings have been defined you can use the “Version control directory” placeholder,
$(VCDIR), to represent the directory in which the project file is stored. Consider the scenario
shown in figure 8.9. Here are three directories, which are mapped from a shared version control
drive (X:\) to alocal drive where the development is being done (C:\).

LOCAL - C:\ Mapped To NETWORK - X:\

- -

C:\work\application\projectl X:\vc\sw\app\projectl

E:

C:\work\application\src

L

C:\work\shared

-
-

X:\ve\sw\app\src

)

X:\ve\swishared

Figure 8.9: Example Mappings

Now let’ simagine that a version control executable has been selected which uses a—GET
command to obtain aread only copy of afile. In order to get all of thefilesin a project we need to
use the following command:
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- GET “$(VCDI R)\ $( FI LENAME)

When the HEW executes the command for a given project file, it will replace $(VCDIR) for the
equivalent version control directory in the file mapping.

For example, suppose FILE1.C islocated at:
c:\work\application\projectl\filel.c
If the get command is applied to FILE1.C then:

(1) X:\we\swh\app\projectl is substituted for $(V CDIR) asthisis the version control directory
mapping for c:\work\application\project1l.
(2) FILEL.C is substituted for $(FILENAME).

Project File: C.\work\application\projectl \ filel.c
Arguments: $(VCDIR) \ $(FI LENAME)

(1) )
Command: X:\vc\sw app\projectl \ filel.c

Figure 8.10: Example of Substitution

832 Specifying Environment

Select the “Projects” tab of the “Version Control Setup” dialog to view the current settings (figure
8.7).

To add anew environment variable click the “Add...” button beside the “Environment” list (the
dialog shown in Figure will beinvoked). Enter the variable nameinto the “Variable” field, the
variable' svalueinto the “Vaue” field and then click “OK” to add the new variable to the
“Environment” list.
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Environment ¥anable EHE |

Wariable :
|
Cancel
Walue —l
| Placehelder
I 4 | ppLIp FEnU

Figure 8.11: Environment Variable Dialog

To modify an environment variable, select the variable that you want to modify from the
“Environment” list and then click the “Modify...” button beside it. Make the required changesto
the“Variable’ and “Value” fields and then click “OK” to add the modified variable back to thelist.
To remove an environment variable, select the variable that you want to remove from the
“Environment” list and then click the “Remove” button beside it.
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8.33 Specifying Comments

If acommand contains the placeholder “$(COMMENT)” then the HEW will request that you
enter the comment when the command is executed (viathe dialog as shown in figure 8.12).

Please Enter Comment HE |

File: o:hhewthdemodemao'sbrk. o -
(]
Cancel
Comment ; —l

[ &pply comment to all files

Figure 8.12: Please Enter Comment Dialog

Y ou may specify acomment for each file or, if you would like to specify the same comment for
all files, check the “ Apply comment to all files’ check box before clicking “OK”.
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8.34 Specifying a User Name and Passwor d

Most version control tools will require you to pass a user name and password on the command line
in order to keep files secure and to keep arecord of which files were changed by which users. The
custom version control support provides two placeholders “User login name”, $(USERNAME),
and “User login password”, $(PASSWORD). When the command is executed, these placeholders
will be replaced with the current settings in the “General” tab of the “Version Control Setup”
diaog (figure 8.13).

Version Control Setup K E

Commands | Projects  General l
E=ecution :

[+ Prompt before executing command
[ Runin DOS Window
[ Use forward slazh ' as version contral directony delimiter

|lzer details ;

Idzer: JHARE.

EEEREE

FPazgward ;

Configuration file:
Current verzion control configuration file:

C:AHew'\Project] \Customt/C5. hve

(] Cancel Expaort... Impart...

Figure 8.13: Version Control Setup Dialog General Tab
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In order to give the $(USERNAME) and $(PASSWORD) fields a value you will first need to
login. If you have not logged in before a command is executed which uses either of these
placeholders then you will be prompted to do so before the command can be executed.

2 Tologin (i.e. specify auser name and password):
1. Clickthe“Login...” button. The dialog shown in figure 8.14 will be displayed.
2. Enter your user name into the “User name” field.
Enter your password into the “Password” field.
Re-type your password again into the “ Confirm password by retyping it below” field.

Click “OK” to set the new user name and password. If there is any inconsistency between
the two versions of the password which you entered then you will be requested to type your
password again.

g s~ w

Log in EHE |
szer name : 0k I
[JHARK.

Cancel |
Pazsword :

Ixxxxxxx

LCanfirm pazsword by retyping it below

Ixxxxxx

Figure8.14: Login Dialog
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8.4 Controlling Execution

The " General” tab of the “Version Control Setup” diaog (figure 8.13) allows you to control the
way in which the version control tool is executed. It also showsthe full path to the current version
control configuration file.

84.1 Prompt befor e executing command

If this check box is set then, before any version control commands are executed, adialog is
displayed (figure 8.15) which lists al of the filesinvolved in the operation. Files may be
deselected by clearing the associated check box. Clicking “ OK” will apply the command to each
of the selected files. Clicking “Cancel” will abort the operation.

History HE

Filez :
w]demo.c  [ohhew'demo'.demo)

[w] shirk. [2:Shewhdemotdema) Cancel |

[w]vecttbl.zre [o:vhew'demo'.demao)]

KN — 2|

Figure 8.15: Command Prompt Dialog (Example)

8.4.2 Run in DOS Window

By default, the output of the version control commands is redirected to the “Version Control” tab
of the “Output” window. If you would rather run each command in a separate DOS window then
set this check box.

8.4.3 Useforward dslash /" asversion control directory delimiter

By default, when the HEW substitutes the placeholder $(VCDIR) it uses the backward slash
character ‘\' to divide directories. However, if the version control system you are using uses a
forward slash character (e.g. Visual SourceSafe) to divide directories then set the “ Use forward
slash */" as version control directory delimiter”.
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8.5 Importing and exporting a Set-up

Each workspace can have a different version control set-up. The HEW allows you to store the
version control settings independently so that you can import them into other workspaces. This
greatly reduces the amount of time it takes to configure the same version control settings across
several workspaces.

S Toexport aversion control set-up:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Click the “Export..."” button. A standard file save dialog will be displayed. Browse to the
directory in which you would like to save the configuration.

3. Enter the name of the file and then click “OK”.
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S Toimport aversion control set-up:
1. Select [Version Control->Configure...]. Thedialog shown in figure 8.1 will be displayed.

2. Click the“Import...” button. A standard file open dialog will be displayed. Browse to the
* HVC file which you would like to import.

3. Select the file and then click “OK”.
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9. Using Visua SourceSafe

The High-performance Embedded Workshop provides specific support for the Visual SourceSafe
version control system. At the time of writing, the HEW can only attach to versions 5 and 6 of
Visual SourceSafe.

The Visual SourceSafe version control system associates a project in your workspace with a
project inside a Visual SourceSafe database. It alows you to quickly invoke the standard
commands either by selecting an option from the [Tools->Version Control] sub-menu or by
clicking aversion control toolbar button.

9.1 Attaching Visual SourceSafeto a Workspace

The following sections describe how you can associate Visual SourceSafe with your current
workspace.

911 Selecting Visual Sour ceSafe
First, you need to select Visual SourceSafe as the version control system.

9 TouseVisua SourceSafe 5.0 or 6.0:

1. Select [Tools->Version Control->Select...]. The“ Select Version Control System” dialog
will be displayed (figure 7.3) which lists all of the supported version control systems.

2. Select the “Visual SourceSafe 5.0/6.0" entry from the Version Control Systems list and
click the “Select” button.

3. Click “OK” to confirm the selection. The SourceSafe Login dialog is displayed (figure 9.1).
4. Enter your Visua SourceSafe login into “Username” and password into “Password” .

5. Enter into Database path the full path to the Visual SourceSafe database (i.e.
SRCSAFE.INI) into which you would like to add this project.

6. Click “OK”. The “Create SourceSafe Project” dialog isinvoked (figure 9.2).

7. The*Project name” field displays the name of the project (i.e. folder) to be created in the
database. If necessary you can change this name to another.

8. Thetree underneath the “ Project name” field shows the structure of the database specified
in step 6. Select the folder into which you would like to create the folder specified in the
“Project name” field.

9. Click “OK”".

10. HEW will require you to repeat steps 7-9 for as many projects as are present in the current
workspace.
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SourceSafe Login H |

I zemame: I
Fazzword: I ﬂl
Databaze path: I Browse. .. |

Figure 9.1: SourceSafe Login Dialog

Create SourceSafe Project EE

Project name:

Ipru:uieu:t

Cancel |

$/project

Eal% agip ﬂ

..... (3 d?f ;I

Figure 9.2: Create Sour ceSafe Project

The HEW has now created the necessary projects within Visua SourceSafe and sets-up the
version control toolbar and menu for immediate access. However, although the Visual SourceSafe
projects themselves have been created, no files have been added to them.

9.1.2 Adding filesto Visual SourceSafe

The previous section has only established the mappings between the project directory on your hard
disk (i.e. the working directory) and the project directory in Visual SourceSafe (i.e. the controlled
directory). Although the project directory (and any subdirectories) on your hard disk may contain
many source files whereas the directly its mapped to in Visual SourceSafe will beinitially empty.

Firstly, you must select Visual SourceSafe as the version control system.

2 Toadd afileor filesto Visual SourceSafe:
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1. Select thefile(s), which you would like to add to Visual SourceSafe. Y ou may also select a
file folder, project folder, a workspace folder or combination thereof. When selecting the
project or workspace folder then the system files will be added to the selected file list. For
example, selecting the project folder will aso add the project file to thefilelist. If the
project fileis then checked out and the version is newer than when it was last loaded you
will be asked whether you want to reload the project.

4. Click the Add Files toolbar button ( @?) or select the [Tools->Version Control->Add
Files] menu option.

When you add files to Visual SourceSafe the local versions in your working directory will become
read only. To check that the add files operation was carried out as you expected, or to quickly
review the status of all of thefilesin a project:

1. Select the poject folder whose files you want to check.
2. Click the Status of Files toolbar button ( @. ) or select the [Tools->Version Control-
>Status of Files] menu option.

3. The status of each file will be displayed in the “Version Control” tab of the “Output”
window. The information shown includes whether the file is added to the project, if the
fileis checked out and, if it is checked out, who did so.
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9.2 Visual SourceSafe commands
The following 8 operations are available:

e Add afileto version control

* Remove afile from version control

» Get aread only copy of afileor files

» Check out aread/write copy of afileor files (i.e. for editing)

« Check in apreviously checked out file or files (i.e. update Visual SourceSafe with the edits
made)

e Undo apreviously check out operation on afile or files (i.e. cancel any edits made)*
* View the status of afile
e View the history of afile

*These commands can only be accessed viathe [Tools->Version Control] sub-menu whereas all
of the other commands can be accessed from both the toolbar and menu.

921 Removing a File from Version Control

Although files appear in your HEW project (in the “Projects’ tab of the “Workspace” window,
Visual SourceSafeis not necessarily controlling them.

S Toremove afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to remove from Visual SourceSafe. Y ou may also
select afile folder, project folder, aworkspace folder or combination thereof.

2. Click the Remove Files toolbar button ( @- ) or select the [Tools->Version Control-
>Remove Files| menu option.

9.2.2 Getting a Read Only Copy of a Filefrom Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable
copy of acontrolled file at any one time. However, it is possible for any user to obtain aread only
copy of any file.

2 Toget aread only copy of afileor filesfrom Visua SourceSafe:

1. Select thefile(s), which you would like to get from Visual SourceSafe. Y ou may also select
afilefolder, project folder, a workspace folder or combination thereof.

2. Click the Get Files toolbar button ( %‘ ) or select the [Tools->Version Control->Get
Files] menu option.
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9.23 Checking Out a Writable Copy of a Filefrom Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable
copy of acontrolled file at any one time. The check out operation takes a writable copy of thefile
from Visual SourceSafe and placesit on your local drive. This can only be done if another user
does not already check out thefile or filesin question.

2 To check out awritable copy of afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to check out from Visual SourceSafe. Y ou may
also select afile folder, project folder, aworkspace folder or combination thereof.

2. Click the Check Out Files toolbar button ( 5 ) or select the [Tools->Version Control-
>Check Out Files| menu option.

9.24 Checking In a Writable Copy of a Fileinto Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable
copy of acontrolled file at any one time. The check out operation takes a writable copy of thefile
from Visual SourceSafe and places it on your local drive. Once afileis checked out it is edited
and then checked back in so that the edits can be made available to other users.

9 Tocheck in editsmadeto afile or filesin Visua SourceSafe:
1. Select the file(s) upon which you would like to check back into Visual SourceSafe. You
may also select afile folder, project folder, a workspace folder or combination thereof.

2. Click the Check In Filestoolbar button ( 5 ) or select the [Tools->Version Control-
>Check In] menu option.

9.25 Undoing a Check Out Operation

Visual SourceSafe protects your source files and ensures that only one user can have awritable
copy of acontrolled file at any one time. The check out operation takes a writable copy of thefile
from Visual SourceSafe and placesit on your local drive. Once afileis checked out it is edited
and then checked back in so that the edits can be made available to other users. However, if the
check out operation was carried out by mistake, or perhapsis no longer required, then the
operation can be undone.

2 Toundo acheck out of afileor filesfrom Visua SourceSafe:

1. Select the file(s) upon which you would like to undo a previous check out operation. Y ou
may also select afile folder, project folder, a workspace folder or combination thereof.

2. Select the[Tools->Version Control->Undo Check Out] menu option.
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9.2.6 Viewing the Status of a File

Although files appear in your HEW project (in the Projects tab of the Workspace window), Visual
SourceSafe is not necessarily controlling them. Of those files, which are being controlled by
Visual SourceSafe, some will be checked in and others will be checked out (i.e. being edited by a
user). The status command displays the current status of afile or file(s).

2 Toview the status of afileor filesin Visual SourceSafe:

1. Select the file(s) whose status you would like to view. Y ou may also select afile folder,
project folder, aworkspace folder or combination thereof.

2. Click the Status of Files toolbar button ( @. ) or select the [Tools->Version Control-
>Status of Files| menu option.

9.2.7 Viewing the History of a File

Visual SourceSafe controls the edits to the filesin its projects and allows you to view the complete
history of these edits right back to the time that the file was first added to the project.

2 Toview the history of afileor filesin Visual SourceSafe:

1. Select the file(s) whose history you would like to view. You may also select afile folder,
project folder, aworkspace folder or combination thereof.

2. Select the[Tools->Version Control->Show History] menu option.
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9.3 Visual SourceSafe I ntegration Options

Y ou can control the way in which the history and status commands are displayed by selecting
[Tools->Version Control->Configure...].

To display the results of a history command in adialog box then check the “Display dialog box for
history” check box or clear it if you would rather display the output in the “Version Control” tab
of the “Output” window. To display the results of a status command in adialog box then check the
“Display dialog box for file status’ check box or clear it if you would rather display the output in
the“Version Control” tab of the “Output” window.
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Sectionl Overview

The High-performance Embedded Workshop (HEW) is a graphical user interface intended to ease
the development and debugging of applications written in C/C++ programming language and

assembly language for Renesas microcomputers. Its aimis to provide a powerful yet intuitive way
of accessing, observing and modifying the debugging platform in which the application is running.

The E10A emulator (hereafter referred to as the emulator) is a software and hardware development
support tool for application systems using the H8S series microcomputer.

The PCMCIA card emulator or PCI card emulator (hereafter referred to as the card emulator),
which is the main unit of the emulator, is connected, through the dedicated debugging interface, to
the user system. The user system can be debugged under the conditions similar to the actual
application conditions. The emulator enables debugging anywhere indoors or out. The host
computer for controlling the emulator must be an IBM PC compatible machine with a PCMCIA
type Il or PCI dlot.

Figures 1.1 and 1.2 show the system configuration using the emulator.

Host computer (PC with PCMCIA TYPE Il slot)

PCMCIA card emulator

fIT T I T
A ﬁ/f//f/ L

-’

User system interface cable

H8S/xxxx

Insert into the PCMCIA TYPE Il slot

Connect to the 14-pin connector
User system

Figurel.1 System Configuration with the Emulator (PCMCIA Card Emulator Used)
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User system interface cable

PCI card emulator
y: H8S/xxxx
Vi

Insert into
the PCI slot

User system

Host computer
(PC with PCI slot)

Figure 1.2 System Configuration with the Emulator (PCI Card Emulator Used)
The emulator has two activation modes:

1. A modein which the emulator program is connected after it has been downloaded to the
target device:

This mode is used when there is no emulator program in the flash memory of the target device.
2. A modein which the emulator is used as the flash memory writer:
This mode is used when the emulator is used for writing to flash memory.

The emulator provides the following features:

» Excellent cost-performance card emulator
Compactness and low price are implemented using the PCMCIA interface or the PCI interface.
* Redtime emulation
Resaltime emulation of the user systemis enabled at the maximum operating frequency of the
MCU.
* Excellent operability
Using the High-performance Embedded Workshop (HEW) on the Microsoft® Windows® 98,
Microsoft® Windows® Me, Microsoft® Windows NT®, Microsoft® Windows® 2000, and
Microsoft” Windows® X P operating systems enables user program debugging using a pointing
device such asamouse. The HEW enables high-speed downloading of load module files.

188
RENESAS




High-performance Embedded Workshop User's Manual

Various debugging functions

Various break and trace functions enable efficient debugging. Breakpoints and break
conditions can be set by the specific window, trace information can be displayed on awindow,
and command-line functions can be used.

Memory access during emulation

During emulation, the memory contents can be read and modified.

Debugging of the user system in the final development stage

The user system can be debugged under conditions similar to the actual application conditions.
Compact debugging environment

When the card emulator specific to the PCMCIA interface is used, alaptop computer can be
used as a host computer, creating a debugging environment in any place.

The emulator can be used to write to the internal flash memory.
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1.1 Environmental Conditions

CAUTION

Observe the conditions listed in tables 1.1 and 1.2 when
using the emulator. Failure to do so will damage the user
system and the emulator product. The USER PROGRAM will
be LOST.

Table1.1 Environmental Conditions

Item Specifications

Temperature Operating: +10°C to +35°C
Storage: —10°C to +50°C

Humidity Operating: 35% RH to 80% RH, no condensation
Storage: 35% RH to 80% RH, no condensation
Vibration Operating: 2.45 m/s® max.
Storage: 4.9 m/s* max.

Transportation: 14.7 m/s* max.

Ambient gases  There must be no corrosive gases present
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Table 1.2 lists the acceptabl e operating environments.

Table1.2 Operating Environments

Item

Description

Host computer

Built-in Pentium® 1l or higher-performance CPU (600 MHz or higher
recommended); IBM PC or compatible machine with the PCMCIA
TYPE Il slot or the PCI slot.

(O

Windows® 98, Windows® Me, Windows NT®, Windows® 2000, and
Windows® XP

Minimum memory
capacity

128 Mbytes or more (double of the load module size recommended)

Hard-disk capacity

Pointing device such as
mouse

Power voltage

Current consumption

Installation disk capacity: 100 Mbytes or more. (Prepare an area at
least double the memory capacity (four-times or more recommended)
as the swap area.)

Connectable to the host computer; compatible with Windows® 98,
Windows® Me, Windows NT®, Windows® 2000, and Windows® XP.

5.0 £ 0.25 V (The power is supplied to the emulator by the host
computer.)

HSO0005KCMO5H: 55 mA (max)
HSO0005KCI05H: 55 mA (max)

CD-ROM drive

Required to install the HEW and the emulator or refer to the emulator
user's manual.

12 Components

Check all the components unpacking. For details on the E10A emulator components, refer to
section 1.1 in the separate document, Specific Guide for the H8S/xxxx E10A Emulator. If the
components are not complete, contact our E-mail address for user registration or refer to the web

site.
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Section 2

E10A Emulator Functions

This section describes the emulator functions. They differ depending on the device supported by
the emulator. For the usage of each function, refer to section 6, Tutorial.

2.1 Overview

Table 2.1 gives afunctional overview of the emulator.

For the functions of each product, refer to the online help.

Table2.1 Emulator Functions

No. Item Function
1 User program execution « Executes a program with the operating frequency within a
function range guaranteed by devices.
¢ Reset emulation
e Step functions:
Single step (one step: one instruction)
Source-level step (one step: one source)
Step over (a break did not occur in a subroutine)
Step out (executed until a program is returned to the original
call function in a subroutine where a PC is being executed)
2 Reset function e Issues a power-on reset from the HEW to the device during
break.
3 Contents of trace « Branch trace function incorporated in the device (four
acquisition branches: min)
4 Break conditions « Hardware break condition (two conditions: min)

PC break condition (255 points)
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Table2.1 Emulator Functions (cont)

No. Item

Function

5 Memory access function

Downloads to RAM
Downloads to flash memory
One-line assemble
Reversed assemble

Reads memory

Writes to memory

Automatically updates the display of variables during user
program execution

Fill
Search
Move
Copy

6 General/control register
access function

Reads or writes the general/control register.

7 Internal I/O register
access function

Reads or writes the internal I/O register.

8 Source-level debugging Various source-level debugging functions.
function
9 Command line function Supports command input.

Batch processing is enabled when a file is created by arranging
commands in input order.

10 Help function

Describes the usage of each function or command syntax input
from the command line window.

The specific functions of the emulator are described in the next section.

Note:  The number of hardware break conditions differs depending on the product.
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2.2 Trace Functions

The branch source addresses, mnemonics, operands, and source lines are displayed. Since this
function uses the trace buffer built into the device, a realtime trace can be acquired.

2.3 Break Function
The E10A emulator has the following two break functions.

(1) Hardware break function
Uses a break controller incorporated in the device.
The access address, instruction fetch address, data, or bus cycle condition can be set.

This function can be a'so set from the EVENT column in the editor window. For the setting,
refer to section 5.2, Viewing a Program.

(2) PC break function (BREAKPOINT)
Breaks when the instruction of the specified addressis replaced by the dedicated instruction.

This function can be set on the [Breakpoint] page in the [Event] dialog box. It can aso be set
when the [Editor] column for the line to be set is double-clicked in the [Source] or
[Disassembly] window.
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24 Memory Access Functions
The emulator has the following memory access functions.

(1) Memory read/write function

[Memory] window: The memory contents are displayed in the window. Only the size specified
when the [Memory] window is opened can beread. If the memory iswritten
in the [Memory] window, aread in the range displayed in the [Memory]
window will occur for updating the window. When the [Memory] window is
not to be updated, change the setting in [Lock Refresh] from the popup menu.

me command: A command line function that reads or writes the specified address with the
specified size.

(2) User program downloading function

A load module registered in the workspace can be downloaded. Such module can be selected
from [Download Modul€g] in the [Debug] menu. Downloading is also possible by clicking the
load module in the workspace by a popup menu that is opened by right-clicking on the mouse
within the window. The user program is downloaded to the RAM or flash memory.

This function a so downloads information required for source-level debugging such as
debugging information.

(3) Memory data uploading function

The specified size from the specified address can be saved in thefile. Thefileis S-type-
formatted.

(4) Memory data downloading function

The memory contents saved in the S-type-formatted file can be downloaded. Select [Load)]
from the popup menu in the [Memory] window.

(5) Displaying the variable contents
The variable contents specified in the user program are displayed. For the usage of the function
for displaying the variable contents, refer to section 5.12, Looking at Variables.

(6) Other memory operation functions
Other functions are as follows:
*  Memory fill
*  Memory copy
*  Memory save
*  Memory verify
e Memory search
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e Internal 1/O display
» Displaying label and variable names and their contents

Notes: 1. Memory access during user program execution:
When amemory is accessed from the memory window, etc. during user program
execution, the user program is resumed after it has stopped in the emulator to access
thememory. Therefore, realtime emulation cannot be performed.
2. Memory access during user program break:
The program can also be downloaded and the BREAKPOINT can be set for the flash
memory area by the emulator.

25 Stack Trace Function

The emulator uses the stack’s information to display the name of the calling function for a
function at which the program counter is currently pointing. This function can be used only when
the load module that has the Dwarf2-type debugging information isloaded. For the usage of this
function, refer to section 6.19, Stack Trace Function.

2.6 OnlineHelp

An online help explains the usage of each function or the command syntax that can be entered
from the command line window.

Select [Emulator Help] from the [Help] menu to view the emulator help.
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Section 3 Preparation before Use

A WARNING

READ the reference sections shaded in figure 3.1 before
using the emulator product. Incorrect operation will damage
the user system and the emulator product. The USER
PROGRAM will be LOST.

Unpack the emulator and prepare it for use as follows:

Reference

| Unpack the emulator

| Check the components against the component list |

| Turn on the host computer |

Set up the emulator
- Install the HEW2
- Set up the main unit of the emulator

Turn off the host computer

Insert the card emulator into the host computer
and connect the emulator to the user system

Component list

) When the emulator
Section 3.1 is used first.

Section 3.2

| Turn on the host computer |

| When the emulator

f is used for second
| Start the HEW2 | Section 3.4 time or later.

| Turn on the user system |

Figure3.1 Emulator Preparation Flow Chart
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3.1 Emulator I nstallation

Insert the CD-R in the host computer’s CD-ROM drive, and then execute Setup.exe from the root
directory of the CD-R.

Follow the instructions given by the installation wizard to install the emulator.

Since hardware settings are also made during installation, the installation procedure differs
depending on the operating system or interface (PCI or PCMCIA) being used. Follow the
installation steps carefully depending on the environment you are using.

311 Installing under Windows® 98 or Windows® M e Operating System

(1) When the emulator isa PCI card:
1. Install the H8S/xxxx E10A emulator (when the component type has to be selected during
installation, be sure to select [PCI Card Driver]).
2. Shut the operating system down and turn off the power to the host computer.
3. Insert the PCI-card emulator in aslot on the host computer. Refer to section 3.2,
Connecting the Card Emulator to the Host Compuiter.
4. Restart the host computer. The hardware is now recognized and the driver is automatically
installed.*
(2) When the emulator isa PCMCIA card:
1. Install the H8S/xxxx E10A emulator (when the component type has to be selected during
installation, be sure to select [PC Card Driver (PCMCIA))).
2. Insert the PCMCIA-card emulator in the host computer’s slot. Refer to section 3.2,
Connecting the Card Emulator to the Host Compuiter.
3. Thehardwareis now recognized and the driver is automatically installed.*

Note:  When [Add New Hardware Wizard] is displayed, select the [Search for the best driver for
your device. (Recommended)] radio button and then the [Specify alocation] check box to
select the path to be searched for drivers. The location must be specified depending on the
emulator type, as indicated below:

When using the PCI-card emulator: <Drive>:\DRIVERS\PCI\98
When using the PCMCIA-card emulator: <Drive>:\DRIVERS\PCM CIA\98
(<Drive> isthe CD-ROM drive name.)
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Installing under Windows NT® 4.0 Operating System

(1) When the emulator isa PCI card:

1
2.

5.

Shut the operating system down and turn off the power to the host computer.

Insert the PCl-card emulator in aslot on the host computer. Refer to section 3.2,
Connecting the Card Emulator to the Host Compuiter.

Start the host computer and log-on with an administrator-level user name.

Install the H8S/xxxx E10A emulator. (For acomponent, be sure to select [PCI Card Driver].
Thereis acheck box for selecting the type name of the product under the [PCI Card

Driver] component. Select the appropriate type name. If the correct name is not selected,
the correct driver will not be installed, and the emulator will not operate.)

Restart the host computer.

(2) When the emulator isa PCMCIA card:

1
2.

6.

Shut the operating system down and turn off the power to the host computer.

Insert the PCM CIA-card emulator in the host computer’s slot. Refer to section 3.2,
Connecting the Card Emulator to the Host Computer.

Start the host computer and log-on with an administrator-level user name.

During emulator installation, the setting value should be checked beforehand because
inquiries are made about the resource used by the PCMCIA-card emulator.

Start the [Start] menu -> [Programs] -> [Administrative Tools (Common)] -> [Windows
NT Diagnostics], check the status of the IRQ, 1/0 port, and memory from the resource
panel, and determine the setting values that do not conflict with other devices. (The
following resources are used: IRQ: one channel, 1/0 port: H’F byte, and memory: H’4000
byte.)

Install the H8S/xxxx E10A emulator. (For a component, be sureto select [PC Card Driver
(PCMCIA)]. Thereisacheck box for selecting the type name of each product under the
[PC Card Driver (PCMCIA)] component. Select the appropriate type name. If the correct
name is not selected, the correct driver will not be installed and the emulator will not
operate.)

Restart the host computer.

Notes: The driver that has been selected in the [Drivers] component starts after the host computer

isinitiated. If the host computer isinitiated with the card disconnected or with the
incorrect driver installed, the driver cannot initiate and the service control manager
informs the system of an error. This, however, is not a problem.
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Installing under Windows® 2000 or Windows® XP Operating System

(1) When the emulator isa PCI card:

1
2.

Log-on with an administrator-level user name.

Install the H8S/xxxx E10A emulator. (When a component is selected, be sure to select [PCI
Card Driver].)

Shut the operating system down and turn off the power to the host computer.

Insert the PCl-card emulator in aslot on the host computer. Refer to section 3.2,
Connecting the Card Emulator to the Host Computer.

Restart the host computer and log-on with an administrator-level user name. The hardware
is now recognized and the driver is automatically installed.*

(2) When the emulator isa PCMCIA card:

1.
2.

4,

Log-on with an administrator-level user name.

Install the H8S/xxxx E10A emulator. (When a component is selected, be sure to select [PC
Card Driver (PCMCIA)].)

Insert the PCM CIA-card emulator in the host computer’s slot. Refer to section 3.2,
Connecting the Card Emulator to the Host Computer.

The hardware is now recognized and the driver is automatically installed.*

Note:  When [Found New Hardware Wizard] is displayed, select the [Search for a suitable driver
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for my device (recommended).] radio button and then the [ Specify alocation] check box
to select the path to be searched for drivers. The location must be specified depending on
the emulator type, as indicated below:

When using the PCI-card emulator: <Drive>:\DRIVERS\PCI\2000

When using the PCMCIA-card emulator: <Drive>:\DRIVERS\PCMCIA\2000

(<Drive> isthe CD-ROM drive name.)
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3.2 Connecting the Card Emulator to the Host Computer

Insert the card emulator into the PCMCIA TYPE I1 slot or the PCI slot of the host computer
(figures 3.2 and 3.3).

Note: Besuretoinstall the H8S/xxxx E10A emulator beforethe card emulator isinserted.

Host computer (PC with the PCMCIA TYPE Il slot)

= PCMCIA card emulator

Jiza s ]
=
e
F Z //f%
A

=

Insert into the PCMCIA TYPE Il slot

Figure3.2 Insertingthe PCMCIA Card Emulator in the Host Computer’s Slot

PCl card emulator

= "4

Insert into the PCI slot
-

[ ]
s ANRTSNEY

Host computer

Figure3.3 Insertingthe PCl Card Emulator in the Host Computer’s Slot

Use the procedure, described in section 3.3, to connect the emulator to the user system with the
user system interface cable, or to disconnect them when moving the emulator or the user system.
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Note:  When installing the PCI card emulator, note the following:
1. Turn off the host computer.
2. Insert the emulator into the PCI dlot in parallel.
3. Screw in the emulator after confirming the connector and cable positions.

3.3 Connecting the Card Emulator tothe User System

(1) The connector must be installed to the user system. Table 3.1 shows the recommended
connector for the emulator.

Table3.1 Recommended Connector

Type Number Manufacturer Specifications

2514-6002 Minnesota Mining & 14-pin straight type
Manufacturing Ltd.

Note: When the connector isused, do not install any componentswithin 3 mm of the
connector.

(2) The pin arrangement of the connector is shown in section 1.3 in the additional document,
Specific Guide for the H8S/xxxx E10A Emulator.

(3) Figure 3.4 shows how to connect the user system interface cable to the user system. Connect
the ground line of the cable to the user system ground. The end of the ground line has ahole
having a diameter of 3 mm, and therefore, when the ground line is screwed to the user system,
the screw diameter must be 3 mm.
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User system interface cable

GND line

User system connector

-~

User system

User system GND
connection

Figure 3.4 Connecting the User System Interface Cableto the User System

Notes: 1. To connect the signalsoutput from the connector, refer to the M CU pin
alignment.

2. Toremovetheuser system interface cable from the user system, pull the tab
on the connector upward.

3.  Therange of frequenciesthat the emulator operatesat isdifferent depending
on the M CUs used.

4. Connect the signals from the connector as shown in section 1.4 in the
additional document, Specific Guide for the H8S/xxxx E10A Emulator.
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34 System Check

When the software is executed, use the procedure below to check that the emulator is connected
correctly. Here, use the workspace for atutoria provided on the product.

Refer to section 4, Preparations for Debugging, for the other activating method to create a new
project or use aworkspace for the HEW of the old version.

1. Connect the emulator to the host computer.

2. Connect the user system interface cable to the connector of the emulator.

3. Connect the user system interface cable to the connector in the user system.
4

. Select [Renesas High-performance Embedded Workshop 2] -> [High-performance Embedded
Workshop 2] from [Programs] in the [Start] menu.

Accessones
=] Startup

Administrative Tools [Commeon]

eh-perfarmance Embedded Wark Tools
E Command Prompt @ High-perfor mance Embedded hop 2
g Internet Explorer E@ High-perfor mance Embedded Warkshop 2 Help

@ ‘windows NT Explarer @ High-performance Embedded Workshop 2 Read Me

Windows NT W\

Figure3.5 [Start] Menu

Note: The [Renesas High-performance Embedded Workshop 2] -> [Tools] is not displayed
depending on the user’s environment.
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5. The[Welcome!] dialog box is displayed.

Welcome!

— Ophions: oK

¥ iCreate a new project workspace Cancel

% " Open a recent project workspace: Administratian...

| i

i

]

g " Browse to anather project workspace

Figure 3.6 [Welcome!] Dialog Box
[Create anew project workspace] radio button: Creates a new workspace.

[Open arecent project workspace] radio button: Uses the current workspace and displays
the history of the opened workspace.

[Browse to another project workspace] radio button:  Uses the current workspace; this radio
button is used when the history of the
opened workspace does not remain

To use aworkspace for the tutorial, select the [Browse to another project workspace] radio button
and click the [OK] button.

When the [Open workspace] dialog box is opened, specify the following directory:
<HEW?2 installation directory>\T ool s\Renesas\DebugComp\Pl atform\E10A\xxxx\Tutorial

After the directory has been specified, select the workspace file (.hws) and press the [Open] button.
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Open Workspace ll EI
Loak jn; IaTutDriaI j & £F B

|1 Debue_H35_sow E108_ SYSTEM

| Source
@Tutu:urial.hws

File name: | Open I
Filzz of type: I'I.I'I.I'n:urkspaces 3 by LI Cancel |/
5

Figure 3.7 [Open Workspace] Dialog Box

6. The[Select Emulator mode] dialog box is displayed.

Select Emulator mode

| HES Ao =l

Device

ioee & E106 Emulator

 Writing Elash memary

Figure 3.8 [Select Emulator mode] Dialog Box

Select the device name in use from the [Device] drop-down list box. The following items are
selected in the [Mode] group box.

0 E10A Emulator
The emulator for the specified MCU is activated to debug programs.
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O Writing Flash memory

The user program is written to the flash memory. Debugging the program is disabled. To
download the load module, register it in the workspace.

7. The[Connecting] dialog box is displayed and the emulator connection is started.

Figure 3.9 [Connecting] Dialog Box
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8. Thediaog box isdisplayed as shown in figure 3.10.

L "_.,‘ Power on the target board and press <Enter> Key.
L

Figure3.10 Dialog Box of the Power-on Request M essage

9. Power on the user system.
10. Input the reset signal from the user system, and click the [OK] button.
11. After the following dialog box is displayed, input the system clock value.

Pleaze input Swetem Clock

i MHz

Figure3.11 [System Clock] Dialog Box

12. After the following dialog box is displayed, input the ID code. When the emulator is activated
in the [E10A Emulator] mode, input the ID code to be set.

ID Code

Pleaze input ID Code

—

[ Mew ID code

Figure3.12 [ID Code] Dialog Box
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13. When "Connected" is displayed in the [Output] window of the HEW, the emulator initiation is
completed.

3 Tutorial - High-perfor mance Embedd ap - [Tutorial.cpp]
< File Edit Wiew Project Options Buld Debug Memory Tools MWindow Help |2 EI

Dede @ o Tal|or @t e & 0|6 |5E||m Sl i

A ] ”J@m ||Debug_HBS_xxxx_E1UA_j||Sess|onHES_xxxx_E1UA_j|)1{"} |@E ”J@@. & & & @ ”JT Bl EfEL # 3o

SEEY SEIL L DENCHEIEED
=l x| &

s =

Bl = e FIIE Tutorial.cpp
=03 Tutorial #% DESCRIFPTION :Main Program
B2 C header file Sx
f Q shik.h <% This file is= generated by Project Generator (Ver. 2. 4).
[ soth ;*
‘e |2] stackseth
= a C source file #ifdef __cplusplus
i [2] dbsete ixtgr? "o
endi
EE — i woid abort(woid):
Bl Co+ source file #ifdef _ cplusplus
o Q resetprg.cpp
H Q sort.cpp #endif
[ Tutorial.epp #include “"sort.h”
523 Download modules #include <=tdlib h>
*- [ Tutarial.abs woid tutorial({woid);
=23 Dependencies
N woid main(void)
while (1){
tutorial():
}
}
woid tutorial(woid)
long a[10]; o
long 3@
int 1

claz= Sanple *p_=an:
p_sam= Sample;
for{ i=0; i<10; i++ ){
j = rand();
(3 < 03]
jo= -1

¥
afi] = i:

p_san—rsortia). =
] Projects | < Mavigation <l Doansachonasial L'_I

E.I Connected

A+ Build }, Debug £Find in Files }, Wersion Cantrol /

Ready

|Read-write  [10784 19 'S [ o

Figure3.13 HEW Window

Note:  When the user program has aready been downloaded to the flash memory, source-level
debugging cannot be executed because there is no debugging information on the user
program after the emulator has been activated.
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Notes: 1. If the user system interface cable is disconnected from the connector on the user
system, the following dialog box will appear.

L] "_.,‘ Connector disconnected. Please, connect and press <Enter’ kew.
L]

Figure3.14 [Connector disconnected] Dialog Box

2. If the emulator is not properly initialized, one of the dialog boxes shown in figures 3.15
through 3.18 will appear.
(@ Thefollowing dialog box is displayed when the flash memory cannot be erased.
Exchange the MCU since the flash memory has been rewritten to more times than the
limitation.

' Flazh memory eraze error!
= Chanee device.

Figure 3.15 [Flash memory eraseerror!] Dialog Box

(b) Thefollowing dialog box is displayed when the flash memory cannot be written to.
An incorrect system clock value has been input or the flash memory has been
rewritten to more times than the limitation.
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L] "_.,‘ Error =ending Flash memory write program
L

Figure3.16 [Error sending Flash memory write program] Dialog Box

(c) Thefollowing dialog box is displayed when an incorrect ID code has been input. For
security, the flash memory is completely erased.

L] "_.,‘ ID code error!
L]

Figure3.17 [ID codeerror!] Dialog Box

(d) Thefollowing dialog box is displayed when the MCU cannot communicate with the
emulator. Check the MCU settings.

L] "_.,‘ Boot Failed !
L]

Figure3.18 [Boot Failed!] Dialog Box

3. If anincorrect driver has been selected, the following dialog box will appear.
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' Unhable to restore the previous driver settings
= pleaze chooze another driver.

Figure3.19 [Unabletorestorethepreviousdriver settings] Dialog Box
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3.5 Uningtalling the Emulator’s Software

Follow this procedure to remove the installed emulator’ s software from the user’s host computer.

Astheinstaled product is known by the HEW, uninstall the product on the HEW screen.

1. Activatethe HEW.

2. Click the[Administration...] button in the [Welcome!] dialog box.

Welcome!

— Options:

& Create a new project workspace

" Open a recent project workspace:;

&

e

" Browse to another project waorkspace

i

k.
Cancel

Adminigtratiar,..

Fll

Figure3.20 [Welcome!] Dialog Box
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3. The[Tools Administration] dialog box is opened.

Tools Administration

Reqistered components:

Component

Wersioh

[ Toolchairs

; (23 Spstern Taolz

(23 Utility Phazes

-2 Debugger Components
|:| E stenzioh Components

<

| &

Cancel

Reqister...
hregister
Eioperties...
Epmart..
Search dizk. ..

Tool information...

JELLLRE

Uninstaller...

™ Show all components

Current HEW tools database location:

IE:\HEWE

Moadify...

;

Figure3.21 [Tools Administration] Dialog Box
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4, Click the [+] mark at the |eft of [Debugger Components] in the [Registered components] list
box to list the installed components. Then, highlight the product name to be uninstalled.

Tools Administration

Registered components:

]
.

[ EUELRRE

0

Component Werzion
=1-£3 Debugger Components

----- #9 Generc \watch View ECx 1.0

W Genenic Locals Wiew ECX 1.0

1.0

Cancel

Register...

Unregister

Generic Status Wiew ECH
Generic EMEMT Wiew EC 1.0
Generic Break Wiew ECH 1.0
----- #¢ Symbol Record object reader 1.0

W Genenic Trace View ECH 20
Generic StackTrace Yiew ECx 50
Generic Memory Wiew ECK 1.0
----- #4 ElfDwarf2 object reader 20

8L mammrim Dl mmimbme i fmnn O in

Properties. ..

e

Epport:..
Search disk. ..

Tool information. .

Urinstaller...

1

[ Show all components

-

Current HE tools database location:
|c;\|-|ew2 HModify..

Figure 3.22 Highlighting the Product to be Uninstalled

5. Click the [Unregister] button. After the following message box is displayed, click the [Y es]
button.

High-performance Embedded Warkshop

Unreqistering this tool removes it From the HEW svstem; consequently, it
will not be available bo any HEW WorkSpace.

Are you sure that wou want to unregisker it ¢

Figure3.23 [Unregistering thistool] M essage Box
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Thisisthe end of canceling the HEW registration. Then, remove the file for the emulator from
the host computer.

6. Click the[Uninstaller...] button in the [Tools Administration] dialog box to open the
[Uninstall HEW Tool] dialog box.

ninstall HEW Tool

Select the directony in which to begin the zearch for tools;

Browse. ..

Start

i

W Include subfolders

Located Toalz which can be uninstalled:

Component | W ergion | Installation Directony Wriirretal |

4] | i

Search Statuz:  Idle

Figure 3.24 [Uninstall HEW Tool] Dialog Box
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7. Click the [Start] button to list the installed components.

ninstall HEW Tool
) : . . Cloze |
Select the directony in which to begin the zearch for tools;

IE:HHEWE

W Include subfolders

Located Toalz which can be uninstalled:

Search Status: 1 file(z] found

Figure3.25 Highlighting the Product to be Uninstalled
8. Highlight the product name to be uninstalled and click the [Uninstall] button.

Thisisthe end of uninstallation.

CAUTION

A shared file may be detected while the program is being
removed. If another product may be using the shared file, do
not remove the file. If another product does not start up after
the removal process, re-install that product.
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Section 4 Preparations for Debugging

4.1 Wor kspaces, Projects, and Files

Just as aword processor alows you to create and modify documents, HEW allows you to create
and modify workspaces. A workspace can be thought of as a container of projects and, similarly, a
project can be though of as a container of project files. Thus, each workspace contains one or more
projects and each project contains one or more files. Figure 4.1 illustrates this graphically.

PROJECT
PROJECT
PROJECT

(]

WORKSPACE

Figure4.1 Workspaces, Projects, and Files

Workspaces allow you to group related projects together. For example, you may have an
application that needs to be built for different processors or you may be developing an application
and library at the same time. Projects can also be linked hierarchically within a workspace, which
means that when one project is built all of its“child” projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace
and then add files to that project before we can actually do anything.
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4.2 Method for Activating HEW
To activate the HEW, follow the procedure listed below.

1. Connect the emulator to the host computer and the user system, then turn on the user system.

2. Turn on the emulator. Be sure to turn on the user system before supplying power to the
emulator if you use the user system.

3. Select [High-performance Embedded Workshop 2] from [Renesas High-performance
Embedded Workshop 2] of [Programs] in the [Start] menu.

4, The[Welcome!] dialog box is displayed.

Welcome!

— Options: oK

* Create a new project workspace Cancel

% " Open a recent project workspace:; Administratian...

| i

Fll

2

E‘ " Browse to another project waorkspace

Figure4.2 [Welcome!] Dialog Box
[Create anew project workspace] radio button: Creates a new workspace.

[Open arecent project workspace] radio button: Uses the current workspace and displays
the history of the opened workspace.

[Browse to another project workspace] radio button:  Uses the current workspace; this radio
button is used when the history of the
opened workspace does not remain.

In this section, we describe the following three ways to start up the HEW:
e [Create anew project workspace] - atoolchainisnot in use

e [Create anew project workspace] - atoolchainisin use

* [Browseto another project workspace]
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The [Open arecent project workspace] radio button is used to omit the operation for specifying
the workspace file when [Browse to another project workspace] is selected.

421 Creating the New Workspace (Toolchain Not Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a
new project workspace] radio button and click the [OK] button.

Welcome!

— Options: oK

* Create a new project workspace Cancel

% " Open a recent project workspace:; Administratian...

| i

Fll

2

E‘ " Browse to another project waorkspace

Figure4.3 [Welcome!l] Dialog Box
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2. The Project Generator is started. This section omits the description on the setting for the
toolchain.
If you have not purchased the toolchain, the following dialog box is displayed.

Mew Project Warkspace EHE |

Workspace Mame;

Itest
Cancel
Project Mame:

Ilik

Itest Browse. ..

Directary:
IE:HH e test

CPU Farnily:
|Has Ha/200 =

Tool chain:

IN:::ne j

Project type:

Figure4.4 [New Project Workspace] Dialog Box

[Workspace Name] edit box:  Enter the new workspace name. Here, enter ‘test’.

[Project Name] edit box: Enter the project name. When the project name is the same as
the workspace name, it needs not be entered.

Other list boxes are used for setting the toolchain; the fixed information is displayed when the
toolchain has not been installed.
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3. Thefollowing dialog box is displayed.

— Targets :

Target type : |.~'1'-.|| Targets j

¢ Back I et > I Finizh | Cancel |

Figure4.5 [New Project — Step 7] Dialog Box

Check [H8S/xxxx E10A SY STEM] and click the [Next] button.
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4, Set the configuration file name. The configuration file saves the state of HEW except for the
emulator.

Configuration name :
IDEbug_HES_}{}{}G{_E1 0A_SYSTEM

— Detail options :

[term | Walue |

i adity |

< Back I [ Ewt | Finizh | Cancel |

Figure4.6 [New Project — Step 8] Dialog Box

Thisisthe end of the emulator setting.
Click the [Finish] button to exit the Project Generator. The HEW is activated.

5. After the HEW has been activated, the emulator is automatically connected. For operation
during connection, refer to section 3.4, System Check.
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422 Creating the New Workspace (Toolchain Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a
new project workspace] radio button and click the [OK] button.

Welcome!

o
¥ iCreate a new project workspace Cancel |

% " Open a recent project workspace: Administratian...

]

g " Browse to anather project workspace

Figure4.7 [Welcome!] Dialog Box
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2. The Project Generator is started. For details, refer to the High-performance Embedded

Workshop2 Tutorial, provided when you purchase the toolchain. This section omits the
description on the setting for the toolchain.

If you have purchased the toolchain, the following dialog box is displayed.

Mew Project Workspace

Workspace Mame;

Itest

Project Mame:

Cancel

Itest

Directary:

Browse. ..

Ilik

IE:"\H ehbest

CPU Farmily:

|Has Ha/300

T ool chain:

| HBS HE/300 Standard

Project type:

Demaonstration

@ Library

4]

@ Empty Application

i) HEShooo E10A Emulator Assemblyf
@ HESkeox E10A Emulator Empty Appli =

228

Figure4.8 [New Project Workspace] Dialog Box

[Workspace Name] edit box:
[Project Name] edit box:

[CPU family] drop-down list box:
[Tool chain] drop-down list box:

[Project type] list box:

Enter the new workspace name. Here, enter ‘test’.

Enter the project name. When the project name is the
same as the workspace name, it needs not be entered.
Select the target CPU family.

Select the target toolchain name when using the toolchain.
Otherwise, select [None].

Select the project type to be used.
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Notes: 1. For the EL0A emulator, either of the following project types isthe same:
[Application] and [H8S/xxxx EL0A Emulator Application]
[Assembly Application] and [H8S/xxxx E10A Emulator Assembly Application]
[Empty Application] and [H8S/xxxx E10A Emulator Empty Application]
2. When [Demonstration] is selected in the EI0A emulator, note the following:
The [Demonstration] is a program for the ssmulator. When using a program to be
generated, delete the Printf statement.

3. Make the required setting for the toolchain. When the setting has been compl eted, the
following dialog box is displayed.

— Targets :

[ JH2/300 Simulator

[ JH8/300HA Sirmulator
[ JHB/300HM Simulator
[ JH3/300L Sirnulator
[JHE5 /20008 Simulator
[HES /20000 Sirmulator
[JHES /26008 Simulator
[HES /26000 Simulator
FHES fuws ET08 SYSTEM

Target type : |.~'1'-.|| Targets j

¢ Back | Mext > I Finizh | Cancel |

Figure4.9 [New Project — Step 7] Dialog Box

Check [H8S/xxxx E10A SYSTEM] and click the [Next] button. Mark other products as
required.
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4, Set the configuration file name. The configuration file saves the state of HEW except for the
emulator.

Configuration name :
IDEbug_HES_}{}{}G{_E1 0A_SYSTEM

— Detail options :

[term | Setting |

i adity |

< Back | Rt I Firizh | Cancel |

Figure4.10 [New Project — Step 8] Dialog Box

Thisisthe end of the emulator setting.
Exit the Project Generator depending on the instructions on the screen. The HEW is activated.

5. After the HEW has been activated, connect the emulator. However, it is not needed to connect
the emulator immediately after the HEW has been activated.
To connect the emulator, use one of the methods (a) and (b) below. For operation during
connection, refer to section 3.4, System Check.

(a) Connecting the emulator after the setting at emulator activation
Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box. Itis
possible to register the download module or the command chain that is automatically executed

at activation. For details on the [Debug Settings] dialog box, refer to section 4.3, Setting at
Emulator Activation.
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After the [Debug Settings] dialog box has been set, when the dialog box is closed, the emulator
is connected.

(b) Connecting the emulator without the setting at emulator activation

The emulator can be easily connected by switching the session file that the setting for the
emulator use has been registered.

Fle Edt Vew Project Options Buld Tods Window Help

R E R A = e e =R ) = & % || 7

i ||| 8 o oo # |5 = [[& e |EEEE s ® @
Lz

===

E@lesl

" & Projects [ Navigation

e

%1\ Build £ Debug J\Find n Files A, Version Gontrol 7

[ = = s [ um
hstart || DyHene | $)4-10.6mp - paint | Sversio | ByEsEventitoioon | Eukeca | EBecevent.op - 1HuT32 [ test - Hitack Embed... | @15, 3s2pm

Figure4.11 Selecting the Session File

Inthelist box that iscircled in figure 4.11, select the session file name including the character
string that has been set in the [Target name] text box in figure 4.10, [New Project — Step 8] dialog
box. The setting for using the emulator has been registered in this session file.

After selected, the emulator is automatically connected.
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423 Selecting an Existing Wor kspace

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Browse to
another project workspace] radio button and click the [OK] button.

Welcome!

o
{~ Create a new project workspace Cancel |

% " Open a recent project workspace: Administratian...

]

e B ) iﬁrnwse to another project workspace

Figure4.12 [Welcome!] Dialog Box

2. The[Open Workspace] dialog box is displayed. Select adirectory in which you have created a
workspace.
After that, select the workspace file (.hws) and press the [Open] button.

2 x|

Cpen Workspace i
Laak. in: IaTutDriaI j = 5 Edr

|_JDebug_HE5_ oo E104 SYSTEM |
|| Source
@Tutu:urial.hws

File name; | Open I
Files of lpe: I'l.l'l.l'l:lrkSpaI:ES * bz ) j Cancel |/
2

Figure4.13 [Open Workspace] Dialog Box
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3. Thisactivates the HEW and recovers the state of the sel ected workspace at the time it was
saved.
When the saved state information of the selected workspace includes connection to the
emulator, the emulator will automatically be connected. To connect the emulator when the
saved state information does not include connection to the emulator, refer to section 4.5,
Connecting the Emulator.
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4.3 Setting at Emulator Activation

When the emulator is activated, the command chain can be automatically executed. It isaso
possible to register multiple load modules to be downloaded. The registered load modules are
displayed on the workspace window.

1. Select [Debug Settings...] from the [Options] menu to open the [Debug Settings] dialog box.

Debug Settings

|SessionHBS _xox_E104_SvS[z] | Taiget | Options |

------ I@ T ukarial

Default Debug Format:

|El/Dwarf2 =l

Download Modules:

File M ame I Offzet Addressz I Forme Add.
SCONFIGDIRNS.. H'O0000000 ElD

EEmoyve

el Edifyl..

il

g

f

[N

(] I Cancel |

Figure4.14 [Debug Settings] Dialog Box ([Target] Page)

2. Select the product name to be connected in the [Target] drop-down list box.

3. Select the format of the load module to be downloaded in the [Default Debug Format] drop-
down list box, then register the corresponding download module in the [Download Modules)
list box.

4. Click the [Options] tab.
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Debug Settings

I SeszionHI S _oos_E1 DA_SYBj Target Dptions

""" @ Tutarial Command batch file load timing:

Al targ

et connection

Command Line Batch Processing:

[V | Conmect up e target om debugias

¥ Download modules after build

Figure4.15 [Debug Settings] Dialog Box ([Options] Page)

The command chain that is automatically executed at the specified timing isregistered. The
following three timings can be specified:

« At connecting the emulator
e Immediately before downloading
e Immediately after downloading

Specify the timing for executing the command chain in the [Command batch file load timing]
drop-down list box. In addition, register the command-chain file that is executed at the specified
timing in the [Command Line Batch Processing] list box.
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4.4 Debugger Sessions

The HEW stores all of your builder optionsinto a configuration. Inasimilar way, the HEW stores
your debugger optionsin asession. The debugging platforms, the programs to be downloaded,
and each debugging platform’s options can be stored in a session.

Sessions are not directly related to a configuration. This means that multiple sessions can share
the same download module and avoid unnecessary program rebuilds.

Each session’s data should be stored in a separate file in the HEW project. Debugger sessions are
described in detail below.

441 Selecting a Session
The current session can be selected in the following two ways:

* From the toolbar
Select a session from the drop-down list box (figure 4.16) in the tool bar.

IDebug j ||DefauItSessiu:un j | 2 ‘@ [ | &

—

Figure4.16 Toolbar Selection
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e From the dialog box

1. Select [Options -> Debug Sessions...]. Thiswill open the [Debug Sessions] dialog box
(figure 4.17).

Debug Sessions

Debug sessions: OF.

Default5esszion
SeszionHES e _E10A_SYSTEM Cancel

dd
Hemmve
Have a5,

Eroperties

LLEEE

Current zezgion;
DefaultSeszion j

Figure4.17 [Debug Sessions] Dialog Box

2. Select the session you want to use from the [Current session] drop-down list.
3. Click the [OK] button to set the session.
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Adding and Deleting Sessions

A new session can be added by copying settings from another session or deleting a session.

e Toadd anew empty session

1

o g ks wbN

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure
4.17).

Click the[Add...] button to display the [Add new session] dialog box (figure 4.18).
Check the [Add new session] radio button.

Enter a name for the session.

Click the [OK] button to close the [Debug Sessions] dialog box.

This creates afile with the same name as the entered session name. |If the file name aready
exists, an error is displayed.

Add new session i E3 |

™ Add new session

Cancel

] I
M arme: |

& Usze an existing session file

M ame:

ITutu:uriaI

Sezzion file path:

I Browse |

¥ Open and maintain link to session file

[ Make sezsion file link read anly
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Figure4.18 [Add new session] Dialog Box
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To import an existing session into anew session file

1

o > w D

6.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure
4.17).

Click the[Add...] button to display the [Add new session] dialog box (figure 4.18).
Check the [Use an existing session fil€] radio button.

Enter a name for the session.

Browse to the existing session file location that you would like to import into the current
project.

If the [Open and maintain link to session file] check box is not checked, the imported new
session file is generated in the project directory.

If the [Open and maintain link to session file] check box is checked, anew sessionfileis
not generated in the project directory but is linked to the current session file.

If the [Make session file link read only] check box is checked, the linked session fileis
used as read-only.

Click the [OK] button to close the [Debug Sessions] dialog box.

To remove asession

1

4.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure
4.17).

Select the session you would like to remove.

Click the [Remove] button.

Note that the current session cannot be removed.

Click the [OK] button to close the [Debug Sessions] dialog box.

To view the session properties

1

2.
3.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure
4.17).

Select the session you would like to view the properties for.
Click the [Properties] button to display the [Session Properties] dialog box (figure 4.19).

Session Properties

M ame: SeszionHBS oeo E10A_SYSTEM : |
Location: Cit Hew? \testt SeszionHE8S _eoe E104A_SYSTEMhhz c I
Last modified:  20:40:25, Thursday, January 30, 2003 il

[ Beadonly

Figure4.19 [Session Properties] Dialog Box
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To make a session read-only

1

5.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure
4.17).

Select the session you would like to make read-only.

Click the [Properties] button to display the [Session Properties] dialog box (figure 4.19).
Check the [Read only] check box to make the link read-only. Thisisuseful if you are
sharing debugger-setting files and you do not want data to be modified accidentally.
Click the [OK] button.

To save a session with a different name

1

o s wD

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure
4.17).

Select the session you would like to save.

Click the[Save as...] button to display the [Save Session] dialog box (figure 4.20).
Browse to the new file location.

If you want to export the session file to another location, leave the [Maintain link] check
box unchecked. If you would like the HEW to use this location instead of the current
session location, check the [Maintain link] check box.

Click the [Save] button.

Save jn: Ia Tutarial j A £ ED-

| IRelease
|:| Source
SezzionHES oo E10A_SYSTEMhat

File name: | Save I
Save 5t lype: ISESSiDnS [*hsf] | Cancel |

[ Maintain link

Z
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Figure4.20 [Save Session] Dialog Box

RENESAS




High-performance Embedded Workshop User's Manual

443 Saving Session | nfor mation

e Tosaveasession
Select [File -> Save Session].
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4.5 Connecting the Emulator
Select either of the following two ways to connect the emulator:

(1) Connecting the emulator after the setting at emulator activation
Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box. Itis
possible to register the download module or the command chain that is automatically executed
at activation. For details on the [Debug Settings] dialog box, refer to section 4.3, Setting at
Emulator Activation.
When the dialog box is closed after setting the [Debug Settings] dialog box, the emulator will
automatically be connected.

(2) Connecting the emulator without the setting at emulator activation

Connect the emulator by simply switching the session file to one in which the setting for the
emulator use has been registered.
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Window Help

o= ale]yseldnal||lomEslEne o S| B

[F=a = = DefaulSession | R [Erene e Gl ERETErEwi
o AT —

o= =

E@lesl

" & Projects [ Navigation

I

%1\ Build £ Debug J\Find n Files A, Version Gontrol 7

[ = [— ms I um
iglstart| | ByHewe | $)4-10.6mp - paint | Sversio | ByEsEventitoioon | Eukeca | EBecevent.op - 1HuT32 [ test - Hitack Embed... | @15, 3s2pm

Figure4.21 Selecting the Session File

Inthelist box that iscircled in figure 4.21, select the session file name including the character
string that has been set in the [ Target name] text box in figure 4.10, [New Project — Step 8] dialog
box. The setting for using the emulator has been registered in this session file.

After the session file name is selected, the emulator will automatically be connected. For details
on the session file, refer to section 4.4, Debugger Sessions.
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4.6 Ending the Emulator
When using the toolchain, the emulator can be exited by using the following two methods:

» Canceling the connection of the emulator being activated
o Exiting the HEW

(1) Canceling the connection of the emulator being activated

1. Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box
([target] page) (seefigure 4.14).

2. Select <None> or another product in the [Target] drop-down list box. When another product is
selected, the connection with that product is started after canceling the connection of the
emulator being activated.

(2) Exiting the HEW

1. Select [Exit] from the [File] menu.

2. A message box is displayed. If necessary, click the[Y es] button to save a session. After
saving a session, the HEW exits. If not necessary, click the [No] button to exit the HEW.

& Session has been modified - do you wank to save it

Mo Zancel

Figure4.22 Message Box
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Section5 Debugging

This section describes the debugging operations and their related windows and dialog boxes.
51 Setting the Environment for Emulation

511 Opening the [Configuration] Dialog Box

Selecting [Options -> Emulator -> System...] or clicking the [Emulator System] toolbar button
(E) opens the [Configuration] dialog box.

512 [General] Page

Sets the emulator operation conditions.

Configuration 5'
General

Device IjHBSfxxxx LI
Emulation mode IN:::rmaI LI
Step option IDisaI:uIes interrupts during sinele step execution ;I
S Glaeis [1.031MHz =]
Flash memory Dizahl

synchronization I 1=abie LI

o] 4 I Cancel | Apply

Figure5.1 [Configuration] Dialog Box ([General] Page)

Note: Theitemsthat can be set in this dialog box differ depending on the product. For the
settings for each product, refer to the online help.
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Items that can be displayed in the sheet are listed below.

[Device] combo box

[Emulation mode] combo box

[Step option] combo box

[JTAG clock] combo box

[Flash memory synchronization]
combo box

Displays the MCU name.

Selects the emulation mode at user program execution.
Select Normal to perform normal emulation.

Select No break to temporarily disable software breakpoints or
break condition settings during emulation.

Sets the step interrupt option.

Disable interrupts during single step execution: Disables
interrupts during step execution.

Enable interrupts during single step execution: Enables
interrupts during step execution.

Sets the frequency* of the JTAG clock.

Sets the synchronization method between the host computer
and the flash memory.

If the frequency of the host computer is synchronized with that
of the flash memory, thereis awaiting time to program the
flash memory when the user program is stopped. However, the
displayed contents and the flash memory are always matched.

If the frequency of the flash memory is synchronized with that
of the host computer, the contents of the flash memory are read
when the user program is stopped, and the reprogrammed
contents in the user program mode are reflected.

Disable: Disables synchronization except when the emulator is
activated and the flash memory areais changed.

PC to Flash memory: Synchronizes the frequency of the host
computer with that of the flash memory.

Flash memory to PC: Synchronizes the frequency of the flash
memory with that of the host computer.

PC to Flash memory, Flash memory to PC: Synchronizesthe
frequency between the host computer and the flash memory.

Note: Therange for the frequency of the JTAG clock differs depending on the supported device.
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52 Viewing a Program

This section describes how to view the program as the source code and the assembly-language

code.

Note: After abreak has occurred, the HEW displays the location of the program counter (PC). In

most cases, for exampleif an Elf/Dwarf2-based project is moved from its original path,

the source file may not be automatically found. In this case, the HEW will open a source
file browser dialog box to allow you to manually locate thefile.

521 Viewing the Sour ce Code

Select your source file and click the [Open] button to make the HEW open thefile in the

integrated editor. It isalso possible to display your source files by double-clicking on them in the

[Workspace] window.

0=00001026

0x0000102a
0=x00001032

0=00001034 |@
0=0000103c
0=0000103e
0=00001046
02000010483

o[]v

0=x0000104=a

0x0000105e
Ox00001063

O=x00001070
O=000010745
O=00001084
O=00001090
0=000010%c

lﬂ]jﬁﬂﬂ'l [

tutorial():

T
T
woid tutorial(void)
{
long a[10];
long 3:
int 1:

claz=s Sample *p_=amn;

0_=am= Sample;
for{ 1=0; 1<10; i++ ){
7 = rand():
1f(3 < 034
1 = —-1:
ali] = 1:

p_=am—r=ort{al;
p_=am—>rchange(a)

p_=am—:=0=a[0]
p_=am—:=l=a[1]:
p_=sam—:=2=al[2];
p_=am—:=3=a[3]:
p =san—r=d4=a[d]

—_ J——— CEE pa N

Figure5.2 [Source] window
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In this window, the following items are shown on the left as line information.
The first column (Source address column): Address information
The second column (Event column): Event information
The third column (Editor column): PC, bookmark, and breakpoint information
The source code is displayed in the right part of the [Source] window.

Sour ce address column

When aprogram is downloaded, an address for the current source file is displayed on the Source
address column. These addresses are hel pful when setting the PC value or a breakpoint.

Event column
The Event column displays the following item:

@A address condition for the break condition is only set for two positions.
Thisisalso set by using the popup menu.

The bitmap symbol above is shown by double-clicking the Event column. Thisis also set by using
the popup menu.

Figure5.3 Popup Menu

Notes: 1. The contents of the Event column are erased when conditions other than the address
condition are added to each channel by using the [Edit] menu or in the [Eventpoint]
window.

2. The setting conditions of Break Condition differ depending on the device. For details,
refer to the online help.

Editor column

Editor column displays the following items:
3 A bookmark is set.

@®: A PC Break is set.

5+ PC location
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S To switch off acolumnin all source files

Click the right-hand mouse button on the [ Source] window.
Click the [Define Column Format...] menu item.
The [Global Editor Column States] dialog box is displayed.

A check box indicates whether the column is enabled or not. If it is checked, the columnis
enabled. If the check box is gray, the column is enabled in some files and disabled in others.

5. Click the [OK] button for the new column settings to take effect.

A w NP

Global Editor Column States

[w]E went
[w] E ditor

[w|Source Address Cancel |

Figure5.4 [Global Editor Column States] Dialog Box

S To switch off acolumn in one source file
1. Open the source file which contains the column you want to remove and click the [Edit]
menu.
2. Click the [Columns] menu item to display a cascaded menu item. The columns are
displayed in this popup menu. If acolumn is enabled, it has atick mark next to its name.
Clicking the entry will toggle whether the column is displayed or not.
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522 Viewing the Assembly-L anguage Code

Click the right-hand mouse button on the [ Source] window to open the popup menu and select [Go
to Disassembly] to open the [Disassembly] window at the address that corresponds to the current
source file.

If you do not have a source file, but wish to view code in the assembly-language level, either
choose [View] -> [Disassembly...] or click on the [Disassembly] window’s toolbar button .
The [Disassembly] window opens at the current PC location and shows [Address] and [Code]
(optional) which show the disassembled mnemonics (with labels when available).

Selecting [Mixed display] from the popup menu of the [Disassembly] window displays both the
source and the code. The following shows an example in this case.

22: void main{void)

23: |
24 while (1)1
00001028 40FC BR& Wz in: g
26: I
271
28:
290 waid tutorial Cvaid)
tutorial HEOOT0F4 J3R @=p_regsvl: 24
UUUU}DZE 9370028 SUB. W BH' 0028, R7
al
oono103z2 0074 MO W R7,R4
31: long al107];
32: long J;
a3 irt i;
24: class Sample *p_sam;
SOk
36: p_sam= new Samele;
oo001034 1900 SUB. W RO, RO
00001036 SEO0Z2000 J3R @Samp e Sample() 24
oo001034 0006 MO W RO,RE
37: faor( i=0; i<10; i++ )

g 0000703C 19EE SUB. W E6,EB

<

Figure5.5 [Disassembly] Window
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523 M odifying the Assembly-L anguage Code

Y ou can modify the assembly-language code by double-clicking on the instruction that you want
to change. The [Assembler] dialog box will be opened.

Aszembler

Addrezs Code tnemaonic:
00001 02E 73370028

ok |

Figure5.6 [Assembler] Dialog Box

The address, machine code, and disassembled instruction are displayed. Enter the new instruction
or edit the old instruction in the [Mnemonic] field. Pressing the [Enter] key will assemble the
instruction into memory and move on to the next instruction. Clicking the [OK] button will
assembl e the instruction into memory and close the dialog box. Clicking the [Cancel] button or
pressing the [Esc] key will close the dialog box.

Note: The assembly-language display is disassembled from the actual machine code in the
debugging platform's memory. If the memory contents are changed, the dialog box (and
the [Disassembly] window) will show the new assembly-language code, but the display
content of the [Source] window will not be changed. Thisis the same even if the source
file contains an assembler.

524 Viewing a Specific Address

When you are viewing your program in the [Disassembly] window, you may wish to look at
another area of your program's code. Rather than scrolling through alot of code in the program,
you can go directly to a specific address. Select [Set Address...] from the popup menu, and the
dialog box shown in figure 5.7 is displayed.

Set Address

_main
Cancel |

Figure5.7 [Set Address] Dialog Box
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Enter the address or label name in the edit box and either click on the [OK] button or press the
[Enter] key. The [Disassembly] window will be updated to show the code at the new address.
When an overloaded function or a class name is entered, the [Select Function] dialog box opens
for you to select afunction. For details, refer to section 5.11.3, Supporting Duplicate Labels.

525 Viewing the Current Program Counter Address

Wherever you can enter an address or value into the HEW, you can aso enter an expression. If
you enter aregister name prefixed by the hash character (#), the contents of that register will be
used as the value in the expression. Therefore, if you open the [Set Address] dialog box and enter
the expression #pc, the [Source] or [Disassembly] window will display the current PC address. It
also allows the offset of the current PC to be displayed by entering an expression with the PC
register plus an offset, e.g., #PC+0x100.
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53 Debugging with the Command Line I nterface

Use the [Command Line] window to enter text-based commands instead of window menus and
commands.

531 Opening the[Command Line] Window

Choose [View -> Command Ling] or click the [Command Line] toolbar button ( to open the
[Command Line] window.

«# Command Line M=l E3

-

Figure5.8 [Command Line] Window

This window allows the user to control the debugging platform by sending text-based commands.
A series of predefined command lines can be called from afile and the output can be recorded in a
file. The command can be executed by pressing the [Enter] key after the command isinput at the
prompt (>) on thelast line. For information on the available commands, refer to the on-line help.

If available, the window title displays the current batch and log file names separated by colons.

Pressing the Ctrl + 1 or Ctrl + | keyson thelast line displays the command line previously
executed.
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5.3.2 Specifying a Command File

It is useful to use acommand file when a series of predefined command lines need to be executed.
Create a command file by atext editor and write necessary command lines. The default extension
of acommand file nameis .hdc.

Choose [Set Batch File...] from the popup menu to open the [Set Batch Fil€] dialog box, in which
the name of a command file (*.hdc) can be specified. Clicking the [OK] button displays the
specified command file name as the window title. Clicking the [Cancel] button closes the dialog
box without changing the setting.

Set Batch File

Batch File:

LCancel

Figure5.9 [Set Batch File] Dialog Box

533 Executing a Command File

Click the [Play] button in the [Set Batch File] dialog box or choose [Play] from the popup menu to
execute the command file. The [Play] menu is displayed in gray while the file isrunning and can
be used when the command file execution stops and control returns to the user.

534 Stopping Command Execution

Choose [Stop] from the popup menu to stop command execution. The [Stop] menu becomes valid
during command execution.

535 Specifyinga Log File

Choose [Set Log File...] from the popup menu to open the [Open Log File] dialog box, in which a
log file to store the command execution results can be specified.
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Cpen Log File

Log File:

ﬂ Browse... | e

Figure5.10 [Open Log File] Dialog Box

Enter the name of alog file (*.log). The logging option is automatically set and the name of the
fileis shown on the window title bar.

Opening a previous log file will ask the user if they wish to append or overwrite the current log.

5.3.6 Starting or Stopping L ogging

Choose [Logging] from the popup menu to toggle logging to file on and off. When logging is
active, the button becomes effective. Note that the contents of the log file cannot be viewed until
logging is completed, or temporarily disabled by clearing the check box. Re-enabling logging will
append to thelog file.

537 Entering a Full Path to the File

It is recommended that the full path to afile is specified as afile name in the [Command Line]
window because the current directory can be moved. However, care must be taken to enter the
correct full path to afile when it is entered from the keyboard. To solve thistrouble, afull path
can be easily specified by browsing through files.

Choose [Browse...] from the popup menu to open the [Browse] dialog box. Select afile and click
[Open] to paste the full path to the selected file to the cursor location. This option can only be used
when the cursor islocated on the last line.

538 Pasting a Placeholder

Select aplaceholder from the [Placeholder] submenu in the popup menu to paste the selected
placeholder to the cursor location. This function is only available when the cursor islocated on the
last line.
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54 Looking at Registers

If you are debugging at assembly-language level, then you will probably find it useful to see the
contents of the CPU's general-purpose registers. Y ou can do this by using the [Register] window.

541 Opening the [Register] Window

To open the [Register] window, choose [View->CPU->Registers] or click the [Register] toolbar
button ). The [Register] window opens showing al of the CPU's general-purpose registers and
the values, displayed in hexadecimal.

Register =)
|Register T IREgister Value

RO H'FCO0030A

Rl H'oooooooo

RZ H'O00010ZE

B3 H'oooooooo

B4 H'OO000OFF40

RS H'oooooooo

BE& H'O00003DA

R7 H'OO000FF40

PC H'O0lo3C

CCER I0-----—-

i

Figure5.11 [Register] Window

54.2 Expanding a Bit Register

If aregister isused as a set of flags at the bit level for the control of state, its one-character symbol
rather than its state indicate each bit. Double-click on the register’s name to display the [Edit
Register] dialog box and switch each bit on or off. Checking the box for any bit specifiesit as
holding a 1, while removing the check specifiesit asaO.
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Register - [CCR]

Cancel

=

Figure5.12 Expanding a Bit Register

54.3 Modifying Register Contents
To change aregister's content, open the [Register] dialog box in one of the following methods:

« Double-click the register you want to change.
* Select the register you want to change, and choose [Edit...] from the popup menu.

Register - [ERO]

Cancel |

SetAg

YWwhole Register j

Figure5.13 [Register] Dialog Box

Y ou can enter anumber or C/C++ expression in the [Value] field. Y ou can choose whether to
modify the whole register contents, a masked area, floating or flag bits by selecting an option from
the combo box (the contents of this list depend on the CPU model and selected register).

When you have entered the new number or expression, click the [OK] button or press the [Enter]
key; the dialog box closes and the new value is written into the register.

544 Using Register Contents

Use the value contained in a CPU register by specifying the register name prefixed by the “#”
character, e.g.: #R1, #PC, #R6L, or #ER3 when you are entering avalue elsewhere in the HEW,
for example when displaying a specified address in the [ Disassembly] or [Memory] window.
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55 Operating Memory

This section describes how to look at memory areas in the CPU's address space. How to look at a
memory areain different formats, how to fill and move a memory block, and how to load and
verify amemory areawith a disk file are described.

551 Viewing a Memory Area

To look at amemory area, choose [View -> CPU ->Memory...] or click the [View Memory]
toolbar button (&) to open the [Set Address] dialog box. Thiswill open the [Set Address] dialog
box shown in figure 5.14.

Set fddress
I LCancel |
End:
|
Format;
| Byte [1) =

Figure5.14 [Set Address] Dialog Box

Enter the range you wish to display as address values or equivalent symbols in the [Begin] and
[End] fields. Select the data size for the display from the [Format] combo box. Click the [OK]
button or press the [Enter] key, and the dialog box closes and the [Memory] window opens. The
display can be scrolled within the range of the entered start and end addresses.
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Addre=s Data Yalue =
0x0000020C FF FF FF FF FF FF  ......
0x00000R12 FF FF FF FF FF FF  ......
0x00000218 FF FF FF FF FF FF ......
0x00000Ra1FE FF FF FF FF FF FF  ......
0x00000224 FF FF FF FF FF FF  ......
0x00000222 FF FF FF FF FF FF  ......
0x00000230 FF FF FF FF FF FF  ......
0x00000R836 FF FF FF FF FF FF  ......
0x00000R83C FF FF FF FF FF FF  ......
Figure5.15 [Memory] Window

There are three display columns:

[Address]: Address of thefirst item in the [Data] column of this row.

[Data]: Dataisread from the debugging platform’s physical memory in the access width,

and then converted to the display width.
[Value]: Data displayed in an alternative format.

552 Displaying Data in Different For mats

If you want to change the display format of the [Memory] window, select [Format] from the

popup menu. The dialog box shown in figure 5.16 is displayed.
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Format Memory Display

Cancel |

Dizplay Walue Az

I.-'l'-.NSI character j
Yalue Font;
I Cournier Mew j

Figure5.16 [Format Memory Display] Dialog Box

To display and edit memory in different widths, use the [Display Data As| combo box. For
example, choose the [Byte] option and the display will be updated to show the memory area as
individual bytes.

The data can be converted into different formats, as shown in the second column [Display Vaue
Asg]. Thelist of formats depends on the data selection.

The font of the [Display Vaue As] column can be different from the font used to display the data.
Thisis useful for displaying [double] byte character values when the datais displayed in the
[Word] format.

553 Splitting Up the Window Display

To horizontally divide the [Memory] window display into two, select [Split] from the popup menu
and move the split-up bar. Moving the split-up bar to the top end or bottom end of the window
cancels the split-up display.

554 Viewing a Different Memory Area

To change the memory area displayed in the [Memory] window, use the scroll bars. To quickly
look at anew address, use the [Set Address] dialog box. This can be opened by choosing [Start
Address] from the popup menu.

Enter the new address value, and click the [OK] button or pressthe [Enter] key. The dialog box
closes and the [Memory] window display is updated with the data at the new address. When an
overloaded function or a class name is entered, the [ Select Function] dialog box opens for you to
select afunction.
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555 M odifying the Memory Contents

The memory contents can be modified viathe [Edit Memory] dialog box. Move the cursor on the
memory unit (depending on the [Memory] window display choice) that you wish to change. Either
double-click on the memory unit or press the [Enter] key. The dialog box shown in figure 5.17 is

displayed.

Edit Memary

Current 4 alue:
|HFF
Cancel |

Mew Yalue:
|

Figure5.17 [Edit Memory] Dialog Box

A number or C/C++ expression can be entered in the [New Valug] field. After you have entered
the new number or expression, click the [OK] button or press the [Enter] key. Then the dialog box
closes and the new value is written into memory.

The memory contents can also be modified by moving the cursor on the memory unit and entering
the new value in hexadecimal through the keyboard.

55.6 Selecting a Memory Range

If the range to be selected isin the [Memory] window, you can select the range by clicking on the
first memory unit (depending on the [Memory] window display choice) and dragging the mouse to
the last unit. The selected range is highlighted.

If the memory address range is larger than or outside the [Memory] window, you can enter the
start address and data size in the respective fields of the [Set Address] dialog box.
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557 Finding a Valuein Memory
To find avalue in memory, open the [Memory] window and select [ Search] from the popup menu.

The [Search Memory] dialog box shown in figure 5.18 is displayed.

Begin:
IH'EIIZIIZIIZH oo

LCancel |

End:
IH'IZIIZIEIIZH FFF

D ata:

Search Data As:

| Byte 1) |

¥ Search Egual Data [ Search Backward

Figure5.18 [Search Memory] Dialog Box

Enter the start and end addresses of the range in which to search (if amemory areawas selected in
the [Memory] window, the start and end address values will be automatically filled in) and the
data value to search for, and select the search format. If pattern search is selected as the search
format, a byte string of up to 256 bytes can be searched for. The end address can also be prefixed
by aplus (+); the end address will become the (start address) + (entered value).

Search conditions other than pattern search are data match/mismatch and search direction. Note
that only data match and forward direction can be selected with pattern search.

Click the [OK] button or press the [Enter] key. The dialog box closes and the HEW searches the
range for the specified data. If the datais found, the address at which the data has been found is
displayed in the [Memory] window.

If the data could not be found, the [Memory] window display remains unchanged and a message
box informing that the data could not be found is displayed.

If [Search Next] is selected from the popup menu in the state where data has been found, the
search will be restarted from the next address.
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55.8 FillingaMemory Areawith aValue
A value can be set as the content of a memory address range using the memory fill function.

To fill amemory range with the same value, choose [Fill] from the popup menu of the [Memory]
window or choose [Fill] from the [Memory] drop-down menu. The [Fill Memory] dialog box is
shown in figure 5.19.

I Cancel |

Format;

IE_I,Ite j

Figure5.19 [Fill Memory] Dialog Box

If an address range has been selected in the [Memory] window, the specified start and end
addresses will be displayed. Select aformat from the [Format] combo box and enter the data value
in the [Data) field. On clicking the [OK] button or pressing the [Enter] key, the dialog box closes
and the new value is written into the memory range.
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559 CopyingaMemory Area

Y ou can copy amemory area using the memory copy function. Select amemory range and then
[Copy...] from the popup menu. The [Copy Memory] dialog box is opened (figure 5.20).

Copy Memary ﬂ E |

I LCancel |

Destination:

Format;
| Byte 1) |

[ Werify

Figure5.20 [Copy Memory] Dialog Box

The source start and end addresses selected in the [Memory] window will be displayed in the
[Begin] and [End] fields. Checking the [V erify] check box enables copying while comparing the
copy source and copy destination. The copy unit can be selected in the [Format] combo box. Enter
the destination start address in the [Destination] field and click the [OK] button or press the
[Enter] key. Thiswill close the dialog box and copy the memory block to the new address.
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5510 Savingand VerifyingaMemory Area

A memory areain the address space can be saved into a disk file using the memory save function.
Open the [Save Memory As] dialog box by choosing [File -> Save memory...].

Sawve Memary As

- -
Cancel |
File name:

| =1
Start address:

End &ddrezs:

Figure5.21 [Save Memory As| Dialog Box

Enter the start and end addresses of the memory block that you wish to save, and a name and
format for thefile. The [File name] combo box contains the previous four file names used for

saving memory.

Clicking the[...] button can open the standard [File Save As] dialog box. On clicking the [OK]
button or pressing the [Enter] key, the dialog box closes and the memory block will be saved into
the disk as afile of the specified format type. When the file has been saved, a message box for
confirmation is displayed.

A memory areain the address space can be verified using the memory verify function. Open the
[Verify Memory] dialog box by choosing [File -> Verify Memory...].
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Werify Memory

Cancel
File name:

| =1

Offzet address:

Figure5.22 [Verify Memory] Dialog Box

5,5.11 Disabling Update of the Window Contents

Automatic update of the [Memory] window contents, which is performed when user program
execution stops and in other cases, can be disabled. Thisis done by checking [Lock Refresh] in the
popup menul.

55.12  Updating the Window Contents

The [Memory] window contents can be forcibly updated. Thisis done by checking [Refresh] in
the popup menu.

5,5.13 Comparing the Memory Contents

The contents of two memory blocks can be compared. Open the [Compare Memory] dialog box
by selecting [Memory -> Compare...] from the main menu or by selecting [Compare...] from the
popup menu of the [Memory] window.
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Compare Memory

I Cancel |

Start Compare:

Format:

| Byte 1) |

Figure5.23 [Compare Memory] Dialog Box

Enter the comparison format ([Format]), the start address ([Begin]) and the end address ([End]) of
the source memory area, and the start address ([Start Compare]) of the destination memory area. If
the memory block is aready highlighted in the [Memory] window, the start and end addresses will
be automatically filled in when the [Compare Memory] dia og box is opened.

If there is a mismatch, the address where it was found is displayed in a message box.
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5514 LoadingaMemory Areafrom aFile

A file can be loaded to the debugging platform’s memory. Select [Load...] from the popup menu
of the [Memory] window to open the [Load Program] dialog box.

Load Program

Cancel

File name:
| =1,
Offzet address:

Figure5.24 [Load Program] Dialog Box

Enter the file format ([Format]) and the file name ([File name]). If the load address value isto be
changed, enter the offset value in the offset field ([Offset address]), otherwise enter zero.
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5.6 Viewing thel/O Memory

A microcomputer contains on-chip peripheral modules. The exact number and type of peripheral
modules differ between devices but the typical modules are DMA controller, serial
communications interface, A/D converter, bus state controller, and watchdog timer. Registers that
are mapped to the microcomputer’ s address space control s the on-chip peripheral modules.

The [Memory] window enables you to look at data in continuous memory addresses as byte, word,
longword, single-precision floating-point, double-precision floating-point, or ASCII values.
However, registers of different sizes are allocated to non-continuous memory addresses in the I/O
memory. To handle this memory, the HEW has the [10] window to facilitate checking and setting
up of these kinds of registers.

56.1 Opening the [10] Window

To open the [10] window, select [View -> CPU -> 10] or click the [View 1/Q] toolbar button
(). Modules that match the on-chip peripheral modules organize the 1/0 register information.
When the [IO] window isfirst opened, only alist of module names is displayed.

Address Accezz
=] ncr DOFFEDE? H'87
- [E] sescr 00FFFDES H'o1

D Interrupt Controller
D Bus Controller

D Data Transfer Control
F-] If0 Port 1

F-[] If0_Port 3

F-[] If0_Port 4

F-[Z] If0_Port 7

F-[] If0_Port 9

F-[Z] If0_Port

#-[] If0_Port E

F-Z] If0_Port C

.77 T4 Dawd N hd
4| | ]

Figure5.25 [IO] Window
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56.2 Expanding the 1/O Register Display

To display the names, addresses, and values of the 1/0O registers, double-click on the module name
or select the module name by clicking on it or using the cursor keys and press the [Enter] key. The
module display will expand to show the individual registers of that peripheral module and their
names, addresses, and values. Double-clicking (or pressing the [Enter] key) again on the module
name will close the I/O register display.

For adisplay in the bit level, expand the I/O register in a similar way to the [Register] window.

5.6.3 Modifying the | /O Register Contents

To edit the valuein an 1/O register, type hexadecimal values directly into the window. To enter
more complex expressions, double-click or press the [Enter] key on the register to open a dialog
box to modify the register contents. When you have entered the new number or expression, click
the [OK] button or press the [Enter] key; the dialog box closes and the new value is written into
the register.

Note: The[l1O] window displays the contents defined in [H8Sxxxx.i0]. Editing those contents
adds or deletes the registers to be displayed.
For the contents to be described as [H8Sxxxx.i0], refer to appendix D, 1/0 File Format.
The following directory contains [H8Sxxxx.io]:
<HEW?2 installation directory>\T ool s\Renesas\DebugComp\Platform\EL0A\xxxx\I OFiles
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5.7 Viewing the Current Status

Choose [View -> CPU -> Status] or click the [View Status] toolbar button (&) to open the
[Status] window and see the current status of the debugging platform.

reew  leaws
Conmected to: HBS/xxxx ELOA SYSTEM
cru HBS/ xxux
Pun status Ready
Cause of last break ONE STEP END
Mun time count 0000h000nind00s10%3ms
Emulation mode Normal
Endian Big
| [\Memnry } Platiorm A Everis f

Figure5.26 [Status] Window

The [Status] window has three sheets:

e [Memory] sheet
Contains information about the current memory status including the memory mapping
resources and the areas used by the currently loaded object file.

e [Platform] sheet
Contains information about the current status of the emulator, typically including CPU type
and mode; and run status.

e [Events] sheet

Contains information about the current event (breakpoint) status, including resource
information.

Note: Theitemsthat can be set in thiswindow differ depending on the emulator in use. For
details, refer to the online help.
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5.8 Looking at Labels

Symbol information isincluded in the debugging information, which is used when the HEW links
the user program source code to the actual code in the memory. Symbol information isincluded in
the debug object file. This information is a text name that indicates addresses in the program.
These names are called labelsin the HEW. The [Disassembly] window shows the first eight
characters of each label instead of the corresponding address or as a part of an instruction operand

*

Note:  When alabel value matches an operand, the corresponding instruction operand is replaced
by the label. If two or more labels have the same value, the one that comesfirstin
alphabetical order is displayed. When [Edit Control] accepts an address or avalue, alabel
can be entered instead.

581 Listing Labels

Choose [View -> Symbol -> Labels] or click the [View Labels] toolbar button (&) to list all
labels defined in the current debugger session.

EFP I Address I HNane ;I
H'O000010Z& _main
H'OO0O1l0Za tutorial i)
H'O00010Fz _abort
H'000010F4 Fsp_regsvid
H'O0001114 fspregldzsa
H'OO0O11Za _ TINITECT
H'O00O113E loopl
H'O0001144 loopE
H'O000114¢ next_loopZ
H'O0001144 next_loopl
H'O000011&82 loop3
H'000011&0 loopd
H'oooolles next_loopd
H'O0001164 next_loop3
H'O0001178 operator newiunsiganed int)
H'O00001l1CeE _ CALL INIT
H'O00011E& _ CALL_END
H'OOOO01lEA operator delete{wvoid *)
H'OO0O11F4 _rand -

1 2w

Figure5.27 [Label] Window
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Y ou can view symbols sorted either alphabetically (by ASCII code) or by address value by
clicking on the respective column heading.

Double-clicking on the [BP] column can set or clear a software breskpoint at the start of the
function.

582 Adding a Label

Choose [Add..] from the popup menu and open the [Add Label] dialog box to add alabel:

Add Label 21 ]
Mame: || j ok, I
Address: IH'|:||:||:||:||:||:||:||:| j Cancel |

Figure5.28 [Add Label] Dialog Box

Enter the new label name into the [Name] field and the corresponding value into the [Address]
field and press[OK]. The [Add Label] dialog box closes and the label list is updated to show the
new label. When an overloaded function or a class name is entered in the [Address]| field, the
[Select Function] dialog box opens for you to select afunction. For details, refer to section 5.11.3,
Supporting Duplicate Labels.

583 Editing a Label

Choose [Edit...] from the popup menu and open the [Edit Label] dialog box to edit alabel:

Edit Label [_main]

Hame: |_mair =l ok, |
=~

Address: |H'D0001 026

Cancel |

Figure5.29 [Edit Label] Dialog Box

Edit the label name and value as required and then press [OK] to save the modified version in the
label list. Thelist display is updated to show the new label details. When an overloaded function
or aclass nameis entered in the [Address] field, the [Select Function] dialog box opens for you to
select afunction. For details, refer to section 5.11.3, Supporting Duplicate Labels.
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584 Deleting a L abel

To delete alabel, select the label and choose [Delete] from the popup menu. A confirmation
message box appears:

Confirrnation Request E3 |

® Are pou gure you want bo delete the label '_main'?

[ Don't ask this question again

Figure5.30 Message Box for Confirming Label Deletion

If you click [OK], the label is removed from the list and the window display is updated. If the
message box is not required then do not select the [Delete Label] option of the [Confirmation]
sheet in the HEW’ s [Options] dialog box.
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5.85 Deleting All Labels

To delete dl the labelsfrom the list, choose [Delete All] from the popup menu. A confirmation
message box appears:

Confirrnation Request E3 |

® Are you gure vou want to delete all labelz’?

[ Don't ask this question again

Figure5.31 Message Box for Confirming All Label Deletion

If you click [OK], al the labels are removed from the HEW system’s symbol table and the list
display will be cleared. If the message box is not required, do not select the [Delete All Labels]
option of the [Confirmation] sheet in the HEW’ s [Options] dialog box.

RENESAS

275




High-performance Embedded Workshop User’'s Manual

5.8.6 Loading Labelsfrom aFile

A symbol file can be loaded and merged into the HEW's current symbol table. Choose [Load...]
from the popup menu to open the [Open] dialog box:

Cpen K E
Look in: | {23 Debue HB5 _ooo_E10A_SYSTEM | &= (] £ ER-
I derno, sym
File name: Open I
ISR U= [P =ntica-B S yrbal File [ zom) Cancel |
4

Figure5.32 [Open] Dialog Box

The dialog box operates like a standard Windows® [Open] dialog box; select the file and click
[Open] to start loading. The standard file extension for symbol filesis“.sym”. When the symbol
loading is complete a confirmation message box may be displayed showing how many symbols
have been loaded (this can be switched off in the [Confirmation] sheet on the HEW’ s [Options]
dialog box).

5.8.7 Saving Labelsinto a File

Choose [Save As...] from the popup menu to open the [ Save Symbols] dialog box. The [Save
Symbols] dialog box operates like a standard Windows”® [Save File As] dialog box. Enter the name
for thefilein the [File name] field and click [Save] to save the HEW's current label list to a
symbol file. The standard file extension for symbol filesis“.sym”.

See appendix E, Symbol File Format, for details on the symbol file format.

Once afileis specified by the [Save As...] menu, the current symbol table can be saved in the
same symbol file just by choosing [Save] from the popup menu.
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5.8.8 Sear ching for a Label

Choose [Find...] from the popup menu to open the [Find Label] dialog box:

Find Label HE

MHame: I LI (0] I
[ Match Case I ;l Cancel |

Figure5.33 [Find Label] Dialog Box

Enter all or part of the [abel name that you wish to find into the edit box and click [OK] or press
the [Enter] key. The HEW searches the |abel list for alabel name containing the text that you
entered.

Note: Thelabel isonly stored by 1024 characters of the start, therefore the label name must not
overlap mutually in 1024 characters. Labels are case sensitive.

5.8.9 Sear ching for the Next Label

Choose [Find Next] from the popup menu to find the next occurrence of the label containing the
text that you entered.

5.8.10 Viewing the Source Corresponding to a L abel

Select alabel and choose [View Source] from the popup menu to open the [Source] or
[Disassembly] window containing the address corresponding to the label.
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5.9 Executing Your Program

This section describes how you can execute your program's code. This section describes how to do
this by either running your program continuously or stepping single or multiple instructions at a
time.

59.1 Running from Reset

To reset your user system and run your program from the reset vector address, choose [ Debug-
>Reset Go], or click the [Go Reset] toolbar button .

The program will run until it hits a breakpoint or a break condition is met. Y ou can stop the
program manually by pressing the Esc key, choosing [Debug->Halt], or by clicking the [Halt]

toolbar button (@)

Note: The program will start running from the address that is stored in the reset vector location.
Thereforeit isimportant to make sure that this location contains the address of your
startup code.

5.9.2 Continuing Run

When your program is stopped, the HEW will display an yellow arrow mark in the gutter of the
linein the [Source] and [Disassembly] window that correspond to the CPU's current program
counter (PC) address value. Thiswill be the next instruction to be executed if you perform a step
or continue running.

To continue running from the current PC address, click the [Go] toolbar button (, or choose
[Debug->Go].

To continue running from a specified address which is not the stop address, change the PC value
in one of the following ways, and click the [Go] toolbar button or choose [Debug->Go].

» Changethe PC valuein the [Register] window. Refer to section 5.4.3, Modifying Register
Contents.

» Placethe text cursor (not the mouse cursor) on atarget line in the [Source] or [Disassembly]
window, and choose [Set PC Here] from the popup menu.
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5.9.3 Running to the Cur sor

Sometimes as you are going through your application you may only want to run a small section of
code, that would require many single steps to execute. Y ou can do this using the Go To Cursor
feature.

2 How to usethe Go To Cursor

1. Make sure that the [Source] or [Disassembly] window is open showing the address at which
you wish to stop.

2. Position the text cursor on the address at which you wish to stop by either clicking in the
[Address] field or using the cursor keys.

3. Choose [Go To Cursor] from the popup menu.

The debugging platform will run your code from the current PC value until it reaches the address
indicated by the cursor's position.

Notes: 1. If your program never executes the code at this address, the program will not stop. If
this happens, code execution can be stopped by pressing the Esc key, choosing [Debug
->Halt], or clicking on the [Halt] toolbar button (.
2. The Go To Cursor feature requires a PC breakpoint - if you have aready used all those
available, then the feature will not work.
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594 Running from a Specified Address

The [Run Program] dialog box allows the user to run the program from any address. Choose
[Debug -> Run...] to open the [Run Program] dialog box.

Run Program

Program Counter:
H'00000aa0

Rezet Go
Temporary PC Breakpoints:

i

Cancel

Figure5.34 [Run Program] Dialog Box
The following execution conditions can be specified in this dialog box:

[Program Counter]: Instruction address to start execution. The initial valueis
the current PC value.

[Temporary PC Breakpoints]: A temporary PC breakpoint. When execution started
by this dialog box stops, this breakpoint is cleared.

Note: The[Temporary PC Breakpoints] feature requires a PC breakpoint - if you have already
used all those available then the feature will not work.

Clicking the [Go] button starts execution depending on the settings. Clicking the [Reset Go]
button starts execution from the reset vector. Clicking the [Cancel] button closes this dialog box
without executing instructions.
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5.95 Single Step

To debug your codeit is very useful to be able to step a single line or instruction at atime and
examine the effect of that instruction on the system. In the [Source] window, a step operation will
step asingle source line. In the [ Disassembly] window, a step operation will step asingle
assembly-language instruction. If the instruction calls another function or subroutine, you have the
option to either step into or step over the function. If the instruction does not perform a call, then
either option will cause the debugger to execute the instruction and stop at the next instruction.

e Stepping Into a Function

If you choose to step into the function the debugger will execute the call and stop at thefirst line
or instruction of the function. To step into the function either click the [Step In] toolbar button
(®)), or choose [Debug->Step In].

e Stepping Over a Function Call

If you choose to step over the function the debugger will execute the call and all of the codein the
function (and any function calls that that function may make) and stop at the next line or
instruction of the calling function. To step over the function either click the [Step Over] toolbar
button (), or choose [Debug->Step Over].

e Stepping Out of a Function

There are occasions when you may have entered a function, finished stepping through the
instructions that you want to examine and would like to return to the calling function without
tediously stepping through all the remaining code in the function.

To step out of the current function either click the [Step Out] toolbar button (, or choose
[Debug->Step Out].
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5.9.6 Multiple Steps

Y ou can step severa instructions at atime by using the [Step Program] dialog box. The dialog box
also provides an automated step with a selectable delay between steps. Open it by choosing
[Debug-> Step...].

The [Step Program] dialog box is displayed:

Skep Program

Steps:

|H'nunnnnm

Delay [zeconds)

I'I - 2.5 seconds j

[ Step Over Calls

[ Source Level Step

Q. I Cancel |

Figure5.35 [Step Program] Dialog Box

[Steps]: Number of steps to be executed.

[Delay (seconds)]: Delay between steps when the program is automatically stepped.
Value 0 to 6 can be specified where value 0 indicates the longest delay.

[Step Over Cals]: Selecting this box steps over function calls.

[Source Level Step]: Selecting this box steps the program at the source level.

Clicking the [OK] button or pressing the [Enter] key starts step execution.
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510 Stopping Your Program

This section describes how you can halt execution of your application’'s code. This section
describes how to do this directly by using the [Halt] button and by setting breakpoints at specific
locations in your code.

5.10.1 Halting Execution

When your program is running, the [Halt] toolbar button is enabled ( (ared STOP sign), and
when the program has stopped it is disabled (\:I) (the STOP sign is grayed out). Press the Esc key,
click on the [Halt] toolbar button (, or choose [Debug->Halt Program].

When the program has been stopped by [Halt], "Stop" is displayed in the [Debug] sheet of the
[Output] window.

5.10.2 Standard Breakpoints (PC Breakpoints)

When you are trying to debug your program you will want to be able to stop the program running
when it reaches a specific point or pointsin your code. Y ou can do this by setting a PC breakpoint
on theline or instruction at which you want the execution to stop. The following instructions will
show you how to quickly set and clear simple PC breakpoints. If more complex breakpoint
operation isrequired, use the [Event] window, which can be opened by clicking the button or
choosing [View -> Code -> Eventpoints]. For details, refer to section 5.13, Using the Event Points.

» Toset aPC breakpoint in the [Source] window
1. Make sure that the [Disassembly] or [Source] window is open at the place you want to set a
PC breakpoint.
2. Choose [Toggle Breakpoint] from the popup menu, or press F9, at the line showing the
address at which you want the program to stop.
3. Youwill see ared circle appear in the gutter to indicate that a PC breakpoint has been set.

4. The current breakpoint set can be enabled or disabled by using [Enable/Disable
Breakpoint] in the popup menu.

Now when you run your program and it reaches the address at which you set the PC breakpoint,
execution halts with the message "BREAK POINT" displayed in the [Debug] sheet of the [Output]
window, and the [Source] or [Disassembly] window is updated with the PC breakpoint line
marked with an arrow in the gutter.

Note:  When abreak occurs, the program stops just before it is about to execute the line or
instruction at which you set a PC breakpoint. If you choose Go or Step after stopping at
the PC breakpoint, then the line marked with an arrow will be the next instruction to be
executed.
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To set a PC breakpoint by using the [Breakpoints] dialog box
Selecting [Edit -> Source Breakpoint...] displays the [Breakpoints] dialog box.

Ereakpoaints HE |

0K

Cancel

Edit Code

Bemove

4

Remove Al

Figure5.36 [Breakpoints] Dialog Box

The [Breakpoints] dialog box allows the user to view the current breakpoints set. Clicking the
[Edit Code] button displays the source where each breakpoint is set. The [Remove] or [Remove
All] button deletes one or all breakpoints, respectively. The check box of each breakpoint enables
or disables the breakpoint.

To toggle PC breakpoints

It is possible to toggle the [PC Breakpoints] setting by either double-clicking in the [BP]
column of the line where the PC breakpoint is set or placing the cursor on the line and pressing
the [F9] key. The setting to be toggled depends on the debugging platform.

Notes on Setting the [Breakpoint] Dialog Box

3.
4,

When an odd addressiis set, the address is rounded down to an even address.

A software break is accomplished by replacing instructions. Accordingly, it can be set only to
the flash memory or RAM area. However, a software break cannot be set to the following
addresses:

O An areaother than the flash memory or RAM

0 An areaoccupied by the E1I0A emulator program

O Aninstruction in which Break Condition 1 is satisfied

During step execution, a software breakpoint is disabled.

A condition set at Break Condition 1 isdisabled immediately after starting execution when an
instruction at a software breakpoint is executed. A break does not occur even if a condition of
Break Condition 1 is satisfied immediately after starting the execution.
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5. When execution resumes from the breakpoint address after the program execution stops at the
software breakpoint, single-step execution is performed at the address before execution
resumes. Therefore, realtime operation cannot be performed.

6. Settings of software breakpoint and Break Condition 1 are invalid while the STEP OVER

function is being used.
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511 Elf/Dwarf2 Support

The HEW supports the Elf/Dwarf2 object file format for debugging applications written in C/C++
and assembly language. It provides a powerful way of accessing, observing and modifying the
symbolic level debugging information about the user application that is running.

Key Features

» Source level debugging

e C/C++ operators

e C/C++ expression (casting, pointers, references, etc.)
*  Ambiguous function names

« Overlay memory loading

»  Watch - locals, and user definition

o Stack trace

5111 C/C++ Operators
The following C/C++ language operators are available;
5 L& N L3> <<%, (), < >, <=, 55, =5, 15,84, |

Buf fer_start + 0x1000

#R1 | B 10001101

((pointer + (2 * increnment_size)) & H FFFF0000) >> D 15
I(flag ™~ #ER4)

5112 C/C++ Expressions

Expression Examples

hj ect . val ue I/Specifies direct reference of a member (C/C++)
p_QObj ect - >val ue //Specifiesindirect reference of amember (C/C++)
C ass: :val ue //Specifies reference of amember with class (C++)
*val ue //Specifies apointer (C/C++)

&val ue //Specifies areference (C/C++)

array[ 0] //Specifies an array (C/C++)

hj ect . *val ue I/Specifies reference of a member with pointer (C++)
::g_val ue //Specifies reference of aglobal variable (C/C++)
Cl ass::function(short) //Specifiesamember function (C++)

(struct STR) *val ue //Specifies cast operation (C/C++)
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5.11.3  Supporting Duplicate L abels

In some languages, for example C++ overloaded functions, alabel may represent more than one
address. When such alabel nameis entered in adialog box, the HEW will display the [Select
Function] dialog box to display overloaded functions and member functions.

Select Function ilﬂ

Select Function M ame Set Function Mame

15 amnple:; sort(long *)} N
{Sample:: sortflong *, short]} |

— Counter
All Function Select Function Set Function

I:2 Functionz I2 Functions ID Functionz

Cancel |

Figure5.37 [Select Function] Dialog Box

Select overloaded functions or member functions in the [Select Function] dialog box. Generaly,
one function can be selected at one time; only for setting breakpoints, multiple functions can be
selected. This dialog box has three areas.

[Select Function Name]: Displays the same-name functions or member functions and
their detailed information.

[Set Function Name]: Displays the function to be set and their detailed information.

[Counter]: [All Function] Displays the number of same-name functions
or member functions.
[Select Function] Displays the number of functions displayed
in the [Select Function Name] list box.
[Set Function] Displays the number of functions displayed
in the [Set Function Name] list box.
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Selecting a Function

Click the function you wish to select in the [Select Function Name] list box, and click the [>]
button. Y ou will see the selected function in the [Set Function Name] list box. To select all
functionsin the [Select Function Name] list box, click the [>>] button.

Deselecting a Function

Click the function you wish to deselect from the [Set Function Name] list box, and click the [<]
button. To deselect al functions, click the [<<] button. The desel ected function will be moved
from [Set Function Name] list box back to the [Select Function Name] list box.

Setting a Function

Click the [OK] button to set the functions displayed in the [Set Function Name] list box. The
functions are set and the [Select Function] dialog box closes.

Clicking the [Cancel] button closes the dialog box without setting the functions.

5.11.4 Debugging an Overlay Program
This section explains the settings for using the overlay functions.
Displaying Section Group

When the overlay mode is used, that is, when several section groups are assigned to the same
address range, the address ranges and section groups are displayed in the [Overlay] dialog box.

Open the [Overlay] diaog box by choosing [Memory->Configure Overlay].

288
RENESAS



High-performance Embedded Workshop User's Manual

2lx
Address: Section Mame:
OOFFE SO0 - DOFFEE0R oK I
Cancel |

Figure5.38 [Overlay] Dialog Box (at Opening)
This dialog box has two areas: the [Address] list box and the [Section Name] list box.

The [Address] list box displays the address ranges used in the overlay program. Click to select one
of the address ranges in the [Address] list box.

21|

Section Mame:

R_sample Ik |
R_zort

R_change Cancel

Figure5.39 [Overlay] Dialog Box (Address Range Selected)
The [Section Name] list box displays the section groups assigned to the selected address range.
< Setting section group

When using the overlay function, the highest-priority section group must be selected in the
[Overlay] dialog box; otherwise the HEW will operate incorrectly.
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First click one of the address ranges displayed in the [Address] list box. The section groups
assigned to the selected address range will then be displayed in the [Section Name] list box.

Click to select the section group with the highest-priority among the displayed section groups.

21|

Address; Section Mame:

QOFFBSE00 - 00FFESDE | A samile ak I
R_change el |

Figure5.40 [Overlay] Dialog Box (Highest-Priority Section Group Selected)

After selecting a section group, clicking the [OK] button stores the priority setting and closes the
dialog box. Clicking the [Cancel] button closes the dialog box without storing the priority setting.

Note:  Within the address range used by the overlay function, the debugging information for the
section specified in the [Overlay] dialog box isreferred to. Therefore, the same section of
the currently loaded program must be selected in the [Overlay] dialog box.
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512 Lookingat Variables

This section describes how you can look at variables in the source program.

5.12.1 Tooltip Watch
The quickest way to look at avariable in your program is to use the Tooltip Watch feature.
< To use Tooltip Watch:

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near
the variable containing basic watch information for that variable.

& 0_=am= Sample;
o for{ 1=0; 1<10; i++ 3L
i = rand(}: [HDO03]
if(3 < 039
1 = —1:
ali] = 1:

Figure5.41 Tooltip Watch

5.12.2 Instant Watch

Open the [Source] window showing the variable that you want to examine.

Rest the mouse cursor over the variable name that you want to examine and choose [Instant
Watch...] from the popup menu; the [Instant Watch] dialog box will appear and display the
variable at the cursor location.

Insktant Watch

- a { 0=ff40 } (lang[10]]

Figure5.42 [Instant Watch] Dialog Box
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“+" shown to the left of the variable name indicates that the information may be expanded by
clicking on the variable name, and “-" indicates that the information may be collapsed. Clicking
[Add] registersthe variable in the [Watch] window. Clicking [Close] closes the window without
registering the variable in the [Watch] window.

5123 [Watch] Window
Y ou can view any value in the [Watch] window.
Opening a [Watch] Window

To open a[Watch] window, choose [View->Symbol->Watch] or click on the [Watch] toolbar
button () if itisvisible. A [Watch] window opens. Initialy the content of the window will be
blank.

3 [ D40 | {one[10)
R [0] H1bf737 { ueff40 } {lone?
R [1] HO011 0064 { Oxff44 } {lone?
B [2] H'03=3906 { 0=ff43 | {lone?
R [E] H'6aB0fd0e { Oxfide } {lone}
R [] H7a0400071 { 0150 } {lone?
R [6] HOGE fetd [ 0=f54 } {lone?
R[] H5a007h0 { Ouxfisa } {lone?
R [7] H'9156229 { OxffGe | {lohe?
R [E] H'fd0e 7904 { Ouxficl } {lone}
R [ H'0001102e { Dxff6d } {lone}
1 3

Figure5.43 [Watch] Window

Thiswindow allows the user to view and modify C/C++-source level variables. The contents of
this window are displayed only when the debugging information available in the absolutefile
(*.abs) includes the information on the C/C++ source program. The variable information is not
displayed if the source program information is excluded from the debugging information during
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optimization by the compiler. In addition, the variables that are declared as macro cannot be
displayed.

The following items are displayed.
[Name]: Name of the variable

[Value]: Value and assigned location.
The assigned location isenclosed by { }.

[Typel: Type of the variable
The [R] mark shows that the value of the variable can be updated during user program execution.

For updating of the content of the variable that has been registered in the [Watch] window, read
the data after the break in user program execution.

Note: The reatime operation for the user program is disabled because the user programis
temporarily stopped.

When the color of the [R] mark is black, a value has been updated by reading the data.

Notes: 1. Thisfunction can be set per variable or per element or body for structures of data.
2. Thecolor of an [R] in the [Name] column changes according to the monitoring
settings.
3. Theinformationislost when it is scrolled out of the [Watch] window or when the
window is closed.
4. A variablethat isallocated to aregister cannot be selected for monitoring.
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Adding a Watch Item

Use the [Add Watch] dialog box in the [Watch] window to add Watch items to the [Watch]
window.

2 To use Add Watch from the [Watch] window:

Open the [Watch] window.
Choose [Add Watch] from the popup menu.
The [Add Watch] dialog box opens:

Add Wakch il il
Yariable or expreszion:
a Cancel

Figure5.44 [Add Watch] Dialog Box

Enter the name of the variable that you wish to watch and click [OK]. The variable is added to the
[Watch] window. A variable can be dragged from the [Source] window and dropped into the
[Watch] window.

Note: If the variable that you have added is alocal variable that is not currently in scope, the
HEW will add it to the [Watch] window but its value will be blank, or set to aquestion
mark, '?.
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Expanding a Watch Item

If awatch item isapointer, array, or structure, then you will see aplussign (+) expansion
indicator to left of its name, this means that you can expand the watch item. To expand awatch
item, click on it. The item expands to show the elements (in the case of structures and arrays) or
datavalue (in the case of pointers) indented by one tab stop, and the plus sign changes to aminus
sign (-). If the elements of the watch item also contain pointers, structures, or arrays then they will
also have expansion indicators next to them.

Expansion indicator
] . 0]
R [0 H'f11bf737 { Oxffd0 } {lore?
E dedwatch
M R 0] H'00110084 { Oxff44 | {lore?
R & H03e81906 { Oxff48 } {long?
B [3E] H'6a89fd9e { Dxffdc } {lone?
B M H'79040001 { DwH50 } {long?
R [l H'0AE1 fetd { Oxffod {lore?
R [ H'5a00f700 { 0xff58 } {lore?
R M H'f9166a09 [ OxffEc | {lorng?
B [kl H'fd%e7004 { D:xff60 } {lone?
Callapsed watch L B[] H'0001102e { Dxffad } {long)
- a { Oxff40 } {larg[101}
4| | >

Figure5.45 ExpandingaWatch Item

To collapse an expanded watch item, double-click on the item again. The item's elements will
collapse back to the single item and the minus sign changes back to a plus sign.
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Editing a Watch Item's Value

Y ou may wish to change the value of awatch variable, e.g. for testing purposes or if thevalueis
incorrect due to abug in your program. To change awatch item's value use the Edit Value
function.

< Editing awatch item's value:
Enter avalue directly in the window.

In another way, select the item to edit by clicking on it, you will see aflashing cursor on the item.
Choose [Edit Value] from the popup menu.
The [Edit Value] dialog box opens:

Edit Yalue
E=pression: I alo]
Current H' 00000000 { 0x0fffffkd }
Walue: (1] 4
Mew Value: || Cancel

Figure5.46 [Edit Value] Dialog Box

Enter the new value or expression in the [New Value] field and click [OK]. The [Watch] window
is updated to show the new value.

Deleting a Watch Item

To delete awatch item, select it and choose [Delete] from the popup menu. Theitem is deleted
and the [Watch] window is updated.

To delete dl watch items, choose [Delete All] from the popup menu. All items are deleted and the
[Watch] window is updated.

296
RENESAS




High-performance Embedded Workshop User's Manual
Specifying Realtime Update

The [R] mark shown to the left of each variable indicates whether the variable is updated in real
time. When an [R] mark is displayed in bold face, the value of the variable will be updated in
realtime during user program execution.

A popup menu containing the following options is available in the [Watch] window:

e Auto Update
Marks the selected variable with abold [R] and updates the variable in realtime.
e Auto Update All
Marks all variables with bold [R]s and updates all variablesin realtime.
e Delete Auto Update
Marks the selected variable with an outlined [R] and cancels realtime update.
« Delete Auto Update All
Marks al variables with outlined [R]s and cancels realtime update.

M odifying the Radix

Theradix for the selected variable display can be modified by choosing [Radix] from the popup
menu.

Saving the [Watch] Window Contentsin a File

To save the contents of the [Watch] window, choose [Save As...] from the popup menu; the [Save
Asg] dialog box opens. It allows the user to specify the name of afile and to save the contents of
the [Watch] window in thefile. If the [Append] check box is selected, the window contents are
appended to the existing file, and if it is not selected, the existing file is overwritten.

Opening a[Memory] Window

The contents of the memory areato which the selected variable is assigned can be displayed in the
[Memory] window. Choose [Go To Memory...] from the popup menu; the [Set Address] dialog
box opens, showing the information (start address, end address, and size) of the selected variable
as default. Clicking [OK] opens the [Memory] window.

297
RENESAS



High-performance Embedded Workshop User’'s Manual

5.124 [Locals] Window
Thelocal variables and their values can be displayed in the [Locals] window.

Opening the [L ocals] Window

To open the [Locals] window, choose [View->Symbol->Locals] or click the [Locals] toolbar

button (&)).

i (long10]]
-------- [ H'00000fE { ERS } (lang)
-------- : H'000a { E6 } fint]
""" p_szam 0x03da {RE } [clazs 5ample*)
4 | I

Figure5.47 [Locals] Window

If alocal variableis not initialized when defined, then the value of the local variable will be

incorrect until another value is assigned to the local variable.

The local variable values and the radix for local variable display can be modified in the same

manner asin the [Watch] window.
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5.13 UsingtheEvent Points

The emulator has the event point function that performs breaking, tracing, and execution time
measurement by specifying higher-level conditions along with the PC breakpoints standard for the
HEW.

5.13.1 PC Breakpoints

When the instruction of the specified address is fetched, the user program is stopped. Up to 255
points can be set.

5.13.2 Break Conditions

Break conditions can be used for higher-level conditions such as the data condition as well as
specification of the single address.

5.13.3  Opening the[Event] Window

Select [View -> Code -> Eventpoints] or click the [Eventpoints] toolbar button ( to open the
[Event] window.

The [Event] window has the following two sheets:

[Breakpoint] sheet: Displays the settings made for PC breakpoints. It is also possible to set,
modify, and cancel PC breakpoints.

[Break condition] sheet:  Displays or sets the settings made for break condition channels.
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5.134  Setting PC Breakpoints

It is possible to display, modify, and add PC breakpoints on the [Breakpoint] sheet.

Type State Condition Action

reakpoint  Enable Lddress=H'0O0001002 (sbrk.c/36) Ereak

reakpoint  Disable Lddress=H'0O000103C (tutorial.cpps37) Ereak

< >
Breakpoint /i Breakconditon [

Figure5.48 [Event] Window ([Breakpoint] Sheet)

Thiswindow displays and sets the breakpoints. Items that can be displayed in the sheet are listed
below.

[Type] Breakpoint

[State] Whether the breakpoint is enabled or disabled
Enable: Valid
Disable: Invalid

[Condition] An address that the breakpoint is set
Address = Program counter (Corresponding file name, line, and symbol name)

[Action] Operation of the emulator when abreak condition is satisfied
Break: Halts execution.

When abreakpoint is double-clicked in this window, the [Set Break] dialog box is opened and
break conditions can be modified.

A popup menu containing the following options is available by right-clicking within the window.

5135 Add

Sets breakpoints. Clicking thisitem will open the [Set Break] dialog box and break conditions can
be specified.
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5.13.6 Edit

Only enabled when one breakpoint is selected. Select a breakpoint to be edited and click thisitem.
The [Set Break] dialog box will open and break conditions can be changed.

5.13.7 Enable

Enabl es the selected breakpoint(s).

5.13.8 Disable

Disables the selected breakpoint(s). When a breakpoint is disabled, the breakpoint will remain in
the list; when specified conditions have been satisfied, abreak will not occur.

5139 Delete

Removes the selected breakpoint. To retain the details of the breakpoint but not have it cause a
break when its conditions are met, use the Disable option (see section 5.13.8, Disable).

5.13.10 Delete All

Removes al breakpoints.

5.13.11 Goto Source

Only enabled when one breakpoint is selected. Opens the [Source] window at the address of the
breakpoint.
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5.13.12 [Set Break] Dialog Box

et Break

Address

Address : H103C

(0] 4 | Cancel

Figure5.49 [Set Break] Dialog Box
This dialog box specifies break conditions.

A breakpoint addressto be set is specified in the [Address] edit box. Up to 255 breakpoints can be
specified.

When [Address] is selected, if an overloaded function or class name including a member function
is specified in address, the [Select Function] dialog box opens.

Clicking the [OK] button sets the break conditions. Clicking the [Cancel] button closes this dialog
box without setting the break conditions.
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Notes on Setting the [Breakpoint] Dialog Box

1. When an odd address is set, the address is rounded down to an even address.

2. A software break is accomplished by replacing instructions. Accordingly, it can be set only to
the flash memory or RAM area. However, a software break cannot be set to the following
addresses:

O An areaother than the flash memory or RAM
0 An areaoccupied by the E10A emulator program
O Aninstruction in which Break Condition 1 is satisfied

3. During step execution, a software breakpoint is disabled.

4, A condition set at Break Condition 1 is disabled immediately after starting execution when an
instruction at a software breakpoint is executed. A break does not occur even if a condition of
Break Condition 1 is satisfied immediately after starting the execution.

5. When execution resumes from the breakpoint address after the program execution stops at the
software breakpoint, single-step execution is performed at the address before execution
resumes. Therefore, realtime operation cannot be performed.

6. Settings of software breakpoint and Break Condition 1 are invalid while the STEP OVER
function is being used.

5.13.13 Setting Break Conditions

On the [Break condition] sheet, the settings for break conditions are displayed, modified, and
added.

Aotion
Ereak

Condition

reak condition 1 Disable None

Breakpnintf, Breakcondition /

Figure5.50 [Event] Window ([Break condition] Sheet)

Note: Theitemsthat can be set in thiswindow differ depending on the product. For the settings
for each product, refer to the online help.
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Thiswindow displays and sets the break condition.
Notes on Setting the Break Condition:

1. When [Go to cursor], [Step In], [Step Over], or [Step Out] is selected, the settings of Break
Condition 1 are disabled.

2. Setting of Break Condition 1 is disabled when an instruction to which aBREAKPOINT has
been set is executed.

3. When step over function is used, the settings of BREAKPOINT and Break Condition 1 are
disabled.

Items that can be displayed in the sheet are listed below.

[Type] Break channel number

[State] Whether the breakpoint is enabled or disabled
Enable: Valid
Disable: Invalid

[Condition] A condition that satisfies a break.

[Action] Operation of the emulator when a break condition is satisfied.
Break: Halts execution

When abreakpoint is double-clicked in this window, the [Break condition 1] dialog box is opened
and break conditions can be modified. For details on the [Break condition 1] dialog box, refer to
the on-line help for each product.

A popup menu containing the following options is available by right-clicking within the window.

5.13.14 Edit...

Only enabled when one breakpoint is selected. Select a breakpoint to be edited and click thisitem.
The [Break condition 1] dialog box will open and break conditions can be changed.

5.13.15 Enable

Enables the selected break channel(s). A break channel that the condition has not been set is not
enabled.
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5.13.16 Disable

Disables the selected break channel(s). When a break channel is disabled, a break will not occur
even if specified conditions have been satisfied.

5.13.17 Delete

Initializes the condition of the selected break channel. To retain the details of the break channel
but not have it cause abreak when its conditions are met, use the Disable option (see section
5.13.16, Disable).

5.13.18 Delete All

Initializes conditions of all break channels.

5.13.19 Goto Source

Only enabled when one break channel is selected. Opens the [Source] window at address of break
channel.

If an address value has not been set to the break channel, this option cannot be used.

5.13.20 Sequential Conditions

Sets the sequentia condition of the break channel.

5.13.21 Editing Break Conditions

Handlings for settings other than PC breakpoints and break conditions are common. The following
describes examples of such handling.

5.13.22 Modifying Break Conditions

Select abreak condition to be modified, and choose [Edit...] from the popup menu to open the
dialog box for the event, which allows the user to modify the break conditions. The [Edit...] menu
isonly available when one break condition is selected.

5.13.23 Enabling Break Conditions

Select a break condition and choose [Enabl€] from the popup menu to enable the selected break
condition.
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5.13.24 Disabling Break Conditions

Select abreak condition and choose [Disable] from the popup menu to disable the selected break
condition. When a break condition is disabled, the break condition will remain in thelist, but an
event will not occur when the specified conditions have been satisfied.

5.13.25 Deleting Break Conditions

Select abreak condition and choose [Delete] from the popup menu to remove the selected break
condition. To retain the break condition but not have it cause an event when its conditions are met,
use the [Disable] option (see section 5.13.24, Disabling Break Conditions).

5.13.26 Deleting All Break Conditions

Choose [Delete All] from the popup menu to remove all break conditions.

5.13.27 Viewingthe SourceLinefor Break Conditions

Select abreak condition and choose [Go to Source] from the popup menu to open the [Source] or
[Disassembly] window at the address of the break condition. The [Go to Source] menu is only
available when one break condition that has the corresponding source file is selected.
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5.13.28 [Break condition 1] Dialog Box

Break condition 1 il 5'
condition |
— fddrezs
[~ Don't care
* Addrezs = Only proeram fetched address after

Addrezs IH'D
ki { User mask

— Data
[~ Don't care
Walue IH'D
 Low byte "~ High byte * \Ward
— Fead Mt ite
{+ Bead Mhirite " Bead Wik ite

(0] 4 I Cancel Spply

Figure5.51 [Break condition 1] Dialog Box

Note: Theitemsthat can be set in this dialog box differ depending on the product. For the
settings for each product, refer to the online help.

This page sets the address bus, data bus, and read/write cycle conditions.

The [Address] group box sets address bus conditions.
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Option Description

[Don’t care] check box Does not set address conditions.

[Address] radio button Sets the use of the normal address bus as break
conditions.

[Only program fetched address after] Sets a break after prefetched address execution as break

radio button conditions.

[Address] edit box Sets the address bus value with a number or a symbol.

[Mask] edit box Sets a value to be masked when [User mask] is selected.
For masked bits, the break condition is satisfied for any
values.

The contents of an option that can be will change depending on the radio button selected.

Option Description

[Address] radio button All options can be set.

[Only program fetched address after] The [Address] option can be set.
radio button

The [Data] group box sets the data bus conditions.

Option Description

[Don’t care] check box No data conditions are set.

[Value] edit box Sets the data bus with a number.

[Low byte] radio button Sets data access size as the lower 8-bit access.
[High byte] radio button Sets data access size as the upper 8-bit access.
[Word] radio button Sets data access size as the word access.

The [Read/Write] group box sets the read/write cycle conditions.

Option Description

[Read/Write] radio button Sets the read/write cycle conditions as break conditions.
[Read] radio button Sets read cycles as break conditions.

[Write] radio button Sets write cycles as break conditions.
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5.14  Viewingthe Trace Information

For the description on the trace function, refer to section 2.2, Trace Functions.

5.14.1 Openingthe[Trace] Window

To open the [ Trace] window, choose [View -> Code -> Trace] or click the [Trace] toolbar button

@

5.14.2  Acquiring Trace Information

The acquired trace information is displayed in the [ Trace] window.

Trace Window

PTR Irp Type Address Instruction Source Lahel
-0oooo03 [ululufe) ERANCH 00ooz1lo ELT [H'Z0EC: &
-0oo00o0z oooz ERANCH 00o00z110 ELT [BH'ZOEC: &
-000oo0l oool EBRANCH ooo0zlle JHF B5spregldzs3: 24

oooooon aooo ERANCH 00001128 RT3

Figure5.52 [Trace] Window

Thiswindow displays the following trace information items:

[PTR] Pointer to alocation in the trace buffer (+0 for the last executed instruction)
[1P] The amount of acquired trace information
[Type] Type of branch:
BRANCH: branch source
[Address] Instruction address
[Instruction] Instruction mnemonic
[Source] The C/C++ or assembly-language source program
[Label] Label information

It is possible to hide any column not necessary in the [ Trace] window. Selecting a column you
want to hide from the popup menu displayed by clicking the right-hand mouse button on the
header column hides that column. To display the hidden column, select the column from the said
pOopup menu again.
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Note:  The number of branch instructions that can be acquired by atrace differs depending on the
product. For the specification of each product, refer to the online help.

5.14.3 Clearing the Trace | nformation

When [Clear] is selected from the popup menu, the trace buffer that stores the trace information
becomes empty. If several [Trace] windows are open, all [Trace] windows will be cleared as they
all access the same buffer.

5.144  Savingthe Trace Information in aFile

Select [Save...] from the popup menu to open the [Save Ag] file dialog box, which allows the user
to save the information displayed in the [ Trace] window as atext file. A range can be specified
based on the [PTR] number. Thisfile can only be saved; it cannot be reloaded into the [Trace]
window.

5.145 Viewing the[Source] Window

The [Source] window corresponding to the selected trace record can be displayed in the following
two ways:

» Select atrace record and choose [View Source] from the popup menu.
» Double-click atrace record

The [Source] or [Disassembly] window opens and the selected line is marked with a cursor.

5.14.6  Trimming the Source

Choose [Trim Source] from the popup menu to remove the white space from the left side of the
source.

When the white space is removed, a check mark is shown to the left of the [Trim Source] menu.
To restore the white space, choose [ Trim Source] while the check mark is shown.
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5.15 Viewingthe Function Call History

The [Stack Trace] window shows the function call history.

5151 Openingthe[Stack Trace] Window

To open the [Stack Trace] window, choose [View -> Code -> Stack Trace] or click the [Stack
Trace] toolbar button ().

StackTrace X
Eind | Hame Yalue

F Sample: sort(long *) { 0=2074 %

F tutoriall) { 0=xl068 7}

F main() { 0=xl028 %

F FPowerCH_Resest () { 0=04lc }

£ >

Figure5.53 [Stack Trace] Window

The following items are displayed.

[Kind]: Indicates the type of the symbol.
F: Function
P: Function parameter
L: Local variable
[Name]: Indicates the symbol name.
[Valuel: Indicates the value, address, and type of the symbol.

5.15.2 Viewing the Source Program

Select afunction and choose [Go to Source] from the popup menu to display, in the [Source]
window, the source program corresponding to the selected function.
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5153 Specifying the View

Choose [View Setting...] from the popup menu to open the [Stack Trace Setting] dialog box,
which allows the user to specify the [Stack Trace] window settings.

Stack Trace Setting

Mest level [1-64) mn =

— Dizplay symbol
[ Barameter
[ Local Variable

— Diaplay A adix
' Hexadecimal
" Decimal
€ Octal Ok
" Binary

Cancel |

Figure5.54 [Stack Trace Setting] Dialog Box

[Nest level]: Specifies the level of function call nesting to be displayed in the [ Stack
Trace] window.

[Display symbol]:  Specifies the symbol types to be displayed in addition to functions.

[Display Radix]: Specifies the radix for displaysin the [Stack Trace] window.
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516 Displaying Memory Contents as an mage

The memory contents can be displayed as an image in the [Image] window.

5.16.1 Opening the[lmage] Window

Choose [View -> Graphic -> Image...] or click the [Image] toolbar button (\Eb to open the
[Image Properties] dialog box shown in figure 5.55.
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Image Properties

2 x|

Colar Information:

" YChEr

Bit/Piuel IBbit[lndEH Color’ "I
Sampliti: |4:4:4 ]v
Earmat: I chunky b I

Buffer |nformation:

Data Address: IH'UUUUUUUD j
[

Falette fddiess: IH'DDDUUUUU
—Width/Height Size[Fizel]:
"width:
Height:

I n
I H'00000000  Byte
I n

Buffer Size:

Wigw |nformnation:

—Yiew Mode; ———— — Foaition;
' Full Size # Position: I 0
" Part Size Y Positior I—EI
— Start Position: = waidthd Heght SizelFixel):
# Top Wit | 0
" Battom Height: Iilj

(0] I Cancel |
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Figure5.55 [Image Properties] Dialog Box
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The [Image Properties] dialog box is used to specify the display method of the [Image] window.

The following items are to be specified:

[Color Information]: Specifies the color information of the image to be displayed.
[Mode]: Specifies the format.

[MONOCHROME]: Displaysin black and white.

[RGB]: Displayed in R (red), G (green), and B
(blue)

[BGR]: Displayed in B (blue), G (green), and R
(red)

[YCDCr]: Displayed by Y (brightness), Cb (color
differencein blue), and Cr (color difference
inred)

[Bit/Pixel]: Specifies Bit/Pixel depending on the selected [Mode]. (Valid when
RGB or BGR is selected)
[Sampling]: Specifies the format of sampling. (Valid when Y CbCr is selected)
[Format]: Specifies Chunky/planar. (Valid when Y ChCr is selected)
[Buffer Information]: Specifies the area to store data, size, and the address of the palette.

[Data Address): Specifies the start address of the memory where image dataisto
be displayed. (Displayed in hexadecimal)

[Pelette Address]:  Specifies the start address of the memory of color palette data.
(Displayed in hexadecimal) (Valid when 8Bit is selected for RGB or
BGR)

[Width/Height Size]: Specifies the width and height of the image.

[Width (Pixel)]: Specifies the width of the image.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Height (Pixel)]: Specifies the height of theimage.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Buffer Size]: Displays the buffer size of the image
from the width and height
(Displayed in hexadecimal)

[View Information]: Specifies the location, size, and data start location of the part to be
displayed among the entire image.
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[View Mode]:
[Full Size]:
[Part Size]:
[Start Position]:
[Top]:
[Bottom]:

[Position]:

Specifies the entire/part to be displayed in the image.

Displays the entire image.
Displays part of the image.

Displays data from the upper left.
Displays data from the lower |€eft.

Specifies the start position of the image where part of the imageis

to be displayed. (Valid when [Part Siz€] is selected)

[X Position]:

[Y Position]:

Specifies the X axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)
Specifiesthe Y axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Width/Height Size]: Specifies the height and width of the image to be displayed partly.

[Width (Pixel)]:

[Height (Pixel)]:

Displays the width of display.

(When aprefix is omitted, the values are
input and displayed in decimal.)
Displays the height of display.

(When aprefix is omitted, the values are
input and displayed in decimal.)

After the settings have been made in the [Image Properties] dialog box, clicking the [OK] button
opens the [Image] window.

Even after the [Image] window is displayed, the display contents can be modified by opening this

dialog box by choosing [Properties...] from the popup menu.
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Figure5.56 [Image] Window

The memory content is displayed as an image.

5.16.2 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will allow the window contents to be automatically
updated when user program execution stops.

5.16.3  Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.
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5.16.4 Displaying the Pixel Information

Double-clicking within the window displays information on the pixel on which the mouse pointer
islocated in the [Pixel Information] dialog box.

Pixel Infarmation il ﬂ

|ridex Colar

Color mode:

|
Pirel | Index Mo.195

Pozition s I 2 " I 4
Buffer Size Width: | 10 Height: | 10
Image Size ‘width; I 10 Height: I 10

Figure5.57 [Pixel Information] Dialog Box
This dialog box displays pixel information on the cursor location.

[Color Mode]:  Displaysthe format of the image.

[Pixel]: Displays color information of the cursor location. (Displayed in decimal)
[Position]: Displays the cursor location in X and Y axes. (Displayed in decimal)
[X]: Displaysthe X axis of the cursor location.
[Y]: Displaysthe Y axis of the cursor location.

[Buffer Size]:  Displaysthe buffer size. (Displayed in decimal)
[Width]: Displays the buffer width.
[Height]: Displays the buffer height.

[Image Size]:  Displays the width and height of the display. (Displayed in decimal)
[Width]: Displays the width.
[Height]: Displays the height.
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5.17  Displaying Memory Contents as Waveforms

Memory contents can be displayed as waveformsin the [Waveform View] window.

5.17.1 Openingthe[Waveform View] Window

Choose [View -> Graphic -> Waveform...] or click the [Waveform] toolbar button () to open
the [Waveform Properties] dialog box shown in figure 5.58.

Waveform Properties

Data Address:  {H'D0000000 =]

DataSize:  |gbir | Cancel |
Channel:

’7 * Mano " Stereo

Buffer Size:  [H'00000000 =]

Figure5.58 [Waveform Properties] Dialog Box
Specifies the waveform format. The following items can be specified.
[Data Address]: Specifies the start address of datain memory (displayed in hexadecimal).
[Data Size]: Selects 8Bit or 16Bit.
[Channél]: Specifies Mono or Stereo.
[Buffer Size]:  Specifiesthe buffer size of data (displayed in hexadecimal).

After the settings have been made in the [Waveform Properties] dialog box, clicking the [OK]
button opens the [Waveform View] window.

Even after the [Waveform View] window is displayed, the display contents can be modified by
opening this dialog box by choosing [Properties...] from the popup menu.
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I Waveform Yiew -0l x|
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Figure5.59 [Waveform View] Window

Displays the memory contents as waveforms. The X axis shows the number of sampling data and
the 'Y axis shows the sampling value.

5.17.2  Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will alow the window contents to be automatically
updated when user program execution stops.

5.17.3 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.17.4  Zoom-In Display

Selecting [Zoom In] from the popup menu displays the waveforms with the horizontal axis
enlarged.

5175 Zoom-Out Display
Selecting [Zoom Out] from the popup menu displays the waveforms with the horizontal axis
reduced.
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5.17.6 Resetting the Zoom Display

Selecting [Reset Zoom] from the popup menu displays the waveformsin its original size.

5.17.7  Setting the Zoom Magnification

In the [Zoom Magnification] submenu of the popup menu, the zoom magnification can be selected
from2, 4, or 8.

5.17.8  Setting the Horizontal Scale

In the [Scale] submenu of the popup menu, the size of the X axis can be selected from 128, 256, or
512 pixels.

5.17.9 Non-Display of Cursor

Selecting [Clear Cursor] from the popup menu hides the cursor display.

5.17.10 Displaying the Sampling Infor mation

Selecting [Sample Information...] from the popup menu displays the [Sample Information] dialog
box.

Sample Information

Diata Size: | St
Channel: I M ano

5% | H'O0000077
Walue

v H00

Figure5.60 [Samplelnformation] Dialog Box

Displays the sampling information of the cursor location in the [Waveform View] window. The
following information is displayed.

[Data Size]: Displays 8bit or 16bit.
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[Channel]: Displays the data channel.

[Value]: [X] Displaysthe X axis of cursor location.

[Y] Displaysthe Y axisof cursor location (displaysthe Y axis for both the upper
and lower plots when Stereo is selected).
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Section 6 Tutorial

6.1 Introduction
This section describes the main functions of the emulator by using atutoria program.

The tutorial program is based on the C++ program that sorts ten random data itemsin ascending or
descending order. Thetutorial program performs the following actions:

e Thenmai n function generates random data to be sorted.
e Thesort function sorts the generated random data in ascending order.
« Thechange function then sorts the data in descending order.

Thefilet ut ori al . cpp contains source code for the tutorial program. Thefile
Tut ori al . abs isacompiled load module in the Dwarf2 format.

Note:  After recompilation, the addresses may differ from those given in this section.

6.2 Runningthe HEW

To run the HEW, refer to section 3.4, System Check.

6.3 Setting up the Emulator

This section describes the basic settings of the emulator.
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6.4 Setting the [Configuration] Dialog Box

e Select [Emulator] then [Systems...] from the [Options] menu for the basic settings of the
emulator. The[Configuration] dialog box is displayed.

Configuration ﬂ
General

Device IjHBSfxxxx LI
Emulation made IN:::rmaI ;I
Step option IDisaI:uIes interrupts during sinele step execution ;l
Jlelce s [1.031MHz =1
Flash memory i -
synchronization I Ol _I

Ok I Cancel Ll

Figure6.1 [Configuration] Dialog Box

Note: Theitemsthat can be set in this dialog box differ depending on the product. For the
settings for each product, refer to the online help.
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Set options as follows:

Table6.1 Setting the [Configuration] Dialog Box

Option

Description

[Device] combo box

Displays the MCU name.

[Emulation mode] combo box

Selects the emulation mode at user program execution.
Select Normal to perform normal emulation.

Select No break to temporarily disable software breakpoints or
break condition settings during emulation.

[Step option] combo box

Sets the step interrupt option.

Disable interrupts during single step execution: Disables
interrupts during step execution.

Enable interrupts during single step execution: Enables
interrupts during step execution.

[JTAG clock] combo box

[Flash memory synchronization]
combo box

Sets the frequency* of the JTAG clock.

Sets the synchronization method between the host computer
and the flash memory.

If the frequency of the host computer is synchronized with that
of the flash memory, there is a waiting time to program the flash
memory when the user program is stopped. However, the
displayed contents and the flash memory are always matched.

If the frequency of the flash memory is synchronized with that of
the host computer, the contents of the flash memory are read
when the user program is stopped, and the reprogrammed
contents in the user program mode are reflected.

Disable: Disables synchronization except when the emulator is
activated and the flash memory area is changed.

PC to Flash memory: Synchronizes the frequency of the host
computer with that of the flash memory.

Flash memory to PC: Synchronizes the frequency of the flash
memory with that of the host computer.

PC to Flash memory, Flash memory to PC: Synchronizes the
frequency between the host computer and the flash memory.

Note: The range for the frequency of the JTAG clock differs depending on the supported device.

« Click the [OK] button to set a configuration.
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6.5 Checkingthe Operation of RAM
Check that RAM is operating correctly.

Display and edit the contents of the memory in the [Memory] window to check that the memory is
operating correctly.

Note: The memory can be installed on the board in some microcomputers. In this case, however,
the above way of checking the operation of memory may be inadequate. Itis
recommended that a program for checking the memory be created.

e Select [Memory...] from the [CPU] submenu of the [View] menu and enter the RAM address.
Here, enter H'FFC000 and H’ FFEFBF in the [Begin] and [End)] edit boxes, respectively, and
set the size in the [Data size] combo box to Byt e.

Set Address

e b4
_ Cenedl |

IH'FFEIZIIZID

LCancel
End:

|_H'FFEFBF

Format;

| Byte (1) =l

Figure6.2 [Set Address] Dialog Box

Note: The settings of the RAM area differ depending on the product. For details, refer to the
hardware manual .

e Click the [OK] button. The [Memory] window is displayed and shows the specified memory
area.
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i Memary

|hddress

0x00FFC000
0x00FFC003
0x00FFC006
0x00FFC00%9
0x00FFC00C
0x00FFCO0F
0x00FFC012
Ox00FFCO15
0x00FFC018

Data

AF 1E
TF 97
BF EF
IF 16
FO E&A
3F FF
26 IF
DFE O9A

3a 17

BC
FB
F3
FD
CF
FF
ARl
44
| )

Figure6.3 [Memory] Window

Placing the mouse cursor on a point in the display of datain the [Memory] window and

double-clicking allows the values at that point to be changed. Data can also be directly edited
around the current position of the text cursor.
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6.6 Downloading the Tutorial Program

6.6.1 Downloading the Tutorial Program
Download the object program to be debugged.

In this emulator, it is enabled to download the program and set the PC breakpoint in the internal
flash memory area. For the method to set the PC breakpoint, refer to section 6.16.1, PC Break
Function.

e Select [Download] from [Tutorial.abs] of [Downlaod modules].

=10l x|

=3y Tutorial
= I@ Tutorial
------ 29 Azzembly zource file
|_‘_| a C header file
-[2] sbrk.h
----- Q zart.h
b Q stackzct h
E-23 T source file
----- ; dbsct.c
- Q shrk.c
S5 T+ zource file
----- Q resetprg.cpp
w[2] sart.cpp

- j tutorial. cpp
=8 a Download modules

...... iﬂ“"""""""

Download module

Unload module

Configure Yiew. ..

Allovy Docking
Hide

3] Projects | = 1 MWavigation |

Figure 6.4 Downloading the Tutorial Program

328
RENESAS




6.6.2 Displaying the Source Program
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The HEW allows the user to debug a user program at the source level.

* Double-click [tutorial.cpp] under [C++ source filg].

oha |

EI@ Tutorial

|
DEI

L

=3
éa

EII@ Tutorial

- [<] SBRKH
-[Z] SORTH
2] STACKSCT

-[2] DBSCTG
‘|2l SBREC

--[<] RESETPRG
- [Z] SORTCPP
i) Tutorialcpp

Azzembly sour
Z header file

G =ource file

C++ zource file

Download mody
28] Tutorialabs
Dependencies
sorth

o Tutorialcpp

(00000835
(00000834

(00000538
(00000844

void abort (void);
Bifdef __cplusplus

bendif
Finclude “sort.h”
Finclude <stdlib.h>

void tutorial (vaid);

void main(void)

{

" torial 0
} 1
void tutorial (void)
: Iong g@10];

Figure 6.5 [Source] Window (Displaying the Sour ce Program)

» Select the [Display] option from the [Tool] menu to set afont and size that are legible, if

necessary.

Initially the [Source] window shows the start of the user program, but the user can use the scroll
bar to scroll through the user program and look at the other statements.
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6.7 Setting a PC Breakpoint
A PC breakpoint is a simple debugging function.

The [Source] window provides avery simple way of setting a PC breakpoint at any pointin a
program. For example, to set a PC breakpoint at the sor t function call:

e Select by double-clicking the [Editor] column on the line containing the sor t function call.

wt- Tutorialcpp

int i

clazs Sample *p_sam;
000000844 p_sam= Samp | e;
0000005 4e forl i=0; i<10; i+ )
000000850 i = rand();
Ox00000858 ifli <0
Ox00000585a | i= -
Ox0000085¢ | alil = i;
000000870 p_sam-rsort (a);
0x0000087a p_zam->change(a);
0000005852 p_sam-><0=al0];
0:0000088a posam-»sl=al1];
Ox000005% p_sam-rs2=al2];
000000842 p_sam-rs3=al3];
0000005 ae p_sam-r=d=al4];
0x000008ba p_sam-><h=alh];
Ox000008c64 p_sam-»sh=alB];
0000005842 p_sam->s/=al7];
M NANNNS An T Y o

Figure 6.6 [Source] Window (Setting a PC Breakpoint)

The symbol « will appear on the line containing thesor t function. This shows that a PC
breakpoint has been set.
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6.8 Setting Registers

Set values of the program counter and the stack pointer before executing the program.

Select [Registers] from the [CPU] submenu of the [View] menu. The [Register] window is

displayed.

High-performance Embedded Workshop User's Manual

=101.x]

Register ... I Fegister Walue

H'oooooooo

H'0oooooooo
H'0ooooooao
H'0oooooooo
H'0ooooooao
H'0ooooooao
H'00o0oalo
H'FFFFFF

RENESAS

Figure6.7 [Register] Window
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« To change the value of the program counter (PC), double-click the value areain the [Register]
window with the mouse. The following dialog box is then displayed, and the value can be
changed. Set the program counter to H'400 in this tutorial program, and click the [OK] button.

Register - [PC] EE |

Walue:

| B

Set A Cancel |

I'W'hu:ule Reqizter j

Figure 6.8 [Register] Dialog Box (PC)
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6.9 Executing the Program
Execute the program as described in the following:

* To execute the program, select [Go] from the [Debug] menu, or click the [Go] button on the
toolbar.

Ell

Figure6.9 [Go] Button
When the program execution isstarted, * ** RUNNI NG is displayed on the status bar.

The program will be executed up to the breakpoint that has been inserted, and an arrow will be
displayed in the [Editor] column to show the position that the program has halted, with the
message [ BREAKPO NT] in the status bar.

Note:  When the sourcefileis displayed after a break, a path of the source file may be inquired.
The location of the sourcefileisasfollows:

<HEW?2 installation directory>\T ool s\Renesas\DebugComp\Platform\EL0A\xxxx\Tutorial
\source
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«#- Tutorialcpp

(00000845
[x0000084e
(00000850
(00000858
(00000852

0:0000085¢

000000870
(00000572

0000005852
Ox0000055a
0=000008%
0000005842
Ox000008ae
Ox000008ba
0x000008ca
0000005842

M ACCCE A

int i;
class Sample *p_sam;

p_sam= Samp | e;
for( i=0; i<10; i++ )

i = rand(J;

it <0

io= i

1

alil = i;
1
p_sam-rsort (a);
p_sam->chanze(a);

p_sam-rsl=al0];
p_zam-rsl=al1];
p_sam->s2=al2];
p_sam-rs3=al3];
p_sam-r=d=al4];
p_sam->sh=alh];
p_sam-><6=al6];

p_sam-rsi=al7];
P o  + 2 I

Figure 6.10 [Source] Window (Break Status)
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The user can see the cause of the break that occurred last time in the [Status] window.

Select [Status] from the [CPU] submenu of the [View] menu. After the [Status] window is
displayed, open the [Platform] sheet, and check the St at us of Cause of | ast break.

Item I Status I
Conmected to: HSS5/xxxx E10A SYSTEM

CIT HES fxnxx

Pun status Ready

Cause of last break EREAE POINT

Pun time count 0000h000nind00s023ns

Enmulation mode Hormal

Endian Big

AT\ Memary }, Platform £ Events

Figure6.11 [Status] Window

Note: Theitemsthat can be set in thiswindow differ depending on the product. For the settings
for each product, refer to the online help.
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6.10 Reviewing Breakpoints
The user can see al the breakpoints set in the program in the [ Event] window.

¢ Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is
displayed. Select the [Breakpoint] sheet.

=101.x]

Type State Condition

Ereakpoint Enable Addrezss=H'00000574 (Tutorial.cpp/45)

F

| 2

L bl‘\ Breahpnintﬂ Breakcondition f

Figure6.12 [Event] Window

The popup menu, opened by clicking the [Event] window with the right-hand mouse button,
alows the user to set or change breakpoints, define new breakpoints, and delete, enable, or
disable breakpoints.
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6.11 Viewing Memory

When the label name is specified, the user can view the memory contents that the label has been
registered in the [Memory] window. For example, to view the memory contents corresponding to
_mai ninword size:

e Select [Memory ...] from the [CPU] submenu of the [View] menu, enter _rrai n in the [Begin]
edit box, enter +f f in the [End] edit box, and set Wr d in the [Format] combo box.

Set Address

Cancel |

T

Figure6.13 [Set Address] Dialog Box

» Click the [OK] button. The [Memory] window showing the specified area of memory is
displayed.

il Memory _I_I— m| 5'
Address Data Yalue j

0x00000834 5502 40pCc 0100 ?2R
0x0000083a GDF3 0120 &HDF4 G2
0x00000840 7937 0028 OFF3 (7
0x00000846 1a80 5SHEQ00 ODFG6 227
0x0000084C oOF846 19244 5EOQO0 227
0x00000852 OODEE 17F0 OF85 2272
0x00000858 4C02 1785 17F4 227 LI

P P T e PN ER. T Y PR Y o

Figure6.14 [Memory] Window
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6.12 Watching Variables

Asthe user steps through a program, it is possible to watch that the values of variables used in the
user program are changed. For example, set awatch on the long-type array a declared at the
beginning of the program, by using the following procedure:

« Click the left of displayed array a in the [Source] window to position the cursor.

e Select [Instant Watch...] with the right-hand mouse button.

The following dialog box will be displayed.

Insktant Watch

F-a [ 0x00ffef?c 1 done[10T)

Figure6.15 [Instant Watch] Dialog Box

e Click the [Add] button to add a variable to the [Watch] window.

=10l x|

- iatch

Figure6.16 [Watch] Window (Displaying the Array)
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The user can also add avariable to the [Watch] window by specifying its name.

Click the [Watch] window with the right-hand mouse button and select [Add Watch...] from
the popup menu.

The following dialog box will be displayed. Enter variablei .

Add Wakch

Warnable or expreszion: ak.

i LCancel

Figure6.17 [Add Watch] Dialog Box
* Click the [OK] button.

The [Watch] window will now also show theint-type variablei .

- Watch

=101 x|

Heffc { R4 }

a

Figure 6.18 [Watch] Window (Displaying the Variable)
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The user can click mark ‘+' at the |eft side of array a in the [Watch] window to watch all the
elements.

=10l x|

= fic e [10
----- R [0l HO0006023 { 0x00ffet?c | {lome)
----- B 0] HO00067d2 { 0x00ffefa0 } {long)
----- R 2 HO0005adb { 0:00f=124 } {one}
----- B [l HOD005a84 { 0x00ffefas } {long)
----- B [ HO00048e2 { 0x00ffetae } {long)
----- R [l HO00043b1 { 0x00ffefa0 | {lome)
----- B [&] HO00041 a6 { 0x00ffet24 | {lomg)
----- B 7 HO0001 768 { 0x00ffefas } {long)
----- B [&] HOD0057d2 { 0x00ffefd: } {long)
----- R @ H'O0006623 { 0x00ffefal } {long)

i Heflc {R4 1 (int}
1| | &

Figure6.19 [Watch] Window (Displaying Array Elements)
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6.13 Stepping Through a Program
The HEW provides arange of step menu commands that allow efficient program debugging.

Table6.2 Step Option

Menu

Command Description

Step In Executes each statement, including statements within functions.

Step Over Executes a function call in a single step.

Step Out Steps out of a function, and stops at the statement following the statement in the
program that called the function.

Step... Steps the specified times repeatedly at a specified rate.

6.13.1 Executing [Step In] Command

The [Step In] command steps into the called function and stops at the first statement of the called
function.

e To step through the sor t function, select [Step In] from the [Debug] menu, or click the [Step
In] button on the toolbar.

#

Figure6.20 [Step In] Button
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- SORTGPP

0=x00000e34
0x00000e3a
Ox00000e40
Ox00000e 44
[x00000edc
0=x00000e54

0=00000e5e
Ox00000e64

0x00000ea8
0x00000edc
0x00000ede
0x00000e?2
0x00000e?s
0x00000e?a

0x00000eRa
0=00000efe

1N

=10] x|

!

2void Sample:isort (long *a)

long t;
imt i, 1.k, zap;

gap = b;
while( gap > 0 )
for( k=0; k<eap; k++){
for( izk+gap; i<10; izi+gap )1
for(izi-gap; i>=k; i=j-zap)i
if(alj>alj+eap]){

t =alil;
alj] = alj+eap];
ali+gap] = t;

elze

d

Figure6.21 [Source] Window (Step In)

« Thehighlighted line moves to the first statement of thesor t function in the [Source] window.
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6.13.2 Executing [Step Out] Command

The [Step Out] command steps out of the called function and stops at the next statement of the
calling statement in the main function.

e Tostep out of thesort function, select [Step Out] from the [Debug] menu, or click the [Step
Out] button on the toolbar.

Note: It takestime to execute this function. When the calling source is clarified, use [Go To
Cursor].

¥

Figure6.22 [Step Out] Button

=18l x|
=18l x|

Visw Project Options Buld Debug Memory Tools Window Help

DFE@ @) ve|oTa||or @aene z @ Es G |8 ~aga
k| o ”m (200 G HJ@ ] “DahugLHss,m,Em j||sEss.mHss,mo<,Ewm j|)g i ‘@ I HJ@, &8 amE |
HEEAR P ||B(He ¢4 B 6|27 802 mE
————— |5 long a[l10]: —
B Tutorisl iﬁ’t‘glj' :I
- Tutorial class Sample *p_san:
&3 Assembly source
253 € header fle 000000846 p_san= 1= Sanple:
0 shikh 00000084 for( i=0; 1107 id+ ){
] 0200000850 i = rand().
=] surth 0200000858 iftg ¢ m
i [2] stackscth 0x0000085a i=-i
523 C source fil ¥
Q dhscte 0x0000085c ! afi] = 3:
o] shike 0x00000870 b sam—rsortia);
£+ Lo+ soucsfle | | nx0000087a |  p_sam->changs(a):
L[] resetpra.cpp
3] satep 0=00000882 p_san—>sl=a[0];
— 0200000884 p_san->si=a[l]
----- = EEEER | | ozoo0o08se p_san—»s2=a[2]
=43 Dowrload modu | | 00000842 o_sam—»s3=a[3]
L [1] Tutorialsbs | | 0200000828 p_san->sd=a[4];
0x000008ba p_sam->s5=a[5]:
00000086 p_sam->sb=al6]
0=000008d2 p_san->s7=a[7]
0=000008de p_san->sf=a[8]
020000082 p_san->s9=a[9]
0=000008f6 p_=sam:
0:000008fc 3
void abort(void)
E
N " " n ANNNans Ay hd
Fero gl o
2| Name | value | Tupe =] :jll Connected
T ® (] Hffif { DmO0ffef0 } {long) Flash memory writing ... Flash memory write end
~R 2 HFFF { 0x00ffefBd } [lang) EREAK POINT
R [3 Hififbd { O400fei8 } {long)
“B Hiffdbfae { Dx00fFefBc } {lng)
R [5 Hifidiedie { D400ffef30 } {long)
~R [ HIIfbF { 04D0ffefa4 {long) =
o - s nte e ent | i » A+ ['Build }, Debug £ Find in Files }, Version Contral J
Ready [Readwrite  [45/84 1 [ins [ uom

Figure 6.23 [HEW] Window (Step Out)
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The data of variable a displayed in the [Watch] window is sorted in ascending order.

6.13.3 Executing [Step Over] Command

The [Step Over] command executes a function call as asingle step and stops at the next statement
of the main program.

« To step through all statementsin the change function at asingle step, select [Step Over] from
the [Debug] menu, or click the [Step Over] button on the toolbar.

¥

Figure 6.24 [Step Over] Button

o — \op ppl ==l
2 Fle Edit View Project Options Buld Debug Memory Iools Window Help _|&] x|
DeEg 3 ee 0 ral|lom@s]t e ¢ =@ |E || SE Y
i e A=y HJ@ {44 ¢4 | [Dohuo Hes nom_E10e 7] |[Sesionres nem_E10e 1| 7t 4 | T 31 HJ& =& s ia |
EE o == = B =S R =
== Tong a(10]:
e — ; «
= & Tutoral et i
E-1F Tutorial class Sanple *p_san;
3 hssembly saurce
523 C header file 000000846 p_san= Sample:
H strkh 0z0000084e for{ i=0; 1<10:; i++ ){
H - 0=00000850 i = rand():
) sorth 0x00000858 if(5 < 0
(=] stackscth 0200000855 jo= -3
=43 € source file }
) doscte 0:0000085c ali] = i;
i} +
""" ] sbike 0x00000870 P_san—ssortia);
E-3 Ce+soucefie | | 020000087a ©_san—>change(a):
2] resstpra.cpr
0x00000882 & p_san—»s0=a[0]:
=l r 00000088 ]
L ST T 0=000006896 2]
=3 Dowrload modu | | 020000082 p_sam—>s3=al[3]
Tutorialabs | | 020000082 D_san—>sd=a[4];
0:000008ba D_sam—»s5=a[5];
0=000008ck p_sam—>»sk=alk]
0x000008d2 p_sam—»s7=a[7]
0x000008d= D_san—>sB=a[8]
0x000008ea D_san->s9=a[9]
0:000008£6 p_sam;
0x000008fc }
woid abort{void)

Kl R E
3P Proj... | < Navig.. i = »
2| Name | Walue | Tyee - :fll BREAK POINT B

q = HfffF { Ox00ffefE0 } [lona) Flash memory writing ... Flash memory write end
R [2 Hfiffftf { Owd0ffefB4 } {long) STOP ADDRESS
~R 3 Hrfififfbd { 0x00Nfef88 llong] Flash mewory writing ... Flash memory write end
R’ 4 Hfffdbiae { Dx00ffefde } (long] STOP ADDRESS
~R [5] Hiffdfedte { 0x00fefa0 } {long)
=N i { D00ffef34 } {lang) . =
- -7 et te o et | tmg » 4[> Build }, Debug fFindin Files }, Version Contral /
STOP ADDRESS [Read-write  [47/54 1 [ms [ nom
Figure6.25 [HEW] Window (Step Over)
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6.14 Forced Breaking of Program Executions
The HEW can force a break in the execution of a program.
* Cancd dl bresks.

» To execute the remaining sections of the mai n function, select [Go] from the [Debug] menu
or the [Go] button on the toolbar.

Ell

Figure6.26 [Go] Button

» Theprogram goesinto an endlessloop. To force abreak in execution, select [Halt] from the
[Debug] menu or the [Halt] button on the toolbar.

L

Figure 6.27 [Halt] Button
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6.15 Displaying Local Variables

The user can display local variablesin afunction using the [Locals] window. For example, we
will examine the local variablesin thet ut ori al function, which declares four local variables: a,
j,i,andp_sam

e Select [Locals] from the [Symbol] submenu of the [View] menu. The [Locals] window is
displayed.

The [Locals] window shows the local variablesin the function currently pointed to by the program
counter, along with their values. Note, however, that the [Locals] window isinitially empty
because local variables are yet to be declared.

- Locals ;IEIEI
Hame I Yalue | Type

----- a { 0:00ffefic | {one[1 0]}

-------- | Ho0ffef?c { ERG } {lone}

........ i H'O00a { R4 (ints

----- p_sam Ox00ffdedd { ERA | iclass Sample*)

<| | L

Figure6.28 [Locals] Window

e Click mark ‘+" at the left side of array a in the [Locals] window to display the elements.

*  When the user refersto the elements of array a before and after the execution of thesor t
function, it is clarified that random datais sorted in descending order.
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6.16 Break Function

The emulator has PC and hardware break functions. With the HEW, a PC breakpoint can be set
using the [Breakpoint] sheet of the [Event] window, and a hardware break condition can be set
using the [Break condition] sheet.

An overview and setting of the break function are described below.

6.16.1 PC Break Function

The emulator can set up to 255 PC breakpoints. Other methods for setting a PC breakpoint than in
section 6.7, Setting a PC Breakpoint, are described below.

e Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is
displayed.
e Select the [Breakpoint] sheet.

_ (O x|
Type atate Condition | Action
1 | r|
A | b [ Breakpoint £ Ereakcondtion
Figure6.29 [Event] Window (Before PC Breakpoint Setting)
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e Click the [Event] window with the right-hand mouse button and select [Add...] from the
popup menul.
e Enter H 0000087Ain the [Address] edit box.

Set Break ilﬂ

Addrezs |

Address :

]9 I Cancel

Figure6.30 [Set Break] Dialog Box

e Click the [OK] button.
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The PC breakpoint that has been set is displayed in the [Event] window.

- Event o | Y
Type State Condition | Action
Ereakpoint  Enable Address=H'00000874 (Tutorial.cpps4n) Ereak

! | 1|
A k[ Breakpoint £, Breakcondtion f

Figure6.31 [Event] Window (PC Breakpoint Setting)
To stop the tutorial program at the PC breakpoint, the following procedure must be executed:

«  Set the program counter value (PC = H'400) that was set in section 6.8, Setting Registers, in
the [Register] window. Click the [Go] button.

» If program execution isfailed, reset the device and execute again the procedures above.
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The program runs, and stops at the set PC breakpoint.

<& Tutorialcpp

int i

class Sample *p_sam;
0=00000344 p_=am= Samp | e;
0x0000034e forl i=0; i<10; i++
000000350 i = rand();
0=00000358 ifCi <00
0=0000035a | =i
0x0000085¢ | alil = i;
Ux00000370 p_sam-rsort (a);
000000873 p_sam->chanze(a);
0=00000382 p_sam-»=(0=al0];
0=0000038a p_sam-»=1=al1];
0x000003% p_sam-r=2=al 2 ];
0=000003a2 p_sam-rsd=al3];
0x000003ae p_sam-r=d=al4];
0=000008ba p_sam-»sh=alh];
0x000008ca p_sam-><6=al6];
0=000008d2 p_sam-»si=al 7];
M NAANT A . T o

Figure 6.32 [Source] Window at Execution Stop (PC Break)
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The [Status] window displays the following contents.

A E T Mermory_h Plattorm f{ Everts

_(Olx]
Iten I Status

Cornmected to: HSS fxxxx E10A STYETEM ( CPU Z000 ) (E1DA PCI Card Driwerf)

CPU HES fxnnx

Pun status Ready

Causze of last brealk EBIEAE DOINT

Pun time count 0000Rh000nin000=000ns

Enulation mode Normal

Exnndian Litcle

Figure 6.33 Displayed Contents of the [Status] Window (PC Break)

Note: Theitemsthat can be set in this window differ depending on the product. For the settings
for each product, refer to the online help.

RENESAS
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6.17 Hardware Break Function

A method is given below in which the address bus condition is set under Break Condition 1 as
hardware break conditions.

e Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is
displayed.

» The PC breakpoint that has been previously set isdeleted. Click the [Event] window with the
right-hand mouse button and select [Delete All] from the popup menu to cancel all PC
breakpoints that have been set.

« To set aBreak condition 1, click the [Break condition] tab.

» Select aline of Break condition 1 in the [Event] window. When highlighted, double-click this
line.

=171 x|

Fle Edt Visw Project Options Buld Debug Msmory Took Window Hslp

e 2| oe0Tal|lor @scne ¢ [o@ms|E||w" &4 b &)
Tl A7 |odoe e [[o=bun_ e veos 108 =] |[seomoniss_oucs 100 =] | 2o 8 [ B [[[ e B & & 2 @)
FEERH TR D - IEEENL=
———— i« =
B3 Tutarial
E-IE Tuterial 21x|
3 Assembly
000000846
=43 Cheader 0=0000084=
] sbkd 0=00000850
2] sorth 0=00000858
0] stack 0=0000085a
i a EQSOSL:E\ ! Oy program fetehed addiess after
I addess D
[Break conditibisable % Hom usermaske ) Wsermesk
HMask I
4| i
[» ' Ereakpaint }, Break i
Afw» reakpoin reaki ¥ Dorftcare
T=00000856
0=000008d2 Yalue Jra
0=000008de _
0=000008=a © Lowbye € Highyie & o
0=000008£6
0000008t Readdwri
| ( | Beadriwiite " Bead & ite |
=l Name [ value [ o | canen ooy |
TERa ] Flash memory write end
B HO000734b { 0x00ftef7c } {long) BREAK POTHT
~R M HIODD0BGe2 { Dx00fefS0 } {long)
R [2 H'ODDD446b { DuD0ffefa4 } {long)
~R B3 HIOD0041 o6 § Dx00ffefS8 } {long)
~R 14 HODDD354 { Ox00efBic } {long)
R [5 HIODD0Z781 § Dx00ffef30 } {long)
~R I8 HODDOT cfb { 0400Fef34 } {long)
®= 17 HANMM R7e § NeNnfefER 1 Ml -
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Ready [Read-write  [48/54 10 [ins [ |nom

i start “ T @& 5% H (=] Contral Panel | (=G \Documents and Settin. . | 1§ Tutorial - High-petfor... % wepm

Figure6.34 [HEW] Window ([Break condition 1])

e The[Break condition 1] dialog box is displayed.
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e Clear the[Don't care] check box in the [Address] group box.
» Select the[Only program fetched address after] radio button and enter H 896 asthevauein
the [Address] edit box.

Break condition 1 ﬂﬂ

condition |

— fddress

" F\ddreés % Only program fetched address after

Addrezs IH'ggﬁ
% Mon user mask { User mask

azk |

— Data
¥ Don't care
Walue IH'D

) Low byte ) Hieh byte * Ward

— ReadMirite
% Bead/Mitite {" Bead {1 Wikite

(0] 4 I Cancel | Spply |

Figure 6.35 [condition] Page ([Break condition 1] Dialog Box)

e Click the [OK] button.

« Thefirst point display in the State line changes from Di sabl e to Enabl e.

» Thefirst point display in the Condition line changes from None to Addr ess =
H 00000896 (Tutorial.cpp/49) pcafter.

e Set the program counter value (PC = H'400) that was set in section 6.8, Setting Registers, in
the [Register] window. Click the [Go] button.

Note: Theitems that can be set in this page differ depending on the product. For the settings for
each product, refer to the online help.

The program runs and then stops at the condition specified under Break Condition 1.
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& Tutorial.cpp

000000850 i = rand();
000000858 il <00
Ox0000085a | I -
O=0000085¢ | alil] = i;
000000870 p_sam-rsort (a);
0:0000087a p_sam->change(a);
000000882 p_zam-r<0=al0];
000000552 p_sam->s1=al1];
O=000008%4 & p_sam->s2=a[2];
000000522 p_sam->s3=al3];
Ox000005ae p_sam->sd=al4];
O=000008ba p_sam->s5zalh];
O=000008¢a p_sam->sb=al6];
000000842 p_zam-rsf=al 7];
O=000008de p_sam->s8=al8];
Ox000008ea p_sam->s9=a[9];
O=00000ata p_sam;
Ox000008fc 1

void abort (vaid)

ot {
Figure 6.36 [Source] Window at Execution Stop (Break Condition 1)
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The [Status] window displays the following contents.

o Status =10f x|
Item IStatus

Connected to: HeS/xxxx EL1OR STSTEM (
CETT HES fnxxx

Durn status Deady

Cauze of last break
D time count
Emulation mode
Endian

EREALE CONDITION 1
0000h000Rind00=s030ns
Normal

Little

4 | |
e I\ Wlernory b Platform f, Events f

Figure 6.37 Displayed Contents of the [Status] Window (Break Condition 1)

Note: Theitemsthat can be set in this window differ depending on the product. For the settings
for each product, refer to the online help.

355
RENESAS



High-performance Embedded Workshop User’'s Manual

6.18 Trace Functions

The emulator has a branch-instruction trace function.

The branch source addresses, mnemonics, operands, source lines, and labels are displayed for four

branches.

6.18.1 Displaying the Trace Window

Select [Trace] from the [Code] submenu of the [View] menu.

Run the program as shown in the example of section 6.16.1, PC Break Function. The trace results
are displayed in the [Trace] window after the program execution is compl eted.

wlt- Trace Windom

FTR | IF | Type | Address

| Inztruction

- | Jource | Label |

=101 x|

-0000C O@ERANCH 00000EAG  BGE B
-0000C O@ERANCH 00000E2G  BLE B
-0000C O@ERANCH 00000EBG  BPL B
+0000C OERANCH 00000ECA  RTS

Figure 6.38 [Trace] Window

If necessary, adjust the column width by dragging the header bar immediately below the title bar.

Note:  The number of branch instructions that can be acquired by atrace differs depending on the
product. For the specification of each product, refer to the online help.
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6.19 Stack Trace Function

The emulator uses the stack’ s information to display the name of the calling function for a
function at which the program counter is currently pointing.

Note: Thisfunction can be used only when the load module that has the Dwarf2-type debugging
information isloaded. Such load modules are supported in H8C/C++ compiler V3.0 or

|ater.

« Double-click the [Editor] columninthesort function and set a PC breakpoint.

o SORT.GPP =101 x|
0:00000e5e void Sample: rsort (long *a) ZI
Ox00000eds

long t:
int i, §, k, zap;
Ox00000e48 zap = 0
0:00000ebc whilel gap > 0 1
Ox00000=de forl k=0; kigap; k++){
0:00000e72 forl izk+gap; <105 i=i+gap )
0x00000e 78 forlj=i-zap; j»zk; j=j-zap){
0x00000e7a | if(alj >ali+zar]){
t =alil;
0x00000e%a alil = ali+zar];
0x00000e%e alj+gap] = 1;
elze -
break;
}
1
1
Ox00000ebd : gap = gap/?;
Knl M
Figure 6.39 [Source] Window (PC Breakpoint Setting)
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»  Set the same program counter value (PC = H’400) as was set in section 6.8, Setting Registers
(again, use the [Register] window). Click the [Go] button.

» After the break in program execution, select [Stack Trace] from the [Code] submenu of the
[View] menu to open the [Stack Trace] window.

1% =101 x|
Kind | Hame | Yalue
F Sample: ;sort{ 0x00000=e7a
F tutorial() { 0=0000087a 7}
F maini ) { 0=x00000836
F PowerCON_Resel{ 0x0000041=
1 I 2

Figure 6.40 [Stack Trace] Window

Figure 6.40 shows that the position of the program counter is currently at the selected line of the
sort () function, and that thesort () functioniscalled fromthet ut ori al () function.
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6.20 What Next?
Thistutorial has described the major features of the emulator and the use of the HEW.

Sophisticated debugging can be carried out by using the emulation functions that the emul ator
offers. This provides for effective investigation of hardware and software problems by accurately
isolating and identifying the conditions under which such problems arise.
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Appendix A Troubleshooting

I have atext filein the editor but it does not show any syntax coloring.

Ensure that you have named thefile (i.e. saved it) and that the “ Syntax coloring” check box is
set on the “Editor” tab of the “Options’ dialog box, which islaunched via[T ools ->
Options...]. HEW checks afile group to which the file's extension belongs and decides
whether the fileis colored. To view the currently defined extensions and their file groups, use
the“File Extensions” dialog box which is launched via[Project -> File Extensions...]. To
view coloring information, select [T ools -> Format] to display the “ Color” tab on the
“Format” dialog box. (See the “Syntax Coloring” section in chapter 4, “Using the Editor” of
the HEW Part for details.)

I want to change the settings of a tool but the [Tools->Administration...] menu option
cannot be selected.

[Tools->Administration...] cannot be selected while a workspace is open. To enter the “Tool
Administration” dialog box, close the current workspace.

| opened a workspace from my PC, and one of my colleagues opened the same workspace
simultaneously from another PC. | changed the settings of the workspace and saved it. He
or she saved the workspace after me. | opened the workspace again and found that the
settings of the workspace differed from what | had set before.

The settings saved last are enforced. Once HEW opens aworkspace, it is updated inside the
memory. HEW does not save the settings into a file until a user saves the workspace
intentionally.
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Appendix B Regular Expressions

The High-performance Embedded Workshop editor allows you to include special charactersin
search strings when performing a find or replace operation. These characters are listed in table B.1
and are detailed in the following pages.

TableB.1 Regular Expression Characters

Character Function

? Matches any single character (except a newline)

* Matches any number of occurrences (0 or more) of any character except a

newline

\n Matches a newline character

\t Matches a tab character

[] Matches any one character or range listed within the brackets

\ Overrides any following regular expression character

e Symbol: ?
Meaning:  This character matches any single character, except the newline character.
Example:  t?p matches “top”, “tip” but not “trap”.

e Symbol: *

Meaning:  This character matches any number of occurrences (O or more) of any character
except anewline. Thus, this character will not match across new lines. The *
character will match as few occurrences as are necessary to make the rest of the
pattern match.

Example 1: t*o matchesthe “to” of “too”, the “tro” of “trowel” and the “ty 0" of “sporty
orange’
but not “smart orange” because the * character does not match across anew line.

e Symbol: \n

Meaning:  This character matches the newline character.

\n would be used to search for line endings or in patterns that cross line
boundaries.

Example1: ;\n
matches every occurrence of a newline following a semicolon

Example 2: ;\nif

searches for a semicolon, anew line and aline beginning with “if”.
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e Symbol: \t
Meaning:  This character matches the tab character.
Example 1: \t8

Finds every occurrence of atab character followed by an 8.
Example 2: init\t
Finds every occurrence of atab character following “init”.

e Symbol: [1

Meaning:  This matches any one character or arange of single characters listed within the
brackets. Brackets cannot be nested.
[-] specifies arange of characters e.g. [a-z] or [0-9]. The beginning character in
the range must have alower ASCII value than the ending character of the range.

[~] matches a single character if it is not any one of the characters between
[~ and]. This pattern also matches newline characters, unless the newline
character isincluded within the brackets.

Example 1: [AEIOU]

Finds every uppercase vowel.
Example2: [<>7]

Findsaliteral <, >, or 2.
Example3: [A-Za-z0-9 ]

Matches an upper or lowercase |etter, adigit or an underscore.
Example 4: [~0-9]

Matches any character except adigit.
Example5: [\t\n]

Matches a space, atab or newline.
Example 6: [\]]

Matches alitera ] if ] isplaced after \.

e Symbol: \

Meaning:  Thisisthe regular expression override character. If the character following the
backslash is aregular expression character, it is treated as anormal character. The
backslash isignored if it isfollowed by anormal (non-regular expression)
character.

Example 1: \*

Searches for every occurrence of an asterisk.

Example2: \\

Searches for every occurrence of a backslash.
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Appendix C Placeholders

This appendix describes how to use the placeholders, afeature provided by several of the High-
performance Embedded Workshop components.

C.1 What is a Placeholder?

A placeholder is aspecial string, inserted into text, which is replaced at some subsequent time for
the actual value. For example, one of the HEW placeholdersis $(FULLFILE) which represents a
filewith afull path. Suppose that you have an editor in c:\myedit\myeditor.exe, which can take the
file to edit as a parameter. When invoking the editor the following shortcut could be made, e.g.:

c:\myedit\myeditor.exe c:\files\filel.c

if you wanted to open FILEL.C from the directory c:\files. However, what happens if you want the
HEW to open any file through this editor? The problem is that the command above is specific to
“c:\files\filel.c”. What we want to be able to do isto tell the HEW to use the editor specified but
to open the file that you have chosen at that time. To do this, you can replace the specific name of
the file with a general placeholder, i.e.:

c:\myedit\imyeditor.exe $(FULLFILE)

Now whenever the HEW launches the editor with afile, it knows that it hasto replace
$(FULLFILE) with the file you have selected.

C.2 Inserting a Placeholder

Placeholders can only be entered into three specific edit fields within the HEW (figuresC.1, C.2
and C.3). There are four ways a placeholder can be entered:

In the first example, place the insertion cursor at the point you would like to insert the placeholder
and then select the required placeholder from the pop-up menu to the right of the edit field.

File:
c:hprojecthmyprojecthouputhfile 7 out | 3 |

FigureC.1 Placeholder Pop-up Menu

In the second example, select the required placeholder other than “ Custom directory” from the
combo box and specify a sub-directory relative to the directory shown by the placeholder. If you
select “ Custom directory”, specify an absolute directory path in the “ Sub-Directory” field.
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Fielative to

IEaniguratiDn directary j

Sub-Directory :

Figure C.2 Placeholder Combo Box and Sub-Directory Field

In the third example, place the insertion cursor at the point you would like to insert the placeholder,
select the required placeholder from the combo box and then click the “Insert” button.

Placeholder:

Configuration directany j Ingert |

Figure C.3 Placeholder Combo Box

In the fourth example, type the placeholder into the field directly. Ensure that you type the
placeholder name in uppercase and that it is preceded by $( and followed by ), i.e.

Thisis correct:
$(FILEDIR)

These are incorrect:
$(Filedir)

$( FILEDIR )
$FILEDIR
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C.3 Available Placeholders
Table C.1 lists the placeholders and their meanings.

Table C.1 Placeholders

Placeholder Meaning
$(FULLFILE) Filename (including full path)
$(FILEDIR) File directory

$(FILENAME)
$(FILELEAF)

Filename (excluding path and including extension)

Filename (excluding path and extension)

$(EXTENSION)
$(WORKSPDIR)

File extension

Workspace directory

$(WORKSPNAME) Workspace name
$(PROJIDIR) Project directory
$(PROJECTNAME) Project name

$(CONFIGDIR)

Configuration directory

$(CONFIGNAME)

Configuration name

$(HEWDIR) HEW installation directory
$(TEMPDIR) Temp directory

$(WINDIR) Windows® directory
$(WINSYSDIR) Windows® system directory
$(EXEDIR) Command directory
$(USERNAME) User login (version control)
$(PASSWORD) User password (version control)
$(VCDIR) “Virtual” version control directory
$(COMMENT) Comment (version control)
$(LINE) Line number of an error/warning
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For example, the placeholders will be expanded as shown in table C.2.

TableC.2 Placeholder Expansions (Example)

Placeholder Expanded placeholder (example)
$(FULLFILE) c:\hew\workspace\project\file.src
$(FILEDIR) c:\hew\workspace\project
$(FILENAME) file.src

$(FILELEAF) file

$(EXTENSION)
$(WORKSPDIR)

src

c:\hew\workspace

$(WORKSPNAME) workspace

$(PROJDIR) c:\hew\workspace\project
$(PROJECTNAME) project

$(CONFIGDIR) c:\hew\workspace\project\debug
$(CONFIGNAME) debug

$(HEWDIR) c:\hew

$(TEMPDIR) c:\Temp

$(WINDIR) c:\Windows

$(WINSYSDIR) c:\Windows\System

$(EXEDIR) v:\velwin32

$(USERNAME) JHARK

$(PASSWORD) 214436

$(VCDIR) “c:\project” is mapped to “x:\vc\project”
$(COMMENT) “Please Enter Comment” dialog is invoked
$(LINE) 12

In table C.2, we are assuming that

« afilepathis*“c:\new\workspace\project\file.src”.

* aworkspace named “workspace” is located at “ c:\hew\workspace”.

e aproject named “project” islocated at “c:\hew\workspace\project”.

» aconfiguration named “debug” has a configuration directory located at
“c:\hew\workspace\project\debug” .

e HEW.EXEisinstalledin “c:\hew”.

» the Windows® operating system isinstalled in “c:\Windows" and the Windows® system

directory is“c:\Windows\System”.
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e aversion control executable path is “v:\wc\win32\ss.exe”, a user name and its password to
login the version control system are “JHARK” and “214436" respectively, (COMMENT) is
specified in acommand line to the version control executable, and “c:\project” is mapped to
“x:\vc\project” on the “Projects’ tab of the “Version Control Setup” dialog, which isinvoked
via[Tools->Version Control->Configure...].

e an error of compiler or assembler occurred at line 12.

Note: Not al of the placeholders are relevant in every field. For example, the $(LINE)
placeholder has no meaning when specifying a dependent files location. §(USERNAME),
$(PASSWORD), $(VCDIR), and $(COMMENT) placeholders are acceptable only in
version control. If you enter a placeholder into an edit field where it is not acceptable, you
might be informed.

C4 Placeholder Tips
Placeholders are there to allow you to create flexible paths to the various files used by the system.

« If thereis aplaceholder pop-up menu ([#]) next to an edit field into which you are about to
enter apath or file, you should consider how you can use a placeholder to make that path or
file definition flexible.

» If you use several configurations, then the $(CONFIGDIR) placeholder is very useful to ensure
that files can be written to and from the current configuration’s directory.

e Wherever possible, use a placeholder. They can always be removed or added later so don’t be
afraid to experiment.
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Appendix D 1/0O File Format

HEW formats the [IO] window based on information it finds in an 1/O Register definition file.
When you select a debugging platform, HEW will look for a“<device>.10" file corresponding to
the selected device and load it if it exists. Thisfile isaformatted text file that describes the 1/0
modules and the address and size of their registers. Y ou can edit thisfile, with atext editor, to add
support for memory mapped registers or peripherals you may have specific to your application e.g.
registersin an ASIC device mapped into the microcomputer's address space.

D.1 File Format

Each module name must be defined in the [Modules] definition section and the numbering of each
module must be sequential. Each module corresponds to aregister definition section and within
the section each entry defines an 1/O register.

The [BaseAddress| definition isfor devices where the location of 1/0 registers movesin the
address space depending on the CPU mode. In this case, the [BaseAddress] valueis the base
address of the I/O registers in one specific mode and the addresses used in the register definitions
are the address |locations of the registers in the same mode. When the 1/0O register fileis actually
used, the [BaseAddress] value is subtracted from the defined register address and the resultant
offset added to the relevant base address for the selected mode.

Each module has a section that defines the registers forming it along with an optional dependency,
the dependency is checked to seeif the module is enabled or not. Each register name must be
defined in the section and the numbering of each register must be sequential. The dependency is
entered in the section as dep=<reg> <hit> <value>.

1. <reg>istheregister id of the dependency.
2. <bit> isthe bit position within the register.
3. <vadue> isthevalue that the bit must be for the module to be enabled.

The [Register] definition entry is entered in the format id=<name> <address> [<size>
[<absolute>[<format>[<bitfields>]]1].

1. <name> register name to be displayed.
2. <address> address of the register.
3. <size> which may be B, W or L for byte, word, or long word (default is byte).

4. <absolute> which can be set to A if the register is at an absolute address. Thisis
only relevant if the 1/0 area address range moves about on the CPU in different
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modes. In this case, if aregister is defined as absolute the base address offset
calculation is not performed and the specified address is used directly.

5. <format> format for register output. Valid values are H for Hexadecimal, D for
decimal, and B for binary.

6. <bitfields> section defining the bits within the register.

Bitfield sections define the bits within aregister each entry is of the type bit<no>=<name>.
1. <no>isthe bit number.
2. <name>isasymbolic name of the bit.

Comment lines are allowed and must start with a“;” character.

An example is shown below.
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Example:
Comment ; H8S/2655 Series 1/0 Register Definitions File

[ [Modules]
FileVersion=2
BaseAddress=0
Modulel=Power_Down_Mode_Registers
Module2=DMA_Channel_Common

Module Module3=DMA_Channel_0

Module42=Bus_Controller
Module43=System_Control
Module44=Interrupt_Controller

[DMA_Channel_Common]
reg0=regDMAWER
regl=regDMATCR

o reg2=regDMACROA
definition reg3=regDMACROB

Module

reg4=regDMACR1A
reg5=regDMACR1B
reg6=regDMABCRH
reg7=regDMABCRL

L dep=regMSTPCRH 7 0
Register name |

Bit

Value

Register [regDMAWER]
definition id=DMAWER Oxffff00 B A H dmawer_bitfields

Register name | ‘
Address

Size

Absolute address flag

Format

Bit field

[dmawer_bitfields]
Bit-field bit3=WE1B

definition bit2=WE1A

bitl=WEOB
bitO=WEOA
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Appendix E Symbol File Format

In order for HEW to be able to understand and decode the symbol file correctly, the file must be
formatted as a Pentica-B file:

1. Thefilemust beaplain ASCII text file.
2. Thefile must start with the word “BEGIN”.

3. Each symbol must be on a separate line with the value first, in hexadecimal
terminated by an “H”, followed by a space then the symbol text.

4. Thefile must end with the word “END”.
Example:

BEG N

11FAH Symbol _nane_1
11FCH Synbol _nane_2
11FEH Synbol _nane_3
1200H Synbol _nane_4
END
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Appendix F Window Functions

This section describes the window functions that can be used with the E10A emulator HEW. Here,
the HEW common functions are omitted, and only the emulation functions are described.

TableF.1 Window Functions

Toolbar
Menu Option Shortcut  Button Remarks
View Disassembly Ctrl +D Opens the [Disassembly]
- window.
Command Line Ctrl +L Opens the [Command Line]
= window.
Workspace Alt + K Opens the [Workspace]
window.
Output Alt + U Opens the [Output] window.
CPU Registers Ctrl +R Opens the [Register] window.
Memory... Ctrl + M Opens the [Memory] window.
=]
10 Ctrl + 1 . Opens the [I0O] window.
Ii'i|
Status Ctrl + U Opens the [Status] window.
Sym-  Labels Shift + - Opens the [Labels] window.
bol Ctrl + A
Watch Ctrl + W Opens the [Watch] window.
Locals Shift + Opens the [Locals] window.
St s w
Code Eventpoints Ctrl + E @ Opens the [Event] window.
Trace Ctrl+T Opens the [Trace] window.
Stack Trace Ctrl + K Opens the [Stack Trace]
window.
Gra- Image... Shift + E Opens the [Image] window.
phic Ctrl+ G
Waveform... Shift + Opens the [Waveform]
Ctrl +V window.
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Option

Toolbar
Shortcut  Button

Remarks

Options

Debug Sessions...

Debug Settings...

Opens the [Debug Sessions]
dialog box to list, add, or remove
the debug session.

Opens the [Debug Settings]
dialog box to set the debugging
conditions or download modules.

Radix Hexadecimal

=

Uses a hexadecimal for
displaying a radix in which the
numerical values will be
displayed and entered by default.

Decimal

I=

Uses a decimal for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Octal

Uses an octal for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Binary

o

Uses a binary for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Emu-  System...
lator

E

Opens the [Configuration
Properties] dialog box allowing
the user to modify the debugging
platform settings.

Debug

Reset CPU

Go

Reset Go

&
—*1

F5

Shift + F5

E@
—

Resets the target hardware and
sets the PC to the reset vector
address.

Starts executing the user
program at the current PC.

Resets the target microcomputer
and executes the user program
from the reset vector address.

Go To Cursor

]
=+

Starts executing the user
program at the current PC until
the PC reaches the address
indicated by the current text
cursor position.
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TableF.1 Window Functions (cont)

Menu Option

Toolbar
Shortcut  Button

Remarks

Debug Set PC To Cursor
(cont)

L.

Sets the PC to the address at
the row of the text cursor.

Run...

Step In

Step Over

F11 F}

F10 ﬁl

Launches the [Run Program]
dialog box allowing the user to
enter the PC or PC breakpoint
during executing the user
program.

Executes a block of user
program before breaking.

Executes a block of user
program before breaking. If a
subroutine call is reached, then
the subroutine will not be
entered.

Step Out

Step...

Shift +
il
F11 L

Executes the user program to
reach the end of the current
function.

Launches the [Step Program]
dialog box allowing the user to
modify the settings for stepping.

Step Auto
Mode

Assembly

Source

Halt Program

Initialize

Disconnect

Esc

Steps only one source line when
the [Source] window is active.
When the [Disassembly] window
is active, stepping is executed in
a unit of assembly instructions.

Executes stepping in a unit of
assembly instructions.

Steps only one source line.
Stops the execution of the user
program.

Disconnects the debugging
platform and connects it again.

Disconnects the debugging
platform. This option cannot be
used in some products.

Download Modules

Downloads the object program.

Unload Modules

Unloads the object program.
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TableF.1 Window Functions (cont)

Toolbar
Menu Option Shortcut  Button

Remarks

Memory  Search...

Searches for the specified value
from the specified memory area.

Copy...

Copies the specified memory
area to the specified address.

Compare... Compares the specified two
memory areas.

Fill... Fills the specified value in the
specified memory area.

Refresh Forces a manual update of the

Configure Overlay...

contents of all the [Memory]
windows open.

Selects the target section group
when the overlay function is
used.
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Appendix G Command-Line Functions

The emulator supports the commands that can be used in the command-line window.

For details, refer to the online help.
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Appendix H Noteson HEW

1. Note on Moving Source File Position after Creating Load Module
When the source file is moved after creating the load module, the [Open] dialog box may be
displayed to specify the source file during the debugging of the created load module. Select
the corresponding source file and click the [Open] button.

2. Source-Level Execution
O Sourcefile
Do not display source files that do not correspond to the load module in the program
window. For afile having the same name as the source file that corresponds to the load
module, only its addresses are displayed in the program window. The file cannot be
operated in the program window.
0 Step
Even standard C libraries are executed. To return to a higher-level function, enter Step Out.
In afor statement or awhile statement, executing a single step does not move execution to
the next line. To move to the next line, execute two steps.
3. Operation During Accessing Files
Do not perform other operations during downloading the load module or saving in the [Verify
Memory], [Save Memory], or [Trace] window because this will not alow correct file
accessing to be performed.
4, Watch
0 Locd variables at optimization

Depending on the generated object code, local variablesin a C source file that is compiled
with the optimization option enabled will not be displayed correctly. Check the generated
object code by displaying the [Disassembly] window.

If the allocation area of the specified local variable does not exist, displays as follows.

Example: The variable nameis asc.
asc = ? - target error 2010 (XxXX)

Variable name specification

When aname other than avariable name, such as a symbol name or function name, is
specified, no datais displayed.

Example: The function nameis main.
main =
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5. Line Assembly

O

Input radix

Regardless of the Radix setting, the default for line assembly input is decimal. Specify H’
or Ox asthe radix for a hexadecimal input.

6. Command Line Interface

O

Batch file

To display the message “Not currently available” while executing a batch file, enter the
sleep command. Adjust the sleep time length which differs depending on the operating
environment.

Example: To display “Not currently available” during memory_fill
execution:

sleep d’3000
memory_fill O ffff O

File specification by commands

The current directory may be altered by file specificationsin commands. Itis
recommended to use absolute paths to specify the filesin a command file so that the
current directory alteration is not affected.

Example: FILE_LOAD C\\Hew2\\T ool s\Renesas\\DebugComp\\Platform\\E10A
\Tutoria\\Debug_H8S_xxxx_E10A_SY STEM\\Tutorial .abs

7. Memory Save During User Program Execution

Do not execute memory save or verifying during user program execution.

8. Load of Motorola S-type Files

This HEW does not support Motorola S-type files with only the CR code (H'OD) at the end of
each record. Load Motorola S-type files with the CR and LF codes (H'ODOA) at the end of
each record.

9. [I1O] window

O

384

Display and modification
Do not change valuesin the [I/O Registers] window because the emulator uses the address
break controller.

Note that the ELI0A emulator does not support the display of the invalid module or bit
information in the [IO] window.
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10. Note on [Register] Window Operation During Program Execution

The register value cannot be changed in the [Register] window during program execution.
Even if the changed value is displayed, the register contents are not changed actually.

11. Break Functions

0 When the PC breakpoint is set in the flash memory area, the program is written to the flash
memory each time the user program is executed. At thistime, note that the number of
rewritable times will be decreased.

0 BREAKPOINT cancellation

When the contents of the BREAKPOINT address is modified during user program
execution, the following message is displayed when the user program stops.

BREAKPOINT ISDELETED A=XXXXXXXX

If the above message is displayed, cancel all BREAKPOINT settings with the [Delete All]
or [Disable] button in the [Breakpoints] window.

12. Number of BREAKPOINT and [Stop At] Settings in the [Run...] Menu

The maximum number of BREAKPOINTs and [Stop At] settings allowed in the [Run...] menu
is255. Therefore, when 255 BREAKPOINTS are set, specification by [Stop At] in the [Run...]
menu becomes invalid. Use the BREAKPOINTSs and [Stop At] in the [Run...] menu with 255
or lesstotal settings.

13. Note on RUN-TIME Display
The execution time of the user program displayed in the [Status] window is not a correct value
since the timer in the host computer has been used.

14. Note on Displaying Ti meout error

If Ti meout error isdisplayed, the emulator cannot communicate with the target
microcomputer. Turn off the emulator and the user system and connect the emulator again by
using the HEW.

15. Support of Double Float Format
In the following memory operations, the double float format is not supported:

O [Fill Memory] diaog box
0 [Search Memory] diaog box
0 MEMORY_FILL command

The [Format] specification in the [Copy Memory] dialog box isignored. Memory is
copied in a byte unit.
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16. Note on Using the [Run Program] Dialog Box
When [Run...] is selected from the [ Debug] menu to specify the stop address, there is the
following note:
O When the breakpoint that has been set as Disable is specified as the stop address, note that
the breakpoint becomes Enable when the user program stops.

17. Memory Access during User Program Execution
When amemory is accessed from the memory window, etc. during user program execution,
the user program is resumed after it has stopped in the EL0A emulator to access the memory.
Therefore, realtime emulation cannot be performed.

18. Interna Flash Memory
The actual MCU, which has been used by connecting to the emulator, has been written to the
flash memory at emulation and stressed. Do not use the MCU that has been used for
debugging for the mass products.
The MCU, which has not been used for debugging, is also available as the programming tool
for mass production.

19. Verification of Memory

Usethe FILE_VERIFY command to verify memory. Do not use [Verify Memory...] in the
[File] menu.

20. Note on Editing Register Values from the [|O] Window

No datawill be written to memory when the values of aregister before and after editing are the
same.

21. Overwrite of aFile
In command line interface, afile that has the same name as the output file is overwritten
without asking the user.

22. Usage with Other Products
Toinstall the SuperH™ RISC engine C/C++ compiler package or H8S, H8/300 series C/C++
compiler package after installing the emulator software for HEW?2, select [High-performance
Embedded Workshop] as the component to be installed in [Select Components] during
installation of the compiler package.
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