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Renesas Synergy™ Platform 

Using IAR C-STAT Static Code Analysis with 
Selected IoT Checks from MISRA C:2012 
Introduction 
This application note describes how to enable and execute code analysis with the integrated IAR C-STAT solution in 
IAR Embedded Workbench® for Renesas Synergy™. 

Required Resources 

A PC running Microsoft® Windows® 7 or later, with the following Renesas Synergy software installed:  

• Synergy Software Platform (SSP) v1.4.0 or later 
• IAR EW for Synergy™ v8.21.1  
• Synergy Standalone Configurator (SSC) v6.2.0. 
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1. Creating the Blinky Project 
1. Create a new workspace with IAR EW for Synergy. Select File > New Workspace. 
 

 

Figure 1   Create Workspace 

2. Select the Renesas Synergy tab and > New Synergy Project.  
 

 

Figure 2   Create a New Synergy Project 
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3. Set up a folder for your new Workspace Project. Create a Workspace File. Name the file .eww and save it. 
Example shown below, Blinky_DKS7G2.eww. 

 

 

Figure 3   Create a Workspace File, name and save it 
 
4. Select the location in the Renesas Synergy Settings where the License file is installed and click OK. 
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Figure 4   Select Renesas Synergy SSC/SSP and License root directory 

5. Create a Project File, name the Project file with .ewp and save it. Example, Blinky_DKS7G2.ewp. 
 

 
Figure 5   Create project file, name and save it 
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6. After you save it, IAR EW for Synergy will automatically use the SSC (Synergy Standalone Configurator) to create 
your new project. You must select the SSP version, Board and Device. Click Next when you are done with 
selection. 

 

Figure 6   Select SSP, Board and Device 
7. The Synergy Standalone Configurator window pops up. Scroll down and select Blinky with ThreadX® and 

click the Finish button. 

 

Figure 7   Select Blinky with ThreadX 
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8. Double check your configuration (SSP, Board and Device) from the BSP tab, then click the Generate Project 
Content button on the upper right side of the window. 

 

Figure 8   Double check the setting and Generate Project Content 
9. Click the Select All button and click OK if the following window pops up. 
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Figure 9   Confirm files for deletion 
 

10. After Generate Project Content and configuration, you must save your configuration with your changes. Click the 
Yes button. 

 

Figure 10   Saving your configuration 
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11. Build your project by selecting the Project tab and scroll down and choose Make F7 to build your project. You 
should have 0 error and 0 warning after the build, shown in the following figure.  

 

 

Figure 11   Building your project  
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2. Analyzing the Project with IAR C-STAT 
1. Right click on the project name and select Project > Options > Static Analysis. In the new version of IAR 

v8.21.1 or above, the cstat IoT setting will be applied when the new project is created or when you click on the 
Factor Setting button as shown in the following figure.  

2. From Category of Options for node Blinky_DKS7G2 scroll down and select Static Analysis. Click on Select 
C-STAT Checks and make sure that the MISRAC2012 check box is enabled with the selected IoT checks. 
Confirm with OK. 

 

Figure 11   Selecting MISRA C:2012 

3. Start the static code analysis over the complete project from Project > C-STAT Static Analysis > Analyze 
Project or use the shortcut key Shift+F7 in the following figure. 

 



Renesas Synergy™ Platform     Using IAR C-STAT Static Code Analysis with Selected IoT 
Checks from MISRA C:2012 

R20AN0436EU0101  Rev.1.01  Page 10 of 13 
Feb 8, 2018  

 

Figure 12   Analyzing project 

4. Additionally, it is possible to analyze specific files or a group of files by right clicking on the file or group and 
using the option C-STAT Static Analysis > Analyze File(s). 

 

 

Figure 13   Analyzing file or a group of files 
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3. Using the Report 
1. After 3-4 minutes, depending on the complexity of your project, you should have the static analysis completed and 

the warnings will be available in the C-STAT messages window. Notice the check names, file details and severity 
in the warnings.  

 

 

Figure 14   C-STAT report 
2. To get additional information about the checks that have been triggered and reference information on how to fix the 

issues, select the warning and press F1. 
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Figure 15   Warning details 
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Website and Support 
Support:  https://synergygallery.renesas.com/support 

Technical Contact Details: 

• America: https://www.renesas.com/en-us/support/contact.html   
• Europe: https://www.renesas.com/en-eu/support/contact.html  
• Japan: https://www.renesas.com/ja-jp/support/contact.html 
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Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for

the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by

you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, or other intellectual property rights of third parties, by or

arising from the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application

examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses or damages incurred by

you or third parties arising from such alteration, modification, copying or reverse engineering.

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for each Renesas Electronics product depends on the

product’s quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

equipment; industrial robots; etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are

not intended or authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause

serious property damage (space system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics disclaims any and all

liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product that is inconsistent with any Renesas Electronics data sheet, user’s manual or

other Renesas Electronics document.

6. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for Handling and Using Semiconductor Devices” in the

reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation

characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such specified

ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a

certain rate and malfunctions under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas

Electronics document, Renesas Electronics products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily injury, injury

or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult

and impractical, you are responsible for evaluating the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and

sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics

products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable

laws and regulations.

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws

or regulations. You shall comply with any applicable export control laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or

transactions.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or transfers the product to a third party, to notify such third

party in advance of the contents and conditions set forth in this document.

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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