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RX113 Group 
RX Driver Package User’s Manual  

Introduction  
This application note documents the RX113 Group RX Driver Package User’s Manual, version 1.00. 

The RX Driver Package is a software platform that collects middleware and drivers that support the Firmware 
Integration Technology (FIT). This package provides an environment for conveniently evaluating the rich set of 
peripheral functions provided by RX microcontrollers. 

The RX Driver Package includes device drivers for the peripheral modules included in RX microcontrollers, 
middleware developed for RX microcontrollers, a variety of interface modules, and the Board Support Package (BSP). 
Users can freely combine the modules included in the RX Driver Package construct systems simply by creating 
applications that using those modules, and thus quickly start the evaluation process. 

This document describes the RX Driver Package, the basic structures and features of RX Driver Package applications, 
and the FIT modules included in this application note. 

See the related documents for detailed information on using the RX Driver Package and procedures for evaluating 
applications that use the RX Driver Package. 

In the use to the product, to fit your environment, please careful evaluated. 

 

Target Device  
RX113 Group (Renesas Starter Kit RX113) 

Related Documents 
• RX Family  Board Support Package Module Using Firmware Integration Technology (R01AN1685EU) 
• Firmware Integration Technology User’s Manual (R01AN1833EU) 
• RX Family  Adding Firmware Integration Technology Modules to Projects (R01AN1723EU) 
• RX Family  Adding Firmware Integration Technology Modules to CubeSuite+ Projects (R01AN1826EJ) 
• The User’s Manual provided with the RX Driver Package Application. 
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1. Overview 

1.1 Applicability 
This document applies to the RX113 Group RX Driver Package, version 1.00. 

 

1.2 RX113 Group RX Driver Package 
The RX113 Group RX Driver Package (referred to as “this package” below) is a software platform(framework) that was 
packaged such as device drivers and middleware for the RX113. It is available for free of charge to everybody. 

 

1.3 Operating Environment 
This package runs under the operating environment described below. 

 
Table 1.3.1   Operating Environment 

Microcontroller RX113 Group 
Evaluation board Renesas Starter Kit RX113 
Integrated development 
environment (IDE) 

e2 studio, V3.1.2 or later 
Or: 
CS+ V3.00.00 or later 

Cross tools RX Family C/C++ Compiler Package V2.02.00 or later 
Emulator E1, E20 
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2. RX Driver Package 

2.1 RX Driver Package Structure 
The RX Driver Package is a software platform that collects the lower level software components required to develop 
application programs. A wide range of applications can be developed using the RX Driver Package. 

 
The RX Driver Package consists of the BSP module, microcontroller peripheral module device drivers, middleware 
(TCP/IP, file systems, and other items), and various interfaces. 

 
Note:  Items marked with an asterisk are examples. 

Figure 2.1.2   RX Driver Package Structure 

 
For example, as shown in the figure below, a system can be constructed by collecting the required components from 
those in the RX Driver Package and providing an application program. 

Evaluation board

A system can be constructed by selecting 
the required modules from the RX Driver 
Package and combining them with the 
application program.

Application
(HTTPD)

Example: HTTPD (Web server)

 

Figure 2.1.3   System Construction with the RX Driver Package 
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Furthermore, all of these modules meet the FIT specifications and since the folder structure and API are standardized 
(with a few exceptions), this structure makes it easy to swap modules in and out or to port an application to another 
microcontroller. 

 

Evaluation board 
(RSKRX6xx)

An application is constructed 
for another RX Driver Package.

Application
(HTTPD)

Evaluation board 
(RSKRX64M)

Here, the USB driver is 
replaced by the SD driver.

Application
(HTTPD)

 

Figure 2.1.4   RX Driver Package Application Examples 
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2.2 RX Driver Package Features 
The RX Driver Package has the following features. 

• The RX Driver Package is a software platform that provides, in a single package, the device drivers and middleware 
required for application program development. Renesas will proved RX Driver Packages in a timely as 
microcontrollers are released. 

• Application programs developed on one RX Driver Package can easily be ported to the RX Driver Package for a 
different microcontroller. 

• All the device drivers and middleware included in the RX Driver Package are either compliant with or compatible 
with the FIT specifications. Thus applications that take advantage of the FIT features can be developed easily. 

• The RX Driver Package provides a common interface to middleware and real-time OSes. This makes it easy to reuse 
software assets and to port applications between real-time OSes. 

• Renesas supplies “RX Driver Package Application” sample applications that, when combined with the 
corresponding RX Driver Package, allow evaluation to be started immediately. 

• The RX Driver Package is provided without charge. All the modules in the RX Driver Package can be used without 
charge, even in commercial applications.  
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3. Structure of the RX113 Group RX Driver Package 

3.1 Folder Structure 
The folder structure used in this package is shown below. 

When the ZIP file for this package is downloaded from the Renesas web site and decompressed, a folder of the same 
name will be present and it will contain a FITModules folder, a reference_documents folder, and this document. 

The FITModules folder contains the FIT modules for the modules shown in table 3.3.1 (as ZIP files and XML files). 

The reference_documents folder contains the documentation for using this package in various development 
environments. 

 

Figure 3.1.1   Folder Structure of the RX113 Group RX Driver Package 
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3.2 Module Structure 
The figure below shows the types and structure of the FIT modules included in this package. 

 

Figure 3.2.1   RX113 Group RX Driver Package FIT Module Structure 
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3.3 FIT Modules 
The table below lists the FIT modules included in this package. 

 
Table 3.3.1   RX113 Group RX Driver Package FIT Modules 

Type Module  FIT Module Name Version 
Board Support 
Package 

Board support package  r_bsp 2.70 

Device Driver Clock Generation Circuit (CGC) r_cgc_rx100 1.30 
Device Driver Data Transfer Controller (DTC) r_dtc_rx 2.01 
Device Driver Compare match timer (CMT) r_cmt_rx 2.40 
Device Driver Serial Communications Interface 

(SCI: Simple I²C Bus) 
r_sci_iic_rx 1.40 

Device Driver I²C Bus Interface (RIIC) r_riic_rx 1.50 
Device Driver Serial peripheral interface (RSPI) r_rspi_smstr_rx 1.07 
Device Driver USB Basic Mini Firmware r_usb_basic_mini 1.00 
Device Driver USB Host Mass Storage Class r_usb_hmsc_mini 1.00 
Device Driver USB Host Communication Device Class r_usb_hcdc_mini 1.00 
Device Driver USB Host Human Interface Device Class r_usb_hhid_mini 1.00 
Device Driver USB Peripheral Mass Storage Class r_usb_pmsc_mini 1.00 
Device Driver USB Peripheral Communications Device Class r_usb_pcdc_mini 1.00 
Device Driver USB Peripheral Human Interface Device Class r_usb_phid_mini 1.00 
Device Driver IrDA Interface (IrDA) r_irda_sci_rx 1.00 
Device Driver LCD Controller/Driver (LCDC) r_lcdc_rx 1.00 
Device Driver Unique ID Read r_uid_rx 1.00 
Middleware Simple I2C Module for EEPROM Access r_eeprom_sci_iic_rx 1.30 
Middleware I2C Bus Interface (RIIC) Module for EEPROM Access r_eeprom_riic_rx 1.40 
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4. Usage Procedures 
The RX Driver Package allows programs to be easily constructed by using the FIT plugin included in e2 studio. The 
remainder of this section presents a simple usage example using e2 studio. To use CS+ (CubeSuite+), see the document 
“RX Family  Adding Firmware Integration Technology Modules to CubeSuite+ Projects (R01AN1826EJ)” included in 
this package. 

 

4.1 Environment Used 
The RX113 is used as the target microcontroller and the Renesas Starter Kit RX113 is used as the target board. If a 
different environment is used, replace the specifics used in the example with the ones for that environment as you read. 

 

4.2 Install RX Driver Package in e2 studio 
Install the FIT modules in the RX Driver Package into e2 studio. 

 

1. Decompress the downloaded file an_r01an2466ej0100_rx113_fit.zip into an arbitrary directory. 
 
2.  Open the folder that was decompressed and open the FITModules folder in that folder. 
 
3. Select all the files in the FITModules folder and click Copy in the Edit menu. 

 
 

Select all files and click 
Copy in the Edit menu. 
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4.  Open the e2 studio install folder (Usually, this will be c:/Renesas/e2_studio.) and open the FITModules folder in 
that folder. 

 
5.  Click Paste on the Edit menu. 

The e2 studio FITModules folder will be copied to the FIT modules. 

 
 
 

4.3 Application Creation 
In this section, create a simple application that drives an LED. 

 

4.3.1 Create a Workspace and a Project 
First, create a new workspace and a new project. 

1.  Start e2 studio. 
 
2.  Enter an arbitrary workspace folder in the displayed dialog box and click OK. 

 
 

Open the FITModules 
folder and click Paste  
on the Edit menu.  
The folder will be copied. 

Enter a workspace 
folder. 

Click OK. 
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3.  When the following window is displayed, click Workbench. 

 
 
4.  When the workbench has started, select New from the File menu and click C Project. 

 
 

Click Workbench. 

Click here. 
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5.  Enter the project name. For the project type, click Sample Project under Executable (Renesas). For the tool chain, 
click Renesas RXC Toolchain. After making these settings, click Next. 

 
 
6.  Select the target. Click the “...” button under Target Selection and select R5F51138AxFP. After making these 

settings, click Next. 

 
 

Click here. 
 

Enter the 
project name. 

Click here. 
 

Click here and 
select 
R5F51138AxFP. 
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7.  Simply click Next here. 

 
 
8.  Simply click Next here. 

 
 

Click here. 
 

Click here. 
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9.  Simply click Next here. 

 
 
10. Select C(C99) under Library Structure and click Next. 

 
 

Select C(C99). 

Click here. 
 

Click here. 
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11. Clear all four check boxes and click Finish. 

 
 
12. Click OK. The project will be generated. 

 
 

Click here. 
 

 

 

 

Clear all the 
check boxes. 

Click here. 
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4.3.2 Prepare to Embed the FIT Modules 
Since the FIT modules are independently initialized in BSP, it is necessary to modify certain aspects of the project 
generated by e2 studio. 

 
1.  In Project Explorer, delete the dbsct.c and typedefine.h files in the src folder. 

 
 
 

Delete these files. 
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4.3.3 Install the FIT Modules with the FIT Plugin. 
Install the required modules with the FIT plugin into the created project. 

Here, install the BSP module (r_bsp) and the compare match timer driver (r_cmt_rx). 

 
1.  In the File menu, select New and click Renesas FIT Module. 

 
 
2.  Select the created project with Project to Add FIT Module to. 

Next, select r_bsp and r_cmt_rx in the module list and click Finish. 

 
 

Click here. 
 

 

 

 

 

 

 

 

 

Select the project. 
 

Select this item. 
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3.  Click OK with changing anything. 

 
 
4.  Click OK with changing anything. 

 
 

5.  Click OK with changing anything. 

 
 

Click here. 
 

 

 

 

 

 

 

 

 

 

Click here. 
 

 

 

 

 

 

 

Click here. 
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6.  Open r_bsp/board/rskrx113 from the e2 studio Project Explorer, select r_bsp_config_reference.h, and click Copy 
on the Edit menu. 

 
 
7.  Select r_config from the e2 studio Project Explorer and click Paste on the Edit menu. 

 
 
8.  Change the names of r_bsp_config.h. That is, delete the “_reference_” part of the file names. 

  
 

Select this file and 
click Copy on the 
Edit menu. 

Select the r_config 
folder and click Paste 
on the Edit menu. 

Rename this file. 
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9.  Modify platform.h to correspond to the target board used. 
Double click r_bsp/platform.h from the e2 studio Project Explorer and, in the editor, uncomment from the include 
line for the r_bsp.h file for the RSKRX113. 

 
 

Double click. 

 

Uncomment this line. 
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4.3.4 Create an LED Driving Program 
Create a program that toggles the LED0 on/off state every 0.5 seconds using the compare match timer. 

Open the file src/led_sample.c and modify it as shown below. 

src/led_sample.c 

/***********************************************************************/ 
/*                                                                     */ 
/*  FILE        :Main.c or Main.cpp                                    */ 
/*  DATE        :Tue, Oct 31, 2006                                     */ 
/*  DESCRIPTION :Main Program                                          */ 
/*  CPU TYPE    :                                                      */ 
/*                                                                     */ 
/*  NOTE:THIS IS A TYPICAL EXAMPLE.                                    */ 
/*                                                                     */ 
/***********************************************************************/ 
#include "platform.h" 
#include "r_cmt_rx_if.h" 
 
/* LED Currently status */ 
uint32_t ledstatus = LED_OFF; 
 
void call_back(void *pdata) 
{ 
 if (ledstatus == LED_OFF) 
 { 
    /* Turn ON the LED0 If the status is LED_OFF */ 
  LED0 = LED_ON; 
  ledstatus = LED_ON; 
 } 
 else 
 { 
    /* Turn OFF the LED0 If the status is LED_ON */ 
  LED0 = LED_OFF; 
  ledstatus = LED_OFF; 
 } 
} 
 
void main(void) 
{ 
 uint32_t cmt_ch; 
 
 /* LED0 off */ 
 LED0 =LED_OFF; 
 /* Create of 0.5 second(2Hz) cyclic timer. */ 
 R_CMT_CreatePeriodic(2, &call_back, &cmt_ch); 
 
 while(1); 
} 
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4.3.5 Build and Try Running the Program 
Build the program just created and verify that it runs. 

 
1.  Click Build Project on the Project menu. 

  
 
2.  When the build completes, the following will be displayed in Console view. 

  
 
3.  Click Debug Build on the Run menu. 

 
 

Click here. 

Click here. 
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4.  Click led_sample HardwareDebug under the Renesas GDB Hardware Debugging. Click the Debugger tab and 
click Connection Setting. 
Modify EXTAL Frequency to be 16.0000. 
When these changes have been made, click Debug. 

 
 

Click here. 

Click here. 

Modify to be 
16.0000. 
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5. When the following message is displayed, click Yes. 

 
 
6. When the load module download completes, a Debug perspective opens. 

 
 
7.  Click Restart on the toolbar. The program will be executed and a break will occur at the start of the main function. 

 
 
8. After the break at the start of the main function, click Restart on the tool bar again. 

The project will be run and the program will iterate toggling LED0 with a period of 0.5 seconds. 
 
 

Click here. 

Click here. 
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5. RX Driver Package Application 

5.1 RX Driver Package Application Structure 
The RX Driver Package Application is a sample application program provided so that users can use the RX Driver 
Package easily. The RX Driver Package Application consists of an application program that operates using device 
drivers and middleware included in the RX Driver Package and a project file for building that application. This allows 
users to start evaluation quickly. 

Project fileSample application program

 

Figure 5.1.1   RX Driver Package Application Structure 

 
Renesas plans to release a variety of types of this RX Driver Package Application in the future, such as system 
programs that operate using a combination of multiple drivers and middleware and evaluation programs for independent 
modules from the RX Driver Package. 

Network server 
and cliant Camera control program Audio player (ADPCM)

Device driver evaluation 
program Boot loader

Image and video 
middleware control 

program

Boot loader RX Driver Package
Application

 

Figure 5.1.2   Types of RX Driver Package Application 

 

5.2 RX Driver Package Application Features 
The RX Driver Package Application has the following features. 

• The RX Driver Package Application is evaluated in combination with the RX Driver Package. 
• Project files are included in the RX Driver Package Application. Since both build and debug configurations for the 

application project are already set up in the provided project file, the user can quickly begin building and evaluating 
simply by importing the project into a workspace. 

• If e2 studio is used as the integrated development environment (IDE), the device drivers and middleware used in the 
application project can be automatically added to the project by using the FIT plugin provided with e2 studio. 

• Renesas provides the RX Driver Package Application without charge. 
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5.3 RX Driver Package Application Usage Example (when e2 studio is used) 
The device drivers and middleware required by the RX Driver Package Application are automatically added to the 
project by the FIT plugin, which comes with the e2 studio. 

After the project provided with the RX Driver Package Application has been installed in an e2 studio workspace, the 
required device drivers and middleware from the RX Driver Package are also installed simply by installing in the 
project by selecting the RX Driver Package Application with the FIT plugin. Therefore all that remains is to build the 
project and start evaluation. 

FIT plugin

Project fileHTTP (Web server)
Application program

Project installation

Application installation

The required device drivers 
and middleware from the 
RX Driver Package are 
installed automatically.

Project

HTTP (Web server)
Application program

 

Figure 5.3.1   FIT Plugin Automatic Installation 
 

5.4 When Using in Combination with an RX Driver Package Application 
See the document provided with each RX Driver Package Application for detailed usage methods for that RX Driver 
Package Application. 
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6. System Structure 
The figure below shows the structure of a system that uses the RX Driver Package. 

Standard 
components

Option

Third party 
evaluation board Renesas evaluation board

Support
tool

e2 studio 
project

Sample application 
(FIT module)

POSIX Wrapper*
(FIT module)

Middleware
(FIT module)

Middleware
(FIT module)

Device driver
(FIT module)

Device driver
(FIT module)

Device driver
(FIT module)

Device driver
(FIT module)

Device driver
(FIT module)

PTOS Wrapper*
(FIT module)

Board Support Package
(BSP module)

 
Note: * Items marked with an asterisk are under development. 

Figure 6.1   System Structure 

 
 

 



RX113 Group RX Driver Package User’s Manual 

R01AN2466EJ0100  Rev.1.00  Page 29 of 29 
Nov 28, 2014  

Website and Support  
Renesas Electronics Website 

http://www.renesas.com/ 
 
Inquiries 

http://www.renesas.com/contact/ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
All trademarks and registered trademarks are the property of their respective owners. 

http://www.renesas.com/
http://www.renesas.com/contact/


 

A-1 

Revision History  

Rev. Date 
Description 
Page Summary 

1.00 Nov 28, 2014  First edition issued 
    
 



 

 

General Precautions in the Handling of MPU/MCU Products 
The following usage notes are applicable to all MPU/MCU products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that 
have been issued for the products. 

1. Handling of Unused Pins 
Handle unused pins in accord with the directions given under Handling of Unused Pins in the manual. 
 The input pins of CMOS products are generally in the high-impedance state. In operation with an unused pin 

in the open-circuit state, extra electromagnetic noise is induced in the vicinity of LSI, an associated shoot-
through current flows internally, and malfunctions occur due to the false recognition of the pin state as an 
input signal become possible. Unused pins should be handled as described under Handling of Unused Pins in 
the manual. 

2. Processing at Power-on 
The state of the product is undefined at the moment when power is supplied. 
 The states of internal circuits in the LSI are indeterminate and the states of register settings and pins are 

undefined at the moment when power is supplied. 
In a finished product where the reset signal is applied to the external reset pin, the states of pins 
are not guaranteed from the moment when power is supplied until the reset process is completed. 
In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function 
are not guaranteed from the moment when power is supplied until the power reaches the level at 
which resetting has been specified. 

3. Prohibition of Access to Reserved Addresses 
Access to reserved addresses is prohibited. 
 The reserved addresses are provided for the possible future expansion of functions. Do not access these 

addresses; the correct operation of LSI is not guaranteed if they are accessed. 
4. Clock Signals 

After applying a reset, only release the reset line after the operating clock signal has become stable. 
When switching the clock signal during program execution, wait until the target clock signal has 
stabilized. 
 When the clock signal is generated with an external resonator (or from an external oscillator) during a reset, 

ensure that the reset line is only released after full stabilization of the clock signal. Moreover, when 
switching to a clock signal produced with an external resonator (or by an external oscillator) while program 
execution is in progress, wait until the target clock signal is stable. 

5. Differences between Products 
Before changing from one product to another, i.e. to a product with a different type number, confirm 
that the change will not lead to problems. 
 The characteristics of an MPU or MCU in the same group but having a different part number may differ in 

terms of the internal memory capacity, layout pattern, and other factors, which can affect the ranges of 
electrical characteristics, such as characteristic values, operating margins, immunity to noise, and amount of 
radiated noise. When changing to a product with a different part number, implement a system-evaluation test 
for the given product. 
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